#mageia-qa Meeting

Meeting started by MrsB at 19:10:00 UTC (full logs).

Meeting summary

  1. Useful Bugzilla Searches (MrsB, 19:12:36)
    1. leuhmanu kindly created some saved searches for us (MrsB, 19:13:07)
    2. You can find all the saved searches in the Prferences page which you can find here https://bugs.mageia.org/userprefs.cgi?tab=saved-searches (MrsB, 19:14:13)
    3. waiting for QA test - our main bug list (MrsB, 19:15:11)
    4. waiting for QA test mga1 - the same list broken down to show mga1 bugs only (MrsB, 19:15:43)
    5. waiting for QA test mga2 - the same list broken down to show mga2 bugs only (MrsB, 19:15:57)
    6. If you tick the box next to them in the Show in Footer column they will show at the bottom of your Bugzilla pages (MrsB, 19:16:34)
    7. QA wait packagers - QA bugs waiting for a response from packagers (MrsB, 19:17:32)
    8. updates-push - These are validated updates waiting to be pushed (MrsB, 19:18:06)
    9. Updates waiting for QA - This is the original list with everything for mga1 and 2 waiting for packagers or not (MrsB, 19:18:56)

  2. Backports (MrsB, 19:20:33)
    1. Certain things were agreed last night at the packagers meeting (MrsB, 19:24:45)
    2. If a package is backported for Mageia 1, the same or a newer version must be in Mageia 2, either core, updates, or backports. (MrsB, 19:24:58)
    3. It's ok if a packager chooses to only backport to Mageia 2. (MrsB, 19:25:10)
    4. The rpmdrake-edit-media program will be modified to warn users who enable backports, that it may break upgrading to the next release. (MrsB, 19:25:24)
    5. Backports will only be accepted for leaf packages or leaf "groups", and must have strict requires for dependencies, to ensure proper dependency selection. (MrsB, 19:25:49)
    6. The procedure will be similar to updates.. (MrsB, 19:26:17)
    7. Backports will be built in Core/Nonfree/Tainted backports testing (DavidWHodgins, 19:26:30)
    8. ACTION: MrsB ask the bugzilla admins to have it automatically set to enhancement/lowest priority if someone selects the Backports component (MrsB, 19:30:31)
    9. AGREED: we should involve the person requesting the backport as much as possible in the testing (MrsB, 19:35:29)
    10. AGREED: The validation process should be the similar to that for validating updates but less thorough. Packages install cleanly and basic testing. (MrsB, 19:41:27)
    11. http://pkgsubmit.mageia.org/ click on uploaded on the right (Luigi12_work, 19:45:12)
    12. AGREED: A common sense advisory should be supplied similar to update and should list rpms and srpms (MrsB, 19:49:56)
    13. A mailing list is going to be created for backports announce (MrsB, 19:51:17)
    14. to find rpms in an srpm you can use Sophie, the IRC bot. eg. :more ocsigenserver -s (MrsB, 19:54:05)
    15. we think we will use the validated_update keyword the same as for updates (MrsB, 19:56:27)
    16. ACTION: Dave H will ask sysadmin about distinguishing mga1 backports from mga2 backports on the backports announce ML (MrsB, 20:00:27)
    17. tmb says it's ok (MrsB, 20:00:58)
    18. QA will be very reluctant to validate any backports until bug 2 3 1 7 is fixed (MrsB, 20:02:37)
    19. extremely reluctant (MrsB, 20:03:27)
    20. AGREED: tmb suggested that to prevent backports testing being abused a time limit be imposed before things are removed. 2 days from build to backport request on bugzilla, and 1 month to delete. (MrsB, 20:07:11)
    21. It's maybe worth noting that backports should have strictly versioned requires so selecting the main package should bring in everything that is needed in the right versions (MrsB, 20:11:40)
    22. the list of rpms would help for this, but they're not all required. It just needs to bring in the ones that are required, so no older versions of any listed there remain installed. (MrsB, 20:12:08)
    23. search for backport waiting for QA test https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=Backport%20waiting%20for%20QA%20test&sharer_id=22 (leuhmanu, 20:14:04)
    24. Another saved search for that - Backport waiting for QA test (MrsB, 20:15:38)

  3. Bug 23 1 7 (The BWNWDNS) (MrsB, 20:16:10)
    1. Hopefully this will be fixed before backports open (MrsB, 20:17:01)
    2. AL13N is actively seeking out assistance with it (MrsB, 20:17:20)

  4. Mageia 3 Features (MrsB, 20:19:33)
    1. https://wiki.mageia.org/en/FeatureMageia3_Review (MrsB, 20:20:08)
    2. There is now an accepted list of approved features for the next release, some other proposals need more detail but there is still a short amount of time (MrsB, 20:20:31)
    3. https://www.mageia.org/pipermail/mageia-dev/2012-June/016819.html (MrsB, 20:20:56)
    4. the final list of approved features will be made on 5th July (MrsB, 20:21:46)
    5. changes in Mageia 3 will be a less of an impact than the change in Mageia 2 from sysvinit to systemd, so should be easier to test. (DavidWHodgins, 20:24:36)

  5. Growing the team (MrsB, 20:25:10)
    1. At the packagers meeting it was agreed that they would try and volunteer some time to help out QA with validating updates \o/ (MrsB, 20:25:55)
    2. http://meetbot.mageia.org/mageia-dev/2012/mageia-dev.2012-06-27-19.11.log.html#l-10 (MrsB, 20:26:09)
    3. A link has been added at the top of pkgsubmit page as a reminder (MrsB, 20:26:42)
    4. http://pkgsubmit.mageia.org/ (MrsB, 20:27:02)
    5. A request for people was sent to mageia-discuss mailing list and the forums today (MrsB, 20:27:43)
    6. we could Ask everyone requesting a backport to help with qa, and suggest they consider joining qa. (MrsB, 20:30:15)
    7. we could make a blog post asking for help (MrsB, 20:31:08)
    8. Asking for help should go hand in hand with explaining how/what QA does (MrsB, 20:33:07)
    9. We need a push getting updates validated to keep on top of our list :\ (MrsB, 20:35:23)

  6. QA wiki pages (MrsB, 20:37:54)
    1. when you've tested something it's a good idea to create a procedure page for it on our portal (MrsB, 20:39:48)
    2. The problem that's being anticipated is that the number of pages grow to an extent where they interfere with the main wiki (MrsB, 20:40:47)
    3. A new namespace has been created to keep the testing procedure pages separate (MrsB, 20:41:19)
    4. what used to be https://wiki.mageia.org/en/Testing_procedure_for_T1lib (MrsB, 20:41:43)
    5. will now become https://wiki.mageia.org/en/QA_procedure:T1lib (MrsB, 20:42:07)
    6. it also means we can search it easily (MrsB, 20:42:23)
    7. https://wiki.mageia.org/mw-en/index.php?title=Special:Search&fulltext=Search&advanced=1&ns0=1&ns100=1&ns102=1&redirs=0&search= (MrsB, 20:42:39)
    8. Anybody can edit the wiki or create new pages (MrsB, 20:45:17)
    9. marja, JohnR, Workaholic are good people to ask for help (MrsB, 20:46:14)
    10. or pop in to #mageia-doc (MrsB, 20:46:41)
    11. ACTION: MrsB to find out what has happened to our wiki pages (MrsB, 20:48:52)
    12. ACTION: everybody please create them when you have completed testing things :) (MrsB, 20:49:16)
    13. they are all in a category (MrsB, 20:52:12)
    14. https://wiki.mageia.org/en/Category:Testing_procedures (MrsB, 20:52:14)

  7. ISO testing (MrsB, 20:53:06)
    1. Nothing much has changed since the last meeting but we can't afford to forget about this (MrsB, 20:53:40)
    2. We need to create our procedure and document it so it is easy for new people or general users to get involved and test thoroughly (MrsB, 20:54:31)
    3. a remind of what we had from last time (MrsB, 20:54:47)
    4. http://www.ethercalc.org/qa (MrsB, 20:54:50)
    5. if you have a better idea then please let's discuss it :) (MrsB, 20:55:12)

  8. Anything else. (MrsB, 20:58:19)
    1. https://bugs.mageia.org/show_bug.cgi?id=6389 (MrsB, 21:01:23)
    2. please prioritise firefox mga1 followed by ffmpeg mga1 then 2 then mplayer etc build upon it (MrsB, 21:12:32)
    3. same time next week! (MrsB, 21:12:53)


Meeting ended at 21:13:28 UTC (full logs).

Action items

  1. MrsB ask the bugzilla admins to have it automatically set to enhancement/lowest priority if someone selects the Backports component
  2. Dave H will ask sysadmin about distinguishing mga1 backports from mga2 backports on the backports announce ML
  3. MrsB to find out what has happened to our wiki pages
  4. everybody please create them when you have completed testing things :)


Action items, by person

  1. MrsB
    1. MrsB ask the bugzilla admins to have it automatically set to enhancement/lowest priority if someone selects the Backports component
    2. MrsB to find out what has happened to our wiki pages
  2. UNASSIGNED
    1. Dave H will ask sysadmin about distinguishing mga1 backports from mga2 backports on the backports announce ML
    2. everybody please create them when you have completed testing things :)


People present (lines said)

  1. MrsB (245)
  2. DavidWHodgins (90)
  3. Luigi12_work (40)
  4. leuhmanu (24)
  5. Luigi12_work_ (17)
  6. harms_ (17)
  7. Akien (16)
  8. [mbot (12)
  9. diogenese (8)
  10. tmb (8)
  11. Inigo_Montoya (3)
  12. Led43NB (3)
  13. Sophie (1)


Generated by MeetBot 0.1.4.