19:10:00 <MrsB> #startmeeting
19:10:00 <Inigo_Montoya> Meeting started Thu Jun 28 19:10:00 2012 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:10:00 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:10:12 <MrsB> so we'll make a start and see who turns up
19:10:36 <MrsB> #chairs DavidWHodgins
19:10:41 <MrsB> #chair DavidWHodgins
19:10:41 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB
19:10:50 <MrsB> :)
19:11:09 <MrsB> so first of all I'd like to say an official welcome to Rémi
19:11:13 <MrsB> aka Akien
19:11:17 * Akien bows.
19:11:36 <MrsB> Akien is stormi's brother so comes from good stock
19:11:53 <diogenese> :)
19:11:59 <MrsB> hi diogenese
19:12:13 <diogenese> Hi MrsB, everybody
19:12:19 <MrsB> First topic, an easy one to get us started
19:12:36 <MrsB> #topic Useful Bugzilla Searches
19:12:57 <MrsB> leuhmanu kindly created some saved searches for us
19:13:07 <MrsB> #info leuhmanu kindly created some saved searches for us
19:13:29 <MrsB> anybody can use that command btw, it makes an info note in the minutes
19:14:13 <MrsB> #info You can find all the saved searches in the Prferences page which you can find here https://bugs.mageia.org/userprefs.cgi?tab=saved-searches
19:14:15 <[mbot> [ Log in to Bugzilla ]
19:14:48 <MrsB> there are a number of useful searches there for QA
19:15:11 <MrsB> #info waiting for QA test - our main bug list
19:15:43 <MrsB> #info waiting for QA test mga1 - the same list broken down to show mga1 bugs only
19:15:57 <MrsB> #info waiting for QA test mga2 - the same list broken down to show mga2 bugs only
19:16:34 <MrsB> #info If you tick the box next to them in the Show in Footer column they will show at the bottom of your Bugzilla pages
19:17:05 <MrsB> there are a few more too which can be useful, or not
19:17:32 <MrsB> #info QA wait packagers - QA bugs waiting for a response from packagers
19:18:06 <MrsB> #info updates-push - These are validated updates waiting to be pushed
19:18:56 <MrsB> #info Updates waiting for QA - This is the original list with everything for mga1 and 2 waiting for packagers or not
19:19:29 <MrsB> any questions so far?
19:19:46 <diogenese> Not yet.
19:20:05 <MrsB> Ok so next topic, a big one.
19:20:13 <leuhmanu> perfect explanation O:)
19:20:22 <MrsB> Dave I hope you'll help here because I'm a bit frazzled today
19:20:30 <DavidWHodgins> Backports?
19:20:33 <MrsB> #topic Backports
19:20:48 <MrsB> morning Led43NB
19:20:59 <DavidWHodgins> Backports will be opened for both Mageia 1 and 2.
19:21:05 <Led43NB> MrsB: morning
19:21:10 <MrsB> you speak Dave
19:21:43 <DavidWHodgins> If a package is backported for Mageia 1, the same or a newer version must be in Mageia 2, either core, updates, or backports.
19:22:03 <DavidWHodgins> It's ok if a packager chooses to only backport to Mageia 2.
19:22:26 <DavidWHodgins> Qa will not start validating backports until after bug 2317 is fixed.
19:22:27 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, High, thierry.vignaud, NEW, PATCH, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
19:23:17 <DavidWHodgins> The rpmdrake-edit-media program will be modified to warn users who enable backports, that it may break upgrading to the next release.
19:23:56 <MrsB> was there anything else?
19:24:07 <DavidWHodgins> Backports will only be accepted for leaf packages or leaf "groups", and must have strict requires for dependencies, to ensure propper dependency selection.
19:24:22 <DavidWHodgins> The procedure will be similar to updates.
19:24:31 <MrsB> lets add some infos
19:24:45 <MrsB> #info Certain things were agreed last night at the packagers meeting
19:24:58 <MrsB> #info If a package is backported for Mageia 1, the same or a newer version must be in Mageia 2, either core, updates, or backports.
19:25:10 <MrsB> #info It's ok if a packager chooses to only backport to Mageia 2.
19:25:24 <MrsB> #info The rpmdrake-edit-media program will be modified to warn users who enable backports, that it may break upgrading to the next release.
19:25:49 <MrsB> #info Backports will only be accepted for leaf packages or leaf "groups", and must have strict requires for dependencies, to ensure proper dependency selection.
19:26:17 <MrsB> #info The procedure will be similar to updates..
19:26:21 <MrsB> so
19:26:30 <DavidWHodgins> #info Backports will be built in Core/Nonfree/Tainted backports testing
19:26:43 <MrsB> It is up to us now to agree the procedure
19:26:54 <MrsB> I was hoping Stormi would be here for this
19:27:13 <DavidWHodgins> I think we should work the same as we do for updates with mga1too, etc.
19:27:29 <DavidWHodgins> One bug report for both releases.
19:27:57 <MrsB> yes I think so too, but  they should be set as enhancements and lowest priority
19:28:09 <DavidWHodgins> Keeps our procedures the same whether we are working on an update, or a backport.
19:28:39 <MrsB> Should we add a new keyword, validated_backport ?
19:28:54 <Luigi12_work> MrsB: possibly you could ask the bugzilla admins to have it automatically set to enhancement/lowest priority if someone selects the Backports component
19:28:57 <DavidWHodgins> Then we have to remember which to paste in.
19:29:07 <MrsB> leuhmanu: still here?
19:29:10 <leuhmanu> yes
19:29:27 <DavidWHodgins> I'd rather stick with validated update, as the backport could be an update for an existing backport.
19:29:30 <MrsB> is that possible do you know?
19:29:41 <leuhmanu> (I'm have no more right than you bur I guess yess
19:29:42 <MrsB> thats a point Dave
19:29:59 <MrsB> I think thats a good idea Luigi12_work
19:29:59 <leuhmanu> arf sorry for all typo
19:30:15 <Luigi12_work> it should be, if you select one of the other components (release process maybe?) it automatically CCs the sysadmin list
19:30:15 <DavidWHodgins> I'd rather not have to do anything different, for a backport compared to an update.
19:30:31 <MrsB> #action MrsB ask the bugzilla admins to have it automatically set to enhancement/lowest priority if someone selects the Backports component
19:31:04 <Luigi12_work> DavidWHodgins: that sounds fine, as long as it's clear to sysadmins which type of thing they're pushing
19:31:05 <MrsB> Akien diogenese harms_ any opinion?
19:31:07 <leuhmanu> same for package request whould be nice too O:) but not the topic
19:31:22 <Luigi12_work> of course it'd be better if they'd work it out so that QA could hit a button and push them directly
19:31:45 <harms_> Not without having made some experience
19:31:51 <Luigi12_work> leuhmanu: true, although maybe just enhancement.  A package request shouldn't necessarily be low priority.
19:31:54 <DavidWHodgins> Keep in mind, although backports are a lower priority, that doesn't mean a tester who want's a backport can't go ahead and test the backport, just because there are outstanding updates to test.
19:32:25 <diogenese> harms_: Was thinking the same. Still learning how to do things.
19:32:41 <DavidWHodgins> We currently have to remember whether to tell sysadmin to push from Core, nonfree, and/or tainted.  Just adding backports shouldn't be too hard.
19:32:48 <MrsB> I think we should involve the person requesting the backport as much as possible in the testing
19:32:56 <DavidWHodgins> Agreed.
19:33:08 <Akien> From what I have seen of the updates validation process, I'm okay to use the same for backports.
19:33:37 <MrsB> do we all agree to involving the requester as much as possible?
19:33:52 <harms_> sure
19:33:54 <Akien> I do. Request is contributing :)
19:34:00 <Akien> s/Request/Requesting/
19:34:03 <diogenese> Chain them to it. :)
19:34:13 * leuhmanu was planning to add a check to the gtrasemonkey script that nobody use (except me) :)
19:34:33 <Luigi12_work> lock them in a room and don't let them out until they help
19:34:42 <MrsB> lol
19:34:58 <MrsB> Led43NB agree too?
19:35:29 <MrsB> #agreed we should involve the person requesting the backport as much as possible in the testing
19:35:44 <Led43NB> yes
19:35:54 <MrsB> Ok so next thing..
19:36:39 <MrsB> The validation process should be the similar to that for validating updates but we will only check it installs and seems to work correctly
19:36:55 <MrsB> agree/disagree?
19:37:11 <DavidWHodgins> Possible info - Procedures for qa testers will be the same for backports, as it is for updates, except when telling sysadmin where to push from.
19:37:18 <DavidWHodgins> Agreed?
19:37:19 <Luigi12_work> people are free to test more thoroughly if they want, but it's not required
19:37:37 <Led43NB> yes
19:37:43 <DavidWHodgins> Testing will be minimal.  Clean install, and program starts.
19:37:51 <harms_> less sure - install is probably not enough
19:37:54 <MrsB> thats a better way of saying it yeah
19:38:16 <harms_> agree
19:38:17 <MrsB> just thinking install and a quick check
19:38:20 <DavidWHodgins> Clean install, and Main features work?
19:38:35 <Luigi12_work> define "Main features" :o)
19:38:44 <DavidWHodgins> Depends on the program.
19:38:50 <leuhmanu> less that 4mins of exploration ? :)
19:38:52 <Luigi12_work> exactly
19:38:53 <DavidWHodgins> We'll use common sense.
19:38:56 <MrsB> so how shall we word this?
19:39:39 <DavidWHodgins> Packages install cleanly, and basic testing completed?
19:39:43 <harms_> I would like the backporter provide a list of main features
19:40:02 <DavidWHodgins> And, where not obvious, a testing method.
19:40:18 <harms_> right
19:40:24 <leuhmanu> I yes there should be an advisory, so you can ask for that
19:40:35 <MrsB> The validation process should be the similar to that for validating updates but less thorough. Packages install cleanly and basic testing.
19:40:45 <Akien> Agreed.
19:40:46 <MrsB> yes good point leuhmanu
19:40:47 <DavidWHodgins> Something like VirtualBox, or firefox, the testing is obvious.
19:41:27 <MrsB> #agreed The validation process should be the similar to that for validating updates but less thorough. Packages install cleanly and basic testing.
19:41:32 <DavidWHodgins> Testing that requires specific hardware may only be tested on one arch, if that's all that's available.
19:41:52 <Akien> If it's libhelloworld-1.mga2.rpm, maybe basic testing can be skipped.
19:42:24 <MrsB> so next thing..
19:42:26 <DavidWHodgins> I think cases like that should be skipped only after agreeing on Mageia discuss.
19:42:48 <MrsB> as leuhmanu said, there should be a similar sort of advisory and listing of packages and srpms
19:42:51 <Akien> Mageia discuss or QA discuss?
19:43:08 <DavidWHodgins> Oh, don't forget backports announce.
19:43:14 <MrsB> i havent :P
19:43:17 <DavidWHodgins> Qa discuss
19:43:23 <DavidWHodgins> Sorry.
19:43:39 <MrsB> agree/disagree on advisory etc same as updates?
19:43:49 <Luigi12_work> what would an advisory say besides "xmoto 1.3.0 is available." ?
19:43:54 <leuhmanu> :)
19:43:56 <MrsB> must list the rpm's aswell as srpms
19:44:20 <leuhmanu> maybe that require to manpower
19:44:22 <leuhmanu> +o
19:44:33 <Luigi12_work> listing the rpms is easy
19:44:34 <MrsB> not sure Luigi12_work maybe it uses a completely different widget that conflicts with xmoto
19:44:48 <MrsB> how do you do that btw?
19:45:05 * leuhmanu check with Sophie
19:45:12 <Luigi12_work> http://pkgsubmit.mageia.org/  click on uploaded on the right
19:45:14 <[mbot> [ Mageia build system status ]
19:45:40 <Luigi12_work> click on the directory inside, then the build.xxx.log (the second if there's two of them) scroll to the bottom
19:45:50 <Akien> Maybe explicit main new features and give a link to the changelog(s)?
19:46:05 <MrsB> hmm monitor the build system then :D
19:46:07 <Luigi12_work> only works if it's been built within the last two days, otherwise I just look on a mirror in updates_testing and find all the packages with the same version
19:46:20 <leuhmanu> sophie is faster :p
19:46:33 <Luigi12_work> if a packager is submitting a backport request, they presumably just built it recently and should be able to access the package list easily
19:46:45 <MrsB> we can add an info for it leuhmanu in a minute
19:46:52 <Luigi12_work> leuhmanu: 1) demonstrate 2) is she always 100% up to date?
19:47:10 <leuhmanu> :more ocsigenserver -s
19:47:11 <Sophie> leuhmanu: http://sophie.zarb.org/rpms/3fb5681187e9728632af06cffeb14b97 // core-release-src (Mga, cauldron, i586), core-release-src (Mga, cauldron, x86_64)
19:47:21 <Luigi12_work> like if you *just* built something will she see it?
19:47:23 <MrsB> anybody disagree with similar advisories being needed to updates?
19:47:34 <leuhmanu> Generated packages: ** done :)
19:47:42 <DavidWHodgins> Nope.
19:47:43 <Luigi12_work> I don't disagree, I just don't know what the advisory should say
19:47:56 <DavidWHodgins> Case by case, commen sense.
19:48:00 <Luigi12_work> the list of packages is tangential, I just mean the text
19:48:01 <DavidWHodgins> common
19:48:15 <Luigi12_work> unfortunately common sense isn't always that common
19:48:19 <MrsB> yeah common sense advisory with list of rpms and srpms
19:48:28 <DavidWHodgins> I think most cases a link to the changelog is enough.
19:48:40 <MrsB> adding an agree then, last chance...
19:48:42 <Luigi12_work> and/or release notes, good idea
19:49:04 <DavidWHodgins> Yeah.  The sysadmins need to know which srpms.  Users need to know which rpm packages.
19:49:13 <Luigi12_work> release announcement, release notes, and/or changelog
19:49:29 <Akien> Yep.
19:49:39 <DavidWHodgins> Agreed.
19:49:43 <Akien> At least we want to know what's new in the package, not just "Hey it's new, so it's better."
19:49:56 <MrsB> #agreed A common sense advisory should be supplied similar to update and should list rpms and srpms
19:50:15 <Luigi12_work> you mean # info I presume?
19:50:32 <DavidWHodgins> Both 32 and 64 bit rpms listed?
19:50:46 <Akien> Luigi12_work: #agreed is also a valid tag :)
19:50:59 <Luigi12_work> I think that's the same mod lib/lib64 DavidWHodgins , either arch should be sufficient
19:51:04 <Luigi12_work> Akien: oh didn't nkow that
19:51:17 <MrsB> #info A mailing list is going to be created for backports announce
19:51:39 <MrsB> ok, what was next?
19:51:59 <Luigi12_work> protest planning if 2317 isn't fixed soon?
19:52:06 <MrsB> lol
19:52:31 <DavidWHodgins> As stated in developers meeting yesterday, qa will not validate any backports until 2317 is fixed.
19:52:52 <MrsB> our procedure I mean, I'm sure we've missed somethign that was said
19:53:32 <DavidWHodgins> I think that covers it for procedure.  Once the advisory is completed, and the update validated, it's up to sysadmin to push.
19:54:05 <MrsB> #info to find rpms in an srpm you can use Sophie, the IRC bot. eg. :more ocsigenserver -s
19:54:39 <MrsB> so is there any reason we need a new keyword or is it ok to use validated_update ?
19:55:14 <DavidWHodgins> I'd prefer validated_update.
19:55:18 <Akien> As long as backports are categorised as such in Bugzilla, it should be okay.
19:55:26 <leuhmanu> you can use the backport one if you like (exist before the component)
19:55:33 <DavidWHodgins> Should there be a separate backports announce for each release?
19:55:55 <MrsB> i can't think of a reason really for a new keyword
19:56:27 <MrsB> #info we think we will use the validated_update keyword the same as for updates
19:57:10 <MrsB> Ok have I forgotten anything?
19:57:22 <DavidWHodgins> People running Mageia 1 won't want to see announcements for things that are only backported to mga 2.
19:57:40 <MrsB> thats common sense tho
19:57:55 <MrsB> oh for the ML, thats nto really our decision
19:58:00 <leuhmanu> DavidWHodgins: more an admin task
19:58:08 <DavidWHodgins> Should we ask sysadmin about different mailing list per relase?
19:58:24 <MrsB> i don't think it's necessary
19:58:25 <leuhmanu> to much ml kill ml :)
19:58:26 <harms_> Its different target user groups
19:58:43 <Luigi12_work> not different list, but different announcement mail per release
19:58:59 <Luigi12_work> then you can filter by subject
19:59:02 <MrsB> who wants to ask sysadmin to do that then?
19:59:14 <DavidWHodgins> Maybe always include release(s) in subjects of mailing list.
19:59:21 * MrsB looking for a volunteer
19:59:28 <Luigi12_work> well tmb already does that for updates
19:59:30 * tmb already do
19:59:31 <DavidWHodgins> I'll ask about it on the sysadmin mailing list.
19:59:36 <MrsB> tmb :)
19:59:47 <Luigi12_work> speak of the devil
19:59:52 <DavidWHodgins> Lol
20:00:15 <DavidWHodgins> tmb: No need for a discussion on the sysadmin mailing list then?
20:00:27 <MrsB> #action Dave H will ask sysadmin about distinguishing mga1 backports from mga2 backports on the backports announce ML
20:00:41 <tmb> nope, ok for me
20:00:53 <Luigi12_work> tmb: you need to find a junior sysadmin to handle backports so you don't get overworked :o)
20:00:56 <DavidWHodgins> How do you undo an action?
20:00:58 <MrsB> #info tmb says it's ok
20:01:14 <MrsB> that'll do
20:01:21 <DavidWHodgins> Ok.
20:01:32 <MrsB> are we forgetting anything tmb?
20:02:13 <DavidWHodgins> Like updates, Mageia 2 should get pushed at the same time as, or before magia 1.
20:02:37 <MrsB> #info QA will be very reluctant to validate any backports until bug 2 3 1 7 is fixed
20:02:38 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2 enhancement, Normal, dmorganec, RESOLVED FIXED, test xmlrpc to see if it works to create a bug
20:02:51 <MrsB> good point dave
20:02:53 <Luigi12_work> only very reluctant?
20:03:00 <DavidWHodgins> s /very reluctant/will not/
20:03:11 <tmb> well, what should we set as timeline to keep backports_testing clean ?
20:03:27 <MrsB> #info extremely reluctant
20:03:31 <Luigi12_work> tmb: like how long to leave something there before it gets deleted?
20:03:38 <leuhmanu> (interesting bug2)
20:04:07 <tmb> Luigi12_lappy: yep, so no-ony tries to leave stuff in testing only...
20:04:15 <DavidWHodgins> I think two weeks from package in testing till bug report must be opened should be enough.
20:04:24 <MrsB> yes, it was mentioned that there should perhaps be a limit to the amount of time a backport could remain in backports testing before it was removed.
20:04:30 <Luigi12_work> tmb: that's a good idea.  How about one month (remembering that backports are low priority)
20:04:47 <DavidWHodgins> I'd be ok with one month.
20:05:01 <MrsB> I'm ok with that, anybody else?
20:05:07 <tmb> I suggested 2 days from build to request, and 1 month to delete in my initial mail too :)
20:05:10 <MrsB> please chip in :)
20:05:18 <Luigi12_work> tmb: sounds good
20:05:44 <MrsB> sounds like a plan yes
20:05:50 <MrsB> we're all ok with that?
20:05:55 <DavidWHodgins> Ok here.
20:06:02 <diogenese> Yes
20:06:37 <DavidWHodgins> Will backports be frozen during release freeze?
20:07:08 <tmb> yep.
20:07:11 <MrsB> #agreed tmb suggested that to prevent backports testing being abused a time limit be imposed before things are removed.  2 days from build to backport request on bugzilla, and 1 month to delete.
20:07:53 <MrsB> who will monitor that?
20:08:03 <MrsB> build to bug?
20:08:52 <DavidWHodgins> I guess that will require some manual searching.
20:09:15 <Luigi12_work> a smart enough bot could do it
20:09:32 <MrsB> It's maybe worth noting that backports should have strictly versioned requires so selecting the main package should bring in everything that is needed in the right versions
20:09:34 <Luigi12_work> search bugzilla for open bugs with a certain package in rpm field and backports component
20:10:03 <Luigi12_work> MrsB: yes, how will that be checked/caught/enforced?
20:10:53 <DavidWHodgins> I think for now, we'll have to manually keep an eye on things, and review in a couple of months how to enforce.
20:10:54 <MrsB> I guess if it doesn't work its wrong?
20:11:10 <MrsB> its partly why I want the list of rpms on the bug report
20:11:20 <DavidWHodgins> It should be rare enough to handle manually.
20:11:20 <MrsB> it should bring in all the ones listed there
20:11:40 <MrsB> #info It's maybe worth noting that backports should have strictly versioned requires so selecting the main package should bring in everything that is needed in the right versions
20:11:48 <Luigi12_work> yes, the list of rpms would help for this, but they're not all required.  It just needs to bring in the ones that are required, so no older versions of any listed there remain installed.
20:12:08 <MrsB> #info the list of rpms would help for this, but they're not all required.  It just needs to bring in the ones that are required, so no older versions of any listed there remain installed.
20:12:25 <MrsB> ok, we can work on this
20:12:37 <Luigi12_work> I wonder if there's some urpm-foo that can catch this easily
20:12:48 <MrsB> anything else then before we move on?
20:13:06 <MrsB> any questions anybody?
20:13:12 <DavidWHodgins> I think that covers it.
20:14:04 <leuhmanu> #link search for backport waiting for QA test https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=Backport%20waiting%20for%20QA%20test&sharer_id=22
20:14:08 <[mbot> [ Log in to Bugzilla ]
20:14:28 <MrsB> nice leumanu thanks, is that a saved search too?
20:14:36 <leuhmanu> yes
20:14:58 <MrsB> Backport waiting for QA test?
20:15:09 <leuhmanu> all search that end with id=22 come from me
20:15:12 <leuhmanu> yep
20:15:38 <MrsB> #info Another saved search for that - Backport waiting for QA test
20:15:45 <MrsB> ok moving on then..
20:15:48 <MrsB> thanks
20:16:10 <MrsB> #topic Bug 23 1 7 (The BWNWDNS)
20:16:13 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=23 normal, Normal, bugsquad, RESOLVED FIXED, Testing bugs ML
20:17:01 <MrsB> #info Hopefully this will be fixed before backports open
20:17:18 <leuhmanu> (/me should found a way for [mbot not responsing on this bug...)
20:17:19 <DavidWHodgins> Must be!
20:17:20 <MrsB> #info AL13N is actively seeking out assistance with it
20:17:39 <MrsB> so not much news yet
20:18:05 <MrsB> has anybody any questions about this bug?
20:18:50 <MrsB> none :O
20:18:57 <DavidWHodgins> Not here.
20:19:12 <MrsB> if not then we'll move swiftly on \o/
20:19:33 <MrsB> #topic Mageia 3 Features
20:20:08 <MrsB> https://wiki.mageia.org/en/FeatureMageia3_Review
20:20:31 <MrsB> #info There is now an accepted list of approved features for the next release, some other proposals need more detail but there is still a short amount of time
20:20:56 <MrsB> https://www.mageia.org/pipermail/mageia-dev/2012-June/016819.html
20:20:57 <[mbot> [ [Mageia-dev] Mageia 3 feature proposals review ]
20:21:14 <DavidWHodgins> I don't think we can really plan iso testing till after there is agreement on what iso images will be built.
20:21:46 <MrsB> #info the final list of approved features will be made on 5th July
20:21:59 <MrsB> thats coming dave
20:22:24 <MrsB> any questions on mageia 3 features?
20:22:56 <diogenese> Not here.
20:23:07 <DavidWHodgins> Looks like a lot less of a change than the change from sysvinit to systemd, so should be easier to test.
20:23:23 <MrsB> add that in an info dave
20:24:36 <DavidWHodgins> #info changes in Mageia 3 will be a less of an impact than the change in Mageia 2 from sysvinit to systemd, so should be easier to test.
20:24:53 <MrsB> ok moving on then..
20:24:58 <DavidWHodgins> Hopefully a lot less iso images too.
20:25:02 <MrsB> yeah
20:25:10 <MrsB> #topic Growing the team
20:25:55 <MrsB> #info At the packagers meeting it was agreed that they would try and volunteer some time to help out QA with validating updates \o/
20:26:09 <MrsB> http://meetbot.mageia.org/mageia-dev/2012/mageia-dev.2012-06-27-19.11.log.html#l-10
20:26:10 <[mbot> [ #mageia-dev log ]
20:26:42 <MrsB> #info A link has been added at the top of pkgsubmit page as a reminder
20:27:02 <MrsB> http://pkgsubmit.mageia.org/
20:27:04 <[mbot> [ Mageia build system status ]
20:27:43 <MrsB> #info A request for people was sent to mageia-discuss mailing list and the forums today
20:28:13 <MrsB> As you are probably painfully aware we are short of people :)
20:28:32 <MrsB> does anybody have any ideas to help grow the team?
20:29:19 <MrsB> any comments?
20:29:32 <DavidWHodgins> Ask everyone requesting a backport to help with qa, and suggest they consider joining qa.
20:29:41 <Luigi12_work_> do other distros have public/community QA teams?
20:29:54 <MrsB> I don't know
20:29:59 <DavidWHodgins> Me neither.
20:30:03 <Luigi12_work_> me neither, I've only been around mdv all these years and they didn't
20:30:15 <MrsB> #info we could Ask everyone requesting a backport to help with qa, and suggest they consider joining qa.
20:30:18 <Luigi12_work_> if any other distros do, it'd be interesting to know how they've done it
20:30:31 <MrsB> I think alot now have automated testing
20:30:36 <Akien> MrsB: We could make a blog post about QA.
20:30:43 <Luigi12_work_> yeah publicity
20:30:50 <MrsB> Akien good idea!
20:31:00 <Luigi12_work_> I imagine a lot of people don't even think about QA when thinking about ways they could help
20:31:02 <Akien> Or a "They make Mageia: MrsB" ;)
20:31:08 <MrsB> #info we could make a blog post asking for help
20:31:23 <MrsB> i think you're right Luigi12_work_
20:31:32 <MrsB> until something goes wrong at least
20:31:47 <MrsB> or updates are slow coming out, like zoltan did
20:32:15 <MrsB> ok so a couple of ideas.
20:32:31 <MrsB> in the meantime I'm afraid we really need to push hard to get things validated
20:32:40 <harms_> Asking for help should go hand in hand with explaining how/what QA does
20:32:56 <MrsB> yes you're right harms_
20:33:07 <MrsB> #info Asking for help should go hand in hand with explaining how/what QA does
20:33:34 <MrsB> That kind of brings us to our documentation
20:33:57 <Akien> The QA portal on the wiki is great :)
20:34:46 <MrsB> Our list is getting longer rather than shorter at the moment though so we really do need to whistle through them
20:35:21 <DavidWHodgins> I'm getting a new 64 bit system next week.
20:35:23 <MrsB> #info We need a push getting updates validated to keep on top of our list :\
20:35:32 <MrsB> oh thats good Dave
20:35:41 <MrsB> long overdue!
20:35:52 <DavidWHodgins> Yep.  7 years with my current system.
20:35:52 <MrsB> your poor old pooter
20:36:07 * Luigi12_work_ 's lappy is 7 years old :o)
20:36:12 <DavidWHodgins> Over 20 years with the same monitor.
20:36:20 <Luigi12_work_> :O
20:36:21 <MrsB> mine is too but i've only had it 2 or 3
20:36:42 <MrsB> are you sure it's a monitor and not a blackboard?
20:36:56 <DavidWHodgins> Lol.  Mitsuibishi diamond scan 20.
20:37:01 <Luigi12_work_> is it amber and black only?
20:37:02 <MrsB> greenscreen?
20:37:07 <Luigi12_work_> or green
20:37:31 <DavidWHodgins> I've used those in the past too, even used punch cards at the start.
20:37:38 <MrsB> anyway, lets move on..
20:37:54 <MrsB> #topic QA wiki pages
20:38:07 <MrsB> There have been some changes.
20:38:26 <MrsB> the latest changes happened this afternoon and to tell the truth I haven't had a chance to look myself yet
20:39:05 <MrsB> as per the meeting email though our procedure pages (what procedure pages you say :P) are being moved into their own namespace
20:39:48 <MrsB> #info when you've tested something it's a good idea to create a procedure page for it on our portal
20:40:03 <MrsB> there are onyl a few so far
20:40:33 <MrsB> The problem that's being anticipated is that the number of pages grow to an extent where they interfere with the main wiki
20:40:47 <MrsB> #info The problem that's being anticipated is that the number of pages grow to an extent where they interfere with the main wiki
20:41:19 <MrsB> #info A new namespace has been created to keep the testing procedure pages separate
20:41:23 <MrsB> so..
20:41:43 <MrsB> #info what used to be https://wiki.mageia.org/en/Testing_procedure_for_T1lib
20:42:07 <MrsB> #info will now become https://wiki.mageia.org/en/QA_procedure:T1lib
20:42:23 <MrsB> #info it also means we can search it easily
20:42:39 <MrsB> https://wiki.mageia.org/mw-en/index.php?title=Special:Search&fulltext=Search&advanced=1&ns0=1&ns100=1&ns102=1&redirs=0&search=
20:42:46 <MrsB> long link :\
20:43:07 <MrsB> I don't yet know how it affects us creating new procedure pages
20:43:29 <MrsB> any questions or comments?
20:43:47 <harms_> Can you quote an example of a page with a test procedure - recommended
20:43:55 <harms_> to follow when doing suc a page
20:44:12 <Luigi12_work_> isn't there a template or something?
20:44:27 <DavidWHodgins> I did https://wiki.mageia.org/en/QA_procedure:Krb5
20:44:30 <MrsB> There were/still are some pages there which told/tell you how to do it. It will have changed now though
20:44:55 <MrsB> All this happened approximately a couple of hours ago
20:45:17 <MrsB> #info Anybody can edit the wiki or create new pages
20:45:28 <MrsB> please feel free to make improvements!
20:46:14 <MrsB> #info marja, JohnR, Workaholic are good people to ask for help
20:46:41 <MrsB> #info or pop in to #mageia-doc
20:46:56 <DavidWHodgins> When I did krb5, I  just took another procedure, copied it, and then edited the copy.
20:47:15 <MrsB> The main problem is creating thepage in the first place
20:47:30 <MrsB> it is easiest to create a link and then click the link and edit the page
20:47:44 <MrsB> but I'm not sure how we will do it now
20:48:10 <MrsB> You can always just visit the URL though
20:48:24 <MrsB> like https://wiki.mageia.org/en/QA_procedure:<package>
20:48:52 <MrsB> #action MrsB to find out what has happened to our wiki pages
20:49:16 <MrsB> #action everybody please create them when you have completed testing things :)
20:49:40 <MrsB> anybody any comments/questions?
20:50:04 <harms_> How about - at least initially - have some informal reviewing, ask some
20:50:17 <harms_> other QA member to check a page once it is initially done?
20:50:32 <DavidWHodgins> harms_: Good idea.
20:51:04 <harms_> QA on QA
20:51:12 <DavidWHodgins> After creating procedure page, always post a link to qa-discuss asking for a review.
20:51:14 <MrsB> sure, yeah if you like. It was all set up so it was easy to do but it's changed now so we'll have to look at it and see what if anything needs doing to make it easy
20:51:47 <MrsB> oh another link I forgot..
20:52:12 <MrsB> #info they are all in a category
20:52:14 <MrsB> https://wiki.mageia.org/en/Category:Testing_procedures
20:52:54 <MrsB> ok so we're almost done, sorry its another long one
20:53:06 <MrsB> #topic ISO testing
20:53:40 <MrsB> #info Nothing much has changed since the last meeting but we can't afford to forget about this
20:54:31 <MrsB> #info We need to create our procedure and document it so it is easy for new people or general users to get involved and test thoroughly
20:54:47 <MrsB> #info a remind of what we had from last time
20:54:50 <MrsB> http://www.ethercalc.org/qa
20:54:51 <[mbot> [ EtherCalc - Share the URL to your friends and edit together! ]
20:55:12 <MrsB> #info if you have a better idea then please let's discuss it :)
20:55:53 <MrsB> so not alot there really but we don't have long as we have to be ready for the alpha which lands at the beginning of September
20:56:05 <harms_> Iso testing is quite repetitive (at least of Live CDs) - can some of it
20:56:12 <harms_> be done automatically? I scratched my head without result
20:56:37 <MrsB> It is possible and its something we should look at
20:56:57 <MrsB> I think it would be hard to have something reliable for production use for mageia 3 though
20:57:11 <MrsB> we can look into it though and begin working on something
20:57:26 <harms_> yes - the is a mid term issue
20:57:30 <MrsB> it's up to us, so if you have an idea please share it :)
20:58:12 <MrsB> so let mop up..
20:58:19 <DavidWHodgins> In the past, I've found most automated testing actually slows things down.
20:58:19 <MrsB> #topic Anything else.
20:58:58 <MrsB> I have something but has anybody anything else they'd like to ask or talk about?
20:59:05 <DavidWHodgins> Not here.
20:59:27 <Akien> I don't.
20:59:36 <harms_> neither
20:59:48 <MrsB> One thing then, alot has happened today with firefox..
21:00:19 <MrsB> where we were previously testing several extra packages relating to xulrunner we now no longer have to
21:00:29 <DavidWHodgins> ?
21:01:03 <tmb> ?
21:01:23 <MrsB> https://bugs.mageia.org/show_bug.cgi?id=6389
21:01:24 <[mbot> Bug 6389: normal, Normal, qa-bugs, NEW, firefox needs to be updated to 10.0.5 for security issues, firefox-10.0.4-1.mga1.src.rpm
21:01:40 <MrsB> eclipse is being rebuilt without xulrunner
21:02:14 <MrsB> it is currently causing segfaults with gnome-python-gtkmozembed and in mga1 perl-Gtk2-MozEmbed
21:02:47 <MrsB> as a result that has been separated off into a separate bug
21:02:47 * Luigi12_work_ wonders if it even really "works" anymore given how much the API has been gutted
21:03:03 <MrsB> It looks likely not to have worked properly since 2007
21:03:15 <MrsB> see bug 6610
21:03:16 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=6610 normal, Normal, dmorganec, NEW, libxul.so.0 segfaults with gnome-python-gtkmozembed (mga1 & 2) or perl-Gtk2-MozEmbed (mga1), xulrunner
21:03:54 <MrsB> what we now have to test is firefox itself
21:04:15 <diogenese> That will be much easier.
21:04:35 <MrsB> it leaves firefox, firefox-l10n, nspr and nss - the last two are to do with https
21:05:01 <MrsB> I think nspr can be shown to work with flash through https
21:05:43 <MrsB> there was alot of discussions about all this today on the mga2 bug if you are interested
21:06:36 <DavidWHodgins> For nspr, is that libnspr4?
21:06:41 <Luigi12_work_> yes
21:07:14 <DavidWHodgins> From it's description, it looks like a core part of firefox.
21:07:15 <MrsB> when mga1 version is pushed we can ask for perl-Gtk2-MozEmbed, gnome-python-extras and xulrunner to be removed from testing
21:07:35 <Luigi12_work_> yes nspr and nss are core parts of FF, we have them packaged as external libs so they can be used by other things
21:07:45 <Luigi12_work_> nspr is used by rpm and nss is used by some other things too
21:07:58 <DavidWHodgins> Ok, so if firefox basically works, then they do too.
21:08:17 <Luigi12_work_> well hopefully we can provide an update for xulrunner at some point just in case anyone's using their own apps built against it
21:08:36 <Luigi12_work_> assuming anything builds against and still works these days
21:08:50 <MrsB> java test, flash test, https, try flash over https to make sure, i10n check make sure spellcheck is ok, general browsing.
21:09:12 <DavidWHodgins> Standard browser testing.
21:09:16 <MrsB> yeah
21:09:41 <MrsB> I think this one should be our first priority
21:09:58 <MrsB> followed by ffmpeg and things built with it, the mplayer etc
21:10:21 <MrsB> is that ok?
21:10:38 <DavidWHodgins> Yep.  I expect to be testing for the next 4 or 5 hours.
21:10:45 <MrsB> Yay \o/
21:10:53 <MrsB> I expect to be asleep in 4 or 5 mins
21:11:10 <DavidWHodgins> Lol.  I only got up about 3 hours ago.
21:11:12 <Luigi12_work_> mga1 ffmpeg stuff is actually more critical than mga2 and can be pushed first, they're differnet updates
21:11:33 <DavidWHodgins> Ok.
21:11:36 <MrsB> has anybody anything to add or any questions?
21:11:41 <MrsB> if not we'll close
21:12:03 <DavidWHodgins> Go ahead.  Time to get back to testing. :-)
21:12:21 <tmb> or sleeping...
21:12:32 <MrsB> #info please prioritise firefox mga1 followed by ffmpeg mga1 then 2 then mplayer etc build upon it
21:12:45 <MrsB> so same time next week guys :)
21:12:53 <MrsB> #info same time next week!
21:12:55 <DavidWHodgins> Ok.
21:13:19 <MrsB> thankyou all for coming, sorry it was another long one. I hope by having them more regularly there will be less to cover each time
21:13:28 <MrsB> #endmeeting