20:08:52 <ennael> #startmeeting
20:08:52 <Inigo_Montoya`> Meeting started Mon Mar  9 20:08:52 2015 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:08:52 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:09:00 <ennael> #chair MrsB
20:09:00 <Inigo_Montoya`> Current chairs: MrsB ennael
20:09:09 <MrsB> uh oh
20:09:13 <ennael> so yet another meeting dedicated to Mageia 5
20:09:24 <ennael> let's try to kill cauldron
20:10:03 <MrsB> it's slow going isn't it
20:10:08 <ennael> it is
20:10:21 <ennael> ok so does QA want to start with ?
20:10:39 <MrsB> start with iso naming please
20:10:53 <MrsB> we currently have classics with rc and lives with RC
20:11:05 <ennael> yep so shall I use RC?
20:11:19 <MrsB> next rebuild, yes please. I think it looks better that way too
20:11:28 <ennael> just need to warn people not to break rsync
20:11:47 <DavidWHodgins> May as well. tmb is not here, so probably better to change the classic iso images to be consistent with the live.
20:12:07 <MrsB> I'll email everybody again to rename them RC
20:12:27 <ennael> ok thanks
20:12:36 <MrsB> #action MrsB email the ISO list about RC iso names
20:13:24 <MrsB> I'll do that early tomorrow so we can be ready
20:13:41 <ennael> ok
20:14:46 <MrsB> How are we looking now, for RC?
20:15:47 <DavidWHodgins> bug 15242 is confusing. I'm getting the impression now, that it may only affect firmware raid setups, where diskdrake is seeing the raw disks as not being used.
20:17:01 <ennael> hi tmb
20:17:03 <DavidWHodgins> I just finished syncing the live iso images. Haven't had a chance to test any of them yet.
20:17:11 <tmb> hi all
20:17:17 <DavidWHodgins> HiYa
20:17:27 <ennael> MrsB: we have some bugs fixed
20:17:33 <ennael> postgresql will be cleant
20:17:37 * tmb just got home from work...
20:17:40 <MrsB> cool \o/
20:17:50 <MrsB> morning tmb
20:17:55 <MrsB> morning Akien
20:18:01 <ennael> polarssl is in progress
20:18:13 <ennael> luigi will ask for push in 10 lminutes
20:18:15 <Akien> Morning
20:18:19 <MrsB> thats sec bug isn't it?
20:18:43 <ennael> nope
20:18:44 <ennael> https://bugs.mageia.org/show_bug.cgi?id=15391
20:18:46 <[mbot> [ Bug 15391 hiawatha incorrectly provides libpolarssl.so.7 ]
20:19:27 <ennael> about failes upgrade
20:19:28 <ennael> https://bugs.mageia.org/show_bug.cgi?id=15350
20:19:30 <[mbot> [ Bug 15350 Upgrade failed mga4 to mga5 - 195 transactions failed ]
20:19:41 <MrsB> yes, thierry just commented on that one
20:19:48 <ennael> tv is on it, MrsB he just asked to try some options
20:19:51 <ennael> yep
20:19:59 <MrsB> they'll work at grub won't they?
20:20:20 <MrsB> dvd doesn't pause loading stage1
20:20:36 <ennael> yep
20:20:42 <ennael> press esc and enter it
20:20:46 <MrsB> yep
20:20:53 <MrsB> another job for morning
20:21:16 <MrsB> was there any progress on 64bit graphic corruption, vga=787 thing
20:21:55 <MrsB> https://bugs.mageia.org/show_bug.cgi?id=15253
20:21:58 <[mbot> [ Bug 15253 5b3: Display corruption once the cursor moves (64bit is KO, 32bit is OK) with 16bpp & 24bpp (OK with 15bpp) ]
20:22:41 <ennael> just added a message for tv
20:23:08 <MrsB> Is colin away at the moment?
20:23:26 <ennael> I guess I've seen a message elsewhere indeed
20:23:30 <ennael> for the week :/
20:23:40 <MrsB> eek! is that allowed :D
20:23:51 <tmb> MrsB, can you reproduce it with boot.iso ?
20:24:07 <MrsB> I'll try that in the morning too tmb
20:24:25 <tmb> MrsB, Do you have a local mirror ?
20:24:37 <MrsB> #action MrsB Follow up bug  15350 (upgrades)
20:24:50 <MrsB> #action MrsB Follow up bug 15253 (corruption)
20:25:00 <MrsB> an http mirror on the lan
20:26:26 <tmb> MrsB, ok, I will rebuild a stage2 with a potential fix for it and let ou know where to download it so you can put it on the local mirror
20:26:41 <MrsB> ok sure, I can do that
20:27:58 <ennael> great ! tmb, what is this fix about?
20:29:43 <tmb> ennael, I'm suspecting the patch in fbdev driver switching to 32bit if it detects only 8bit
20:30:10 <ennael> erf
20:30:42 <tmb> (it's done for some hw that misidintifies itself as 8bit even if it supports more
20:30:58 <tmb> for example some matrox cards
20:31:34 <tmb> as Gnome is not happy about pseudo color
20:31:58 <ennael> ok so let's cross fingers for that one
20:32:09 <tmb> but before I revert it I want MrsB to test if it really is that one
20:32:16 <MrsB> seems to be affecting both nvidia340 and the nvidia304 cards
20:32:25 <ennael> about the bugs assigned to you, any information?
20:33:59 <tmb> if you mean for me, then no :/ my $dayjob has kept be busy this whole weekend and today, so not much done... will review the stuff tomorrow
20:34:07 <ennael> ok
20:34:39 <ennael> https://bugs.mageia.org/show_bug.cgi?id=12079 all fixed. ok to close it.
20:34:40 <ennael> ?
20:34:41 <[mbot> [ Bug 12079 [TRACKER]: kde related bugs ]
20:35:28 <MrsB> we're not at Final yet so there is still time, just not much of it. RC will be widely tested & also reviewed most likely so we need it close to right but not perfect yet
20:36:21 <MrsB> close the tracker yes sure, we can probably even bring everything onto the main release blocker tracker now
20:36:37 <MrsB> 14069
20:37:07 <Akien> back in a minute
20:37:21 <ennael> MrsB: ?
20:37:43 <MrsB> we have trackers for other areas too don't we
20:37:51 <ennael> yep
20:38:07 <ennael> so close them all and keep only 14069
20:38:10 <ennael> for a better view
20:38:12 <ennael> ?
20:38:15 <MrsB> could close those and add all the remaining bugs to the main tracker, yes thats it
20:38:31 <ennael> ok :)
20:38:47 <MrsB> let's be optimistic we won't need them
20:39:21 <tmb> we can "fix" them the m$ way... it's not a bug... its a feature...
20:39:24 <ennael> the list is quite messy
20:39:39 <ennael> tmb: good idea :)
20:40:00 <MrsB> well it's served them well enough
20:40:15 <MrsB> course they pay huge amounts to Pr PEOPLE
20:40:15 <DavidWHodgins> lol
20:40:18 <MrsB> pr
20:40:29 <MrsB> PR even
20:43:04 <ennael> tmb: can we stop all pushes soon except those who may fix release critical bugs?
20:43:22 <MrsB> one easy fix  - hexchat
20:43:42 <MrsB> https://bugs.mageia.org/show_bug.cgi?id=15399
20:43:44 <[mbot> [ Bug 15399 Include hexchat in DE installs from classic ISO where no IRC client is provided - needed by mageiawelcome ]
20:43:51 <DavidWHodgins> ennael: We should still let in critical security updates.
20:44:03 <ennael> DavidWHodgins: yep I did not close the tracker for now
20:46:04 <ennael> ok cleaning done
20:46:28 <tmb> ennael, yes, I think we should do so..
20:46:36 <Akien> oops, I was a bit too quick at adding some of the non-fixed issues of the closed trackers to the release_critical tracker, I'll revert
20:46:58 <ennael> will avoid errors like the one on lxde-common... :)
20:49:12 <ennael> ok any other comments ?
20:49:52 <DavidWHodgins> Nothing else here.
20:50:06 <MrsB> synergy update should be pushed into mga4 before mga5 release Akien
20:50:50 <Akien> So release_blocker
20:51:10 <MrsB> preferably, it's an upgrade issue
20:51:17 <Akien> Done
20:51:27 <MrsB> also /etc/shadow perms is relevant in mga5
20:52:15 <MrsB> and the medias one
20:52:28 <MrsB> 3rd party sources
20:52:58 <MrsB> one tracker let's at least keep the related bugs
20:53:12 <MrsB> ^if we're moving to
20:53:22 * MrsB turns off touchpad
20:53:32 <DavidWHodgins> :-)
20:53:56 <ennael> :)
20:54:07 <Akien> The 3rd party sources one is not release critical IMO
20:54:22 <ennael> agree on this one
20:54:43 <Akien> It's not a broken feature that users would expect, it's just a nice improvement now that users are starting to use Google repos that contain important security updates
20:55:09 <Akien> If we don't have this improvement for mga5, so be it :)
20:55:12 <DavidWHodgins> Agreed, provided we warn people to save /etc/urpmi/urpmi.cfg prior to upgrading, to make it easier to readd third party sources. That should be in release notes, I think.
20:55:19 <MrsB> i don't mind either way, just not a unilateral decision
20:55:19 <tmb> yep, it's been with us since the beginning, so it's an enhancement
20:55:50 <MrsB> wasn't anaselli doing somethign with that one?
20:57:07 <ennael> nothing in release notes
20:57:08 <Akien> He proposed a patch to backup /etc/urpmi/urpmi.cfg, but it seems it did not work
20:58:01 <ennael> what about adding something in notes and keep this bug as an enhancement for Mageia 6
20:58:14 <tmb> well, subtle changes to installer at this point may end up breaking more than expexted
20:58:22 <MrsB> sure yeah
20:58:58 <ennael> who wants to write it?
20:58:59 <tmb> as shown with draklive breakage...
20:59:24 <MrsB> Dave dude
20:59:33 <DavidWHodgins> Sure.
20:59:36 <ennael> thanks
20:59:49 <ennael> DavidWHodgins: can you add it on the bug and decrease priority ?
21:00:38 <DavidWHodgins> What's the bug number for that one?
21:00:57 <MrsB> https://bugs.mageia.org/show_bug.cgi?id=14980
21:00:59 <[mbot> [ Bug 14980 installer removes third-party sources/media from urpmi.cfg when upgrading ]
21:03:11 <MrsB> all done then i think
21:03:35 <Akien> Did you discuss https://bugs.mageia.org/show_bug.cgi?id=14520 ?
21:03:37 <[mbot> [ Bug 14520 Outdated ldconfig cache resulting in "Oh no! Something has gone wrong" in GNOME (liveDVD with xdriver=...) ]
21:03:42 <ennael> nope
21:04:12 <DavidWHodgins> release notes updated, to advise people using 3rd party repos to include urpmi.cfg in the files being backed up.
21:04:25 <ennael> thanks DavidWHodgins
21:08:04 <DavidWHodgins> bug 14980 severity lowered to enhancement, with comment added.
21:10:05 <MrsB> Shall we finish?
21:10:27 <ennael> postgresql is in progress btw
21:10:42 <ennael> MrsB suggestiopn should be the one applied
21:11:10 <tmb> for the ldconfig thing, I wonder if we are missing a call to it after uninstalling the nonfree drivers that does not apply
21:11:16 <MrsB> that'll haf the work testing updates for it, only 8 separate tests
21:11:19 <MrsB> half
21:11:50 <ennael> yep
21:12:27 <tmb> kernel-rt, kernel-vserver + util-vserver are nuked from the repos.... I will still need to upload kernel-tmb-3.19 wich scales tmb series down to a single -desktop flavour
21:12:44 <MrsB> that'll really help too
21:12:44 <DavidWHodgins> Nice!
21:13:07 <MrsB> i'll miss them, in a weird kind of way
21:13:21 <ennael> :)
21:13:27 <tmb> MrsB, oh, I can bring them back :)
21:13:30 <DavidWHodgins> tmb: How does that affect upgrading from a Mageia 4 system, with one of the nuked kernels?
21:13:31 <MrsB> no no
21:13:41 <Akien> DavidWHodgins: Good question
21:13:56 <ennael> tmb: MrsB has no humor on this kind of topic :)
21:14:06 <DavidWHodgins> :-)
21:14:12 * MrsB dreads kernel updates
21:14:31 <tmb> DavidWHodgins, well, -rt and -vserver users will get stuck on 3.14 series from mga4 (wich should still work without problems)
21:14:54 <MrsB> we'll need to test that then
21:15:44 <ennael> ok more inputs?
21:16:00 <DavidWHodgins> I think that's about it, for now.
21:16:13 <tmb> kernel-tmb-desktop-latest will obsolete the laptop/server variants
21:16:13 <MrsB> #action QA test upgrades with kernel-rt kernel-vserver and kernel-tmb's
21:16:28 <Akien> I think we can decrease priority for https://bugs.mageia.org/show_bug.cgi?id=3723
21:16:30 <[mbot> [ Bug 3723 locale needed for country settings get lost in liveDVD / liveCD install ]
21:16:55 <Akien> It has been there for a while it's not a show-stopper, so I don't expect it to be fixed for mga5
21:17:07 <tmb> MrsB, well, nothing will really happend... the kernel that booted before the upgrade will still boot after the upgrade :)
21:17:09 <Akien> s/while/while and/
21:17:26 <MrsB> yeah we should make sure it does boot though
21:21:21 <DavidWHodgins> Akien: Agreed. it should not be a release blocker, as it's been there since Mageia 2, though we do need to ensure it gets fixed early in Mageia 6.
21:21:45 <Akien> DavidWHodgins: Yeah, it's an annoying bug that we need to get rid of
21:22:49 <tmb> a "quick fix" would be to leave all locales on the system :)
21:24:00 <DavidWHodgins> That would work, but would probably annoy more people then the bug affects.
21:25:01 <tmb> or just put in errata for those annoyed to "unselect" "remove locales"
21:25:37 <DavidWHodgins> Hmm. Just noticed that the livecd-kde4 is 702 MB. That's too large for some cd burners.
21:26:05 <DavidWHodgins> Gome is ok, at 693MB.
21:26:58 <tmb> DavidWHodgins, yeah, it really is within official limits, but I will drop some not needed firmwares to gain some space...
21:27:17 <ennael> (removing kernel will be more efficient)
21:27:18 <DavidWHodgins> I think k3b will reject anything over 700.
21:27:25 <DavidWHodgins> lol
21:27:52 <tmb> the downside with going to vlc-2.2... it made a lot of qt5 stuff land on the iso :(
21:28:03 <MrsB> kleopatra can go
21:29:25 <tmb> and ceasar too... :)
21:29:30 <MrsB> :D
21:29:48 <tmb> caesar that is...
21:29:50 <ennael> outch time to end meeting ? :)
21:30:25 <tmb> yeah, I'm so tired  I'm already sleeping... it's just my fingers working anymore...
21:30:57 <ennael> ok let's go back to real life or release hell
21:31:02 <DavidWHodgins> Yep. Let's end this for now. Mailing lists can be used till next meeting.
21:31:09 <ennael> thanks all for attending
21:31:09 <MrsB> Thanks all
21:31:16 <ennael> was a good one
21:31:23 <ennael> #endmeeting