19:34:46 <ennael> #startmeeting
19:34:46 <Inigo_Montoya`> Meeting started Mon Oct 7 19:34:46 2013 UTC. The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:34:46 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:35:01 <ennael> hi all thanks for attending
19:35:22 <sebsebseb> hi
19:35:27 <DavidWHodgins> HiYa
19:35:33 <tmb> hi
19:36:37 <malo> Hi all
19:36:47 <ennael> #topic Things to happen until first beta release
19:38:12 <ennael> so alpha 3 is now out and next one is beta 1
19:38:28 <ennael> we have some important steps until then to make it successfull
19:39:25 <ennael> things like version freeze, rebuild, artwork integration
19:39:46 <ennael> so maybe start with one of them to review pending tasks
19:39:53 <ennael> what about artwork ?
19:41:53 <trishf42> We've got some entries, but not really enough to do the whole job. Time for a nother call-out, I think
19:42:09 <trishf42> Also, do we need the installer texts by beta 1?
19:42:18 <MrsB> Do you think it would be worth approaching somewhere like deviantart with that, see if they'd be willing to host a competition
19:42:23 <ennael> is it about official artwork or additionnal one
19:42:24 <ennael> .
19:42:30 <trishf42> sounds like a plan, MrsB!
19:43:12 <trishf42> both, really - I haven't heard from Schultz about the official stuff, but the additional backgrounds are a bit thin on the ground
19:43:18 <MrsB> maybe a small cash prize/goodies and the honour of being the official mageia artwork for mageia 4
19:43:24 <trishf42> I'll get onto the list about it today
19:47:02 <ennael> just saw your mail trishf42
19:47:23 <ennael> maybe not all ready for beta 1 but at least choose the final one to avoid last minute integration
19:47:51 <trishf42> okay, I'll talk more about it with Schultz.
19:48:12 <ennael> thanks :)
19:48:38 <trishf42> so, when do we need to have the installer texts/artwork ready?
19:48:39 <ennael> we will have also version freeze before beta1 together with full rebuild of the distribution
19:48:43 <ennael> oups
19:49:01 <ennael> trishf42: it would be nice to have all of them for beta2
19:49:12 <trishf42> okay, np
19:49:34 <ennael> tmb: anything planned for full rebuild?
19:51:07 <malo> ennael: there is quite a lot of breakage in current cauldron
19:52:02 <MrsB> hardware breakage too at the moment
19:52:09 <malo> ennael: last test by pascal terjan showed over 1000 packages which do not rebuild
19:52:22 <DavidWHodgins> Ouch
19:52:27 <ennael> nice...
19:52:34 <ennael> so maybe start with solving this before
19:53:40 <malo> ennael: I'm responsible of breaking 100 of them for messing with texlive ;-) so let's say that we are working on it :-P
19:53:59 * MrsB slaps malo for breaking stuff
19:54:12 <ennael> :)
19:54:14 <malo> hopefully it's just a few of these to fix and get back to a reasonable situation
19:54:23 <ennael> well better break it now than later
19:54:30 <ennael> ok
19:54:32 <philippem> same for python
19:54:51 <tmb> yep, rebuild will show the real mess :)
19:55:02 <DavidWHodgins> What about the network renaming? WIll that be backed out?
19:56:35 <MrsB> it's working mostly now isn't it?
19:56:58 <ennael> malo: can we sum up then all the mess in progress just to have a clear view before full rebuild ?
19:57:01 <tmb> I'll check with colin & tv where we are...
19:57:29 <DavidWHodgins> If the installer can not be fixed to handle it by beta 1, I think it should be backed out for it.
19:58:00 <MrsB> the decision should definitely be made earlier rather than later
19:58:14 <tmb> yeah, we need to decide what to to and soon
19:58:44 <DavidWHodgins> Same with boot.iso and boot-nonfree.iso
19:58:52 <malo> ennael: yep
19:59:53 <ennael> malo: also I will sum up pending features to be done (or not) before beta1
20:00:23 <tmb> well, boot iso & the installer is intended to use udev in stage1 wich will affect the network naming too
20:00:49 <ennael> MrsB and leuhmanu : could we start also work on releas_critical bugs list?
20:01:07 <MrsB> lots :D
20:01:20 <ennael> 26 in my list for now
20:01:43 <leuhmanu> what does it mean "start work" ?
20:02:00 <ennael> rather than waiting for last month
20:02:12 <ennael> meaning regular mail on -dev and during meetings
20:02:14 <DavidWHodgins> Get the list, and contact the maintainers to ensure they are working on them
20:02:16 <MrsB> I think reviewing and making sure everything is set as desired
20:02:17 <malo> leuhmanu: means raising attention :-)
20:02:25 <ennael> and matches
20:02:41 <DavidWHodgins> propane torch! :-)
20:02:45 <ennael> :)
20:02:54 <MrsB> we have to poke and prod to avoid things being left until the last minute this time
20:03:08 <ennael> malo: so I guess a topic for all our coming packagers meetings
20:03:29 <DavidWHodgins> We can't have installer bugs left till after rc, like what happened with Mageia 3.
20:03:52 <leuhmanu> we agree on that, but it never go such way
20:03:54 <MrsB> yes, the RC needs to be a release candidate
20:04:21 <leuhmanu> I will try, but without warranty
20:04:22 <MrsB> i think it depends on the urgency we inject. It has to be driven a bit
20:04:49 <leuhmanu> for the "drive" I'm certainly not the best person
20:04:56 <MrsB> also needs to come from team leaders too
20:05:11 <DavidWHodgins> Make it clear, the features will be backed out, if not ready.
20:05:30 <ennael> features are one thing, release critical bugs are others
20:05:41 <ennael> both have to be managed on time
20:05:55 <DavidWHodgins> I'm thinking of features that are causing rc bugs, such as the network renaming.
20:06:12 <MrsB> maybe weekly dev mails about them ennael?
20:06:21 <ennael> yep
20:06:29 <leuhmanu> no new feature should come until 15 octobre anyway (iirc)
20:06:44 <leuhmanu> so if I saw something i ASK FOR REVERT ?
20:06:47 <leuhmanu> oups
20:07:39 <DavidWHodgins> When is gnome expected to become stable? It's currently got a lot of problems.
20:08:07 <MrsB> there was talk of bringing DE maintainers together to work on stuff
20:08:15 <sebsebseb> DavidWHodgins: 3.10.0 was releaed the other week. one more bug fix release coming up I guess
20:08:20 <ennael> yep it's still to be organized
20:08:35 <sebsebseb> DavidWHodgins: I think Beta 1 is meant to get the final 3.10 GNOME verison
20:08:36 <ennael> will try to plan this through an email this week
20:08:46 <tmb> it pretends to be stable as of 3.10, but reality is not so
20:09:03 <tmb> alpha3 aleady have 3.10
20:09:12 <MrsB> it's approximately 3 weeks until we start building beta1
20:09:13 <sebsebseb> they do a bug fix release after the point 0 though, maybe more than one even if neasrey
20:09:29 <sebsebseb> tmb: yes, but not the bug fix release that I assume is coming up
20:09:42 <sebsebseb> 3.10.1
20:10:00 <tmb> sebsebseb: we know that, but it will take them until .3 or so to get to real quality status
20:10:28 <sebsebseb> I think only a point 1 is planned, anyway continue
20:10:37 <ennael> so a question to follow carefully the coming updates
20:11:01 <leuhmanu> ok
20:11:14 <tmb> and we need to be more strict on freeze push requests
20:12:11 <MrsB> we have to keep everybody on-side aswell so we'll need to communicate well the reasoning behind all this
20:12:58 <ennael> #action plan an email about version freeze reexplaining all the rules and why it's important to be rather strict
20:12:59 <DavidWHodgins> Agreed. We have to make it clear that we are pushing, because we can't be late this time, due to fosdem.
20:13:33 <ennael> #action plan an email about pending features to check what is finalized and what we may revert (if needed)
20:13:43 <MrsB> not just that but to ensure stability when it's supposed to be stable etc
20:13:53 <sebsebseb> MrsB: yep
20:14:08 <ennael> #action start working on release critical bugs with regular review implying packagers, triage and QA
20:14:30 <ennael> #action plan an email about current breakages that should be fixed before mass rebuild
20:14:48 <MrsB> I'll mention in QA meeting to try and make sure people are responding quickly to any extra info needed with bugs we've created
20:15:22 <MrsB> i think we do pretty well though in general
20:15:56 <ennael> #action final artwork should be all ready for beta 2 release the latest
20:16:19 <trishf42> Schultz: see that action, that's you
20:16:30 <sebsebseb> trishf42: hehheh :d
20:16:43 <trishf42> (talking to him in another window)
20:16:58 <sebsebseb> oh ok
20:17:11 <Schultz> yeah, you know what Douglas Adams says about deadlines....
20:17:36 <ennael> anything else we should add for this topic ?
20:17:41 <trishf42> If you can substantiate that DA actually said it, there's a bloke who wants to know
20:18:19 <leuhmanu> (if no satisfied artwork is here ?)
20:18:40 <trishf42> It'll be here!
20:18:41 <DavidWHodgins> Stick with the Mageia 3 artwork, then.
20:18:41 <ennael> leuhmanu: we have some contacts also to ping
20:19:24 <sebsebseb> DavidWHodgins: hopefully not :)
20:19:36 <DavidWHodgins> worst case
20:20:31 <ennael> anything else we should add for this topic ?
20:20:46 <DavidWHodgins> Nothing else here.
20:20:56 <leuhmanu> (ok fine, but remember the planning beta-rc less than 3 weeks)
20:20:58 <trishf42> not from us
20:21:40 <Schultz> nope good from me
20:22:50 <Schultz> actually, how do we go about creating accounts in places like deviant art/flickr for mageia, so far i have just used my own email, do we have a mageia address we can use?
20:23:28 <trishf42> On that, we need a couple of atelier people to have @mageia.org accounts so we can use git/svn
20:23:37 <trishf42> Was going to bring that up in team review
20:24:10 <trishf42> if that gets satisfied, we'll have an account to use for mageia accounts on deviantart and flickr etc
20:24:12 <MrsB> you should have schultz@mageia.org
20:24:27 <DavidWHodgins> Everyone on the council has an @mageia.org address, if I understand correctly.
20:24:30 <MrsB> and trishf42@ if that's your id trish
20:24:50 <MrsB> it redirects to your registered email
20:24:50 <trishf42> well, maybe we do and maybe we don't - nobody's ever told us!
20:25:04 <DavidWHodgins> ☺
20:25:09 <ennael> ok next topic then :)
20:25:25 <Schultz> ah ok, that wasnt what I was meaning as that email is still only accessed by me, having a centralised account would be great
20:25:35 <sebsebseb> and average Mageian's can't just get them either f they want or not but that's off tpic, yep next topic
20:25:39 <Schultz> I guess atelier@ would do
20:25:49 <ennael> #topic blog posts
20:26:20 <trishf42> I've pinged coling a couple of times about his post, discussed at last meeting, not yet forthcoming
20:26:31 <MrsB> leuhmanu :)
20:26:36 <trishf42> Treasurer post is still sitting, I think
20:26:41 <ennael> yep
20:26:42 <ennael> https://wiki.mageia.org/en/Blog_articles_planning
20:26:44 <ennael> as a reminder
20:26:51 <ennael> so what about leuhmanu post ?
20:27:14 <MrsB> leuhmanu was looking for a photo
20:27:22 <trishf42> sitting as a draft, waiting for approval
20:27:27 <leuhmanu> ah s**t
20:27:55 <ennael> so can we get that photo and publish the article?
20:28:03 <trishf42> there are 4 drafts waiting
20:28:04 <leuhmanu> I have found an identity, yes will scan it
20:28:10 <ennael> (everybody will discover leuhmanu is a human being
20:28:22 <tmb> ooohh...
20:28:40 <ennael> :)
20:28:48 <trishf42> boklm: can we publish the treasurer post after leuhmanu?
20:28:51 <ennael> tmb: do not laugh it may be your turn soon :)
20:28:53 * tmb wonders about funda interview
20:29:05 * trishf42 applauds
20:29:11 <MrsB> yes!
20:29:29 <ennael> let's add it to the list :)
20:29:33 <trishf42> yes, good idea, if we can just get planet access organised, would be a good post to announce his planet addition
20:30:05 <ennael> also I'm finalizing questions to be sent to bruno cornec as he has also presented mageia to linuxcon in the US
20:30:11 <ennael> (I'm late)
20:30:33 <tmb> another "fork" coming ?
20:30:42 <trishf42> leuhmanu: can you let atelier have the pic, so we know when to publish?
20:31:08 * sebsebseb is planning on peaking about Mageia at OGG Camp in just under two weeks
20:31:25 <ennael> tmb: ?
20:31:40 <trishf42> sebsebseb: write up a post about what happens at OGGcamp and we'll make a post out of it
20:31:51 <sebsebseb> trishf42: yep ok :)
20:32:01 <tmb> ennael: you are "late" :)
20:32:22 <ennael> no I will not participate to such foolish thing a second time :)
20:32:29 <MrsB> lol
20:32:51 <ennael> ok so we have some fuel for the blog
20:32:53 * trishf42 is hearing Monty Python music
20:33:08 <ennael> still needs to hurry for leuhmanu
20:33:15 <leuhmanu> trishf42: ok will cc it to the my thread
20:33:37 <leuhmanu> hey the scanner is not in the kitcheen
20:33:37 <trishf42> leuhmanu: thanks!
20:33:56 <leuhmanu> -e
20:34:14 * trishf42 is getting more tea, brb
20:34:34 <boklm> trishf42: for treasurer post I think we need to have updated accounts before we publish it
20:35:07 <ennael> great so a question of time
20:37:55 <trishf42> boklm: still needing to get svn access working
20:39:51 <boklm> trishf42: you should have access
20:40:10 <trishf42> ok, need to ping you for some help
20:40:12 <boklm> ok
20:40:15 <ennael> anything else on blog topic?
20:41:17 <trishf42> not just at the moment...
20:41:23 <ennael> ok :)
20:42:04 <doktor5000> maybe chocolate en bloc? nope, that was something different :p
20:42:29 <ennael> :)
20:42:34 <ennael> #topic syncing teams work for end of the release
20:42:56 <ennael> this is an opened topic about things we should solve to help finalizing Mageia 4
20:46:15 <MrsB> Is there a way to ensure we don't have the same issues with final release, soem lint check we can introduce maybe?
20:47:11 <ennael> ?
20:47:37 <MrsB> the devel/official setting for the medias
20:48:34 <MrsB> bit off topic maybe, sorry
20:48:52 <DavidWHodgins> I forget, which file was it that still had devel instead of official?
20:49:29 <MrsB> i was trying to remember too
20:49:37 <ennael> in bcd configuration. I'm working on a check list to add on wiki so that it does not happen anymore
20:50:10 <tmb> well, we'll need to clean repo and check it before doing final iso build, so it's sysadm <-> isobuilders teamwork :)
20:50:20 <MrsB> that's a good solution too yeah, we're usually pretty worn out by that time so somethign foolproof
20:50:23 <ennael> also yes :)
20:50:54 <tmb> and the file is product.id
20:51:32 <ennael> but also bcd one. it just means we need to finalize this check list properly
20:51:35 <MrsB> That was on the installed system wasn't it, but it was the media config on the iso itself
20:51:58 <MrsB> i can't remember exactly now
20:52:35 <ennael> devel / official paramter in bcd configuration that points media
20:53:39 <MrsB> as long as you've something you can work with, thats fine
20:54:31 <ennael> yep
20:55:02 <MrsB> it was a bit off topic though, sorry
20:55:03 <tmb> but some of the issues was simply due to too much happening between rc and release, something we want to avoid this time
20:55:41 <ennael> yep
20:55:52 <ennael> so anthing else we should speak about?
20:56:05 <sebsebseb> right, but early versoin freeze etc, so about three months bug fixing I guess then really
20:57:15 <sebsebseb> in tho topic or in general>
20:59:18 <tmb> well, we need packagers to focus on stability and bugfixing, wich is hard as many just want to work on "next big thing"...
20:59:51 <ennael> yep a big point indeed
20:59:51 <DavidWHodgins> I think that's partly because they expect the next version to fix the old bugs.
21:00:32 <MrsB> some truth there i think. Update it and see what's still brooken
21:00:39 <tmb> yep, and just "hope it wont introduce any regressions"
21:02:10 <MrsB> well it falls on us as team leaders to guide and motivate
21:04:45 <tmb> "matches for all..."
21:04:55 <MrsB> :D
21:05:58 <MrsB> was there anything else?
21:06:03 * MrsB bedtime
21:06:24 <DavidWHodgins> Nothing else here, that I can think of right now.
21:06:44 <tmb> nothing else here for now either...
21:06:48 <Schultz> nothing from me
21:07:09 <trishf42> I've got a couple of followups, but I can do them with sysadmin team
21:08:45 <ennael> ok we can speak further about that point on ML before next meeting
21:10:37 <MrsB> shall we close?
21:10:49 <ennael> ok let's close the meeting before everybody fell asleep
21:10:55 <DavidWHodgins> :-)
21:11:01 <ennael> #endmeeting