18:08:09 <misc> #startmeeting
18:08:09 <Inigo_Montoya> Meeting started Fri Oct  8 18:08:09 2010 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:08:09 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:08:18 <misc> #chair misc ennael blino
18:08:18 <Inigo_Montoya> Current chairs: blino ennael misc
18:08:32 <misc> #meetingname Founders
18:08:32 <Inigo_Montoya> The meeting name has been set to 'founders'
18:08:46 <misc> #topic association creation process
18:08:59 <misc> rtp: it is up to you :)
18:09:23 <rtp> ok :)
18:09:56 <rapsys> hu
18:09:58 <boklm> hello
18:10:04 <rapsys> hi
18:10:12 <rtp> so, the association creation process has made quite a lot of progress
18:10:58 <rtp> after some delays (proofreading & things like that), the paper work has been done and given to the french Administration (aka "prefecture de police") \o/
18:11:36 <misc> #info paper have been sent to the french administration
18:12:04 <rtp> this means that, now, we have to wait that our application is processed. This may take up to 4-6 weeks and up to 8 weeks for the official publication
18:13:00 <rtp> so, after this delays we'll have an official existence and we'll be able to create bank account
18:13:19 <misc> #info we need to wait for the application to be processed ( 4 to 6 weeks )
18:14:35 <misc> what about the issue that fredxx found ?
18:14:49 <rtp> Also, on the down side, our preferred french lawyer (Fredxx) had some comments today so we'll probably have to make some small corrections to our status and it'll be proposed in an association assembly :(
18:15:20 <rtp> I won't give all details here but he made some valid remarks
18:15:44 <Nanar> 
18:15:59 <rtp> Nanar: a question ? :)
18:16:11 <Nanar> just showing I am here
18:16:14 <t_m_b> why first today? hasn't he seen the draft ?
18:16:51 <rtp> t_m_b: bad timings
18:17:05 <ennael> also he was very busy these last days
18:17:10 <misc> well, i guess he didn't found before, like we do not see all bugs at the first time :)
18:17:21 <rtp> if I understood corrrectly he has been busy a lot
18:18:08 <misc> couldn't we send the correction to the administration before they process it ?
18:18:38 <rtp> misc: it may also be due to our last changes. Anyway, we should try to blame someone but rather go forward and try to fix where neede
18:18:42 <rtp> d
18:18:47 <rtp> +not
18:18:57 <rtp> oops ... I ate a word /o\
18:19:08 <rtp> misc: no, too late
18:19:13 <fcrozat> it is always possible to change them later
18:19:37 <rtp> fcrozat: exactly. that's why I talked about making an assembly (A.G.E.)
18:19:38 <fcrozat> it will "just" require a new publication on "journal officiel" (official log)
18:20:01 <misc> rtp: general extraordinary assembly ?
18:20:05 <rtp> fcrozat: not "just". afaik status modifications needs an AGE
18:20:07 <rtp> misc: yeah
18:20:18 <ennael> also we need it to be created quickly as it's needed for bank account, hosting solutions...
18:20:22 <misc> yup
18:20:41 <fcrozat> rtp: well, for now, going a assembly won't be difficult ;)
18:21:09 <misc> and in any case, we have to wait 1 or 2 months for this general assembly, no ?
18:21:27 <misc> ( 1 or 2 month for now, ie wait until the administration say "ok" )
18:21:45 <rtp> fcrozat: hmm... I don't know. we need to know first what should be changed and then there are some legal delays before convocation.Also, creation needs to be done first :)
18:22:16 <fcrozat> rtp: I just hope you allowed "electronic"  assembly ;)
18:22:21 <fcrozat> in the status
18:22:49 <pterjan> a big Christmas assembly physical meeting ? :)
18:23:20 <fcrozat> maybe it is too late, anyway : http://www.gnomefr.org/association/statuts/
18:23:29 <fcrozat> but if it can be useful..
18:23:37 <fcrozat> http://www.gnomefr.org/association/reglement/ too
18:23:38 <ennael> fcrozat: it's included indeed
18:24:01 <fcrozat> ennael: excellent
18:24:09 <erwan_taf> fcrozat: _o/
18:24:16 <misc> rtp: anything to add ?
18:24:35 <misc> ( or we can go on the next topic )
18:24:36 <rtp> pterjan: at least we hope to have a physical meeting in fosdem :)
18:24:42 <rtp> misc: it's ok for me
18:24:55 <misc> good
18:25:01 <misc> ok for everybody ?
18:25:11 <pterjan> rtp: oh yes I should buy eurostar ticket soonm it opens 4 months before :)
18:25:11 <ennael> ok
18:25:13 <fcrozat> ok for me
18:25:16 <misc> #topic pandora board
18:25:20 <misc> blino: up to you
18:25:21 <rtp> pterjan: mouarf
18:25:57 <ennael> misc: if blino is not around rtp can also speak about this :)
18:26:08 <blino> I am here
18:26:12 <ennael> oups
18:26:15 <rtp> :)
18:26:25 <blino> ok, so the Pandaboard is an ARM board using the TI OMAP4 processor
18:26:46 <rtp> #url pandaboard.org
18:26:59 <misc> #link http://pandaboard.org/
18:27:03 <blino> they recently offered boards for some projects
18:27:13 <blino> so I registered Mageia there, in the hope we get selected
18:27:25 <misc> #info the Pandaboard is an ARM board using the TI OMAP4 processor, and they offer some to some project
18:27:28 <blino> #link http://www.omappedia.org/wiki/PEAP_Projects#Mageia_support
18:27:53 <blino> this will likely not be used for build system
18:28:02 <blino> but it is a good platform to consolidate our ARM support
18:28:09 <blino> and do some multimedia demos
18:28:36 <misc> why not for the BS ?
18:28:42 <blino> it's a dual-core 1GHz Cortex-A9 processor
18:28:51 <blino> but it lacks some decent way to plug local storage
18:28:57 <blino> see http://www.omappedia.org/wiki/File:PandaBoard_Setup.png
18:28:57 <rtp> misc: not possible to connect a  hard drive
18:29:54 <Nanar> is there oter possible storage ?
18:29:56 <blino> rtp suggested to test network storage like nbd
18:30:10 <misc> rtp: usb
18:30:26 <blino> or SD
18:30:29 <misc> ok
18:30:36 <rtp> usb is not a good idea imho
18:30:53 <misc> well, when will they give us a answer ?
18:30:59 <blino> they will have 2 phases of projects selection
18:31:10 <blingme> nfs with caching ?
18:31:16 <blino> first round with results on oct 11, second on oct 25
18:31:18 <rtp> fwiw, our friends at genesi are using nbd for the debian armhf port
18:31:36 <blingme> iscsi ?
18:31:54 <blino> rtp: BTW, maybe you could ask genesi/efikamx guys for a TO3 board now that Mageia is public
18:32:07 <misc> #info answer on oct 11 and oct 25
18:32:27 <blingme> what are the ideas for ARM?
18:32:29 <misc> #action rtp ask genesi/efikamx for a TO3 board
18:32:43 <rtp> blino: iirc, nfs may introduce some bugs with some apps "make test"
18:32:52 <blingme> E.g., do we intend to be able to run on Nokia N900 ?
18:33:17 <blino> blingme: not phone in a first time, Mageia would be more suited to tablets and smartbooks
18:33:32 <blino> like the AlwaysInnovating Touchbook, or the Genesi Smartbook
18:33:49 <rtp> blingme: it's omap3 and phone. this makes 2 "annoying" problems
18:34:16 <misc> blino: so anything to add on the pandaboard topic ?
18:34:21 <rtp> aka we don't have support for phone and omap3
18:34:45 <misc> ( not that I want to interrupt the discussion and be impolite )
18:35:47 * misc wonder if speaking of arm would be a good discussion to replace the one about browser and releases on -dev
18:36:00 <ennael> :))
18:36:02 <rtp> misc: no side tracking please :)
18:36:19 <ennael> misc: we could ask rtp to manage this :)
18:36:48 <ennael> anything else on that topic ?
18:37:08 * misc guess not but wait on blino
18:37:53 <blino> no, that's finished for me (sorry for the lag)
18:37:57 <misc> no problem
18:38:00 <misc> #topic epoll
18:38:12 <misc> Nanar: up to you
18:38:31 <Nanar> Epoll v2 has been massively review, fixed, and translated
18:38:54 <Nanar> except in some useless plugins, no french remains
18:39:14 <Nanar> it has been translated in french and german
18:39:20 <Nanar> #link http://forge.ipsl.jussieu.fr/epoll/demotrunk/
18:39:32 <Nanar> here the link to v2 for testing purpose
18:39:42 <misc> #info epoll v2 has been reviewed, tested and translated in french and german ( and soon in italian )
18:40:01 <Nanar> no news about italian at time
18:40:29 <Nanar> for me, the soft is ready to use
18:40:38 <Nanar> and soon ready to release
18:40:40 <misc> is there a official release :) ?
18:40:58 <Nanar> not yet, but make rpm works
18:41:31 <misc> ennael: so, when do we want to have a server ready ?
18:41:50 <Nanar> but test welcome to ensure we miss nothing
18:42:00 <ennael> well would be nice for beginning of next week
18:42:22 <misc> i can do it so
18:42:36 <Nanar> just generated this: Epoll-1.90-1mdv2011.0.noarch.rpm
18:42:41 <misc> #action misc install epoll on mageia server for beginning of next week
18:43:30 <ennael> Nanar: does it need more testing ?
18:43:42 <blingme> Nanar: is it possible to have a web designer look at it?
18:43:55 <blingme> It does look a bit "functional" ...
18:44:06 <blingme> (ie, not pretty)
18:44:11 <ennael> blingme: you don't like Nanar pure design? :)
18:44:22 <Nanar> ennael: I don't think, but more test are always welcome
18:44:26 <misc> blingme: i started looking at it ( i am no web designer, but I was working in HCI ), but we wanted to not change it too much before release
18:44:32 <blingme> ennael: I won't criticise, as I can't do any better ....
18:44:33 <Nanar> blingme: everything is welcome
18:44:53 <Nanar> blingme: I am good to do Web App, not to design HTML
18:44:54 <misc> ( so we focused on tests and translations )
18:45:52 <Nanar> misc is true, some change in template can break it, so avoiding massive changes ensure to not break it
18:46:13 <blingme> Nanar: indeed, but I was wondering if someone who has a bit of design experience could look at the templaet
18:46:17 <Nanar> the goal was to have it ready to works
18:46:53 <misc> i guess we could ask help to the web team after the first batch of poll
18:46:59 <Nanar> blingme: but any help is appreciate for later version
18:47:06 <blingme> It is unclear what the dropdown and the "Submit Query" button next to it do ....
18:47:23 <misc> this could be changed easyly, i wanted to do it too
18:47:51 <blingme> maybe change the button text to "Change Language"?
18:48:05 <misc> yup
18:48:14 * misc will do after the meeting
18:48:23 <blingme> any further feedback I have I will send by mail
18:48:26 * blingme stops sidetracking misc
18:48:32 <Nanar> :)
18:48:33 <misc> :)
18:48:45 <Nanar> ah notice
18:48:45 <misc> anyway, on epoll, Nanar , ennael anything to add ?
18:48:51 <ennael> nope
18:48:56 <Nanar> The version on forge.ipsl can be used
18:49:07 <ennael> maybe plan to ask webteam to have a look on it ?
18:49:10 <Nanar> I don't plan to remove it
18:49:17 <Nanar> if it can be usefull
18:50:25 <Nanar> was the last point for me
18:50:29 <misc> good
18:50:42 <misc> #topic candidating for hosting by Free foundation
18:50:48 <misc> ennael: up to you
18:50:52 <ennael> yep
18:51:22 <ennael> we have now sent all information needed for applying on Free foundation for hosting
18:51:36 <ennael> we had to send a full description of all servers
18:51:47 <ennael> give some figures about bw
18:52:11 <ennael> and explain who will have to go to datacenter in case of need
18:52:29 <ennael> so now we "just" have to wait for final decision
18:52:38 <ennael> it seems it should not be long
18:52:38 <misc> no ETA ?
18:52:42 <ennael> nope
18:52:56 <misc> #info all informations have been sent, we are waiting on their answer
18:53:04 <misc> #info answer should not be long
18:53:09 <ennael> also as i'm on that topic
18:53:28 <ennael> I spoke with the guys who proposed hosting for mageia official forum
18:53:44 <ennael> the guy is technical manager of Nfrance datacenter in Toulouse
18:54:18 <ennael> they have very good references and focus on open source hosting
18:54:33 <ennael> so we will share a server with MLO
18:54:45 <ennael> and they also proposed to host some other servers if needed
18:55:10 <misc> do he have a name ? ( and is he ok to tell it to us ? )
18:55:20 <ennael> Julien DAL
18:55:26 <ennael> (xkomodor)
18:55:44 <misc> #info ennael spoke with Julien dal ( xkomodor ) about forum hosting
18:55:49 * misc have seen julien at rmll
18:55:54 <ennael> arf :)
18:57:38 <ennael> I guess taht's all for that topic
18:58:16 <misc> good
18:58:29 <misc> #topic ldap directory and tools review
18:58:49 <misc> i guess blingme can speak of this :)
18:58:55 <ennael> yep
18:59:03 <blingme> So, we have briefly tested phpbb with LDAP
18:59:21 <blingme> it works fine, without any real effort
18:59:47 <blingme> I created an "application" account for phpbb (anonymous access to LDAP is very limited, I plan to not allow any real anonymous access)
19:00:00 <blingme> I created an account for maat, which he used after applying the settings I provided
19:00:09 <blingme> I was also able to login to the forum
19:00:35 <blingme> I haven't progressed much with gosa, I installed the Mandriva package, which doesn't work (php too new, gosa too old)
19:00:47 <blingme> I am updating the package now, and will test it further
19:01:03 <misc> #info ldap and phpbb work fine
19:01:04 <blingme> I think it should be able to do all we need (there are some nice plugins)
19:01:11 <misc> #info gosa need to be updated
19:01:53 <blingme> The only issues is that php (trunk) still doesn't have support for controls, so it won't be able to e.g. tell a contributor that their account has been locked out
19:02:10 <blingme> I have a perl CGI for stuff like that
19:02:39 <blingme> Anyway, I will play with gosa a bit on my own machines, and try and get a nice config that does what we need
19:02:56 <blingme> once I have that ... can I go ahead and install on the ldap box? Or should it go somewhere else?
19:03:07 <ennael> I have a question about ldap
19:03:18 <ennael> I will speak later about teams
19:03:29 <ennael> one thing we would like to setup quickly is team ML
19:03:35 <ennael> and switch to Sympa
19:03:46 <neoclust> blingme: for gosa we need to use http://gitweb.kde.org/websites/identity-kde-org.git
19:03:53 <misc> blingme: personnaly, I am not a huge fan of having php on the box with ldap, as php is a security nightmare that should be eradicated with flame thrower, or at least, be kept in some machine
19:03:55 <blingme> ok
19:04:24 <ennael> can we register people on wiki in ldap directory to start with with minimum account?
19:04:24 <blingme> neoclust: I will look at that too, but I also want to play with vanilla gosa
19:04:55 <neoclust> blingme: they added nice features  i think this the version to really use
19:04:59 <misc> ennael: well, if we later need to add information to their account ?
19:05:05 <blingme> ennael: how many ?
19:05:11 <ennael> misc: that's my question
19:05:12 <neoclust> blingme: you can look to the git depo to see the features they have added
19:05:14 <boklm> one problem maybe is that we only have their email address, and we don't know what login name they would like
19:05:29 <ennael> blingme: someting like 9 groups and a total of 250 users
19:05:32 <ennael> something like that
19:05:32 <blingme> misc: well, they should be able to add any personal stuff, for more access, we probably need it vetted
19:06:31 <ennael> sympa can use ldap request to manage registration for a ML
19:06:38 <blingme> misc: is there another machine we could run gosa or similar from ?
19:06:52 <ennael> blingme: we have 2 VMs in Gandi
19:07:03 <blingme> ennael: for that number, it might be best to finish working on something that allows users to register themselves
19:07:15 <ennael> yerk
19:07:17 <boklm> blingme: we would like to make a script to create all the accounts on ldap, and send them a password by email, would that be possible ?
19:07:18 <blingme> for 10-20 or so I am ok
19:07:22 <blingme> ok, so should I put gosa on web1?
19:07:39 <blingme> boklm: sure it's possible, but it's still a bit of work collecting 250 usernames and email addresses
19:08:02 <blingme> (but, if the list can be provided, I can do it)
19:08:10 <boklm> blingme: we have them in text files, but problem is that we only have email address
19:08:10 <ennael> blingme: we have lists already
19:08:13 <ennael> ready to use
19:08:31 <blingme> incl. desired username?
19:08:32 <misc> blingme: i think you should discuss with sysadmin team
19:08:37 <boklm> would they be able to change their username later, if we assign them a random username ?
19:09:03 <blingme> boklm: not on their own at present ...
19:09:21 <blingme> I am not sure if they would be able to change it for themselves in future
19:09:25 <boklm> ok
19:09:35 <blingme> (it can quite easily be done by admin)
19:09:50 <misc> well, if the admin are ok to handle 300 requests :(
19:10:03 <blingme> but if they have used the forum, it's probably a bit more work ....
19:10:14 <boklm> so we have to find an other solution
19:10:23 <misc> so, we need to get username before creating the ml ?
19:10:23 <blingme> how soon do we want to migrate mailing lists to sympa?
19:10:36 <Nanar> I have a question about ldap usage ? can I ?
19:10:42 <blingme> Nanar: sure
19:10:44 <ennael> blingme: well as soon as possible
19:10:56 <misc> ennael: you really hate mailman :)
19:10:57 <ennael> to let teams organize themselves
19:11:05 <blingme> ennael: is Monday or so ok ?
19:11:06 <ennael> misc: guess :)
19:11:10 <ennael> blingme: sure
19:11:35 <dmorgan> hi
19:11:38 <Nanar> Do we want to use ldap for all applications we'll setup ? I mean including Postgres for exemple as soon the app support it ?
19:11:49 <boklm> Nanar: postgres ?
19:11:55 <blingme> ok, I'll try and have something supporting registering by Monday, but will need assistance/approval from sysadmin to get it running
19:12:09 <blingme> Nanar: I think that is for sysadmins to discuss ....
19:12:11 <Nanar> postgres support ldap authentication, yes
19:12:20 <ennael> blingme: ok
19:12:25 <blingme> Nanar: for pg, AFAIK, it supports both LDAP and Kerberps
19:12:27 <boklm> Nanar: do we need users to authenticate on the database ?
19:12:30 <misc> Nanar: only if this make sense, and I think it wouldn't in most use case we will have
19:12:41 <blingme> I would prefer Kerberos for real people
19:12:53 <Nanar> misc: it centralize password
19:12:58 <blingme> database accounts used by applications should probably stay in the database
19:13:12 <Nanar> blingme: both are possible
19:13:25 <blingme> but if e.g. web team needs database access, those should be by LDAP
19:13:31 <blingme> or Kerberos
19:13:41 <Nanar> I am not talking specifically about postgres, postgres is just an exemple that come to me
19:13:46 <misc> well, I will had the postgres possibility in the ldap spec I will finish for monday
19:13:59 <misc> Nanar: we will discuss this after the meeting
19:14:01 <ennael> add ?
19:14:25 <misc> ennael: yeah, i am constantly using had and add in the wrong way :(
19:14:49 * blingme apologises for lag ... 2s latency from home to office
19:15:32 <blingme> is there anything else I should be working on now? mediawiki+LDAP ?
19:15:54 <ennael> yep that one
19:15:58 <blingme> (I do need to document everything further ... which I will try and do over the weekend too)
19:16:04 <ennael> wordpress ?
19:16:15 <misc> i think you should see with the web team
19:16:15 <blingme> wordpress-mu has some LDAP plugin
19:16:32 <blingme> (I think I linked to it on the directory page on the wiki)
19:16:49 <misc> ( and I think some people were against mediawiki, and so it would be nice to at least discuss with the community about what they want before pushig tools :/ )
19:16:57 <blingme> Will we be provided @mageia.org email aliases?
19:17:10 <blingme> misc: mojomojo ?
19:17:29 <boklm> blingme: yes, but maybe not to all users
19:17:31 <rtp> blingme: we need a mail server first and then we may think about mail aliases
19:17:56 <ennael> misc: was just thinking about testing
19:18:02 <blingme> rtp: yes ... but I may need to take it into account for users registering accounts now ...
19:18:25 <blingme> (e.g. populate mailForwardingAddress or similar, not just 'mail')
19:18:27 <misc> ennael: sure, but people may assume that's the real one :)
19:18:47 <Nanar> hum
19:18:54 <blingme> we can always password protect it ...
19:19:16 <Nanar> about ldap, I startedd an ldap plugin for epoll, should I work on it ?
19:19:50 <misc> blingme: there is lots of solution, we just need to be aware, and be ready for a 3 weeks long discussion about the comparative merit of every 50 possibles solution
19:19:51 <Nanar> can it be usefull soon ?
19:19:55 <blingme> Nanar: what does it do? Just authentication?
19:20:06 <Nanar> blingme: fetching mail + auth
19:20:07 <boklm> Nanar: it can be useful later
19:20:08 <misc> it import the list of voters from ldap
19:20:29 <misc> for now, we have csv, but for the next batch of vote, this would be useful, yes
19:20:47 <blingme> Nanar: the Catalys authentication provide for LDAP should do all you need
19:20:57 <blingme> just needs some stuff in your config
19:21:12 <blingme> (for auth)
19:21:31 <Nanar> blingme: it's a bit more due epoll constraint, but it's out off topic :)
19:21:44 <blingme> for pulling voter list, Model::LDAP should make it relatively easy
19:21:55 <blingme> ok
19:22:18 <blingme> Nanar: let me play with epoll a bit before I answer fully (to understand how it works)
19:23:00 <blino> how will the users register in this ldap? will gosa allow to do that automatically?
19:23:01 <misc> the discussion is interessant, out of topic, but interessant, so maybe this could be done on -dev ml ? ( so we could have something less repetitive than browser discussion ) ?
19:23:15 <misc> blino: yes, that's the idea
19:23:31 <misc> like identity.kde.org, like fedora account system, and like lauchpad
19:23:38 <misc> ( if I understood well )
19:24:08 <Nanar> so people register themself
19:24:14 <blingme> blino: yes, the plan is to allow users to register themself
19:24:24 <Nanar> but an admin is need to win power ?
19:24:29 <misc> Nanar: yup
19:24:30 <boklm> Nanar: yes
19:24:37 <blingme> I am not sure if gosa itself will do it, or if I will have to pull some from the git clone KDE uses
19:24:42 <Nanar> works for me
19:25:06 <blingme> by default, user will just be registered as "inetOrgPerson", with username, password, email address, and any other personal details
19:25:06 <misc> speaking of admin, anything to add on ldap, or can we go on the next topic, ie sysadmin ?
19:25:32 <Nanar> could be nice if some people could have some delegation
19:25:32 <blingme> so, access to forum, wiki etc., not much else
19:25:45 <Nanar> but maybe later
19:26:02 <blingme> Nanar: from LDAP side that is no problem, will have to see about providing interface for it
19:26:25 <blingme> misc: nothing from me
19:26:26 <misc> #action see if gosa support delegation of power to change group and so on
19:26:29 <misc> ok
19:26:29 <Nanar> ok
19:26:38 <misc> #topic sysadmin review
19:26:49 <misc> boklm: up to you, if you have finished to eat fries
19:27:24 <boklm> ok, so for sysadmin, we started some discussions on sysadm mailing list
19:27:39 <boklm> we are thinking about using puppet to manage servers configuration
19:27:48 <boklm> and store the configuration on svn
19:28:42 * pterjan has his google mentor a puppetcamp in San Francisco currently
19:28:44 <pterjan> at
19:28:47 <boklm> :)
19:28:48 <blino> boklm: whih sysadm ML? has it been announced somewhere?
19:29:10 <boklm> blino: for now, it is was a private mailing list, but we are thinking about making it pubilc
19:29:12 <misc> we have also discussed about opening archives of the ml, for those that want to read it
19:29:20 <boklm> yes
19:29:24 <misc> blino: in previous episo^W meeting
19:29:32 <misc> but maybe we could be more public
19:29:40 <boklm> yes
19:30:02 <boklm> so we should open archives
19:30:22 <boklm> we are discussing about using a ticket system
19:31:04 <misc> #info sysadmin ml will be public soon
19:31:32 <boklm> and soon we should start to setup first services like dns, or mageia web site
19:31:34 <misc> #info software planned : puppet + svn + ticket system ( either bugzilla or something else, still discussed )
19:31:37 <blino> boklm: why puppet and not cfengine like at Mdv? couldn't we use git too instead of svn?
19:31:59 <misc> blino: cfengine 2 is deprecated, and no one know cfengine 3
19:32:09 <blingme> boklm: besides ticket system, what about inventory, ip address etc.?
19:32:20 <misc> and svn because git hooks are slightly more complex ( imho )
19:32:24 <blingme> (e.g., glpi does all of those, not extremely well)
19:32:41 <misc> ( i tried puppet + git, and despites loving git, I prefered to go back to svn )
19:32:48 <boklm> blingme: we can look at it
19:33:21 <boklm> blingme: what does glpi do ?
19:33:33 <misc> afaik, guillomovitch is a fusion inventory contrib
19:33:34 <blino> misc: boklm : but this means we will have to migrate to puppet all the cfengine config files from the cluster, could be heavier than just migrating to cfgengine3
19:34:08 <Nanar> boklm: glpi hardware / software inventory
19:34:11 <misc> blino: well, the vast majority of cfengine config on the cluster was to be sure that 40 services were not started
19:34:31 <blino> not just this
19:34:38 <blino> and to replicate files from /var/lib/config on the local systems
19:34:48 <boklm> and copy files in some directories
19:34:49 <blino> like local scripts, or ssh public keys
19:35:19 <misc> blino: well, for what it is worth, guillomovitch also plan to migrate zarb to puppet
19:35:21 <boklm> blino: ssh keys ?
19:36:04 <Nanar> boklm: ~root/.ssh/authorized_keys I guess
19:36:14 <blino> no, all packagers ssh pub keys
19:36:18 <boklm> I think ssh keys were not manager by cfengine
19:36:39 <boklm> we had a script in cron to extract ssh keys from ldap
19:36:46 <blino> /var/lib/config/cfengine/cfengine.conf: /var/lib/config/pubkeys                 dest=/var/lib/pubkeys           type=sum recurse=inf ignore=*~ ignore=RCS
19:37:02 <blino> yes, to extract them from ldap, but only on kenobi
19:37:21 <blino> then the keys where copied from kenobi to other nodes, without extracting from ldap again
19:37:28 <misc> well, anyway, we could discuss technologics issue outside f the meeting, i would love to have feedback on this, but that's maybe not the right moment
19:37:37 <boklm> blino: ah ok
19:37:49 <rtp> misc: \o/
19:37:49 <boklm> blino: for copying files like this, I think puppet has the same features
19:38:18 <Nanar> puppet has server for distributing files
19:38:30 * blingme has people waiting for him before starting movie ... will leave if not needed ....
19:38:42 <blino> and cfengine was also used to update files like fstab
19:38:53 <misc> blino: puppet can also do it
19:39:00 <blino> puppet probably has the same features, but we have to make sure we migrate everything
19:39:07 <blino> i.e., pick a lucky guy to do that
19:39:11 <boklm> it looks like puppet has many plugins for various config files
19:39:19 <misc> I guess I will do it
19:39:19 <blingme> I think feature set is quite simialr, but it will eb some work to migrate
19:39:35 <misc> blingme: the mdv config fileis quite simple
19:39:53 <misc> anyway, on the sysadmin review, nothing to add ?
19:40:04 <blino> my point is that we are not so many people in the team, and we don't need more work, so keeping it same way as before can be a good thing too
19:40:08 <Nanar> blingme: I think you can go, good movie :)
19:40:19 <blingme> thanks ... bye
19:41:08 <boklm> blino: yes, but I don't think it's a lot of work, and maybe it can save us time later by using a better tool
19:41:28 <Nanar> puppet is not quite complex
19:41:59 <Nanar> and once first setup are done, I think others things are easy
19:42:19 <blino> just have to find the right balance, spending time migrating if there is no clear benefit, that's not so useful
19:42:32 <Nanar> I succeed to use puppet ! so you will not have problem
19:43:16 <boklm> blino: and maybe it's a good idea anyway to look at all files from mandriva bs, to remove unused ones and do some cleaning
19:43:46 <blino> yep
19:44:47 <misc> well, anything else to add on the review ?
19:44:52 <Nanar> yes
19:44:57 <Nanar> a question
19:45:07 <Nanar> I am in charge off mirror
19:45:25 <Nanar> so I'll probably need root access or root action on the server
19:45:42 <Nanar> I'll have to find my place somewhere in sysadmin team
19:45:49 <Nanar> What is the best ?
19:45:56 <boklm> Nanar: so, maybe you can join sysadmin team
19:46:01 <misc> yup
19:46:06 <misc> come to the dark side
19:46:09 <Nanar> I subscribe to sysadmin ML and discuss about this ?
19:46:25 <Nanar> ok
19:46:29 <boklm> Nanar: I add you to the list
19:46:30 <Nanar> so I come
19:46:35 <Nanar> boklm: thanks
19:46:40 <blino> boklm: can you please add me as well?
19:46:46 <boklm> blino: ok
19:46:54 <misc> #action boklm add blino and nanar as sysadm
19:47:23 <misc> now there is 10 people in the ml, I guess we will be enough to manage the 3 servers
19:47:32 <ennael> :)
19:48:22 <blino> outch, it was a trap!
19:48:24 <misc> anyway, speaking of organisation, can we go on the last topic ?
19:48:33 <ennael> no more sysadmin topic ?
19:48:43 <misc> i do not see anything :)
19:49:20 <boklm> maybe blingme can be part of sysadmin team too (for ldap part) ?
19:49:57 <misc> boklm: well, if we are too much, we will just be ineffective I fear
19:50:22 <boklm> ok
19:50:30 <ennael> would be nice to have ldap expert inside
19:50:32 <misc> when I see the discussion in this meeting, I do not really have much hope about being productive in a team of 11 people to manage ... 8 servers
19:52:00 <Nanar> notice that I enter in sysadmin, but  first step is finding my place
19:52:12 <Nanar> and definig my role :)
19:53:02 <misc> #action boklm discuss with blingme if he want to be in sysadmin team
19:53:13 <misc> anything else to add ?
19:53:22 <boklm> not for me
19:53:45 <misc> #topic start with global organization
19:54:37 <misc> ( yeah, ennael , up to you )
19:54:42 <ennael> oups
19:54:45 <ennael> ok
19:55:08 <ennael> we would like to start team work next week as soon as ML are up
19:55:29 <ennael> we are working on some guidelines about what we wait about organization
19:55:41 <ennael> vote for representative and leaders
19:55:54 <ennael> and fix various internal process
19:56:02 <misc> we == ?
19:56:15 <ennael> I worked on it with romain
19:56:40 <ennael> as soon it looks like readable I will post an url for proof reading and comments
19:57:01 <misc> #info ennael and rda worked on guildeline about organisation, and vote for leader and representative
19:57:27 <ennael> so next week we hope that we will have representatives elected and work started
19:58:37 <ennael> we had some big discussions about words
19:58:45 <ennael> but I guess this should be solved soon
19:59:17 <t_m_b> you mean the master-"slave" on the ml ?
19:59:23 <ennael> yep :)
20:00:09 <t_m_b> people is reading _way_ too much into what someone writes ...
20:00:16 <ennael> sure
20:00:25 <rtp> yeah
20:01:09 * misc had a 3 points explication when he gave his opinion about this
20:01:21 <ennael> add ?
20:01:30 <misc> no, had
20:01:31 <ennael> oh no, had
20:01:57 * Nanar have to go, will read log
20:02:26 <misc> well, anything else to add ( yes, add ) ?
20:02:30 <ennael> :)
20:02:33 <ennael> not for now
20:02:41 <ennael> also planning a blog post
20:02:49 <misc> #info blog post is planned
20:02:54 <ennael> to give a review on what is going on
20:03:00 <ennael> so I will need ahmad78 lights :)
20:03:22 <ennael> and finally I sent an email to Pascal blaser about FOSDEM
20:03:30 <ennael> to ask for a room at least 1/2 day
20:03:38 <ennael> for our first general meeting
20:04:00 <misc> #info fosdem have been contacted for 1st general assembly
20:04:53 <boklm> did you ask for the big amphitheatre ? :)
20:05:10 <ennael> maybe a bit small :)
20:06:57 <misc> nothing to add ?
20:08:04 <misc> guess not
20:08:08 <ennael> nope
20:08:20 <misc> thanks for being there, ready for next week meeting
20:08:25 <misc> #endmeeting