20:01:40 <papoteur> #startmeeting
20:01:40 <Inigo_Montoya> Meeting started Mon Nov  2 20:01:40 2015 UTC.  The chair is papoteur. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:40 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:01:41 <lebarhon> Hi, I am there
20:01:50 <marja> lebarhon: hi :-)
20:02:00 <lebarhon> hi Marja
20:02:01 <papoteur> Hi lebarhon, just in time, fine ;)
20:02:07 <yurchor> lebarhon: Hi!
20:02:13 <papoteur> #chair lebarhon
20:02:13 <Inigo_Montoya> Current chairs: lebarhon papoteur
20:02:14 <lebarhon> a little late, hi papoteur
20:02:15 <marja> yurchor: hi :-)
20:02:25 <papoteur> #chair marja
20:02:25 <Inigo_Montoya> Current chairs: lebarhon marja papoteur
20:02:33 <yurchor> marja: Hi ;)
20:02:36 <papoteur> hi yurchor
20:02:46 <yurchor> papoteur: Hi!
20:03:09 <papoteur> We have some topics today
20:03:31 <lebarhon> hi yurchor
20:03:41 <papoteur> first one:
20:03:43 <papoteur> We should remember to update
20:03:44 <papoteur> http://gitweb.mageia.org/software/i18n/tools/tree/docs/stylesheets/
20:03:45 <[mbot> [ tools - Tools for Managing Translations ]
20:03:46 <papoteur> with the stylesheets you created and changed.
20:04:05 <papoteur> "you" is me ;)
20:04:25 <papoteur> #topic update stylesheets
20:04:54 <marja> I'm wondering whether the languages part could be po-ified... they're the same for every webhelp stylesheet
20:05:09 <papoteur> marja: I don't remember to have altered stylesheet, but I have not a good memory.
20:06:07 <marja> papoteur: hadn't you created one for the Live manual?
20:06:19 <marja> papoteur: sorry, I haven't looked in Calenco, yet
20:06:44 <papoteur> marja: no, just a new manual.
20:06:59 <marja> papoteur: ah, ok
20:07:35 <papoteur> OK. Thus nothing to do about that ;)
20:08:32 <marja> apart from reminding translators to add a section in those stylesheet for their language, if it doesn't exist... or to update it if it isn't complete
20:08:42 <lebarhon> do we need stylsheets for Draklive manual ?
20:08:46 <papoteur> about po-ified stylesheet, perhaps yurchor can say us something
20:09:11 <marja> lebarhon: yes, without a stylesheet publications cannot be made
20:09:53 <lebarhon> marja: who did them ?
20:10:02 <papoteur> marja: I made the publications with existing stylesheets.
20:10:35 <marja> papoteur: so, if you didn't change the stylesheet: how do you add which screenshot to use (the Live one or the Classical one)?
20:10:59 <marja> papoteur: for pages that are the same, but have different screenshot
20:11:09 <papoteur> :)
20:11:20 <papoteur> It my secret ;)
20:11:25 <marja> lol
20:11:39 <lebarhon> we will use torture
20:11:57 <papoteur> OK, I used WebHelp-DrakX.xsl for example, without alteration.
20:12:37 <papoteur> I added  "profile.condition= live" in parameter for the stylesheet.
20:13:04 <yurchor> papoteur: It's XML but the structure is not vry easy to parse. Can be extracted/merged with Python script. But who will run this script...
20:13:12 <marja> papoteur: ah, good :-) ... it'll have to be repeated for every language, though
20:13:39 <papoteur> Than in xml file, I added the attribute "condition=live" in sections specific to live publication.
20:14:01 <marja> papoteur: good
20:14:24 <marja> papoteur: did you see yurchor's reply?
20:14:59 <marja> about the po'ification
20:15:14 <papoteur> yes. I don't figure out what is to translate in the stylesheet. Marja, can you say us?
20:16:00 <papoteur> lebarhon: torture is working ;)
20:16:07 <marja> papoteur: you'll see it if you look at the webhelp stylesheets, they now have sections for several languages
20:16:18 <lebarhon> papoteur: always :)
20:17:13 <lebarhon> it is not relly about translation but localization
20:17:20 <lebarhon> *really
20:17:27 <yurchor> papoteur: Buttons, messages (everything in l10n block).
20:18:21 <papoteur> OK, I understand better.
20:18:47 <papoteur> marja:  where are stored stylesheets
20:18:50 <papoteur> ?
20:19:05 <marja> in Calenco? In the international space
20:19:17 <marja> papoteur: and in git, of course
20:20:51 <papoteur> Ok, it's the same stylesheet with language specific sections.
20:21:35 <marja> papoteur: yes, and many translators don't know about those sections
20:21:54 <papoteur> yes, even me ;)
20:22:08 <lebarhon> and me
20:22:19 <papoteur> yurchor: is the python script already exists?
20:22:21 <marja> and I probably forgot to add new sections for newly added languages
20:22:45 <papoteur> s/is/does
20:22:55 <yurchor> papoteur: No. But can be relatively easy written.
20:23:44 <papoteur> I have no rights for committing on transifex
20:24:23 <yurchor> papoteur: mmmm... For what?
20:25:04 <papoteur> to upload any new file to translate.
20:25:04 <yurchor> papoteur: I can give you any rights you want.
20:26:04 <papoteur> Thus, I will be able to run the script.
20:26:43 <yurchor> Done.
20:27:23 <papoteur> yurchor: do you mind to prepare a script?
20:27:24 <papoteur> Thanks
20:27:59 <papoteur> Or you can give me a example to modify.
20:28:12 <yurchor> papoteur: Yes. But maybe tomorrow. I'm a bit sick now (flu).
20:28:49 <papoteur> yurchor: Ok, it's an urgent matter. You have to care with you.
20:28:53 <marja> yurchor: get better soon
20:28:59 <lebarhon> I though there was no virus with linux :)
20:29:01 <yurchor> Thanks.
20:29:10 <papoteur> ;)
20:29:19 <yurchor> :)
20:30:27 <papoteur> #info yurchor will prepare or give papoteur a script to manage translation in stylesheets.
20:30:41 <papoteur> Thanks yurchor
20:31:10 <papoteur> next topic?
20:31:20 <papoteur> #topic Draklive filenames
20:32:27 <papoteur> I look for lebarhon messages
20:33:12 <lebarhon> If we have more and more manuals, may be we should have a convention for the filenames
20:34:12 <lebarhon> for exemple the string "live" for files in the Draklive manual
20:34:26 <lebarhon> it is just a suggestion
20:34:54 <marja> for traditional installer, the file names are used that are required by drakx-installer-stage2.... some of those files are re-used for the live manual
20:35:02 <papoteur> I didn't take this convention yet in draklive part.
20:35:20 <marja> so, for the reused pages, that cannot be done
20:35:30 <marja> but for the new pages it can
20:35:33 <papoteur> marja: I agree
20:36:11 <papoteur> The name of the xml file is also used in the url in web publication.
20:36:25 <lebarhon> May be iti is more useful for SC names
20:36:57 <papoteur> lebarhon: may be, yes
20:37:48 <marja> I saw dx3 was used?.. yeah, maybe use "live" instead of "dx3"
20:37:58 <papoteur> for the moment, I have prefixed them with dx3.
20:38:12 <marja> that is fine with me, too
20:38:33 <papoteur> Yes, this can be done.
20:38:56 <marja> or, no, in the long run no one will remember what dx3 was for, so better make it "live"
20:39:07 <papoteur> I hope that I can rename file through webdav
20:39:52 <marja> papoteur: no, renaming is impossible, you have to upload it again with the new name, and move the old file to the thrash
20:40:07 <papoteur> And we keep the xml files names?
20:40:23 <papoteur> :/
20:40:31 <marja> :-)
20:42:19 <papoteur> #action papoteur renames the pictures replacing dx3 with live in live manual
20:42:31 <admel> morning docteam.
20:42:39 <lebarhon> hi admel
20:42:55 <papoteur> hi admel
20:43:16 <papoteur> lebarhon: and for the xml file names?
20:43:42 * admel take time to read all of the discussion
20:43:52 <marja> admel: hi :-)
20:44:00 <lebarhon> papoteur: as you like,
20:44:41 <papoteur> OK, I prefer not to change them.
20:44:41 <lebarhon> but I think it is easier when we know what a file is about
20:45:04 <papoteur> admel: will be not too long ;)
20:45:13 <papoteur> next topic ?
20:45:30 <papoteur> #topic Mageia UEFI uninstallation
20:46:05 <papoteur> I didn't yet experiment this ;)
20:46:24 <lebarhon> It is said in the doc that one Mageia advantage is that you can uninstall it, yes but how ???
20:47:10 <lebarhon> Mostly, what must be done in the ESP ?
20:48:27 <papoteur> lebarhon: I don't know precisely, but I think that we have only to delete the "mageia" directory.
20:48:49 <marja> the Mageia part must be removed, but also from the boot order in the UEFI/BIOS... I no longer have an UEFI system, I'm not sure there is an easy way
20:48:51 <lebarhon> No you will delete the Grub
20:49:07 <papoteur> I can ask tmb, I'm sure he knows
20:49:32 <lebarhon> The grub program is still in the Mageia partition
20:50:07 <papoteur> but before installing Mageia, there was already bootloaders
20:50:33 <lebarhon> grub replaced them and chained
20:50:40 <marja> I think first, with efibootmgr, Mageia must be removed from the entries and windows must be put first in the boot order
20:51:22 <marja> then windows will boot as if Mageia never existed and then the windows partition can be expanded to use the Mageia space
20:52:01 <papoteur> It's the case where the other OS is Windows.
20:52:12 <marja> but maybe the Mageia partitions need to be ntfs formatted, first... with a Live DVD?
20:52:44 <papoteur> marja: no, i don't think it's needed
20:53:09 <lebarhon> the order in the ESP is read by grub, and grub isnot in the ESP
20:53:54 <marja> lebarhon: I'm talking about a different order, that's set in the UEFI(BIOS)
20:54:15 <marja> lebarhon: the order you can edit with efibootmgr
20:54:53 <papoteur> marja: I think you're right
20:55:39 <marja> lebarhon: if you remove Mageia from the entries and put windows (or whatever) first, it'll neglect the Mageia bootloader in the ESP
20:56:04 <lebarhon> Mageia bootloader isn't in the ESP
20:56:44 <lebarhon> it is in the Mageia partition
20:56:46 <marja> lebarhon: whatever it's called
20:57:05 <marja> lebarhon: boot manager
20:57:33 <lebarhon> if you format the mageia partition, UEFI will say no loader found
20:57:34 <papoteur> lebarhon: a part of the bootloader is in ESP : EFI/mageia/grubx64.efi
20:57:38 <marja> lebarhon: it'll neglect the mageia boot manager (or even wipe it, not sure about that, though)
20:57:56 <marja> papoteur: it might be called "boot manager"
20:58:05 <lebarhon> papoteur: yes, a part only
20:58:24 <marja> papoteur: or I'm totally confused :-รพ
20:59:11 <lebarhon> EFI/mageia/grubx64.efi need the following on the mageia partition
20:59:24 <papoteur> marja: yes. If the mageia partition is deleted, the mageia entry is no more working.
21:01:07 <marja> papoteur: so the mageia boot manager has to be removed or disabled first with efibootmgr
21:02:00 <papoteur> I think that any os has is own bootloader. Mageia can boot them also, by another way. But the main way is still availbale, even if we delete Mageia and its bootloader
21:02:46 <marja> yes
21:02:56 <papoteur> marja: yes, it should be done first, but it can also be done though UEFI settings
21:03:32 <papoteur> efibootmgr is not the only way.
21:03:52 <lebarhon> I tried to format a Mageia partition in a dual boot, I got: Gub rescue > _
21:05:09 <marja> if Mageia has 0006 in the list of entries of efibootmgr, then "efibootmgr -B 0006" will remove it (not sure it is then removed from the boot order list, too)
21:05:12 <lebarhon> efibootmgr is only for configuration
21:05:13 <papoteur> lebarhon: yes, because you keep UEFI entry pointing to Mageia one. This has to be changed also, either with efibootmgr, or from UEFI setting
21:06:05 <lebarhon> papoteur: no, I never had the menu to choose the entry
21:06:37 <papoteur> lebarhon: at boot or in settings?
21:06:40 <marja> the boot order list can be deleted with "efibootmgr -O" and created again with e.g. "efibootmgr -o 0003,000B,0012"
21:07:31 <lebarhon> papoteur: at boot
21:08:10 <lebarhon> wwhatever the list is, this list is displayed by grub and grub is in the mageia partition
21:08:36 <papoteur> lebarhon: yes, it's normal. But in setting, you have to specify a new entry a first which should be valid.
21:08:57 <marja> lebarhon: in the UEFI(BIOS) you can choose to boot from USB, or local disk etc
21:09:14 <papoteur> lebarhon: your Mageia entry is still in ESP, thus UEFI don't know that it is no more valid.
21:09:57 <lebarhon> Someboody write a method and I will test it
21:10:10 <marja> lebarhon: with efibootmgr, you can choose that, too
21:10:39 <papoteur> lebarhon: I presume that if you delete EFI/mageia, the behavior will change at boot.
21:10:52 <papoteur> lebarhon: ;)
21:11:04 <lebarhon> marja: I think efibootmgr doesnot write on the disk, only in firmware
21:11:15 <papoteur> yes, we need validation tests
21:11:31 <papoteur> lebarhon: yes, you're right
21:12:26 <marja> lebarhon: yes
21:12:55 <lebarhon> If I delete EFI/mageia, the boot manager will nevertheless call the bootloader for an other entry, but the boot loader is still grub on the Mageia partition
21:14:38 <lebarhon> I remind you that grub settings are in /etc/defaut/grub it is in the Mageia partition
21:14:38 <papoteur> lebarhon: No, UEFI can access grub only through EFI/mageia in ESP.
21:14:39 <marja> if you delete EFI/mageia, most probably the next boot manager will be tried, probably the windows one
21:15:39 <lebarhon> marja: I never tried that
21:16:14 <marja> indeed, booting Mageia is impossible when there's no mageia in the ESP (unless there's a bootloader from a different Linux distribution, and its bootloader knows the Mageia partition)
21:16:15 <lebarhon> marja: but what happen if you have several Mageia installations and you want uninstall just one
21:16:44 <papoteur> I can't help for such testing, my UEFI machine is for working !
21:17:16 <marja> lebarhon: I've done that, and I don't remember... I'm sure that there was only one mageia in the ESP
21:17:21 <lebarhon> Work can wait :)
21:17:43 <papoteur> lebarhon: :p
21:18:26 <marja> lebarhon: ah, I remember now: it can lead to the other installs becoming unbootable (if Grub was on the install you deleted)
21:19:16 <marja> lebarhon: so first make sure to run grub2-install on a partition that's kept
21:19:37 <marja> or was it update-grub2 (or both)?
21:19:47 <papoteur> I tink that there is only one mageia/grubx64.efi which lead to one grub, which should manage the diffrent Mageia.
21:20:08 <marja> papoteur: yes
21:20:42 <papoteur> lebarhon: thus, this case can be problematic.
21:20:45 <lebarhon> and where is this grub ? on the last installed Mageia partition
21:21:02 <papoteur> lebarhon: probably
21:21:03 <marja> lebarhon: usually
21:22:00 <marja> lebarhon: iirc, it is the Mageia that's at the top of the grub boot entries list
21:22:03 <papoteur> thus, we have to write a draft and submit it to qa/dev
21:22:10 <marja> yep
21:23:28 <papoteur> I will write something and propose it.
21:23:36 <marja> papoteur: thx
21:24:15 <papoteur> #action papoteur writes a draft for undeleting Mageia/UEFI and submit to qa/dev lists
21:24:44 <marja> #undo
21:24:44 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0xb69d5a8c>
21:25:17 <marja> #action papoteur writes a draft for deleting Mageia/UEFI and submits it to qa/dev mls
21:25:25 <papoteur> ;)
21:25:32 <marja> papoteur: undeleting isn't the same as deleting ;-)
21:25:40 <papoteur> yes ;)
21:25:56 <papoteur> #topic Using the "Condition" label in Calenco and as a consequence, the wiki update.
21:26:34 <papoteur> I have already spoken about that.
21:27:14 <lebarhon> yes we did, but you need to update the howto in the wiki
21:27:59 <papoteur> I look for it
21:28:11 <marja> I don't remember anything about a condition label :-(
21:29:17 <papoteur> https://wiki.mageia.org/en/Calenco_publications
21:29:38 <papoteur> marja: no, there is nothing for now
21:30:35 <marja> papoteur: ah, it is about stylesheet parameters?
21:30:48 <papoteur> yes.
21:31:00 <papoteur> I should add it.
21:31:27 <marja> now I understand, thx
21:31:27 <papoteur> lebarhon: do you mean another place?
21:31:34 <lebarhon> there is also this one https://wiki.mageia.org/en/How_to_write_and_translate_Mageia_doc
21:31:54 <lebarhon> to add how to use the "conditions"
21:32:33 <lebarhon> in Calenco
21:33:10 <marja> I'm not sure it is easiest to add it for every language, instead of creating separate stylesheets for the Live publications
21:34:14 <lebarhon> I though it was not the same purpose
21:34:23 <papoteur> marja: there is no need to specific stylesheets for live manual
21:34:47 <marja> papoteur: I'm fine with what you think is wisest
21:34:50 <papoteur> ok, I have to update two pages;
21:35:07 <papoteur> marja: like I done ;)
21:35:31 <lebarhon> "conditions" is to change some lines between drakx and draklive whereas the xml file is the same
21:35:32 <marja> papoteur: we just need to remember to add the parameters when creating the publications for the translations
21:35:38 <lebarhon> IIUC
21:36:23 <papoteur> marja: we have to check that it is keeped, yes
21:37:09 <papoteur> #action papoteur to revise https://wiki.mageia.org/en/Calenco_publications and https://wiki.mageia.org/en/How_to_write_and_translate_Mageia_doc for condition in xml files
21:37:47 <papoteur> last topic ?
21:37:55 <papoteur> #topic Paris Open Source Summit, flyers ? new ideas ?
21:38:17 <marja> I like stormi's flyer very much
21:38:40 <papoteur> I didn't check it yet.
21:39:13 <marja> well, I'm not sure it is the same one as I read ;-)
21:40:01 <papoteur> http://stormi.lautre.net/fichiers/jdll/2015/tract2015mageia.pdf
21:40:38 <marja> yeah, that's the one
21:40:51 <marja> :-D
21:41:05 <lebarhon> how many do you think I need ?
21:41:31 <papoteur> no idea
21:41:35 <papoteur> :(
21:41:54 <marja> better too many than too few, you can still hand them out anywhere after POSS
21:42:10 <lebarhon> it is french flyers
21:42:27 <marja> lebarhon: anywhere in France, then ;-)
21:42:46 <papoteur> and somewhere in Belgium ;)
21:42:53 <marja> lebarhon: with a laser printer, 250 flyers won't cost too much
21:44:21 <papoteur> I think 250 could be good.
21:44:42 <papoteur> With color?
21:44:45 <marja> or you could do 500, A5 pages side by side on a A4 sheet, and cutting them in half
21:45:03 <marja> papoteur: just black is cheapest
21:45:22 <marja> but Mageia blue is nicer
21:45:41 <papoteur> I know, color is ten times more expensive.
21:45:55 <lebarhon> I will see if A5 is readable
21:46:14 <marja> papoteur: for Fosdem, the Dutch flyers I printed were black only
21:46:30 <papoteur> marja: OK
21:47:35 <papoteur> Is it OK for you, lebarhon
21:47:45 <marja> lebarhon: in a few years your grandchild can color the flyers with pencils :-)
21:48:09 <papoteur> :)
21:48:32 <lebarhon> he is due for this week
21:48:57 <papoteur> exciting
21:49:06 <marja> we should give him a box of Caran d'Ache pencils :-)
21:49:16 <papoteur> :)
21:49:22 <lebarhon> I will buy him/her a notepad with Mageia
21:49:32 <marja> lebarhon: nice :-D
21:50:00 <lebarhon> marja: you know Caran d'Ache
21:50:28 <marja> lebarhon: I had such pencils as a kid, they were the best pencils I ever had
21:50:34 <pilotauto> sorry: just logged on: Key to any flyers success is following tested rules: have a quick google, it's all about the headline. Here in Australia, a flyer has 0.7 seconds to grab their attention before it goes in the bin with the rest: AFK
21:51:35 <papoteur> pilotauto: hello, welcome.
21:51:40 <marja> pilotauto: the headline is good: "Mageia - putting the magic back in computing"
21:52:31 <marja> pilotauto: my translation is maybe less good ;-)
21:52:46 <lebarhon> There is no bin in the booth
21:52:56 <marja> lebarhon: lol
21:53:00 <papoteur> pilotauto: do you know how it should be to have 1.4s instead ;)
21:53:12 <marja> pilotauto: and welcome from me, too :-)
21:53:50 <lebarhon> is it over ?
21:54:10 <marja> the meeting?
21:54:24 <lebarhon> yes chairwoman
21:54:36 <marja> :-) ... I guess we're done
21:54:41 <pilotauto> papoteur: don't know. Here in Aus, industry stand is 3 leads per 100 flyers, following good layout I get between 7 and 9 per hundred
21:55:22 <marja> pilotauto: are you Aussie_mat?
21:55:25 <papoteur> Yes, I think we can stop now, I fall asleep
21:55:35 <pilotauto> marja: correct, i'm at work
21:55:38 <pilotauto> afk
21:55:47 <marja> pilotauto: lol, you did fool me ;-)
21:55:55 <papoteur> Ah, OK
21:56:34 <papoteur> end meeting ?
21:56:47 <marja> fine with me
21:56:53 <marja> I'm falling asleep, too
21:57:07 <lebarhon> for me too
21:57:21 <papoteur> #endmeeting