20:06:03 <papoteur> #startmeeting
20:06:03 <Inigo_Montoya> Meeting started Thu Mar 26 20:06:03 2015 UTC.  The chair is papoteur. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:06:03 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:06:08 <papoteur> #topic current state of EFI
20:06:13 <marja> papoteur: thx :-)
20:06:15 <papoteur> marja ;)
20:07:04 * marja tested a bunch of tv patches before they were added to the isos, and here they worked rather well
20:07:26 <marja> the existing ESP was used (no new one was created)
20:07:52 <marja> when choosing to install to existing partitions, everything went fine automatically
20:08:53 <papoteur> I saw that the ESP partition has to have a specific UUID
20:08:56 <papoteur> ?
20:09:11 <marja> installing to empty space gave an error about no EFI partition, but then (without rebooting) choosing to use existing partitions worked fine (the new partitions were already visible)
20:09:13 <papoteur> Is that confirmed?
20:09:44 <marja> papoteur: almost: is is the Global one
20:10:02 <Dune06> hello everybody
20:10:07 <marja> Dune06: hi
20:10:12 <marja> papoteur: so the GUID
20:10:16 <papoteur> Hi Dune06, you'r ewelcome
20:10:55 <marja> papoteur: which differs from the unique UID
20:10:57 <papoteur> marja: need something to be documented on that
20:11:33 <papoteur> ?
20:12:16 <papoteur> I didn't tried install since beta3
20:12:17 <marja> papoteur: I think it needs some documentation.... see tv's comment 16 here https://bugs.mageia.org/show_bug.cgi?id=15482#c16
20:12:20 <[mbot> [ Bug 15482 UEFI installer makes bad partition choices with "use free space" option ]
20:13:22 <marja> papoteur: but I think that, if fdisk -l sees the partition as "EFI System", that that might be good enough for users
20:14:06 <marja> papoteur: it is possible to detect the GUID with gdisk (see the example in comment 18)
20:14:20 <papoteur> OK. We have not to give this code to the user.
20:15:52 <marja> papoteur: yeah, maybe explaining that if a 2nd EFI partition is created, that that is most probably because the first one was bogus, might be good enough (maybe adding to check with fdisk -l )
20:16:14 <papoteur> OK
20:16:51 <papoteur> the informations are collected yet in the page https://wiki.mageia.org/en/Installation_using_a_UEFI_firmware
20:18:11 <papoteur> I think it is to early to put it in our official pages ?
20:19:30 <marja> papoteur: yes, that is too early (and would drive the translators crazy).. we should focus on updating the wiki page, maybe splitting it in a Mga 4 and a Mga5 version (because in Mga5 much more works out-of-the box)
20:20:59 <papoteur> #info it is not time update the official documentation with UEFI stuff.
20:21:30 <papoteur> #undo
20:21:30 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0xb6a2842c>
20:21:39 <papoteur> #info it is not time to update the official documentation with UEFI stuff.
20:22:24 <papoteur> Something else about UEFI?
20:22:51 <papoteur> Thus next topic
20:23:14 <marja> well, people choosing to resize their windows partition should really be told to back it up well
20:23:47 <marja> and maybe be told about something like clonezilla
20:23:55 <papoteur> It is already said, isn't it ?
20:24:55 <marja> I'm not sure about a warning popping up before resizing is done, it is long ago that I tried that
20:25:16 <marja> I only know that you cannot choose the windows partition to resize... installer chooses
20:25:50 <papoteur> marja did you experienced lost of partition?
20:26:39 <marja> not with the EFI installs I did .....only one time, long ago, when I expected a confirmation screen to come that did not come, and wiped my entire disk ;-)
20:26:55 <papoteur> :/
20:27:08 <marja> papoteur: I learned a lot from it :-)
20:28:38 <papoteur> so we have to check which message is displayed and that documentation is in accordance with that.
20:28:39 <marja> papoteur: I don't remember how I created space for Mageia on my EFI system, I probably used a Live DVD and gparted to resize windows and make space
20:30:15 <papoteur> I have no box to test that. My windows is on my workmachine, which is not a testing one :/
20:30:20 <marja> yes, the message needs to be checked...... but I still think (because you cannot choose *which* windows partition) that it is better to tell users to do a custom install
20:30:31 <marja> papoteur: it is wise not to test on that one :-)
20:30:51 <papoteur> Can someone do the check?
20:31:11 <psyca> If you select "use empty space" and it resizes the windows installation it only tells you that you should check the drive with chkdsk and maybe defrag it
20:32:20 <papoteur> "Use empty space" is not for resizing Windows partition, for what I know
20:32:21 <marja> psyca: so there's a message, and it does not immediately start, but you can go back to the former screen?
20:32:54 <marja> psyca: papoteur: I think it is called "use empty space on a windows partition"
20:33:20 <papoteur> marja: Ok for that.
20:33:40 <psyca> "Use free space on a Microsoft Windows partition" > then you get an message to use chkdsk and defrag before
20:33:52 <psyca> but no warning to make a backup
20:34:36 <marja> psyca: do you happen to have a screenshot?
20:35:28 <marja> I read lebarhon's windows partition became unusable today, when testing that option on an EFI system
20:35:44 <papoteur> In our documentation we have " It is highly recommended to back up your personal files."
20:35:57 <papoteur> https://doc.mageia.org/installer/4/en/content/doPartitionDisks.html
20:35:58 <[mbot> [ Partitioning ]
20:37:22 <marja> papoteur: thx..... I think in the EFI wiki page, we should change that to "make a backup of your system, for instance with clonezilla, if you want to resize your windows partition"
20:37:49 <psyca> http://mageia.psyca.de/WinMaginstall1.png
20:37:53 <psyca> http://mageia.psyca.de/WinMaginstall2.png
20:38:14 <marja> psyca: you're great :-)
20:38:18 <marja> psyca: thx
20:38:55 <psyca> your welcome
20:39:01 <marja> good, it tells to backup your data....... and there is a "Previous" button
20:39:16 <psyca> oh i see.. theres a backup at the end of the line
20:39:31 <marja> psyca: :-)
20:40:50 <papoteur> #action in the EFI wiki page, we should change that to "make a backup of your system, for instance with clonezilla, if you want to resize your windows partition"
20:41:02 <papoteur> Ok
20:41:12 <papoteur> next topic ?
20:41:23 <marja> .rpmnew
20:41:35 <marja> yeah, next topic
20:41:45 <papoteur> #topic .rpmnew
20:43:22 <papoteur> I copy your message, marja:
20:43:26 <papoteur> We did not write about https://bugs.mageia.org/attachment.cgi?id=6113
20:43:27 <papoteur> in http://docteam.mageia.nl/en/MCC/content/MageiaUpdate.html
20:43:28 <[mbot> [ Software Packages Update ]
20:43:29 <papoteur> probably because the instruction the tool gives is good:
20:43:30 <papoteur> https://bugs.mageia.org/attachment.cgi?id=6114
20:43:32 <papoteur> However, many users do get confused and make the wrong choice.
20:43:58 <marja> #info many users, even advanced ones, get confused when after updating they get a pop-up about configuration files that were changed
20:44:39 <Kernewes> with regard to .rpmnew, the instinct is that you should use the new one
20:45:02 <Kernewes> whereas if you click for info it tells you if in doubt to stick with the old one
20:45:02 <marja> #info and then choose to use rpmnew, even if the tool tells to remove rpmnew if they do not know what to do
20:45:42 <Kernewes> I'd prefer it if the user had that info on the same screen not hidden away and you have to click to find it
20:45:49 <marja> Kernewes: oops, wasn't aware that you can choose without seeing that message
20:46:08 <Kernewes> I got it wrong when I first started
20:46:30 <marja> :-(
20:46:50 <Kernewes> I always stay with the old one now :)
20:46:58 <marja> OK, so the tool itself should be improved, too
20:47:02 <Kernewes> yes
20:47:34 <marja> but we should also tell the users to stick with the old file
20:47:36 <Kernewes> most people aren't going to read all the possible wiki pages before starting to use Mageia
20:48:18 <marja> nor the official documentation (I didn't even discover Mdv had official documentation, until I started to work on Mageia's)
20:48:54 <Kernewes> perhaps when Mga5 is out we should file a bug report about the way the tool presents the info
20:49:01 <marja> i kept using my Mdk 9.0 paper manual ;-)
20:49:09 <Kernewes> marja: :)
20:49:12 <marja> Kernewes: good idea
20:49:42 <Kernewes> someone will have to remember :)
20:49:47 * Kernewes hasn't got a memory
20:50:12 <marja> Akien: can you please remember for us?
20:50:32 <marja> Kernewes: Akien was working on a list of bugs to be fixed for Mga6
20:50:39 <Kernewes> marja: ah, fine
20:52:27 <papoteur> #action file a bug for Mageia 6 against .rpmnew not to keep by default.
20:52:30 * marja checks bugs mails to see whether setup got fixed, and won't show the option to use rpmnew any more
20:53:14 <Kernewes> it can show the option, but the explanation needs to be more visible
20:54:50 <papoteur> other topic ?
20:55:01 <Kernewes> not from me
20:55:14 <papoteur> do you mind speak about the wiki update?
20:55:17 <marja> it hasn't been tested yet https://bugs.mageia.org/show_bug.cgi?id=14266
20:55:19 <[mbot> [ Bug 14266 If you accept .rpmnew from the setup package, all your login data is lost and you cannot log in anymore ]
20:55:51 <marja> but a fix for setup is on the way, it seems
20:56:07 <marja> papoteur: yeah, fine
20:56:10 <Kernewes> that's not the same thing as we were discussing though
20:56:15 <Kernewes> that's one particular issue
20:56:26 <admel> papoteur: wiki update, great. :-)
20:56:55 <marja> Kernewes: yes, but if it wouldn't get fixed, we'd have to shout out everywhere: "don't use .rpmnew!"
20:56:58 <papoteur> topic not yet closed
20:57:27 <marja> Kernewes: but it seems it is getting fixed
20:57:29 <Kernewes> marja: true, we need that fixed *and* another bug about the general design
20:57:40 <marja> Kernewes: indeed
20:58:08 <papoteur> thus we keep the action
20:58:14 <marja> papoteur: yes
20:58:40 <papoteur> #topic wiki update
20:59:51 <marja> #info obgr_seneca will be back soon, and be Local Communities Team deputy leader, he intends to help with the wiki upgrade, too
21:00:25 * Kernewes didn't know we had a Local Communities Team
21:00:32 <marja> #info he needs a dump of our wiki database
21:00:59 <papoteur> marja: who can do that?
21:01:02 <marja> Kernewes: it has been sleeping since the beginning, and didn't even have a link from the contributors page :-/
21:01:13 <marja> papoteur: sysadmin team
21:02:06 <marja> diogenese: I said that wrong, how do you call a dump that is stripped of private things?
21:02:14 <papoteur> thus colin or tmb?
21:02:52 <marja> papoteur: yes, and it would be nice if both obgr_seneca and diogenese could get that dump (stripped of user data)
21:02:59 <marja> #undo
21:03:34 <marja> #info a dump of our wiki database (stripped of user data) is needed for upgrade testing
21:04:14 <marja> the undo didn't work, maybe I didn't have the right to undo (or to info)
21:04:23 <diogenese> Dumps come in handy for testing. I believe we use postgresql. Someone with access could dump selected tables.
21:04:42 <papoteur> #chair marja
21:04:42 <Inigo_Montoya> Current chairs: marja papoteur
21:04:49 <marja> papoteur: thx :-)
21:05:10 <marja> #info a dump of our wiki database (stripped of user data) is needed for upgrade testing
21:05:56 <papoteur> did the new version have an internationalisation feature?
21:06:30 <marja> papoteur: yes, both for linking pages between language wikis, and translate extension
21:07:53 * marja feels reluctant to ask sysadmin team now
21:08:10 <papoteur> I wonder we can have an access to a test version?
21:08:53 <marja> papoteur: sysadmins had planned on creating VMs for forums and wiki testing, but never got around to doing it
21:09:46 <marja> diogenese: with a dump we could test on any server that's available, correct?
21:10:15 <marja> diogenese: I mean, *you* could test ;-)
21:10:21 <diogenese> I would think so. That's how I do it.
21:11:14 <diogenese> I migrate to new releases, that requires I dump my wiki databases, set up the new wiki and import the data. Easy to do.
21:11:25 <marja> diogenese: do you have suggestions about what the dump should at least contain?
21:13:08 <diogenese> marja: I'd have to take a look at the tables again. I usually dump the whole database, but not all tables are needed. Some hold temp data.
21:14:38 <marja> diogenese: I think the only private data our wiki registers (and saves) is when you logged in from which ip address
21:14:43 <papoteur> diogenese: do you mind ask to colin to have the dump?
21:14:49 <marja> because that was obligatory
21:15:12 <marja> diogenese: so that is probably the only thing that should be left out
21:15:13 <diogenese> You would also need the uploaded images. The wiki has references to them and they are kept in ./images
21:15:34 <marja> diogenese: ah
21:16:26 <diogenese> But that's it. Once you have a clone of the wiki, testing the upgrades can be done without losing data.
21:16:39 <marja> nice :-)
21:17:29 <marja> diogenese: even if the test wiki is not connected with mageia's ldap server?
21:18:52 <Kernewes> sorry, have to go now, getting very tired
21:18:58 <marja> Kernewes: sleep well
21:19:03 <Kernewes> marja: thanks
21:19:09 <diogenese> Bye Kernewes, sleep well. ;)
21:19:10 <admel> Kernewes: have a good sleep !
21:19:12 <marja> Kernewes: thanks a lot for having attended the meeting!
21:19:13 <papoteur> Kernewes: thanks
21:19:16 <Kernewes> thanks everyone
21:21:02 <diogenese> marja: Hadn't thought about that. ldap has limited user data used for logging in. I might be able to turn that off and just use user info from the database. Not sure.
21:21:50 <marja> diogenese: you'll find out ;-)
21:22:38 <papoteur> OK, I hope that this topic can progress with your help an obrg's one
21:23:13 <marja> diogenese: or we should get a test wiki on mageia.org somewhere, so that it can stay connected to ldap
21:24:31 * marja is getting sleepy
21:24:43 <papoteur> for this evening, I think we can stop?
21:24:51 <marja> papoteur: yes :-)
21:25:01 <marja> next meeting in two weeks?
21:25:09 <diogenese> We can talk about this later ;)
21:25:14 <papoteur> marja: I read in your brain ;)
21:25:21 <marja> papoteur: :-)
21:25:34 <papoteur> yes, in two weeks.
21:25:36 <marja> April 9 next meeting, 19h UTC, 21h CEST
21:25:47 <papoteur> #endmeeting