17:00:34 <marja> #startmeeting
17:00:34 <Inigo_Montoya`> Meeting started Mon May  6 17:00:34 2013 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:34 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:39 <marja> Kernewes: np
17:00:59 <marja> #topic getting our documentation (installer + MCC help) ready for doc.mageia.org
17:01:13 <marja> what is ready?
17:02:26 <marja> about installer help, there is not one language ready yet, the ones that have up-to-date translations don't have all screenshots, yet
17:02:57 <marja> that is partly caused by my adding screenshots for screens that had no screenshots, yesterday
17:03:39 <marja> however, for resizeFATChoose and takeOverHdChoose I can't find the screens
17:04:43 <marja> Some time ago, when I expected to get the resizeFATchoose screen when I had two windows partitions that could be made smaller, installer didn't let me choose between them, but just picked one
17:06:39 <marja> MrsB: sorry, but I could use QA team help with finding those screens, if no one gets to choose between windows partitions, then I guess it's a bug
17:07:35 <marja> MrsB: or we should just remove that text, so no one will expect to get a choice, and tell to choose "custom" if someone has more than one windows partition
17:09:45 * marja wonders whether anyone is still around
17:09:58 <simonnzg> We were waiting for you to finish typing ;-)
17:10:05 <marja> simonnzg: lol
17:11:23 <simonnzg> marja: I just created a virtualbox disk with two Windows partitions (NTFS) to see how the installer reacts.
17:11:33 <marja> simonnzg: ah, great :)
17:11:49 <marja> simonnzg: I hope you can get that screenshot, or prove the bug ;)
17:13:04 <simonnzg> Just trying to reboot...
17:13:24 <marja> #info simonnzg tests what happens in doPartitionDisk when there are 2 windows NTFS partitions (to see whether he gets the resizeFATChoose screen)
17:14:01 <marja> #info the takeOverHdChoose screen needs to be found, too
17:15:00 <marja> #info for all languages screenshots are missing, varying between 1 and nearly all... please feel free to upload any missing ones
17:15:08 <marja> #undo
17:15:08 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x82e1fec>
17:15:23 <marja> #info for all languages installer screenshots are missing, varying between 1 and nearly all... please feel free to upload any missing ones
17:15:41 <simonnzg> I have to say that I wonder if we're going to too much effort to get screenshots.  If the screen isn't self-evident, then it's probably not worth getting a picture.
17:15:57 <lebarhon_> Why is it so important to have the last screensplash?
17:17:04 <marja> #info for MCC help, the "write some text" lines must be replaced by "This help texts still needs to be written, please contact <link to documentation team wiki page> if you want to help"
17:17:43 <marja> lebarhon_: that looks less messy, but I agree that having an old screenshot is better than no screenshot at all
17:18:14 <lebarhon_> It isn't really old, it is Mageia 3 RC instead of Mageia 3
17:18:52 <marja> lebarhon_: for installer help, I've come accross at least 1 Mageia 1 screenshot ;)
17:19:13 <marja> lebarhon_: it depends on the language, I suppose
17:19:54 <simonnzg> marja: hmmm.  OK, two partitions, originally / and /home on a default Virtualbox Mageia3 install on a 20GB disk.  Both NTFS formatted (not NTFS-3G).  I had no choice what partition to resise: It just resised my "Windows Partition".  I'm rebooting to see what happened to the virtual drive.
17:20:35 <simonnzg> I would expect my second NTFS disk to be resized...
17:22:03 <marja> simonnzg: did you by any chance take a screenshot before you chose to install on a windows partition?
17:23:52 <simonnzg> OK, it resized my second partition, using the hole where my swap was as the starting point, then put a minimum root and then swap and home space at the end.  That will result in a system that is hard to upgrade without actually deleting the donor NTFS partition.
17:24:02 <simonnzg> I have a before and after
17:25:02 <simonnzg> Whoops.  I've just resized the partition again!
17:25:08 <marja> simonnzg: nice... I didn't when I tried that
17:25:13 <marja> simonnzg: oh?
17:25:42 <marja> simonnzg: in my case, it resized my C partition where I wanted the D partition to be resized :-/
17:25:57 <simonnzg> I will be very interested to see what it does now.  Apart from the empty primary NTFS partition, everything else is too small, now.
17:27:05 <simonnzg> I thought it would go for the second one, which it did.  It should look for free space and then ask.
17:28:21 <marja> simonnzg: can you see in the doPartitionDisk screenshot from *before*, which windows partition it was going to use?
17:28:29 <simonnzg> Very interesting patchwork of little Linux EXT and Swap partitions.  Well worth doing for the entertainment
17:28:37 <marja> :)
17:29:16 <simonnzg> marja: No, you select the "Use the free space on a Windoze partition" and it takes you to a warning page and then does "it".  Whatever it decides "it" will be.
17:30:03 <simonnzg> I now have Blue, Red, Blue, Red, Green, Red, Green and Red partitions on the map. Pretty.
17:30:53 <marja> simonnzg: do you want to file a bug report, and add the relevant screenshot(s) to it?
17:31:34 <simonnzg> Me? Use Bugzilla?  I wouldn't know where to start. That thing is designed to put people off reporting, I'm sure.
17:32:17 <marja> simonnzg: send me the screenshots and I'll report :)
17:32:58 <marja> simonnzg: you don't have the / partition of that install anymore, do you?
17:34:36 <simonnzg> I have several, it seems.. ;-)
17:34:39 <marja> simonnzg: because if you do, I'd love to have the /root/drakx/report.bug.gz , too ;)
17:34:46 <marja> simonnzg: lol
17:34:51 <marja> simonnzg: of that install ;)
17:34:59 <simonnzg> I'll see if it's mountable
17:35:06 <marja> simonnzg: thx :)
17:35:59 <marja> lebarhon_: The French MCC help is ready, isn't it?
17:36:11 <lebarhon_> I think so
17:36:36 <marja> lebarhon_: you and dune have done a tremendous job :)
17:36:53 <marja> lebarhon_: the English MCC help isn't ready, yet
17:37:09 <lebarhon_> Why ?
17:37:55 <marja> lebarhon_: it still needs the "write some text" to be replaced with a notification that the page wasn't written yet, and a link to the docteam wiki page
17:38:16 <lebarhon_> Ok, I can do that
17:38:36 <marja> lebarhon_: perfect! Thanks a lot :-)
17:39:25 <marja> #action lebarhon will replace the "write some text" lines in the English MCC help, with a better text (like the one in French)
17:40:40 <marja> #info in a council meeting it was suggested to add a note at the beginning of not fully translated manuals, that it hasn't been translated completely and to contact us if someone desires to help
17:43:16 <marja> #info for languages for which SVN + po are not used, that will mean that complete pages can be missing (like for Swedish) and strings can be wrong... if SVN + po are used, the English pages and strings will be used in case of not updated or missing translations
17:43:54 <marja> #info and only the translation where it is up-to-date
17:45:46 <marja> do you have any ideas about this (e.g. letting the few Swedish pages we have go into doc.mageia.org)?
17:46:26 <yurchor> I think it's up to Sweden team to decide.
17:47:21 <marja> yurchor: ah, I'm fine with that :-)
17:48:32 <marja> yurchor: so the same for all other translations, if it is incomplete, let the translator or team decide whether they want it in doc.mageia.og
17:48:38 <marja> s/og/org/
17:49:20 <marja> does everybody agree?
17:49:27 <yurchor> Sure. And if there is no translation team it is better not publish the translated docs at all.
17:49:48 <marja> yurchor: sounds good :)
17:50:35 <marja> yurchor: as long as 1-person teams count as team ;) (Qilaq, dglent, you etc)
17:51:27 <yurchor> Sure these are the teams. ;0 I meant "the teams that does not show any activity, say, for 6 months".
17:51:43 <marja> yurchor: fine :)
17:53:32 <marja> #action for incomplete translations, every team decides whether it should go into doc.mageia.org or not (with the message that it is incomplete on the index page and instructions how to contact the team to help)
17:54:21 <marja> #info if there is no team anymore, then the translation won't go in doc.mageia.org
17:55:53 <marja> yurchor: does the help.pot file get updated automatically?
17:56:38 <Qilaq> I'm of course seriously beaten that marja did new screenshots and so Estonian translation again was not fully complete but I do all I can it will not stay so!
17:56:48 <yurchor> No. I will update it by hand aevery time it will be changed in Calenco.
17:57:12 <marja> Qilaq: I uploaded the new screenshots for you, just didn't find time to add them in the .xml files
17:57:21 <yurchor> It is impossible to update it automatically without unveiling Calenco credentials.
17:57:30 <marja> yurchor: you're good at spotting changes!
17:57:36 <Qilaq> aha, good, vry good, I didn't know that :-)
17:58:23 <yurchor> marja: It's easy. Every day I open WebDav folder in Dolphin (the folder is sorted by date). ;)
17:58:26 <marja> yurchor: I think I've asked camille before for read-only access
17:58:35 <marja> yurchor: ah, nice :)
17:59:43 <marja> Qilaq: if you have time, you can just copy-paste the lines from the En files (but they should be in the DIFFs, too)
18:01:32 <Qilaq> I'll do (just now am busy with quick translation job but probably tomorrow)
18:01:39 <marja> Qilaq: thx :)
18:02:22 <marja> Qilaq: I think I missed one of the screenshots you asked for
18:03:42 <marja> does anyone have anything to add?
18:03:46 <Qilaq> there was two and IMHO you did both (add_supplemental_media and installUpdates)
18:04:25 <marja> Qilaq: ah, good, then I mixed your question up with one of someone else ;)
18:04:54 <Qilaq> I did some remarks about other screenshots, one in Ukrainian and one in French
18:05:15 <Qilaq> maybe that confused you :-)
18:05:21 * marja considers removing the resizeFatchoose and takeOverHdChoose pages from the installer manual
18:05:36 <marja> Qilaq: ah, that must be it (I've totally forgotten :-/ )
18:06:23 * marja only for the online help, not for the inline one (because we never seem to see the screens related to those two help files)
18:07:38 <marja> #action marja ask pasmatt for the code to remove the othercredit lines from the online help
18:09:29 <marja> wdyt about removing those two pages?
18:11:03 <lebarhon_> Is TakeoverHdConfirm also to be removed ?
18:12:00 <marja> lebarhon_: no, you do get that screen when choosing to use an entire disk
18:12:28 <marja> lebarhon_: I can get you a French screenshot, if you want
18:13:14 <lebarhon_> There is 7 missing screenshots in French help
18:13:19 <marja> lebarhon_: or do you think that one should be removed, too? (and do you agree about the other 2)
18:13:51 <marja> lebarhon_: I'm now doing a German install, I can try to find the French missing screenshots
18:13:57 <lebarhon_> marja: I don't know, I need to see the installer
18:14:30 <marja> lebarhon_: it is not that the screenshots are there, but just the code to include them missing in the .xml file?
18:15:46 <marja> lebarhon_: we can decide later.... maybe you do find the screens :)
18:16:28 <lebarhon_> I know the missing screens, I don't follow you
18:16:59 <marja> lebarhon_: ah, you said you needed to see the installer
18:17:18 <lebarhon_> To know which pages to remove
18:17:28 <marja> lebarhon_: I thought you said that because you didn't know whether to agree with removing those two pages
18:17:31 <marja> yes
18:18:07 <lebarhon_> OK What about the missing French screenshots ?
18:18:50 <marja> lebarhon_: what I said about the code to include, was about the French screenshots.... for some languages I've seen that a screenshot was in Calenco, but it wasn't in the .xml file
18:19:00 <marja> papoteur: hi
18:19:26 <lebarhon_> I see now, I will check that
18:19:29 <papoteur> Hello marja, docteam
18:19:39 <lebarhon_> hello Papoteur
18:19:51 <marja> papoteur: lebarhon just mentioned that some screenshots are missing in French installer help (undoubtedly my fault, too, because I added new ones in the En installer help)
18:20:30 <papoteur> I did see them.
18:20:38 <papoteur> I did not see them.
18:21:20 <papoteur> which ones are lacking?
18:21:49 <lebarhon_> ChoosePackageTree ConfigureServices ConfigureTimeZoneUTC
18:21:59 <marja> papoteur: all screens, except resizeFATchoose and takeOverHdChoose, should have a screenshot now
18:22:12 <lebarhon_> MinimalInstall SecurityLevel SelectCountry
18:22:54 <marja> papoteur: lebarhon's lists are better ;) ^^^
18:23:32 <lebarhon_> The isn't in the .xml file but perhaps in Calenco
18:23:56 <lebarhon_> *The screenshot isn't
18:25:51 <marja> papoteur: if needed, I can try to do those screenshots (I'm aware it was nasty to add them so late)
18:27:35 <papoteur> marja: lebarhon_ I will have a look tonight. I am not yet really available.
18:27:54 <marja> papoteur: thx!
18:28:14 <papoteur> Is it only lack of screenshots or are the links also lacking?
18:28:33 <marja> papoteur: for many, the links need to be made, too
18:29:00 <papoteur> Ah OK.
18:29:04 <marja> papoteur: you can copy them from the en files, if you open 2 calenco instances side by side
18:29:04 <simonnzg> That was painful. marja: I have managed to coax the required screenshots and report.bug.xz file out of that VM.
18:29:18 <marja> simonnzg: you're an angel!
18:29:27 * simonnzg needs to go and feed several hungry animals.
18:29:53 <papoteur> I have also hungry sons ;)
18:29:59 <simonnzg> marja: Slow ADSL, Windows Remote Desktop and a VM running on my office PC. Ouch.
18:30:16 <marja> do we have anything else that needs discussing? (maybe, for installer help, the size of screenshots9?
18:30:19 <simonnzg> papoteur: I sent mine back to school just now.  I have four cats and a dog to feed now.
18:30:28 <marja> papoteur: how many sons do you have?
18:30:56 <marja> simonnzg: night school (that is en vogue here, too)
18:31:13 <marja> papoteur: sorry, have a nice evening
18:31:43 * marja thinks everyone wants to end this meeting
18:32:54 <marja> #endmeeting