19:04:24 <ennael> #startmeeting
19:04:24 <Inigo_Montoya> Meeting started Wed Jun  8 19:04:24 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:24 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:04:25 <erzulie> [ MeetBot - Debian Wiki ]
19:04:30 <brianb> Hi
19:04:37 <ennael> #chair misc stewb
19:04:37 <Inigo_Montoya> Current chairs: ennael misc stewb
19:04:44 <ennael> hi all
19:05:05 <ennael> let start with first topic
19:05:14 <ennael> #topic short review of Mageia 1 launch
19:05:46 <ennael> firts of all thanks all for the efforts for Mageia 1. We can say now feedbacks are rather good
19:05:56 <ennael> and people seem to like this first release
19:06:36 <ennael> we will give in coming days some more figures about blog and web site visits to give an idea
19:06:55 <ennael> but we have still now new articles and reviews about Mageia 1
19:07:03 <ennael> all quite good
19:07:16 <misc> ( except some french people )
19:07:19 <dmorgan> nice :)
19:07:41 <ennael> and because of that we have new proposals from new contributors
19:07:56 <ennael> and more mirrors, biggest one to come is kernel.org
19:08:51 <ennael> anybody wants to add something there ?
19:09:03 <Kharec> nope
19:09:13 <anaselli> ennael:  new proposals?
19:09:21 <anaselli> sorry
19:09:25 <anaselli> i misunderstood :)
19:09:34 <ennael> honnest proposals :)
19:09:41 <anaselli> :p
19:09:46 <ennael> so that means first round is successfull
19:09:53 <anaselli> i read for new contributors :D
19:09:59 <anaselli> not from
19:10:02 <ennael> *but* the hardest is coming :)
19:10:20 <Kharec> what?
19:10:44 <ennael> we have to work to keep this first release stable and secure
19:10:52 <ennael> and think about next one
19:10:59 <dmorgan> so 2 goals
19:11:03 <anaselli> and to build a great next one :D
19:11:10 <dmorgan> anaselli: yes :)
19:11:11 <ennael> (/me is not trying to kill motivation :p)
19:11:29 <ennael> ok so let's go to next topic
19:11:30 <obgr_seneca> (if you don't kill contributors)
19:11:34 <Kharec> ennael: no, you're right
19:11:36 <ennael> #topic organize post-portem for packagers team
19:11:38 <dmorgan> ennael: i take one year holiday i am back after :)
19:11:41 <ennael> :)
19:11:51 <ennael> is post-mortem clear for everyone ?
19:11:57 <ennael> this is not about death
19:12:02 <anaselli> dmorgan: no we have some things to do... :P
19:12:18 <misc> debriefing
19:12:49 <ennael> ok we finalize first release with good things
19:12:54 <ennael> but also things to be improved
19:13:08 <ennael> so that debriefing will go in coming days
19:13:20 <ennael> http://mageia.org/wiki/doku.php?id=iso1:mageia1_postmortem
19:13:21 <erzulie> [ iso1:mageia1_postmortem [Mageia temporary wiki] ]
19:13:37 <anaselli> ennael: post-mortem? or post-portem? (topic is wrong)
19:13:52 <ennael> the point here is to list what went good and what went wrong to improve it
19:13:54 <ennael> anaselli: typo
19:14:00 <misc> anaselli: post-mortem :)
19:14:17 <stewb> "lessons learned" is another popular term
19:14:42 <ennael> thanks :)
19:14:55 <ennael> so please take some time to think about it
19:15:03 <ennael> and add your comments on this wiki page
19:15:15 <ennael> we will review it for next meeting
19:15:28 <ennael> is that all clear ?
19:15:35 <anaselli> ok for me
19:15:38 <obgr_seneca> yep
19:15:44 <misc> #action add comments to the wiki page http://mageia.org/wiki/doku.php?id=iso1:mageia1_postmortem
19:15:44 <erzulie> [ iso1:mageia1_postmortem [Mageia temporary wiki] ]
19:16:00 <ennael> feel free to add categories for items so that we can classify it
19:17:12 <ennael> this is important to improve our way of working so please take this time
19:17:16 <ennael> any question?
19:17:30 <brianb> what type of classifications will you be using?
19:17:36 <misc> no
19:18:02 <ennael> brianb: as an example, build system, packaging, policies, tests...
19:18:04 <brianb> what will be the obtectives?
19:18:24 <ennael> if you read above the point is to improve what went wrong
19:18:40 <ennael> and formalize all things that were ok
19:19:08 <ennael> ok next topic then :)
19:19:23 <ennael> #topic start brainstorm on release cycle
19:19:31 <ennael> burning topic :)
19:20:02 <ennael> as we announce it, coming weeks will be busy to think about goals and organization of Mageia in future
19:20:25 <spturtle> release cycle depends a lot on how many stable releases we will support concurrently and for how long
19:20:29 <ennael> we did not fix anything for now about release cycle and maintainance
19:20:48 <ennael> so this will be our main topic in 2 coming weeks
19:21:05 <ennael> or befiore if we do agree on a final decision
19:21:30 <anaselli> agree
19:21:34 <ennael> here is the process we propose
19:22:02 <ennael> 1 - we will make some proposals on friday as we need to finalize presentation
19:22:16 <ennael> 2 - we take time to speak about it on -dev ML
19:22:34 <ennael> not only packagers but also i18n, marketing, testers...
19:23:12 <ennael> until 23rd of june
19:23:56 <ennael> 3 - we summarize discussions and take final decision
19:24:25 <ennael> everyone can discuss about it provided it's done in a constructive way
19:24:28 <ennael> meaning
19:24:36 <AL13N> should we wait on finish of postmortem before doing proposals  ?
19:24:39 <anaselli> that means we have the decision by the end of this month at the latest, right?
19:24:42 <ennael> I make a proposal, I explain it, give pros and cons
19:24:49 <ennael> anaselli: yes
19:24:55 <ennael> AL13N: nope
19:25:00 <misc> AL13N: that's not the same target
19:25:15 <AL13N> but, doesn't postmortem could have effect on proposals?
19:25:20 <misc> AL13N: no
19:25:25 <ennael> is it clear? does it sound reasonable? realistic?
19:25:53 <obgr_seneca> I think so
19:25:54 <brianb> take it these proposals are for the next release?
19:26:04 <anaselli> well i believe we can't go on so far without some important points fixed in mind :)
19:26:07 <misc> brianb: yes
19:26:23 <Stormi> I already have written my proposals so it's OK for me :)
19:26:32 <brianb> SMART objectives?
19:26:35 <ennael> this is important to take part in discussion if you have things to say
19:26:40 <ennael> speak now or never :)
19:26:41 <misc> Stormi: on piratepad ?
19:26:45 <Stormi> misc: yes
19:27:13 <Stormi> I'll send the link again in the ML
19:27:34 <ennael> also as it's important decision again it's important to explain with concrete arguments
19:27:46 <ennael> otherwise it will be just a kind of troll :)
19:27:51 <AL13N> this is about the major goals
19:28:12 <Stormi> we might want to consider what's been said in the dedicated topic on the forum too
19:28:20 <ennael> Stormi: it will be done
19:28:48 <ennael> but for once we will ask people who want to speak about it to join ML
19:28:55 <ennael> so that discussion can be centralized
19:28:57 <misc> Stormi: I have read old topic on mandriva forum, old mail and also discussed with fedora and opensuse people about their respective releases cycle
19:29:22 <anaselli> misc: and?
19:29:23 <ennael> so main questions are:
19:29:30 <AL13N> is this about major goals? or also technical stuff or only release cucle?
19:29:34 <ennael> how long between 2releases
19:29:35 <misc> anaselli: and, that's a long task :)
19:29:40 <ennael> LTS version ?
19:29:43 <misc> AL13N: release cycle for now
19:29:51 <ennael> general maintainance time for one release
19:30:00 <dmorgan> 6 monthes seems a good compromise for each releases
19:30:16 <anaselli> ennael:  LTS?
19:30:18 <brianb> what about have a stable release and a bleading edge ?
19:30:21 <ennael> stewb: of course secteam opinion is very important too :)
19:30:21 <AL13N> misc: ah, it was not clear to me...
19:30:28 <ennael> anaselli: long time support
19:30:34 <anaselli> ah right :)
19:30:35 <misc> so if people could keep the discussion for ml, it would be good
19:30:41 <AL13N> ok
19:30:48 <misc> we are not here to have a 2 week long discussion on irc
19:30:54 <ennael> avoid IRC as everybody will not see it
19:31:01 <Stormi> ennael: - backports policy (if we choose a non-rolling model of course)
19:31:09 <mikala> ennael: i guess we're probably too young to have a LTS release.
19:31:17 <ennael> mikala: ML :)
19:31:25 <mikala> oh ok.
19:31:30 <ennael> thanks :)
19:31:47 <spturtle> ennael: so close the topic already
19:31:51 <ennael> comments? disagreement?
19:31:58 <brianb> surly having a LTS and a rolling release will require more people?
19:32:07 <ennael> ML :)
19:32:11 <dmorgan> brianb: ML
19:32:16 <leuhmanu> :)
19:32:28 <ennael> again it's important people can have all points of view
19:32:41 <Kicer86> i'd prefer rolling
19:32:45 <ennael> ML
19:32:46 <Stormi> Kicer86: ML :)
19:33:17 <ennael> anything to add on this process ?
19:33:27 <Kicer86> ML means ... ?:>
19:33:33 <ennael> mailing list :)
19:33:39 <Kicer86> D:
19:33:45 <ennael> ok
19:33:51 <ennael> #topic start and organize discussions about first technical specifications
19:34:05 <ennael> another burnong topic :)
19:34:09 <ennael> burning
19:34:28 <ennael> we have to think about Mageia 2 specifications
19:34:48 <dmorgan> ennael: ML to answer too ? :)
19:34:50 <ennael> we will speak about technical and functionnal specifications
19:35:14 <ennael> the second one may be discussed in a larger way with marketing, users...
19:35:29 <ennael> we can start now on technical specifications
19:35:44 <Stormi> now means IRC or ML ? :)
19:35:47 <anaselli> ennael: do you mean about mageia tools?
19:35:51 <ennael> it will deal with technical evolutions we want to include in Mageia 2
19:36:04 <ennael> rather about nice topics like
19:36:12 <ennael> systemd, grub2, gnome3...
19:36:20 <misc> well, the idea is that the meeting is short, so the real discussion are not now, that's about how we organize ourself
19:36:24 <AL13N> not about drak* redesign?
19:36:27 <Nanar> rpm5 /o\
19:36:29 * Nanar runs
19:36:33 <AL13N> lol
19:36:35 <ennael> Nanar: also :)
19:36:36 <brianb> will Mageia 2 be based upon Mageia 1 or the mandriva 2011 ?
19:36:42 <Stormi> Nanar: I saw that already in an IRC meeting :)
19:36:48 <misc> ( and the first one to say "i would prefer such feature" now during the meeting will be banned using iptables on server )
19:36:51 <Stormi> brianb: mageia
19:36:52 <boklm> brianb: Mageia 1
19:36:52 <mikala> brianb: we're a fork, so i would say from mageia 1 :)
19:37:10 <ennael> misc: +1 :)
19:37:18 <dmorgan> brianb: we have nothing to do with mdv anymore ;)
19:37:22 <Stormi> I would prefer... not to be banned
19:37:25 <misc> ( except Nanar because we share the same ip )
19:37:32 <ennael> ok so to summarize
19:37:51 <AL13N> Stormi: :-)
19:37:53 <ennael> we have to start discussion about this point
19:37:57 <ennael> *now*
19:38:11 <misc> ( with now being "now, once the meeting is finished" )
19:38:14 <ennael> so that we can plan who is doing what, when or why we will not do it
19:38:19 <ennael> yep
19:38:35 <spturtle> so who asks for this on the ml, such that people can reply with all their crazy ideas
19:38:46 <ennael> whatever the time for the release, experience showed in previous life that we tended to start such work much too late
19:38:55 <Nanar> in *Mandriva, we had maintainers with an highter voice on such topic
19:39:06 <Nanar> don't we need maintainers ?
19:39:07 <ennael> spturtle: we can speak about it in ML but I would rather propose a wiki page
19:39:09 <Nanar> first
19:39:30 <misc> Nanar: we need them yes, but that requires a maintainer db to tack them
19:39:33 <misc> track
19:39:35 <brianb> agree wiki would be better
19:39:56 <ennael> so I guess proposals can be done on wiki and discussed in ML
19:40:43 <ennael> does it sound reasonable ?
19:40:46 <spturtle> so let's discuss maintainer db in this meeting
19:40:54 <ennael> spturtle: wait please
19:41:51 <spturtle> is there a wiki page already for those proposals?
19:41:56 <misc> nope
19:42:33 <Stormi> agreed about such a proposals wiki page + discuss on ML
19:43:07 <ennael> http://mageia.org/wiki/doku.php?id=iso2:technical_specification
19:43:08 <erzulie> [ iso2:technical_specification [Mageia temporary wiki] ]
19:43:15 <ennael> just wrote a short one
19:43:23 <ennael> feel free to improve it
19:43:46 <leuhmanu> Mageia2 no ?
19:43:59 <ennael> tmb was fast :)
19:44:02 <tmb> :)
19:44:14 <ennael> leuhmanu: using existing categories for now
19:44:21 <leuhmanu> ok
19:44:36 * anaselli can follow ML for the most
19:45:07 <ennael> is that clear enough ?
19:45:33 <ennael> if yo have details about planning for a release (ex: kernel) please add it
19:45:43 <ennael> it will give an idea for general planning for mageia
19:45:55 <brianb> why ex kernel?
19:46:04 <ennael> have a look on wiki page
19:46:10 <AL13N> ex == example
19:46:20 <ennael> tmb already added his baby :)
19:46:39 <anaselli> not his name/nick though :p
19:46:45 <ennael> indeed
19:46:50 <ennael> I'm sure he will add it
19:47:02 <anaselli> me either :)
19:47:19 <ennael> questions
19:47:20 <ennael> ?
19:47:30 <AL13N> what about maintainers db?
19:47:41 <AL13N> spturtle mentioned something about it
19:47:41 <misc> AL13N: still not deployed
19:47:42 <ennael> indeed on this topic ?
19:47:51 <misc> because sysadmin are too busy answering questios about it :)
19:47:53 <AL13N> i'm asking is this for this topic or not?
19:48:03 <AL13N> or is this for some other time
19:48:21 <misc> AL13N: to me, it does look like something that as to do with technical specification organization per se
19:48:45 <misc> #action add proposal on  http://mageia.org/wiki/doku.php?id=iso2:technical_specification
19:48:45 <erzulie> [ iso2:technical_specification [Mageia temporary wiki] ]
19:48:45 <AL13N> misc: it does?
19:48:53 <misc> AL13N: it does not
19:49:07 <spturtle> new topic
19:49:08 <AL13N> k
19:49:22 <ennael> anything else to add on that specific topic ?
19:49:36 <dmorgan> ennael: no, i added my baby too :)
19:49:40 <anaselli> how can we merge ML and wiki?
19:49:42 <ennael> as said misc the point tonight is not to speak about all this but only about process
19:50:07 <spturtle> so release cycle discussion will include a timeframe for deciding on tech specifications?
19:50:17 <ennael> ?
19:50:26 <ennael> these are 2 discussions
19:50:35 <Stormi> tech specs depend on the duration of the cycle
19:50:45 <tmb> yep.
19:50:45 <spturtle> yes but the specs must be decided sometime, "frozen"
19:50:48 <olorin_> And do remember to not grow the temp wiki too much...
19:50:56 <misc> Stormi: yes but not proposal
19:51:12 <anaselli> dmorgan: Unordered List Itemgcc-4.6x?
19:51:13 <misc> and I doubt the majority of proposal will really depend on the duration
19:51:39 <ennael> proposal can also be managed on 2 releases
19:51:44 <dmorgan> anaselli: a typo i will fix this :)
19:51:48 <ennael> having long term projects
19:52:01 <obgr_seneca> anaselli: my fault while trying to correct the wiki syntax...
19:52:06 <dmorgan> ennael: would be nice to have this "idea" of long term projects
19:52:22 <misc> a long term project is just 2 related short term project :)
19:52:27 <anaselli> dmorgan: i will add mine after having a breafing with you later :)
19:52:29 <ennael> sure but still we need ideas
19:52:30 <ennael> :)
19:52:38 <dmorgan> anaselli: sure :)
19:52:47 <dmorgan> ennael: we will have :þ
19:52:51 <spturtle> people can write tech specs for mageia 42 if they want, those would be long term projects
19:53:13 <brianb> mageia 42?
19:53:16 <rda> hey, we could number mageia releases only by prime numbers
19:53:23 * ennael slaps rda
19:53:30 <AL13N> well, let's add specs first, and perhaps we can use those to see which cycle is best
19:53:30 <dmorgan> brianb: yes the one after mageia 41
19:53:38 <dmorgan> brianb: and before mageia 43
19:53:39 <dmorgan> :)
19:53:42 <AL13N> rda: +1
19:53:57 <brianb> what the 4 in relationto?
19:54:09 <ennael> when release cycle is decided then we can finalize choice on technical proposals
19:54:17 <anaselli> ennael: ideas are free... realizing them is harder :D
19:54:21 <ennael> brianb: 42 is the answer
19:54:34 <anaselli> ennael: always 42 :D
19:54:36 <obgr_seneca> to, the life, the universe and all the rest
19:54:45 <brianb> ok
19:54:54 <ennael> ok before getting mad shall we close that specific topic ?
19:55:29 <anaselli> fine for me
19:55:31 <Stormi> ok
19:55:39 <spturtle> yes, maybe wiki page must be announced on ml though
19:55:48 <ennael> spturtle: it will be
19:55:50 <AL13N> obgr_seneca: "... and everything"
19:55:56 <ennael> together with release cycle discussion
19:56:37 <spturtle> ok!
19:56:42 <ennael> ok
19:56:46 <AL13N> ok
19:56:51 <ennael> any other topic ?
19:56:57 <spturtle> mentoring forgotten?
19:57:03 <ennael> mmm yes
19:57:15 <ennael> #topic relaunching mentoring
19:57:30 <ennael> ok quick word about this
19:57:41 <ennael> we do have now new packagers and new trainees
19:57:56 <ennael> we think we can improve this
19:58:05 <dmorgan> s/can/must/ :)
19:58:13 <ennael> in same time we are lacking resources on triage team
19:58:26 <ennael> so I thought about one proposalfor new comers
19:58:48 <ennael> spend a given time to help in triaging to be more familiar with distribution and process
19:58:59 <ennael> wdyt?
19:59:08 <Stormi> + help fixing some bugs
19:59:11 <ennael> yep
19:59:23 <anaselli> and if they want to do packaging... they could package the fixing :)
19:59:28 <misc> yes
19:59:28 <dmorgan> ennael: ML
19:59:28 <dmorgan> :þ
19:59:29 <AL13N> i'm not in triaging, but isn't it more usefull for a triager to be an experienced packager?
19:59:34 <dmorgan> ennael: sound like a good idea :)
19:59:43 <obgr_seneca> Shouldn't you already be familiar with distribution and process to be able to help in triaging?
19:59:43 <spturtle> I would say mainly fixing some bugs as part of traineeship
19:59:47 <misc> AL13N: people do gain experience by that
19:59:52 <misc> spturtle: yes
19:59:54 <AL13N> true
19:59:55 <spturtle> + packaging
20:00:26 <misc> and fixing is also triaging , to grasp what is a bug, how to ask for more information, etc
20:00:35 <Stormi> ahmad78 will organize their triaging work I suppose ?
20:00:50 <ennael> well another point is we need to clone ahmad78
20:00:59 <ennael> *fear*
20:01:10 <misc> some of you may have seen http://blogs.gnome.org/bolsh/2011/05/31/effective-mentoring-programs/ , but one of the advice is "have small task" and I think bug triaging is more suited for that than packaging a huge software
20:01:11 <erzulie> [ Safe as Milk >> Blog Archive >> Effective mentoring programs ]
20:01:28 <misc> ( I also advice to mantor to read the article, if not done already )
20:01:33 <anaselli> ennael: yes cloning was the topic i wanted to discuss later :)
20:01:46 <ennael> misc: can you add it in mentoring_start page ?
20:02:11 <ahmad78> Stormi: that should be part of the job of their mentors, I think
20:02:14 <saispo> hi all
20:02:20 <misc> ennael: yes
20:02:33 <Stormi> ahmad78: but their mentors may not be good triagers themselves
20:02:38 <Remmy> I think it's not really fair to have people wanting to package to first do triaging for months, then ask for a mentor, who isn't available
20:02:43 <Remmy> and then have them give up and walk away
20:02:46 <Stormi> we need guidelines, and people to answer questions
20:02:51 <ennael> Remmy: it's not for onths
20:02:52 <ennael> months
20:03:01 <Remmy> Still, you are raising the barrier.
20:03:20 <Stormi> ahmad78: have the mandriva triaging wiki pages been migrated ?
20:03:31 <ennael> well experience shows for now that beginners take months to be able to  get an account
20:03:34 <brianb> is there a mentor policy?
20:03:43 <ahmad78> Stormi: sure, but dumping organising the triage work of all new comers on one guy is wishful thinking
20:03:44 <stblack> triage could be the first step
20:03:47 <ennael> because there are lacking practise
20:03:47 <spturtle> note also that triaging issues may be related to missing maintainer db
20:03:47 <ahmad78> Stormi: yes they have
20:03:50 <brianb> under mageia policies
20:04:00 <misc> brianb: no, there isn't
20:04:00 <Stormi> ahmad78: ok
20:04:04 <Remmy> Looking how few new packagers Mageia got till now, and how many have expressed interest, suggest the mentoring process needs fixing and perhaps not the ones wanting to be mentored.
20:04:13 <spturtle> and fixing new bugs is better than triaging, 1 step instead of 2
20:04:15 <misc> Remmy: so what would be the proposal ?
20:04:18 <ennael> http://mageia.org/wiki/doku.php?id=mentoring_start
20:04:18 <erzulie> [ mentoring_start [Mageia temporary wiki] ]
20:04:22 <ennael> as a reminder
20:04:38 <Stormi> I also think that fixing bugs is better for trainees than just triaging
20:04:39 <Remmy> misc: If there are no mentors, don't require mentorship, or do group mentoring... on the -dev list
20:04:54 <misc> Remmy: that's already what is also done
20:04:55 <Stormi> but : packaging a little soft is easier than fixing bugs
20:05:18 <Remmy> That's not what the documentation says though... following the documentation it's near impossible to get started packaging.
20:05:19 <spturtle> Stormi: depends
20:05:19 <Stormi> (as a start, because in the long run you have to be able to fix bugs)
20:05:24 <misc> Stormi: all easy softs are already packaged, most of the time
20:05:31 <ennael> pb is packaging is also being able to follow a software and fix bugs
20:05:42 <Remmy> (This is no complaint directed at anyone in particular, just an observation)
20:05:46 <ennael> not only pushing new version
20:05:50 <misc> last time I did a teaching, I spend hours to find something easy to package and interesting
20:05:59 <Stormi> misc: in other distributions yes, but we have less packages so more opportunities
20:06:05 <ahmad78> (I became a packager so that I don't have to wait too long for trivial fixes, kind of being proactive instead of triaging and then watching the report rot due to lack of time of the maintainers/devs)
20:06:34 <ahmad78> Stormi: less packages, is a word I wouldn't use to describe Mageia...
20:06:45 <ennael> quality of a distribution depends also on the ability of packager to do some good integration and bug fixinf
20:06:48 <Remmy> And speaking of triaging, we should have a way to mark a "new RPM package request" as triaged, even when it's not packaged yet.
20:06:49 <ennael> fixing
20:07:04 <spturtle> I would like to see a report about current trainees, how many do we have, how far are they
20:07:17 <ennael> http://mageia.org/wiki/doku.php?id=packages_mentoring
20:07:17 <erzulie> [ packages_mentoring [Mageia temporary wiki] ]
20:07:18 <ahmad78> Remmy: just adding the "Triaged" stamp is a useless bureacracy ATM
20:07:18 <spturtle> and how many people are waiting for a mentor
20:07:18 <ennael> for now
20:07:29 <ennael> we have to improve that part
20:07:32 <misc> spturtle: http://mageia.org/wiki/doku.php?id=packages_mentoring#current_mentoring is a start
20:07:33 <erzulie> [ packages_mentoring [Mageia temporary wiki] ]
20:07:56 <brianb> and potential trinees waiting for mentoring should also be included in the report!
20:08:02 <Remmy> ahmad78: Well, I faint if I look at the number of untriaged open bugs
20:08:07 * ennael will propose some improvments in taht page
20:08:17 <ennael> give me one week and we can speak again
20:08:22 <Stormi> Remmy: exlude package requests in the query :)
20:08:24 <ahmad78> Remmy: you shouldn't, that's not a measure
20:08:53 <brianb> i have a proposal
20:08:54 <Remmy> Would be nice if someone would keep track of mentoring requests so we don't get people who asked back in September still waiting for any sort of response.
20:08:59 <ahmad78> Remmy: the whole "triaged" keyword idea is:
20:08:59 <ahmad78> - triage team works on the bug
20:08:59 <ahmad78> - the maintainer only looks _after_ it's been triaged
20:09:05 <ahmad78> that never worked in reality
20:09:15 <ahmad78> maintainers do read the bug ML
20:09:20 <ahmad78> and they fix when they can
20:09:27 <ennael> because triage team is also much too small
20:09:45 <ahmad78> true, but also some packagers are bugzilla-active
20:09:56 <ennael> yep which is good
20:10:01 <spturtle> bugs will be assigned automatically I hope
20:10:11 <misc> spturtle: that's the idea
20:10:21 <spturtle> for the maintainer(s) triaging bugs on their packages is not hard
20:10:25 <misc> spturtle: the amahad-cloning project is not working well
20:10:32 <ahmad78> (e.g. you had fcrozat reading every bug report, you have tv doing search/triaging all the time in Mageia; mikala is always quick on the kde bugs.. etc)
20:10:49 <Remmy> Bottom line seems to be: Everyone is overloaded, new people have a hard time starting for whatever reason, an things fall through the cracks.
20:10:51 <ahmad78> FWIW, more triage team members will _require_ a maintainers DB
20:11:05 <ennael> #action ennael will propose some improvments on mentoring process
20:11:19 <ennael> ok maintainers db
20:11:23 <ennael> rda: ping ?
20:11:24 <brianb> i totaly agree with Remmy
20:11:29 <Remmy> Bottom line #2: I fear people will roll their eyes when I speak and I'd like to be able to assist more as time permits it instead of griping.
20:11:32 <spturtle> do need a mentoring manager who actively keeps track of trainees and new requests, and also asks current packagers to be mentor for at least 1 trainee
20:11:49 <misc> ennael: the maintainer db is packaged, but it seems the communication didn't occurs
20:11:54 <rda> hm?
20:11:59 <ennael> misc: communication ?
20:12:12 <misc> ennael: shikamaru did a rpm, but sysadmin didn't notice it was uploaded
20:12:20 <ennael> outch
20:12:28 <ennael> can we solve this in coming days ?
20:12:40 <misc> we could, provided no other task come in
20:12:42 <rda> packaged?
20:12:51 <rda> but who finished it before?
20:13:21 <spturtle> mageia-maintainers-database-0.0-2.mga1.src.rpm
20:13:35 <spturtle> it's not finished I'm afraid, but we have to start somewhere
20:13:42 <brianb> wht cant new people who want to be mentored in packaging be assigned to help out the prople who are packinging and developing  i.e. if someone is intrested in kernels then work with the person responable for kernel packaging
20:13:57 <rda> ok... but I don't really see the point of packaging something that is likely to be a live app most of its starting time
20:14:11 <rda> anyway. if this packaging loop can be automatic, good.
20:14:30 <rda> for maintdb, we first need someone to take from where it is and push it further (rails app)
20:15:31 <spturtle> brianb: sure that's why it helps if people looking for a mentor tell what they would like to package/maintain
20:15:35 <brianb> apart from asiging a mentor manage there should be an official policy on mentoring
20:15:51 <ennael> okok
20:15:52 <brianb> .. manager..
20:16:03 <ennael> let see maintainers db later with webteam and sysadmin
20:16:06 <rda> volunteer for maintdb progress => #mageia-web and mageia-webteam@ ml please
20:16:28 <misc> brianb: a mentor manager to do what ? to tell to volunteer that are already having too much people to take more people ?
20:16:52 <Stormi> would it help to have junior tasks listed somewhere with a mentor attached to them ? (those wouldn't be people-related mentors but task-related mentors)
20:17:09 <misc> Stormi: yup
20:17:20 <Remmy> misc: Requiring people who want to join to have a mentor when none is available is a sure fire way to get them to leave Mageia for distribution X real fast.
20:17:34 <misc> Remmy: ok so we accept people without checking ?
20:18:05 <obgr_seneca> Remmy: We just can't accept people without any mentoring...
20:18:22 <Stormi> misc: a mentor manager would be useful to have at least someone who has a global view one current mentoring and can mediate if problems occur
20:18:23 <stewb> there is some distribution that lets you just become a packager with no barriers to entry?
20:18:23 <Remmy> I don't say I have the solution... but it seems strange for me to translate 5 times how we need help and contributors, and when they show up, they can't get started.
20:18:46 <brianb> see misc if you exclude new people who want to train as packagers who need a mentor and your agrument re the mentor manager and not having enouther mentors is mking mageai an exclusive club for only those people who can package!
20:18:51 <Stormi> and that same person could gather the junior tasks from other packagers
20:18:55 <Nanar> stewb: yes, mdv /o\
20:18:59 <ennael> tsss
20:19:05 <ennael> ok
20:19:09 <anaselli> stewb: not to most free one, debian for instance
20:19:15 <ennael> here is what I think we can improve
20:19:30 <ennael> have a list of people asking for mentoring and have it up to date
20:19:51 <ennael> follow carefully mentoring in progress and ask for status regularly
20:19:59 <misc> Remmy: so, if you do not have the solution and I do not have, what should be changed ?
20:20:06 <Remmy> I don't say to give people SVN access when they ask... but lets try to get the interested people started before they pull out their hair in frustration and leave.
20:20:08 <ennael> keep a list of mentors up to date and statsu
20:20:29 <Remmy> ennael: That sounds like a good start
20:20:32 <misc> brianb: there is no exclusion of people who want to train besides the fact that they need to train by themself
20:20:50 <ennael> I will propose it in coming week
20:20:52 <spturtle> ennael: + maintain a wiki page the explains how mentoring works
20:21:04 <ennael> give me some time to sleep and write it
20:21:08 <misc> brianb: afaik, you do not need a account to do a rpm on your local system, so people can do the training without trouble
20:21:08 <brianb> and they also need help!
20:21:10 <ennael> spturtle: this page already exists
20:21:11 <Nanar> there is  a wiki page iirc
20:21:21 <ennael> spturtle: we just have to complete it
20:21:24 <anaselli> ennael: maybe a reminder on ml from time to time with pending requests page also?
20:21:29 <misc> brianb: I didn't see much unanswered question on irc and on ml
20:21:32 <ennael> anaselli: yep
20:21:41 <Nanar> ennael: do you have url ?
20:21:58 <Nanar> to refresh memories
20:22:02 <ennael> already given tonight
20:22:03 <ennael> http://mageia.org/wiki/doku.php?id=mentoring_start
20:22:03 <brianb> what are you saying misc
20:22:04 <erzulie> [ mentoring_start [Mageia temporary wiki] ]
20:22:09 <spturtle> many stuff on the current wiki is outdated, that a wiki page exists doesn't mean much
20:22:11 <ennael> nobody reads it
20:22:13 <Nanar> ooops /o\
20:22:16 * ennael jumps over the window
20:22:21 <rda> spturtle: ?
20:22:36 <ennael> spturtle: feel free to help with it
20:22:46 <ennael> this is a wiki page it can be modified
20:22:47 <brianb> can i ask you misc when you started out as a packager did you need mentoring?
20:22:58 <spturtle> yes, I will try to help get a final wiki working
20:23:16 <misc> brianb: afaik, I didn't
20:23:18 <ennael> you will save us
20:23:37 <misc> I just sent a rpm to lenny ( contribs manager at mandrake ) and he accepted it
20:23:40 <brianb> right hope you have taken the point we are trying to make
20:23:48 <rda> about the mentoring page, if a signal can be raised when/if it reaches a stable enough status, so we can see with marcom how we can port it and make it more accessible through www
20:24:15 <brianb> so misc it would appear that all your linux experence is self taught
20:24:28 <ennael> rda: you want to add flowers and hearts?
20:24:29 <misc> brianb: is this something that is important for the meeting ?
20:24:30 <ennael> :me runs
20:24:30 <Stormi> brianb: please keep this discussion for outside the meeting
20:24:44 <rda> ennael: don't tempt me!
20:24:52 <brianb> well i think you have a big attitue problem misc
20:25:00 <ennael> ok I guess for now we can stop the meeting it's already 1h30
20:25:04 <ennael> brianb: please
20:25:14 <obgr_seneca> brianb: Could you check your attitude as well?
20:25:21 <ennael> as a reminder of our topics
20:25:25 <brianb> Remmy is right and I agree
20:25:31 <ennael> release cycle discussion
20:25:35 <anaselli> misc: i sent a pacakge to lenny too :)
20:25:37 <ennael> technical specifications
20:25:49 <ennael> improving mentoring process
20:26:02 <ennael> please take time to discuss about the 2 first subject
20:26:06 <ennael> mmm + post-mortem
20:26:16 <ennael> in a constructive way of course
20:26:17 <olorin_> Remmy: If we have resources, it could be sandboxed.
20:26:23 <AL13N> i don't feel there was a solution for mentoring process, though
20:26:42 <ennael> thanks for coming tonight
20:27:17 <ennael> #endmeeting