14:08:41 <rda> #startmeeting
14:08:41 <Inigo_Montoya`> Meeting started Wed Mar 23 14:08:41 2011 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:41 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:08:51 <rda> #topic maintdb
14:08:58 <rda> kosmas: let's start with you :-p
14:09:13 <kosmas> ok.. since i'm here :-)
14:09:37 <kosmas> ok so rda, done a lot of the interface work.
14:09:54 <kosmas> and we have started working on the post of the packages
14:10:05 <kosmas> from the build system
14:10:31 <rda> #info interface work added, implemented the creation of package/maintainer from buildsystem
14:10:37 <rda> kosmas: anything else? :)
14:10:54 <rda> I think we can start test-drive it from the buildsystem with all submissions and see how it goes
14:10:57 <kosmas> the remaining details to be worked during the following week
14:11:04 <rda> ok
14:11:15 <rda> #info still some work to do before the app is totally ready
14:11:26 <rda> #info can still be already tested from buildsystem point of view
14:11:37 <kosmas> yes, it would be good if at some point we can drive it from the buildsystem
14:11:40 <rda> #action rda will push the details so that the buildsystem posts new submissions
14:11:43 <rda> ok
14:11:56 <rda> next then
14:11:58 <rda> #topic forums
14:12:13 <rda> maat: some progress on this end. anything to add?
14:12:23 <rda> #info English forums are up, pending the layout of forums
14:12:41 <rda> #info forums team details have been updated (see http://mageia.org/wiki/doku.php?id=web:forums )
14:12:48 <rda> #info German forums in the works
14:13:00 <rda> or pasmatt for that matter? :-p
14:14:51 <rda> ok, we'll add to this later if needed
14:14:55 <rda> #topic wiki
14:15:05 <rda> obgr couldn't be here for the meeting.
14:15:19 <rda> boklm: no news on that front either?
14:15:51 <boklm> for this, packages are done, but need to be setup in puppet
14:16:15 <boklm> however I didn't find how to create mediawiki automatically, it doesn't seem to be easy to do
14:16:20 <boklm> mediawiki databases
14:16:33 <rda> ok. any idea of what this would take, or what help is needed, or when it could be done? (just asking)
14:17:04 <rda> #info mediawiki packages done (generic + our custom setup)
14:17:12 <rda> #info db creation to sort out
14:17:17 <rda> #info puppet setup to be done
14:17:32 <boklm> mediawiki has an install page to create the database, using a browser to enter parameters
14:17:49 <rda> yes.
14:17:56 <boklm> and I was looking at how we could automate this using puppet
14:18:23 <boklm> but this require taking code from the install page and change it, so this is not very simple
14:18:24 <rda> ok
14:18:52 <boklm> so for now I think we'll do the setup manually using the install page
14:18:53 <rda> and... couldn't we install a default setup with the browser page, see the diff in config and db and then use that as a copy for puppet setup?
14:18:58 <rda> ok
14:19:37 <rda> I'd like too to make sure the final setup will look like what we need (a single code base, specific config files per locale, all locales, English included, distributed as http://wiki.mageia.org/{locale}/ )
14:19:55 <rda> will we be able to test the setup before we deploy in prod?
14:20:35 <boklm> rda: hmm, maybe I can do an install, dump the database, and use this dump to create new ones
14:20:56 <boklm> rda: yes, we will be able to test it before we deploy
14:20:56 <rda> boklm: there will necesarrily be differences depending on locales, but that could be a start.
14:21:00 <rda> ok, cool.
14:21:32 <rda> #info default mediawiki is done through a web page, difficult to port to a puppet setup script
14:22:00 <rda> ok, anything elsE?
14:22:53 <boklm> not for wiki
14:29:32 <rda> ok
14:29:43 <rda> any other topic one would want to discuss?
14:30:10 <rda> I did not get comments on the web sites direction doc I pushed past week
14:30:11 <rda> http://mageia.org/wiki/doku.php?id=web:website
14:30:17 <rda> any comments here already?
14:30:26 <rda> or should we proceed with that?
14:36:13 <rda> ok then :-p
14:36:27 <rda> thanks for coming by
14:36:30 <rda> #endmeeting