14:20:40 <rda> #startmeeting
14:20:40 <Inigo_Montoya`> Meeting started Wed Mar 16 14:20:40 2011 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:20:40 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:21:01 <rda> #chair damsweb boklm maat obgr_seneca
14:21:01 <Inigo_Montoya`> Current chairs: boklm damsweb maat obgr_seneca rda
14:21:09 <rda> #topic review: wiki
14:21:21 <rda> boklm: so, do you have news? :)
14:21:25 <rda> obgr_seneca: ping
14:21:33 <obgr_seneca> pong
14:21:46 <boklm> for the wiki, I sent an email last week, about some change that I think are needed
14:21:57 <obgr_seneca> boklm: didn't get to it
14:22:06 <boklm> and I started doing the changes and imported mediawiki package on the svn
14:22:14 <rda> ha, and I didn't post my draft answer to it /o\
14:22:22 <obgr_seneca> saw your email but had so much things on my mind
14:22:43 <maat> yup
14:22:50 <boklm> so for now there is a mediawiki package on the svn (not tested yet)
14:22:56 <boklm> and what remains to be done is :
14:23:02 <boklm> - packages for plugins
14:23:03 <rda> does it support multi-locale install?
14:23:06 <obgr_seneca> boklm: is it a standard setup?
14:23:24 <boklm> obgr_seneca: yes, standard setup
14:23:40 <boklm> rda: multi wiki install is done in the config file, so it should support it by changing the config file
14:24:22 <rda> boklm: so it does trigger creating a new database, and new tables as well?
14:24:23 <obgr_seneca> boklm: you need either multiple sourcecode installations each with a config of it's own
14:24:42 <obgr_seneca> or some kind of script like the LocalSettingsChanges.php I wrote
14:26:06 <boklm> rda: database are not created by the package, so it has to be done using something else, for instance using the script created by obgr_seneca which we can add to puppet
14:26:41 <rda> ok, and can it still source modifications from a source repository, or should every change be packaged (thinking of templates or specific code changes)
14:26:44 <rda> ?
14:27:19 <boklm> rda: for templates, we can point to an additional directory in the config
14:27:22 <obgr_seneca> rda: most template stuff is done in the configuration that is not packaged
14:27:35 <rda> ok, same for forcing a cache refresh?
14:27:51 <boklm> rda: so we can store the templates on svn, checkout the templates somewhere and point that directory in the config
14:28:02 <rda> ok, sounds good then
14:28:16 <rda> so, where are we at, then? (backlogging)
14:28:26 <boklm> however if we need to change code in mediawiki, we'll have to update package
14:28:35 <rda> ok
14:28:38 <boklm> (but it should not happen often)
14:28:44 <rda> #info boklm imported mediawiki onthe svn
14:28:51 <rda> no, I guess. mostyl at the beginning
14:28:59 <rda> boklm: do you have a pointer to the repository?
14:29:11 <rda> after that, what's left to be done?
14:29:46 <boklm> http://svnweb.mageia.org/packages/cauldron/mediawiki/current/
14:29:52 <boklm> after that what's left :
14:29:54 <obgr_seneca> boklm: should I rewrite my script not being interactive like you wrote in your email?
14:30:02 <obgr_seneca> or do you?
14:30:03 <boklm> obgr_seneca: yes
14:30:24 <boklm> obgr_seneca: I will do it if you don't have time to do it
14:30:29 <obgr_seneca> ok, I'll use some variables I define on top and not use any interactive stuf
14:30:34 <boklm> ok
14:30:45 <boklm> so what's left :
14:30:52 <rda> #link http://svnweb.mageia.org/packages/cauldron/mediawiki/current/
14:30:59 <boklm> - package mediawiki plugins
14:31:15 <rda> #action rewrite config script to be non-interactive
14:31:15 <boklm> - update database script to be not interactive
14:31:25 <rda> #action package mediawiki plugins
14:31:40 <boklm> - setup mediawiki and config files in puppet
14:31:50 <rda> #action setup mediawiki, config files in puppet
14:31:57 <boklm> and create a theme
14:32:01 <rda> is the ldap auth tested/working or not yet?
14:32:05 <rda> #action design a theme
14:32:23 <obgr_seneca> rda: I haven't done it not knowing much about ldap
14:32:26 <rda> well, the theme will come later as it should match mageia theme (that's still under ... thinking at best)
14:32:30 <rda> obgr_seneca: ok
14:32:44 <boklm> rda: I saw some discussions with buchan about ldap, but I didn't test yet
14:32:46 <rda> #action test/ensure ldap auth works as expected (and define roles to be used by mediawiki)
14:33:26 <rda> ok. can we have an estimate for each action? like, config/plugins/puppet by next week? or too optimistic?
14:33:54 <boklm> I think it should be possible by next week
14:37:00 <rda> ok, cool
14:37:14 <rda> then we could consider having a wiki to test drive in two weeks
14:37:26 <rda> #info packaging/setup/puppet config could be ready next week
14:37:29 <boklm> I think yes
14:37:35 <rda> that would be excellent
14:37:47 <rda> #info expected test-drive wiki on week 13
14:37:55 <rda> next topic?
14:38:08 <rda> #topic review: maintdb
14:38:36 <rda> kosmas and me did some progress on the app (cleaning stuff out, updating the UI, following the spec better)
14:39:03 <rda> it's not yet ready (we still need to have the build system capable of posting a (package,maintainer) tuple to the maintdb
14:39:07 <rda> but it looks really near
14:39:24 <rda> #info not ready yet, good progress since past week
14:39:33 <rda> #info expected test-drive on week 12
14:39:51 <rda> #topic forum
14:40:03 <rda> maat: your turn! :) (and boklm, if you have some info as well?)
14:43:11 <rda> maat: O-nid: ping pong
14:43:19 <boklm> so forums are now online
14:43:21 <maat> ha
14:43:26 <maat> yup
14:43:36 <rda> http://forums.mageia.org/en and http://forums.mageia.org/ not working
14:43:44 <maat> forums are online https://forums.mageia.org/en
14:43:49 <rda> neither in https
14:44:02 <maat> Categories and forums created
14:44:09 <maat> http forwards to https
14:44:23 <rda> ha, sorry, wrong /etc/hosts (old)
14:44:30 <boklm> rda: ah, missing / at the end (we probably have to add a redirect)
14:44:55 <boklm> https://forums.mageia.org/en/ is working but not https://forums.mageia.org/en
14:45:31 <maat> users are pushed to identity when they want to register (thanks boklm to push the idea... it was less complex than i thought)
14:45:33 <rda> ok
14:45:35 <obgr_seneca> only /en or other languages as well?
14:45:47 <maat> obgr_seneca: atm only /en
14:45:52 <obgr_seneca> ok
14:45:53 <rda> #info forums online at http://forums.mageia.org/
14:46:01 <rda> is there any plan to open /fr and other languages?
14:46:03 <maat> but the structure is thought to host others
14:46:03 <boklm> (it think it was idea coincoin who pushed the idea)
14:46:07 <coincoin> yep :p
14:46:12 <maat> heu
14:46:18 <maat> oup's you're right
14:46:18 <rda> or to redirect /{locale} to an external site?
14:46:29 * maat apologises to coincoin
14:47:12 <maat> main user groups are created
14:47:54 <boklm> I think it was planned to use MLO forums for french forums
14:47:56 <maat> but we must wait that people log in once to be able to put them in groups
14:47:59 <rda> ok, cool
14:48:08 <rda> #info forums accounts are tied to identity accounts
14:48:40 <rda> boklm: then /fr should redirect to mlo forums (and we have an inconsistency regard accounts, but that's another thing)
14:48:57 <boklm> rda: yes
14:49:03 <rda> we should use http://forum.mageia.org/{locale} as a canonical url for all forums, and redirect when appropriate
14:49:08 <rda> +s
14:49:14 <rda> (or without)
14:49:26 <rda> who's going to moderate it?
14:50:41 <maat> there are 6 or 7 global moderators
14:51:08 <maat> i think some people will get partial moderation rights on sub forums
14:51:23 <maat> like support team
14:51:32 <rda> maat: but who are they? (are they listed on the wiki page, or have a specific group in ldap already?)
14:51:42 <rda> maat: yep, sounds sensible, but should be documented
14:51:57 <maat> yup
14:52:15 <maat> atm the list not public yet
14:52:41 <maat> i can give it if you want
14:53:23 <rda> should be public asap. I can put it on the wiki if you like, I'm going to organize the page.
14:53:35 <maat> yup
14:53:49 <rda> maat: so, many, many, many thanks for setting this up! :)
14:53:56 <maat> i think i pushed it to sysadmins
14:53:57 <rda> we do have a forum now \o/
14:53:59 <boklm> how is the moderators list managed ?
14:54:13 <boklm> is it in phpbb database, or in ldap ?
14:54:18 <maat> phpbb
14:54:19 <rda> boklm: I'm putting the list of forums to redirect to on http://mageia.org/wiki/doku.php?id=forums
14:54:24 <boklm> rda: ok
14:54:56 <maat> putting it in ldap would require a really intrusive patch in phpbb users/groups management classes
14:55:00 <boklm> ok
14:55:11 <maat> i think in due end it will be unavoidable
14:55:37 <maat> but for the while we are going to use phpbb offered features :)
14:55:39 <rda> we'll see
14:55:45 <rda> :)
14:55:46 <rda> cool
14:56:10 <rda> maat: boklm: misc: thanks a lot for putting this in motion, evenwith the frictions! :)
14:56:23 <rda> #link http://mageia.org/wiki/doku.php?id=forums forum wiki page
14:56:25 <maat> you're welcome :)
14:58:08 <rda> maat: should we use a dedicated irc channel for the forums team or web channel?
14:58:10 <rda> or other?
14:58:19 <rda> I mean, for forum admins/moderators
14:58:28 <maat> well
14:58:44 <maat> i don't think moderators will use a lot irc
14:58:52 <rda> mailing-list then?
14:58:59 <maat> i'll bet on mailing list
14:59:03 <rda> ok
14:59:17 <maat> (already created)
14:59:22 <rda> and who in the list would like to drive the forums team?
14:59:25 <rda> ho? where?
14:59:27 <obgr_seneca> wouldn't an internal area in the forum be perfect for the forum moderators?
14:59:50 <maat> the is one also
14:59:56 <rda> are both public?;
15:00:12 <maat> but for notifications, alerts and things like that the mail is better
15:00:19 <maat> nope
15:00:21 <obgr_seneca> ok
15:00:24 <rda> :-/
15:00:35 <rda> maat: the list is not @mageia?
15:00:40 <maat> it is
15:00:49 <maat> i think
15:00:54 <maat> well
15:01:00 <maat> perhaps still zarb ?
15:01:17 <rda> doesn't show up on ml.mageia.org or mageia.org/mailman (or I need new eyes)
15:01:28 <obgr_seneca> Is it "@mageia" or "@ml.mageia"?
15:01:52 <rda> or the list isn't public?
15:02:13 <rda> (it should at least have one list public for most communication there)
15:02:19 <maat> it is @mageia
15:02:32 <maat> well
15:02:59 <maat> i dont understand de need of a public ml for moderators
15:03:32 <maat> for public things about forum... we have the forum
15:04:08 <rda> well, it just is crucial that the team activity is public and that it does not look hidden/restrained in any way.
15:04:22 <rda> so that it happens through the forum or the list, I don't know, but it's important to have public archives.
15:04:35 <rda> (and made clear where to go to get access to these)
15:04:39 <obgr_seneca> rda: but there are things when moderating a forum, you have to discuss in private
15:04:39 <maat> for private dealing of legal threats, calls to moderators and so on we can not publish thoses
15:04:56 <rda> for these, there can be a private channel, yes
15:05:17 <rda> but that does not remove the importance of showing public activity somewhere (and meeting summaries, if ever)
15:05:32 <maat> if we publish alerts like "you bastards make this son of a bitch shut the fuck up" people will want to kill each other
15:05:36 <rda> that's why the moderators list should be quickly public on the forums wiki page, and kept up to date
15:05:43 <rda> maat: :)
15:05:50 * rda agreed
15:06:08 <rda> ok, cool.
15:06:14 <rda> what would be next steps for the forum now?
15:06:17 <maat> meeting summaries okay
15:06:35 <boklm> do we need to create forums in other languages ?
15:06:39 <maat> and periodic reports of activities and decisions ok too :)
15:06:53 <rda> boklm: ah yes, we need too to write the process to ask for a new locale forum
15:06:58 <rda> maat: cool :)
15:07:13 <rda> a new language-forum should be created if there are enough people to manage it (moderator, admin)
15:07:24 <rda> and those can work within the global forums team
15:07:36 <rda> that coordinates all
15:07:40 <maat> yup
15:09:17 <maat> we'll have later to adapt templates to match mageia graphical chart
15:09:42 <rda> yes
15:09:51 <rda> which chart has to be designed first (same again) :-p
15:09:52 <maat> and add nice features... linking bugs<->forums, mailings<->forums
15:10:09 <rda> ouch. :) let's see if we can write down the use cases but why not.
15:10:14 <maat> add tagging to ease searching (semantic ?)
15:10:18 <rda> ah, yes, and an idea section (voting up/down for ideas)
15:10:34 <maat> that can be done easily :)
15:10:41 <rda> cool
15:10:47 <rda> ok, next topic then
15:10:52 <rda> #topic website(s) direction doc
15:10:56 <rda> has anyone read my doc?
15:10:57 <rda> :-p
15:11:00 <Stormi> I
15:11:07 <Stormi> sorry I forgot our meeting !
15:11:49 <obgr_seneca> rda: not yet, sorry
15:12:11 <rda> ok. anyone ? :)
15:12:32 * coincoin raise his hand
15:12:51 <rda> coincoin: good boy
15:13:07 <rda> anyone else? :-p
15:14:42 <rda> ok, let's postpone this, then.
15:14:47 <rda> #undo
15:14:47 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Topic object at 0x82a4a4c>
15:14:52 <rda> any other topic to discuss?
15:15:34 <Stormi> you probably already saw that mageia-app-db has an updated roadmap and a new ML
15:15:42 <rda> #topic mageia-app-db
15:15:53 <rda> ha, good point. Stormi could you remind us?
15:15:55 <rda> #chair Stormi
15:15:55 <Inigo_Montoya`> Current chairs: Stormi boklm damsweb maat obgr_seneca rda
15:16:04 <rda> (links, info)
15:16:39 <Stormi> #info updated roadmap for mageia-app-db : http://mageia-app-db.tuxette.fr/projects/mageia-app-db/roadmap
15:17:11 <Stormi> #info mailing list for mageia-app-db : https://listes.lautre.net/cgi-bin/mailman/listinfo/madb
15:17:47 <Stormi> #info next milestone is version 0.2 due on 2011-03-31, which features automated synchronization to sophie
15:18:18 <Stormi> do you have questions ? :)
15:18:25 <rda> ouch, huge 0.2 milestone :)
15:18:44 <Stormi> the next milestone always appears bigger because tickets are more detailed
15:18:58 <rda> oh ok
15:19:07 <rda> Stormi: how many are you on it?
15:19:19 <Stormi> ttp and I are the main developers
15:19:44 <Stormi> and we get help from time to time from other people
15:20:01 <rda> ok, cool.
15:20:13 <Stormi> but you know well how it's hard to make people pass from "I want to help" to have them really doing things regularly :)
15:21:01 <rda> oh yes :)
15:21:14 <rda> ok, fine.
15:21:14 <Stormi> the mailing list may help, we will see
15:21:32 <Stormi> the plan is :
15:21:34 <rda> hopefully, yes. we can make the list of various projects from the web team page more obvious.
15:21:39 <Stormi> have a working version deployed for mageia 1
15:21:50 <Stormi> maybe not full-featured, but usable
15:22:11 <Stormi> and I would like to deploy it even earlier to have it used on cauldron if deemed useful
15:22:41 <Stormi> I must see with the sysadm team what's possible
15:23:14 <Stormi> I'm done :)
15:23:31 <rda> ok cool.
15:23:33 <rda> any other thing?
15:23:47 <coincoin> I think we should see with i18n how to manage www/blogs translations (as for example, es/pl/tr/..., are often missing or arrive very late)
15:25:05 <rda> #topic translations
15:25:24 <rda> #info see with i18n how to manage www and blog translations (tools, process, team motivation)
15:25:43 <rda> ok
15:26:12 <rda> thanks everyone for coming and for your reports and your work!
15:26:17 <coincoin> \o/
15:26:33 <rda> let's keep on and aim for a great whole website for beta1
15:26:37 <rda> #endmeeting