14:06:14 <coincoin> #startmeeting
14:06:14 <Inigo_Montoya> Meeting started Wed Feb 16 14:06:14 2011 UTC.  The chair is coincoin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:14 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:06:41 <coincoin> #chairs boklm dmorgan kosmas Clod Jehane leeloo
14:06:46 <coincoin> #chair boklm dmorgan kosmas Clod Jehane leeloo
14:06:46 <Inigo_Montoya> Current chairs: Clod Jehane boklm coincoin dmorgan kosmas leeloo
14:07:05 <coincoin> #chair obgr_seneca
14:07:05 <Inigo_Montoya> Current chairs: Clod Jehane boklm coincoin dmorgan kosmas leeloo obgr_seneca
14:07:22 <coincoin> maat|alt: ping?
14:07:43 <coincoin> kosmas: we start with maint-db?
14:07:48 <coincoin> #topic maint-db
14:07:54 * blingme is here
14:08:09 <coincoin> #chair blingme
14:08:09 <Inigo_Montoya> Current chairs: Clod Jehane blingme boklm coincoin dmorgan kosmas leeloo obgr_seneca
14:08:35 <coincoin> so what new for maint-db? sorry with the alpha I'm late with mails...
14:08:44 <kosmas> ok. not a lot of progress and we might go back a bit, since there is a small problems with rpms needed to be installed in the live environment
14:08:44 <coincoin> any info to share?
14:09:13 <kosmas> send an earlier msg to ML for Michael to let me know what we can use (stack for live)
14:09:55 <kosmas> also got in touch with the web-dev to see if i can help build some packages there
14:10:16 <coincoin> #info kosmas send a mail on the ML to give info about packages
14:10:19 <kosmas> so the plan is to find out what I can use and then redo the app with the minimum features needed
14:10:23 <coincoin> #undo
14:10:23 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x8678a2c>
14:10:27 <coincoin> #info kosmas sent a mail on the ML to give info about packages
14:10:49 <coincoin> kosmas: the issue is package versionning right?
14:11:54 <kosmas> the issue is that when I started there was no mention about ruby version, or gems that I could use. so I used the latest. But then it turned out that we cannot use the latest ones in the live server.
14:12:06 <stormi> hi
14:12:13 <stormi> sorry for being late :)
14:12:24 <coincoin> hello stormi
14:12:27 <coincoin> #chair stormi
14:12:27 <Inigo_Montoya> Current chairs: Clod Jehane blingme boklm coincoin dmorgan kosmas leeloo obgr_seneca stormi
14:12:32 <Clod> hi stormi
14:12:38 <kosmas> hi stormi
14:13:04 <boklm> kosmas: so, is it planned to backport to previous version ?
14:13:40 <boklm> to backport maint-db to older version of ruby
14:13:54 <coincoin> #info kosmas used the latest ruby version by thinking we will have it on server.
14:14:12 <kosmas> Yes afaik. Waiting for reply from Michael what version I should be building it. I believe it should be with versions in 2010.2 but waiting form confirmation.
14:14:47 <boklm> yes, we are currently using 2010.2 on the servers
14:15:01 <coincoin> #action kosmas see with misc for the ruby package to use
14:15:40 <boklm> we have this version installed at the moment: ruby-1.8.7.p249-4mdv2010.1
14:16:08 <kosmas> that is fine.. it's more about the rails rpm..
14:16:18 <coincoin> #info as puppet also use ruby, we must be careful with the package installed on server
14:16:36 <kosmas> do you know what you have or can be installed 2.3.11 maybe?
14:17:25 <blingme> 2.3.10 seems to be available
14:17:53 <kosmas> that is good as well, but there was a security announcement last week about it...
14:18:24 <kosmas> http://weblog.rubyonrails.org/2011/2/8/new-releases-2-3-11-and-3-0-4
14:18:55 <kosmas> so it maybe better, depending on work involved, to get 2.3.11 packaged
14:18:58 <boklm> yes
14:19:00 <blingme> kosmas: well, AFAIK, servers are still running mandriva (probably at least until stable mageia release)
14:19:19 <blingme> and 2.3.10 is in contrib/backports, while contrib/release has 2.3.4
14:19:20 <coincoin> #action we need someone to package ruby 2.3.11 as it's a sec update (we have 2.3.10 for now)
14:19:27 <coincoin> boklm: wanna package it? :p
14:19:39 <blingme> so if mandriva pushes 2.3.11 to contrib/updates, no problem
14:19:40 <boklm> hmm, I didn't see 2.3.10 is in backports
14:19:42 <blingme> :maint rails
14:20:47 <coincoin> #undo
14:20:47 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x8678f6c>
14:20:56 <coincoin> #action we need someone to package rails 2.3.11 as it's a sec update (we have 2.3.10 for now)
14:21:32 <kosmas> coincoin: I'll have a look to see if i can help with that. but haven't done any packaging before :-(
14:22:30 <boklm> so we need to find someone to maintain this package
14:22:31 <coincoin> kosmas: great but perhaps to be more reactive for this point we should ask a packager to have it ready soon
14:22:43 <kosmas> true :-)
14:23:56 <coincoin> kosmas: can you ask on -dev for a mainteners for rails?
14:24:18 <boklm> so we need to find a maintainer for this on mageia, and he can help with backports on 2010.2
14:24:57 <kosmas> i believe it is shikamaru, yes I will get in touch.
14:26:33 <coincoin> #action kosmas ask shikamaru if he want to be the maintainer of rails
14:26:57 <coincoin> kosmas: any other point for you?
14:27:20 <coincoin> any other help needed or point to share?
14:27:35 <kosmas> not at the moment. as we said as long as I know what to use , I can start it again.
14:28:02 <coincoin> great
14:28:08 <coincoin> so, next topic? :)
14:28:49 <kosmas> bugzilla, maybe? seems to be working and used at the moment?
14:29:02 <coincoin> #topic bugzilla
14:29:05 <coincoin> dmorgan: ping?
14:29:48 <ashledombos> hi
14:29:55 <coincoin> #topic forums
14:29:57 <coincoin> hi :)
14:30:04 <kosmas> hi ashledombox
14:30:11 <coincoin> ashledombos: so do you have any news about forums? :)
14:30:17 <Clod> hi ashledombox
14:30:35 <kosmas> sorry ashledombos (not x)....
14:30:49 <Clod> sorry
14:31:05 <ashledombos> coincoin: with maat, we spent last weekend nights to build it on our server (mandrivafr.org), as we had no access to the server
14:31:11 <Clod> my typo...
14:31:50 <ashledombos> so it's ready to work, but maat and I think it should be better, for such a web app, to have direct shell access to the server
14:31:56 <coincoin> #info ashledombos and maat spent last nights to build forum on mandrivafr.org server
14:32:05 <boklm> ashledombos: so, do you have instructions to install it ?
14:32:34 <ashledombos> boklm: ennael already sent tarball with files and postgres dump
14:32:51 <ashledombos> all git repository
14:33:09 <ashledombos> to misc
14:33:32 <coincoin> #info ennael sent tarball with files and postgress dump to misc
14:33:38 <ashledombos> so... i am waiting for informations :)
14:33:39 <boklm> so I think I have seen commits in puppet from misc installing it
14:33:42 <coincoin> ashledombos: did you sent process to install it?
14:33:55 <coincoin> yep I have seen commits too
14:33:57 <coincoin> your right ;)
14:34:05 <ashledombos> nope, after that maat|alt was in touch with ennael and rda
14:34:49 <ashledombos> if you want to see how the forum looks like
14:34:53 <coincoin> so what is the next step to have forum working? just deploying it on server? nothing else to do?
14:35:02 <ashledombos> i can give you the line to add in /etc/hosts :)
14:35:29 <ashledombos> coincoin: yes, all has already been configured
14:35:49 <ashledombos> even the linking to mageia ldap
14:36:10 <ashledombos> the forums, a welcome message
14:36:22 <coincoin> #info forum is entirely packaged: even the link to mageia ldap
14:36:22 <ashledombos> some patches
14:36:27 <ashledombos> as phpbb-seo
14:36:40 <coincoin> it's based on the last phpbb3 release?
14:36:45 <ashledombos> for the moment we use the default theme
14:36:54 <ashledombos> coincoin: yes, the last git version
14:37:06 <coincoin> great
14:37:17 <boklm> last git version ?
14:37:55 <ashledombos> just a second
14:37:58 <coincoin> #info the phpbb3 release is the last git version
14:38:07 <coincoin> stable git revision? :p
14:39:12 <ashledombos> yes but, i can't connect to it now, behind a firewall
14:39:22 <boklm> so it's the stable version ?
14:39:27 <ashledombos> yes
14:39:58 <boklm> #info misc is working on deploying php code
14:40:03 <ashledombos> please add this to /etc/hosts
14:40:05 <ashledombos> 91.121.11.63 forums.mageia.org forum.mageia.org testforum.mageia.org testforums.mageia.org devforums.mageia.org devforum.mageia.org
14:40:23 <ashledombos> and go to http://forums.mageia.org/en/
14:40:40 <ashledombos> 91.121.11.63 forums.mageia.org is enough
14:41:03 <coincoin> k, thanks you
14:41:09 <boklm> ashledombos: so misc should have all the instructions to install the forums ?
14:41:26 <ashledombos> boklm: he should, but this part was lead by maat
14:41:38 <ashledombos> he took holidays for finishing it
14:41:47 <ashledombos> this monday and tuesday
14:41:51 <ashledombos> i couldn't
14:42:16 <coincoin> so we won't have forum before next week?
14:42:21 <coincoin> so, anything else about forum?
14:43:03 <ashledombos> mmm, no, the ball is in sysadmins field :)
14:43:22 <coincoin> ok, thank you
14:43:42 <ashledombos> can you see the forum ?
14:43:57 <coincoin> will have a look next but I will try :)
14:43:58 <coincoin> #topic bugzilla
14:44:05 <coincoin> dmorgan: ping :)
14:44:32 <coincoin> so bugzilla is working as expected. alpha1 was released yesterday and bugs are comming on bugzilla
14:44:49 <coincoin> FYI dmorgan is working on upgrading it to 4.0 released yesteday
14:45:04 <coincoin> #info dmorgan is working on upgrading bugzilla to 4.0 released yesteday
14:45:12 <stormi> is he ? misc said we have more important to do
14:45:24 <coincoin> I think he is looking for help if anybody is interested in
14:45:28 <stormi> however bugzilla works at the moment
14:45:42 <stormi> only thing missing is the bugs ML in CC
14:46:11 <coincoin> stormi: yes it's working but will be better to upgrade it now rather than when the database and customization will be huge
14:46:19 <stormi> (and I wouldn't deploy the .0 release the day after it's been release :P)
14:46:21 <coincoin> yes missing bugs@ in CC
14:46:38 <coincoin> #action dmorgan need to fix the lack of bugs ML in CC of bugs
14:47:03 <coincoin> stormi: the time we will need to do it, the .1 should have been released ;)
14:47:30 <coincoin> #info a few bugs about bugzilla configuration
14:47:37 <coincoin> anything else about bugzilla?
14:48:06 <stormi> no, it just works and dmorgan maintains it well :)
14:48:24 <coincoin> #info it just works and dmorgan maintains it well :)
14:48:25 <coincoin> ;)
14:48:27 <coincoin> #topic www
14:48:33 <coincoin> boklm: your turn \o/
14:49:06 <boklm> hmm, I'm not really aware of what is being done on www part :)
14:49:14 <coincoin> not my problem :p
14:49:33 <coincoin> so, migration from zarb server to mageia server is still in progress
14:50:02 <boklm> there is a static.mageia.org vhost created for static files for the website
14:50:45 <coincoin> I think rda is still working on the new website
14:50:46 <boklm> I think rda is working on new website, but he is not here today
14:51:05 <boklm> any other people doing something on new web site ?
14:51:10 <coincoin> #info boklm created a static.mageia.org vhost for static files
14:51:34 <coincoin> boklm: I do but really few things so...
14:51:49 <coincoin> I have issue because we don't have enough rights on zarb server
14:52:12 <coincoin> #topic blog
14:52:19 <coincoin> so...
14:52:42 <coincoin> blogs should be moved from zarb server to mageia server (Gandi VM) next week
14:52:49 <coincoin> #info blogs should be moved from zarb server to mageia server (Gandi VM) next week
14:53:01 <coincoin> I still have issue with mod_rewrite
14:53:30 <coincoin> I try to find if I can have two kind of url on blogs to prevent redirecting all old post in a .htaccess
14:53:58 <coincoin> I made some tests: the migration from a server to an other one is working as expected
14:54:17 <coincoin> we still need translators for a lot of language for blogs!!!
14:54:32 <coincoin> that a big issue (not for developpers but a big issue :))
14:54:39 <coincoin> #info we still need translators for a lot of language for blogs
14:54:40 <obgr_seneca> I think that's sth. for i18n team
14:55:12 <coincoin> obgr_seneca: yes but no success for now :)
14:55:27 <coincoin> #action dams send a mail on i18n ML to recruite people for blogs
14:55:36 <coincoin> nothing else to add for me
14:55:44 <coincoin> #topic wiki
14:55:47 <obgr_seneca> end of last year it was decided in i18n to wait with further recruiting of people till the infrastructure is up
14:56:09 <obgr_seneca> So, about wiki
14:56:13 <coincoin> obgr_seneca: but infra is up since september for blogs :
14:56:19 <coincoin> obgr_seneca: your turn :)
14:56:33 <obgr_seneca> I sent my src.rpm to sysadmin team on - I think - sunday
14:56:41 <obgr_seneca> for review and fine tuning
14:56:53 <obgr_seneca> Haven't heard from them since then
14:56:58 <coincoin> #info obgr_seneca sent src.rpm to sysadmin team on sunday
14:57:08 <obgr_seneca> But there was a lot going on in the past few days
14:57:10 <coincoin> obgr_seneca: can you ping them about it?
14:57:28 <obgr_seneca> #action obgr_seneca ping sysadmin about wiki
14:57:35 <coincoin> #action obgr_seneca ping sysadmin team about hwiki
14:57:38 <coincoin> #undo
14:57:38 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x864b56c>
14:57:41 <coincoin> :)
14:58:01 <obgr_seneca> what I do need is someone with a knowledge of ldap
14:58:06 <coincoin> obgr_seneca: all was done for wiki (ldap too)?
14:58:24 <obgr_seneca> But that's really for those who actually configure it on the server
14:58:34 <coincoin> you have a new guy in the team: Clod
14:58:41 <Clod> present
14:58:46 <coincoin> prehaps do you know ldap Clod :)
14:58:47 <Clod> how can i be of help...
14:59:05 <Clod> yap..we've used that one unfortunately, using PHP...
14:59:12 <coincoin> obgr_seneca: so did you tried to ping buchan?
14:59:16 <Clod> with ADLdap library...
14:59:21 <obgr_seneca> I think packaging the ldap extension is no problem
14:59:52 <obgr_seneca> it's more or less just the configuration on site but I think that is for sysadmins to do?
15:00:08 <Clod> i'm new here so i'm not familiar with who's the champion of that and this...sorry.
15:00:30 <obgr_seneca> Clod: no prob and welcome aboard
15:00:41 <Clod> thanks..
15:00:53 <obgr_seneca> #action obgr_senecaping buchan about ldap config of mediawiki
15:01:02 <obgr_seneca> #undo
15:01:02 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x864b50c>
15:01:07 <obgr_seneca> #action obgr_seneca ping buchan about ldap config of mediawiki
15:01:48 <coincoin> obgr_seneca: ok so all is in progress, just need information...
15:01:50 <coincoin> thank you
15:02:09 <coincoin> anything else?
15:02:10 <Clod> correct ne if m wrong...you want guys the existing wiki(PHP) to authenticate in LDAP?
15:02:13 <coincoin> or next topic?
15:02:33 <obgr_seneca> Clod: The existing wiki is temporary only
15:02:43 <Clod> I see...
15:02:54 <obgr_seneca> We plan to setup a shiny new mediawiki with ldap support
15:03:11 <obgr_seneca> That will replace the dokuwiki we have right now
15:03:26 <Clod> Ok..where can I check the test server on that...probably I could be of help at least.
15:03:35 <Clod> on the mediawiki...
15:03:39 <Clod> not the old one...
15:03:49 <obgr_seneca> Clod: I'll contact you about that
15:03:55 <Clod> copy...
15:03:58 <Clod> thanks.
15:04:07 <obgr_seneca> coincoin: next topic?
15:04:21 <coincoin> #topic mageia-app-db
15:04:28 <coincoin> Clod: great, a new motivated guy! :)
15:04:32 <coincoin> stormi: your turn ;)
15:04:46 <stormi> well
15:05:01 <stormi> project goes on, there's progress done each week
15:05:05 <Clod> he..he..he.. i'll something productive than playing chess after office, ;)
15:05:15 <coincoin> :)
15:05:17 <Clod> i'll do rather...
15:05:29 <coincoin> #info mageia-app-db goes on, there's progress done each week
15:05:32 <stormi> we released a 0.1 version but without communication about it, because it's not ready to welcome critics :)
15:05:43 <coincoin> he he
15:06:01 <coincoin> stormi: if you need a call for test on blog or twitter, just ask me!
15:06:04 <stormi> we're targetting version 0.2 whose main feature will be regular synchronization with sophie's RPM database
15:06:32 <coincoin> #info version 0.2 will have regular synchronization with sophie's RPM database
15:07:01 <blingme> about mediawiki and LDAP ...
15:07:19 <stormi> we have new contributers who joined recently, for example one of them will work on e-mail and RSS notifications
15:07:45 <coincoin> stormi: do you need other contrib people?
15:08:14 <coincoin> blingme: yes? after mageia-app-db we can go back to wiki if needed
15:08:16 <blingme> I am using LdapAuthentication at work (please don't ask what mediawiki release, or php release, or Mandriva release it runs on)
15:08:21 <stormi> coincoin: we can always use help, provided it doesn't take contributers away from more urgent tasks
15:08:25 <blingme> without problems
15:08:37 <blingme> coincoin: you can return to topic
15:08:47 <blingme> (but, better to use my irc nick if you want my attention)
15:08:48 <boklm> blingme: is there a patch needed in mediawiki for this to work ?
15:08:53 <obgr_seneca> blingme: I will ping you later...
15:09:07 <obgr_seneca> boklm: it's an extension to mediawiki
15:09:08 <blingme> boklm: no, just drop the plugin, some additions to LocalSettings.php
15:09:12 <coincoin> #action dams make a call for contrib for mageia-app-db
15:09:14 <boklm> ok, so we'll try it, and see if it works
15:09:35 <coincoin> please wait for stormi to finish on mageia-app-db :)
15:09:54 <coincoin> stormi: anything else?
15:10:22 <stormi> yes, the easier way to get in touch and discuss the project or propose help is the #madb channel on freenode
15:10:41 <coincoin> #info the easier way to get in touch and discuss the project or propose help is the #madb channel on freenode
15:11:03 <coincoin> #action dams tweet about mageia-app-db channel with mageia_org
15:11:53 <coincoin> stormi: thank you for the report, anything else?
15:12:17 <stormi> I still haven't decided if we should put version 0.2 in production or wait for a later release
15:12:50 <stormi> because it's still rough and we risk a flow of critics that will make us lose time
15:12:55 <stormi> however, it can already be of use
15:13:03 <stormi> (well, once the 0.2 is ready)
15:13:16 <coincoin> perhaps you can ask for private review/test/feedback first
15:14:04 <stormi> I know it will work, people will just criticize the lack of functionalities, overall UI, and so on :)
15:14:22 <coincoin> welcome in real life ;)
15:14:24 <stormi> but the application works, within a limited set of functionalities
15:14:44 <stormi> however, we decide that later, when 0.2 is ready
15:14:48 <stormi> can*
15:15:06 <coincoin> that the way it works... but critics can help you to improve it. and think about all the positives reviews too ;)
15:15:23 <coincoin> ok so for now: we just wait for 0.2 so?
15:15:32 <stormi> I don't fear critics, just that releasing too soon may give useless critics :)
15:15:48 <stormi> yes, waiting for 0.2
15:16:11 <coincoin> #info waiting for 0.2 to ask review/test/communication
15:16:15 <coincoin> ok, thank you
15:16:23 <coincoin> going back to wiki so
15:16:24 <coincoin> #topic wiki (back to the future)
15:16:33 <coincoin> obgr_seneca, boklm; Clod, blingme :)
15:17:01 <blingme> obgr_seneca: we will need to create an LDAP account for the wiki to use to be able to list users
15:17:19 <blingme> and then you will need to configure that, password, basedn, and some other basics
15:17:47 <blingme> we will need to add these details to the puppet password lookup stuff ...
15:18:00 <blingme> and add a config template in puppet for LocalSettings.php
15:18:21 <boklm> ok
15:18:32 <blingme> besides that, just some means of managing LDAPAuthentication.php (a package? for one php file and a dep on php-ldap?)
15:18:53 <blingme> and satisfying other sysadm reqs
15:19:28 <blingme> I should be able to do it, but I haven't added passwords etc. to the puppet lookup thingy
15:20:34 <obgr_seneca> As far as I understand the wiki shell use the accounts managed through catdap
15:20:52 <blingme> CatDap allows users to register accounts in LDAP
15:20:58 <obgr_seneca> yes
15:21:30 <boklm> blingme: for the password, it should be added to /etc/puppet/extdata/common.csv on valstar
15:21:44 <obgr_seneca> so I have to package the ldap plugin (into the main package)
15:21:48 <blingme> boklm: cool, thanks
15:21:59 <blingme> obgr_seneca: maybe a separate package?
15:22:05 <obgr_seneca> and leave the rest to sysadmin?
15:22:09 <blingme> I could do it ... I should have a while back already
15:22:22 <obgr_seneca> blingme: My src.rpm builds two packages
15:22:24 <blingme> obgr_seneca: is there a mediawiki package and/or config ready for sysadm to deploy?
15:22:29 <obgr_seneca> One normal mediawiki setup
15:22:39 <obgr_seneca> and one special multilingual setup for Mageia
15:23:06 <obgr_seneca> As I said, I sent it to sysadmin-ml on sunday
15:23:24 <obgr_seneca> There currently is no Mandriva package
15:23:36 <boklm> obgr_seneca: so the 2nd one allow to setup multiple instances of the wiki, using one installation ?
15:23:47 <obgr_seneca> yes
15:23:54 <obgr_seneca> including some scripts
15:24:08 <obgr_seneca> that do the Changes in config for those different languages
15:24:45 <boklm> ok
15:25:02 <coincoin> #topic planet
15:25:21 <coincoin> so, planet.mageia.org will be up tomorrow or on Friday
15:25:41 <coincoin> I just need to finish my scrip to deploy it via puppet
15:25:49 <coincoin> #info planet.mageia.org will be up tomorrow or on Friday
15:26:02 <coincoin> nothing else to had on this...
15:26:11 <coincoin> any other topics I forgot?
15:26:30 <coincoin> Clod: did you find a new game for you free time so? :)
15:26:52 <Clod> OT:nope...just chess at chesscube, lol why?
15:27:57 <coincoin> so thank you all
15:28:00 <coincoin> #endmeeting