14:09:41 <rda> #startmeeting
14:09:41 <Inigo_Montoya> Meeting started Wed Feb  9 14:09:41 2011 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:09:41 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:10:27 <rda> #chair obgr_seneca damsweb kosmas stormi blingme dmorgan maat stef74home boklm Jehane xrogaan
14:10:27 <Inigo_Montoya> Current chairs: Jehane blingme boklm damsweb dmorgan kosmas maat obgr_seneca rda stef74home stormi xrogaan
14:10:38 <rda> who wants to start?
14:10:50 <maat> hi all
14:11:05 <maat> rda who wants to start? <-- you ;-)
14:11:14 <rda> #topic forum
14:11:18 <rda> maat: so? ;)
14:11:22 <damsweb> :-)
14:11:23 <maat> :)
14:11:27 <maat> so
14:11:40 <maat> afaik
14:11:52 <maat> the server has been installed for os part
14:11:54 * Jehane is afk, at work
14:12:09 <maat> dunno about apache/MySQL/PHP stack
14:12:39 <maat> ldap has been set up by misc so that we can test tsl connection
14:12:47 <maat> from ennael's box
14:12:58 <rda> hmm ok, what are the next steps?
14:13:25 <maat> next we need a git repos and the write access on it for ash and i
14:13:39 <rda> there is a git repository...
14:14:00 <maat> cool
14:14:09 <maat> seems i missed something
14:14:46 <stormi> can we set a firm reasonable deadline and/or milestones ?
14:15:03 <maat> then we need to fresh start from phpBB 3.0.8
14:15:14 <rda> ok.
14:15:19 <rda> wait, checking the wiki page about that
14:15:20 <maat> and re-inject the mods we already approved
14:16:20 <maat> then we need to template it with the official logo
14:16:34 <maat> (and official skin if there is already one)
14:16:41 <rda> no no. we first need it working and set up. template, logo, design, this will come later.
14:17:19 <maat> ok
14:18:09 * maat asks for git accesses to forum project repos
14:18:44 <rda> and please, please, update your wiki page about this (code repositories, upstream, middle, mageia ones)
14:18:52 <rda> and please (will setup the link, use bugzilla)
14:19:13 <ennael> If I can ad something
14:19:25 <ennael> we should have forums up for alpha
14:19:31 <maat> yes
14:19:37 <ennael> otherwise it will be a mess on ML
14:19:57 <stormi> Isn't alpha planned in less than one week ?
14:20:04 <ennael> it is
14:20:06 <obgr_seneca> next tuesday
14:20:43 <maat> ouch
14:22:53 <rda> maat: for the doc wiki page, feel free to remove unnecessary doc as time goes by and stuff gets done as well.
14:23:08 <stormi> #info forum server up, need to check LAMP stack, then phpBB 3.0.8 install + already approved mods
14:23:37 <maat> ( rda i'll need a word in private this evening )
14:24:15 <rda> maat: yes? or now, as you prefer. I won't be that much online between 6 and midnight
14:25:00 <rda> ok, next topic?
14:25:05 <rda> #topic bugzilla
14:25:06 <stormi> #action forum should be up for alpha release
14:25:10 <rda> dmorgan: around?
14:25:11 <stormi> oops too late
14:25:19 <rda> stormi: sorry :-p
14:27:19 <obgr_seneca> seems not
14:28:22 <dmorgan> rda: yes  quickly :)
14:28:52 <rda> dmorgan: so, what status?
14:28:58 <rda> #link http://mageia.org/wiki/doku.php?id=web:forums => forum wiki page
14:29:12 <rda> (ok, sorry, thinkgs will be mixed wrt forum/bugzilla)
14:30:53 <dmorgan> rda: for bugzilla i am still on it but really harder than planned, i will soon remove all from my server and try to do it cleanly i think that looking all the time the same mistakes makes me blind
14:31:11 <dmorgan> rda: saturday i mail to webteam to give the status
14:31:20 <dmorgan> and i do a general mail asking for help
14:31:33 <stormi> must bugzilla be up also for alpha release ?
14:31:59 <dmorgan> it would better
14:32:04 <obgr_seneca> It would be good, wouldn't it?
14:32:13 <dmorgan> stormi: you wanna help ?
14:32:22 <stormi> dmorgan: why not
14:32:31 <stormi> but I never did that before :)
14:32:50 <dmorgan> stormi: in about half an hour i can talk to you in private to explain what had been done and what need to be done
14:32:55 <stormi> dmorgan: ok
14:33:16 <stormi> #info bugzilla hard to setup. Stormi will try to help dmorgan.
14:33:34 <stormi> #info deadline if feasible is alpha release
14:35:08 <stormi> if we have to find compromises but that bugzilla is available for bug reports, it would be already not bad
14:35:15 <plalien> ok. but i see bugzilla at http://bugs.mageia.org/index.cgi...
14:36:23 <plalien> first for all we must up bugzilla and forum in my opinion
14:37:13 <rda> dmorgan: actually, I planned to use bugzilla as a stable now.
14:37:46 <rda> it's a matter of best effort.
14:37:53 <rda> alpha is released on Feb 15th no matter what.
14:40:23 <rda> ok... next?
14:40:30 <obgr_seneca> #topic wiki
14:40:36 <rda> hmm a last one
14:40:46 <rda> dmorgan: is it safe to post bugs already or will they be removed?
14:41:02 <stormi> #undo
14:41:02 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x863e44c>
14:41:28 <rda> dmorgan: ping :)
14:41:30 <stormi> (I'm not sure you should have chaired us all :))
14:41:43 * obgr_seneca neither
14:41:54 <rda> stormi: yes, it's better, I look at who can chair later on :)
14:42:07 <rda> ok, I'll reduce the list next time
14:44:30 <rda> well...
14:44:32 <rda> #topic wiki
14:44:36 <obgr_seneca> ok
14:44:45 <obgr_seneca> Wiki is almost ready
14:45:01 <obgr_seneca> will have it packaged till weekend for sysadmin team to have a look on it
14:45:10 <obgr_seneca> (especially the ldap part)
14:45:42 <obgr_seneca> Themeing has to be done afterwards
14:45:44 <rda> #action obgr_seneca packages wiki + locale layout + ldap for sysadmin to check it for this weekend
14:45:48 <rda> #info theme still to be done
14:45:54 <rda> yes, the theme part will be done later.
14:45:59 <rda> first, let's set up all the tools
14:46:15 <obgr_seneca> I didn't look into that at all since I don't have any theme/logo/colours and so on
14:46:26 <obgr_seneca> has to be done by artwork team I think
14:47:00 <rda> and webteam for integration, but yes, later.
14:47:02 <rda> anything else?
14:47:16 <obgr_seneca> nothing I can think of at the moment
14:47:28 <rda> as a side note, for the theme, it may come out of the preliminary work of alex for the distribution artwork. we'll see.
14:47:33 <rda> obgr_seneca: ok, thanks!
14:47:42 <obgr_seneca> no prob
14:47:51 <rda> #topic maintainer db
14:47:52 <rda> kosmas: ?
14:48:26 <kosmas> some progress to report.
14:48:57 <rda> go ahead! :)
14:49:36 <kosmas> relationship between sources and maintainers. Search for source packages in place. Started work with ldap authentication.
14:50:00 <stormi> have you make a roadmap with estimated deadline ?
14:50:03 <stormi> made*
14:51:57 <kosmas> not yet stormi
14:52:09 <stormi> I think it would be great for rda :)
14:52:19 <stormi> and obgr_seneca
14:52:24 <rda> not only me :)
14:52:28 <stormi> our beloved leaders
14:52:49 <obgr_seneca> I didn't do anything to merrit that title
14:52:58 <obgr_seneca> except volunteering for the job
14:53:03 <stormi> that's enough
14:53:28 <kosmas> need to know what is necessary first for deployment. Haven't got a chance to find out about the live server yet. Would we need to finish off ldap authentication before live?
14:54:04 <rda> kosmas: if we can manually insert emails for one, we can start withouth ldap for live
14:54:29 <rda> but if you can provide again the updated list of requirements and see with sysadmin how to match the two lists... that would help
14:54:41 <stormi> kosmas: if you write down all tasks then maybe rda and obgr_seneca could help prioritizing them and set milestones ?
14:55:21 <kosmas> ok: I'll probably send another mail to ML with the tasks to be done and then you can decide about priorities.
14:55:21 <stormi> (with estimated workload for each task, roughly)
14:55:30 <rda> well, milestones based on status, not dates, but yes. that would help. tasks with expected involved people (here, kosmas and sysadmin I guess)
14:55:35 <rda> kosmas: cool thanks
14:56:02 <rda> #info progress made (sources/maintainers relationships; package search; started ldap auth)
14:56:20 <rda> #info tasks list needed to set milestones before live integration
14:56:26 <stormi> rda: dates help, even if we don't respect them :) For mageia-app-db we planned 0.1 at the end of 2010, and it really was done only last week, but still I gave us some good incentives to work
14:56:29 <rda> #info environment reqs list to update
14:56:35 <rda> stormi: yep :)
14:56:41 <kosmas> so if anyone wants to have a look and add things, make comments the staging is here: maintdb.mageia.org.uk
14:58:30 <stormi> #info testing and comments welcome on staging instance : http://maintdb.mageia.org.uk
14:59:39 <rda> ok, next?
14:59:55 <dmorgan> rda: back
15:00:08 <rda> #topic bugzilla again
15:00:11 <dmorgan> rda: we will keep the existing bugreports i think
15:00:23 <rda> #info bugs are safe to be filled in already
15:00:25 <rda> cool
15:00:33 <dmorgan> rda: we have only 3 bugreports one from buchan, and 2  to test xmlrpc
15:00:39 <dmorgan> so no pbs to keep them
15:00:45 <rda> dmorgan: yep, but it's good to know if we can encourage people to use it right now
15:01:02 <Jehane> dmorgan: no reservation of bug #1 for an awesome first bug ?
15:01:16 <dmorgan> rda: i think we should try 'us' to us it and see any issue
15:01:30 <stormi> you mean "us" webteam ?
15:01:42 <dmorgan> stormi: webteam, sysadm, ...
15:01:45 <obgr_seneca> or "us" whole project?
15:01:48 <rda> dmorgan: that's the goal. I meant people as us.
15:01:48 <dmorgan> but no real user bug yet
15:01:58 <dmorgan> rda: so i agree :)
15:02:09 <rda> these are still real user bugs :)
15:02:17 <dmorgan> rda: ;)
15:04:44 <rda> ok next ?
15:04:46 <rda> #topic calendar
15:05:07 <rda> no progress so far but I will postpone this until end of Feb (unless someone wants to take it)
15:05:42 <obgr_seneca> I wanted to, but I didn't have the time
15:06:17 <rda> no pb. :)
15:06:24 <rda> #topic website
15:06:38 <rda> current version ok, I'm still late to integrate russian translations (2 pages)
15:07:02 <rda> and a possible next version is still pending on my hd.
15:07:16 <rda> notwithstanding design/layout/theme points that are not set yet.
15:07:21 <rda> ha.
15:07:29 <rda> #topic alpha release page/mirrors/etc.
15:20:11 <obgr_seneca> ping?
15:20:59 <damsweb> other meeting at the same time explaning why we lost rda :-)
15:21:07 <rda> lost, lost...
15:21:10 <rda> not completely.
15:21:13 <rda> sorry for the lag...
15:21:27 <rda> so, question is (open). We'll have to setup a page for alpha one release.
15:21:32 <rda> will be rought, on purpose.
15:21:35 <rda> rough
15:21:42 <rda> just link to existing mirrors.
15:21:51 <rda> no fancy stuff. no dynamic, etc.
15:22:09 <rda> any hint/opinion about this? or even someone wanting to make it?
15:22:44 <stormi> just a big flashing text saying this is not usable for common users, but I know you already have it :)
15:22:58 <rda> ok :)
15:23:01 <rda> anything else?
15:23:03 <stormi> + links to bugzilla and forum
15:23:07 <stormi> if they're ready
15:23:08 <rda> ah, yes.
15:23:34 <damsweb> + link to the wiki with all erratas or informations
15:23:55 <damsweb> + a link to donate page \o/
15:24:18 <rda> yes too
15:24:43 <rda> #info dead simple download page (list of links to mirrors) + warning message + links to bugzilla, forum, wiki, errata, release notes, donate page
15:24:58 <rda> damsweb: will you be available to set it up for the releasE?
15:25:08 <damsweb> the download page?
15:25:12 <rda> (I will be offline from Saturday evening to the week after)
15:25:13 <rda> yes
15:25:29 <rda> I can draft it and make it ready but you'd need to update it/release it when necessary
15:25:29 <damsweb> rda: hum ok I can do it
15:25:46 <damsweb> but I will need help for CSS
15:26:05 <rda> no need. again, this will be a very simple page.
15:26:15 <rda> but anyone else may propose an upgrade on this.
15:26:57 <obgr_seneca> damsweb: we could do it together but I don't have permissions to publish it on the server
15:27:20 <damsweb> obgr_seneca: ok, great!
15:27:40 <damsweb> I can publish on the server
15:27:48 <obgr_seneca> since release is on tuesday we could get in contact over the weekend?
15:27:48 <damsweb> obgr_seneca: thank you for the help
15:27:49 <rda> obgr_seneca: we'll fix that. can you post a mail on the list about that?
15:28:11 <obgr_seneca> about not having permissions on the server?
15:28:14 <damsweb> rda: webteam@ or @sysadmin?
15:28:23 <stormi> rda: a page explaining how to contribute would be great (not just the list of teams), linked from the download page (and mageia's main front page)
15:28:29 <rda> obgr_seneca: yep, we'll push your key
15:28:37 <obgr_seneca> ok
15:28:51 <rda> stormi: yes, but one thing at a time. or if you can see how to set it up on the wiki (I believe there are starts for this)
15:29:07 <rda> #action stormi to gather info on a page for contributions input
15:29:16 <stormi> /o\ :)
15:29:17 <rda> #action damsweb & obgr_seneca to build/setup/release the download page
15:29:24 <damsweb> #info will be good to have the page before the release to have it translated in time
15:29:32 <rda> #action obgr_seneca to mail webteam to get a push access on website as well
15:29:47 <obgr_seneca> rda: Could you show me how to publish sth on the website?
15:30:13 <rda> obgr_seneca: see that with damsweb maybe. or I can send you the script I use for taht. that's basically a scp command.
15:30:26 <rda> beware, it's rough! :)
15:30:30 <obgr_seneca> both would be fine
15:32:47 <rda> ok
15:32:49 <rda> so...
15:32:53 <rda> meeting done for today.
15:32:57 <rda> sorry for the length of it.
15:33:02 <rda> thanks a lot for attending!
15:33:07 <obgr_seneca> ok, have to get back to work...
15:33:20 <rda> again, for next week, you'll have to set it up without me ;)
15:33:23 <rda> #endmeeting