14:06:55 <rda> #startmeeting
14:06:55 <Inigo_Montoya> Meeting started Wed Jan 12 14:06:55 2011 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:55 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:07:23 <rda> #chair rda misc damsweb
14:07:23 <Inigo_Montoya> Current chairs: damsweb misc rda
14:07:50 <rda> #topic progress review
14:08:14 <rda> so, forum: ashledombos, maat; status? any news ?
14:08:32 <maat> So
14:08:45 <maat> we are waiting for VM to come to life
14:08:58 <ashledombos> :)
14:09:13 <maat> i sent a mail to daax (forwarded to anne ans syadmins)
14:09:29 <maat> mlo and nfrance guys are rather loaded
14:09:30 <rda> so, we're on our own
14:09:47 <rda> ennael tells me that we may be building a VM on our servers first
14:09:51 <rda> misc: you confirm?
14:10:05 <rda> #info forum VM still in the waiting
14:10:15 <maat> they are working on it and the birth is supposed to comme in a matter of days
14:10:25 <maat> but anne wants us to accelerate
14:10:43 <rda> yeah but (without blaming anyone), it's been weeks that it was a matter of days
14:10:54 <maat> even if this choice implies to create the vm somewhere else
14:11:05 <rda> ok
14:11:06 <maat> rda: i know
14:11:39 <rda> catdap/identity: misc, obgr_seneca, AL13N any news on your side?
14:11:41 <maat> next step (this afternoon) : mail to syadmin with requirements
14:11:54 <rda> maat: ok
14:12:01 <maat> so that thek know what VM to create
14:12:07 <rda> #action maat mail to sysadmin forum VM setup requirements
14:12:58 <maat> i already gave them directly to misc via irc but i guess this has been lost in the flow
14:13:12 <rda> #info identity pending a patch to allow user-triggered password reset
14:13:25 <rda> maat: likely :)
14:13:34 <rda> bugzilla: dmorgan, any news ?
14:14:06 <maat> then, once haviung the VM we'll need (ash and i) a few days to have the forum up and runnning
14:14:38 <maat> (i'll try to get days off for that)
14:15:51 <rda> maat: don't feel forced to make it a hurry on you because some other thing delayed it.
14:15:53 <maat> at this moment we'll probably need buchan support for ldap connexion / tuning
14:15:59 <rda> yes
14:16:25 <rda> #info once the VM is available, maat and ash will need a few days for the full working setup; plus help from buchan/sysadmin
14:16:26 <maat> please make sure to have him no too loaded :)
14:17:05 <ashledombos> the documentation about the forum is getting more and more filled (and in english)
14:17:31 <rda> dmorgan: ping
14:17:36 <maat> and ashledombos is drastically improving he's git skills :)
14:17:49 * maat impressed
14:17:50 <rda> :)
14:17:53 <obgr_seneca> sorry, was away
14:18:18 <maat> rda: what about cassification of web apps ?
14:18:25 <rda> maat: what do you mean
14:18:28 <rda> ?
14:18:35 <maat> phpCAS = SSO
14:18:58 <maat> (well CAS is not only php but phpCAS is the php connector)
14:19:18 <rda> maat: yes and?
14:19:30 <rda> what does it support/provide?
14:19:54 <maat> iirc we spoke about setting up SSO system (CAS was mentionned) for all web apps
14:20:13 <maat> so i ask about this part because phpBB is not well cassified atm
14:20:36 <maat> so we need to prepare ourselves quickly if SSO is started
14:20:49 <rda> maat: could you send a memo about that specifically (and defining what you mean by SSO here) on thelist?
14:21:00 <maat> and if SSO is delayed we are less under pressure on this specific matter
14:21:12 <maat> SSO = single sign on
14:21:16 <rda> maat: SSO is a least concern in front of services availability
14:21:32 <maat> tha implies having a CAS server connected on LDAP
14:21:33 <rda> maat: I know, but what is implied under this. this may not be clear to everyone.
14:21:44 <maat> (ie CAS app on tomcat stack)
14:21:51 <rda> tomcat ?...
14:22:17 <maat> and then have all web apps patched to use CAS
14:23:05 <maat> then once you are connected on an app (let's say bugzilla) you can jump to something else (blog, forum, maintainers db, whatever)
14:23:22 <maat> without needing to go through login process
14:23:31 <maat> yes
14:23:48 <rda> yes, I know that but... a mail is better suited to discuss about this first, than here
14:23:49 <maat> CAS server is written with java
14:23:58 <maat> well
14:24:10 <rda> maat: I'm not sure hosting even more a java stack is going to make it :) but we can always discuss this
14:24:20 <maat> irc would have been ok if SSO was already planned and started
14:24:21 <rda> but again, that's not a priority over having services just made available
14:24:30 <maat> ok
14:24:34 <rda> maat: not started and not formally planned either
14:24:49 <maat> then we can consider that will be discussed about later
14:24:54 <rda> moreover, OAuth may even do the same with lighter stacks
14:24:59 <rda> maat: yep
14:25:08 <maat> => not included in current roadmap
14:25:12 <maat> cool :)
14:25:14 <rda> indeed
14:25:18 <rda> so, next.
14:25:24 <rda> obgr_seneca: any updates about the wiki?
14:25:47 * rda should use meetbot better...
14:25:48 <obgr_seneca> I did a test installation here
14:25:48 <rda> #topic wiki
14:26:08 <obgr_seneca> I wrote two short php scripts to get it multi lingual
14:26:27 <rda> obgr_seneca: install scripts or patches against the vanilla mediawiki?
14:26:32 <obgr_seneca> it reads the language settings transmitted by the browser and goes to the right one
14:26:46 <obgr_seneca> I used vanilla
14:27:01 <rda> #info obgr did a multilingual mediawiki setup
14:27:16 <obgr_seneca> But there aren't any active patches in current mandriva rpm
14:27:22 <rda> obgr_seneca: that is?
14:27:47 <obgr_seneca> that is what?
14:28:02 <rda> I did not get your remark about the current mandriva rpm
14:28:27 <obgr_seneca> current mandriva svn is just a vanilla mediawiki packaged into an rpm
14:28:33 <rda> ok
14:29:00 <rda> obgr_seneca: could you write and push an install procedure + your script to sysadmin ? and see if this can be packaged as well?
14:29:02 <obgr_seneca> s/svn/rpm/
14:29:11 <obgr_seneca> Can do
14:29:34 <rda> #action obgr_seneca will write down the install procedure, join scripts, see packagability of this
14:29:54 <rda> obgr_seneca: any specifics about your experience w/ mediawiki?
14:30:48 <obgr_seneca> Not really, haven't gone into anything about layout (not my strength)
14:31:02 <obgr_seneca> Setup is easy enough following the online docu
14:31:20 <obgr_seneca> Don't know about login procedure
14:31:34 <obgr_seneca> user management has to be patched to use identity?
14:32:28 <rda> yep
14:32:36 <rda> there is an extension to use LDAP IIRC
14:32:51 <obgr_seneca> yes
14:32:51 <rda> anyway, we can document/Try this further with your setup
14:32:57 <obgr_seneca> ok
14:33:17 <rda> you can use http://mageia.org/wiki/doku.php?id=web:wiki to document it
14:33:21 <rda> #topic
14:33:25 <obgr_seneca> will do
14:33:26 <rda> #topic calendar
14:33:28 <rda> obgr_seneca: thanks
14:33:35 <rda> obgr_seneca: and now for something completely different :)
14:33:43 <rda> obgr_seneca: about the calendar, what news? :-p
14:33:49 <obgr_seneca> http://www.mageia.org/wiki/doku.php?id=web:calendar
14:33:58 <obgr_seneca> haven't gotten very far
14:34:25 <obgr_seneca> I have started looking into a few of those solutions
14:34:37 <obgr_seneca> But nothing specific, yet
14:37:15 <rda> ok, do you think you'll have time for next week? or do you want/need to share the load with someone here?
14:37:24 <rda> #info calendar review started
14:37:39 <obgr_seneca> Someone sharing the load would be nice
14:37:49 <obgr_seneca> Especially for those solutions not php based
14:38:07 <rda> there are python and.? other?
14:38:25 <rda> obgr_seneca: feel free to ask on the list specifically
14:38:38 <obgr_seneca> Ok
14:39:08 <rda> #help obgr_seneca would appreciate help for reviewing calendar solutions, especially non-php ones
14:39:22 <obgr_seneca> I will look further into http://www.k5n.us/webcalendar.php and http://www.agendadulibre.org/
14:39:35 <obgr_seneca> If someone would like to take the rest
14:39:37 <obgr_seneca> ?
14:39:57 <rda> #info obgr_seneca takes webcalendar and agendadulibre
14:40:16 <rda> #info rda takes davical and radicale
14:40:27 <rda> others welcome
14:40:28 <kosmas> obgr_seneca: I can help you with the rest :-)
14:40:33 <obgr_seneca> ok
14:40:52 <rda> #info kosmas steps in too
14:41:23 <rda> so we review and update the compat table afterwise and we see the result next wednesday
14:41:31 <rda> #topic maintainers db
14:41:59 <rda> kosmas: so, the issue here is the server setup it looks; as said by mail, could you check with pterjan and shikamaru about the packaging issue?
14:42:20 <rda> kosmas: plus, seeing if using fastcgi and lower releases of dependencies  could work?
14:42:53 <kosmas> rda: I think the first question is if I should continue with the current Ruby on Rails stack or not, as there have been people that don't favour that solution?
14:43:19 <stormi> if you mean me, this is not true :)
14:43:25 <stormi> (hi by the way :))
14:44:14 <kosmas> stormi: Hi stormi. Didn't mean you specifically... If anyone disagrees, as I've said before I don't have any problem stoping.
14:45:11 <kosmas> But unless we decide whether I do it or not, then every week could be somebody else that suggests to do it differently :-(
14:45:24 <rda> not everyone disagrees and it's an opportunity too to help level up the distribution. but I don't want this to feel bad/wrong either.
14:45:32 <rda> yep
14:45:38 <rda> so... opinions?
14:45:54 <maat> hem
14:45:57 <rda> #info given the issue to setup hosting for it, question is, whether we keep on this Rails stack or not
14:46:43 <maat> This is late but... may i give a tiny suggestion / calendar (and much more ?)
14:46:57 <rda> maat: yes?
14:47:07 <maat> http://www.cynapse.com/community/home/app_calendar
14:47:17 <rda> maat: please add it to the wiki page (list and table)
14:47:47 <maat> (cyn.in is a knowledge management and community webapp)
14:48:10 <maat> (with a calendar feature)
14:48:11 <rda> yep, but not the topic right now :)
14:48:14 <maat> ok
14:48:16 <rda> so, about maint db and rails?
14:48:17 <maat> end
14:48:22 <boklm> for deployement on the servers, we need to use only tools available as packages in the distribution, so either use versions available in Mandriva 2010.1, or someone has to work on updated packages
14:48:43 <rda> boklm: not "to use only". because there are things not packaged (website, for instance)
14:48:54 <rda> but clearly, packaged stuff is better
14:49:30 <rda> so somehow, it requires more/better packaging and more drive from both developers and sysadmins
14:49:43 <rda> still, that doesn't solve the issue at hand
14:50:44 <boklm> would it be possible to do it using versions from 2010.1 for now, and update later to newer versions when packages are available ?
14:50:55 <rda> kosmas: ? (+ fastcgi thing)
14:51:20 <kosmas> boklm: Everything is possible if there is no problem with the Rails stack
14:51:48 <boklm> if there are problems in the packaged Rails stack, it's a good oportunity to fix them
14:52:08 <obgr_seneca> If I understood misc correctly in his mails, he has no problem with ruby on rails as long as it can be done with packaged software
14:52:14 <rda> kosmas: so go for it. further problems with the Rails stacks shall be fixed.
14:52:41 <rda> kosmas: but try to match misc reco's if possible (and if problematic, please report so we can share the issue)
14:53:08 <kosmas> ok.. that's fine, so we should move on to the status, and hopefully won't have to talk about this issue again :-)
14:53:23 <rda> hopefully. :)
14:53:50 <rda> #info go for the rails stack, using packages from 2010.1 and trying to keep on misc' reco's
14:53:54 <rda> ok next
14:53:56 <rda> #topic bugzilla
14:54:00 <rda> dmorgan: ping
14:54:20 <kosmas> rda: don't you want some info about progress?
14:54:43 <rda> #undo
14:54:43 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x85b98cc>
14:54:59 <rda> kosmas: ha yes. sorry. thought you were on hold then.
14:55:01 <rda> kosmas: so? :-p
14:55:08 <boklm> rda: I think #undo doesn't work for #topic
14:55:15 <rda> boklm: /o\ :)
14:55:23 <rda> boklm: well, we'll see :)
14:55:31 <kosmas> ok.. so a litte more development made on app, and I've started seting up the staging server for deployment.
14:55:36 <boklm> I think you undone the last #info
14:55:48 <rda> #info go for the rails stack, using packages from 2010.1 and trying to keep on misc' reco's
14:55:59 <rda> kosmas: any public url to check on it?
14:56:29 <obgr_seneca> boklm: I've used #undo for #topic a few times in i18n meetings, it works
14:56:42 <kosmas> Not yet, but it would be very soon and probably on http://maintdb.mageia.org.uk..
14:56:54 <rda> #link http://maintdb.mageia.org.uk
14:57:16 <kosmas> As an idea, we could probably host the production version in a domain in mageia.org.uk
14:57:23 <kosmas> initially
14:57:32 <obgr_seneca> I would go for a mageia.org domain
14:57:48 <obgr_seneca> what exacly is mageia.org.uk?
14:58:03 <obgr_seneca> some british third party website?
14:58:04 <rda> kosmas: mageia.org will be needed for prod hosting
14:58:15 <rda> obgr_seneca: but you may use .org.uk for staging
14:58:15 <kosmas> obgr_seneca: I've registered it and redirected to mageia.org
14:59:11 <rda> #info mageia.org.uk is not prod but dev preview
14:59:52 <rda> #topic gitorious
15:00:30 <rda> #info on hold. given requirements gathering/mixes, install setup and needs are not clearly defined enough
15:00:39 <rda> #topic team org
15:00:52 <rda> any comment about it? (relative to my mail of last week)
15:01:00 <rda> (forwarded to -discuss, btw)
15:02:26 <rda> *dong*
15:02:40 <kosmas> rda: seems fine ?
15:02:51 <rda> yep, to this point at least.
15:03:00 <rda> dmorgan seems not available for bugzilla, we'll see later.
15:03:09 <rda> about transifex, anyone has any news?
15:03:29 <rda> (should have reminded of the meeting by email maybe)
15:03:33 <rda> ok.
15:03:41 <obgr_seneca> about tx:
15:03:52 <rda> #topic transifex
15:03:55 <obgr_seneca> we talked about it in i18n meeting last week
15:04:24 <obgr_seneca> We will do some "training" setup on mandrivauser.de for the translators to get to know it
15:04:50 <rda> #info i18n organizing "training" for translators
15:04:54 <rda> obgr_seneca: sounds nice
15:05:05 <obgr_seneca> When that's done and there has been a testrun testing the tx-svn bridge, we can use it on transifex.mageia.org
15:05:56 <rda> #link https://transifex.mageia.org/
15:05:59 <rda> obgr_seneca: ok
15:06:03 <rda> thanks
15:06:12 <rda> any topic someone would want to discuss?
15:08:00 <rda> ok, thanks everyone. let's see later on the list or here next Wednesday, same time!
15:08:02 <rda> #endmeeting