14:07:45 <rda> #startmeeting
14:07:45 <Inigo_Montoya> Meeting started Wed Jan  5 14:07:45 2011 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:45 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:08:07 * misc is here in a zombie form
14:08:18 <rda> #chair rda misc
14:08:18 <Inigo_Montoya> Current chairs: misc rda
14:08:22 <rda> ok, fetching my notes
14:09:13 <rda> #topic progress review since last time
14:09:36 <rda> first, transifex. any status?
14:09:48 <misc> it is deployed
14:10:05 <rda> working, used, all that? or what's next for it?
14:10:09 <misc> but there is no integration with svn, nor anything to translate, nor structured feedback from i18n
14:10:30 <dmorgan> misc: we need to add the other part ? or is it done ?
14:10:37 <rda> #info transifex has been deployed; not linked to svn yet, nothing to translate, waiting for feedback from i18n
14:10:46 <rda> dmorgan: the other part?
14:10:53 <obgr_seneca> doesnt transifex 1.0 use it's command line tools to integrated with vcs?
14:11:00 <misc> it us
14:11:01 <dmorgan> rda: iirc transifex is in 2 parts now
14:11:03 <misc> it use
14:11:24 <misc> but Jehane and goom said they would look at this part
14:11:28 <rda> dmorgan: oh ok
14:11:29 <dmorgan> misc: the command line need to be packaged/added ?
14:11:36 <dmorgan> misc: ah ok nice
14:11:36 <misc> dmorgan: it was already packaged
14:11:55 <misc> but the fact that there was no plan of what to do is just #fail
14:11:55 <rda> ok
14:12:16 <rda> who leads on this?
14:12:23 <misc> i am not sure that the i18n requested us to us transfiex
14:12:38 <dmorgan> misc: they did at the begining
14:12:40 <misc> so no one know how to integrate it, or the need of the translator
14:12:41 <obgr_seneca> I'm quite sure, we will use transifex
14:12:44 <misc> dmorgan: define "they"
14:12:53 <dmorgan> misc: some ppl, i don't remember the names
14:13:00 <misc> well, yeah, that's a problem
14:13:06 <dmorgan> misc: when all installed we just need to tell them
14:13:06 <misc> because most people do not know it
14:13:16 <misc> dmorgan: we already told them
14:13:19 <dmorgan> misc: and ?
14:13:28 <misc> dmorgan: most of them didn't know what it was
14:13:32 <rda> #action review with i18n, get/define a lead to coordinate/close the transifex setup
14:13:36 <obgr_seneca> but tx is by far better then using a sinple svn workflow as in mdv
14:13:39 <rda> #undo
14:13:39 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x8615a0c>
14:14:07 <misc> and next time we install a soft, we need to have clear use case, and someone to manage it
14:14:11 <rda> #action review with i18n, get/define a lead to coordinate/close transifex setup (misc, wobo)
14:14:23 <rda> ok
14:14:26 <rda> identity/catdap status?
14:14:46 <misc> should be deployed in production soon, as said during last meeting ( founders )
14:15:05 <misc> didn't found the time to do it, but a single cp to live should be enough, and then announce it
14:15:10 <rda> #info catdap/identity will be soon updated in production
14:15:12 <misc> ( and go on the sympa announce )
14:15:18 <rda> ok
14:15:28 <rda> forum status? ashledombos_
14:15:42 <misc> we do not have the server, mlo didn't contact ( at least not me )
14:15:59 <rda> #info still no progress on forum setup (still waiting for the server from mlo)
14:16:09 <rda> bugzilla status?
14:16:34 <dmorgan> rda: for bugzilla i am looking on the templates to add the rpm field
14:17:01 <rda> dmorgan: what else is on the road before prod deployment apart from this?
14:17:04 <dmorgan> rda: we still need to define the products to use
14:17:19 <rda> dmorgan: anything more?
14:17:35 <dmorgan> rda: for now this is all, after we will need to add the integration to maintainer
14:17:43 <rda> ok, not blocking then
14:18:02 <rda> dmorgan: the products, that is, what you proposed on the wiki?
14:18:08 <dmorgan> rda: yes
14:18:24 <dmorgan> rda: Mageia ( with componoments ) Websites, ...
14:18:37 <rda> dmorgan: I guess time has been enough for people to provide their feedback, so post a follow-up with a draft proposal and if no objection, we do it
14:18:39 <dmorgan> rda: you see on mdv or fedora bugzilla when you wanna create a new bugreport
14:18:43 <rda> dmorgan: what types of components?
14:18:54 <rda> dmorgan: yes, I know, the point here is to focus on the actual list
14:18:58 <dmorgan> rda: for mageia, cauldron now
14:19:01 <stormi> current you mean ?
14:19:03 <dmorgan> and 1.0 when it will be available
14:19:52 <rda> dmorgan: ok, so let's do it with two products for now: Mageia (cauldron component) and Websites (www, blog, wiki, identity, epoll components) ? for instance
14:19:58 <rda> we can add/rename later
14:20:02 <dmorgan> rda: seems OK for me
14:20:33 <rda> dmorgan: could you please post then this (or after your proposal) on the ml and we apply it by the end of this week so there's only the template stuff bloacking
14:20:33 <misc> can we rename later ?
14:20:45 <rda> dmorgan: about the template, do you need help, and what kind of help?
14:21:13 <rda> #info bugzilla setup is pending; needs a template change (rpm field) and agreed list of products/components
14:21:31 <dmorgan> rda: i will mail today to tell if i need help to make this quicker
14:21:41 <rda> #action dmorgan to post a followup draft proposal to -dev list for products/components, to use/apply for first setup
14:21:51 <rda> dmorgan: don't hesitate :)
14:22:07 <rda> #action dmorgan update the template to manage the rpm field in bugzilla
14:22:30 <rda> #info maintainers db integration will be needed (ajax) later in connection with this rpm field
14:22:40 <rda> ok, anything else about the bugzilla ?
14:23:11 <dmorgan> for now i think this is all
14:23:18 <rda> as for the wiki, status someone?
14:23:37 <rda> I guess not
14:23:37 <rda> #info still no progress on wiki setup
14:24:02 <misc> well, wasn't ennael working on the package ?
14:24:07 <misc> and who is in charge of the wiki ?
14:24:09 <obgr_seneca> rda what is needed for the wiki?
14:24:25 <rda> obgr_seneca: the setup of it
14:24:42 <rda> #action rda to summarize the wiki status, steps and work (to redispatch after)
14:24:45 <obgr_seneca> i did have a look into it but that was some time ago
14:25:00 <obgr_seneca> i can try again, have more time now
14:27:21 <obgr_seneca> there were two or three more people wanting to work on the wiki, does anybody remember?
14:27:31 <misc> yes, the log are here for that
14:28:05 <rda> obgr_seneca: yes
14:28:12 <obgr_seneca> I'll look them up and try and contact them
14:28:17 <rda> but the thing is to make all those people to coordinate
14:28:24 <rda> leu has a back pain currently
14:28:33 <rda> obgr_seneca: would be great, yes
14:28:34 <rda> #undo
14:28:34 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x848398c>
14:28:52 <rda> #action obgr_seneca to contact candidates for the wiki work and coordinate with them
14:28:59 <obgr_seneca> ok
14:29:36 <rda> as for the website, I've made some progress; migrated current website contents, built the global nav, but still has to commit this somewhere (git preferred) and build the staging website before prod
14:29:46 <rda> misc: do we have git reps or not yet?
14:29:57 <misc> rda: we only offer svn for the moment
14:30:13 <misc> we can setup git, but it will only be marginally better than git-svn
14:30:25 <misc> ( in fact, it would likely have less integration, so I prefer to avoid )
14:30:33 <rda> well, just one indirection less
14:30:37 <rda> misc: which to avoid?
14:30:49 <misc> rda: setting a custom hand made git repository
14:30:55 <kosmas> what about gitorious?
14:30:59 <rda> ha yes, it's not what I'd ask :)
14:31:17 <rda> kosmas: that's a candidate, but it needs to be setup
14:31:34 <rda> misc: ok, let's go for the svn for now then; I'll post sysadm for this
14:31:48 <misc> just look at the installation document of gitorious to see how painful it can be
14:32:00 <kosmas> rda: I've setup gitorious for the maint-db
14:32:00 <rda> #action rda to post new website/nav to svn repositories and to prepare staging servers
14:32:12 <misc> s/servers/website/
14:32:17 <rda> misc: :-p yes
14:32:44 <rda> kosmas: if it's manageable, maybe see with sysadm team then
14:33:03 <rda> #action kosmas to review gitorious setup feasability with sysadm team
14:33:06 <misc> kosmas: you have setup gitorious, or you have used gitorious.org ?
14:33:37 <misc> ( because using gitorious.org is easy, but this just totally bypass our ldap for obvious reason )
14:34:16 <kosmas> misc: what do you mean setup? I probably mean used gitorious to host a project, but I guess you mean something else?
14:34:22 <rda> #undo
14:34:22 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x84d0f8c>
14:34:41 <rda> kosmas: yes, we meant using gitorious source code to host our own, not using gitorious.org service
14:34:46 <misc> kosmas: yeah, I mean installing gitorious on mageia server
14:35:20 <kosmas> rda, misc: ok sorry... I can have a look if you want me to, though
14:35:35 <misc> i already had a look, but you can have one if you want
14:35:51 <kosmas> ok
14:36:01 <misc> kosmas: how much time do you think it will take ? ( and what would be a deliverable ? )
14:36:09 <rda> #action check gitorious install/setup feasability (kosmas)
14:36:47 <kosmas> misc: what are the requirements? install the source code and then try to integrate with ldap?
14:37:43 <rda> yes
14:37:59 <misc> kosmas: sysadm team use puppet, so a patch against the svn is the best
14:38:08 <misc> we also do have rpm in mandriva
14:38:31 <misc> so no need to provides so unmaintable hack like source code untarred and so on
14:38:59 <kosmas> ok. I can have a look at the rpm and what is needed and report back?
14:39:29 <misc> sure, and so, back to the first question, how much time do you expect this to take ?
14:40:14 <kosmas> A couple of days to see what is possible?
14:40:56 <misc> ok
14:41:16 <rda> #topic maintainers db
14:41:20 <rda> kosmas: status? :)
14:41:41 <kosmas> Setup git repository in gitorius http://gitorious.org/mageia-maintainers-database
14:41:55 <rda> #link http://gitorious.org/mageia-maintainers-database
14:42:01 <obgr_seneca> why not using mageia svn?
14:42:05 <kosmas> Setup up the redmine for the project  http://mageia-app-db.tuxette.fr/projects/mageia-maint-db
14:42:20 <rda> #link http://mageia-app-db.tuxette.fr/projects/mageia-maint-db
14:42:42 <misc> obgr_seneca: maybe because like me to become angry seeing I work for nothing
14:42:50 <rda> obgr_seneca: using what's at hand first; the important part is that the master moves to mageia
14:42:55 <rda> misc: why take it this way?
14:43:23 <misc> rda: well, that's quite annoying to setup lots of stuff, and see people not use it
14:43:30 <kosmas> obgr_seneca: I remembered talk about gitorious, and I personally prefer git, and I believe there was no requirement to use svn
14:43:46 <misc> rda: at least, if we were asked to do it and didn't answer ok
14:44:00 <misc> but no one asked anything regarding hosting, no one idsucssed it , nothing
14:44:03 <obgr_seneca> just thought it would be good to use mageia servers for mageia apps
14:44:08 <rda> misc: I understand that, but people do use it and it will be further used as well
14:44:29 <misc> rda: that's just one more communication fail...
14:44:35 <rda> misc: that doesn't prevent people from trying, making a first draft/setup on their side, then moving things around
14:45:06 <kosmas> misc: I think that rda is right and things can change and moved about
14:45:08 <rda> misc: not my opinion
14:45:26 <rda> anyway, back to topic
14:45:41 <rda> kosmas: is it working or... what's the status of it?
14:46:20 <kosmas> so, these two things setup and initial commit. not working yet, but it wouldn't take long. Is there any plan for hosting it somewhere?
14:46:57 <rda> kosmas: that's step two, but yes, we still have to discuss of that
14:47:28 <rda> kosmas: could you update the wiki page about it, especially with requirements for the setup?
14:47:42 <rda> (or in the redmine instance, but then provide a link to it from the wiki page)
14:47:52 <misc> hosting of ?
14:47:54 <stormi> misc: anytime there's hosting on mageia servers I move mageia-app-db there
14:47:57 <rda> #info only been setup, needs work still
14:47:59 <rda> misc: maintainers db
14:48:15 <stormi> (git hosting)
14:48:53 <kosmas> ok. it's still in development but will need a staging environment. Should I host it on my server until setup exists for mageia servers?
14:49:03 <rda> kosmas: first, yes
14:49:12 <rda> kosmas: but for the setup, we need you to provide the requrements
14:49:32 <rda> #action kosmas to stage it on his side, provide hosting requirements
14:49:35 <misc> sure, do not ask at all to sysadm the opinion on hosting, we will happyly host server written in 15 languages and 3 framesworks :/
14:49:45 <misc> ( another #fail )
14:49:48 <rda> misc: maintainers db was proposed to be taken by someone on the list in mid-december; kosmas proposed to have a look at it and did;
14:49:55 <misc> rda: yeah, on sysadm ?
14:49:57 <rda> misc: it's been discussed in several mails through december on webteam
14:50:06 <misc> good so sysadm were not asked
14:50:18 <rda> misc: or may have provided some insight at the time
14:50:26 <misc> so we are optional in such discussion and then you wonder why I am angry :/
14:50:45 <rda> misc: I think to need to step back and stop getting angry for every time things are not made by the book
14:51:26 <kosmas> misc: Some people are willing to help with the skills they have
14:51:28 <misc> rda: if that was 1 time, that would be ok, but I provided several communication failure
14:51:45 <rda> misc: and if you could focus on what does not fail instead of the contrary?
14:51:49 <rda> misc: I'll post sysadm for an update about this precisely and something else
14:51:53 <rda> ok, next topic
14:52:02 <rda> #topic calendaring solution
14:52:15 <rda> it's been suggested on -discuss about a calendaring solution for the project
14:52:37 <rda> I've posted a few solutions in the list for this meeting, along the lines of the discussion
14:53:01 <rda> who would like to take on this? (list requirements, with a kiss requirement; check solutions; propose; implement)
14:53:06 <obgr_seneca> haven't been able to read the list till now, was afk
14:53:30 <obgr_seneca> I could take on the calendar thing asuming it's nothing in perl
14:54:04 <rda> obgr_seneca: so far, it looks like there are very decent PHP/Python-based solutions
14:54:19 <rda> but things is to make sure it all comes to something that matches expectations
14:54:42 <obgr_seneca> php/python is ok
14:54:45 <rda> obgr_seneca: so you take on this one?
14:54:49 <obgr_seneca> yes
14:54:56 <rda> great
14:55:18 <rda> #action obgr_seneca take on the calendaring solution work, check requirements from the list, review the few solutions available
14:55:33 <rda> obgr_seneca: could you have this done for next week?
14:55:53 <obgr_seneca> yes
14:56:36 <rda> thanks!
14:56:52 <rda> #topic team organisation (leaders, reps) and FOSDEM
14:57:07 <rda> FOSDEM is taking place on Feb. 4/5/6
14:57:11 <rda> who is going to attend there?
14:57:13 <rda> (me)
14:57:27 <obgr_seneca> me
14:57:31 <stormi> me, probably
14:59:54 <rda> ok
15:00:11 <rda> would be great to discuss the team organisation by then (and over there)
15:00:25 <rda> and have candidates for representative/leader/deputy leader.
15:00:36 <rda> and setup a mentoring process
15:01:01 <rda> and get a grasp on how we articulate the voting rights in the team (larger than just the webteam, but a local discussion can help too)
15:02:01 <rda> any view/opinion about this?
15:02:52 <obgr_seneca> the question is: who is really in the web team?
15:03:30 <stormi> I think we can count those who took tasks :)
15:03:36 <stormi> + those who will
15:03:43 <rda> non-helping answer: people actively contributing/working on web apps; that have been recognized by their peers (mentored in)
15:04:27 <rda> so before the mentoring process is up and working, that counts only people who took a hold on something
15:04:39 <misc> what about starting by a first member, like rda, and let him them mentor other to bootstrap everything
15:05:03 <misc> ( by mentor, it can be quick for people, just recognize people in fact )
15:05:07 <rda> yep
15:05:12 <rda> that's an option
15:05:13 <obgr_seneca> +1
15:05:25 <misc> so the first peer is rda, and he then decide what other peers exist and so the webteam is created
15:05:40 <rda> *evil grin*
15:06:38 <rda> well, that would be an obvious first list to draw (from my POV). If that's ok for everyone, I can post this on the list later.
15:06:45 <obgr_seneca> misc: sure you haven't created some kind of monster now?
15:07:09 <rda> beat me if I'm too hideous
15:07:16 <stormi> ok
15:09:01 <rda> #action rda to post a list of first peers in the team
15:09:17 <rda> st else? or next point?
15:09:37 <stormi> mageia-app-db 0.1 should be released soon
15:09:49 <stormi> I'll post to the -discuss list I think
15:10:01 <misc> sophie 2.0 was released quietly by nanar
15:10:58 <rda> #info mageia-app-db 0.1 to be released soon
15:11:10 <rda> #info sophie 2.0 released quietly lately
15:11:25 <rda> #topic roadmap/wishlist
15:11:31 * misc missed catdap merg but maybe this should not be added to the log
15:12:03 <rda> now, on this new year and after about three months; do you have wishes, ideas for the web team roadmap?
15:12:10 <rda> (nothing formative at this point, it's consultative)
15:12:32 <rda> misc: I won't tell
15:12:43 <misc> sure, it will not go out of the internet
15:13:23 <stormi> well, "as soon as possible" is the more precise I can get for forum, wiki, bugzilla etc. :)
15:13:47 <stormi> difficult to establish a roadmap without knowing how much work there is to be done
15:13:56 <misc> stormi: technically, it should be "as soon someone do the work"
15:14:18 <misc> and project planning is indeed something that would requires a dedicated volunteer
15:14:41 <misc> ( and that should be the role of someone whose I forget the title )
15:15:50 <obgr_seneca> the problem is not only being a dedicated volunteer but also having the time
15:16:41 <misc> depending on the size of the team, it can be done on part time
15:17:50 <obgr_seneca> i think most of us, being in several teams and living a real life will find it difficult doing this full time :D
15:18:33 <obgr_seneca> I'm just glad, I'm only wobo's substitute in i18n team and letting him do the work
15:18:41 <fj> I missed the begin of the meeting : has anything been told about bugzilla ?
15:19:10 <rda> ok, so need to have at least one person dedicating on the planning/coordination within the team (best for leader or deputy leader, actually)
15:19:33 <rda> fj: yes, will be in the logs; or do you have something specific to state about it?
15:19:47 <misc> doing coordination is not especially hard, even I can do it, and god know how much I am messy
15:20:28 <fj> rda: at least have an RPM field
15:20:30 <rda> not hard, but requires some focus, and to focus on the coordination part (rather than going back and forth from coordination to dev/anything else and back)
15:20:36 <rda> fj: that's planned :)
15:21:06 <fj> rda: ok
15:21:21 <obgr_seneca> i would volunteer to do part of it but I would be more happy if someone would step out of the mist, doing it
15:22:04 <rda> obgr_seneca: you're already with a role in the i18n team, so maybe better not to take too much on. but up to you.
15:22:11 <obgr_seneca> yes
15:22:25 <obgr_seneca> like i said, i would be more happy if someone else does it
15:22:28 <rda> we can think about this and decide later (next week), try, see at fosdem.
15:22:29 <rda> :)
15:22:30 <rda> ok
15:23:04 <obgr_seneca> and I do take on too much from time to time
15:23:05 <rda> #info need for coordination/planning roles within team, for each project (to track, help keep track/focus on tasks)
15:23:28 <rda> anything else?
15:25:06 <rda> echo
15:25:38 <misc> nope
15:25:50 <misc> maybe indeed a better procedure for meeting to manage timeout
15:26:03 <rda> yes. not sure how.
15:26:12 <rda> ok, closing the log
15:26:15 <rda> #endmeeting