14:08:00 <rda> #startmeeting
14:08:00 <Inigo_Montoya> Meeting started Wed Dec  8 14:08:00 2010 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:00 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:08:10 <rda> #chair rda misc coincoin
14:08:10 <Inigo_Montoya> Current chairs: coincoin misc rda
14:08:37 <rda> #topic past week actions review
14:09:10 <rda> so, identity/catdap: blingme misc? (obgr is not here atm)
14:09:15 <coincoin> hello all
14:09:38 <blingme> Hi
14:10:07 <blingme> Unfortunately, I am moving countries again this week ... if I can get to everything ...
14:10:18 <blingme> so, I don't have much time at present ...
14:10:36 <rda> blingme: ok. where are you moving to?
14:10:46 <blingme> rda: moving back to South Africa
14:11:32 <rda> ok :)
14:11:38 <rda> obgr_seneca: hi!
14:11:50 <obgr_seneca> hi, sorry, I'm a bit late
14:11:50 <rda> obgr_seneca: we are on catdap/identity topic; anything to say about this?
14:12:27 <dmorgan> Regarding the CSS/HTML i saw commits in trunk, is it planned to backport them ?
14:12:41 <obgr_seneca> misc told me howto set it up but sth. doesn't work on my local instance and I didn't have much time
14:13:05 <obgr_seneca> As soon as it works, I can finish css work
14:13:24 <obgr_seneca> dmorgan: blingme told me to commit in trunk
14:13:58 <blingme> well, at present, we have "trunk" and a live branch ....
14:13:59 <rda> obgr_seneca: did you identify the blocking sth?
14:14:01 <dmorgan> obgr_seneca: iirc we need to have it backported on the "live" branch to have then on "production"
14:14:03 <blingme> live branch is what is running live ...
14:14:15 <blingme> it doesn't make sense to commit directly to live
14:14:26 <blingme> feel free to create a different branch if you want
14:14:30 <obgr_seneca> sth about authentification
14:14:37 <obgr_seneca> mom, I'm looking it up
14:14:42 <blingme> obgr_seneca: what is not running? catdap application, or ldap or the combination
14:14:56 <blingme> (e.g., you can see live generated login and registration pages etc. without ldap working)
14:15:01 <obgr_seneca> I think sth between catdap and ldap
14:15:37 <obgr_seneca> I can't register a new user, so I can't look into anything beyond the login and registration pages
14:16:06 <rda> ok, can you see that after/along the meeting then?
14:16:52 <obgr_seneca> yes
14:17:53 <rda> blingme: obgr_seneca: plus, as soon as you have time for it, could you sort through http://mageia.org/wiki/doku.php?id=web:identity#issues to see what may be done (and by who) and/or what is blocking for a broader usage. and if we ought to ask/search for one more dev to contribute? (no hurry, but just to sum it up for next week)
14:18:16 <obgr_seneca> ok
14:18:17 <misc> one more dev will never be refused
14:19:23 <rda> ok, next: wiki setup: obgr_seneca you again (leu isn't here)
14:19:25 <rda> :)
14:20:10 <rda> any update on this? did you manage to sync with each other?
14:20:39 <obgr_seneca> no, I'm sorry
14:20:49 <obgr_seneca> Perhaps someone else could look into it?
14:20:55 <blingme> 1) and 2) are probably valid, 3)the account you tested with was privileged, test with an unprivileged account
14:20:58 <obgr_seneca> I'm running out of time lately
14:21:21 <blingme> 6)I can't test ipv6, but misc commited at least one fix
14:21:40 <blingme> 7)Do you really want this? There were discussions about other auditing requirements
14:21:43 <misc> blingme: s/one/the start of a fix/ :)
14:21:51 <rda> obgr_seneca: ok, just good to know. :) I'll sync with leu this evening most likely and see hwo to dispatch.
14:21:59 <misc> ( which remind me I have a question for you, after the meeting )
14:22:22 <blingme> 8)invalid, only Account admins and LDAP admins can change loginShell
14:22:34 <rda> next: website; nothing new at once, apart that we will start to think about the whole site information architecture and global nav; that's just a note, we should do that with comm/market teams as well.
14:22:48 <rda> next: forums: ashledombos ?
14:22:54 <rda> (maat isn't there)
14:22:59 <misc> rda: I have a question for the website
14:23:02 <rda> misc: sure?
14:23:15 <ashledombos> rda: represent
14:23:15 <obgr_seneca> do you sync with him via irc? Then I'll be present
14:23:28 <misc> https://www.mageia.org/pipermail/mageia-webteam/2010-November/000056.html
14:23:42 <rda> obgr_seneca: hopefully, yes. thanks. I guess he would be online around 18/19 CET
14:23:43 <misc> rda: you told "working on the infrastructure to ease deployement"
14:23:50 <rda> misc: yes?
14:24:15 <misc> can you clarify, as I didn't see any mail on sysadm or webteam about what exactly was or would be done on infrastructure ?
14:24:16 <rda> that's not a rpm, that's about the edition/translation and full website update process actually.
14:24:38 <rda> misc: the www website would be pushed through a script from a git/svn rep, likely.
14:25:56 <rda> this far (it may change, but how it is since we started mageia and it will be in the next tw months at least), that's 100% in-house code/structure. will write about that soon I hope.
14:26:19 <misc> and so, this script is in what svn ?
14:26:46 <rda> misc: you have the existing www svn but the next I'm working on is not yet.
14:26:51 <rda> but will somehow similar
14:26:53 <rda> +be
14:28:02 <misc> rda: well, is there something that prevent to commit in our svn for the moment, something missing ?
14:28:57 <misc> ( if you prefer git, I could understand that svn is not what you like :) )
14:29:03 <rda> mostly, it doesn't work at all for now and I'm looking for a way to better separate app code from contents (but it's not easy)
14:29:13 <rda> I prefer git as well, but that's not as critical as previous issue :)
14:29:31 <misc> well, I tried to setup gitorious, and it will be harder
14:29:40 <rda> harder?
14:29:45 <misc> than svn
14:30:36 <kosmas> need any help with git setup?
14:30:43 <misc> there is 4 daemons to start, a special setup on ssh, various problem when some deps are updated, etc, etc
14:31:49 <misc> kosmas: not yet, what we need is more a design on how to host git rather than help, but we will discuss this later , so if you want to help, do not hesitate to signal again ( if we forget )
14:32:04 <misc> anyway, the goal was not to interrupt the meeting :)
14:33:03 <rda> :-p
14:33:09 <rda> ok, so, ashledombos, about the forum? :-p
14:36:52 <misc> ( timeout ? )
14:37:21 <rda> ashledombos: ping
14:37:35 <rda> ok, next, we'll get back to forums later
14:37:41 <rda> next: bugzilla: dmorgan ?
14:37:57 <dmorgan> so
14:38:43 <dmorgan> for bugzilla, i started a mail, ( i will send it after some modifications ) but basically what is missing is :
14:39:26 <dmorgan> 1- Define the main categories
14:39:42 <dmorgan> 2- Modify the edit.cgi page to fit our needs
14:40:02 <dmorgan> we could look to the mdv one as this is available on the svn ( from what i saw )
14:42:39 <dmorgan> rda: and after we will need to modify the look and feel of the bugzilla but this is "minor"
14:42:54 <rda> dmorgan: really, really minor for the time being.
14:42:54 <dmorgan> as long as users can report bugs easily i'm good with it :)
14:43:07 <rda> what is major is having this stuff set up and working. then we'll improve on usage.
14:43:19 <dmorgan> rda: yes i agree
14:43:25 <dmorgan> 1 and 2 here
14:43:47 <rda> ok. dmorgan anything else?
14:43:50 <rda> anyone: comments?
14:44:45 <dmorgan> rda: for me this is all
14:44:55 <dmorgan> rda: my mail will show better how we can do it
14:45:19 <rda> ok
14:45:26 <rda> so, that's it for past week actions.
14:45:40 <rda> anyone has a topic/question to raise? (open bar for the next 5 minutes :) )
14:46:01 <misc> o/
14:46:11 <misc> ( yeah, always the same )
14:46:21 <rda> misc: yes ?
14:46:51 <kosmas> so have you decided about bugzilla or are you looking at other ones as well?
14:46:52 <misc> I am working on sympa, and so given the default template, i assume that webteam will want to change it
14:47:38 <rda> misc: maybe, maybe not. not urgent either, but maybe at some point yes.
14:47:41 <misc> so, since sympa is already taking care of this, all that is needed is placing file in a well defined directory , using tt
14:47:56 <rda> kosmas: we discussed some others but here yes, we opted for bugzilla for the distribution.
14:48:12 <kosmas> rda: ok
14:48:17 <misc> we lightly discussed...
14:48:20 <rda> kosmas: as we're headed to have some sort of forge as well, we hope, we may have alternative for other non-distribution things. we'll see.
14:48:37 <rda> misc: yes, lightly.
14:48:45 <rda> misc: (about sympa) cool then
14:49:09 <misc> rda: the problem is the default tempaltes is offering fonction that mean nothing with out setup
14:49:21 <misc> like "reset password "
14:49:43 <misc> or change email ( without changing ldap )
14:49:51 <rda> misc: so that means we should manage these now then?
14:50:10 <rda> because we should update these parts to redirect to ldap (or not, depends on the context)
14:50:22 <misc> simply removing them would be ok
14:50:47 <rda> add a notice/link to identity then maybe?
14:50:49 <misc> but my main point is "what and how do we do", ie, shall i add another directory in some svn, open a new one ?
14:52:07 <rda> misc: in web/templates/sympa/trunk then maybe (alongside bugzilla templates)
14:53:33 <misc> ok so I guess my explanation about multiple svn didn't really convince people :/
14:56:43 <rda> misc: that is?
14:57:02 <misc> rda: something I cannot find, so maybe I didn't send it, hence lack of reaction
14:57:17 <misc> but basically, it was "smaller svn would be easier to migrate to git later if needed"
14:57:27 <misc> ( and easier to back, etc, etc )
14:57:32 <rda> ah yes. I remember we talked about it.
14:57:47 <rda> well, I'm all for it as well, but as long as it's not enforced/put in place, we tend to use what we have.
14:58:04 <rda> here, that would be a svn for templates for vanilla apps in general
14:58:13 <rda> but yes, it's technically a branch in the web svn rep.
15:02:05 <misc> I guess we would be able to see once there is some more practice on this side
15:02:17 <misc> ( as we should also add catdap and epoll one day )
15:04:22 <rda> well, yes, or have a forge-like list of projects and link to upstream repository
15:04:28 <rda> when appropriate
15:07:57 <misc> so the meeting should be stopped ?
15:08:11 <rda> unless someone has anything more to raise?
15:08:22 * rda realizes he didn't use meetbot at all...
15:08:32 <rda> #action better use meetbot next time (rda)
15:09:17 * misc has something not related to webteam in particular so wait for the end of the meeting
15:10:38 <rda> ok
15:10:40 <rda> #endmeeting