20:03:10 <wilcal> #startmeeting
20:03:10 <Inigo_Montoya> Meeting started Thu Feb  4 20:03:10 2021 UTC.  The chair is wilcal. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:10 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:03:22 <wilcal> Welcome to this weeks QA meeting
20:03:36 <wilcal> #topic Who's new?
20:03:46 <wilcal> Anyone new here today
20:04:27 <wilcal> Nope
20:04:29 <wilcal> #topic M8 RC ISO testing
20:04:45 <wilcal> We had a really good release blockers meeting last week
20:04:57 <auroud_85[m]> RC Take 5 is in very good shape to be released public.
20:04:58 <wilcal> that took a few blockers off the list
20:05:25 <wilcal> Here is the blockers page:
20:05:26 <wilcal> http://madb.mageia.org/tools/blockers
20:05:43 <neoclust> nemo seems fixed soon
20:05:49 <neoclust> we need to add the latest patches
20:06:06 <wilcal> If you have pet release blocker please mark it such so it can get resolved
20:06:21 <tmb> martin  just submitted the new nemo
20:06:31 <bri_an> nice
20:06:37 <neoclust> ah nice didn't saw this
20:06:40 <neoclust> this is a good news
20:06:46 <Benmc> yep
20:06:53 <wilcal> So we may get another set of ISOs by this weekend
20:07:36 <wilcal> I'm just not having any problems with the ISOs comng up and running nor the CI nor the netinstall
20:07:38 <Benmc> bug 28280 to be fixed first me thinks
20:07:40 <[mbot> Bug: ['Drakxtools fail to launch in GUI mode after configuring network', 'NEW', 'Mageia Bug Squad'] https://bugs.mageia.org/show_bug.cgi?id=28280
20:08:01 <wilcal> There are problems for me but none that can't be worked after release
20:08:35 <Benmc> that one prevents updating the sytem
20:09:22 <neoclust> Benmc: which one prevent you from updating ?
20:09:54 <Benmc> bug 28280
20:09:56 <[mbot> Bug: ['Drakxtools fail to launch in GUI mode after configuring network', 'NEW', 'Mageia Bug Squad'] https://bugs.mageia.org/show_bug.cgi?id=28280
20:10:04 <auroud_85[m]> See a previous update for sddm which was messed by a lack of proper hostname... Please set a real one and ditch "localhost"
20:10:20 <Benmc> if the user doesnt set update repos before install, difficult after install
20:11:38 <auroud_85[m]> Anyway, this involves the MIT-X-MAGIC-COOKIE that permits X connections and if hostname change without update it, X refuses new connections.
20:12:02 <bri_an> intersting - has that always existed or related to soemthing new?
20:12:26 <DavidWHodgins> Oops. Sorry, didn't notice the time.
20:12:39 <wilcal> Hello David
20:13:00 <neoclust> i don't see how sddm update can create this issue to be honnest
20:13:35 <DavidWHodgins> I haven't checked yet. Are the bumblebee, mageia-prime packages on the iso images?
20:14:01 <wilcal> #chair DavidWHodgins
20:14:01 <Inigo_Montoya> Current chairs: DavidWHodgins wilcal
20:14:14 <wilcal> you've got the gavil David
20:14:20 <DavidWHodgins> neoclust: It's due to change in settings as shown by hostnamectl
20:14:43 <auroud_85[m]> <neoclust "i don't see how sddm update can "> Because of race and how services are launched by Systemd. The sddm started with a localhost as hostname later renamed localhost.local with avahi or network-manager...
20:14:51 <DavidWHodgins> The transient hostname is now set
20:15:07 <DavidWHodgins> In Mageia 7 it wasn't set
20:15:17 <neoclust> ah
20:16:03 <auroud_85[m]> neoclust: https://bugs.mageia.org/show_bug.cgi?id=27601
20:16:05 <[mbot> [ 27601 – Blackscreen after an update of sddm ]
20:16:08 <auroud_85[m]> FYI
20:17:25 <DavidWHodgins> That's a release blocker for the final iso images. If we can fix it quickly, we should, but otherwise I'd like to get the rc iso images out.
20:17:52 <neoclust> yes i think this does not block RC release but blocker for final
20:18:13 <auroud_85[m]> Me too
20:18:18 <wilcal> I'm get'n really good at burn'n isos :-))
20:18:37 <DavidWHodgins> bug 28154 is the only current blocker that I see as a blocker for  the RC iso images
20:18:39 <[mbot> Bug: ['Live media not booting with some Radeon HD GPU or system installed with Classic ISO', 'NEW', 'Kernel and Drivers maintainers'] https://bugs.mageia.org/show_bug.cgi?id=28154
20:19:51 <auroud_85[m]> Thomas A. (MageiaTJ) does not seems to be affected anymore.
20:20:07 <DavidWHodgins> That's good.
20:20:24 <auroud_85[m]> The other reporter seems to have reinstalled a Cauldron and not longer bitten by it.
20:20:42 <tmb> its not a blocker. we want the RC out for wider testing so we can get an idea if we need to revert to radeon first  setup for final isos
20:20:45 <auroud_85[m]> Also, a too long boot process that needs to be investigated
20:20:50 <DavidWHodgins> I also see discussions about mageia-prime and optimus in the dev ml
20:20:52 <Benmc> wilcal: I just invested i 3 new USB 16gb sticks
20:21:10 <DavidWHodgins> tmb Ok
20:21:36 <tmb> we just need to add to the release announcement that we want feedback if it works or not for users
20:22:20 <DavidWHodgins> So, do you think we should release the rc iso images as they are currently, or go for one more rebuild to include latest fixes first.
20:22:23 <auroud_85[m]> tmb: I agree
20:22:47 <tmb> something like we have switched the following gpus to amdgpu:
20:22:48 <tmb> SI bit is for:  Tahiti, Pitcairn, Oland, Verde, Hainan
20:22:48 <tmb> CIK bit is for: Kaveri, Bonaire, Hawaii, Kabini, Mullins
20:23:34 <tmb> SI is Southern Islands, CIK is Sea Islands (so mostly HD7xxx and HD8xxx)
20:23:57 <DavidWHodgins> tmb do you think we should release the rc iso images as they are currently, or go for one more rebuild to include latest fixes first.
20:25:05 <Benmc> I would go for 1 more spin. if done today and tested over the weekend all good, releae to wider community next week
20:25:06 <auroud_85[m]> I think we should Release them as is, we get more feedbacks on it.
20:26:26 <neoclust> important part will be communication, blog post etc. We should explicitly ask tests on our blockers needed tests.
20:27:18 <DavidWHodgins> I'm inclined to agree with releasing as is. There will always be issues, and sooner we get the RC out to the public the more feedback we will get
20:27:46 <DavidWHodgins> A lot of testers don't install beta versions, and only try new releases when there is an rc
20:28:40 <auroud_85[m]> #agree
20:28:55 <wintpe> I also agree with releasing what we regard as rc5. sorry i  was late. but i found no showstoppers, and your right dave, there will always be something else we havnt seen
20:28:59 <DavidWHodgins> I'll post to the council mailing list then, that we are ready for release pending preparation of blog post etc.
20:29:27 <DavidWHodgins> #action I'll post to the council mailing list then, that we are ready for release pending preparation of blog post etc.
20:30:01 <DavidWHodgins> Ok. Moving on
20:30:06 <DavidWHodgins> #topic Testing updates - Any questions or problems
20:30:07 <tmb> well, we have 125 srpm updated/fixed/... sincce last rc build
20:30:45 <neoclust> tmb: we have not slept :-p
20:30:57 <DavidWHodgins> tmb: So do you think we should rebuild for those? I don't know how many of those are on the iso images
20:31:10 <neoclust> tmb: when we release RC we go in "full freeze mode" ? would be nice
20:31:20 * tmb is reading changelog
20:32:01 <auroud_85[m]> I pinged updates that are waiting a feedback from packagers.
20:32:04 <auroud_85[m]> Other pending updates involve server abilities.
20:32:21 <wintpe> if you add to rc5 now, we wont be sure that its as stable as when we tested, could introduce showstoppers, wheras if we keep to rc5 we can always update anything thats in repos
20:32:39 <neoclust> auroud_85[m]: /buffer 2
20:32:42 <neoclust> sorry
20:32:43 <wintpe> without breaking the install
20:33:45 <DavidWHodgins> wintpe: That's always true of new iso builds. They must be tested for regressions before being considered for release.
20:34:29 <wintpe> so we are not going to add the new updates to the rc5 then?
20:34:43 <DavidWHodgins> Waiting for tmb feedback
20:35:11 <DavidWHodgins> wintpe: If we do, it will be complete new iso images - rc6
20:35:18 <wintpe> ok IMHO if you do, then do a retest before release, otherwise release
20:35:45 <wintpe> agreed
20:35:47 <DavidWHodgins> All new iso images must always be tested for regressions and fixes
20:36:10 <wintpe> agreed
20:36:40 <wintpe> if thats your descision, then bring it on, happy to run another round of reinstalls
20:36:43 <tmb> we have some plasma-desktop fixes, drakconf close crash fix, and the non-starting nemo fix... and of course various security updated packages ... but I dont really see something standing out that bad
20:37:29 <tmb> and then various upgrade fixes... but as we need to state "add online medias for upgrade" I dont see them too bad critical either
20:38:07 <DavidWHodgins> Ok. We'll need to produce a list of issues to pass on to the docteam, so they can prepare for release
20:39:05 <DavidWHodgins> I'll put that together after the meeting, pass it on to the docteam, and let council know we are close to being ready to release rc iso images
20:39:25 <bri_an> :-)
20:39:35 <auroud_85[m]> Agree
20:39:50 <tmb> but I think we whould post a go/no-go question on qa list too if some of testers have some objections
20:39:58 <auroud_85[m]> Bugsquad Team will be also present.
20:40:07 <wintpe> out of interest how many of you are using mga8 as your daily, as ive switched over all my systems now
20:40:22 <wintpe> i dont have a mga7 any more
20:40:31 <wintpe> and im having no issues at all
20:40:55 <auroud_85[m]> wintpe : Me, daily basis use.
20:41:23 <DavidWHodgins> tmb, ok, will do, but keep in mind there will always be people who want the latest fixes included. If we always allow that, we never release.
20:41:45 <auroud_85[m]> <DavidWHodgins "tmb, ok, will do, but keep in mi"> This is completely true.
20:41:50 <wintpe> theres always tomorow theres always the repo
20:42:18 <tmb> DavidWHodgins, yeah, I was mote thinking of maybe martin has an objection and so on...
20:42:43 <bri_an> I run MGA8 all the time on this laptop.  But MGA7 as prod and others for MGA7 testing
20:42:45 <DavidWHodgins> I'll be using the log of this meeting to get list of topics for the info to pass on to the docteam
20:42:56 <tmb> since he's been testing a lot of bits too, so maybe he thinks he has an "important enough fix"
20:43:13 <DavidWHodgins> tmb: Good point.
20:43:27 <bri_an> but more hours on MGA8 than 7 now days
20:43:56 <tmb> DavidWHodgins, or we mail him directly :)
20:44:33 <DavidWHodgins> Probably better that way. I'll ask him
20:44:47 <tmb> the nemo fix could be nice, but we could limit the build to only respin 32bit isos with only that added
20:45:33 <tmb> that way we'd minimize the breakage possibility compared to everything already tested
20:46:00 <DavidWHodgins> I don't like the idea of having the 32 bit and 64 bit versions of the iso images having different versions of packages on them.
20:46:19 <tmb> we used to do that sometimes with ennael... just cherrypick the important enough fix in respin iso build
20:47:14 <tmb> DavidWHodgins, yeah, normally I agree, but since nemo is only crashing on 32bit and everyone else will get it with installing updates... :)
20:47:17 <DavidWHodgins> True. I'm not completly against it, I just dislike it as it makes debugging bug reports somewhat more tricky
20:47:47 <auroud_85[m]> Bugsquad is aware of this ;)
20:47:53 <DavidWHodgins> :-)
20:48:53 <tmb> after we release RC I will switch on full freeze and switch myself to "grumpy mode" for freeze pushes :)
20:49:17 <DavidWHodgins> lol
20:49:27 <wintpe> when we say freeze does tthat mean rc5 means release or are changes allowed
20:49:50 <wintpe> if so is that where nemo update should happen
20:50:02 <DavidWHodgins> The nemo crash only affects cinnamon installs, not xfce, so it's just the i586 classic iso that would need to be rebuilt
20:50:31 <auroud_85[m]> <tmb "after we release RC I will switc"> Lol
20:50:37 <DavidWHodgins> wintpe: It means only changes for critical bugs are allowed in cauldron
20:50:54 <wintpe> so is that not the place to update nemo
20:51:02 <wintpe> as a crash is critical
20:51:29 <DavidWHodgins> wintpe: The fix is already done in cauldron, it's just not on the current iso images.
20:51:46 <wintpe> ok so it could wait till thefinal release dvd
20:52:18 <wintpe> or am i missing the point
20:52:44 <DavidWHodgins> tmb: I think I'd prefer to go with the current iso images, and just have in the RC release notes that people using the i586 classic iso image to install cinnamon must add online media during install
20:53:40 <DavidWHodgins> wintpe: The fix will be on the final iso images for sure. It's already been committed in the online cauldron repos.
20:54:07 <tmb> DavidWHodgins, yeah, I forgot nemo was cinnamon, so not so critical to need respin... but please get an go/no-go from martin for ny other things
20:54:09 <wintpe> great , sound perfect, i agree with you dave dont change the current rc
20:54:24 <DavidWHodgins> tmb: Will do
20:54:50 <bri_an> I have one btw
20:55:07 <tmb> bri_an, what ?
20:55:20 <auroud_85[m]> This sounds good.
20:55:25 <bri_an> I tried an upgrade on classic x86_64.  Without pulling in the Network updates it failed.
20:55:39 <wilcal> IMO we should wrap this David
20:55:45 <bri_an> not a habit I nor users commonly do.
20:56:07 <bri_an> not a RC stopper, but something we need to bundle so it works
20:56:49 <bri_an> but overall it is clean to me
20:57:02 <tmb> bri_an, we now always recommend using online medias during upgrades as we push new updates to mga7 after mga8 is out so there would be conflicts / problems
20:57:28 <DavidWHodgins> I've sent a msg to Martin, cc qa discuss ml asking for any rc5 release blockers
20:57:33 <bri_an> then set that as default in classic
20:58:16 <DavidWHodgins> bri_an: We are not going to change that now. That can be discussed as a feature for Mageia 9.
20:58:24 <bri_an> no issues
20:58:45 <tmb> we try to have proper upgrade path on isos at release time, but...
20:59:27 <DavidWHodgins> #action If Martin agrees with rc5 release, we'll go for release as soon as docteam is ready.
20:59:28 <bri_an> understood we are a small team
21:00:10 <DavidWHodgins> Anything else about the rc iso images before we move on to discussing testing updates?
21:00:22 <wilcal> Not from me
21:00:27 <wintpe> nope
21:00:36 <auroud_85[m]> Nope
21:00:56 <bri_an> nope
21:00:58 <guygoye[m]> nope
21:01:20 <DavidWHodgins> Ok. On the updates, this week I've barely looked at them, due to testing cauldron and working on mageia association issues
21:01:44 <DavidWHodgins> Does anyone have a problem they've encountered with a specific update?
21:01:58 <wilcal> not from me
21:02:02 <wintpe> no
21:02:17 <auroud_85[m]> No, server related. Also I pinged updates that are waiting a feedback from packagers.
21:02:21 <neoclust> tmb: http://check.mageia.org/cauldron/dependencies.html and http://check.mageia.org/cauldron/missing.html is empty
21:02:22 <[mbot> [ dependencies global report ]
21:02:30 <neoclust> tmb: i don't remember a mageia so clean :-)
21:02:41 <DavidWHodgins> lol
21:02:45 <wilcal> M7 is very stable
21:02:46 <bri_an> my son and I are testing nodejs
21:02:58 <bri_an> I should have an approval on that EOD
21:02:59 <wintpe> it does get better every year
21:03:11 <DavidWHodgins> Rather then going over each update, I'll just ask everyone not to forget about the Mageia 7 updates.
21:03:34 <DavidWHodgins> So moving on ...
21:03:37 <DavidWHodgins> #topic Anything else?
21:03:51 <wilcal> I get my first Covid-19 dose tomorrow. If it kills me I'll put a message on the QA ML.
21:03:59 <DavidWHodgins> lol
21:04:03 <neoclust> :)
21:04:06 <auroud_85[m]> Lol
21:04:11 <guygoye[m]> Lol
21:04:14 <auroud_85[m]> Me too this weekend
21:04:18 <wintpe> my wifes had hers, it might hurt your arm a bit
21:04:21 <wilcal> I recommend the SanDisk 16GB Ultra Fit USB 3.1 Flash Drive. They're less than $10 on Amazon
21:04:23 <bri_an> excellent news you're getting it wilcal
21:04:27 <DavidWHodgins> Probably not till August for me here
21:04:31 <auroud_85[m]> Working on intensive health service
21:05:04 <bri_an> I'm hoping for June, but we'll see
21:05:20 <guygoye[m]> Me too not till August
21:05:34 <wintpe> i may get mine in a month as im at risk group
21:05:36 <wilcal> Count it down David
21:05:43 <wilcal> I'll end it
21:05:45 <DavidWHodgins> Agreed
21:05:49 <DavidWHodgins> t - 5
21:05:51 <DavidWHodgins> 4
21:05:54 <DavidWHodgins> 3
21:05:55 <bri_an> good day/night all
21:05:56 <DavidWHodgins> 2
21:05:58 <DavidWHodgins> 1
21:06:00 <wilcal> #endmeeting