20:01:57 <DavidWHodgins> #startmeeting
20:01:57 <Inigo_Montoya> Meeting started Thu Nov 24 20:01:57 2016 UTC.  The chair is DavidWHodgins. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:57 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:09 <DavidWHodgins> #chair lewyssmith MrsB
20:02:09 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB lewyssmith
20:02:27 <DavidWHodgins> Hi everyone. Welcome to another qa team irc meeting
20:02:42 <DavidWHodgins> #topic * Who's new? - If you are then come and say hello.
20:02:55 <lewyssmith> Evening Len.
20:03:00 <DavidWHodgins> Anyone here who hasn't been to a qa team irc meeting before?
20:03:29 <DavidWHodgins> Moving on ...
20:03:33 <DavidWHodgins> #topic * Mageia 5.1 - How do the latest isos look?
20:03:40 <youpburden> yes, I'm new here
20:03:50 <DavidWHodgins> Oops. Too quick
20:04:01 <lewyssmith> youpburden: Please tell us about yourself.
20:04:04 <DavidWHodgins> youpburden: HiYa. Welcome to the qa team
20:04:34 <youpburden> I use Mageia since the 5th release and I try to help by reporting bugs
20:04:34 <lewyssmith> Welcom Thomas.
20:04:51 <DavidWHodgins> I'm Dave Hodgins from London, Ontario, Canada. 55, former ibm mainframe software developer, deputy leader of the qa team since it first had elected leaders
20:05:22 <DavidWHodgins> Have you subscribed to the qa-discuss mailing list?
20:05:55 <youpburden> yes and the security one, I'm more a security focused guy but I'll try to contribute to qa too
20:06:27 <lewyssmith> Ah, perhaps you could help David our security man.
20:06:43 <lewyssmith> He could use it.
20:06:49 <DavidWHodgins> Ah. Yes. Saw your msgs in mageia-dev. Are you familiar with rpm packaging?
20:07:00 <youpburden> I don't know how to patch and package yet, but I report CVE when I can
20:07:16 <DavidWHodgins> lewyssmith: is referring to David Walser, aka Luigi12
20:07:18 <tjandrews> I'm Tom Andrews, better known as "TJ." I'm 67, and a farmer in Central New York State, USA. I've been using Mandrake/Mandriva/Mageia since 2002.
20:07:33 <lewyssmith> youpburden: Where are you?
20:07:40 <youpburden> France
20:07:46 <lewyssmith> Moi aussi.
20:08:26 <youpburden> Je regarde les tutos sur MLO pour l'instant
20:08:40 <DavidWHodgins> There are quite a few people missing here today. Probably a good idea to post a msg introducing yourself to the mageia-discuss mailing list too
20:08:55 <lewyssmith> I am another deputy leader (we grow on trees) expat Celt living in France.
20:09:09 <DavidWHodgins> :-)
20:09:17 <Benmc> Ben McMonagle from Te Awamutu, North Island of New Zealand,  just a normal user, QA for a couple of years
20:09:43 <lewyssmith> And very thorough.
20:09:50 <Benmc> thx
20:10:36 <DavidWHodgins> lewyssmith: As you're both in France, would you be ok as youpburden's mentor
20:10:57 <lewyssmith> If he wishes, avec plaisir.
20:11:51 <DavidWHodgins> youpburden: Ok with you? If ok, lewyssmith will help you get started learning the procedures we use for qa testing of both updates for stable releases, and testing of new iso images
20:12:12 <youpburden> I didn't think it would go this fast, I accept and am ready to learn, Le plaisir est partagé !
20:12:27 <DavidWHodgins> It'll go as fast as you're willing. :-)
20:12:51 <DavidWHodgins> lewyssmith: and youpburden, please exchange email addresses
20:12:57 <tjandrews> We're desperate for all the help we can get...  ;)
20:13:13 <lewyssmith> youpburden: Find my e-mail address from mageia-qa list, et m'envoyer un courriel.
20:13:14 <DavidWHodgins> The qa team is one of the easiest teams to join
20:13:32 <lewyssmith> Very friendly.
20:14:13 <DavidWHodgins> Anyway, let's get back to the Mageia 5.1 iso images
20:14:39 <lewyssmith> The Classic is ready to go - or nearly?
20:14:52 <DavidWHodgins> As I posted to the qa-discuss mailing list, I'm having some weird hardware problems with usb sticks, so can't rely on my testing
20:15:27 <tjandrews> What's with the "i386" stuff on the 32-bit CI version?
20:15:34 <DavidWHodgins> Other then the i386 showing up in the boot menu, any blocker problems found?
20:16:01 <lewyssmith> -2 I was about to ask...
20:16:20 <DavidWHodgins> tjandrews: It's due to the wrong version of syslinux being on the iso. It still works, just adds the i386 item to the menu, or at least that's my understanding
20:16:46 <lewyssmith> Saw Ben's post, but it is not something I ever see.
20:16:54 <tjandrews> I tried it just to see what would happen, and it just started the installer.
20:16:55 <DavidWHodgins> Normally I would not consider it to be a blocker, but it's so visible, I'm thinking perhaps it should be
20:17:14 <DavidWHodgins> It's cosmetic, but so highly visible
20:17:14 <lewyssmith> Disconcerting, certainly.
20:17:24 <lewyssmith> Easy to fix?
20:17:37 <DavidWHodgins> With a rebuild and retest of the iso image
20:17:50 <DavidWHodgins> ennael: ping
20:17:59 <lewyssmith> That could be difficult or easy.
20:18:07 <tjandrews> I kinda wondered if it limited things to stuff that would work on really old machines...
20:18:42 <tjandrews> But that didn't make much sense.
20:18:46 <DavidWHodgins> My understanding is that it doesn't make any difference, as it's the same kernel etc, being loaded
20:19:03 <ennael> pong
20:19:07 <ennael> just in time
20:19:17 <DavidWHodgins> ennael: We're discussing the i386 entry in the menu
20:19:26 <ennael> which menu ?
20:19:42 <DavidWHodgins> Classical installers
20:19:50 <lewyssmith> Ban posted about it on qa-discuss.
20:19:53 <Benmc> i586
20:20:10 <tjandrews> I only remember seeit on the 32-bit version.
20:20:13 <DavidWHodgins> bug 19768
20:20:15 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19768 normal, Normal, isobuild, NEW , [5.1] i386 listed as option initial boot screen
20:20:33 <tjandrews> seeit=seeing it
20:22:02 <tjandrews> Yes, just booted the 64-bit CI on my laptop, and it isn't there.
20:22:38 <DavidWHodgins> ennael: It's a cosmetic bug, but it's so visible, I'm thinking it may be worth fixing/rebuilding the iso for it.
20:22:38 <lewyssmith> Is it not 32-bit specific?
20:23:22 <lewyssmith> I agree.
20:23:48 <Guest9749> the fix is simple, just rename i386 to i586 and adjust menu config accordingly
20:24:12 <DavidWHodgins> Guest9749: HiYa tmb
20:24:27 <Guest9749> hi, seems nickserv does not like me today...
20:24:37 <DavidWHodgins> :-)
20:24:57 <Benmc> lewys: only shows up in legacy boot  for i586, x86_64 legacy  is not there
20:25:20 <lewyssmith> As I understood it.
20:25:35 <ennael> I did not modify anything
20:25:42 <Guest9749> that's because "base arch" for 32bit is i386 (in naming that is)
20:25:43 <ennael> I'm not the one choosing this :)
20:25:50 <ennael> but I can modify it for new iso
20:26:04 <DavidWHodgins> It wasn't there in the iso images prior to this one
20:26:17 <DavidWHodgins> At least, I don't remember seeing it before
20:26:23 <lewyssmith> ennael: Just the i586 one.
20:26:54 <DavidWHodgins> Guest9749: Any idea why it just showed up now?
20:27:03 <tjandrews> Seems to me like it was in the last one before this one, but I'm not sure. I don't have one anymore to check.
20:27:39 <lewyssmith> Dave said earlier: It's due to the wrong version of syslinux being on the iso.
20:28:20 <Benmc> ther is an entire i386 directory on the .iso
20:28:24 <Guest9749> no idea... boot.iso has always used i386 on 32bit, but we dont show it in any menu...
20:28:57 <Benmc> this directory is not on the public release of Mageia5
20:29:30 <lewyssmith> Is there aslo an i586 directory?
20:29:34 <Benmc> yes
20:29:36 <DavidWHodgins> What generates the menu?
20:29:47 <Guest9749> no, because it's syslnux specific and gets added on isos only
20:30:01 <ennael> http://mirrors.kernel.org/mageia/distrib/5/i586/isolinux/
20:30:03 <[mbot> [ Index of /mageia/distrib/5/i586/isolinux/ ]
20:30:35 <Guest9749> yeah, sorry, I forgot it's under isolinux :)
20:30:38 <tjandrews> Looking at the original 5 iso, there is no "i386" directory.
20:32:14 <DavidWHodgins> tjandrews: Mageia 5 i586 iso?
20:32:57 <tjandrews> Ah. on the original, the directory under "isolinux" is named "i586." In 5.1, it's "i386."
20:33:04 <tjandrews> Yes.
20:33:52 <lewyssmith> Odd that it has escaped notice for so long.
20:34:09 <Guest9749> yeah, but technically it does not matter what the name of the directory is, but the menu should not list it...
20:34:29 <DavidWHodgins> Guest9749: Weren't there recent commits of changes for the drakx utilities used for building the iso images?
20:35:14 <Guest9749> nope, nothing that would affect this... as I said on all drakx-installer-images the dir under isolinux is i386
20:35:46 <Guest9749> it was the same in mga4 and mga5, the current mga5.1 isos and mga6 sta1
20:36:46 <lewyssmith> Martin confirmed the problem; but there is no picture nor itemisation of it (menu).
20:37:53 <tjandrews> "i386" is an additional item, in the middle of the ones that are expected.
20:38:07 <lewyssmith> Marja suggested it may be a hangover from the old dual-arch ISOs.
20:39:09 <lewyssmith> -2 In which case we could leave it, since the menu entry does something useful.
20:39:34 <Guest9749> anyway, the problem and quickfix is known,  lets just fix it and move on
20:40:02 <lewyssmith> OK. What about the Live ISOs?
20:40:34 <DavidWHodgins> Live iso images are ok to release, from what I've seen
20:40:44 <DavidWHodgins> Anyone disagree?
20:40:59 <lewyssmith> dvg had problems.
20:41:35 <tjandrews> Wilcal had some problems with screen resolution, but he voted in an email to let them go.
20:41:51 <lewyssmith> Apparently we still need to do release notes & errata! Who, how?
20:42:43 <lewyssmith> I noticed that the rlease notes in the Classic installer at least made no refrence to the release.
20:43:01 <DavidWHodgins> Ah. See in the pad dvg had the good luck error with live mode
20:43:35 <lewyssmith> And ran into Udev error at the end of another install.
20:44:09 <DavidWHodgins> That's with the gnome iso. No indication if the same problem with the original Mageia 5 iso images. May be due to no proprietary driver, which we can't do anything about
20:44:33 <DavidWHodgins> dvg was ok with kde
20:45:27 <lewyssmith> Can we vote on the ISOs? first, for correcting the i386 issue?
20:45:34 <lewyssmith> I say yes.
20:45:54 <DavidWHodgins> ennael: Are you clear on how to fix the i386 menu entry?
20:46:22 <lewyssmith> [with advice from tmb].
20:46:35 <ennael> in progress
20:47:41 <DavidWHodgins> Ok. There is at least one more iso image being built. Let's wait for that, work on the release notes and errata, and plan on releasing this weekend if everything ok
20:47:54 <tjandrews> Meaning you've already done it and a new iso is on the way?
20:48:01 <lewyssmith> So, 1 more Classic i586 ISO on the way. For the rest, I say OK. And for the rest of you?
20:48:09 <DavidWHodgins> tjandrews: It takes a while to build the iso image
20:48:36 <tjandrews> Sure. I was just looking for clarification.
20:48:46 <DavidWHodgins> The rest are ok, but I'd rather we wait, and release all of the iso images at the same time
20:49:14 <ennael> ok i386 remonved from menu I will upload iso in 5 minutes
20:49:26 <DavidWHodgins> Great. Thanks
20:49:36 <lewyssmith> -3 The important thing is that we agree they *are* OK. To release whenever.
20:50:06 <DavidWHodgins> Is anyone against release once we have the new i586 iso image tested?
20:50:12 <tjandrews> Other than that menu, I saw no problems.
20:50:17 <Benmc> Lewyssmith: agreed, just waiting on i586
20:50:17 <ennael> (shall I update the pad ?)
20:50:26 <DavidWHodgins> ennael: Yes please
20:50:28 <Guest9749> hm, maybe I should fix boot.iso (for mga6) to use i586 as dir under isolinux on 32bit... (still cosmetic, but...)
20:50:49 <lewyssmith> -4 Best to.
20:50:52 <ennael> I must say I did not see it before :)
20:51:21 <lewyssmith> We learn something new every day!
20:51:32 <DavidWHodgins> Me neither till Ben reported it
20:51:53 <ennael> Guest9749: is it just about make_boot_img ?
20:52:41 <lewyssmith> Repeat: who/how for release notes & errata?
20:52:53 <Guest9749> hm, could bcd/syslinux be relying on some macro that now returns i386 ? mga5 isos were built on mga4 host, mga5.1 isos are built on mga5 host
20:53:36 <Guest9749> ennael, not sure yet, iirc syslinux itself does some stuff...
20:53:58 <DavidWHodgins> The only important change I'm aware of for the release notes and errata, is the lack of proprietary video drivers on the iso images, which may cause problems for some video cards
20:54:23 <ennael> Guest9749: check mirror it uses also i386
20:54:39 <ennael> so it's not about bcd but rather about isolinux.cfg
20:54:54 <lewyssmith> -3 How do we add that?
20:55:22 <lewyssmith> With advice about how to fix post-install.
20:56:15 <DavidWHodgins> lewyssmith: I'm thinking we can just add that to existing release notes and errata for Mageia 5. Less work for translators that way
20:56:23 <Benmc> for release notes- some wifi cards not supported on Lives (I'm looking at you =>  BCM4311)
20:56:50 <lewyssmith> DavidWHodgins: But how exactly?
20:57:37 <DavidWHodgins> Benmc: Is that new with Mageia 5.1, or was it present with Mageia 5?
20:57:42 <ennael> Guest9749: confirmed. isolinux.cfg comes from drakx-installer-images. When new package is released it's deployed in repository in isolinux/
20:58:21 <Benmc> David - dont know, only recently aquired a unit with the card
20:58:28 <Benmc> will check later
20:59:35 <tjandrews> The BCM4318 works fine again with b43-openfwwf. Odd.
21:00:17 <DavidWHodgins> I'll look at them later tonight or early tomorrow. We should discuss it on the mailing list, as there are people not here. I'll update the release notes and errata, after discussing the changes on the mailing list
21:00:45 <lewyssmith> Agreed. good of you. Move on now?
21:00:47 <Guest9749> ennael, I know that, it has always been i386... but I dont know what has changed in CI build process to leave i386 in menu (unless you manually removed it during mga4/5 builds)
21:02:14 <Guest9749> anyway lets move on for now
21:02:18 <DavidWHodgins> #info New i586 classical iso image being built, and will need testing asap
21:02:35 <ennael> Guest9749: nope no modification
21:02:39 <DavidWHodgins> #action I'll update the release notes and errata tomorrow
21:02:40 <ennael> DavidWHodgins: iso available
21:02:57 <lewyssmith> Rapide!
21:03:07 <DavidWHodgins> Syncing now
21:03:47 <DavidWHodgins> Sync done.
21:04:13 <Benmc> wish my connection was that speedy :)
21:04:14 <DavidWHodgins> Testing should be quick
21:04:36 <lewyssmith> Ben & TJ...
21:04:37 <DavidWHodgins> It's a very small change, so rsync doesn't have much to download
21:05:06 <Benmc> yes.....?
21:05:22 <tjandrews> Yes?
21:05:24 <DavidWHodgins> Confirmed the i586 entry is gone
21:05:34 <Benmc> i386?
21:05:39 <DavidWHodgins> s /i586/i386/ :-)
21:05:41 <lewyssmith> On your marks - but you were already off the blocks.
21:05:50 <tjandrews> Syncing now. Had to boot up the laptop first.
21:06:31 <DavidWHodgins> ennael: Guest9749 Thanks for the quick fixing
21:06:49 <lewyssmith> DavidWHodgins: How did you boot so quickly? VB?
21:06:53 <DavidWHodgins> install in progress, looks ok so far
21:06:59 <DavidWHodgins> Yes, testing under vb
21:07:19 <tjandrews> Just to be sure, I'll put it on a usb stick and boot from that.
21:07:27 <DavidWHodgins> Thanks
21:07:35 <DavidWHodgins> Anyway, Moving on
21:07:40 <DavidWHodgins> #topic * Mageia 6 - After 5.1 gets released
21:07:54 <lewyssmith> Too soon, Dave.
21:08:03 <DavidWHodgins> Oops
21:08:12 <tjandrews> Mageiasync done, checking checksums...
21:08:29 <lewyssmith> I meant to talk about M6. One thing at a time. And all those updates.
21:09:08 <tjandrews> Uh-oh. MD5 says OK, SHA12 says Failed.
21:09:30 <tjandrews> SHA512
21:10:42 <DavidWHodgins> ennael: sha512 file is still from Nov 22
21:11:06 <Guest9749> its ok on rabbit
21:11:30 <ennael> grumbl
21:11:41 <Guest9749> and dated nov 24 on rabbit
21:11:54 <Guest9749> so re-check your syncs
21:11:55 <ennael> argh
21:11:56 <tjandrews> Would you rather I kept quiet?
21:12:01 <ennael> nope wrong file name
21:12:05 <ennael> my bad sorry
21:12:22 <ennael> should be better
21:12:26 <ennael> you can sync again
21:12:30 <DavidWHodgins> Ah. DVD.sha512 instead of DVD.iso.sha512
21:12:35 <ennael> yep
21:12:39 <ennael> I changed it
21:12:58 <Guest9749> ah, I just used -c on existing files, didnt read the name :)
21:13:25 <DavidWHodgins> Yep. It passes check now
21:13:38 <tjandrews> Checking...
21:13:47 <DavidWHodgins> Ok to move on to discussing Mageia 6 now?
21:14:10 <tjandrews> Both OK.
21:14:40 <DavidWHodgins> ennael: Guest9749 Any eta on how soon Mageia 6 sta2 iso images will be ready?
21:15:40 <DavidWHodgins> brb
21:15:59 <lewyssmith> I think we should see 5.1 out of the door before pushing  M6.
21:16:29 <lewyssmith> ...for M6.
21:17:02 <DavidWHodgins> back
21:17:08 <ennael> well I built some isos yesterday evening
21:17:17 <DavidWHodgins> lewyssmith: Yes, but hopefully that will be this weekend
21:17:23 <ennael> and had a good surprise. Nearly no rpmcheck errors
21:17:30 <ennael> so that's a bug improvment
21:17:33 <ennael> big
21:17:34 <DavidWHodgins> Yeah
21:17:47 <ennael> Guest9749: one thing
21:18:00 <Guest9749> ennael, yes ?
21:18:01 <ennael> we have 3 or 4 different kernels in core/release
21:18:17 <Guest9749> for mga6 ?
21:18:38 <ennael> yep
21:18:54 <DavidWHodgins> That's like on an installed system, where new kernels don't remove old ones
21:18:59 <ennael> kernel-desktop-4.8.10-1.mga6-1-1.mga6.i586.rpm
21:19:00 <ennael> kernel-desktop-4.8.8-1.mga6-1-1.mga6.i586.rpm
21:19:00 <ennael> kernel-desktop-4.8.9-1.mga6-1-1.mga6.i586.rpm
21:19:08 <Guest9749> ok, will run manual cleaning on primary mirror and resync rabbit after
21:19:23 <ennael> ok no hurry
21:19:24 <ennael> thanks
21:19:32 <lewyssmith> We have a long list of updates which will just get ignored if new M6 ISOs are announced immediately.
21:19:51 <ennael> lewyssmith: I'm not releasing isos
21:19:57 <ennael> but working on content and first tests
21:20:01 <ennael> I will upload it :)
21:21:07 <lewyssmith> In due course, of course.
21:21:17 <DavidWHodgins> So not much to discuss about Mageia 6 until after the Mageia 5.1 iso images are released
21:21:29 <ennael> oups
21:21:33 <ennael> I will not upload it
21:21:38 * ennael eats words
21:21:39 <DavidWHodgins> :-)
21:22:03 <lewyssmith> J'aime 'oups'!
21:22:03 <DavidWHodgins> Everyone ready to move on then?
21:22:39 <DavidWHodgins> #topic * Testing updates - Any difficulties, problems, issues?
21:23:15 <lewyssmith> The list is long with few OKs. Herman has been busy on them, thankfully.
21:23:28 <tjandrews> lewyssmith: seems like there's ALWAYS a long list of updates these days.
21:23:50 <lewyssmith> It is the emty OK space that is worrying!
21:23:56 <DavidWHodgins> I'll validate the kernel updates tomorrow, after some more testing of the various ones available, on real hardware, if no problems found
21:24:31 <DavidWHodgins> lewyssmith: Most of them are fairly new. Easy to test, just a matter of getting around to doing it.
21:25:12 <lewyssmith> Finding the time...
21:25:23 <DavidWHodgins> Just a reminder. http://madb.mageia.org/tools/updates shows the updates waiting for qa testing
21:25:25 <[mbot> [ Mageia App Db - Current Update candidates ]
21:26:59 <DavidWHodgins> We'll skip Luigi's roundup of upcoming security updates. http://madb.mageia.org/tools/security shows the packages waiting for packages to provide updates
21:27:01 <[mbot> [ Mageia App Db - Security issues ]
21:27:36 <DavidWHodgins> That only leaves ...
21:27:39 <DavidWHodgins> #topic * Anything else?
21:27:47 <lewyssmith> Not here.
21:27:49 <DavidWHodgins> Nothing else here.
21:28:36 <tjandrews> A watched usb stick never finishes.
21:28:44 <DavidWHodgins> :-)
21:28:50 <lewyssmith> Thank you Dave for chairing, and everyone who came. Goodbye everyone.
21:28:50 <DavidWHodgins> Countdown time then
21:28:54 <DavidWHodgins> t - 5
21:28:58 <DavidWHodgins> 4
21:29:03 <DavidWHodgins> 3
21:29:06 <DavidWHodgins> 2
21:29:12 <DavidWHodgins> Thanks for coming everyone
21:29:15 <DavidWHodgins> 1
21:29:22 <DavidWHodgins> #endmeeting