19:03:04 <MrsB> #startmeeting
19:03:04 <Inigo_Montoya> Meeting started Thu Jun  9 19:03:04 2016 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:04 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:11 <MrsB> morning all, welcome to another one
19:03:13 <DavidWHodgins> #topic
19:03:15 <DavidWHodgins> http://www.openwall.com/lists/oss-security/2016/05/27/7
19:03:16 <[mbot> [ oss-security - Re: CVE request: VLC - crash and potential code execution when processing QuickTime IMA files ]
19:03:16 <DavidWHodgins> http://git.videolan.org/?p=vlc/vlc-2.2.git;a=blob;f=NEWS;h=1af86bef0317c8882acc363a7c8fc5e83097c7bd;hb=888b7e89d78e7073075fc0a007d47b93f4570fab
19:03:18 <DavidWHodgins> ========================
19:03:19 <[mbot> [ git.videolan.org Git - vlc/vlc-2.2.git/blob - NEWS ]
19:03:20 <DavidWHodgins> oops
19:03:36 <MrsB> #chair DavidWHodgins lewyssmith
19:03:36 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB lewyssmith
19:03:43 <DavidWHodgins> #topic * Who's new? If you are then come and say hi
19:03:52 <MrsB> dude :)
19:03:54 <wilcal> Yipppeeee!! I'm not in charge :-))
19:03:59 <MrsB> Is there anybody new here today?
19:04:12 <MrsB> oh, yeah. You can be if you like?
19:04:19 <DavidWHodgins> Meant to paste in the topic, but forgot I had the vlc stuff in the pasted buffer. :-)
19:04:41 <MrsB> nobody new today
19:04:45 <DavidWHodgins> #topic * Mageia 6 - How's it looking?
19:04:53 <wilcal> OOOoooOooOo
19:04:56 <DavidWHodgins> I haven't tried the latest iso images yet
19:04:59 <MrsB> Sooooo.. how's it looking?
19:05:01 <lewyssmith> is it safe to try?
19:05:04 <wilcal> what am I doing wrong
19:05:10 <MrsB> me either Dave
19:05:14 <tmb> No need to try... we need new isos
19:05:22 <MrsB> grub2?
19:05:26 <tmb> yep
19:05:26 <wilcal> you can say that again
19:05:38 <MrsB> #info There will be new isos for grub2 fixes
19:05:43 <wilcal> what is that graphical good luck thingy
19:06:08 <MrsB> it's what happens when X fails to start
19:06:11 <DavidWHodgins> That's when X fails to start for gnome
19:06:22 <tmb> I think I saw tv adding the missing fixes, so hopefully ennael will hage time to rebuild Classical isos
19:06:24 <wilcal> I tried it everywhere and it failed everywhere
19:06:43 <wilcal> Is there a specific bug for that?
19:07:03 <MrsB> yeah, great. It'll be good to make the move finally, even if it is a bit controversial.
19:07:21 <rindolf> Hi all.
19:07:24 <wilcal> I'm get'n good at get'n the logs from a busted install :-))
19:07:25 <MrsB> morning
19:07:41 <MrsB> it's been good practise then wilcal
19:07:43 <rindolf> Almost missed the meeting.
19:07:49 <wilcal> it has
19:07:58 <MrsB> So we may as well move on then and await the next set of ISOs
19:08:02 <rindolf> I haven't tried the latest ISOs either.
19:08:30 <MrsB> #action MrsB to email qa-d about isos
19:08:56 <MrsB> dude
19:09:11 <DavidWHodgins> #topic * Testing updates - any problems, difficulties, issues.
19:09:11 <wilcal> wait for the next ones rin
19:09:17 <MrsB> tah :)
19:09:35 <MrsB> We've pushed all the bits now that were making kernel testing difficult
19:09:53 <tarazed> Managing to get a grip on wireshark at last.
19:09:57 <MrsB> kernels are awaiting feedback atm due to some sound issues
19:10:08 <MrsB> well doen Len, what was the problem?
19:10:27 <wilcal> i wanted to mention that you can test vlc on infinitium
19:10:35 <tarazed> General ignorance.  Have the PoCs now.
19:10:47 <MrsB> lol nowt wrong with that
19:10:59 <wilcal> some things are not so good but this was a security update not a functional test
19:11:44 <DavidWHodgins> IIRC, libimobiledevice needs an iphone or similar, to connect to for testing
19:11:44 <MrsB> So can we try and clear the non kernel updates for now, so we're ready when they are and can all dive onto those
19:11:54 <lewyssmith> Congratulations to whoever did the openslp thing.
19:11:55 <MrsB> yeah, just do basic tests
19:12:09 <DavidWHodgins> lewyssmith: It's very easy to test
19:12:16 <wilcal> yippppeeeee!!! I get to test wireshark again :-))
19:12:28 <DavidWHodgins> wilcal: It seems to never end.
19:12:44 <lewyssmith> DavidWHodgins: *IF* you know how.
19:12:55 <wilcal> wireshark - another career app
19:13:06 <lewyssmith> Bug 18433 is a serious affair.
19:13:30 <lewyssmith> I looked into it once: the background was hard.
19:13:34 <DavidWHodgins> lewyssmith: See the comment I added to but 18600
19:13:49 <lewyssmith> https://bugs.mageia.org/show_bug.cgi?id=18433
19:14:05 <MrsB> is [mbot broken?
19:14:25 <DavidWHodgins> s /but 18600/bug 18600/
19:14:38 <DavidWHodgins> bug 18600
19:14:46 <DavidWHodgins> Yep. Mbot is not working
19:15:02 <lewyssmith> You can copy/paste the links.
19:15:26 <MrsB> The reporter has confirmed the fix, so just basic tests again
19:15:40 <lewyssmith> But back to 18433. What are we going to do? Just test installe/update it?
19:16:15 <DavidWHodgins> lewyssmith: That's good enough, as the actual fix has been confirmed to work
19:16:19 <MrsB> seems like he has added a require for openssh-askpass-qt4
19:16:28 <MrsB> use urpmq to confirm
19:16:32 <lewyssmith> It has not been left 20d for nothing.
19:16:57 <Luigi12_work> for libimobiledevice/libusbmuxd just confirm it updates and an application linked to it can run
19:17:09 <Luigi12_work> I don't even know how to make it listen on a port, which is what the issue is about
19:17:18 <MrsB> you can even use the rpmdiff in madb to check what's changed, check the require
19:19:16 <lewyssmith> Can we validate https://bugs.mageia.org/show_bug.cgi?id=18594 poedit with its 1 good OK?
19:19:28 <DavidWHodgins> Yes
19:19:35 <lewyssmith> Will do.
19:19:51 <DavidWHodgins> I'll add the advisory to svn after the meeting
19:19:54 <MrsB> any other problem ones?
19:20:44 <wilcal> you ok with VLC testing david?
19:20:50 <DavidWHodgins> gitpython may take some work to figure out
19:20:54 <Luigi12_work> wilcal: sure
19:20:54 <MrsB> apache mod perhaps. not updated that one before so it'll need experimenting with
19:21:07 <lewyssmith> https://bugs.mageia.org/show_bug.cgi?id=18540 git python has been left for some time, which is ominous.
19:21:22 <Luigi12_work> the apache mod one, you can install it and start apache and make sure httpd -M show that module loaded
19:21:42 <MrsB> yeah, no idea what it's supposed to do tho
19:21:47 <Luigi12_work> currently loading that module crashes apache, so it's a pretty obvious fix
19:22:04 <Luigi12_work> yeah who knows what it does, we've used httpd -M to test weird apache mods before
19:22:31 <Luigi12_work> we can ask the original reporter to make sure it "works" too, since he presumably knows what it does
19:22:41 <MrsB> Soemthing to do with zeroconf. If it's just a crash fix that's easy though you're right
19:22:57 <Luigi12_work> yeah, loading and not crashing apache is better than not working at all :o)
19:23:37 <MrsB> i'll do that one after then
19:23:44 <MrsB> Ready to move on?
19:23:53 <DavidWHodgins> #topic * Luigi's roundup - Security news & upcoming updates
19:24:13 <wilcal> moving along nicely today :-))
19:24:20 <DavidWHodgins> :-)
19:24:31 <MrsB> need to ping him
19:24:36 <MrsB> Luigi12_work: ping :D
19:24:39 <Luigi12_work> posted the roundup to the list
19:24:54 <MrsB> #info Roundup was posted to qa-discuss
19:24:55 <lewyssmith> Luigi12_work: Do you want me to copy/paste your e-mail summary here?
19:25:04 <MrsB> go for it lewis
19:25:08 <Luigi12_work> https://ml.mageia.org/l/arc/qa-discuss/2016-06/msg00068.html
19:25:18 <Luigi12_work> tmb: is Thunderbird OK to go?
19:25:24 <Luigi12_work> leuhmanu said it works fine for him now
19:25:40 <Luigi12_work> lewyssmith: yeah, it's only like 4 lines, go for it
19:25:44 <lewyssmith> - still waiting for packager action with the imagemagick and graphicsmagick updates
19:25:44 <lewyssmith> - waiting for a status update from tmb on Thunderbird
19:25:44 <lewyssmith> - new bugs filed for dnsmasq, libtorrent-rasterbar, puppet, spice, glibc, libtirpc, and openssl
19:25:44 <lewyssmith> - plenty of older ones still needing packager action
19:25:51 <tmb> Nope, I still need to fix the MIA calendar
19:26:08 <MrsB> Sooo, that only leaves...
19:26:14 <DavidWHodgins> #topic * Anything else
19:26:19 <MrsB> Is there anything else?
19:26:25 <DavidWHodgins> Nothing else here
19:26:28 <wilcal> just any idea on next M6 isos
19:26:36 <MrsB> go on bill
19:26:41 <lewyssmith> Please confirm we can expect new ISO.
19:26:45 <MrsB> yes
19:26:52 <lewyssmith> Thanks.
19:26:53 <wilcal> when
19:26:57 <ennael> hi there sorry
19:27:02 <MrsB> hi anne
19:27:08 <wilcal> hello anne
19:27:14 <lewyssmith> Bonsoir Anne.
19:27:32 <wilcal> just the right entry time
19:27:49 <MrsB> who knew we'd be done in 30 mins :D
19:27:53 <lewyssmith> tarazed: Welcome back, Len. Tardy greeting, I know.
19:27:59 <wilcal> next M6 isos when?
19:28:06 <tmb> ennael, will you have time to build isos ?
19:28:13 <tarazed> Thanks Lewis
19:28:23 <ennael> yep I was testing some but saw some more fixes
19:28:34 <ennael> do we have all of them?
19:28:44 <wilcal> i've a mostly empty weekend
19:29:14 <tmb> I see tv fixed a grub upgrade issue in git, not yet pushed to buildsystem
19:29:22 <ennael> ok
19:29:39 <tarazed> What about the graphics?
19:29:47 <tmb> Maybe we should roll that fix in, then build the isos
19:29:56 <tmb> tarazed, what about it ?
19:30:12 <tmb> meaning "what graphics" ?
19:30:33 <tarazed> I had an issue with an older laptop but don't think I reported a bug on it.
19:31:01 <tmb> tarazed, well, in that case its hard to fix... :)
19:31:33 <tarazed> The problem was I could not get any debugging info because the monitor went into test mode.
19:31:53 <DavidWHodgins> test mode?
19:31:57 <MrsB> try to ssh to it
19:32:04 <tarazed> It is something which occurs often.
19:32:36 <MrsB> or switch to tty sometimes brings it back up when that happens
19:32:58 <tarazed> Tried that - no go
19:33:03 <DavidWHodgins> Please describe what you mean by test mode
19:33:24 <tarazed> ssh needs some kind of setup at bothe ends.
19:33:58 <DavidWHodgins> Also, is it a crt or a digital monitor?
19:34:12 <MrsB> lap so i guess not crt :D
19:34:15 <MrsB> laptop
19:34:17 <tarazed> As soon as the X driver fails or whatever the screen displays alternating RGB colours and black, forever.
19:34:28 <Luigi12_work> probably the video card crashing the computer
19:34:42 <Luigi12_work> bad video driver or bad settings probably
19:34:45 <MrsB> yes, could be a kernel crash
19:34:51 <Luigi12_work> ssh doesn't require setup, but won't work if it's crashed
19:35:00 <Luigi12_work> be good to verify that though
19:35:06 <DavidWHodgins> Sounds like a graphics mode not supported by the video card. Try various kernel video parameters
19:35:11 <tarazed> OK willdo
19:35:49 <tarazed> Will try vesa as well
19:36:11 <DavidWHodgins> And file a bug report. :-)
19:36:23 <tarazed> Yeah, right
19:36:24 <tmb> tarazed, try to remove "splash quiet" from kernel command line to get text output before crash
19:36:27 <Luigi12_work> yes tmb is not a mind reader :o)
19:36:52 <tmb> not yet anyway :)
19:36:52 <lewyssmith> Despite his considerable talents!
19:37:09 <MrsB> it'son his todo list
19:37:18 <DavidWHodgins> lol
19:37:30 <MrsB> Is there anything else else?
19:37:33 <wilcal> during the stage 2 part of the install how quickly are the tty terminal fucntions available
19:38:05 <MrsB> when the graphical installer is displayed, the tty's are available
19:38:17 <DavidWHodgins> As soon as multi-user part is done, before the gui is started
19:38:25 <wilcal> i've been killing installs early to test that
19:38:36 <wilcal> wow that's early
19:38:45 <wilcal> will it also mount a usb drive
19:38:47 <MrsB> it uses the old tty7 for GUI though rather than tty1
19:39:00 <wilcal> that to get logs outta there
19:39:18 <MrsB> yes, not automatically though. If you're trying to get logs, just plug in a usb stick and type "bug" in tty
19:39:33 <wilcal> k
19:39:38 <MrsB> if you want to mount it to do stuff manually, you have to mount it manually
19:39:51 <wilcal> ya i can now do that :-))
19:40:06 <MrsB> bug command mounts it and drops logs onto it then (iirc) unmounts it
19:40:14 <wilcal> trying to get logs earlier and earlier
19:40:14 <lewyssmith> 'bug' for Live or Classic or both?
19:40:19 <MrsB> classical
19:40:43 <MrsB> live installer runs in a window on the desktop anyway so journal is always available
19:41:02 <MrsB> in live mode install at least
19:41:16 <lewyssmith> I need to ask about this on the MailList, to enhance the ISO testing Wiki. Someone asked.
19:41:17 <wilcal> journalctl >> journalctl.txt  :-))
19:41:56 <lewyssmith> But where is journalctl.txt ?
19:42:07 <DavidWHodgins> Current directory
19:42:11 <wilcal> can put it in /tmp
19:42:15 <MrsB> that command creates it
19:42:17 <wilcal> done that a couple times
19:42:32 <wilcal> and get it with a live media
19:42:42 <wilcal> or copy it to a mounted usb
19:42:43 <DavidWHodgins> To put it on a usb stick, mount it and then add the path "journalctl -ab >/mnt/stick/"
19:43:40 <wilcal> ok i'm done
19:43:50 <MrsB> Is there anything else else else?
19:43:53 <DavidWHodgins> Not here
19:44:06 <lewyssmith> Not here.
19:44:21 <MrsB> T - 5 then
19:44:27 <MrsB> thanks for coming everyone
19:44:30 <MrsB> 4
19:44:32 <MrsB> 3
19:44:33 <MrsB> 2
19:44:35 <MrsB> 1
19:44:37 <MrsB> #endmeeting