19:20:26 <MrsB> #startmeeting
19:20:26 <Inigo_Montoya`> Meeting started Thu Apr  7 19:20:26 2016 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:20:26 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:20:35 <MrsB> Welcome to another typo night
19:20:46 <TheSuperGeek> Yes :)
19:20:48 <rindolf> Hi all.
19:20:49 <MrsB> quick topic before we get into it
19:20:57 <MrsB> #topic Election results
19:21:05 <tarazed> Hi rindolf
19:21:22 <MrsB> Thanks to everyone who took part in the election process, both volunteers and voters
19:21:43 <MrsB> We now have Myself, DavidWHodgins and lewyssmith as leaders
19:22:10 <MrsB> Lewis won't be taking a council seat so we held elections to fill that role
19:22:33 <MrsB> Congratulation to wilcal who was elected
19:22:38 <wilcal> Take bow
19:22:40 <lewyssmith> Great!
19:22:43 <MrsB> all happy?
19:22:45 <wilcal> takes bow
19:23:13 <MrsB> #chair lewyssmith DavidWHodgins
19:23:13 <Inigo_Montoya`> Current chairs: DavidWHodgins MrsB lewyssmith
19:23:31 <MrsB> #topic Who's new?
19:23:44 <MrsB> Is there anybody new here today?
19:24:18 <MrsB> doesn't look like it
19:24:20 <DavidWHodgins> #topic * Mageia 6 Plasma with neoclust
19:24:24 <MrsB> thanks dave
19:24:34 <MrsB> So welcome to neoclust :)
19:24:57 <MrsB> As you all know there have been numerous issues with plasma so far
19:25:05 <MrsB> did you all bring a list?
19:25:15 <neoclust> MrsB: you lie ;)
19:25:21 <MrsB> *shock*
19:25:39 <MrsB> where do you want to start Nicolas?
19:26:04 <neoclust> i want to read your questions, and try to help
19:26:13 <neoclust> you may have "blocker" things
19:26:17 <Linuxero> Hi all
19:26:19 <neoclust> bugs, etc
19:26:22 <Linuxero> Akien: thanks
19:26:23 <rindolf> Linuxero: hi.
19:26:24 <MrsB> ok thanks. This is really over to you now then guys
19:26:32 <tjandrews> Actually, I haven't had many issues except for look and feel, once I finally got it to install...
19:26:41 <MrsB> Who has a plasma bug?
19:26:42 <Linuxero> neoclust: I'm lost, but i got the tarball
19:26:48 <Linuxero> rindolf: hi
19:26:54 <neoclust> Linuxero: go on #mageia-dev please :)
19:27:00 <wilcal> I can't tell you if they are bugs or features :-0
19:27:05 <Linuxero> neoclust: ok
19:27:11 <tjandrews> Two volume controls?
19:27:15 <MrsB> let loose then wilcal neoclust can help :)
19:27:17 <neoclust> tjandrews: fixed on last isos
19:27:22 <rindolf> neoclust: right now I'm running into this problem - https://bugs.mageia.org/show_bug.cgi?id=18130#c1
19:27:22 <Linuxero> MrsB: Arabic is not well-rendered in plasma
19:27:24 <[mbot> Bug 18130: major, Normal, mageia, NEW , unable to install plasma5  libKF5Kipi.so.30.0.0 required, task-plasma5
19:27:34 <neoclust> tjandrews: we now only install plasma-pa, not kmix anymore
19:27:43 <wilcal> first and foremost
19:27:44 <wilcal> Today on real hardware I attempted a boot.iso that failed. The boot.iso app worked but not the installed
19:27:46 <wilcal> I was successful to install the 6dev1 CI and that updated with only a couple minor complaints
19:28:04 <wilcal> so I can create a working platform
19:28:07 <neoclust> rindolf: i am fixing digikam build , so consider this as fixed
19:28:18 <rindolf> neoclust: ok.
19:28:30 <neoclust> ennael: this is an issue for you :)
19:28:34 <wilcal> can I start with something extremely basic
19:28:43 <MrsB> arabic issue from your student neoclust
19:29:17 <wilcal> ready
19:29:33 <MrsB> yep, it'll help if there is a bug report too tho
19:30:12 <wilcal> in KDE a ctrl-f8 presents a screen with the working desktops. That is supposed to work in Plasma and does not at all
19:30:24 <wilcal> bug or feature?
19:30:30 <hviaene> How many dev steps are considered/planned now??
19:30:53 <DavidWHodgins> hviaene: Council hasn't decided yet.
19:30:56 <Linuxero> Plasma is flickering when opening new windows, minimising or maximising, changing windows...etc
19:31:30 <neoclust> can we do "bugs/features" at once ?
19:31:34 <neoclust> i am a little lost now
19:32:16 <hviaene> I have no blocking bugs for dev2 if at least a dev3 is to follow
19:32:41 <MrsB> so far we have arabic issues, window flickering when minimised/maximised as bugs
19:32:57 <neoclust> is there a bugreport for arabic issues ?
19:33:05 <MrsB> Linuxero: ?
19:33:37 <hviaene> You want me to list all my Plasma bugs??
19:33:50 <ennael> hi there
19:33:52 <neoclust> hviaene: list "no", report "yes"
19:34:02 <wilcal> I'm not convinced that a "Plasma Bug" is appropriate right now
19:34:03 <tarazed> Morning Anne
19:34:04 <neoclust> hviaene: but we need to see if this is mageia bug or an upstream bug
19:34:05 <Linuxero> I confirmed the arabic bug by mustafa and I cannot remember if I reported one for plasma. I'll check
19:34:23 <MrsB> morning ennael
19:34:33 <Linuxero> MrsB: the whole desktop flickers
19:34:36 <neoclust> Linuxero: if still valid please report it "upstream" and add me as cc:
19:34:36 <wilcal> hello Anne
19:34:45 <MrsB> herman do you have bug reports for them all?
19:35:00 <Linuxero> neoclust: it is still valid. I'll do
19:35:04 <hviaene> Bug 17958 - Dolphin crashes when copying file into same directory
19:35:05 <neoclust> can i tell something really really really important ?
19:35:20 <DavidWHodgins> neoclust: Go ahead
19:35:22 <wilcal> yes
19:35:26 <hviaene> yes
19:35:32 <neoclust> For bugreports in plasma
19:35:39 <neoclust> i want to clarify something
19:35:57 <neoclust> and this is a discussion that took place on KDE MLs too
19:36:06 <neoclust> if a bug is Distro specific
19:36:25 <neoclust> it MUST be reported on the distro bugtracker ( our bugzilla )
19:36:32 <neoclust> if this is a KDE/PLASMA bug
19:36:48 <neoclust> it MUST be reported on kde bugzilla ( bugs.kde.org )
19:36:55 <neoclust> this way the resolution is quicker
19:37:03 <MrsB> aswell as though rather than instead of
19:37:17 <neoclust> MrsB: what ?
19:37:24 <MrsB> How will the QA team know if a bug is distro specific?
19:37:31 <wilcal> I can't honestly tell you I know enough about Plasma to be able to decide either way
19:37:32 <DavidWHodgins> Report on both kde bugzilla and our bugzilla
19:38:16 <lewyssmith> [Thanks Dave]
19:38:38 <hviaene> That would defeat what the plasma pepple want
19:38:46 <hviaene> people
19:38:57 <tarazed> And if you think it is a plasma bug indicate that the report will be cloned.
19:39:03 <wilcal> If I knew what Plasma was supposed to do then maybe that would help
19:39:05 <hviaene> And I can see their point
19:39:10 <Linuxero> neoclust: how can i add you to the bug report? https://bugs.mageia.org/show_bug.cgi?id=18146
19:39:12 <[mbot> Bug 18146: critical, High, bugsquad, NEW , Plasma Arabic Dialogs and Windows are scrabbled
19:39:38 <MrsB> enter 'neoclust' into the CC field Linuxero
19:39:48 <neoclust> Linuxero: i told on kde bugzilla :p
19:40:06 <neoclust> DavidWHodgins: i don't think adding on our bugzilla TOO is needed
19:40:13 <rindolf> good night, everyone - I'm too tired.
19:40:17 <rindolf> bye all.
19:40:19 <wilcal> nite rin
19:40:23 <DavidWHodgins> rindolf: Have a good night
19:40:25 <Linuxero> I tried, but i get a non-match error!!
19:40:28 <neoclust> DavidWHodgins: but you can add me as cc: so i follow the bugreports and add the patches when needed
19:40:39 <MrsB> neoclust: how will we know which bugs to report on KDE bugzill and which bugs to report on our bugzilla?
19:40:44 <Linuxero> rindolf: bye
19:40:57 <wilcal> Absolutely MrsB
19:41:14 <neoclust> MrsB: you see if this is missing requies, etc.  You QA'ed :)
19:41:18 <wilcal> I've tried two other Plasma Distros and both work different;y
19:41:26 <wilcal> what's right?
19:41:36 <MrsB> I think it's better if we start with our bugzilla and report upstream when advised
19:41:37 <tjandrews> We in QA are of varying skill levels.
19:41:45 <neoclust> wilcal: so this is missing deps maybe
19:41:54 <neoclust> MrsB: so we can add a bug keyword
19:41:54 <DavidWHodgins> I think it's better to have on both bugzillas with a reference to the kde one on ours, just in case it turns out to be distro specific, and not an upstream bug
19:41:59 <neoclust> MrsB: UPSTREAM
19:42:05 <MrsB> many who test the ISOs are quite novice neoclust
19:42:11 <wilcal> I fully understand we are very early in all this not only for Mageia but other Distros
19:42:12 <neoclust> MrsB: to close bugreports and ask to report upstream
19:42:17 <lewyssmith> wilcal: Do the other distros *work* ?
19:42:20 <neoclust> MrsB: i think this is a good compromise
19:42:43 <MrsB> yes sure, just let people know when to report upstream and we can do that
19:42:49 <wilcal> I tried openSUSE and some parts of Plasma there does strange things
19:42:59 <lewyssmith> Benmc: Hello Ben.
19:43:02 <neoclust> MrsB: i think we can do this way
19:43:10 <wilcal> Kubuntu is another. Which one is closer to being correct
19:43:32 <Benmc> Lewis, QA, good morning
19:43:47 <MrsB> #info When reporting bugs for plasma you may also need to report them upstream on the kde bugzilla (bugs.kde.org). If you are asked or if somebody adds the UPSTREAM keyword to your bug report, please report it to kde also.
19:43:50 <neoclust> MrsB: can you ask to create the bug resolution CLOSED/UPSTREAM ?
19:43:54 <hviaene> I have a Mint 17.3 DVD, I can install it in Vbox
19:44:09 <wilcal> If we could designate a Plasma Distro that I/we can use as an example that would help greatly
19:44:21 <TheSuperGeek> hviaene: mint don't ship plasma 5
19:44:24 <wilcal> I found differences there too
19:44:32 <DavidWHodgins> neoclust: Should our bugzilla bug be closed before the fix is made upstream and applied to our release?
19:44:37 <brian_> like wilcal - I've used kubuntu flavor and opensuse 42 version
19:44:52 <wilcal> those are the two that I have played with
19:44:56 <neoclust> DavidWHodgins: yes, we close WHEN we report upstream and we add the upstream bugreport in our bugzilla
19:44:56 <hviaene> Mint 17.3 is supposed to??? I did not check yet
19:45:07 <MrsB> #action MrsB to ask for our bugzilla to have a new bug resolution as CLOSED/UPSTREAM
19:45:08 <neoclust> DavidWHodgins: so we keep track and i make sure i am cc: of the bugreport
19:45:17 <neoclust> DavidWHodgins: this will allow to filter
19:45:29 <brian_> how about if it doesn't work we do bugzilla.  up to dev to move upstream upon research?
19:45:29 <neoclust> DavidWHodgins: if we keep all open this is hard to see real mga bugs
19:45:32 <DavidWHodgins> I don't like that, as people reporting bugs normally only search open bugs, so we will end up with more duplicate bug reports
19:45:35 <Akien> neoclust: Just close it as RESOLVED/MOVED
19:45:47 <TheSuperGeek> hviaene: only on mint 18
19:45:47 <Akien> With the UPSTREAM keyword that we already have
19:46:08 <neoclust> Akien: i don't care about the words as long as it allow us to have the best plasma :)
19:46:20 <MrsB> Which way would you prefer neoclust?
19:46:37 <hviaene> bad luck, but the same has opensuse leap 42.1, i could try that one on my own bugs
19:46:41 <neoclust> MrsB: as long as it works for QA i am OK
19:46:48 <neoclust> MrsB: Akien solution is OK for me
19:47:12 <neoclust> MrsB: as long as there is the upstream bugreport on our bugreport and as long as i am a cc: on the upstream bugreport :)
19:47:23 <MrsB> #info cancel that action. Neoclust will use CLOSED/MOVED with UPSTREAM keyword to filter bugs reported upstream.
19:47:26 <neoclust> MrsB: as RESOLVED/MOVED already exist this is OK
19:47:42 <neoclust> MrsB: I or QA will use it ;)
19:47:52 <wilcal> there are clearly functions in opensuse 42.1 leap that work that don't in M6
19:47:53 <MrsB> you will need to monitor this
19:47:56 <lewyssmith> The policy to follow must be circulated on qa-discuss.
19:48:05 <wilcal> is that a bug?
19:48:11 <MrsB> lewis yes indeed
19:48:17 <neoclust> MrsB: i can ask QA to create upstream bugreport ? this is OK for you ?
19:48:19 <DavidWHodgins> Sorry, is that close our bug report or not?
19:48:25 <MrsB> and probably a reminder when we start isos again
19:48:34 <MrsB> yesof course neoclust
19:48:41 <neoclust> MrsB: ok for me then
19:48:48 <lewyssmith> DavidWHodgins: I think closed, moved, upstream.
19:49:05 <wilcal> I think when we get the next round of Live media maybe a lot of this will come into focus
19:49:11 <MrsB> we will start with a bug report on our bugzilla, as normal, and you ask for any relevant ones to be reported upstream instead.
19:49:19 <DavidWHodgins> We will have to change our bug reporting to not only search open bug reports then
19:49:22 <wilcal> Like the ctrl-f8 thingy
19:50:23 <MrsB> #info We'll need to alter our bug searches to also search for 6dev1,2 etc with CLOSED/MOVED and UPSTEAM keyword
19:50:24 <lewyssmith> DavidWHodgins: Our bug should refer to the KDE one, obviously. Then that can be followed if interested.
19:51:03 <MrsB> Do you want to go through some bugs tonight neoclust?
19:51:03 <DavidWHodgins> I'm against closing our bug report till the bug is fixed in our packages
19:51:22 <neoclust> MrsB: i want to add a word on the systray bug
19:51:25 <wilcal> Agreed David
19:51:28 <neoclust> i am back in 30seconds
19:51:31 <MrsB> k
19:51:55 <MrsB> that's a good point dave
19:52:07 <wilcal> can we agree that opensuse 42.1 is at least a general example of the way Plasma should work
19:52:17 <MrsB> no idea
19:52:22 <neoclust> back
19:52:22 <DavidWHodgins> I'm fine with reporting to upstream and adding a keyword, but not with closing
19:52:25 <neoclust> wilcal: no
19:52:34 <wilcal> why is that neo?
19:52:53 <neoclust> wilcal: this is good but i think kubuntu neon can be better
19:52:53 <lewyssmith> DavidWHodgins: Sensible, Dave. The important thing is that the method is clearly understood.
19:53:00 <neoclust> but i want US to be the reference ;)
19:53:06 <MrsB> neoclust: Dave has suggested we don't close our bug reports until any upstream fix has been included in our packages
19:53:13 <DavidWHodgins> wilcal: Let's keep discussion here about Mageia, not other distros
19:53:21 <wilcal> Ahhhhh now i have something to work with Neo made my day
19:53:25 <neoclust> MrsB: i am against this will make our work harder
19:53:31 <neoclust> MrsB: we can :
19:53:36 <neoclust> CLose as MOVED
19:53:45 <wilcal> but our plasma is so badly flawed I don't know how it is supposed to work
19:53:47 <neoclust> MrsB: and Closed as Resolved when patches are added
19:53:59 <neoclust> wilcal: this is wrong it works fine
19:54:07 <neoclust> so  systray bug
19:54:24 <DavidWHodgins> But people reporting bugs normally only search open bug reports. We'll have to change our reporting strategy to also search closed bugs.
19:54:31 <neoclust> MrsB: i talked with tv and he will work on our apps to migrate them to GNotifications
19:54:39 <lewyssmith> DavidWHodgins: Between you & Nicolas, Dave.
19:54:42 <MrsB> That's workable neoclust. Will need to create some saved searches though to work around the closed bug issue
19:54:53 <DavidWHodgins> Also, once fixed upstream, I don't think it should be closed on ours till the fix is applied to our packages
19:55:50 <DavidWHodgins> I think it would be easier for the few devs working on plasma to filter out bug reports with the upstream keyword
19:55:53 <MrsB> #info neoclust talked with tv and he will work to alter our apps to use GNotifications which should fix the systray issue
19:56:44 <MrsB> As long as it's a process we can all work with, i don't think it matters
19:56:49 <neoclust> MrsB: DavidWHodgins : for the bugreports do how this is best for you to triage handle bugreports :)
19:56:51 <hviaene> Have to go, g'night all
19:56:58 <lewyssmith> DavidWHodgins: On reflexion, I agree with you on this.
19:57:02 <wilcal> nite hvi
19:57:04 <MrsB> Nite herman
19:57:30 <MrsB> traditionally we'd keep a ug report open until resolved in our package
19:57:33 <MrsB> bug
19:57:54 <DavidWHodgins> Or closed as wontfix etc.
19:58:00 <neoclust> MrsB: so be it
19:58:14 <MrsB> Will that work for you?
19:58:26 <DavidWHodgins> Do we have an UPSTREAM keyword?
19:59:19 <neoclust> DavidWHodgins: Akien told yes so i trust him :)
19:59:39 <DavidWHodgins> bugzilla is not responding right now, of course. :-)
19:59:55 <MrsB> here either
20:00:19 <MrsB> Will that method work ok for your purposes neoclust?
20:00:35 <neoclust> MrsB: i will adapt :)
20:00:47 <DavidWHodgins> neoclust: Thanks. :-)
20:01:01 <MrsB> Ok thanks. That will simplify things from a triaging perspective. Keeps everything the same
20:01:27 <tjandrews> Reminds me of Seven-of-Nine. ;^)
20:01:38 <DavidWHodgins> lol
20:01:58 <MrsB> #info Changed: If a bug is reported upstream we will leave open with UPSTREAM keyword added until the fix in included in our packages
20:02:18 <MrsB> #info this aligns the process with other areas
20:02:27 <MrsB> all hapy on that?
20:02:30 <MrsB> p
20:02:35 <DavidWHodgins> Happy here. :-)
20:02:58 <lewyssmith> Agree.
20:02:58 <wilcal> yes sounds like a good way to start making sense of this
20:03:03 <MrsB> Do you want to go through some bug reports now neoclust?
20:03:32 <MrsB> ro shall we start by triaging the ones we have and reporting upstream
20:03:34 <MrsB> or
20:04:13 <neoclust> MrsB: i would start by triaging
20:04:17 <DavidWHodgins> I think we should triage the ones we have first, and leave going through individual reports for another time
20:04:26 <neoclust> DavidWHodgins: yes!
20:04:36 <DavidWHodgins> Like around version freeze
20:04:50 <neoclust> MrsB: https://bugs.mageia.org/show_bug.cgi?id=17523
20:04:56 <neoclust> MrsB: let start by this :)
20:05:15 <neoclust> MrsB: when bugzilla will be fixed
20:05:31 <MrsB> if only there was a sysadmin..
20:05:47 <DavidWHodgins> tmb is rebooting alamut now
20:05:47 <wilcal> so back to my specific example ctrl-f8 that's a mageia bug not upstream?
20:05:51 <neoclust> MrsB: we are here :)
20:05:56 <neoclust> MrsB: alamut is rebooting
20:06:01 <MrsB> cool
20:06:10 <neoclust> MrsB: sysadmins are always around :)
20:06:20 <MrsB> could you advise wilcal neoclust please
20:06:31 <neoclust> MrsB: of what ?
20:06:36 <MrsB> go wilcal
20:06:36 <neoclust> ah
20:06:49 <neoclust> ctrl+f8 ?
20:06:57 <wilcal> the ctrl-f8 function not working on M6 but working on opensuse
20:07:06 <neoclust> what is it supposed to do ?
20:07:12 <lewyssmith> !
20:07:16 <DavidWHodgins> Doesn't do anything on my Mageia 5 system. Specific shortcut added?
20:07:25 <wilcal> a ctrl-f8 in plasma presents the avalable desktops. Works in M5 too but not in Plasma
20:07:39 <wilcal> should present in plasma but does not
20:07:48 <neoclust> wilcal: i don't agree
20:07:50 <neoclust> you know why ?
20:07:59 <wilcal> why
20:08:08 <neoclust> ctrl + fx    go to the selected "desktop"
20:08:16 <neoclust> ctrl + f2  => desktop 2 etc
20:08:29 <neoclust> what if i have 8 desktops ?
20:08:36 <neoclust> here for ex i have 6
20:08:41 <wilcal> i have seen docs in opensuse 42.1 that say it should work
20:08:56 <neoclust> wilcal: i accept the link :)
20:09:03 <DavidWHodgins> Ah. That's why I don't see anything. I always cut number of desktops to 1.
20:09:18 <MrsB> it should on opensuse i suppose. I suspect it's a suse feature
20:09:35 <wilcal> i only use this as an example of trying to decipher bugs vs features
20:09:44 <DavidWHodgins> bugzilla is back
20:09:52 <wilcal> and it works on Mageia M5
20:10:04 <wilcal> works on this m5 laptop
20:10:17 <neoclust> wilcal: are desktop effects enable for you ?
20:10:18 <Luigi12_work> yeah it works on mga5 here
20:10:54 <lewyssmith> [TheSuperGeek: Envoye-moi un courriel avec ta question.]
20:11:13 <Luigi12_work> wilcal: how about the similar feature of the top-left hot corner that presents the windows when you move your mouse there?
20:11:25 <neoclust> Luigi12_work: from what i read this is supposed to work ONLY if desktop effects are ON
20:11:31 <neoclust> Luigi12_work: maybe this is the pb here
20:11:37 <Luigi12_work> neoclust: that sounds likely
20:11:47 <MrsB> kwin effects in kde
20:11:56 <wilcal> anyway lets not try to solve this here I'm only trying to figure out what's a bug vs a feature
20:12:41 <wilcal> there's widget called "Pager" that I've also tinkered with
20:12:44 <DavidWHodgins> Ok to move on?
20:12:48 <MrsB> #info Is it a bug or a feature? If in doubt, ask and feel free to create a bug report anyway.
20:13:01 <wilcal> presents the the desktops on the panel
20:13:11 <wilcal> that will help greatly MrsB
20:13:14 <neoclust> "You can also use the desktop grid effect to get a big overview of your virtual desktops, try pressing Ctrl+F8 (requires desktop effects support"
20:13:48 <wilcal> exactly neo and that does not seem to work in my M6 Plasma installs
20:14:14 <wilcal> so I have to turn on "desktop effects" somewhere?
20:14:18 <neoclust> wilcal: please report in our bugzilla
20:14:20 <MrsB> Neoclust, could you go through current bugs then please (not now) and advise which to upstream
20:14:26 <wilcal> got it
20:14:42 <MrsB> We'll make sure everyone knows what to do
20:14:56 <wilcal> that's why he's here today :-)))
20:15:04 <neoclust> https://bugs.mageia.org/show_bug.cgi?id=16589 => UPSTREAM
20:15:05 <[mbot> Bug 16589: normal, Normal, mageia, NEW , dolphin's Detailed View Mousewheel scrolling is very small at all settings, dolphin-15.07.90-2.mga6.src.rpm
20:15:11 <MrsB> ahaa now then, ok
20:15:31 <MrsB> SOme of these may not be reported by the QA team
20:15:34 <neoclust> https://bugs.mageia.org/show_bug.cgi?id=16850 => "I THINK"   UPSTREAM
20:15:35 <[mbot> Bug 16850: normal, Normal, mageia, NEW , Plasma 5 cannot restore its session (running applications not plasmoids), plasma-workspace-5.4.1, plasma-desktop-5.4.1
20:15:45 <neoclust> MrsB: you see i am not always 100% sure ;)
20:16:17 <neoclust> https://bugs.mageia.org/show_bug.cgi?id=16940 => UPSTREAM
20:16:18 <[mbot> Bug 16940: major, Normal, mageia, NEW , Selecting both edge and two-finger scrolling in plasma 5 silently disables edge scrolling, kcm-touchpad
20:16:21 <MrsB> yes, but just ask on the bug to report upstream and we'll make sure the QA guys know what/why/how to do so
20:16:53 <neoclust> MrsB: i will do it
20:16:59 <MrsB> cool, thanks
20:17:07 <DavidWHodgins> Thanks for being here today neoclust
20:17:11 <neoclust> MrsB: how ? because there is already bugreports where i ask to report upstream :)
20:17:19 <wilcal> huge help thanks
20:17:28 <lewyssmith> Looks worth agreeing privately the procedure before posting it on the mailList.
20:17:48 <MrsB> The first step is for us to let QA people know
20:18:12 <DavidWHodgins> Yeah. I didn't know we have an upstream keyword
20:18:18 <neoclust> MrsB: how ? there is an email to add as CC: ?
20:18:24 <neoclust> a keyword to use ?
20:18:38 <MrsB> neoclust perhaps put an email together to qa-discuss which ones to upstream
20:18:50 <lewyssmith> See -6
20:19:21 <neoclust> MrsB: add extra steps :)
20:19:46 <MrsB> Well when we know, we can get everybody to do it
20:19:48 <neoclust> MrsB: btw i will update to plasma 5.6.2
20:20:20 <DavidWHodgins> I think it's just a matter of informing everyone that when reporting a bug on plasma, that is likely a bug in plasma itself, to also report it to bugs.kde.org, reference the kde bug report on our bug report, and add the upstream keyword on our bug report
20:20:34 <MrsB> Ill send emails to qa-d and dev ML tomorrow. possibly also discuss
20:20:34 <DavidWHodgins> neoclust: eta?
20:20:51 <neoclust> DavidWHodgins: i will update on the svn in some minutes
20:21:00 <neoclust> DavidWHodgins: i will mail on dev@ to inform :)
20:21:10 <DavidWHodgins> Ok. Thanks
20:21:16 <TheSuperGeek> lewyssmith: ok i'll do it tomorow
20:21:24 <wilcal> we need that stake in the ground Live media
20:21:33 <Luigi12_work> Plasma 5.6.3 is soon too
20:21:35 <TheSuperGeek> Nite all !
20:21:40 <MrsB> nite TheSuperGeek
20:21:41 <wilcal> nite super
20:21:47 <TheSuperGeek> thx
20:21:57 <MrsB> Has this helped to assess any timescales?
20:22:03 <lewyssmith> [TheSuperGeek: Mieux ; c'est tard]
20:22:17 <MrsB> possibly will do when we have an accurate idea of packaging bugs
20:22:46 <MrsB> Shall we move on?
20:22:52 <wilcal> yes whewww
20:22:54 <MrsB> Thanks neoclust for being here
20:22:54 <DavidWHodgins> #topic * Testing updates - Any difficulties, problems?
20:23:19 <lewyssmith> vtun = ? Mercurial = ?
20:23:21 <MrsB> http://madb.mageia.org/tools/updates
20:23:28 <[mbot> [ Mageia App Db - Current Update candidates ]
20:23:44 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=18135
20:23:45 <[mbot> Bug 18135: major, Normal, qa-bugs, NEW , vtun new DoS security issue, vtun-3.0.2-10.mga5.src.rpm
20:23:57 <MrsB> mercurial we've updated before, it's a versioning thing like git/svn
20:24:00 <wilcal> any help here would help :-)
20:24:11 <tjandrews> I will check Thunderbird 64-bit after we are done here.
20:24:29 <DavidWHodgins> Never used vtun before. Looks like it's best tested with multiple vbox guests running. I'll look at it after the meeting
20:24:36 <wilcal> docs I found tend to be complex. I'm looking for something useful and simple
20:24:58 <wilcal> Ya I'd like to tinker with it too
20:25:01 <MrsB> vtun is a first update, not seen before so we'll have to look into it
20:25:03 <wilcal> sounds useful
20:25:09 <lewyssmith> The rest look OK.
20:25:24 <wilcal> bte the youtube-dl thingy is really super
20:25:49 <wilcal> tiny app hugely useful
20:25:57 <MrsB> tmb: will you be able to look at xymon or rather we push it as-is?
20:26:02 <wilcal> never knew it was there
20:26:56 <lewyssmith> I can try Postgres. But I  have mixed versions. How can I upgrade to the later one without screwing databases etc?
20:27:14 <tmb> lewyssmith, you cant...
20:27:18 <MrsB> i believe you backup and repopulate
20:27:30 <lewyssmith> Oh dear...
20:27:31 <tmb> lewyssmith, iw you want to switch, then dump dataabase before
20:27:33 <DavidWHodgins> lewyssmith: Best to use a vbox guest for something like that
20:27:46 <wilcal> Vbox is best
20:27:47 <DavidWHodgins> snapshot, test, revert
20:27:49 <lewyssmith> No VBox.
20:28:13 <MrsB> incompatibility is the reason we have sevral versions
20:28:30 <DavidWHodgins> Makes it harder to revert without a seperate test environment
20:28:56 <lewyssmith> Can you have both versions installed & running?
20:29:10 <MrsB> no, due to libpg5
20:29:15 <MrsB> or whatever it is
20:29:26 <Luigi12_work> actually oden fixed it so the library isn't an issue
20:29:32 <Luigi12_work> it's everything else in the package that is the issue :o(
20:29:47 <MrsB> in that case, yes :)
20:29:55 <MrsB> but probably no
20:30:08 <lewyssmith> So we need two people each with a different version.
20:30:46 <MrsB> i think most use mariadb so can easily remove postgres to try a dfferent version
20:31:01 <lewyssmith> I like to be different...
20:31:04 <DavidWHodgins> That's why I have seperate test environments I can backup/restore, on both real hardware and in vb.
20:31:07 <MrsB> test which you can lewis and say which you can't. If you're familair with it it'll be a better tets anyway
20:31:13 <wilcal> Ahhhhh we have another Flash update. It's been a few weeks :-)
20:31:56 <DavidWHodgins> Surprise, surprise. Another 0-day flash security bug
20:31:57 <MrsB> We all know what we're doing then?
20:32:13 <wilcal> list under control too
20:32:17 <DavidWHodgins> #topic * Luigi's roundup - Security news & expected updates
20:32:19 <MrsB> yeah looking good atm
20:32:28 <MrsB> thanks Dave
20:32:32 <MrsB> over to David
20:32:43 <Luigi12_work> apache-commons-collections needs to be updated to 3.2.2  (hopefully david_david can take care of that)
20:32:44 <MrsB> Flash is a major one making news headlines
20:32:55 <MrsB> actively exploited etc
20:33:05 <Luigi12_work> networkmanager has some minor security issues, but we probably won't update that since the maintainer refuses to help with stable releases
20:33:21 <Luigi12_work> that's all
20:33:28 <lewyssmith> Coo.
20:33:44 <DavidWHodgins> If the maintainer won't help with stable releases, it should be dropped from cauldron before version freeze
20:33:45 <tjandrews> How did THAT happen???
20:33:49 <MrsB> #info apache-commons-collections needs version bump, david_david handling. networkmanager has small issues but no maintainer in stable :\
20:34:06 <MrsB> Akien: ^^
20:34:29 <tmb> DavidWHodgins, well, unfortunately we cant really drop networkmanager :)
20:34:31 <tjandrews> I meant such a short list this week.
20:34:40 <DavidWHodgins> :-)
20:34:44 <MrsB> Nice list Luigi12_work thanks :)
20:35:05 <DavidWHodgins> #topic * Anything else?
20:35:12 <MrsB> Is there anything else?
20:35:14 <lewyssmith> Not here.
20:35:30 <wilcal> i'm done again thanks to neo
20:35:41 <DavidWHodgins> Nothing else here
20:35:54 <MrsB> Thanks then everybody and special thanks to our special guest
20:36:04 <MrsB> T - 5
20:36:07 <MrsB> 4
20:36:08 <MrsB> 3
20:36:10 <MrsB> 2
20:36:11 <MrsB> 1
20:36:15 <MrsB> #endmeeting