20:06:29 <MrsB> #startmeeting
20:06:29 <Inigo_Montoya`> Meeting started Thu Jan 14 20:06:29 2016 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:06:29 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:06:47 <MrsB> #chair lewyssmith wilcal DavidWHodgin
20:06:47 <Inigo_Montoya`> Current chairs: DavidWHodgin MrsB lewyssmith wilcal
20:06:48 <DavidWHodgin> #topic * Who's new? - If you are then come and say Hi!
20:07:02 <MrsB> Welcome to another one guys
20:07:12 <MrsB> Is anybody new today?
20:07:31 <lewyssmith> [no obvious sign]
20:07:38 <MrsB> no tracks
20:07:38 <Benmc> no-one admitting it
20:07:43 <brian_> <gray bearded here>
20:07:49 <MrsB> ok then :)
20:08:08 <MrsB> #topic Me..
20:08:23 <MrsB> This is a bit of a difficult one
20:08:46 <lewyssmith> Your decision.
20:09:09 <MrsB> Increasing demands on my time from various angles are making it very hard for me to contribute, let alone lead the team as it deserves to be led.
20:09:25 <wilcal> are you getting more work
20:09:28 <MrsB> you probably noticed
20:09:35 <MrsB> that and other stuff
20:10:09 <MrsB> Things may change in a few months when my contract ends, but really I hope it wont
20:10:26 <wilcal> share with us a little of what your going to be doing
20:10:45 <MrsB> I am painfully aware that at the moment I'm not being a very good leader
20:11:28 <MrsB> It means we need to make a decision
20:12:00 <MrsB> I like to think the team has always had good leadership and want it to continue that way
20:12:11 <MrsB> it needs it now though
20:12:16 <wilcal> it is a team
20:12:34 <MrsB> there's a few of us now and some good skills between us
20:13:08 <MrsB> I'm at a point where I need to take at least a step back, allow others to lead
20:13:24 <MrsB> you all deserve that as does the community
20:13:30 <DavidWHodgin> While I certainly understand the need to take a break, from time to time, I don't think you need to step down.
20:14:03 <wilcal> I have some general thoughts I'd like to share
20:14:30 <lewyssmith> Of you go, Bill.
20:14:35 <tjandrews> Sabbaticals are acceptable to me...
20:14:42 <MrsB> Well, this is the choice really. I can take a step back and officially let you guys deputise and see how it goes.. or I can make it official and step down and we could maybe even have a new election
20:14:45 <wilcal> pre-recorded message :-))
20:15:02 <wilcal> Many thanks to MrsB for her efforts to lead this group over the years.
20:15:03 <wilcal> I look forward to whatever capacity shes sees herself here in the future.
20:15:05 <wilcal> Am I qualified. You betcha. I've a Degree in Computer Engineering ( 68 ).
20:15:06 <wilcal> I've managed entire departments of technical people on two continents ( USA & Europe ).
20:15:08 <wilcal> And, have been part of the Mandrake/Mandriva/Mageia Distro since 98.
20:15:09 <wilcal> I'm now retired and am continuing to work hard at being irresponsible ( doctors orders ).
20:15:11 <wilcal> I see this as a golden opportunity. Managing a group of technical people and getting
20:15:12 <wilcal> results is an art-form. Just getting the opportunity to do that is a privilege. There
20:15:14 <wilcal> are people here in our group who I believe could really use that reference on their resume'.
20:15:15 <wilcal> I am especially encouraging students ( and I know your here ) to really consider taking
20:15:17 <wilcal> the reins here and do it. The day after you became leader of this group put that on
20:15:18 <wilcal> your Linkedin profile and resume' Go for it. I'll continue to support as best I can.
20:15:20 <wilcal> You will be the QA Group Leader of one of the top 5 Linux Distributions. Not bad.
20:16:23 <Akien> Phew, I'm no longer a student :P
20:16:42 <wilcal> This is really an opportunity for someone
20:16:42 <MrsB> Yeah, so I need to know what you all want me to do
20:16:49 <DavidWHodgin> :-)
20:16:59 <lewyssmith> Akien: There is always the U3A.
20:17:04 <wilcal> I think we should see if there is someone who wants to take the reins
20:17:10 <DavidWHodgin> My vote is take a break, and see how you feel in a month or so.
20:17:40 <brian_> MrsB - how many months on your contract that are known?  <if you can share>
20:17:44 <wilcal> Absolutely we have been doing fine but I think we should really think about someone stepping up
20:17:46 <tarazed> But work can be all consuming, and with a family to look after...
20:17:54 <Benmc> currently there is a deputy leader. correct?
20:18:00 <lewyssmith> I see it more as how *available* Claire is, not how she feels.
20:18:04 <wilcal> Two actually
20:18:08 <wilcal> Me and David
20:18:28 <wilcal> We don't have to make this decision today
20:18:38 <lewyssmith> Bill has been effectively leading the group quite a lot lately.
20:18:48 <DavidWHodgin> Who can't figure out why konversation is now dropping the s off of the end of my name. :-)
20:19:01 <tarazed> So how do you feel about it wilcal?
20:19:12 <wilcal> Yes, and I don't mind that but I do not want to be in the way of someone who can really use the reference and experence
20:19:16 <MrsB> do /nick DavidWHodgins
20:19:22 <wilcal> read my message
20:19:50 <DavidWHodgins> MrsB: Thanks
20:19:56 <wilcal> you don't have to be the best or extremely technical just lead technical people
20:20:06 <lewyssmith> wilcal: I thought your discourse was about yourself, until the end!
20:20:07 <MrsB> well this is the choice really. In a nutshell, we can either stick with the deputies for the time being or hold an election and find a new leader
20:20:16 <wilcal> a HUGE reference on your resume's and Linkedin
20:20:28 <wilcal> I don't need a job
20:20:44 <Benmc> official elections are due when?
20:20:48 <wilcal> MrsB a question of you. Do you think your experence here helped you find work
20:21:06 <tjandrews> I don't need another job, either.
20:21:07 <tmb> after Fosdem usually iirc
20:21:08 <DavidWHodgins> Benmc: Usually right after fosdem
20:21:19 <MrsB> Yeah, early Feb
20:21:23 <brian_> My thought - not that anyone should or does take me seriously  ;-)
20:21:25 <wilcal> Cool
20:21:51 <brian_> MrsB if you feel like you need to step down - do it.  I doubt any of us would be offended by it at all.
20:21:52 <wilcal> So everyone give it a thought and we will revisit this after fosdem
20:22:29 <Akien> I think the team can continue as is until the elections then - and MrsB is of course free to take some time off, the deputies will continue leading as they did recently
20:22:44 <wilcal> Agreed Akien
20:22:47 <Benmc> +1
20:22:47 <Akien> In the meantime wilcal has the opportunity to talk many people into candidating for the future elections ;)
20:22:48 <brian_> agreed
20:22:58 <tjandrews> Sounds like a plan, Aiken.
20:23:04 <DavidWHodgins> Ok with me
20:23:09 <brian_> I promise not to run
20:23:10 <wilcal> ok by me
20:23:27 <MrsB> Lewis ok with that too?
20:23:28 <lewyssmith> Agree, of course. But we have been here before.
20:23:56 <wilcal> I tend to be of a pushy manager
20:24:06 <MrsB> Let's do that then.
20:24:18 <brian_> @wilcal - me too
20:24:20 <tarazed> That's ok bill - maybe we need pushing.
20:24:22 <lewyssmith> wilcal: In your younger days!
20:24:42 <MrsB> it's mentoring and motivating now, not managing
20:24:44 <tarazed> Agreed.
20:24:49 <wilcal> There was a course in technical management at school I didn't take it
20:24:58 <wilcal> it's an artform
20:25:03 <DavidWHodgins> #Action Decisions on elections will be made before fosdem
20:25:04 <wilcal> like manageing cats
20:25:17 <brian_> yup
20:25:21 <MrsB> after Dave, normal time
20:25:27 <lewyssmith> DavidWHodgins: I thought it was *after*.
20:25:37 <DavidWHodgins> Decision before, election after
20:25:37 <MrsB> #undo
20:25:37 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0xb693d38c>
20:25:56 <wilcal> we'll revist this after fosdem
20:26:01 <MrsB> #Action Decisions on elections will be made after fosdem, deputies wil deputise until then
20:26:34 <MrsB> Thanks guys and I'm really sorry and sad that it's come to this
20:26:47 <DavidWHodgins> Don't feel bad about it
20:26:50 <brian_> Don't be - it's life
20:26:57 <wilcal> Don't be sorry you've done a great job here
20:27:10 <brian_> agreed
20:27:15 <MrsB> Let's move on then
20:27:20 <tarazed> We are all grateful for what you have done.
20:27:25 <wilcal> Somebody here needs your job
20:27:26 <DavidWHodgins> Don't see vlad here, so
20:27:36 <DavidWHodgins> #topic * Testing updates - Any problems, difficulties, issues?
20:27:45 <MrsB> A quick word about OpenQA anyway
20:28:02 <DavidWHodgins> Ah. Sorry, missed that
20:28:18 <MrsB> Vlad has been working with Florian (doktor5000) and OpenQA is now packages and mostly working as it should in Cauldron
20:28:40 <MrsB> It should be able to be backported to 5 sometime soon
20:29:00 <MrsB> it can then be pressed into action on the build server with any luck!
20:29:05 <lewyssmith> Is that necessary? Its main interest is pre-release testing.
20:29:14 <lewyssmith> backport
20:29:20 <MrsB> Well, if not 5 then infra_5 for sysadmins
20:29:35 <tmb> lewyssmith, backport for infra that is :)
20:29:43 <lewyssmith> infra?
20:30:00 <tmb> lewyssmith, the mageia servers
20:30:37 <lewyssmith> And the sysadmin interest?
20:30:41 <DavidWHodgins> lewyssmith: short for infrastructure
20:31:12 <DavidWHodgins> The sysadmins build the iso images
20:31:29 <MrsB> They'll make it workon the server when we get it into a working package
20:31:37 <tmb> lewyssmith, well, it hits me both as sysadmin and iso builder  :)
20:31:56 <MrsB> it'll mean the ISOs can be basically tested before people get their hands on them
20:32:19 <MrsB> perhaps in future it could also be used for testing some updates too
20:32:35 <MrsB> one of your wishes :)
20:32:42 <lewyssmith> Vlad deserves big praise for his work (Florian also, surely).
20:33:43 <MrsB> It's something we've wanted since day one really. Just needed somebody with time, knowledge and dedication to brin it all together and Vlad has done a great Job - along with Florian
20:34:35 <MrsB> So on to testing updates
20:34:37 <MrsB> http://madb.mageia.org/tools/updates
20:34:48 <MrsB> It's been a busy period for updates
20:34:53 <lewyssmith> Too many, too diffiuclt!
20:35:12 <DavidWHodgins> :-)
20:35:14 <brian_> lots out there.
20:35:23 <DavidWHodgins> 20 right now
20:35:30 <lewyssmith> We certainly need to accept just one OK (except for kernels).
20:35:36 <MrsB> There have been a number of people getting involved and big-ups to you, you know who you are
20:35:36 <tarazed> Most of the easy ones are gone now.
20:35:45 <brian_> confusion on my part what's the difference between kernel-linus, kernel-tmb and what appears to be the regular one
20:35:52 <MrsB> Yes, agree with that Lewis
20:36:05 <wilcal> tmb still here?
20:36:16 <tmb> yep
20:36:19 <MrsB> #info continue with validating on one OK, apart from kernels etc
20:36:29 <DavidWHodgins> Search the wiki on "kernel flavours" (might be flavors)
20:36:42 <wilcal> one of them I think the linus version is hard to tell in the boot screen. tmb is labeled tmb i think
20:37:07 <MrsB> linus just shows as the version number
20:37:17 <lewyssmith> tarazed: And they weren't all easy!
20:37:17 <brian_> will do
20:37:31 <MrsB> you all sorted now lewis?
20:37:46 <lewyssmith> In what respect? Life - no.
20:37:49 <MrsB> :P
20:37:59 <MrsB> kernels
20:38:09 <lewyssmith> Yes thanks. Usin,g 15 here.
20:38:10 <DavidWHodgins> https://wiki.mageia.org/en/Kernel_flavours
20:38:24 <tmb> brian_, kernel-linus is unpatched upstream kerne, kernel-(desktop/server) is the core kernel with mageia patches that most uses, kernel-tmb is pretty much core kernel + some experimental stuff
20:38:40 <MrsB> stick with the *-latest packages and you won't go far wrong
20:38:42 <tarazed> docker looks interesting but as wilcal might say could be a career job.
20:39:02 <MrsB> there is a one liner to test docker IIRC
20:39:07 <brian_> ok - I was just looking at it from a QA time investment.  Which should I focus on for best bang
20:39:24 <brian_> I leaned toward the common name
20:39:27 <lewyssmith> Docker is like FreeBSD jails, I think.
20:39:33 <brian_> not linus/not tmb
20:39:50 <DavidWHodgins> Always start with bugs you are at least familiar with how to use.
20:39:51 <tmb> brian_, yep, the core kernel is always the most important
20:40:06 <DavidWHodgins> desktop and server
20:40:11 <lewyssmith> DavidWHodgins: Dave - wishful thinking!
20:40:33 <DavidWHodgins> lol
20:41:48 <MrsB> So apart from docker, are there any there that look scary?
20:42:17 <DavidWHodgins> qemu an xen
20:42:21 <MrsB> xen maybe, tmb can help there though :)
20:42:34 <MrsB> qemu can be tested with a one liner, search bugzilla
20:42:36 <tjandrews> I tried the libreoffice update last week, but a number of the packages come up with missing signatures.
20:42:41 <brian_> libvirt - I have up
20:42:46 <brian_> have = gave
20:43:14 <MrsB> libvirtd & qemu can be tested together if you install virt-manager
20:43:16 <DavidWHodgins> tjandrews: That's why it has the feedback marker,and shows in gray in the updates list
20:43:31 <tjandrews> Actually, the 64-bit version had but one missing signature, and I went ahead with that update.
20:43:32 <MrsB> virt-manager is a bit like virtualbox
20:43:45 <tmb> ah, I need to check the missing signatures
20:43:59 <tjandrews> FWIW, Calc has been working just fine this week on my farm stuff.
20:44:36 <tjandrews> Several in the 32-bit version.
20:44:55 <DavidWHodgins> When there are missing sigs, I don't install the update, let alone test it.
20:45:10 <MrsB> What's the best way to test Xen tmb please?
20:45:38 <tjandrews> First time that's happened with me.
20:45:48 <DavidWHodgins> I've tried, but keep running into problems that are likely caused by me.
20:46:08 <MrsB> cakephp we've updated before and most of the others should have procedures to follow if you click the Buzilla link next to them on the madb page to perform a search
20:46:49 <MrsB> perl-PathTools is a new one IINM
20:46:51 <tmb> MrsB, I'll need to refresh the testing info for that one, will try to do so in a day or so...
20:46:57 <MrsB> thanks tmb
20:47:34 <MrsB> Any others there too hot to handle?
20:48:21 <DavidWHodgins> I don't think so
20:48:30 <brian_> just libvirt one --- could it be because I was running it through VB VM?
20:48:48 <MrsB> it wont help, qemu is relatively slow
20:48:51 <DavidWHodgins> It has to be tested on native hardware
20:49:09 <DavidWHodgins> bug 44
20:49:10 <brian_> ok - that may be it then
20:49:46 <MrsB> Let's move on then
20:49:50 <tmb> yeah, virtualizers/hypervisors should really be tested on real hw
20:49:55 <DavidWHodgins> #topic * Luigi's Roundup
20:50:02 <lewyssmith> I suspect we need to thank Dave for his campaign against Advisories. Great job.
20:50:14 <MrsB> Yeah good purge Dude
20:50:19 <DavidWHodgins> Have to catch up again, after the meeting
20:50:43 <MrsB> Luigi12_work: Luigi12_lappy ping :)
20:50:44 <Luigi12_work> note that Dave's topic changes aren't working, since he was chaired with the wrong nick
20:50:52 <DavidWHodgins> Oops
20:50:56 <MrsB> oops
20:51:05 <MrsB> chair DavidWHodgins
20:51:08 <MrsB> oops again
20:51:11 <DavidWHodgins> #topic * Luigi's Roundup
20:51:13 <MrsB> #chair DavidWHodgins
20:51:13 <Inigo_Montoya`> Current chairs: DavidWHodgin DavidWHodgins MrsB lewyssmith wilcal
20:51:22 <DavidWHodgins> #topic * Luigi's Roundup
20:51:26 <MrsB> whew :)
20:51:29 <DavidWHodgins> That's better
20:51:33 <lewyssmith> 3rd time lucky!
20:51:39 <MrsB> out of practise
20:51:53 <DavidWHodgins> :-)
20:51:55 <Luigi12_work> I'm working on finishing up the Qt5 5.4.2 update right now
20:52:20 <MrsB> Wasn't neoclust doing that one?
20:52:40 <Luigi12_work> it was mostly a new member of the KDE team (Filip) doing it
20:52:45 <MrsB> ahh
20:52:46 <Luigi12_work> it was three packages short of being done
20:53:06 <Luigi12_work> so I'm finishing those up now, and assuming the builds finish fine (they should) will assign it to QA
20:53:10 <MrsB> what do we have that uses qt5?
20:53:16 <Luigi12_work> wireshark :D
20:53:21 <MrsB> oh yeah :\
20:54:22 <MrsB> #info Qt5 update almost ready, can be tested with wireshark
20:55:03 <wilcal> wireshark wow what a task
20:56:32 <Luigi12_work> looks like calibre, eyesight, vlc, qupzilla, lxqt, sddm, owncloud-client, qt-creator, recoll, stellarium, and wireshark are some good things to test with
20:56:55 <MrsB> #info looks like calibre, eyesight, vlc, qupzilla, lxqt, sddm, owncloud-client, qt-creator, recoll, stellarium, and wireshark are some good things to test with
20:56:56 <Luigi12_work> then my next order of business will be the critical polarssl update, which has been delayed by the fact that upstream renamed it to mbedtls in the middle of a stable branch (!?)
20:57:13 <MrsB> ouch
20:57:14 <Luigi12_work> and updated the soname in the middle of a stable branch (library major number) which will require rebuilding the packages that use it
20:57:32 <MrsB> will we be following?
20:57:40 <Luigi12_work> yeah we have to
20:57:52 <Luigi12_work> there's a LOT of security fixes and enhancements, including at least one critical one
20:57:55 <MrsB> we'll have to blog about that one when it's pushed
20:58:29 <Luigi12_work> I wish I knew the status of the samba4 update, but I don't.  neoclust was working on that one.
20:58:54 <Luigi12_work> if anyone has Cauldron working, or can get it working, could you please test dhcpcd with a wireless network interface and make sure it works OK?
20:58:54 <DavidWHodgins> Looks like linphone is the only app that uses polarssl
20:59:25 <Luigi12_work> belle-sip, hiawatha, linphone, pdns
20:59:30 <Luigi12_work> more specifically
20:59:35 <Luigi12_work> I think belle-sip is a lib used by linphone
20:59:37 <MrsB> #info Polarssl update complicated by being renamed upstream to mbedssl in middle of stable branch - we will need to follow - blog post maybe?
20:59:39 <Luigi12_work> not sure what hiawatha is
20:59:47 <Luigi12_work> pdns is a DNS server, which we've updated before
20:59:55 <MrsB> #info Samba4 status unknown - neoclust?
21:00:29 <MrsB> that's an easy one to test
21:00:33 <MrsB> pdns
21:00:48 <Luigi12_work> I filed a bug with coling today on cgit, which needs an update for a security issue (it's a web interface to git, which Fedora uses for its packages git, if you don't know what cgit is)
21:01:11 <tjandrews> I know the Hiawatha historical reference, but nothing about the software.
21:01:22 <Luigi12_work> I've filed a bug for pterjan asking to update ruby to a newer stable branch, since 2.0.0 is EOL in February
21:01:47 <Luigi12_work> I've asked for help figuring out what to do about WebKit in the -dev list, we might end up updating that for Mageia 5
21:02:05 <MrsB> #info cgit coming & ruby will need to be bumped to new stable branch as 2.0.0 is EOL in Feb
21:02:12 <tjandrews> Hiawatha brought together the Six Nations of the Iroquois on the shores of a lake less than 15 miles from here.
21:02:14 <Luigi12_work> plus if any apps port themselves from WebKit1 to WebKit2 (like shotwell has done) we should backport those changes, since WebKit1 has several security issues which will never be fixed
21:02:49 <Luigi12_work> in fact I did ask Olav for the shotwell update, as it also implements TLS certificate verification
21:02:52 <MrsB> http://madb.mageia.org/package/show/application/0/name/hiawatha
21:02:52 <tmb> I looke on the webkit stuff, but I cant find references to all fixes :/  atleast some of them would be easy to backport
21:03:25 <Luigi12_work> yeah it's a big mess :o(
21:03:48 <Luigi12_work> anyway, again if someone could test dhcpcd + wireless in Cauldron, please do.  There are two CVEs that also apply to Mageia 5 that I'm trying to figure out how to handle.
21:04:10 <MrsB> #info Maybe a bunch of updates related to webkit - more info to follow
21:04:16 <Luigi12_work> so that's the highlights from me
21:04:29 <MrsB> Thanks Luigi12_work :)
21:04:37 <lewyssmith> Seconded.
21:04:42 <MrsB> Anybody want to ask anything?
21:04:52 <wilcal> it's all good
21:05:15 <DavidWHodgins> #topic * Anything else?
21:05:18 <MrsB> So that only leaves
21:05:22 <MrsB> beat me to it
21:05:29 <DavidWHodgins> :-)
21:05:30 <MrsB> Is there anything else?
21:05:35 <lewyssmith> Not here, for once.
21:05:40 <DavidWHodgins> Nothing else here
21:05:41 <tarazed> To backtrack, how do we report tests of Cauldron applications.
21:05:41 <wilcal> i'm done
21:05:46 <brian_> none
21:05:51 <Ages> no
21:06:02 <tmb> there might show up some mga6 isos this weekend
21:06:11 <MrsB> on dev ML tarazed, or to Luigi12_work for that one
21:06:26 <MrsB> we dont routinely test cauldron
21:06:35 <MrsB> only when it becomes an ISO
21:06:40 <tarazed> Understood.
21:06:51 <Benmc> i currentlty have cauldron 32+64
21:07:07 <MrsB> That's two volunteers then, well done Benmc
21:07:09 <DavidWHodgins> #info New Mageia 6 iso images may be available for testing this weekend
21:07:20 <tmb> with the latest rpm pushed today + stage2 atleast live media building works again
21:07:31 <MrsB> Did you just make that up Dave?
21:07:51 <MrsB> oh, sorry tmb - missed your comment
21:07:57 <DavidWHodgins> No. Tmb posted that 7 lines earliar
21:08:11 <tmb> ennael said she would try a classical build ~tonight too
21:08:29 <wilcal> is plasma working?
21:08:38 <tmb> they wont be perfect, but atleast -dev1 quality :)
21:09:11 <MrsB> dev1 quality is bootable and installable and you can log in
21:09:44 <MrsB> Is there anything else else?
21:10:05 <lewyssmith> Goodbye all.
21:10:16 <MrsB> Nite lewis
21:10:19 <MrsB> T - 5 then
21:10:22 <MrsB> 4
21:10:24 <MrsB> 3
21:10:25 <MrsB> 2
21:10:27 <wilcal> bye all
21:10:27 <MrsB> 1
21:10:31 <MrsB> Thanks for coming everybody
21:10:33 <Benmc> i'll contact david re dhcpcd when I have dug up a wifi dongle
21:10:34 <MrsB> #endmeeting