20:07:07 <MrsB> #startmeeting
20:07:07 <Inigo_Montoya`> Meeting started Thu Oct 30 20:07:07 2014 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:07 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:07:08 <diogenese> Ok, I'm good now.
20:07:18 <MrsB> Welcome everybody to another one
20:07:29 <MrsB> well done for getting the times right \o/
20:07:38 <MrsB> who want's to be Dave today?
20:07:57 <wilcal> oliver :-))
20:08:10 <MrsB> #chair wilcal olivier_cc
20:08:10 <Inigo_Montoya`> Current chairs: MrsB olivier_cc wilcal
20:08:14 <MrsB> done :D
20:08:17 <olivier_cc> arf
20:08:30 <MrsB> #topic Who's new?
20:08:41 <MrsB> Is there anybody new today?
20:09:07 <MrsB> just looking I don't think we have any new nicks in the list
20:09:32 <MrsB> so everybody is an old hand and knows what they're doing!
20:09:36 <olivier_cc> I'm puzzled what is "to be Dave" ?
20:09:48 <Kernewes> old hand, yes, dunno about the rest
20:09:51 <MrsB> dave usually sets the topics, don't worry about it
20:10:07 <MrsB> #topic Beta 1
20:10:23 <wilcal> I've got both a working HW and Vbox version they both update and reboot
20:10:26 <MrsB> Sooo straight in at the deep end
20:10:53 <MrsB> #info Could everybody move on to testing on real hardware now please
20:10:55 <wilcal> I'm seeing at least a half dozen apps that need work some I've already bugged
20:11:08 <hviaene> Same here as wilcal, still have to fill in the pad
20:11:28 <olivier_cc> managed on real hardware but with vesa at installation
20:11:31 <MrsB> #info please also remember to list which ISO you are testing on the pad, along with the test results further down the page
20:11:35 <wilcal> Ya when I bug'em I usually put that in the pad too
20:11:42 <MrsB> https://pad.riseup.net/p/mageia5beta1
20:11:43 <[mbot> [ Riseup Pad ]
20:12:16 <olivier_cc> do we enable updates when installed ?
20:12:20 <MrsB> #info Please create bug reports against Cauldron for any you encounter and add 5beta1 into the whiteboard field
20:12:46 <wilcal> nvidia thing looked to be a problem
20:12:48 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=14410
20:12:49 <[mbot> Bug 14410: normal, Normal, bugsquad, NEW , nvidia proprietary driver not installing
20:13:33 <olivier_cc> could install it afterwards inside cauldron but didn't know if it was the proper thing to do
20:13:36 <MrsB> As long as updates can be installed you can do but we need to test the actual ISOs rather than current cauldron so best to stick to what is on the ISO itself and just test the updates feature as anything else
20:13:48 <olivier_cc> ok
20:13:49 <tmb> ah, the nvidia driver does not properly filter out 32bit deps... will fix..
20:13:57 <wilcal> somebody's gotta rebuild xbmc
20:13:59 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=14407
20:14:00 <[mbot> Bug 14407: normal, Normal, anssi.hannula, NEW , xbmc cannot be installed or built, xbmc-13.0-1.mga5.i586
20:14:04 <MrsB> dude :)
20:14:09 <lewyssmith_> Hello Dave.
20:14:12 <olivier_cc> hi dave
20:14:12 <marja> DavidWHodgins: wb :-)
20:14:14 <MrsB> #chair DavidWHodgins
20:14:14 <Inigo_Montoya`> Current chairs: DavidWHodgins MrsB olivier_cc wilcal
20:14:28 <DavidWHodgins> HiYa everyone. Sorry I'm late. Had a doctor's appointment.
20:14:40 <diogenese> Dave \o
20:14:40 <wilcal> I'm in the middle of defining a problem with k9copy
20:14:54 <wilcal> Welcome David
20:14:56 <olivier_cc> I'm quite relieved, Dave, I was supposed to be you tonight ^^
20:14:58 <Kernewes> hi Dave
20:15:17 <DavidWHodgins> :-)
20:15:26 <MrsB> Officially insane now then Dave?
20:15:27 <Kernewes> DavidWHodgins: appointment OK?
20:15:30 <wilcal> funky error message when nfs-utils are installed
20:15:46 <DavidWHodgins> Always have been. ☺
20:15:50 <MrsB> :D
20:16:12 <DavidWHodgins> Kernewes: Yep. Just a prescription renewal.
20:16:21 <Kernewes> good
20:17:09 <MrsB> #info nvidia driver issue in 64bit, tmb will respin the live ISOs
20:17:57 <olivier_cc> lewys, will you be able to teach me how to fill a bug report, I didn't dare do it for nvidia ?
20:18:04 <Akien> There's an issue with GNOME not using the keyboard layout defined at install time
20:18:13 <MrsB> There haven't been many people testing since the last lot of ISOs, can we all jump on the new ones please when they're ready
20:18:25 <Kernewes> is there a third round coming?
20:18:26 <lewyssmith_> olivier_cc: Privately?
20:18:31 <Akien> I read somewhere that the keyboard layout was good in tty, so this seem to be a GNOME issue.
20:18:43 <dvg_i> Yeah but not through hoops...
20:18:57 <wilcal> My last few days have been nothing but M5B1 rd2
20:18:59 <DavidWHodgins> Kernewes: I think we are already on the third round, so this will be the fourth.
20:19:01 <Akien> *seems
20:19:16 <Kernewes> DavidWHodgins: I'm only on the second round :)
20:19:28 <lewyssmith_> rsync!
20:19:46 <MrsB> #info  There's an issue with GNOME not using the keyboard layout defined at install time
20:19:57 <Kernewes> I don't get to check my e-mails every day so I must have missed somethi8ng
20:19:58 <MrsB> is there a bug number for that akien please?
20:20:00 <Kernewes> something
20:20:00 <DavidWHodgins> There was less than a day between second and third, so you're probably on the third.
20:20:09 <wilcal> ya probably
20:20:11 <lewyssmith_> Actually Classic still is 2nd round, I think.
20:20:19 <Kernewes> I'm testing dual
20:20:22 <wilcal> Ya I've been work'n the CI's
20:21:02 <lewyssmith_> DavidWHodgins: Your remark reminds me that we could include DATE.TXT *in* the system.
20:21:20 <lewyssmith_> And add its provenance.
20:21:25 <Akien> MrsB: I'll check the pad
20:21:31 <MrsB> that's not a bad idea lewis
20:21:38 <leuhmanu> what for ?
20:21:45 <hviaene|2> So how the @@@ do I know what I have been testing??
20:21:45 <DavidWHodgins> lewyssmith_:  That a good idea.
20:21:53 <lewyssmith_> I've said it before, everal times...
20:22:11 <MrsB> #info Lewis had an idea to include DATE.txt on the actual ISO to help identify them
20:22:20 <MrsB> heard this time :P
20:22:24 <lewyssmith_> And what ISO it is, please.
20:22:37 <MrsB> #info and the ISO name
20:22:46 <DavidWHodgins> MrsB: Not just on the iso, where it is already present, but on the installed system.
20:22:55 <lewyssmith_> e.g. bet1v3
20:23:08 <lewyssmith_> DavidWHodgins: You have it.
20:23:09 <MrsB> #info and tranfered to the installed system too
20:23:15 <MrsB> yeah, good diea
20:23:18 <MrsB> idea
20:23:47 <wilcal> i got a question for tmb about M5
20:23:59 <wilcal> tmb: Should this work as an additional repo source:
20:24:00 <wilcal> http://192.168.1.2:8080/~mageia/distrib/5/media/i586
20:24:03 <Akien> Otherwise you have to check the md5sum and the DATE.txt file
20:24:16 <Akien> They should also have the same date of creation
20:24:33 <Akien> mageiasync checks the date for you :-)
20:24:41 <hviaene> Isn 't the DATE.txt the date i downloaded?
20:24:53 <MrsB> No it's the date/time the iso was created
20:24:58 <dvg_i> If one renames the grub entry to e.g. M5B1b3d64 then youd find all
20:25:05 <dvg_i> Do it always
20:25:14 <Kernewes> My perpetual gotcha is in the fact that the directory name in /isos/ and the file name are different
20:25:24 <Akien> MrsB: No bug report for the gnome issue yet, I'll open one
20:25:30 <Kernewes> i.e. mageia5-beta1 and Mageia-5-beta1
20:25:31 <MrsB> thanks Akien
20:25:43 <Kernewes> can't they be the same?
20:25:45 <tmb> wilcal, it should
20:25:46 <MrsB> #Akien will create a bug report for the gnome keyboard issue
20:25:48 <DavidWHodgins> wilcal: That's a rfc1918 address, so no one outside of you're lan can check it.
20:25:48 <MrsB> oops
20:25:54 <Akien> I'm a tag :-D
20:25:55 <MrsB> #info Akien will create a bug report for the gnome keyboard issue
20:26:02 <lewyssmith_> Akien: Thanks.
20:26:05 <wilcal> Ya i understand that David
20:26:08 <Akien> #akien is like #action, but just better.
20:26:16 <DavidWHodgins> lol
20:26:28 <dvg_i> ROFLMAO
20:26:32 <MrsB> It's important that we do create bugs guys please and not just comment on the pad alone
20:27:05 <lewyssmith_> I always wonder if problems are 'just me'
20:27:13 <diogenese> Same here.
20:27:15 <olivier_cc> same here :)
20:27:17 <hviaene> Sorry, the date I see in the Date.txt is the same date and time the files have been created on my machine: 27 oct 19.09 CET
20:27:19 <Kernewes> lewyssmith_: in my case they usually are
20:27:20 <DavidWHodgins> wilcal: Make sure you run genhdlist2 to create the media info files.
20:27:34 <lewyssmith_> So don't like buging them immediately.
20:27:37 <MrsB> they may be, but there are no doubt other you's out there with the same problem and besides, they should work for you too
20:27:41 <lewyssmith_> bugging
20:27:59 <Akien> MrsB: +1
20:28:36 <lewyssmith_> There is always the problem of tings which work, but could be better.
20:28:42 <DavidWHodgins> hviaene: That's the correct date/time for the latest classical install iso images.
20:28:44 <MrsB> bore da lewis btw :)
20:29:01 <lewyssmith_> Da iwan!
20:29:09 <lewyssmith_> iawn
20:29:10 <dvg_i> no BR means time wasted testing
20:29:35 <lewyssmith_> BR ?
20:29:39 <MrsB> bug report
20:29:50 <dvg_i> own and others'
20:29:59 <MrsB> Is everybody familiar enough with bugzilla to create a bug?
20:30:05 <wordgazer> cymru am byth
20:30:14 <olivier_cc> soon will be I'm sure MrsB
20:30:22 <DavidWHodgins> wordgazer: ?
20:30:29 <lewyssmith_> wordgazer: Da iawn eto.
20:30:35 <wordgazer> :-)
20:30:43 <diogenese> I can create the reports. The bugs are created elsewhere, iirc.
20:30:43 <MrsB> It's fairly straight forward but please don't hesitate to ask if you need help
20:30:56 <marja> #link https://wiki.mageia.org/en/How_to_report_a_bug_properly
20:31:02 <MrsB> thanks marja
20:31:07 <wordgazer> DavidWHodgins: sry, lapsing into Welsh
20:31:18 <DavidWHodgins> lol
20:31:20 <olivier_cc> bookmarked marja
20:31:22 <Akien> diogenese: I can create bugs if need be :-p
20:31:24 <Kernewes> DavidWHodgins: bet you thought your cat was on the keyboard :)
20:31:31 <lewyssmith_> It *is* quite easy. Just do the 'create a new bug' & follow it through.Bugzilla is good.
20:31:58 <wilcal> Don't worry about creating a duplicate bug. It happens to all of us
20:32:07 <DavidWHodgins> Kernewes: He's been fed, and is now sleeping. :-)
20:32:17 <lewyssmith_> But Bugzilla amost stops that in the process.
20:32:22 <MrsB> yes, but it helps if you can do a quick search first
20:32:23 <wilcal> I usually do a search to see if something has been reported before
20:32:37 <Kernewes> +1
20:32:41 <wilcal> but likely the dup is titled something completely different
20:32:44 <lewyssmith_> It offers likely looking existing bugs.
20:33:06 <lewyssmith_> Very clever.
20:33:09 <DavidWHodgins> Do a search on the rpm name, not the description.
20:33:18 <Kernewes> I've been known to read right through a bug report and right at the end decide it's not the same as mine after all
20:34:00 <Kernewes> DavidWHodgins: that's fine if you know the RPM name or can find it easily
20:34:28 <dvg_i> any process or file name can be found out the package for easily
20:34:43 <DavidWHodgins> What ever program is involved, use "urpmf bin/programname"
20:34:59 <lewyssmith_> Should I bug EFI problems? I don' think they are valid.
20:34:59 <MrsB> The important thing is that we have a bug report so that it can be picked up and fixed, even if it needs further triage
20:35:09 <dvg_i> or 'rpm -qf' /file/that
20:35:26 <MrsB> tmb do you want us to start creating bug reports for EFI issues?
20:35:30 <Kernewes> but if it's something general like installation or the DE you might not know which bit is at fault
20:35:33 <marja> tmb: see lewyssmith_'s question ^^^
20:36:03 <marja> tmb: is it any use reporting any EFI issues atm?
20:36:11 <marja> MrsB: oops
20:36:12 <dvg_i> Kernewes: if you really dont choose installer i/o package and bug team will reassign
20:36:13 <MrsB> lol
20:36:23 <marja> MrsB: sorry, didn't see you had already asked tmb
20:36:27 <lewyssmith_> And what happens if EFI problems disappear from one release to the next? As happens.
20:36:38 <dvg_i> ...dont know choose...
20:37:08 <dvg_i> a solved problem should close the BR if any
20:37:16 <dvg_i> a solution is never a problem
20:37:20 <tmb> for EFI not yet, I have to re-create my setups since my laptop died on me so I lost some work :/
20:37:26 <MrsB> Dave are you able to do triage still for the duration?
20:37:29 <Kernewes> dvg_i: thks
20:37:37 <marja> lewyssmith_: there were some efibootmgr issues that were reported upstream and solved thx to Mga bug reports
20:37:41 <tmb> so EFI support is at same level as MGA4 for now
20:37:47 <marja> lewyssmith_: so that part is certainly useful
20:37:48 <MrsB> #info No EFI bugs just yet thanks
20:37:58 <DavidWHodgins> MrsB: I haven't been able to do much of anything, due to being too tired.
20:38:45 <lewyssmith_> tmb:  Can you say in in announcements if things should work for EFI? To stop a lot of abortive work. Like the Classic DCD not being recgonised.
20:38:54 <lewyssmith_> DVD
20:39:15 <hviaene> General question: do you prefer to raise an issue first in the pad, or go straight to bug logging?
20:39:17 <MrsB> I guess it'll work the other way lewis, it'll be specifically mentioned when it's ready for tests
20:39:29 <MrsB> both please hviaene
20:39:32 <lewyssmith_> Which counts me out.
20:39:57 <hviaene> OK one coming tomorrow
20:40:03 <DavidWHodgins> hviaene: Probably best to update the pad first, then add the bug report number to the pad once the bug report has been opened.
20:40:23 <tmb> hm, Classic DVDs should be able to boot EFI atleast like mga4
20:40:27 <MrsB> we use the pad within the team to keep track of any issues and who is testing what. We don't release the isos until all have been tested. We create bugs so that maintainers can then pick them up and work on fixes
20:40:28 <dvg_i> hviaene: the BR is the utmost important, but the pad helps all of us here to know whats up
20:40:47 <lewyssmith_> tmb: Not for me.
20:41:06 <dvg_i> no long stories needed on pad, brief as possible
20:41:29 <tmb> lewyssmith_, and if you copy the contents to an usb ?
20:41:43 <hviaene> tmb: I had to cut out all the EFI ### to be able to install MGA4 on an Caer laptop with Win8.1
20:41:52 <hviaene> Acer
20:41:59 <MrsB> If there are any major issues which are likely to stop us releasing the ISOs we also email qa-discuss and CC the person who asked for the testing. Generally make some noise about it :)
20:42:24 <marja> lewyssmith_: tmb: I haven't tried yet with beta1, sorry, but will put an EFI-install at the top of my todo..... might take until Sunday, though :-/
20:42:28 <lewyssmith_> tmb: The Classic always worked directly from DVD. When you say copy to USB, do you mean the ISO image or its contents?
20:43:28 <DavidWHodgins> lewyssmith_: For efi installs, copy the contents to a vfat partition with the right label (I forget off hand what the label should be).
20:43:41 <lewyssmith_> hviaene: I have Mageais installed EFI alongsde W8.
20:44:13 <lewyssmith_> DavidWHodgins: That works for the Live ISOs.
20:44:16 <marja> tmb: last time before beta that I tried, it didn't work, don't remember whether that was alpha2 dual or a boot.iso install
20:44:29 <hviaene> Yes, but I dd'ed the ISO to a USB stick, and there was no way that would boot.
20:45:03 <DavidWHodgins> hviaene: Using dd only works for a regular bios install, not for efi.
20:45:15 <hviaene> I got around, and now my wife is happy with MGA4 on it
20:45:28 <MrsB> https://wiki.mageia.org/en/UEFI_how-to
20:45:53 <hviaene> I hate burning DVD's nowadays
20:46:20 <MrsB> yeah feels wrong somehow
20:46:49 <hviaene> Have to go, see you later
20:46:55 <MrsB> Nite hviaene
20:47:10 <DavidWHodgins> hviaene: I don't even have a working cd/dvd reader/burner. I smoke too much, and have a cat that sheds a lot of fur.
20:47:17 <MrsB> Is there anything else to add about ISOs?
20:47:31 * wordgazer copies the iso to a separate partition and does the Install from HD option in the netinstall image (which fits on a 128mb USB stick)
20:48:00 <marja> wordgazer: nice :-)
20:48:12 <MrsB> flash'arry
20:48:14 <lewyssmith_> Worth documenting?
20:48:18 <wordgazer> lol
20:48:21 <wilcal> I've been pretty successful with M5 USB isos
20:48:27 <marja> lewyssmith_: good idea
20:48:33 <wordgazer> I can write it up if you like
20:48:38 <marja> wordgazer: do you mind adding that to the wiki?
20:48:40 <MrsB> please do, it could be useful
20:48:42 <DavidWHodgins> wordgazer: That's a good idea as it's faster, but the images do need testing from real optical discs, and usb sticks too.
20:48:55 <lewyssmith_> Are we talking MBR or EFI here?
20:49:04 <MrsB> you can add it to the QA portal if you like wordgazer
20:49:19 <MrsB> ought to add the UEFI page too
20:49:30 * MrsB looks at Dave
20:49:43 <DavidWHodgins> lewyssmith_: That would be standard bios install, I think. I don't think that would work for uefi.
20:49:59 <lewyssmith_> Thanks. Need to know.
20:50:36 <Kernewes> MrsB: you mean link to the UEFI page on the portal?
20:50:42 <MrsB> yes please
20:50:51 <Kernewes> MrsB: I could do that
20:50:55 <MrsB> thanks Kernewes
20:51:03 * Kernewes makes a note
20:51:03 <wordgazer> marja: will do
20:51:11 <marja> wordgazer: thx :-)
20:51:19 <MrsB> #action Kernewes to add UEFI howto page to the QA portal
20:51:32 <lewyssmith_> The price of leaving the shadows.
20:51:46 <DavidWHodgins> uefi howto link, not tha actual how to.
20:51:57 <Kernewes> DavidWHodgins: yes
20:52:16 <Kernewes> MrsB: in the section about testing isos?
20:52:26 <MrsB> #action wordgazer to add page about and alternative ISO boot method
20:52:34 <MrsB> -d
20:52:39 <Kernewes> then I can link to that one as well
20:52:49 <wordgazer> k
20:52:52 <MrsB> yes, or the resrources somewhere Kernewes, whichever seems right
20:52:57 <Kernewes> ok
20:52:59 <MrsB> thanks wordgazer
20:53:03 <wordgazer> np
20:53:28 <MrsB> cool, delegating, me likey!
20:53:47 <MrsB> Is there anything else ISO related or shall we move on?
20:53:52 <wilcal> not here
20:53:56 <Kernewes> not here
20:53:57 <lewyssmith_> On!
20:53:58 <dvg_i> That is a requirement of leadership
20:54:04 <DavidWHodgins> #topic Testing updates - Well done, keep it up, the list never empties
20:54:22 <MrsB> #action dvg_i to keep archiving the pad
20:54:33 <MrsB> :)
20:54:37 <MrsB> Thanks Dave
20:54:49 <dvg_i> Easily done by any as described
20:54:54 <MrsB> The list grew massively over the weekend
20:54:58 <lewyssmith_> The list grows like a Trifyd.
20:55:00 <dvg_i> Atcion completed
20:55:08 <dvg_i> Action...
20:55:16 <wilcal> where are we on the kernels
20:55:36 <lewyssmith_> David mentioned new ones soon, so they may be held.
20:55:44 <wilcal> Note:
20:55:46 <wilcal> HORRAY!!!!!! For a successful KDE update here. Whew!!! relief.
20:55:47 <wilcal> Gotta find an easier way to test all that.
20:55:53 <MrsB> We've done a pretty good job between us of keeping on top of it until that point, let's keep going with it please. Everybody has a part to play
20:56:02 <dvg_i> MrsB: Seriously have no pb
20:56:13 <dvg_i> MrsB: to continue,
20:56:17 <MrsB> ok thanks
20:56:33 <dvg_i> MrsB: but shant be always available at the right time
20:56:52 <MrsB> #info Dbus and KDE updates were pushed and so far no issue so well done all concerned!
20:57:01 <wilcal> YIPPEEEEE!!!!!!
20:57:11 <MrsB> you're doing well so far dvg, and thankyou for doing it
20:57:12 <wilcal> Now we're ready for dem kernels
20:57:26 <dvg_i> MrsB: yw, no need
20:57:55 <dvg_i> MrsB: can you kindly keep a little order
20:57:58 <Kernewes> reckon we need brigadiers and generals to deal with the kernels
20:58:05 <dvg_i> MrsB: some are shouting
20:58:18 <MrsB> Kernels need some tmb attention IINM
20:58:25 <MrsB> Thanks dvg_i, on it
20:58:32 <Kernewes> wilcal: stop shouting
20:58:41 <wilcal> Kernels + Virtualbox need to be tested together
20:58:53 <lewyssmith_> The Mageia 4 kernels are probably going to be rebuilt .... Anyway, that's what's holding this update up at the moment.
20:59:05 <MrsB> I don't want us to worry particularly about those while we are ISO testing
20:59:05 <lewyssmith_> Quoting David's note.
20:59:12 <Akien> Yes, kernels are a big issue currently for mga3 -> mga4 upgrades
20:59:28 <Akien> They are also an issue for people who installed Mageia 4 with the original media and not 4.1
21:00:02 <Akien> Basically they include too much meta-information for our poor urpmi :-)
21:00:14 <MrsB> #info Kernels have some issues at the moment which affect mga3 => 4 upgrades
21:00:39 <Akien> So tmb will probably have to rebuild the last kernel to remove some of these meta-data, and even nuke the already validated 3.14.18 kernel
21:00:48 <Akien> That won't be pretty :-/
21:01:09 <MrsB> Nuing a released update?
21:01:13 <MrsB> nuking
21:01:26 <MrsB> That's a bit extreme
21:02:08 <tmb> MrsB, yes, as the rpms have too much provides, there is not much else to do :/
21:02:39 <MrsB> wouldn't a new update simply take precendence and negate any issues?
21:03:00 <wilcal> Maybe we hold the M4 kernel & Vbox at the level they are now till after we release M5?
21:03:01 <tmb> MrsB, but as Luigi12 suggested, one could place them in backports for availability...
21:03:10 <marja> MrsB: kernels are usually not deleted when a new one's installed
21:03:20 <DavidWHodgins> Why didn't we have problems when testing those kernels?
21:03:32 <marja> MrsB: but only when the user decides to
21:03:42 <Akien> DavidWHodgins: There was an update to perl-URPM before Mageia 4.1 that fixed the issue
21:03:45 <MrsB> I know marja, it's to do with upgrades from 3 though
21:03:48 <tmb> DavidWHodgins, because you installed the perl-URPM udate
21:03:57 <Akien> Since all of us were testing on up to date systems, there was no issue
21:03:58 <DavidWHodgins> Ah. Ok. Thanks.
21:04:02 <marja> MrsB: ah, yes,
21:04:27 <wilcal> I always start a Vbox test client with a completely updated version
21:04:33 <Akien> But it seems that even in the 4.1 install, the perl-URPM version hadn't been updated, so upgrades with the DVD would fail
21:04:57 <MrsB> so IIUC the released mga4 ISOs are unable to perform the upgrade? Are online upgrades affected too?
21:05:13 <Akien> Online upgrade work, because perl-URPM is pulled first
21:05:20 <Akien> At least that's what Luigi12 told me
21:05:34 <tmb> MrsB, the problem is that every rpm in /updates gets their metadata added to hdlists, and it's that data perl-URPM parses
21:06:08 <marja> ouch
21:06:09 <diogenese> I take it there's a limit to the size of that.
21:06:11 <tmb> Akien, no, the reason online upgrade works is that we released the perl-URPM update for mga3 too
21:06:32 <Akien> tmb: Ah thanks for the precision
21:06:53 <MrsB> So if mga3 is up to date, with new perl-URPM, why do upgrades fail?
21:07:30 <tmb> MrsB, online updated dont fail, only when using isos
21:07:38 * MrsB confused
21:07:49 <MrsB> I'll have to study the report
21:07:53 <DavidWHodgins> MrsB: The old perl-URPM is on the 4.1 iso images.
21:07:57 <Akien> MrsB: The perl-URPM-blabla.mga4 from the ISOs would replace the updated one from mga3
21:08:04 <MrsB> Ahhh that makes sens Dave
21:08:14 <MrsB> I see
21:08:29 <DavidWHodgins> Maybe we should create 4.2 iso images.
21:08:49 * Kernewes runs away
21:08:58 <Akien> I think nuking a released kernel is still better than that :-)
21:09:06 <DavidWHodgins> Same as 4.1, except for the updated perl-URPM package, to minimize testing needed.
21:10:06 <tmb> Well, the idea is to fix kmod.prov to stop adding module versions, and we should be able to get below provides size limit
21:10:23 <DavidWHodgins> I don't remember the exact circumstances, or which package(s) involved, but updates have been removed from the repos in the past.
21:10:47 <DavidWHodgins> Very rare, but it has happened.
21:10:59 <tmb> the only kmod versions we rely on is for nonfree gpu drivers
21:11:15 <MrsB> #info To summarise. current mga4 kernels have metadata which is too long for for the perl-URPM contained on the mga4 and mga4.1 ISOs. There have since been updates in mga3 and 4 but upgrade is is currently not possible using the existing ISOs. Solution are either to release new mga4 ISO (4.2) or nuke the affected kernel update from update repositories. Online upgrades from 3 to 4 are unaffected because it uses the updated
21:11:16 <MrsB> perl-URPM
21:11:23 <DavidWHodgins> If I remember correctly, it was the iso images, due to copyright problems.
21:11:51 <marja> ah, yes, with the background
21:12:22 <tmb> I hope to have this sorted out this weekend
21:12:25 <MrsB> We don't have much time left to fix this do we
21:12:34 <marja> tmb: thx :-)
21:12:35 <Kernewes> DavidWHodgins: yes, I remember that
21:12:49 <MrsB> ah ok, so we really need to push ahead and get beta 1 released ASAP
21:13:11 <DavidWHodgins> Mageia 3 support ends in about 3 weeks (Nov. 19th).
21:13:24 <MrsB> If we can release beta 1 we can do a 4.2 if you prefer tmb
21:13:35 <marja> ouch.... I still need to help some people to upgrade to Mga4
21:13:48 <lewyssmith_> MrsB: As Dave says: "When it is ready".
21:14:21 <MrsB> it'll need to be ready quickly
21:14:41 <tmb> the more annoying fact is that the 4.1 stage2 rebuild didn't pick up the fixed perl-URPM despite it being available:/
21:14:54 <MrsB> do we know why?
21:15:00 <tmb> I think atleast stage2 on mirrors need to be fixed
21:15:34 <tmb> MrsB, nope, it should have been automatic according to perl-URPM priority upgrade rules  :/
21:15:47 <tmb> and no-one noticed :(
21:15:55 <marja> :'-(
21:15:59 <MrsB> it's an easy one to miss
21:16:47 <MrsB> 4.2 would be the better solution i think and testing would be fairly quick for it
21:16:52 <tmb> (not that we expected the kmod provides overflow to happend in mga4 back then, it was only a preemptive fix for cauldron/mga5
21:17:03 <MrsB> having said that my availablility is about to drop for a few weeks :\
21:17:24 <DavidWHodgins> Ouch
21:17:27 <marja> MrsB: sorry to hear that
21:17:38 <Kernewes> a few weeks?
21:17:41 <MrsB> it's a good thing, some paid work
21:17:50 <marja> MrsB: congrats :-)
21:17:50 <wilcal> Good for you MrsB
21:17:51 <MrsB> around a month
21:17:56 <Kernewes> doing what?
21:18:00 <wilcal> The team here will make it all work
21:18:06 <MrsB> it'll mean I won't be available here during the day though most likely
21:18:30 <wordgazer> congrats MrsB
21:18:39 <MrsB> I'm writing search engine friendly text for a business website
21:18:52 <marja> :-)
21:18:54 <Kernewes> ooh great
21:19:16 <MrsB> thanks for congrats, it's a bit awkward with everything that's going on at the moment though
21:19:31 <MrsB> Hope everybody will step up a bit where they can do
21:19:31 <Kernewes> is there ever a good time in QA though?
21:19:31 <lewyssmith_> What *is* search engine friendly text ?
21:19:50 <MrsB> reasobly paid, as it turn out
21:19:51 <tmb> MrsB, yeah, but such is life
21:20:08 <marja> MrsB: I'm glad it is a _nice_ reason which causes you to have less time!
21:20:10 <Kernewes> that'll help with Christmas coming up
21:20:16 <DavidWHodgins> lewyssmith_: Having the right key words in the text.
21:20:22 <MrsB> yes we won't be cancelling it this year
21:21:06 <MrsB> So i'll be cracking the whip but not doing as much for a while I'm afraid
21:21:50 <lewyssmith_> Back to updates now?
21:22:00 <MrsB> So guys, are there any updates that look scary?
21:22:13 <wilcal> just the kernels :-))
21:22:16 <DavidWHodgins> #info MrsB will be taking some time off, probably about a month.
21:22:24 <MrsB> off-ish
21:22:30 <olivier_cc> I tried python-djblets, so installed django but I have been at a loss to make anything of it since I didn't find information how to use djblets in django.
21:22:41 <lewyssmith_> tarazed: I propose Len for the Ruby one.
21:22:54 <MrsB> Len, you fancy that?
21:23:15 <lewyssmith_> olivier_cc: I know a Python man, I may ask his advice for this one.
21:23:24 <tarazed> I have already done something for that Lewis but there are a couple of loose ends.
21:23:24 <Akien> I guess p11-kit is not that straight-forward
21:23:41 <MrsB> well done :)
21:23:42 <Akien> There's not much to test though, but a basic procedure from the packager could be handy
21:23:54 <MrsB> there should be a previous update for p11-kit
21:23:57 <lewyssmith_> tarazed: You may be the only one here who knows Ruby.
21:24:11 <olivier_cc> thanks lewys
21:24:19 <tarazed> Ain't no expert though....
21:24:28 <Akien> Yes but the update candidate only removes a dependency on /bin/sh, I don't expect anything to change in p11-kit
21:24:39 <Akien> But it would be nice to test that it does fix the bug that it is supposed to fix
21:24:43 <MrsB> we generally just paste some ruby into irb tarazed so you're the best man for the job :)
21:24:50 <lewyssmith_> tarazed: These things are relative.
21:24:54 <Akien> And for this, it's some docker stuff, and I no naught about this :-)
21:26:21 <MrsB> I haven't looked at it yet Akien
21:26:32 <MrsB> http://mageia.madb.org/tools/updates as a reminder
21:26:35 <[mbot> [ Mageia App Db - Current Update candidates ]
21:27:02 <olivier_cc> About privoxy I'm not sure my test was enough afterwards. So I didn't test it on MGA4-32 or MGA3-64.
21:27:42 <Akien> I guess nobody fancies bacula either :-)
21:28:25 <lewyssmith_> Olivier has done it; I may try yet again, but I am sick of it by now.
21:28:41 <wilcal> Have we got a simple ruby test
21:28:42 <MrsB> We can check the removal of the /bin/sh dependency using urpmq --media "Core Release" --requires <package> and again with --media "Core Updates Testing"
21:29:07 <MrsB> pasting ruby into irb wilcal
21:29:19 <lewyssmith_> irb ?
21:29:26 <Kernewes> interactive ruby
21:29:30 <MrsB> irb is an interactive ruby shell
21:29:50 <MrsB> a bit like typing 'python' for a python shell
21:29:50 <wilcal> so if it runs the shell it updated ok
21:30:15 <MrsB> if you paste ruby scripts into irb and the scripts work then ruby is ok
21:30:16 <Kernewes> if it only needs some simple Ruby I can possibly do that
21:30:32 <MrsB> tarazed is on it I think :)
21:30:39 <Kernewes> fine
21:30:55 <MrsB> two tests are never a bad thing
21:31:04 <tarazed> There are other things that need to be checked like installing gems and the documentation utilities, for completeness sake.
21:31:14 <MrsB> yes
21:31:29 <lewyssmith_> Kernewes: Carolyn, you have opened a floodgate for yourself!
21:31:31 <MrsB> You can search for previous updates dont' forget to see how it was done before.
21:31:42 <Kernewes> MrsB: talking of which, I didn't add any Oks to the LibreOffice whiteboard because I thought it probably needed more people to test it than just one
21:31:59 <MrsB> Ok, we'll not be rushing that one, you're right
21:32:12 <lewyssmith_> I was wondering at what point you can OK it. It looks godd anyway.
21:32:32 <Kernewes> tarazed: I'll have to leave the advanced stuff to you
21:32:58 <MrsB> make sure all the various LO applications work, spellchecks are OK and hyphenation too IINM
21:33:05 <tarazed> Sure.  Ask for help if needed.
21:33:10 <lewyssmith_> Re LibreOffice, we should not sit on it too long because it is important.
21:33:11 <MrsB> saving/loading etc
21:33:21 <DavidWHodgins> lewyssmith_: Like kde, libreoffice is a large application, with lot's of pieces that need to be tested, hopefully with various printers.
21:33:31 <MrsB> If you're confident lewis then add the OKs
21:33:44 <Kernewes> forgot to try printing from it
21:33:44 <lewyssmith_> I merely posed the question...
21:34:00 <Kernewes> I'm just glad someone's been working on it
21:34:06 <lewyssmith_> I created PDF outputs.
21:34:27 <MrsB> have you tested all the LO bits?
21:34:29 <DavidWHodgins> It's a package notorious for having problems with landscape/portrait printing.
21:34:33 <Kernewes> lewyssmith_: me too
21:34:55 <lewyssmith_> MrsB: I tried all the apps briefly.
21:34:58 <Kernewes> Writer, Calc, Base, Draw, Impress but not printing yet
21:35:13 <DavidWHodgins> A problem that keeps getting fixed, but then comes back in the next update.
21:35:14 <Kernewes> tried OLE and importing images
21:35:20 <lewyssmith_> PS except Base.
21:35:58 <Kernewes> I haven't installed all the language packs
21:36:14 <lewyssmith_> Nor me.
21:36:17 <MrsB> find some example files with google and see that they open/display/print/save ok etc too
21:36:34 <Kernewes> MrsB: examples of what?
21:36:37 <MrsB> no it's not expected that you will, your one should work though
21:36:53 <MrsB> files for the various LO bits
21:37:11 <Kernewes> oh I see
21:37:28 <MrsB> or save some with the old LO and open them again with the new one
21:37:33 <Kernewes> done that
21:37:58 <DavidWHodgins> Anything more on updates testing, or shall we move on?
21:38:11 <Kernewes> move on, it's bedtime
21:38:13 <wilcal> Not from me
21:38:17 <MrsB> let's move on
21:38:17 <lewyssmith_> Agree.
21:38:21 <DavidWHodgins> #topic Luigi's Roundup
21:38:24 <MrsB> thanks
21:38:41 <lewyssmith_> He sent an e-mail.
21:38:52 <DavidWHodgins> Like last week, see the qa-discuss mailing list for the message about the roundup.
21:39:02 <MrsB> #info Luigi12 is not here again today so has sent an email to qa-discuss
21:39:14 <MrsB> cool, that was eays
21:39:16 <MrsB> easy
21:39:21 <DavidWHodgins> #topic Anything else?
21:39:27 <wilcal> Not from me
21:39:27 <MrsB> Is there anything else?
21:39:32 <DavidWHodgins> Nothing else here.
21:39:41 <olivier_cc> nothing either
21:39:41 <wilcal> I've a couple of M5 bugs to post
21:40:02 <MrsB> olivier_cc: you cal close the meeting, type #endmeeting after the countdown :)
21:40:06 <MrsB> can*
21:40:19 <MrsB> go ahead wilcal
21:40:25 <Kernewes> olivier_cc: ooh, promotion :)
21:40:32 <DavidWHodgins> :-)
21:40:33 <olivier_cc> lol
21:40:48 <olivier_cc> big pressure here
21:41:02 <DavidWHodgins> 5
21:41:06 <DavidWHodgins> 4
21:41:10 <DavidWHodgins> 3
21:41:12 <DavidWHodgins> 2
21:41:15 <DavidWHodgins> 1
21:41:16 <wilcal> bye all
21:41:22 <Kernewes> go for it
21:41:24 <DavidWHodgins> olivier_cc: Go ahead. :-)
21:41:26 <olivier_cc> #endmeeting