19:06:57 <MrsB> #startmeeting
19:06:57 <Inigo_Montoya> Meeting started Thu Aug 21 19:06:57 2014 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:57 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:18 <MrsB> Morning everybody welcome to another one
19:07:27 <MrsB> #chair DavidWHodgins wilcal
19:07:27 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB wilcal
19:07:30 <DavidWHodgins> #topic Who's new? If that is you then come and say hello
19:07:36 <MrsB> tah
19:07:47 <MrsB> Is there anybody new with us today?
19:08:00 <MrsB> doesn't look like it
19:08:12 <ennael> hi there
19:08:15 <DavidWHodgins> #topic  Alpha 2
19:08:17 <MrsB> hi ennael
19:08:28 <wilcal> Hello there ennael
19:08:40 <MrsB> you're not new
19:08:49 <wilcal> ennael likes to hang out with the cool people in QA
19:08:57 <DavidWHodgins> :-)
19:09:03 <MrsB> but of ocurse
19:09:15 <lewyssmith> Here tonight, *cold* people.
19:09:40 <MrsB> #info a quick word to say that Alpha2 was released and thank you everybody for all your tests
19:10:10 <wilcal> It's truly an Alpha
19:10:20 <MrsB> that's a good thing though
19:10:32 <MrsB> alphas have tended to happen at beta 2 stage
19:10:42 <MrsB> hopefully this means beta2 will be a proper beta
19:10:56 <wilcal> What the heck happened to the M5A2 classic installer?
19:11:12 <lewyssmith> What do you mean?
19:11:12 <wilcal> Installs here just fine but updates or reboots and it's all over
19:11:27 <dvg_i> no such prob here
19:11:33 <lewyssmith> I can use it.
19:11:39 <Tonyb> installed fine UEFI fopr me
19:11:48 <wilcal> hmmm
19:12:03 <MrsB> driver problem maybe?
19:12:14 <wilcal> happened on both Vbox and real hardware
19:12:28 <ennael> :)
19:12:52 <MrsB> see if you're able to track the issue down and create a ug report with report.bug
19:12:58 <MrsB> bug*
19:12:59 <wilcal> Live media CD/DVD install and update just fine
19:13:35 <MrsB> i think i was testing classical before i went and it seemed ok
19:14:07 <wilcal> latest and greatest off mirrors.kernel.org is what I'm using
19:14:18 <MrsB> #info beta1 is scheduled for release at the end of September
19:14:30 <wilcal> plenty of time to tinker then
19:14:46 <MrsB> is that the boot.iso you're using?
19:14:47 <dvg_i> rsync should IMHO be from bsc(?).mageia.org ?
19:14:54 <wilcal> I'm not seeing a dramatic difference between M4 & M5
19:15:18 <lewyssmith> You expected...?
19:15:43 <wilcal> KDE seems exactly the same
19:15:54 <wilcal> Firefox is different
19:16:02 <MrsB> it's still early days but I'd hope that if there are any outstanding major changes they happen very soon.
19:16:19 <MrsB> https://wiki.mageia.org/en/Mageia_5_Development
19:16:33 <MrsB> version freeze is a few weeks away
19:16:55 <lewyssmith> M5 is in much better shape than was M4 at the the same stage.
19:17:21 <wilcal> I agree with that lew
19:17:21 <MrsB> i just ope that's a good sign and doesn't mean changes are being left for later
19:17:47 <MrsB> ennael: does anything need a push in that department?
19:18:21 <lewyssmith> M4 alpha2 to beta1 was a big step backwards. Fingers crossed for M5.
19:18:35 <Tonyb> I hope RAID installations can still be addressed after version freeze
19:18:49 <ennael> well we will have packager meeting next week
19:19:00 <MrsB> thanks
19:19:07 <ennael> we will focus on last development steps before beta
19:19:48 <Luigi12_work> when will there be a council meeting so we can get the mga4 KDE update un-stuck?
19:20:07 <lewyssmith> Agreed.
19:20:08 <Luigi12_work> there's at least three pending security issues on hold because of that, plus several other bugs
19:20:20 <wilcal> Ahh yes, I thought I was missing them
19:20:33 <Luigi12_work> it's been months since I requested a resolution on this
19:20:35 <MrsB> AFAIK there has been no packager discussion yet or pro's/con's type email to council
19:20:48 <Luigi12_work> all of that has already happened
19:20:56 * MrsB missd it
19:21:07 <ennael> we should have it next monday
19:21:16 <lewyssmith> There were heated exchanges. I think we should let the updates go.
19:21:31 <ennael> I(ve asked KDE team about it
19:21:41 <Luigi12_work> and they've been asking me for weeks has the council done anything yet
19:21:49 <Luigi12_work> AFAIK the council hasn't met in months
19:21:56 <ennael> 1 month
19:22:14 <ennael> council members are human beings having some vacation :)
19:22:25 <wilcal> Europe is on Holiday  :-))
19:22:28 <Luigi12_work> ok, well please make sure it gets raised on Monday
19:22:47 <MrsB> Is there anything else alpa/beta or iso testing?
19:23:06 <wilcal> I'm fine
19:23:09 <DavidWHodgins> #topic Minor changes coming to our madb page
19:23:10 * MrsB having a typo day
19:23:22 * Luigi12_work wonders what tv's development plans are for the mga5 cycle, but the baby development might be the priority now
19:23:29 <ennael> :)
19:23:37 <MrsB> indeed Luigi12_work
19:23:41 <MrsB> thanks Dave
19:23:56 <MrsB> Just a quicky this one
19:24:08 <Luigi12_work> babies don't keep a commit log though
19:24:26 <ennael> and they don't suspend
19:24:30 <wilcal> And they have a 9-month development time
19:24:34 <MrsB> As we're trialling the one test per release thing at the moment it's makign it more dificult to see what can be validated.
19:25:00 <MrsB> I've asked Stormi for a minor alteration to the madb page
19:25:07 <MrsB> http://mageia.madb.org/tools/updates
19:25:09 <[mbot> [ Mageia App Db - Current Update candidates ]
19:25:56 <MrsB> Instead of showing a tick next to each release when two tests have been completed, we'll move to having a coloured circle, a bit like a traffic light
19:26:17 <MrsB> so red = 0 tests done, yellow = 1 test and green for 2 tests
19:26:46 <MrsB> that way, with one test per release, we can validate when we get at least two yellow
19:26:59 <DavidWHodgins> Do we have anyone on the team who is colour blind?
19:27:36 <wilcal> sounds good to me
19:27:42 <Luigi12_work> oh my, yeah maybe blue instead of green?
19:27:42 <MrsB> I'm not and afaik Akien isn't
19:28:07 <DavidWHodgins> I'm not either, but have worked with people who are.
19:28:12 <Luigi12_work> oh there's blue-yellow besides red-green :o(
19:28:18 <Luigi12_work> hmm
19:28:19 <Tonyb> not me
19:28:24 <MrsB> it's mainly for those who need to see when validation is possible
19:28:30 <Akien> I'm not colour-blind either
19:28:50 <MrsB> ie. those uploading advisories and soon to be doing the pushes
19:28:56 <Akien> For colour-blind people Stormi could probably add a hovering tip
19:29:05 <MrsB> that's a good idea Akien
19:29:15 <MrsB> Stormi: if you're here ^^
19:29:23 <Luigi12_work> ahh good idea
19:29:30 <Luigi12_work> that would work for screen readers too probably
19:29:48 <lewyssmith> Luigi12_work: Gosh, do you jump traffic lights?
19:30:06 <MrsB> One other thing, about the automated pushing which Colin is workign on..
19:30:15 <Luigi12_work> lewyssmith: I try to gun it such that I make it, it usually works :P
19:30:28 <MrsB> at present it needs the mageia bug link to be the first link.
19:30:43 <wilcal> Yes, where are we with the automated push
19:30:59 <Stormi> for colour-blind the "yes" text remains in the columns
19:31:03 <MrsB> I've suggested that mgaadv add a new field in the advisory such as BugNumber instead
19:31:19 <Luigi12_work> what about updates that reference/fix multiple bugs?
19:31:20 <Stormi> the coloured orbs are just a means to see thinks uicker
19:31:40 <Stormi> but a hovering tip can be added too
19:31:52 <MrsB> Well afaik it checks the 'depends' now before pushing
19:32:36 <DavidWHodgins> MrsB: Are you referring to the references section of the advisories?
19:33:38 <MrsB> aparently the advisory filename is lost in the process of doing the push and the bug number gleened from the references link, which has to be the first link currently. He's going to look at adding a new field to carry the bug number so the order of references won't make any difference.
19:34:02 <Luigi12_work> that's good
19:34:13 <MrsB> I've always left the mga link at the bottom as we ended up getting blank lines at the end of advosires which I couldn't get rid of
19:35:26 <MrsB> Is everybody clear what the new coloured blobs are going to mean?
19:35:35 <DavidWHodgins> Yes
19:35:41 <RemyServices> yup
19:35:42 <lewyssmith> Yes.
19:35:44 <MrsB> thankyou Stormi for that
19:35:53 <wilcal> Yep
19:36:11 <DavidWHodgins> #topic Testing updates
19:36:19 <MrsB> thanks
19:36:24 <wilcal> Ahh the faster we go the further behind we get
19:36:27 <MrsB> So the list grew again
19:37:11 <MrsB> There are a few there now with procedures listed but i'll go through in the morning and try to add some which don't
19:37:11 <lewyssmith> Most are security. Do we blame Luigi?
19:37:18 <MrsB> oh always
19:37:29 <wilcal> It's his fault
19:37:35 <MrsB> no doubt
19:37:37 <wilcal> no kernels though
19:37:50 <wilcal> I still try to pick on one a day
19:37:58 <MrsB> Are three any there that are intimidating?
19:37:59 <wilcal> may not be successful
19:38:08 <MrsB> try to pick on 3 a day please
19:38:26 <wilcal> What's the deal with krb
19:38:50 <DavidWHodgins> wilcal: I'll try to test kerberos after this meeting.
19:38:59 <MrsB> Dave's domain that one
19:39:33 <MrsB> i think you've always done that one
19:39:37 <wilcal> the grub2 thing should just be update and successful reboot right?
19:39:40 <Akien> Good to see you btw Dave :-)
19:39:51 <DavidWHodgins> Thanks
19:39:54 <DavidWHodgins> wilcal: Yes
19:40:11 <MrsB> yes i think so wilcal, unless there is some kind of poc
19:40:56 <MrsB> not sure what lzo is used for in grub2, maybe some corner case initrd's
19:40:58 <wilcal> Today for me was blender. I left a note there for you Luigi
19:41:28 <wilcal> I don't know of any other use in Mageia for blender
19:41:31 <Luigi12_work> for me?  I don't know anything about openshot
19:41:45 <Luigi12_work> just use blender directly and check previous bugs for ideas on testing it
19:41:59 <Luigi12_work> anyway, honestly for these CVE-2014-4607 lzo bugs, I wouldn't stress too much on testing those
19:42:15 <Luigi12_work> I don't see any risk for regression, so if it installs and runs and doesn't eat tv's baby, that should be fine
19:42:19 <Luigi12_work> it's a minor issue anyway
19:42:26 <wilcal> k
19:42:49 <MrsB> any others look scary?
19:43:11 <MrsB> jakarta is java stuff and we usually just check they update without issue
19:43:22 <Akien> mednafen is quite easy, it can be validated after a mga4 test
19:43:41 <MrsB> i'll have a look at ansible in the morning
19:43:44 <wilcal> Can we just make sure the 4607's load with no errors
19:43:56 <wilcal> update with no errors
19:44:04 <Luigi12_work> yeah that's fine really
19:44:06 <MrsB> serf is a new one, it'll need some research
19:44:14 <Luigi12_work> serf is used by subversion in mga4
19:44:20 <MrsB> ok
19:44:21 <Luigi12_work> used by nothing in mga3
19:44:35 <lewyssmith> I am stuck on Bugzilla & Bacula. Can't make them fly.
19:44:41 <wilcal> That makes the list a lot shorter
19:44:59 <MrsB> libgcrypt - as with other libs check urpmq --whatrequires and check with strace that it's being used
19:45:21 <Luigi12_work> libgcrypt is used by gpg2
19:45:22 <MrsB> bugzilla is a bit tricky, you have to run the script twice IIRC
19:45:30 <Luigi12_work> well gnupg2 is the package, gpg2 is the command IIRC
19:45:35 <MrsB> run once, alter some settings, run again
19:46:01 <MrsB> gnupg2 is used by enigmail i think
19:46:42 <MrsB> python-django is dead easy, simple procedure in old bugs for that one
19:46:58 <MrsB> icecream mmmm
19:47:25 <wilcal> icream's a 4607 small dip
19:47:56 <Luigi12_work> oh we pushed subversion already, you should be able to mark serf as OK on mga4.  Just test that it updates cleanly on mga3 and validate it
19:48:13 <MrsB> ok, then busybox could probably do with a 'busybox lzop' & #busybox.static lzop' check on mga4
19:48:22 <Luigi12_work> yep
19:49:07 <MrsB> italc is another 4607 isn't it
19:49:13 <MrsB> never heard of that one
19:49:28 <MrsB> oh theres a few
19:49:48 <MrsB> so nothing terribly troubling there. I'll have a look at ansible and bugzilla tmrw
19:50:01 <MrsB> what are you going to do?
19:50:04 <wilcal> especially since the testing of the 4607's should be easy
19:50:11 <Akien> Luigi12_work: I'm not sure I had used sdcc from updates_testing when testing svn on mga4
19:50:22 <Akien> But if it installs, it should be fine
19:50:39 <MrsB> subversion is quick to check anyway
19:50:45 <Akien> true
19:51:30 <MrsB> bacula i remember being a bit of a pain, one for after morning cuppa's
19:52:23 <MrsB> everybody happy?
19:52:52 <wilcal> Happy here
19:53:21 <MrsB> lewis ok?
19:53:41 <MrsB> dvg_i: ?
19:53:45 <lewyssmith> So-so.
19:53:47 <MrsB> Tonyb: ?
19:53:53 <Tonyb> OK
19:54:03 <MrsB> have i forgotten anybody?
19:54:11 <dvg_i> MrsB: I'm ready to be guided when you are; say tomorrow
19:54:20 <MrsB> sure \o/
19:54:30 <RemyServices> im here, but been too busy to help much, school starting back, im on track with the changes though
19:54:44 <dvg_i> ok
19:54:57 <MrsB> hi RemyServices, sorry, i did forget you there
19:54:58 <wilcal> Ahhh school thought about going back myself
19:55:22 <MrsB> you'll never stop learning in QA :)
19:55:42 <RemyServices> no worries. work for a school district and this is the first week back, really bad time for me for helping out here
19:56:08 <MrsB> I dare say there is enough in the pipeline to keep us busy nexy week too
19:56:14 <MrsB> speaking of which..
19:56:18 <DavidWHodgins> #topic Luigi's Roundup
19:56:23 <MrsB> disco dave \o/
19:56:29 <DavidWHodgins> :-)
19:56:30 <MrsB> Luigi12_work: ping
19:56:45 <Luigi12_work> pongdiddlyongtious
19:56:50 <MrsB> lol
19:57:14 <Luigi12_work> so I guess we covered the current update set
19:57:29 <DavidWHodgins> Yes
19:57:35 <MrsB> if we all dig into them we should clear those fairly quickly
19:57:59 <Luigi12_work> once Oden gets back to working on Linux stuff (Monday he told me) he'll be working on updates for php and cacti
19:58:13 <MrsB> dvg_i: we can do busybox together tomorrow, it's a really simple one
19:58:18 <Luigi12_work> one of the PHP CVEs is yet another CDF fileinfo issue, so I'll have to make another update for the file package too
19:58:36 <MrsB> there's no end of those atm
19:58:52 <Luigi12_work> yeah it's crazy
19:59:01 <Luigi12_work> I wonder if it'd be better to just disable the CDF parser completely :P
19:59:02 <MrsB> #info php is coming soon wiith yet another file update too
19:59:21 <Luigi12_work> anyway, other than that, I asked on the dev list again for help with security updates, so maybe something will get unstuck
19:59:26 <dvg_i> MrsB: I'll first need assistance to completevbox setup :(
19:59:30 <MrsB> hopefully it'll not be seen again for a few years when it's been fully torn apart
19:59:38 <MrsB> that's ok dvg_i
19:59:44 <Luigi12_work> yeah
19:59:54 <Luigi12_work> so that's all I have, unless anyone has a question
20:00:01 <MrsB> really?
20:00:06 <lewyssmith> Gret!
20:00:10 <DavidWHodgins> :-)
20:00:14 <wilcal> not here
20:00:26 <MrsB> did you get a decent reponse to your dev email?
20:00:55 <Luigi12_work> yeah a few
20:01:08 <MrsB> I'll repost it if you like so gmail can see it. I had to create a specific rule on gmail webmail to not delete your emails :(
20:01:24 <Luigi12_work> philippem was looking into python-djblets and Akien commented on prosody/lua-expat
20:01:39 <Luigi12_work> everyone should see that mail since I sent it from Yahoo!
20:02:06 <Luigi12_work> it's just replies that are an issue since those go through Gmane
20:02:24 <MrsB> ok that's not so bad
20:03:00 <MrsB> keep chasing it up if you need to. I'm sure ennael will be able to fit it in the packagers meeting next week too
20:04:02 <MrsB> Thanks for that then Luigi12_work
20:04:06 <DavidWHodgins> #topic Anything else?
20:04:13 <MrsB> Is there anything else?
20:04:16 <wilcal> I wanted to raise the awareness of:
20:04:17 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=12781
20:04:19 <[mbot> Bug 12781: normal, High, doktor5000, ASSIGNED , Remote CUPS server not being detected automatically, only when searching for hostname, system-config-printer
20:04:19 <wilcal> And set that as a gating factor for the release of M5
20:04:42 <lewyssmith> Brave.
20:04:51 <wilcal> The remote printer thing still persists
20:05:04 <Luigi12_work> system-config-printer is all new in mga5.  New major version, python3 rewrite, philippem doing some cleaning in our package, etc
20:05:08 <MrsB> ok, we need to find out about releae blocker settings
20:05:14 <MrsB> release*
20:05:18 <wilcal> CUPS works locally but not from another Mageia system on the LAN
20:05:19 <Luigi12_work> yeah we don't have a tracker yet
20:05:32 <MrsB> I'll ask leuhmanu how he wants to handle them
20:05:43 <Luigi12_work> I think ennael usually creates the trackers
20:05:52 <MrsB> #action MrsB to ask leuhmanu how he wants to handle release blocker bugs
20:06:07 <MrsB> i thought of somethign else else but i've forgotten it
20:06:17 <philippem> I hope scp is ok it was new for me
20:06:45 <MrsB> oh that was it..
20:06:58 <MrsB> Does anybody know hen mga3 becomes EOL?
20:07:08 <MrsB> i'll find out if  not
20:07:20 <MrsB> 18 months from release
20:07:36 <wilcal> I don't think we have 3 active at the same time
20:07:42 <lewyssmith> Why not when M5 is released?
20:07:57 <wilcal> Do we have a 3-month overlap
20:08:08 <Luigi12_work> we don't have an overlap
20:08:10 <DavidWHodgins> MrsB: See https://www.mageia.org/en/support/
20:08:11 <[mbot> [ Support for Mageia distribution ]
20:08:32 <lewyssmith> I think last time M2 died *before* M4 was released.
20:08:34 <DavidWHodgins> Nov. 19th, 2014
20:08:39 <MrsB> It's been too much work to support two live stable releases and concentrate on final. It's a 9 month release cycle with 18 months support is what we work to
20:08:57 <DavidWHodgins> So about a month before m5
20:09:20 <wilcal> Ya M3 dies a month before M5 is released
20:09:34 <MrsB> thanks Dave. That might be a bit tight but we can see how we get on. It all depends how well we keep on top of the updates
20:10:39 <MrsB> Is there anything else else else?
20:10:45 <wilcal> No here
20:10:51 <lewyssmith> No.
20:10:53 <DavidWHodgins> Not here.
20:11:26 <Luigi12_work> time to push the button
20:11:33 <wilcal> Count it down MrsB
20:11:33 <MrsB> T - 5 then
20:11:40 <MrsB> thanks for coming peeps
20:11:41 <lewyssmith> Goodbye all.
20:11:42 <MrsB> 4
20:11:44 <MrsB> 3
20:11:45 <wilcal> nite all
20:11:45 <MrsB> 2
20:11:47 <MrsB> 1
20:11:49 <MrsB> #endmeeting