20:05:39 <MrsB> #startmeeting
20:05:39 <Inigo_Montoya> Meeting started Thu Mar 27 20:05:39 2014 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:39 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:05:47 <MrsB> #chair wilcal DavidWHodgins
20:05:47 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB wilcal
20:05:49 <DavidWHodgins> #topic Who's new? Are you? Come and say hello!
20:05:58 <Kernewes> DavidWHodgins: greased lightning
20:06:05 <MrsB> Hi all welcome to another QA meeting :)
20:06:29 <MrsB> I still have a splitting headache so let's make it a quicky
20:06:42 <MrsB> Is anybody new here today?
20:07:11 <MrsB> Doesn't look like it
20:07:12 <DavidWHodgins> #topic The clocks change. Starting next week, meetings will be a 1900UTC.
20:07:16 <MrsB> thanks Dave
20:07:37 <MrsB> So I'm told on Sunday the clocks change, has anybody worked it out yet?
20:07:52 <wilcal> I changed a couple weeks ago
20:08:03 <Kernewes> yeah that's right, have the meetings at 1900 UTC
20:08:10 <Kernewes> which keeps it at 2000for the Brits
20:08:13 <DavidWHodgins> Changed here several weeks ago, so meetings have been an hour later than normal.
20:08:15 <MrsB> What we have done before is to change the meeting UTC time so that the actual local time remains the same.
20:08:31 <wilcal> Yep only announce UTC
20:08:44 <lewyssmith> Same once the differences are passed.
20:08:49 <MrsB> Is everybody still OK with those arrangements?
20:08:54 <Kernewes> yes
20:09:03 <wilcal> I'm good
20:09:29 <MrsB> #info We will change the meeting time to 19:00UTC/GMT so that the local time remains the same.
20:09:41 <DavidWHodgins> #topic Testing updates
20:09:44 <MrsB> good, that was easy :)
20:09:57 <lewyssmith> Change the intro here.
20:10:03 <MrsB> So we have a list of updates waiting for us again.
20:10:14 <MrsB> yeah will do
20:10:23 <wilcal> Yep, grows'n shrinks grows'n shrinks grows'n shrinks grows'n shrinks grows'n shrinks grows'n shrinks
20:10:23 <DavidWHodgins> I pushed myself too much on Tuesday, so was too zonked to to much yesterday. Hope to finish iso testing today, then get back to testing updates.
20:10:40 <lewyssmith> Too many biggies.
20:10:41 <DavidWHodgins> s /to to/to do/
20:11:00 <wilcal> Pushed an easy one this morning - perltidy
20:11:14 <Kernewes> yeah, that was an easy one
20:11:21 <wilcal> Ya the db ones are tough for me
20:11:28 <MrsB> wilcal we need to train you up to add the advisories
20:11:31 <DavidWHodgins> wilcal: I'll add the advisory to svn shortly.
20:11:50 <Kernewes> MrsB: agree
20:11:58 <wilcal> We'll I've been certified to do that so I got to get my behind in gear there
20:12:31 <MrsB> yeah, it's a bit of a fiddle to get set up but then just repetitious
20:12:49 <DavidWHodgins> wilcal: I'll go through the procedure with you after the meeting, if you have the time today, and have you add the advisory for perltidy.
20:13:04 <MrsB> thanks Dave
20:13:09 <wilcal> ok thanks
20:13:18 <Kernewes> I've managed to suss out how to set up mediawiki
20:13:23 <Kernewes> so I can help with that another time
20:13:39 <MrsB> I'll try and add some procedures to the bugs tomorrow but everybody knows by now to click the 'Bugzilla' link on madb to find them, don't they?
20:13:56 <MrsB> morning dvg_i
20:14:01 <Kernewes> MrsB: what link?
20:14:08 <MrsB> on the madb bugs list
20:14:16 <dvg_i> Good evening MrsB
20:14:22 <MrsB> in the last column, there are links for Bugzilla and Wiki
20:14:36 <Kernewes> MrsB: you mean the wiki ones
20:14:51 <MrsB> Bugzilla link searches bugzilla for previous updates
20:15:00 <MrsB> next to the wiki ones yes
20:15:20 <lewyssmith> It' seldom that easy. Try this "setup the mail system using amavisd and clamd for virus"
20:15:22 <Kernewes> MrsB: I'm trying to add some wiki procedure pages as I go along
20:15:37 <MrsB> that's helpful thankyou
20:15:47 <DavidWHodgins> Kernewes: For some of the more complicated packages, such as kerberos, we've set up wiki pages. For the rest, click on the bugzilla link, and look at older updates, for procedures.
20:16:09 <MrsB> when you need a procedure though, click the Bugzilla link and see how it was done before. There isn't much now that we haven't updated at least once
20:16:42 <Kernewes> maybe I'm thinking like a doc team member, but isn't it better to build up the collection of wiki pages?
20:16:50 <DavidWHodgins> There are still a lot of packages that have never been updated before, but they are rarely getting updates anyway.
20:16:55 <lewyssmith> But how do you try: "sshd in OpenSSH before 6.6 does not properly support wildcards on AcceptEnv
20:16:56 <lewyssmith> lines in sshd_config, which allows remote attackers to bypass intended environment restrictions by using a substring located before a wildcard character"?
20:17:00 <wilcal> It' seldom that easy. Try this "setup the mail system using amavisd and clamd for virus"
20:17:01 <wilcal> That's a career not a test Lewy
20:17:05 <MrsB> Yes indeed it is Kernewes, just we're not good at creating them :\
20:17:16 <Kernewes> MrsB: well I'll try and help with that
20:17:19 <lewyssmith> wilcal: Exactly.
20:17:41 <DavidWHodgins> lewyssmith: If there is no proof of concept, it's just testing that the update installs cleanly, and basic functions work.
20:17:56 <MrsB> Sometimes all we can do is test something works ok and not be able to reproduce the issue
20:18:14 <wilcal> That may also be true for testing the tv remote thing(s)
20:18:27 <MrsB> yeah
20:19:16 <MrsB> Make sure any service start and stop without errors etc
20:19:25 <DavidWHodgins> When we don't have the hardware needed for some tests, we ask for volunteers. If none will help, we only test that the packages install cleanly.
20:19:34 <wilcal> Can we somehow tag those as such in the list
20:19:34 <lewyssmith> And what about 12842 - loads of moduels.
20:19:43 <MrsB> bug 12842
20:19:45 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=12842 normal, Normal, qa-bugs, NEW , php: infinite recursion and OOB parsing PE files (CVE-2014-1943, CVE-2014-2270), php
20:19:59 <lewyssmith> It is huge.
20:20:01 <MrsB> how was it done last time?
20:20:40 <MrsB> the best test for php is a real world test, using some web apps etc. There are bits we can test individually too.
20:20:57 <lewyssmith> The magic link throws up loads of other bugs.
20:21:09 <MrsB> it's updated quite regularly
20:21:23 <DavidWHodgins> lewyssmith: Instlal all of the packages, to ensure they all install cleanly, then make sure packages such as phpmyadmin work.
20:21:27 <MrsB> look for the has_procedure whiteboard marker
20:21:48 <MrsB> there may be a PoC we can use too
20:22:02 <Kernewes> can we test it using mediawiki, that uses php doesn't it?
20:22:14 <DavidWHodgins> Unless there is a poc in the bug report. Then try to recreate it first, before installing the update, and confirm it's fixed after the update is installed.
20:22:33 <MrsB> yes, that, wordpress, drupal, moodle, etc
20:22:44 <MrsB> phpmyadmin
20:23:01 <lewyssmith> Needs something to administer!
20:23:18 <lewyssmith> But I will try Moodle.
20:23:40 <MrsB> also php-apc is usually part of it now I think, which has php-apc-webadmin
20:25:16 <MrsB> any other questions while we're here?
20:25:27 <wilcal> nope
20:25:55 <DavidWHodgins> #topic 4.1 ISOs
20:26:11 <MrsB> This is pretty much over to you Dave
20:26:17 <MrsB> How are they looking?
20:26:22 <wilcal> These problems continue to be specific to some platforms but not all right?
20:26:49 <wilcal> No problems with Live media no problems in Vbox
20:27:00 <lewyssmith> What remains?
20:27:05 <MrsB> I tried a kde live isos on an old computer and had issues with it not starting kde (kdeinit4 failed or it got stuck at kdm)
20:27:24 <DavidWHodgins> Ouch
20:27:28 <lewyssmith> Damn.
20:27:42 <wilcal> Tried with burned CD/DVD or usb stick?
20:28:09 <MrsB> It was burned, could have been a bad cd drive etc
20:28:22 <DavidWHodgins> I was about to say, I think we're ok to release, but let's give it a couple of more days to do more testing.
20:28:53 <MrsB> I've sturggled to find time so far this week and now full of cold :\
20:28:55 <DavidWHodgins> Testing on my old system is painful, but I'll give it a try.
20:29:03 <wilcal> be careful burning a CD with new DVD drive and playing on an old CD drive
20:29:11 <lewyssmith> MrsB: I rather think Brasero can be made to verify the DVD it writes.
20:29:18 <wilcal> they may not be compatible
20:29:29 <dvg_i> k3b is more reliable
20:29:42 <lewyssmith> But can it do that?
20:29:42 <MrsB> yes. I'll need to test it again.
20:29:44 <wilcal> Best is to burn on the same drive that reads it but then you can't move it somewhere else
20:30:07 <wilcal> removable media, I could write a book and almost did a couple times
20:30:15 <lewyssmith> !
20:30:26 <MrsB> It was one of John's old ones I set up to try and rescue any files from. The livecd/livedvd 32 both had issues though
20:30:35 <DavidWHodgins> I've given up on optical drives. Replace my dvd burner 4 or 5 times in 9 years. Too unreliable for a heavy smoker with  a cat.
20:31:09 <DavidWHodgins> That may be due to other hardware problems.
20:31:22 <lewyssmith> The only trouble I had with one was down to crummy ISOs.
20:31:29 <MrsB> yep. So I'll set it up again tomorrow and have another go I guess
20:31:54 <Kernewes> I've been preoccupied trying to install and boot Mageia 3 (yes 3) on one of my 64-bit laptops
20:32:02 <Kernewes> it doesn't want to know
20:32:04 <DavidWHodgins> I've also seen a lot of bad burns due to defects in the cd/dvd, especially on rw dvds.
20:32:07 <wilcal> I think at some point the ultimate install is via boot.iso on a usb drive and pointed to the repo
20:32:43 <MrsB> Any other issues with the ISOs?
20:32:46 <wilcal> If you can't get it to work with a CD/DVD then you gotta go to a usb boot.iso
20:32:55 <wilcal> I've not had any real problems here
20:32:56 <DavidWHodgins> That's  the best way to install if you have a local repo, or fast and stable internet.
20:33:00 <MrsB> yeah, i'll have another go tomorrow
20:33:12 <wilcal> But sometimes old hardware you gotta do it
20:33:23 <lewyssmith> the real way.
20:33:28 <MrsB> we need to test the ISOs themselves for 4.1 though rather than the repo
20:33:46 <wilcal> The Live-CD's are pretty good and should work most places
20:33:50 <DavidWHodgins> Including the boot.iso and bootnonfree.iso.
20:34:23 <MrsB> Nobody anything to report?
20:34:42 * MrsB hasn't seen the pad even
20:35:22 <lewyssmith> *Are* we going to have a review of M4?
20:35:28 <wilcal> pad is still here I think:
20:35:30 <wilcal> https://pad.riseup.net/p/Mageia-4.1
20:35:32 <[mbot> [ Riseup Pad ]
20:35:40 <DavidWHodgins> No problems that I haven't mentioned on the mailing list. network problems were a mistake in my vb guest setup. Keyboard not working, I could not reproduce (which is annoying, as it may show up for some people, who will not retry).
20:35:51 <MrsB> a post-mortem you mean lewis?
20:36:10 <lewyssmith> Yes.
20:36:51 <DavidWHodgins> Let's plan on having that next week, hopefully after the 4.1 iso images have been released.
20:37:09 <wilcal> Sounds like a plan
20:37:20 <lewyssmith> But it is too big for IRC alone.
20:37:44 <DavidWHodgins> We can cover main points in irc, then take it to the discuss mailing list.
20:38:07 <lewyssmith> There was a Wiki page.
20:39:12 <MrsB> add comments there if you like, we'll refer to it next meeting then
20:39:56 <lewyssmith> Already have.
20:40:00 <MrsB> we kind of got wrapped up in the slew of updates and neglected the post-mortem
20:40:27 <MrsB> maybe one comment should be to fix more stuf *before* release
20:40:56 <Kernewes> but not so late in the cycle that it makes the betas worse than the alphas
20:41:00 <wilcal> I think the biggest factor here was the Feb 1 date for FOSDEM
20:41:18 <Kernewes> yes, I think it was rushed a bit
20:41:48 <MrsB> Unfortunately so, largely due to destabilisation in later stages though
20:41:55 <lewyssmith> My 1st point was WHAT GOES IN IS WHAT SHOULD COME OUT.
20:41:57 <DavidWHodgins> Yes, we did rush things, but the biggest problem (syslinux), we would not have found anyway, as none of us had hardware affected by it.
20:42:04 <lewyssmith> NO develoment along the way.
20:42:26 <MrsB> Let's do it next week though please
20:42:36 <DavidWHodgins> lewyssmith: There has to be devel after release freeze, to fix bugs we find.
20:42:54 <DavidWHodgins> Shall we move on?
20:42:55 <Kernewes> it's new stuff going in too late
20:42:58 <wilcal> Yup
20:43:00 <MrsB> i think so
20:43:05 <DavidWHodgins> As per the msg on the mailing list, we'll skip Luigi's Roundup.
20:43:07 <lewyssmith> On.
20:43:19 <DavidWHodgins> #topic Anything else?
20:43:19 <MrsB> let's have a topic and an info tho
20:43:28 <MrsB> or just an info :)
20:43:41 <wilcal> I see Philippe Makowski just posted new system-config-printer files
20:43:42 <wilcal> in core/updates_testing so I'll get to that today or tomorrow.
20:43:54 <MrsB> #info Luigi's Roundup is on the ML this time as Luigi is out running today
20:43:54 <DavidWHodgins> #info see the msg in the discuss mailing list for Luigi's Roundup
20:44:10 <lewyssmith> wilcal: Ah. Your bete noir.
20:44:26 <DavidWHodgins> Regarding the ldap group http://people.mageia.org/g/mga-qa.html
20:44:28 <[mbot> [ people.mageia.org: g/mga-qa ]
20:44:50 <DavidWHodgins> Currently it only has the members allowed to commit advisories to svn
20:44:59 <MrsB> Is this a something else?
20:45:13 <Kernewes> same for other teams too by the look of it
20:45:44 <DavidWHodgins> I'd like to see a seperate group qa-committers, and have more people officially recognized for participating in qa testing, by adding them to the qa group.
20:46:06 <MrsB> yes we should organise it a bit better. It would be helpful for ISo testers too
20:46:08 <DavidWHodgins> Yes, this is a something else. :-)
20:46:13 <Kernewes> there was supposed to be a long list of credits for Mga4 but it doesn't seem to have appeard
20:46:15 <MrsB> a qa-iso-testers group
20:46:44 <lewyssmith> Which could/should be seperate.
20:46:56 <lewyssmith> i.e. The functions.
20:47:06 <MrsB> I'll discuss it with colin, he seems to be doing alot of ldap stuff at the moment
20:47:26 <DavidWHodgins> That would be good too. I'll post a msg to the sysadmin list, asking for the new groups, and other changes needed to get qa-commiters svn access, but not all qa members.
20:47:31 <MrsB> ok
20:48:15 <DavidWHodgins> Then we can use the discuss list, to get a list of people who whould like to officially be listed in the qa, and qa-isotesters groups.
20:48:38 <MrsB> #action Dave to speak to sysadmins about adding a qa-committers group and qa-iso-testers group and some way to add people to mga-qa group who are a part of the qa team.
20:49:05 <MrsB> It would be useful to be able to email the qa-iso-testers group too Dave
20:49:17 <DavidWHodgins> I'm pretty sure adding people is done via bug reports assigned to sysadmin.
20:49:24 <DavidWHodgins> Yes.
20:49:34 <MrsB> i18n have some way to do it through identity
20:49:53 <MrsB> Speaking with Akien about this before
20:49:55 <DavidWHodgins> I'll ask about that in the msg to the sysadmin list.
20:50:26 <MrsB> We'll leave that with you then Dave
20:50:46 <DavidWHodgins> Ok. That's all from me. Anyone else have anything else?
20:50:50 <MrsB> thanks :)
20:50:52 <lewyssmith> Not me.
20:50:56 <MrsB> Anything else else?
20:50:58 <wilcal> Not from me
20:51:40 <MrsB> Well in that case, thankyou all for coming and for keeping it short :)
20:51:50 <Kernewes> MrsB: thank you for coming
20:51:59 <MrsB> Same time next week - kinda
20:52:06 <DavidWHodgins> Hope you're feeling better soon Claire.
20:52:11 <MrsB> t - 5
20:52:15 <MrsB> 4
20:52:17 <MrsB> 3
20:52:18 <lewyssmith> Bon soir�e.
20:52:18 <MrsB> 2
20:52:20 <MrsB> 1
20:52:22 <MrsB> #endmeeting