19:05:04 <MrsB> #startmeeting
19:05:04 <Inigo_Montoya`> Meeting started Thu Jul 25 19:05:04 2013 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:04 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:19 <MrsB> Hi all, wlecome to another QA meeting!
19:05:28 <MrsB> typo's start now ^^
19:05:35 <MrsB> #chair DavidWHodgins
19:05:35 <Inigo_Montoya`> Current chairs: DavidWHodgins MrsB
19:05:36 <DavidWHodgins> #topic Who's new?
19:05:43 <MrsB> thankyou :)
19:05:49 <MrsB> Sooooo who's new?
19:06:05 <MrsB> |Slacker|: hi
19:06:24 <DavidWHodgins> Doesn't look like sandro is on right now.
19:06:43 <MrsB> shame, if he comes back soon we'll do it then
19:06:52 <MrsB> let's go on
19:06:53 <DavidWHodgins> #topic Clearing the ISO testers list
19:07:03 <MrsB> Ah yes
19:07:12 <wilcal> Probably a good idea
19:07:40 <lewyssmith> Can you not leave those people who *did* participate last time?
19:07:44 <MrsB> The existing list of ISO testers is a dated now, people signed up with good intentions but never actualyl did anything
19:08:03 * led43_mag1 needs to remove his name
19:08:03 <MrsB> yep, was thinking that would be a good start lewis
19:08:18 <MrsB> not so fast led43_mag1 :P
19:08:43 <MrsB> DavidWHodgins: what are your thoughts on doing this?
19:09:10 <DavidWHodgins> I think it would be easier to clear the list, and have everyone re-add their names.
19:09:25 <MrsB> https://wiki.mageia.org/en/QA_ISO_testers as a reminder
19:09:34 <lewyssmith> Nameas are asy; the h/w details more of a pain
19:09:35 <led43_mag1> i won't be able to do the beginning of the testing, once the ribs have healed i can do some inbetween the chemoand radiation doses
19:10:05 <MrsB> I can leave those that have already said, or those that do do testing, and clear the rest.
19:10:08 <DavidWHodgins> We should leave the hardware list, as is, I think.
19:10:19 <lewyssmith> Good
19:10:19 <wilcal> You can leave me on the list
19:10:41 <MrsB> that's OK led43_mag1, we can leave oyu there and you join in when you're feeling a bit better
19:10:55 <led43_mag1> when i do start testing i should be able to do 32 & 64bit tests on real h/w
19:11:13 <lewyssmith> Are we liable to get kernewes back?
19:11:18 <swecarp> MrsB:  remowe me from listu can
19:11:50 <MrsB> #info We'll leave those that have already said, or those that do do testing, and clear the rest.
19:12:12 <MrsB> swecarp: thanks for saying
19:12:13 <Akien> I intend to do more ISO testing as for mga3, as time permits.
19:12:18 <Luigi12_work> uh oh, freenode notice, there's going to be some disruption and netsplits
19:13:07 <wilcal> There is a new piece of hardware hitting the market from multiple suppliers
19:13:09 <wilcal> Helps a lot in ISO testing on real hardware
19:13:10 <wilcal> http://kingwin.com/products/cate/mobile/racks/kf_253_bk.asp
19:13:11 <[mbot> [ Welcome to www.Kingwin.com: Mobile Racks - KF-253-BK ]
19:13:47 <MrsB> #info those to leave who have said just now include Akien, marja, lewyssmith, wilcal, led43 so far (and Dave and MrsB)
19:14:10 <MrsB> spiky001: shall we leave you too?
19:14:33 <spiky001> I dont test iso???
19:15:11 <MrsB> I'm guessing dvg we can leave too
19:15:41 <MrsB> #info spiky001 and dvg and probably others too
19:16:07 <DavidWHodgins> spiky001: By leave, Claire means leave on the list. (I.E. keep) :-)
19:16:15 <MrsB> that's a good start and more realistic than the list there right now
19:16:22 <MrsB> sorry, yes
19:16:29 <wilcal> I agree
19:17:21 <MrsB> Let's move on then, i'll do that in the morning
19:17:27 <DavidWHodgins> #topic Getting ready for ISOs
19:17:29 <MrsB> #action MrsB to trim the list
19:17:39 <MrsB> thanks Dave
19:17:54 <MrsB> So we're approaching ISO testing again as you know
19:18:25 <MrsB> Is everybody ready for it, got a spare partition or somewhere to install things? Maybe VBox too.
19:18:39 <wilcal> I'd like to ask that you send me a copy of your script program again MrsB
19:18:51 <MrsB> Yep sure can
19:18:58 <DavidWHodgins> It's a good idea to prepare in advance, at least one spare partition, and decide how you're going to handle the boot manager.
19:19:13 <MrsB> We need, between us, to write the wiki page on how to ISO test
19:19:26 <wilcal> David, I'm finding the latest version of Vbox quite nice
19:19:33 <DavidWHodgins> I've set aside a seperate hd, so I can also test various boot managers.
19:19:38 <marja> DavidWHodgins: do you mean you can choose to only have Grub2?
19:19:55 <marja> DavidWHodgins: s/you/I/
19:19:58 <MrsB> I can do it but I need time to do so. I'm struggling to keep pace with testing updates and 'anything else'
19:20:11 <DavidWHodgins> grub legacy, grub2, lilo, or third party utilities such as gag.
19:20:16 * led43_mag1 has a spare 32bit pc, and when i can pick up the poorly 64bit boxes i will repair them
19:20:17 <lewyssmith> Do we know whether it will be EFI ready?
19:20:40 <MrsB> I don't think so at this stage lewis
19:20:49 <MrsB> i think Colin has plans for that though
19:20:57 * led43_mag1 no efi h/w
19:20:57 <lewyssmith> OK. I shall stick to 32-bit
19:21:21 <MrsB> Last time, the first alpha was really stable as not much had really changed
19:22:02 <MrsB> We should set our expectation at 'a bit rough around the edges' though
19:22:37 <MrsB> this one is really somethign of a base to build upon
19:22:44 <MrsB> It *should* have all the ISOs built this time though. With Mga3 we didn't get those until later on
19:22:44 <DavidWHodgins> At this point, I think we should concentrate on testing the drak* tools, and the installers.
19:22:47 <wilcal> 1st Alpha is usually pretty good, it's the 2nd & 3rd that can be fun
19:23:00 <wilcal> will it install at all
19:23:05 <MrsB> yeah, basically
19:24:12 <MrsB> I'd be happy if we can get the docs written though as we've found that people join in as we go along, so we need to be able to direct people to  page saying how to ISO test
19:25:06 <wilcal> Is there any really BIG new app or feature that would get people interested
19:25:36 <DavidWHodgins> Not that I know of.
19:25:47 <wilcal> I myself would LOVE to see OpenShot 2.0 but I'm not see'n that till Dec
19:26:25 <MrsB> I thought I'd started a new ISo testing howto page, can't see it there :\
19:26:27 <wilcal> Lightworks is also I think too many months out
19:26:51 <lewyssmith> Can I expect my elderly SiS video h/w to work properly?
19:27:07 <MrsB> Oh I found it
19:27:08 <MrsB> https://wiki.mageia.org/en/Pre-release_ISO_testing
19:27:13 <wilcal> My old SiS box is running M3 as a print server
19:27:33 <MrsB> Maybe lewis, if you test it early and report any problems
19:27:34 <wilcal> Circa 2004
19:27:55 <lewyssmith> Mine has never worked properly under M3
19:28:13 <wilcal> It's really really slow though
19:28:22 <swecarp> i hope my wifi will work
19:28:24 <MrsB> Anybody volunteer to either step up their testing so I can plough some time into creating the wiki page or to make a start on the wiki page?
19:28:50 <wilcal> I'm starting to get a little more agressive on update testing
19:28:59 <DavidWHodgins> I'll try to put in more time over the next couple of days.
19:28:59 <MrsB> It's nice to see, thanks
19:29:27 <lewyssmith> Claire, you know too well that I was willing to write a procedure last time; but have forgotten everything I thought should be in there.
19:29:28 <wilcal> Was tinkering with the QT4 thing this morning
19:29:46 <MrsB> that's precisely why we need it lewis
19:29:59 <lewyssmith> Exactly!
19:30:37 <MrsB> Ok, if everybody could please test as much as you can I'll make a start on the page.
19:31:00 <lewyssmith> I will add as I can
19:31:32 <MrsB> If you see any glaring missing bits please add a topic or send an email to qa-d or something
19:31:47 <lewyssmith> Claire: I sent you an e-mail once with the skeleton of what seemed to me to need explaining
19:31:56 <MrsB> I'll see if I can find it
19:32:06 <MrsB> It's just time I'm short of
19:32:20 <lewyssmith> I will look for it too
19:33:00 <MrsB> Let's go on then. Please have a think though and make yourself ready for the ISOs when they arrive.
19:33:09 <DavidWHodgins> #topic Testing updates - How's it going?
19:33:15 <MrsB> if you've any questions, as ever, don't hesitate to ask
19:33:21 <MrsB> Thanks
19:33:33 <MrsB> That all brings us nicely onto this :)
19:33:33 <wilcal> I've an interesting technical point on my testing
19:33:46 <MrsB> oh, go on
19:33:54 <wilcal> I learned an inportant technical point testing VirtualBox
19:33:55 <wilcal> VirtualBox don't work so good inside VirtualBox  :-0
19:34:09 <MrsB> lol I'm not surprised
19:34:26 <DavidWHodgins> :-) That's to be expected. vb, like the kernel, needs to be tested on real hardware.
19:34:53 <MrsB> How are you all getting on with testing updates though, in general?
19:34:58 <DavidWHodgins> Same with things like xen or qemu.
19:34:58 <lewyssmith> I have tried (am using) 10766 Qt update, & OK'd it in the bug for M3 32-bit
19:35:14 <MrsB> Lewis I noticed yours tonight, well done. That can be validated now can't it?
19:35:15 <wilcal> I think the Vbox and Apache exercises went well
19:35:38 <wilcal> Those are big apps
19:35:46 <lewyssmith> MrsB: I imagine so. Want me to try that?
19:36:05 <MrsB> Yes, please do. If you follow the validation process it's all there
19:36:25 <MrsB> https://wiki.mageia.org/en/QA_process_for_validating_updates
19:36:39 <lewyssmith> I *know* about this!
19:36:41 <DavidWHodgins> Oops. The advisory hasn't been uploaded yet. I'll do that shortly.
19:36:48 <lewyssmith> thanks
19:36:53 <MrsB> :)
19:37:20 <MrsB> spiky001: Have you seen any that take your fancy?
19:37:47 <spiky001> Not yet I will have a look and see
19:37:51 <MrsB> \o/
19:38:04 <MrsB> So we're doing quite well it seems
19:38:19 <MrsB> Anybody have any questions while we're all here?
19:38:29 <wilcal> not here
19:38:34 <spiky001> I have been off line last week but all fixed now
19:38:48 <MrsB> |Slacker|: if you gte back, say hi :)
19:39:21 <MrsB> I hate it when t'internet dies
19:39:38 <MrsB> end up doing weird stuff like gardening
19:39:55 <lewyssmith> i.e. the important things in life
19:39:56 <MrsB> I'd sooner the telly and phone went than t'internet
19:40:00 <spiky001> yes idid
19:40:44 <MrsB> Is everybody OK to carry on with these then? Gaining confidence?
19:41:12 <lewyssmith> I am often baffled by bug descriptions; they could be in Martian
19:41:15 <wilcal> Get'n better here
19:41:56 <MrsB> The security updates can be a bit that way. It helps to google the CVE and see what turns up, but if there is no PoC then just test the package orks
19:42:05 <MrsB> works*
19:42:13 <wilcal> Do no damage
19:42:20 <MrsB> yep
19:42:30 <lewyssmith> e.g. pykolab needs patch to deleted some none existent roundcubemail plugins
19:42:37 <wilcal> Sometimes that's all you can do with security updates
19:42:49 <wilcal> I can't do a DoD attack here
19:43:27 <MrsB> If you can't then don't. Just test the update works and updates Ok.
19:43:57 <wilcal> wrinkle at the start of testing the Apache update then things went fine
19:44:12 <MrsB> For alot of things the PoC is kept private until major vendors (ie. distributions like us) have released updates
19:44:32 <DavidWHodgins> lewyssmith: Advisory for qt uploaded to svn. Go ahead and validate it.
19:44:35 <MrsB> that kind of thing is to be expected wilcal, that's just why we're here though to find things like that
19:45:08 <lewyssmith> DavidWHodgins: thanks; tomorrow
19:45:26 <MrsB> Have a stab at it lewis, yeah
19:45:51 <MrsB> If there are no immediate questions let's move on
19:46:07 <DavidWHodgins> #topic Luigi's Roundup
19:46:12 <Luigi12_work> boo
19:46:13 <MrsB> thankyou :)
19:46:16 <MrsB> OoOoOo
19:46:27 <wilcal> HiYa Luigi
19:47:15 <MrsB> |Slacker|:  If you're reading the logs and wondering who Luigi12 is, he builds most of our security updates. You'll see alot of him :)
19:47:43 <MrsB> Over to you then Luigi12_work
19:48:06 <wilcal> Anything further on nagstamon Luigi?
19:48:16 <MrsB> yes, nice poke wilcal
19:48:51 <Luigi12_work> no, haven't heard anything from guillomovitch
19:49:00 <Luigi12_work> as well as many other packagers with things pending...
19:49:01 <wilcal> That should be an easy test if turned loose
19:49:07 <Luigi12_work> you can assign the nagstamon bug back to guillomovitch
19:49:27 <MrsB> Luigi12_work: what is waiting for packagers please?
19:49:38 <Luigi12_work> lemme check
19:50:20 <MrsB> I'll speak to malo tomorrow, see if he can gently prod some
19:50:37 <Luigi12_work> dmorgan has a whole list of things
19:50:52 <MrsB> can you name the more important ones
19:50:56 <Luigi12_work> zabbix from mitya.  I reminded him of it yesterday, still not sure his plan.
19:52:15 <Luigi12_work> dmorgan list is apache-commons-compress (Bug 6331), tomcat5 (Bug 8307), tomcat6 (Bug 10201), and openjpa (Bug 10817)
19:52:20 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=6331 normal, Normal, bugsquad, bugsquad, NEW , apache-commons-compress new security issue CVE-2012-2098, apache-commons-compress, apache-commons-compress10
19:52:21 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=8307 normal, Normal, dmorganec, dmorganec, NEW , Tomcat5 security update [WAS: tomcat5, tomcat6, tomcat (tomcat7) new security issues fixed upstream], tomcat5
19:52:22 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10201 critical, Normal, dmorganec, dmorganec, NEW , tomcat6 new security issues CVE-2012-3544 and CVE-2013-2067, tomcat6-6.0.36-5.mga3.src.rpm
19:52:23 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10817 major, Normal, dmorganec, dmorganec, NEW , openjpa new security issue CVE-2013-1768, openjpa-2.2.1-2.mga4.src.rpm
19:53:11 <MrsB> #info Waiting for packagers: dmorgan list is apache-commons-compress (Bug 6331), tomcat5 (Bug 8307), tomcat6 (Bug 10201), and openjpa (Bug 10817)
19:53:15 <Luigi12_work> the X.org update still needs done for mga2, not sure if tv's planning to do it (Bug 10105)
19:53:16 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10105 normal, Normal, bugsquad, bugsquad, NEW , Multiple vulnerabilities in X.Org
19:53:31 <Luigi12_work> the KDE update for Mageia 3 fixes three security issues, not sure why that's still on hold
19:53:53 <lewyssmith> Good ppoint
19:53:54 <Luigi12_work> glpi from guillomovitch (Bug 10579)
19:53:54 <wilcal> That's gotta be big
19:53:55 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10579 normal, Normal, guillomovitch, guillomovitch, NEW , glpi new security issues fixed in 0.83.9 and 0.83.91, glpi-0.83.8-1.mga3.src.rpm
19:54:09 <Luigi12_work> iceape from spturtle/cjw (Bug 10707)
19:54:09 <MrsB> #info Xorg for mga2 (bug 10105) maybe TV
19:54:10 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10707 normal, Normal, cjw, cjw, NEW , iceape multiple security issues fixed in IceApe 2.19
19:54:32 <Luigi12_work> freeswitch from dlucio, he worked on it in Cauldron today, so that might be on its way soon (Bug 10743)
19:54:33 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10743 normal, Normal, luis.daniel.lucio, luis.daniel.lucio, NEW , freeswitch new security issue CVE-2013-2238, freeswitch-1.2.8-1.mga3.src.rpm
19:54:55 <Luigi12_work> you can see the full list here https://bugs.mageia.org/buglist.cgi?quicksearch=comp:secu+-@qa-b  most of the ones I haven't mentioned I don't expect will get fixed
19:55:37 <wilcal> Java????
19:55:45 <Luigi12_work> what about Java?
19:55:47 <MrsB> #info guillomovitch glpi (bug 10579) cjw iceape (bug10707) dlucio freeswitch (bug 10743)
19:55:53 <Luigi12_work> openjpa is some java thing, as is apache-commons-compress
19:55:57 <wilcal> The weekly Java explot???
19:56:02 <MrsB> #info complete list https://bugs.mageia.org/buglist.cgi?quicksearch=comp:secu+-@qa-b
19:56:15 <wilcal> Seems to have gone quiet
19:56:15 <DavidWHodgins> :-)
19:56:35 <Luigi12_work> lcms2 should be coming to QA soon, other than that, I don't know of anything definitely in the pipeline
19:56:41 <MrsB> #action MrsB to really speak to malo, not just promise to like last week.
19:56:59 <MrsB> #info lcms2 is in the pipeline
19:57:07 <DavidWHodgins> Wow. That list is massive.
19:57:16 <Luigi12_work> yeah :o(
19:57:32 <Luigi12_work> so looks like just php needs tested right now, security-wise.  32-bit Mageia 3 is all that's left to test.
19:57:51 <Luigi12_work> the qt/qtwebkit one might be what the KDE team is waiting on (just guessing)
19:58:01 <MrsB> Yes probably
19:58:02 <Luigi12_work> that's all I have
19:58:07 <MrsB> easy to test that on
19:58:09 <MrsB> e
19:58:30 <MrsB> just install the updates and make sure kde dialogs all still look ok
19:59:01 <DavidWHodgins> #topic Anything else?
19:59:13 <MrsB> Thanks Luigi12_work
19:59:15 <|Slacker|> hello everyone
19:59:22 <dvg> count me in for iso tetsing (was away earlier, sorry)
19:59:22 <|Slacker|> just passing to say hi
19:59:23 <MrsB> Hi |Slacker|
19:59:30 <|Slacker|> I'm about to go to work now
19:59:40 <MrsB> Welcome to the QA team :)
19:59:42 <led43_mag1> |Slacker|: hi
19:59:47 <DavidWHodgins> |Slacker|: Welcome!
19:59:48 <MrsB> thanks for popping in
19:59:51 <|Slacker|> I'm Sandro Cristiano, the guy from Brazil who's just joined this week
20:00:09 <wilcal> Get paid for this Computer Stuff ;-)
20:00:22 <wilcal> Hello Sandro
20:00:27 <MrsB> I'm Claire, UK based, I wrote the reply to you
20:00:30 <wilcal> I saw your messages
20:00:33 <led43_mag1> Hi and welcome, I'm john bowden from the Midlands UK
20:00:43 <MrsB> Instroduce yourselves quickly guys please
20:00:47 <DavidWHodgins> I'm Dave Hodgins, from London, Ontario, Canada.
20:00:56 <spiky001> Hi Sandro
20:01:04 <dvg> from NL
20:01:15 <wilcal> William Kenney ( wilcal ) from Surf City USA ( San Diego CA )
20:01:21 <lewyssmith> I'm Lewis in France
20:01:44 <|Slacker|> :)
20:02:00 <marja> |Slacker|: I'm from NL (the Netherlands), too, but not really in QA
20:02:09 <MrsB> Please don't hesitate to get stuck in and have a go at stuff |Slacker| and never hesitate to ask questions or ask somebody here for some help
20:02:23 <|Slacker|> got it
20:02:39 <marja> |Slacker|: I'm extremely happy to see someone from Brazil in QA :-D
20:02:47 <|Slacker|> \o/
20:02:50 <MrsB> Is there anything you'd like to ask now?
20:02:58 <wilcal> Big Big computer market is Brazil
20:03:15 <|Slacker|> I don't think so...just passed to say hi
20:03:25 <MrsB> Have a good day then :)
20:03:25 <|Slacker|> gotta go to work, my people, need me
20:03:26 <|Slacker|> :P
20:03:33 <MrsB> lol
20:03:40 <marja> |Slacker|: até a vista
20:03:42 <|Slacker|> thanks...I'll be here later on
20:03:53 <MrsB> Dave will probably be around :)
20:03:54 <|Slacker|> marja, o/~
20:04:12 <MrsB> and Luigi12 too
20:04:35 <MrsB> Is there anything else?
20:04:40 <wilcal> Not from me
20:04:42 <diogenese> They're both on later than most.
20:05:15 <led43_mag1> not here
20:05:23 <lewyssmith> Would a signifcant refinement of the ISO testing result system be out of the question?
20:05:43 <MrsB> Not if you've a better way of doing things
20:05:44 <DavidWHodgins> I'm in the eastern time zone of the americas, and a night hawk. :-)
20:06:09 <marja> :)
20:06:22 <lewyssmith> I have an idea which would make life easier for all, but it would not be trivial to implement
20:06:39 <MrsB> Put in in an email lewyssmith
20:06:48 <lewyssmith> Can I post it in the mailgroup?
20:06:54 <DavidWHodgins> Sure
20:06:55 <MrsB> of ocurse yes
20:07:03 <lewyssmith> Will do.
20:07:13 <MrsB> Is there anythign else else?
20:07:16 <led43_mag1> always open to suggestions
20:07:47 <MrsB> 5..
20:07:50 <MrsB> 4..
20:07:54 <MrsB> 3..
20:07:55 <DavidWHodgins> :-)
20:07:57 <MrsB> 2..
20:08:00 <MrsB> 1...
20:08:05 <lewyssmith> au revoir
20:08:13 <MrsB> Thatnks for coming everybody. Please keep testing!
20:08:20 <MrsB> #endmeeting