19:02:30 <MrsB> #startmeeting
19:02:30 <Inigo_Montoya> Meeting started Thu Jul 11 19:02:30 2013 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:30 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:33 * led43_mag1 will lurk but needs to finish setting up his netbook
19:02:39 <MrsB> Morning guys
19:02:58 <MrsB> welcome to another one
19:03:03 <MrsB> #chair DavidWHodgins
19:03:03 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB
19:03:10 <DavidWHodgins> #topic Who's new?
19:03:17 <MrsB> thanks :)
19:03:30 <MrsB> Is there anybody new here today, or thinking about starting?
19:03:57 <MrsB> i don't think so
19:04:13 <DavidWHodgins> #topic Release planning for Mageia 4
19:04:21 <MrsB> Ahh yes
19:04:37 <MrsB> I was looking for a wiki page for this but it's not there yet
19:04:56 <wilcal> Still a little early
19:04:59 <MrsB> #info Mageia 4 will be released just before FOSDEM next year
19:05:20 <MrsB> #info FOSDEM is 2nd & 3rd February
19:05:52 <wilcal> Sun/Mon????
19:06:06 <MrsB> #info First alpha release is scheduled for August so we only have a month to get our ISO testing documentation sorted out :\
19:06:14 <MrsB> hmm not sure
19:06:43 <MrsB> #info FOSDEM is really 1st & 2nd Feb next year not 2nd & 3rd
19:06:52 <wilcal> Just checked it's 1/2 Feb 2014
19:06:57 <wilcal> Whew
19:06:57 <MrsB> https://fosdem.org/2014/
19:06:58 <[mbot> [ FOSDEM 2014 - Home ]
19:07:15 <david_david> hello all
19:07:23 <MrsB> hi david_david :)
19:07:46 <MrsB> anybody any questions yet?
19:07:47 <wilcal> There will be a Mageia meeting also at Fosdem right
19:08:04 <MrsB> yes, it's the AGM
19:08:19 <wilcal> I pray for low airfares
19:08:50 <MrsB> if there's no questions we can move on
19:09:10 <DavidWHodgins> #topic Testing updates - how's it going?
19:09:13 <MrsB> i'll let you know the final dates when we have them
19:09:26 <MrsB> Soooooo
19:09:34 <MrsB> how's it going with testing updates?
19:09:51 <wilcal> I'm do'n some   :-))
19:09:56 <DavidWHodgins> I'll be retesting the kernels, right after the meeting.
19:09:58 <spiky> think i,m doing ok
19:10:01 <wilcal> Got the gscan2pdf pretty good
19:10:24 <MrsB> you're both doing well
19:10:29 <MrsB> keep it up :)
19:10:43 <wilcal> I've been following the kernel stuff and testing
19:10:55 <lewyssmith> 10402 & 10591 are both whitboarded MGA3-32-OK but not shown as OK in the Test 32 summary column. Why so?
19:11:29 <MrsB> bug 10591 does
19:11:30 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10591 normal, Normal, qa-bugs, qa-bugs, NEW , httpd sometimes deadlocks on restart/shutdown resulting in systemd timeout after a delay, httpd
19:11:38 <MrsB> bug 10402
19:11:40 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=10402 normal, Normal, qa-bugs, qa-bugs, RESOLVED FIXED, gscan2pdf: wrong encodging wih gocr and tesseract not seen, gscan2pdf-1.0.6-2.mga3.src.rpm
19:11:43 <wilcal> is there a difference between mga3-32-ok and MGA3-32OK or are they both ok   ;-)
19:11:49 <MrsB> that one was validated and pushed
19:12:22 <led43_mag1> i tested some 32bit kernels and 2 other bugs, but won't be able to do any for a week or two
19:12:37 <MrsB> wilcal: use mga3-32-ok please
19:12:45 <wilcal> will do
19:12:55 <wilcal> lwer case
19:13:03 <MrsB> caps don't matter but if you miss a - then it will
19:13:19 <lewyssmith> Bizarre: I started with http://mageia.madb.org/tools/updates and it showed a longer list including my queries
19:13:21 <[mbot> [ Mageia App Db ]
19:13:27 <MrsB> led43_mag1: you concentrate on getting better
19:13:38 <lewyssmith> but re-loading the page shows a shorter list & the 2 cited gone! Good
19:13:57 <DavidWHodgins> lewyssmith: As sood as an update is validated, it no longer shows there.
19:13:58 <wilcal> I've a question about moodle but that can wait till luigi's time
19:13:58 <led43_mag1> will do
19:14:14 <lewyssmith> I'm talking about minutes agho
19:14:42 <MrsB> When we validate things they move from our list onto the sysadmin list, you can see that here https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=updates-push&sharer_id=22&list_id=10791
19:14:55 <wilcal> I get the impression that testing a kernel takes more then just an install and successful reboot
19:15:11 <lewyssmith> What happened about that big KDE update?
19:15:15 <MrsB> It's a bugzilla saved search, so in bugzilla preferences you can choose to add it to the bottom of your pages if you like
19:15:30 <DavidWHodgins> wilcal: It also involves making sure hardware works, and dkms compiles/loading.
19:15:38 <led43_mag1> wilcal: you need to check any dkms modules are re done and loaded and all h/ware works
19:15:52 <lewyssmith> how do you do that?
19:16:02 <MrsB> bugzilla?
19:16:02 <wilcal> I think where I can help there is try on different and real hardware to see if successful reboot
19:16:10 <DavidWHodgins> Play sound, access the net, etc.
19:16:33 <wilcal> Ya I ran into a screen resolution prob in Vbox
19:16:40 <wilcal> noted that in the bug
19:16:50 <DavidWHodgins> On a security update, we're primarily looking for obvious regressions.
19:16:51 <MrsB> wilcal: you can check dkms modules with # dkms status
19:16:55 <led43_mag1> lewyssmith: hit the esc button when you see the cauldron pic and watch the boot msg. then check h/ware after boot finished
19:18:20 <MrsB> kernel testing is a bit of a marathon
19:18:44 <wilcal> kernel-desktop seems to go easily
19:18:55 <MrsB> don't be scared of them though, they are just another package, the same as any other
19:18:57 <wilcal> or do people do that first
19:19:11 <wilcal> I've been poke'n at'em
19:19:16 <DavidWHodgins> Mainly because it has to be done on real hardware, and there are so many kernels. Testing all of the kernels on both arches, for both releases involves around 80 reboots.
19:19:27 <wilcal> You test kernels in Vbox David?
19:19:42 <DavidWHodgins> Some. But mostly on real hardware.
19:19:50 <MrsB> david_david: how are you getting on?
19:20:18 <lewyssmith> What is kernel-rt?
19:20:25 <david_david> MrsB: it's good for me
19:20:29 <DavidWHodgins> real-time
19:20:46 <lewyssmith> Any way I can try it?
19:20:54 <DavidWHodgins> It's for sound recording, etc, where latency matters, as I understand it.
19:20:56 <MrsB> david_david: don't be afraid to ask if there is anything you don't understand
19:21:02 <david_david> it's been almost three years since I test
19:21:09 <MrsB> yes
19:21:39 <DavidWHodgins> All of the kernels should at least work, on an 64 bit system, though the i586 kernels are not expected to work, in an x86-64 install.
19:22:11 <wilcal> "work" means a successful reboot using test kernel?
19:22:18 <DavidWHodgins> Yes.
19:22:42 <david_david> MrsB: thanks, I feel pretty comfortable with the QA test
19:22:47 <MrsB> \o/
19:22:47 <wilcal> Sooooooo many things can get screwed up with a kernel change and you not know it
19:23:27 <DavidWHodgins> With practice, and watching the bug reports, to see what else is getting reported, you learn what to watch for.
19:24:18 <wilcal> Seems GRUB1 is better to test with then GRUB2 because it's easier to go back to an earlier ( working ) kernel
19:25:06 <DavidWHodgins> Easier to edit the menu.lst, too. With all kernels installed, on an i586 install, there are 22 entries (11 kernels, old and new).
19:25:30 <DavidWHodgins> That's on Mageia 2. On 3, it's a few less, as the netbook kernels were dropped.
19:25:51 <MrsB> spiky: all ok with everything?
19:26:02 <wilcal> Anyway I keep poke' and note'n when it makes sense
19:26:10 <spiky> yep just watching whats going on
19:26:32 <MrsB> lewis, you too?
19:26:50 <wilcal> http://mageia.madb.org/tools/updates is really kinda short from what it was
19:26:51 <lewyssmith> Not bad. I try those I think I can
19:26:53 <[mbot> [ Mageia App Db ]
19:27:13 <DavidWHodgins> Don't worry. It'll grow again. :-)
19:27:13 <wilcal> Take the kernel stuff out and it's really short
19:27:39 <MrsB> yes it went mad for a while. It has quiet time and busy times. There is always always stuff to do though
19:27:46 <DavidWHodgins> virtualbox update hasn't been assigned to us yet. It'll require testing on real hardware too.
19:27:59 <wilcal> I've committed and entire removable 1TB HD on big system for Vbox testing
19:28:59 <MrsB> Is everybody happy then for now?
19:29:12 <spiky> all good here
19:29:15 <wilcal> Again, we are making sure the app updates not necessarly how well it works
19:29:24 <wilcal> kinda the gscan2pdf thing
19:29:29 <david_david> What's going on about KDE in testing?
19:29:39 <lewyssmith> Seconded
19:29:44 <MrsB> it's not assigned to us yet david_david
19:29:55 <DavidWHodgins> Hasn't been assigned to qa yet, as there are still more changes planned.
19:30:02 <david_david> why ?
19:30:04 <MrsB> I remember neoclust saying he was going to update cauldron with something first
19:30:17 <lewyssmith> I am sure I have seen huge updates available
19:30:36 <DavidWHodgins> Yes, but there are more too be included, that are not ready yet.
19:30:45 <wilcal> cauldron is still VERY dynamic I assume
19:30:50 <MrsB> yeah, things are built into updates testing, when the packager thinks theyre ready for us they assign a bug to us to test them
19:30:52 <david_david> KDE4.10.5 certainly will come
19:31:02 <wilcal> I'm not even updating my local repo yet
19:31:08 <MrsB> yep, it's still coming, just not ready yet
19:32:00 <MrsB> anything else here or shall we ping Luigi12_work
19:32:04 <DavidWHodgins> #topic Luigi's Roundup
19:32:10 <Luigi12_work> boo
19:32:16 <MrsB> OOoOooOoo
19:32:19 <wilcal> Hello luigi
19:32:31 <Luigi12_work> sup :o)
19:32:44 <MrsB> chillin
19:32:49 <Luigi12_work> true, true
19:32:54 <MrsB> safe
19:33:09 <Luigi12_work> so the security update we did for Java 7 a couple weeks ago is finally ready for Java 6, so that's the big one we have right now
19:33:11 <wilcal> I've a question for Luigi on one of his Security updates
19:33:37 <MrsB> #info java6 & icedtea web are ready for tests on mageia 2
19:33:41 <Luigi12_work> the squid update has become a security update as a security issue was announced this morning, a buffer overflow related to DNS lookups with HTTP requests
19:33:51 <MrsB> #info use browser and java test sites
19:34:07 <wilcal> This is the browser java right
19:34:19 <MrsB> #info squid ldap bug is now a sec update today
19:34:23 <Luigi12_work> as for the other issue the squid update fixes, the previously missing files are included in the updated package, so I'm confident the initially reported issue is fixed
19:34:24 <MrsB> yes in mageia 2
19:34:27 <DavidWHodgins> Yes, icedtea-web is the browser plugin for java applets.
19:34:31 <Luigi12_work> so for squid, I'd just focus on the security issue
19:34:46 <Luigi12_work> I did fix the ksh thing that the reporter found
19:34:59 <Luigi12_work> I actually want to say more about that later
19:35:04 <DavidWHodgins> Any poc for the squid security bug?
19:35:09 <MrsB> #nfo focus on sec update for squid, just check those helper files are present
19:35:44 <MrsB> squid is a web proxy, you'll find previous updates and should find a procedure there
19:35:49 <Luigi12_work> DavidWHodgins: not sure, it was only announced today, no CVE yet, the CVE request was only done a few hours ago (it might have one assigned now, I need to check)
19:35:58 <MrsB> #info focus on sec update for squid, just check those helper files are present
19:36:50 <Luigi12_work> the only other security update we have right now is for Moodle, which is just a simple bugfix update, so that should be uneventful.  I did the upgrade locally at work, so my class will take their final exam in the updated Moodle tomorrow morning.
19:37:03 <wilcal> I have one for luigi
19:37:04 <wilcal> moodle new security issues fixed in 2.4.5
19:37:06 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=10755
19:37:07 <[mbot> Bug 10755: normal, Normal, qa-bugs, qa-bugs, NEW , moodle new security issues fixed in 2.4.5, moodle-2.4.4-1.1.mga3.src.rpm
19:37:07 <wilcal> I installed moodle 2.4.4-1.1.mga3 into a Vbox M3-32 that
19:37:09 <wilcal> had Apache already installed and running. When Moodle
19:37:10 <wilcal> installed it took down Apache and I could not start it
19:37:12 <wilcal> again. Moodle creates no icon in the launcher menus and
19:37:13 <Luigi12_work> if all goes well there, I can promise it works, so should be an easy validation next week once the advisory is available
19:37:13 <wilcal> I tried various URL names to try and get it to work in
19:37:15 <wilcal> a browser. All to no success. What would I expect when
19:37:16 <wilcal> I install Moodle? It seems to be an Apache killer.
19:37:33 <wilcal> How do I "run" moodle
19:37:38 <MrsB> #info moodle is ready for tests too, bugfix update
19:38:02 <Luigi12_work> wilcal: it restart apache automatically, the issue you saw is related to the bugfix update we have for apache also assigned to QA
19:38:05 <MrsB> wilcal: click the Bugzilla link on madb page and see the last update for it
19:38:12 <Luigi12_work> so it'd be nice to get that validated sooner rather than later as well
19:38:27 <Luigi12_work> but yes there's more info on testing Moodle in the previous bug
19:38:36 <wilcal> Thanks Luigi so maybe I wait till Monday to try again?
19:38:39 <Luigi12_work> basically you have to create a database for it first
19:38:45 <Luigi12_work> wilcal: yes Monday is fine
19:38:51 <MrsB> moodle might need you to uninstall php-suhosin
19:39:08 <Luigi12_work> shouldn't have to uninstall suhosion, I include settings in the package to make it work with suhosin
19:39:08 <wilcal> Is it a browser based thing
19:39:11 <Luigi12_work> I run it with suhosin at work
19:39:25 <MrsB> yes it's a webapp
19:39:42 <wilcal> so instead of localhost i use moodle?
19:39:49 <wilcal> or something
19:40:13 <MrsB> it'll be http://localhost/moodle i would imagine, can't remember of the top of my head but most webapps work that way
19:40:33 <wilcal> Thanks MrsB will give that a go next week when things settle
19:40:35 <Luigi12_work> correct
19:40:36 <MrsB> it'll need a database too
19:40:50 <Luigi12_work> so for pending updates lemme check
19:41:02 * Stormi waves then hides again
19:41:05 <MrsB> morning Stormi
19:41:09 <DavidWHodgins> :-)
19:41:24 * MrsB teathers Stormi to the back seat
19:41:35 <Luigi12_work> yeah don't leave Stormi I have something for you later
19:41:57 <Stormi> a job offer? :P
19:42:06 <MrsB> you have one of those
19:42:16 * MrsB needs one of those :\
19:43:28 <MrsB> spiky: lewyssmith david_david ok so far?
19:43:41 <david_david> yep ok
19:43:41 <lewyssmith> Just watching
19:43:46 <Luigi12_work> ok pending updates.  I hope to get mediawiki fixed for QA next week.  Still waiting on Funda for the ruby update (mga2 isn't done yet) and dmorgan for tomcat6 (init script isn't fixed yet).  darktable and libkdcraw need updates for the libraw issue we fixed a month ago, waiting on maintainers there.  Still waiting on guillomovitch for GLPI and nagios, and spturtle for Iceape, as well as dlucio for freeswitch.
19:44:02 <Luigi12_work> we have an apache update coming, once the update is available in Cauldron and Mageia 3 (mga2 is ready)
19:44:12 <Luigi12_work> in other news I still need maintainers to pitch in :o(
19:44:25 <Luigi12_work> and of course a virtualbox update for mga2 and mga3 is coming soon (tmb is working on it)
19:44:56 <Luigi12_work> und das ist alles
19:45:55 <david_david> Luigi12_work: Is that all? :D
19:46:15 <lewyssmith> mediawiki ruby tomcat6 darktable libkdcraw GLPI nagios Iceape freeswitch
19:46:19 <lewyssmith> What a list!
19:46:57 <MrsB> #info mediawiki might be next week. Waiting on Funda for the ruby update (mga2), dmorgan for tomcat6 (init script) , guillomovitch for glpi & nagios, spturtle for iceape and dlucio for freeswitch. Darktable & libkdraw need updates for the libraw issue we fixed last month
19:47:12 <david_david> and about libreoffice ?
19:47:39 <MrsB> #info apache update also coming
19:48:00 <MrsB> not sure what's happening with LO. I think tv maintains that now
19:48:41 <MrsB> #action MrsB to ask malo to gently prod some maintainers
19:49:12 <wilcal> M3 is pretty stable right now
19:49:24 <MrsB> #action david_david to find out what's happening with LO
19:49:27 <MrsB> :)
19:49:39 <david_david> :)
19:49:42 <Stormi> it was a trap
19:49:46 <MrsB> :D
19:50:03 <MrsB> Anybody want to ask Luigi12 anything?
19:50:26 <david_david> no for me :)
19:50:28 <wilcal> Not from me
19:50:36 <DavidWHodgins> #topic Anything else?
19:50:43 <MrsB> thanks Luigi12_work
19:50:43 * Luigi12_work has something
19:50:49 <Luigi12_work> yep
19:50:50 <MrsB> Ohh go!
19:50:54 <Luigi12_work> :o)
19:50:57 <MrsB> do we need a topic?
19:51:06 <Luigi12_work> nope, anything else is the topic I was waiting for
19:51:17 <MrsB> ok, the stage is yours
19:51:29 <Luigi12_work> so in the squid update candidate before I fixed it yesterday, it had accidentally pulled in a new dependency of ksh
19:51:39 <Luigi12_work> in the olden days, we would have caught something like this with depcheck
19:51:48 <Luigi12_work> but now we don't need to run it anymore
19:52:12 <Luigi12_work> another thing that would have caught something like this, is something Stormi did briefly, he had an rpmdiff thing that he would run on update candidates
19:52:25 <DavidWHodgins> Depcheck would not have caught it, if it was missing from the requires.
19:52:29 <MrsB> rpmdiff -iT
19:52:30 <Luigi12_work> rpmdiff would show what files or dependencies changed between the previous update or release version and the new update candidate
19:52:52 <Stormi> indeed
19:53:06 <Luigi12_work> so I was thinking, it would be nice if we could have a couple of reports automatically generated for update candidates.  It could either happen in madb or pkgsubmit or something else in the mageia infrastructure.
19:53:08 <Stormi> and we talked with sysadmins of having that autotically generated with an update candidate
19:53:16 <Luigi12_work> one would be an rpmdiff report
19:53:24 <MrsB> yes, that would still be nice to have Stormi
19:53:31 <DavidWHodgins> Only way to find that one, would have been to look at the contents of the shebang, in the scripts.
19:53:36 <Luigi12_work> the other would automatically generate the package and SRPM list that I currently have to manually put together with copy-paste and some awk commands
19:53:41 <Luigi12_work> for the advisory
19:54:13 <MrsB> so, you want an action?
19:54:21 <Stormi> we need to see with sysadmins
19:54:24 * MrsB hovers ready
19:54:27 <Stormi> would be better in pkgsubmit
19:54:42 <Luigi12_work> well I had this thought today, don't know what to do about it beyond just stating it, but yeah pkgsubmit would seem to be a nice place for it, especially the package lists
19:55:26 <Luigi12_work> Stormi: do you think you could look into this and maybe harass^H^H^H^H^H^Hspeak to rda or boklm or whoever?
19:55:31 <MrsB> yes, be nice if it were automated. The trouble with pkgsubmit is that the data disappears after a day or two and updates are often in testing longer than that before being assigned to us
19:55:56 <Luigi12_work> yes, just as long as it's available long enough for the packager to look at it and copy-paste anything needed into a bug report
19:56:13 <Luigi12_work> but yes, maybe something available always for current update candidates rather than just for two days would be nice
19:56:22 <Stormi> Luigi12_work: I can have a look this WE. At the end of the WE I would then tell you if I can handle it / have it handled by sysadmins
19:56:22 <MrsB> unless it could keep a history for stable releases
19:56:27 <Luigi12_work> especially for when packagers don't look at it right away, forget to look at it, or don't assign to QA right away
19:56:43 <Luigi12_work> Stormi: cool, thanks
19:56:51 <Luigi12_work> MrsB: I guess that can be your action thing
19:57:21 * Stormi now remembers why he rarely attends meetings :P
19:57:26 <DavidWHodgins> :-)
19:57:28 <Luigi12_work> haha, glad you're here today
19:57:33 <MrsB> #action Stormi to liase with sysadmin about generating rpmdiff -iT and srpm/rpm list on pkgsubmit
19:57:41 <MrsB> welcome back :)
19:57:45 <Luigi12_work> thanks, that's all from me
19:57:55 <DavidWHodgins> Nothing else here.
19:57:59 <wilcal> FWIW I've been spending a LOT of time with a friends M2
19:58:01 <wilcal> and my M3 system(s) getting the midi functions to work.
19:58:02 <wilcal> Makes my head spin.
19:58:17 * MrsB installs a 'delegate' button next to the escape key
19:58:21 <wilcal> ding ding ding dong
19:58:29 <DavidWHodgins> midi can be a royal pain!
19:58:40 <wilcal> You've really gotta be using ALSA
19:59:19 <wilcal> Got a WinXP Midi editor to run under wine on M3 worked pretty well
19:59:26 <wilcal> Didn't work on XP
20:00:04 <MrsB> Is there anything else?
20:00:15 <DavidWHodgins> Not here.
20:00:35 <MrsB> any last questions or shall we close?
20:01:06 <MrsB> Thanks for coming everybody, keep testing :) Same time next week!
20:01:10 <wilcal> I'm done and gotta get out of here
20:01:10 <MrsB> #endmeeting