19:03:19 <MrsB> #startmeeting
19:03:19 <Inigo_Montoya> Meeting started Thu Jun 13 19:03:19 2013 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:19 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:28 <MrsB> Hi everybody, welcome to another one :)
19:03:37 <MrsB> #chair DavidWHodgins
19:03:37 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB
19:03:38 <DavidWHodgins> #topic Who's New?
19:03:48 <MrsB> Thanks
19:03:58 <MrsB> Is there anybody new here today?
19:04:11 <MrsB> ca-on-adam: back yet?
19:04:47 <MrsB> guess not
19:04:55 <wilcal> All vets
19:05:12 <MrsB> ca-on-adam is new and was mentoring him earlier on while he was testing ffmpeg
19:05:36 <MrsB> we didn't finish due to some other issues
19:05:50 <DavidWHodgins> We can switch back to this topic, if he returns.
19:05:56 <MrsB> lets move on and see if he catches up
19:05:58 <DavidWHodgins> #topic  News from tmb
19:05:58 <MrsB> yep
19:06:30 <MrsB> If you were wondering whether we killed tmb during ISO testing, the answer is nearly!
19:06:51 <MrsB> He's been in hospital and had an operation but is out now
19:07:15 <MrsB> he'll be taking his time to recover properly, so won't be around for a while
19:07:17 <wilcal> Finger operation too much keyboard typing
19:07:53 <MrsB> #info we wish him a speedy recovery (but not too speedy)
19:08:23 <MrsB> #topic Push Script
19:08:51 <MrsB> You know how when we've tested an update and validated it we ask for sysadmins to push it for us
19:09:06 * MrsB waits for knowing nods
19:09:16 * DavidWHodgins nods
19:09:24 <lewyssmith> Ditto
19:09:31 <MrsB> Well...
19:09:31 <wilcal> Yes
19:09:56 <wilcal> At least I've been watching the process
19:10:12 <MrsB> sysadmins have been working on a script which will enable us to push for ourselves, most likely myself and Dave for now.
19:10:13 <DavidWHodgins> 11 validated update currently waiting to be pushed.
19:10:37 <ca-on-adam> back
19:10:40 <wilcal> I am not worthy yet to push one myself
19:10:45 <MrsB> there he is!
19:11:00 <wilcal> The Flash thing is pretty simple
19:11:14 <MrsB> you need to follow the validation process is all wilcal
19:11:33 <MrsB> any questions on this, if not we'll go back and say Hi to ca-on-adam
19:11:47 <DavidWHodgins> Let's come back to this after.
19:12:02 <MrsB> #topic Adam is new!
19:12:14 <MrsB> So welcome to the QA team (officially) ca-on-adam
19:12:40 <spiky001> welcome adam
19:12:47 <MrsB> Say a few words to introduce yourself and the others will do the same
19:12:48 <DavidWHodgins> ca-on-adam: Welcome to the qa team.  I'm Dave Hodgins, from London, Ontario, Canada.  Been with the qa team, since it started.
19:13:36 <MrsB> I'm Claire, based in the west midlands UK.
19:13:36 <ca-on-adam> Hi David.  I'm a bit East, in Toronto
19:13:42 <wilcal> Hi Adam wilcal ( William from California ) Surf City USA San Diego
19:13:53 <Tonyb> ca-on-adam: I'm Tony Blackwell, Brisbane, Austrlia, relative-newcomer.
19:14:19 <DavidWHodgins> I grew up here, lived in Montreal for 3 years, Toronto for 15, then moved back here.
19:14:19 <lewyssmith> ca-on-adam: I'm Lewis, Welshman living in France
19:14:35 <dvg> Dick Gevers from central Netherlands
19:14:48 <MrsB> Is anybody under 40 ?
19:14:56 <ca-on-adam> Umm, I'm 24
19:14:59 <spiky001> how rude
19:15:01 <wilcal> Good question
19:15:02 <MrsB> Wow!
19:15:10 * MrsB isn't
19:15:15 <dvg> no
19:15:26 * Luigi12_work == 31
19:15:31 <DavidWHodgins> I'm 52.
19:15:43 <Tonyb> 65
19:15:45 <alfred__> nearly 62
19:15:51 <MrsB> a good mix of people, all ages from all over the places!
19:16:02 <wilcal> Going on 68 here, first official college computer class in 64
19:16:17 <MrsB> did you have to build it yourself then wilcal?
19:16:32 <Luigi12_work> woo punch cards
19:16:34 <Tonyb> first used SCO xenix serial number 264 in the world...
19:16:39 <wilcal> I was very very lucky to be in the right place ( school ) at the right time
19:17:19 <wilcal> I still have knots on my head from crawling around inside vacuume column tape drives
19:17:25 <MrsB> how have you found it so far ca-on-adam?
19:18:05 <wilcal> Yep IBM punch cards I did a LOT
19:18:19 <ca-on-adam> Well this is a nice welcome.  Do you mean to ask how I found Mageia the OS, or the community, or Linux in general?
19:18:32 <MrsB> everything :)
19:18:36 <MrsB> and QA
19:18:48 <rindolf> ca-on-adam: welcome abroad, I am Shlomi Fish from Tel Aviv, Israel.
19:19:09 <MrsB> Kharec is sometimes here too but goes out partying instead sometimes
19:19:25 <ca-on-adam> Well, I switched away from Windows in 2009, started with Ubuntu and never went back.
19:19:26 <Kharec> hi I'm here :)
19:19:29 <rindolf> I'm 36. Below 40.
19:19:43 <MrsB> o/
19:20:08 <dvg> 36 berlow 40 = 4 ?
19:20:14 <ca-on-adam> MS-DOS was my first system (when I was 8), and I immediately like using the command line again...
19:20:16 <dvg> below
19:20:21 <Kharec> welcome ca-on-adam :)
19:20:42 <MrsB> he's been actively avoiding the GUI
19:20:56 <DavidWHodgins> I'm 34 (base 16) :-)
19:21:03 <wilcal> I'm pretty good with machine code on DEC PDP-11's
19:21:06 <ca-on-adam> I dislike GUI just like newbies hate the terminal.
19:21:11 <Kharec> I'm 23 in two days (the 15th)
19:21:12 <Kharec> :)
19:21:29 <MrsB> Kharec: I think you're the youngest then!
19:21:31 <ca-on-adam> Well Kharec, were nearly the same age!
19:21:33 <marja> Kharec: happy birthday in advance
19:21:39 * Luigi12_work is not a big fan of GUIs either
19:21:47 <Kharec> MrsB: I'm the youngest at my office yet :)
19:21:48 <Luigi12_work> Kharec: so another party then?  :o)
19:21:54 <MrsB> yeah happy bathday :)
19:21:59 <Kharec> Luigi12_work: saturday night fever :)
19:22:02 <Kharec> thanks all :)
19:23:04 <ca-on-adam> Well, pretty much I should have taken a path to college/university a few years ago, but I'm still not sure what to study.
19:23:16 <MrsB> so, an official welcome ca-on-adam, our meetings are recorded by a bot in the same way a normal meeting might b recorded by a secretary
19:23:32 <MrsB> you can see Inigo_Montoya changing topic and things
19:23:41 <ca-on-adam> Thus I have continued to delve into Linux to find out whether I can get a solid footing in it.
19:23:48 <MrsB> the minutes and logs will be on meetbot.mageia.org later
19:23:52 <ca-on-adam> ok
19:23:52 <wilcal> Want a good paying job in electronics specialize in radio/radar
19:24:08 <MrsB> you can add a minute to the logs by using the #info command
19:24:25 <wilcal> we're drifting :-))
19:24:38 <MrsB> we usually do :D
19:24:55 <MrsB> lets move on then
19:25:01 <Tonyb> must be somewhat up-to-date with important issues
19:25:01 <MrsB> I can't remember what was next
19:25:08 <DavidWHodgins> Back to the push script.
19:25:26 <MrsB> there wasn't much else to say on that yet
19:25:33 <MrsB> Lets go to...
19:25:40 <MrsB> #topic Testing Updates
19:25:40 <DavidWHodgins> When the validated keyword is added, will it still add sysadmin-bugs to the user list?
19:25:50 <MrsB> yes it does now Dave
19:26:08 <MrsB> So how are you all getting on with testing the updates?
19:26:21 <wilcal> good topic I'm obviously still a little confused
19:26:31 <wilcal> Is what I did in:
19:26:32 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=10495
19:26:33 <[mbot> Bug 10495: normal, Normal, qa-bugs, qa-bugs, NEW , Security update request for flash-player-plugin, to 11.2.202.291, flash-player-plugin
19:26:34 <wilcal> Comment 6 correct to help get it pushed
19:26:54 <MrsB> your testing is fine wilcal, you just need to follow the validation process to add the right whiteboard flags and validate the bug when it's ready
19:27:26 <MrsB> https://wiki.mageia.org/en/QA_process_for_validating_updates as a reminder
19:27:33 <wilcal> Ya that's where I'm get'n confused
19:27:49 <wilcal> is ther a whiteboard flag I should have used there
19:27:52 <DavidWHodgins> wilcal: If you look at comment 5, that one was already validated.  It's just waiting to get pushed.
19:28:06 <MrsB> yes, Dave beat us all to it for flash
19:28:16 <wilcal> I'll keep poke'n at it
19:28:24 <wilcal> It was good exercise for me
19:28:25 <MrsB> Try mercurial-server
19:28:32 <DavidWHodgins> The whiteboard entries are there for both arches, on both releases, and the validated keyword.
19:28:42 <wilcal> I can't edit
19:28:44 <wilcal> http://mageia.madb.org/tools/updates
19:28:46 <[mbot> [ Mageia App Db ]
19:28:47 <wilcal> right?
19:28:57 <MrsB> thats right, you don't touch that
19:29:06 <wilcal> K that was confusing me
19:29:10 <MrsB> everything you do is through bugzilla
19:29:14 <DavidWHodgins> It looks at the whiteboard entries, and looks for the validated keyword.
19:29:18 <wilcal> Thanks that helps
19:29:33 <MrsB> does that need to be made clearer on the wiki page?
19:29:47 <MrsB> I'm hoping to be able to take some time out from testign to work on our docs a bit
19:29:49 <DavidWHodgins> After changing the whiteboard entries, or adding the validated keywork, reload the updates page, and it should show the change.
19:30:27 <wilcal> Ok, note that I will be following folks till I get my confidence up on this
19:30:37 <wilcal> I DO NOT want to validate something that shouldn't
19:30:39 <MrsB> that's good advice in general
19:30:59 <MrsB> Never be afraid to ask though before you do something
19:31:31 <ca-on-adam> I've learned that the testing very much depends on the user's experience.
19:31:36 <MrsB> also you'll find it helps to watch what goes on on the qa-bugs mailing list if theres nothing you feel able to test
19:32:01 <MrsB> and to get somebody to go through it with you on IRC as you do it
19:32:07 <wilcal> The security things you can only test that the app works not the compromises
19:32:28 <MrsB> it depends, there are often PoC's we can use
19:32:37 <MrsB> proof of concept's
19:32:51 <DavidWHodgins> wilcal: Sometimes we have a proof of concept, to test the security bug, before and after installing the update.
19:32:51 <ca-on-adam> If it is software the edits video feeds, a user who works with video editing will have more confidence that they've tested it's functionality.
19:32:52 <MrsB> some snippet of code etc that triggers the vulnerability
19:33:20 <MrsB> Nobody is expected to know everything, we have to test everything though
19:34:06 <wilcal> why is backintime on the list when it is not really ready for update_testing
19:34:21 <DavidWHodgins> Sometimes, all we can test, is that a module loads.
19:34:36 <MrsB> It is ready ready for updates_testing but not ready for updates yet
19:34:50 <MrsB> if you notice if is greyed out on the madb page
19:34:53 <wilcal> so my entry there was a good one noting that it loaded but crashed
19:35:08 <MrsB> that happens when you add 'feedback' to the whiteboard
19:35:22 <MrsB> yep, it's not unusual to find problems, that's why we're here
19:35:37 <wilcal> Kool, I'm useful :-))
19:35:41 <MrsB> everso!
19:35:44 <Luigi12_work> indeed
19:36:13 <lewyssmith> A few lines, so please wait...
19:36:14 <MrsB> anybody else?
19:36:15 <wilcal> I'll keep poke'n at'em
19:36:23 <wilcal> more simple ones please
19:36:46 <lewyssmith> After testing a source RPM, how do you revert your system to 'before' it?
19:36:49 <MrsB> If there are any other ones which are easy to actually test I'll send email to qa-discuss again
19:37:07 <wilcal> super thanks
19:37:17 <ca-on-adam> I saw an email about testing NFS installs.  IS the author here?
19:37:22 <MrsB> You can just uninstall it lewyssmith
19:37:25 <lewyssmith> urpme only?
19:37:40 <MrsB> there is actually a downgrade function to urpmi now
19:37:42 <Luigi12_work> MrsB: unless it is needed by regular stuff on your system and uninstalling would majorly break it, which could happen sometimes
19:37:44 <DavidWHodgins> lewyssmith: For most of my testing, I use virtualbox, and create a snapshot before installing anything from updates testing, then restore the snapshot, after testing.
19:37:58 <Luigi12_work> can't you do something like disable the testing repo and do urpmi --replacepkgs foo?
19:38:14 <wilcal> I try to use real hardware and start with a Live media. Easily reproduceable by others
19:38:24 <MrsB> There are way to work around dependency problems
19:38:28 <wilcal> but I do have Vbox running M3
19:38:39 <MrsB> If it's something that's needed though then why not leave it installed
19:39:06 <lewyssmith> Exactly; but the procedure requires you to start with a clean system
19:39:24 <lewyssmith> Installed + user-updated
19:39:27 <Luigi12_work> well if the updates_testing version is messed up and a new one is submitted, you might want to re-test upgrading to the newer update candidate from the current stable versoin
19:39:36 <MrsB> For instalce, rpm -e --nodeps <package> removes a package ignoring complaints from anything that requires it, but be careful doing so as your system does need the package so be sure to re-install the old version
19:39:59 <MrsB> also urpmi --downgrade (I think it is) does something similar for you
19:40:07 <Luigi12_work> yeah, I guess you could also just download the rpms of the release/updates version (if you don't have them already) and rpm -Uvh --force them
19:40:07 <lewyssmith> I think I was already thinking along Dave's line
19:40:18 <MrsB> if using that option you need to specify the version to downgrade to
19:40:23 <Luigi12_work> ooh, hadn't heard about urpmi --downgrade
19:41:30 <ca-on-adam> ...so I take it the NFS testing is not needed?  Because I do have a full PXE/NFS setup...
19:42:09 <wilcal> Mandrake/Mandriva/Mageia have had NFS issues for years
19:42:19 <MrsB> Things that we test though will be actual updates sonner or later though so there is usually no harm in leaving them installed. Problems can arise if things get removed from updates testing and an older version resubmitted or if it's sriously broken but it's quite unusual that something so vital to a system would have that kind of error. They are usually well tested before they reach us.
19:42:20 <wilcal> M3 is pretty usable and stable
19:42:20 <DavidWHodgins> ca-on-adam: It probably needs to be fixed, but yes, it should be tested.
19:43:01 <ca-on-adam> It depends.  I know that Ubuntu does nfs well, surprisingly Debian not at all.
19:43:17 <wilcal> Yep, all sounds normal ca-
19:43:38 <ca-on-adam> But Debian specifically does not want to ship for NFS out of the box, so its not an issue for them.
19:44:24 <ca-on-adam> So, is it a priority for Mageia to support this? Admittedly, not many people will set up a DHCP/TFTP/NFS server to do this type of work.
19:45:09 <DavidWHodgins> ca-on-adam: We didn't test it for Mageia 3. Would be nice to have it fully working and tested for Mageia 4.
19:45:24 <lewyssmith> I noticed one update with just one source RPM, but loads of updated modules
19:45:42 <lewyssmith> Would it be necessary to update all the modules cited as well?
19:45:51 <MrsB> rpm's are built from srpm's
19:45:56 <MrsB> we test the actual rpms
19:46:17 <MrsB> it's best to install many, if nto all the rpm's listed, just to check they actually update ok
19:46:30 <DavidWHodgins> lewyssmith: Usually, all of the rpms should be installed (to ensure none are missing sigs, etc.), but testing is concentrated on those that have actually changed.
19:46:40 <wilcal> Side question if there is a RedHat/Fedora rpm what's the chances it works on Mageia
19:46:52 <wilcal> I've tried a few and they worked
19:47:11 <lewyssmith> I have generally had success with raw RPMs
19:47:26 <wilcal> one coming I'm excited about
19:47:31 <Luigi12_work> have we ever seen a set of RPMs built from the same SRPM where some got signed and some didn't?
19:47:33 * led43_mag1 most of the rh ones i have tried seem to have worked
19:47:55 * Luigi12_work can't remember that happening
19:48:03 <DavidWHodgins> Luigi12_work: Sometimes it's signed for one arch, but not the other.
19:48:12 <Luigi12_work> DavidWHodgins: oh, ouch
19:48:25 <MrsB> it's not supported obviously wilcal
19:48:43 <MrsB> and could break your upgrade later
19:49:10 <lewyssmith> You need to keep everyday & testing Mags apart, I think
19:49:34 <DavidWHodgins> Right now, kmag-handbook in core updates testing is not signed, but in that case, it's both arches.
19:49:37 <MrsB> I never have done, but it's up to you how you do it
19:50:08 <Luigi12_work> DavidWHodgins: how about kmag itself?
19:50:22 <DavidWHodgins> kmag is signed, is both arches.
19:50:27 <Luigi12_work> OMG
19:50:53 <DavidWHodgins> That's why we have to check all rpm packages.
19:51:01 <MrsB> spiky001: how are you getting on?
19:51:07 <Luigi12_work> yeah.  Hope they figure that out and get it fixed.
19:52:27 <MrsB> led43_mag1: may join us testing updates soon ;)
19:52:46 * led43_mag1 might not be fit enough to help much
19:52:51 <MrsB> :(
19:53:30 <DavidWHodgins> led43_mag1: Went through a similar problem a couple of years ago, due to pleurisy.
19:53:39 <MrsB> What's up?
19:53:48 <led43_mag1> been having lots of nasty test, seems its the big C
19:53:54 <wilcal> I had pleurisy when I was a kid, not fun
19:54:01 <MrsB> Ohhh nasty!
19:54:21 <ca-on-adam> 3led43_mag1: life... it happens.  I don't pretend to be committed to any degree, but when I do something for Mageia, it will be done to the fullest of my ability.
19:54:39 <DavidWHodgins> In my case, the cause was not found, and it went away on it's own after a month. Cause is assumed to be lupus.
19:54:49 <MrsB> have they confirmed it led43_mag1?
19:55:07 <led43_mag1> find out tomorrow what type of lung cancer and if they want to do an opp to find out if its spread to liver
19:55:16 <DavidWHodgins> Ouch!
19:55:22 <dvg> OMG
19:55:24 <MrsB> that's scary :z
19:55:30 * led43_mag1 is not dead yet!
19:55:48 <MrsB> you hadn't better, got plans for you
19:56:13 <DavidWHodgins> Hope it turns out to be just auto-immune, like mine.
19:56:17 <MrsB> let me know how it goes would you
19:56:25 <led43_mag1> any ways this is off topic
19:56:27 * DavidWHodgins too
19:56:31 <MrsB> yep
19:56:38 <MrsB> lets do the roundup!
19:56:46 <DavidWHodgins> #topic Luigi's Roundup
19:56:49 <MrsB> thanks
19:56:52 <wilcal> I'm ready for some more update testing
19:56:56 <Luigi12_work> w00t
19:56:57 <MrsB> Luigi12 builds most of our security updates
19:57:25 <wilcal> See ya all next Thursday
19:57:35 <MrsB> Could you do your thing with colins dbus Luigi12_work when you get a chance please
19:57:41 <wilcal> Na it's time for Luigi
19:57:55 <Luigi12_work> MrsB: yes I haven't had a chance to look at it but I know Colin did something, I'll clean it up in a bit
19:58:06 <MrsB> tahverymuchly
19:59:32 * MrsB waits for news of more work
19:59:38 <Luigi12_work> so that update might be serious, not sure yet, but sounds like it probably is
19:59:46 <Luigi12_work> the ffmpeg thing isn't, and that's all QA has at the moment
19:59:49 <Luigi12_work> lemme check what's pending
20:00:33 <MrsB> #info dbus is probably high priority, ffmpeg not so much
20:01:16 <DavidWHodgins> I think drakfirewall should be considered security as well. I'll test that right after the meeting.
20:01:30 <MrsB> yes, good idea Dave
20:01:39 <Luigi12_work> mediawiki will go to QA once I get a chance to help clean up some things in the package
20:01:59 <MrsB> #info mediawiki is coming soon
20:02:10 <Luigi12_work> there's a huge X.org update in progress, there's like 3 packages left to build for mga3, not sure when tv plans on finishing that
20:02:17 <Luigi12_work> almost every X package is being updated :o(
20:02:30 <MrsB> i saw he'd been doing that, theres kde soon too
20:02:33 <Luigi12_work> it's also needed for mga2, but nobody's working on it, so not sure when that'll happen
20:02:42 <Luigi12_work> yeah, the KDE 4.10.4 update will go to QA soonish
20:03:08 <MrsB> #info Thierry has been working on X11 so in progress and coming soon
20:03:22 <wilcal> The KDE thing'll be fun
20:03:37 <MrsB> yeah, it's alot of packages
20:03:43 <wilcal> Remember when Ubuntu blew up it's GUI
20:03:51 <MrsB> we'll need to ensure it updates cleanly
20:03:55 <Luigi12_work> still waiting on maintainers for apache-mod_security, otrs, chromium-browser, wireshark, python-pymongo, rubygem-passenger, and perl-Dancer
20:04:19 <MrsB> #info not too far away are apache-mod_security, otrs, chromium-browser, wireshark, python-pymongo, rubygem-passenger, and perl-Dancer
20:04:35 <lewyssmith> Whatever they are
20:04:39 <Luigi12_work> also possibly python-keystoneclient, python3 and a couple other python packages, libkdcraw, and darktable
20:04:41 <MrsB> yeah :D
20:04:53 <MrsB> crikey, you kept all those quiet
20:04:55 <ca-on-adam> wilcal: As in when Ubuntu chose Unity?
20:04:56 <Luigi12_work> well you all probably know what chromium-browser is at least
20:05:16 <lewyssmith> Yes!
20:05:21 <Luigi12_work> dmorgan submitted the wrong version to updates_testing, which has a higher version number but is actually older than the correct version
20:05:24 <MrsB> #info also sometime, python-keystoneclient, python3 and a couple other python packages, libkdcraw, and darktable
20:05:29 <Luigi12_work> so that needs to be deleteed and the correct version resubmitted
20:05:42 <Luigi12_work> so if you install the current chromium-browser in updates_testing, you'll need to uninstall it
20:05:46 <wilcal> Chromium - fallback when Firefox does not work
20:06:11 <wilcal> which happens a lot
20:06:19 <MrsB> we only install the packages we're testing (or should do) so it shouldn't be a problem
20:06:48 <Luigi12_work> in other news, I really need some package maintainers to step up and help fix their stuff :o(
20:07:07 <MrsB> maybe raise it at next council meeting or packagers meeting Luigi12_work
20:07:27 <Luigi12_work> work is going to be crazy for me for at least the next couple months, so I can only do so much right now
20:07:56 <MrsB> I'll let malo know there are some waiting and direct him your way :)
20:08:53 <Luigi12_work> any questions for me?
20:08:59 <DavidWHodgins> Not here.
20:09:00 <wilcal> Not from me
20:09:09 <MrsB> #info Some are waiting on package maintainers
20:09:27 <MrsB> #action MrsB to ask malo to speak with Luigi12_work
20:09:28 <DavidWHodgins> #topic Anything else?
20:09:28 <led43_mag1> nope
20:09:38 <wilcal> nope not here
20:09:40 <lewyssmith> No
20:09:41 <MrsB> thanks David
20:09:54 <MrsB> Anybody anything else?
20:10:13 * led43_mag1 can't think of any thing
20:10:14 <DavidWHodgins> I think we can wrap it up.
20:10:33 * led43_mag1 need a T refill
20:10:33 <MrsB> Well, thankyou all for coming! It's been good to see so many here tonight
20:10:42 <wilcal> See you next Thur
20:10:50 <MrsB> Same time next week
20:10:53 <led43_mag1> hopefully
20:11:14 <MrsB> don't forget to do soem testing and never be afraid to ask if there is anything you don't understand
20:11:31 <MrsB> or ask for somebody to sit with you on irc while you have a go
20:11:42 <MrsB> #endmeeting