19:02:21 <MrsB> #startmeeting
19:02:21 <Inigo_Montoya`> Meeting started Thu May 23 19:02:21 2013 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:21 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:41 <MrsB> Welcome then everybody to our first meeting of mageia 3!
19:02:52 <MrsB> #chair DavidWHodgins
19:02:52 <Inigo_Montoya`> Current chairs: DavidWHodgins MrsB
19:02:57 <DavidWHodgins> #topic Who's new?
19:03:07 <MrsB> Is there anybody new today?
19:03:10 <spiky_> me
19:03:15 <MrsB> \o/
19:03:18 <Kernewes> spiky_: hi there
19:03:19 <MrsB> welcome spiky_
19:03:26 <spiky_> hi evertone
19:03:34 <rindolf> spiky_: hi, welcome.
19:03:35 <spiky_> everyone
19:03:36 <wilcal> Hi spiky
19:03:43 <MrsB> Say a few eords to introduce yourself and the others will do the same
19:03:49 <MrsB> few words* even
19:04:02 <DavidWHodgins> Welcome to the Qa team!  I'm Dave Hodgins, from London, Ontario, Canada.
19:04:10 <MrsB> I'm Claire based in the UK
19:04:16 <MrsB> in the middle
19:04:27 <wilcal> wilcal here for William in California, Surf City USA San Diego
19:04:27 <spiky_> not a lot not say  from surrey uk
19:04:41 <Kernewes> I went to uni there
19:04:47 <MrsB> lewyssmith: here too?
19:04:48 <Kernewes> I'm Carolyn from Cornwall
19:04:48 <DavidWHodgins> London, Ontario is in Middlesex County. :-)
19:05:03 <MrsB> Led43_nb: here too?
19:05:24 <rindolf> I'm Shlomi Fish from Tel Aviv.
19:05:41 <spiky_> I am interested in helping out  where I can
19:05:51 <MrsB> you definitely can :)
19:05:52 <spiky_> and learning more
19:06:01 <Kernewes> spiky_: you will
19:06:08 <MrsB> don't be put off if you find it a bit scary at first
19:06:08 <spiky_> thks
19:06:20 <wilcal> you learn a lot on anything that you can help with
19:06:27 <DavidWHodgins> Always learning new things, when figuring out how to test packages I've never heard of before.
19:06:41 <MrsB> everybody is in the same boat really
19:07:25 <MrsB> Please never hesitate to ask anything, no matter how small, it's good to ask
19:07:44 <spiky_> ok
19:07:58 <Kernewes> spiky_: and rest assured, you'll never ask anything more stupid than what I ask
19:07:59 <MrsB> and if you'd like somebody to hold your hand through your first few updates then we can do that
19:08:50 <MrsB> spiky_ is Martyn who said hello on the ML the other day btw
19:09:12 <spiky_> I am
19:09:23 <MrsB> have you ever been to an irc meeting like this before?
19:09:34 <Mag2_Led43> spiky_: im Led43_??? and i live in the midlands uk
19:09:42 <spiky_> nope  not really used irc before
19:09:59 <spiky_> Mag2_Led43: hi
19:10:02 <wilcal> Your do'n fine just like a pro
19:10:12 <spiky_> thks
19:10:17 <MrsB> ok, well you may have noticed the topic has changed. The meeting is minuted much like a regular face to face meeting
19:10:29 <MrsB> Inigo_Montoya` is our meetbot
19:10:29 <Inigo_Montoya`> MrsB: Error: "is" is not a valid command.
19:10:54 <Kernewes> Inigo_Montoya`: is stupid
19:10:54 <Inigo_Montoya`> Kernewes: Error: "is" is not a valid command.
19:10:56 <lewyssmith> MrsB: Yes; lurking
19:10:57 <MrsB> it records the meeting unde rtopics we set and creates logs you can view online
19:11:34 <MrsB> anybody can add a minute to the meeting notes by using the #info command
19:11:43 <Kernewes> makes me jealous as a real-life minute-taker
19:11:51 <Kernewes> would save me no end of hassle
19:11:53 <MrsB> #info this is how you use the #info command
19:12:30 <MrsB> so with welcome mat extended, lets move on..
19:12:49 <MrsB> #topic Mageia 3 Post-Mortem
19:13:09 <wilcal> irst I wanna say that M3 looks really good. It settled out about
19:13:09 <wilcal> 30-days ago and is a solid Linux OS.
19:13:12 <MrsB> You probably saw the email on qa-discuss about this
19:13:30 <MrsB> yeah feedback has been good so far :)
19:13:46 <Kernewes> I was unlucky, everything I tried at first didn't work properly
19:13:51 <Kernewes> but going through my list
19:13:53 <MrsB> #info Well done everybody who helped to make Mageia 3 a success
19:13:56 <Kernewes> and trying different installs
19:14:08 <Kernewes> most of it is related to LXDE or the dual CD
19:14:13 <wilcal> I gotta say one bad bump
19:14:16 <Kernewes> which won't affect most users
19:14:18 <MrsB> the dualcd is very basic
19:14:33 <Kernewes> it's also very buggy
19:14:33 <wilcal> Probably a seperate subject
19:14:41 <Kernewes> KDE seems fine though
19:14:52 <wilcal> Naw I haven't seen much. I use KDE
19:15:12 <MrsB> What we really need to think about now is our procedures and tools and process of the release, what worked, what didn't, what can we do better next time and how?
19:15:14 <Kernewes> but even LXDE added on to KDE isn't quite right this time
19:15:27 <wilcal> That would get me to my bad bump
19:16:02 <MrsB> For me, one thing which was not so good was alot of the development happened only in the last week.
19:16:21 <wilcal> Yep, not a good thing
19:16:25 <Kernewes> we seemed to have a lot of boot-related problems with the pre-final isos
19:16:35 <MrsB> It seemed bugs were left and left and suddenly in the last week it went crazy
19:16:37 <Kernewes> didn't leave much scope for testing in more detail
19:16:43 <MrsB> exactly yeah
19:16:45 <DavidWHodgins> I've been thinking about the procedure, and have an idea that would reduce the work near release time, but would increase our work overall.
19:17:28 <wilcal> What's your proposal David
19:18:19 <DavidWHodgins> Create the Mageia 4 release now, as a copy of Mageia 3, separate from cauldron, and as packagers have things ready, have them submit to Magiea 4 updates testing, and we test them, like regular updates.  When release freeze happens, everything should be pretty much already tested.
19:18:43 <lewyssmith> Agreed
19:18:52 <wilcal> I want to see a 3 -> 5 day freeze on cauldron ( Mx ) and the ISO's
19:19:06 <DavidWHodgins> More work for packagers and us, but a better final product, with less time needed between release freeze and release.
19:19:11 <Kernewes> what about major system changes?
19:19:31 <DavidWHodgins> They would have to go through qa testing as well.
19:19:33 <MrsB> Well, it would be nice, but we struggle to keep up with updates for stable releases as it is
19:19:48 <Kernewes> DavidWHodgins: I mean would they be easy to add on to a copy of Mga3?
19:19:52 <MrsB> I think we could automate some of our testing
19:20:00 <DavidWHodgins> That's my only concern with the proposal.
19:20:13 <wilcal> Automated QA now there's a thought
19:20:33 <MrsB> it's not a whole thought though, it's basic testing
19:20:34 <Kernewes> Exterminate, exterminate, exterminate ...
19:20:51 <wilcal> Can I mention the bump I encountered
19:20:56 <DavidWHodgins> The developers would continue to develop on cauldron, but as they think each update is ready, submit it updates testing for Mageia 4.
19:21:07 <MrsB> there are soem things which get updated regularly or are easy to test which we could automate
19:21:22 <DavidWHodgins> Go ahead wilcal
19:21:24 <MrsB> who would test them though Dave?
19:21:27 <wilcal> Can't disable firewall ( critical ) bug
19:21:27 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=9329
19:21:27 <wilcal> 27 files in core/release were changed on 17/18 May
19:21:27 <wilcal> Including drakx-installer and drakxtools. The ISO's
19:21:27 <wilcal> are dated 18 May
19:21:29 <[mbot> Bug 9329: critical, Normal, thierry.vignaud, thierry.vignaud, REOPENED , Can't disable firewall, drakx-net
19:22:08 <MrsB> that's a bug yeah, but this time is more to discuss ourselves and the process as a whole
19:22:48 <wilcal> If Cauldron were frozen for 3 -> 5 days this would'nt have happened
19:23:11 <DavidWHodgins> We can discuss specific bugs in the Anything else topic, or after the meeting.
19:23:20 <wilcal> k
19:23:37 <MrsB> https://wiki.mageia.org/en/Mageia2_Postmortem here's the post-mortem from mageia 2 to give you an idea
19:23:59 <Kernewes> speaking for myself, unless QA can have more time for pre-release testing
19:24:15 <Kernewes> I shall have to stick to testing alphas and betas after they're released
19:24:21 <Kernewes> one build, less time pressure
19:24:22 <wilcal> During that "time" things can't be changing
19:24:45 <wilcal> It's a moving target
19:25:22 <wilcal> There's local time thing here too. I'm always at least 9-hours different than Europe
19:25:47 <MrsB> We could perhaps look to automate alot of the basic iso testing, making sure programs started and close ok, things like that.
19:26:24 <wilcal> Actually worked on such a thing over 10-years ago
19:26:35 <MrsB> nelg made a start on that, we could find out how he got on
19:26:59 <wilcal> Simulate that keyboard and mouse movements
19:27:24 <DavidWHodgins> Automated testing for the iso images would really only be useful if the iso images are rebuilt regulary, with the automatic testing done then.  There isn't really enough time for it during release testing.
19:27:32 * Mag2_Led43 while i was looking for an alternative to the "pad" last year i came across some but did not read into them much
19:27:51 <MrsB> if when isos are built they go through some automated tests to ensure the applications start and stop it would lift some of the workload
19:28:21 <MrsB> bear in mind that in early testing we were going through 5 builds per release
19:28:24 <Mag2_Led43> we definatly need a earlier freeze and then only bugs get updated and teasted
19:28:31 <Kernewes> I can't understand how QA get given isos that won't even boot
19:28:42 <lewyssmith> Seconded
19:28:58 <DavidWHodgins> That's why we test every iso. :-)
19:29:01 <dvg> never had that happen
19:29:16 <wilcal> It's happened
19:29:26 <Kernewes> DavidWHodgins: what do you mean?
19:29:27 <dvg> oh i believe you
19:29:32 <DavidWHodgins> A lot of the times, it was hardware dependant.
19:29:41 <wilcal> Yes david
19:29:41 <Kernewes> ah, ok
19:29:47 <Mag2_Led43> could there also be an "first run script thas starts / stops apps and reports on the outcome
19:30:11 <wilcal> That's why we need lots of people in QA testing on different hardware
19:30:25 <wilcal> Even if it's just booting the Live media
19:30:32 <MrsB> that's what I'm thinking of, not really a script but a VM on the server testing the basics before they are handed to us to test
19:31:10 <DavidWHodgins> The iso builders are ususally testing too, but pretty much only in vbox.
19:31:29 <Mag2_Led43> MrsB: that would not test the iso's on different h/w but would help
19:31:29 <dvg> that's why i alwasy test on real hw
19:31:31 <Kernewes> could they be persuaded to use real how as well
19:31:31 <wilcal> I rarely test in Vbox
19:31:41 <DavidWHodgins> They have to rsync the images, before they can test, so they are in pretty much the same position as we are.
19:31:43 <Kernewes> real hw
19:31:43 <MrsB> that's what I mean Mag2_Led43
19:31:55 <ennael> (hi I'm around)
19:32:09 <wilcal> Don't throw away your old computers use them for testing
19:32:11 <MrsB> ennael: do you think this is possible to set up?
19:32:17 <MrsB> hi btw :)
19:32:18 <DavidWHodgins> Sometimes we're faster then they are, so find out about non-working iso images first.
19:32:20 <ennael> what ?
19:32:23 <ennael> hi :)
19:32:49 <DavidWHodgins> Some basic automated testing of iso images, as part of the build process.
19:32:49 <MrsB> some automated testing of the basics of the isos before they reach qa, applications start and stop, install is possible etc
19:32:53 * Mag2_Led43 does that, but has had 3/4 faill and can't afford to repair them at mo
19:33:11 <ennael> MrsB: this is the point of having automatic tests before dev releases
19:33:28 <MrsB> that's what i mean yes, we don't have anything liek that at the moment
19:33:45 <ennael> nope and there is discussion started on that point
19:33:58 <ennael> but it was in the middle of the release so this should start again now
19:34:30 <MrsB> imho that would one thing we should work on for mga4 iso tests
19:34:50 <ennael> also one of the main bug on classical isos was about gfxboot and isolinux, this should be handled in the beginning of the release for mageia 4
19:34:53 * Mag2_Led43 seconds that
19:35:11 <ennael> but yes automatic tests have to be set up
19:35:23 <MrsB> We can help/create the test cases for it if there is the infrastructure there
19:36:51 <ennael> ok
19:37:29 <ennael> as an information we are also preparing next packagers meeting so that SIG can be set up
19:37:38 <MrsB> #info automating the basics of iso testing as part of build would be helpful. QA can create/help create test cases.
19:37:55 <MrsB> that should help to speed up the bug fixing process then
19:37:57 <ennael> it should help to manage low resources on some components
19:38:16 <ennael> and we will have one focused on specific devs (drak*)
19:38:16 <wilcal> fwiw I for years have a menu listing of how and what I install. It's a long one
19:38:28 <wilcal> I follow the same proceedure every time
19:39:00 <ennael> imho the big pb in mageia 3 release was about these specific devs
19:39:08 <ennael> too few people on it
19:39:43 <MrsB> #info packagers are working to create small subteams called SIG's (special interest groups) who will work together on a subsection of packages, for example Desktops SIG's etc (yet to be discussed)
19:39:43 <Kernewes> on what?
19:39:56 <Kernewes> oh
19:40:07 <ennael> on our tools
19:40:17 <Kernewes> ok, got it :)
19:40:17 <ennael> installer, mcc...
19:40:18 <DavidWHodgins> drakx* packages were the main problem.
19:40:30 <wilcal> I second that David
19:40:38 <MrsB> #info doing so should help in having people willing and able to fix bugs earlier
19:40:56 <ennael> so the point will be to create some doc, training process so that new devs can work on it
19:41:12 <ennael> just keep in mind it will not happen in 1 month :)
19:41:21 <DavidWHodgins> :-)
19:41:26 <MrsB> #info dev team/docs will also be created to work on drak tools
19:41:29 <Kernewes> you mean it'll happen in one week :)
19:41:47 <MrsB> ennael: brianb may be interested in helping in dev team
19:42:09 <ennael> yep there will be a call for volunteer
19:42:47 <ennael> while I'm here I just wanted to thank you personnally
19:42:56 <ennael> mageia 3 release was an amazing work
19:42:57 <MrsB> #info there will be a call for volunteers (not just drak tools but everything dev-ish)
19:42:59 <ennael> thanks guys :)
19:43:07 <ennael> and girls
19:43:14 <Kernewes> ennael: yw
19:43:20 <MrsB> thankyou ennael :)
19:43:28 <DavidWHodgins> Thank you too ennael, and tmb.
19:43:41 <MrsB> It was very much a team effort
19:43:44 <dvg> +1 on all of that
19:43:49 <Kernewes> I've really enjoying being part of it
19:43:57 <DavidWHodgins> Took a while, but the matches finally had some effect. :-)
19:44:02 <ennael> :)
19:44:04 <MrsB> :D
19:44:10 * Mag2_Led43 wishes he had done a lot more
19:44:16 <Kernewes> I haven't done much, but I can really say that Mageia is MY operating system
19:44:19 <Kernewes> thanks everyone
19:44:23 <MrsB> your time is now Mag2_Led43 :)
19:45:03 <Kernewes> ennael: did I read something about MATE for Mga4?
19:45:12 <ennael> no ! :)
19:45:17 <MrsB> So, let's not forget we did a good job, what DID work well?
19:45:20 <Mag2_Led43> feeling a little stronger today
19:45:34 <Kernewes> good leadership
19:45:44 <Kernewes> team and project
19:46:02 <lewyssmith> Communication
19:46:05 <DavidWHodgins> Really makes a big difference having a separate computer, that can always be on irc, the pad, bugzilla, etc.
19:46:29 <Kernewes> yeah I was doing that some of the time
19:46:35 * Mag2_Led43 second the spare pc on irc
19:46:42 <MrsB> what about our system with the pad, bugzilla, the ML etc?
19:47:16 <lewyssmith> They work fine, but you have to repeat the same thing 3 times sometimes
19:47:19 <DavidWHodgins> I think that went fairly well, except the last day, where the mailing list pretty much got ignored, as we were too busy testing the final images.
19:47:45 <Kernewes> is there a way to search bugzilla for the most recently added bugs?
19:47:53 <DavidWHodgins> Only used irc for the last images.
19:47:54 <Kernewes> would be easier than searching by words
19:48:00 <MrsB> #info it would be nice if we could integrate pad/bugzilla/ml somehow
19:48:10 <lewyssmith> Thanks
19:48:10 <dvg> subscribe to bugs
19:48:15 * Mag2_Led43 still having pad probs, havingto repeat what i have typed
19:48:23 <Kernewes> MrsB: would that quadruple the number of e-mails?
19:48:38 <dvg> depends how many you get now :)
19:48:48 <DavidWHodgins> I copy/paste between the pad, bugzilla, and mailing list, to a point.
19:48:51 <wilcal> You can browse all the bugs by latest. I do that
19:48:54 <Kernewes> dvg: my inbox is full of QA ones
19:48:54 <MrsB> I'm thinking there may be some web package which would help
19:49:00 <Kernewes> wilcal: thanks
19:49:11 <dvg> filter to folder is your help
19:49:24 <dvg> never a full inbox
19:49:40 <Kernewes> dvg: you still have to go through all the folders
19:49:58 <dvg> as far as needed
19:50:01 <MrsB> #info is there some web package which could help collaboration, tie in bugzilla/pad comments and make an easy to read report?
19:50:26 <Kernewes> dvg: I mean you still have to look at zillions of e-mails and decide which ones to delete
19:50:52 <dvg> Kernewes: yes but that does not have to be done today
19:51:04 <lewyssmith> That is quick to do
19:51:31 <Kernewes> not when you've got four other e-mail accounts besides your Mageia one :)
19:51:36 <dvg> i get sometimes 2,000 per day. dont believe i ever read them all
19:51:48 <Kernewes> 2,000 !!!!!!
19:52:03 <MrsB> I think one thing we did do well is to work together as a team, and also as part of a larger team
19:52:17 <Kernewes> agreed
19:52:37 <dvg> package commits (for reference), all bugs, dev, qa, doc, various packages etc. and some unrelated interests
19:53:15 <MrsB> lewis mentioned communication and that is important. It involves the pad/bugzilla again but I don't think at any point we lost track
19:53:32 <DavidWHodgins> And the errata, which I forgot to update till after release.
19:54:49 <DavidWHodgins> Anyone updating the errata, please send a message to the i18n-discuss.ml.mageia list, so translators know which sections have been changed.
19:55:03 <DavidWHodgins> #info Anyone updating the errata, please send a message to the i18n-discuss.ml.mageia list, so translators know which sections have been changed.
19:56:28 <DavidWHodgins> One way we might be able to reduce the iso images, would be to modify the live isos to work more like the classical installer.  Would make those images bigger, but would eliminate the need for the x86_64 and i586 dvd iso images.
19:56:56 <MrsB> #info Could everybody have a think on what we did do well and what could be improved for next time. Anything with an idea to make it better is good. You can either let me know your thoughts and I will add them to the wiki or add them yourself, please add your nick beside your comment too if you do.
19:57:18 <wilcal> 3 -> 5 day freeze before release
19:57:25 <MrsB> https://wiki.mageia.org/en/Mageia3_Postmortem#QA
19:58:01 <Kernewes> keep the same leadership, that's what I say
19:58:02 <MrsB> #info Is there a way to reduce the number of ISO images further?
19:58:21 <Mag2_Led43> Kernewes: second that
19:58:23 <DavidWHodgins> wilcal: If the first build was all that was needed, that would work, but doesn't work when there are still release critical bugs.
19:59:03 <wilcal> After release critical bugs are solved
19:59:17 <dvg> radical, but skip the CDs?
19:59:24 <Kernewes> NO
19:59:39 <Kernewes> they're quicker to download and to install
19:59:57 <lewyssmith> But not a lot of use in France etc
20:00:03 <DavidWHodgins> The cds are what magazines tend to distribute, as far as I understand.
20:00:13 <wilcal> I like the Live-CD's to check unknown platforms ( old ones )
20:00:15 <Kernewes> DavidWHodgins: thought they did DVDs
20:00:17 <dvg> if we have DVD, it just adds to the number no?
20:00:21 <Mag2_Led43> still a lot of people around the world on dial up speeds so keep some cd's
20:00:25 <Kernewes> yeah we still need live media
20:00:29 <MrsB> I think that was the reason for keeping them yes, and they are useful for events etc
20:00:42 <Kernewes> wilcal: seconded
20:00:43 <dvg> ok, i can live with them
20:00:52 <lewyssmith> And test them!
20:01:14 <MrsB> we have to be here to provide the needs of our community
20:01:25 <lewyssmith> I knwo, I know...
20:02:15 <MrsB> we do need that community to step up ad get more involved though
20:02:31 <lewyssmith> But it does raise something I have mentioned before: people testing certain variants
20:02:48 <MrsB> yep, It's alot of work
20:02:54 <lewyssmith> rather than trying to do them all
20:02:57 <Kernewes> lewyssmith: trouble is, some of us can't be sure when we'll be available
20:03:08 <MrsB> It would be helped by some sutomated testing of the isos before they reach us though
20:03:27 <lewyssmith> Kernewes: Agreed, but changes nothing.
20:03:55 <Kernewes> lewyssmith: exactly, that alone isn't the answer
20:03:59 <DavidWHodgins> I have a fast enough system, I'll always try all of the iso images, but I don't expect everyone else to.
20:04:11 <dvg> and auto-tetsing needs time and effort and take the consequences from the results
20:04:20 * MrsB admires Daves whizzy new computer
20:04:27 <wilcal> You use UBS ISO images right David
20:04:31 <wilcal> USB
20:04:41 <Kernewes> so do I now
20:04:49 <DavidWHodgins> Mostly.  Sometimes boot from the iso on the ssd drive.
20:04:55 <wilcal> Not quite exactly the same but almost
20:05:09 * Mag2_Led43 will lurk in #mageia and try and russel up new mageian's to volunteer giving priority to qa, dev packageing and doc departments
20:05:17 <MrsB> \o/
20:05:18 <DavidWHodgins> The ssd drive is a lot faster than the usb stick.
20:05:24 <lewyssmith> Is USB faster than DVD?
20:05:31 <DavidWHodgins> Yes.
20:05:34 <wilcal> I've a pile of about a dozen USB drives with ISO's on them
20:05:39 <dvg> and no burn time
20:05:44 <wilcal> Yes
20:05:45 <DavidWHodgins> I don't have any optical drive in this system.
20:05:51 <Kernewes> it saves wasting CDs or DVDs you can't reuse
20:06:01 <MrsB> It takes me 15-20 mins still to dump onto usb
20:06:02 <dvg> i reuse them forever
20:06:08 <DavidWHodgins> Still takes several minutes to copy an iso to a usb stick.
20:06:13 <MrsB> the big dvd images anyway
20:06:19 <Kernewes> dvg: thought rewritable ones didn't work
20:06:24 <dvg> sure
20:06:25 <wilcal> dd if=/home/wilcal/databank/distros/mageia_3/Mageia-3-dual-CD/Mageia-3-dual-CD.iso of=/dev/sdb bs=1M
20:06:44 <lewyssmith> Kernewes: They do
20:06:52 <DavidWHodgins> Kernewes: They tend to wear out, but do work well, until they wear out.
20:07:15 <Kernewes> oh well, I'm happy with USBs now but that's interesting to know, thanks
20:07:27 * mga3gazer likes to copy the install .iso to a separate partition on the disk and use the boot.iso on stick or CD to do the install from hard drive
20:07:35 * Mag2_Led43 has some 10 year old rewritable dvd disks that are just starting to fail
20:07:36 <MrsB> There are no plans to make dorsync burn onto dvd :P
20:07:38 <Kernewes> USBs don't last for ever either
20:07:53 <lewyssmith> Should write DVDs *slowly*
20:08:04 <Kernewes> yeah, that's true
20:08:08 <dvg> always use highest speed available
20:08:09 <MrsB> not too slowly though
20:08:18 <lewyssmith> I have had 2 USB stick failures after short lives
20:08:19 <Kernewes> dvg: highest?
20:08:21 <MrsB> too slow can be as bad as too fast
20:08:27 <DavidWHodgins> Mag2_Led43: When I was using rw dvds, they tended to wear out after a few dozen rewrites, even though done at the slowest speed.
20:08:28 <lewyssmith> 2.4 x
20:08:40 <MrsB> wrw105: hi!
20:08:55 <DavidWHodgins> lewyssmith: Try putting the stick in a freezer for 10-20 minutes.
20:09:05 <lewyssmith> True?
20:09:10 <Kernewes> really?
20:09:12 <wilcal> Potentially you can fix a bad USB drive with https://www.grc.com/sr/spinrite.htm
20:09:14 <[mbot> [ GRC | Hard drive data recovery software ]
20:09:15 <DavidWHodgins> I've kept my 16GB stick working by doing that.
20:09:30 <MrsB> wrw105: hi!
20:09:33 <MrsB> again
20:09:36 <wrw105> Hi, MrsB!
20:09:42 <MrsB> sorry i missed you earlier
20:09:44 <Mag2_Led43> DavidWHodgins: depends on their quality, i buaght some cheap asda ones just before m3 testing and most of the ones i have used are failing
20:10:06 <MrsB> Shall we move on then?
20:10:08 <wrw105> No biggie...it was probably a better question for luigi anyway, after looking at the bug....
20:10:11 <wilcal> Yes
20:10:14 <MrsB> Has everybody had their say for now? Please speak up if you have any thought to add now.
20:10:57 <DavidWHodgins> #topic Getting ready for update candidates.
20:11:01 <MrsB> We have until early June to update the post mortem page on the wiki so we can atke a week to think/research and talk again next time
20:11:18 <MrsB> Ahaa yes, thanks Dave
20:11:36 <MrsB> So, now our major task is going to be testing update candidates
20:11:59 <MrsB> #info we need to move on to testing update candidates for mga2 and mga3
20:12:19 <MrsB> pretty soon (like tomorrow) we will be inundated with updates
20:12:28 <lewyssmith> The wiki is helpful here
20:12:30 <DavidWHodgins> I've setup 4 vb guests and 4 real hardware install, other than my day-to-day system, for testing updates.  Both arches, both Magiea 2 and 3.
20:12:36 <wilcal> OK are the repo's gonna be moving?
20:12:49 <MrsB> packagers have been twiddling their thumbs for a week or so and have a backlog of updates for us
20:13:23 <MrsB> It's alot of work and is our main task really
20:13:48 <MrsB> if we got paid, this is what would pay the bills
20:14:04 <DavidWHodgins> The repos have opened.  There have been 147 packages submitted so far.  Most are for cauldon, but quite a few are for Mageia 3.
20:14:14 <MrsB> yep
20:14:15 <Mag2_Led43> if Im strong enough over the weekend i will set up 2x 32bit boxe, 1 for each mag version
20:14:15 <DavidWHodgins> Like firefox and tb.
20:14:34 <MrsB> There is always a link to the howto pages in the topic in this channel
20:14:51 <DavidWHodgins> Mag2_Led43: Can you get someone to help you?  Not a good idea to over-strain yourself.
20:14:55 <MrsB> (apart from now because Inigo_Montoya`changed it)
20:15:32 <Mag2_Led43> DavidWHodgins: feeling stronger today, new meds maybe helping
20:15:40 <wrw105> Have the ff/tb updates landed for 3 yet?  I looked a few hours ago, but nothing yet then.
20:15:45 <MrsB> https://wiki.mageia.org/en/QA_process_for_validating_updates shows the process we use as we test updates
20:16:15 <DavidWHodgins> wrw105: They are currently building.
20:16:25 <MrsB> http://mageia.madb.org/tools/updates shows update candidates waiting for us to validate them
20:16:27 <[mbot> [ Mageia App Db ]
20:16:45 <wrw105> Thanks David!
20:16:47 <DavidWHodgins> http://pkgsubmit.mageia.org shows the current build system status.
20:16:49 <[mbot> [ Build system status ]
20:16:55 <MrsB> #info if you want somebody to hold your hand as you get started testing updates we can do that
20:17:52 <MrsB> #info actually testing helps to make sense of the process so it's best to get stuck in but always ask for help or somebody to check if you're not sure of anything
20:18:18 <MrsB> #irc is a good place to get quick answers or the mailing list if you prefer
20:18:20 <MrsB> oops
20:18:28 <MrsB> #info irc is a good place to get quick answers or the mailing list if you prefer
20:18:46 <DavidWHodgins> I'm now using my old computer for irc, which I don't use for testing, so should be around a lot more, than I used to be.
20:19:07 <MrsB> #info on IRC somebody can be there with you and guide you as you do your first few updates
20:19:13 <wilcal> Which mageia IRC channel is the most active
20:19:36 <MrsB> in general or for us?
20:19:42 <wilcal> in general
20:19:49 <DavidWHodgins> Proably mageia-social, but I don't follow that channel. Next would be the mageia channel.
20:19:59 <Mag2_Led43> wilcal: use the qa channel  incase there is a lot of traffick on mageia
20:20:13 <wilcal> k
20:20:38 <Mag2_Led43> DavidWHodgins: mag-social has gone very quite over the last month or so
20:20:41 <MrsB> Does everybody have sufficient information to at least know where to begin?
20:20:49 <MrsB> guys please..
20:20:50 <wilcal> yep
20:20:54 <Mag2_Led43> yep
20:21:01 <spiky_> I think so thks
20:21:07 <MrsB> everybody going to have a good go at it?
20:21:16 <spiky_> I will be asking for advice tho
20:21:21 <lewyssmith> Me too
20:21:27 <MrsB> Anybody want some mentoring on IRC?
20:21:28 <wilcal> I got my name on some of that stuff
20:21:38 <DavidWHodgins> While I'm just as guilty as others, I think we should try to keep general chit-chat to a minimum, in this channel.  Keep it in other channels or pm windows.
20:21:49 * Mag2_Led43 definatly if health permoits, it will keep my mind off of my other troubles ;-)
20:21:58 <MrsB> general chit chat is fine, just not in the middle of the meeting :P
20:22:27 <DavidWHodgins> Ok. :-)
20:22:33 * Mag2_Led43 will need some irc mentoring, but once back up to speed will pass on that knowledge
20:22:54 <MrsB> #info Please, I mean this, please never be affraid to ask questions. There really is no such thing as a stupid question.
20:23:36 <MrsB> #info Mag2_Led43 would like some mentoring
20:24:18 <MrsB> Anybody anything they'd like to ask right now?
20:24:40 <lewyssmith> It would be useful to know time differences. Can everyone on-line now say what their time is?
20:24:45 <lewyssmith> Me 22.24
20:24:51 <Mag2_Led43> never be imbarist asking a question, it will be very embarising if you pass an update and it breaks lots of users system
20:24:53 <wilcal> 13:24
20:24:56 <spiky_> 21:24
20:24:56 <wrw105> 16:24
20:25:04 <Mag2_Led43> 21:25
20:25:04 <dvg> UTC 20:25
20:25:10 <MrsB> 21:25
20:25:12 <DavidWHodgins> It's 1625 here too.
20:25:12 <Kernewes> 21.28 but it was 2 mins fast before I installed Mga3
20:25:17 <Kernewes> so it still might be
20:25:33 <MrsB> You'll tend to find Dave and Myself are on at opposite times
20:25:35 <dvg> use ntpdate
20:25:36 <Mag2_Led43> Kernewes: install ntp
20:25:48 <Kernewes> what does that do?
20:25:54 <MrsB> Luigi12 is also more Dave's timezone
20:26:11 <MrsB> isn't he the same TZ Dave?
20:26:16 <Mag2_Led43> network time protocol, it asks an atomic clock for correct time
20:26:19 <mga3gazer> Network Time Protocol synchronizes the compyter's clock for accurate time
20:26:22 <Kernewes> Mag2_Led43: ok, thanks
20:26:24 <DavidWHodgins> I'm in North America's eastern time zone, but don't usually get online till 1 or 2 pm.
20:26:28 <Mag2_Led43> and sets system to it
20:27:12 <lewyssmith> 2 main groups: evening now & after noon now
20:27:22 <MrsB> I'm here mostly during the EU daytime, not so much evenings & weekends
20:27:42 <Kernewes> I'm only here evenings and weekends, and then not every day
20:27:43 <mga3gazer> systemctl status ntpd.service  # check status of ntp on your machine
20:27:50 <DavidWHodgins> MrsB: is usually just about ready to logoff, when I logon.
20:28:17 <MrsB> #info good people to ask are Myself, DavidWHodgins or Luigi12, among others
20:28:34 <dvg> hm thought it ewas always morning with her?
20:28:45 <MrsB> tiz
20:28:54 <lewyssmith> If one of you is normally on-line, then
20:28:55 <DavidWHodgins> qa meetings always start in the morning, and end at night. :-)
20:28:55 <MrsB> morning dvg
20:29:11 <mga3gazer> qa never stops
20:29:21 <dvg> MrsB: hello :)
20:29:26 <MrsB> :D
20:30:05 <MrsB> action MrsB to start sending the Easy Bugs email to qa-discuss again
20:30:09 <MrsB> oops
20:30:16 <MrsB> #action MrsB to start sending the Easy Bugs email to qa-discuss again
20:30:50 <Mag2_Led43> good idea
20:30:50 <MrsB> So is everybody happy they can have a go?
20:31:00 <dvg> not sure
20:31:10 <dvg> i only have cauldron machines
20:31:12 <Mag2_Led43> yep
20:31:17 <dvg> and little free time
20:31:22 <MrsB> dvg you can run VM's
20:31:23 <lewyssmith> I'll try most things once
20:31:24 <dvg> till late next year
20:31:37 <MrsB> lewyssmith: more than once ;)
20:31:52 <MrsB> We really need people to stick at this
20:32:06 <dvg> how does one say: that's not my cup of tea? (though i do not use tea)
20:32:15 <MrsB> It's the less glamorous but much more varied task we have to do
20:32:42 <lewyssmith> dvg: quite correct
20:32:48 <Mag2_Led43> you can learn a lot about how software works under the bonnet so to speak (thats under the hood for our american testers)
20:32:58 <MrsB> yep
20:33:34 <MrsB> It will be challenging and interesting and you will learn a ton of stuff about a ton of stuff
20:33:40 <DavidWHodgins> brb
20:34:07 <MrsB> Anybody any questions so far?
20:34:17 <wilcal> Good to go here
20:34:23 <dvg> since i started using Linux (Mdk/Mdv) I learned a lot and hope to learn more & contributed some,
20:34:35 <dvg> but im not sure about this sorry
20:34:36 <Mag2_Led43> not here
20:34:50 <dvg> for now
20:35:25 <DavidWHodgins> back from phone call.
20:35:35 <MrsB> If we're all happy then let's do the roundup
20:35:42 <wilcal> Phone???? 19th Century technology
20:35:48 <DavidWHodgins> #topic Luigi's Roundup.
20:35:49 <dvg> 18th
20:36:09 <MrsB> i made some notes..
20:36:42 <MrsB> Luigi12 is at a track meeting today, part of a regional championship so won't be here
20:36:51 <MrsB> but he told me what is coming soon
20:37:16 <MrsB> #info <Luigi12_lappy> if you're curious, the ones queued up (not all by me) are mediawiki, nginx, krb5, owncloud, openswan, ruby, firefox, thunderbird, wireshark, and moodle.  Funda might have something too.
20:37:34 <wilcal> more ruby stuff
20:37:43 * Mag2_Led43 grabs a snorkel and awaits the deluge
20:37:51 <MrsB> yep, hopefully this will actually work though in mga3
20:38:09 <MrsB> as you can see there is a bit of a queue already
20:38:25 <DavidWHodgins> krb5 I have scripts for (on our wiki), and can test that in a few minutes per release/arch.
20:38:27 <Kernewes> thought we hadn't sorted out the last ruby one
20:38:33 <wilcal> So by Monday all of this will be turned loose
20:38:41 <MrsB> none of these are too difficult to test though so it'll be a busy but not so testing start
20:39:00 <MrsB> these are on their way to updates_testing as we speak
20:39:13 <MrsB> we have to get them validated and pushed as updates asap
20:39:17 <wilcal> in M2 & M3
20:39:21 <MrsB> yep
20:39:27 <MrsB> in i586 & x86_64
20:40:17 <MrsB> Anybody want to add anything?
20:40:32 <wrw105> Firefox and thunderbird are good to go in M2, just waiting on the builds for M3 to validate.
20:40:32 * Mag2_Led43 is a bit short of 64bit boxes at moment :(
20:41:06 <MrsB> #info things have to be pushed in mga3 either before mga2 or at the same time to ensure an upgrade path exists
20:41:26 <MrsB> thanks for the reminder wrw105
20:41:45 <wrw105> np MrsB--that was actually my question from this morning!
20:41:47 <MrsB> I'm not sure if it mentions that on the wiki page
20:42:34 <MrsB> ok then let's move on
20:42:37 <DavidWHodgins> #topic Anything Else?
20:42:41 <MrsB> thanks :)
20:42:49 <MrsB> Is there anything else?
20:42:57 <wilcal> Here's a good one for MrsB
20:43:00 <wilcal> FWIW QA Handbooks tend to be one of those things that are proposed
20:43:00 <wilcal> when a Company is fat and happy and one of the first things to go
20:43:00 <wilcal> when there's a budget crunch.
20:43:11 <MrsB> lol
20:43:21 <wilcal> That's my experiance over the years
20:43:40 <Kernewes> but we're free from the shackles of a company's fortunes now
20:43:50 <DavidWHodgins> We have the same effect as a budget crunch, all of the time, due to lack of people.
20:43:57 <wilcal> Ya but we have no real budget to begin with
20:44:13 <MrsB> only bodies to do the work
20:44:26 <wilcal> Yep
20:44:32 <DavidWHodgins> Our budget is effectively the time and skills of all of the volunteers.
20:44:51 <wilcal> David you gonna be around after the meeting?
20:44:58 <DavidWHodgins> Yes.
20:45:10 <wilcal> Thanks
20:45:12 <Mag2_Led43> and skills  can be learned, the big limiter is time
20:45:41 <Kernewes> trouble is, if it takes time to learn the skills it doesn't leave any time to do the work :(
20:45:43 <DavidWHodgins> And sometimes, the motivation. :-)
20:46:06 <MrsB> that's part of the reason we don't have enough documetation too
20:46:13 <MrsB> both reasons
20:46:15 <DavidWHodgins> Or health issues can get in the way.
20:46:24 <Kernewes> too true
20:46:41 <Mag2_Led43> yep
20:47:48 <MrsB> Is there anything else?
20:47:54 <DavidWHodgins> Not here.
20:47:58 <wilcal> Not from me
20:48:00 <MrsB> if not we'll wrap it up
20:48:05 <Mag2_Led43> nor me
20:48:30 <MrsB> Thankyou all for being here, please do get involved with testing update candidates and never be shy to ask a question
20:48:41 <MrsB> Same time next week!
20:48:46 <MrsB> #endmeeting