19:09:41 <MrsB> #startmeeting
19:09:41 <Inigo_Montoya`> Meeting started Thu May  9 19:09:41 2013 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:09:41 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:09:55 <MrsB> Morning all, welcome to another meet
19:10:01 <MrsB> #chair DavidWHodgins
19:10:01 <Inigo_Montoya`> Current chairs: DavidWHodgins MrsB
19:10:03 <DavidWHodgins> #topic Who's new?
19:10:26 <MrsB> Is there anybody new today?
19:10:46 * mga3RCgazer attending firt meet
19:10:56 <MrsB> wow, welcome mga3RCgazer
19:11:08 <mga3RCgazer> tnx
19:11:09 <MrsB> aka tree/path/wikigazer :D
19:11:25 <DavidWHodgins> Welcome mga3RCgazer
19:11:25 <mga3RCgazer> :-)
19:11:37 <mga3RCgazer> tnx DavidWHodgins
19:11:50 <DavidWHodgins> Tell us a bit about yourself.  I'm Dave Hodgins from London, Ontario, Canada.
19:11:53 <MrsB> Some won't know you, can you introduce yourself and the others will do the same
19:12:17 <MrsB> I'm claire, from midlands UK
19:12:25 <mga3RCgazer> Good morning everone. Thanks for welcoming me
19:12:29 <rindolf> mga3RCgazer: welcome.
19:12:43 <wrw105> Bill Wilkinson from outside Johnstown, Pennsylvania, USA
19:12:44 <rindolf> I am Shlomi from Tel Aviv, Israel.
19:12:59 <sebsebseb> hi
19:13:01 <wilcal> Wilcal here ( Bill Kenney ) from Surf City USA, San Diego California
19:13:34 <lewyssmith> I'm Lewis, a Cymro Cymraeg living in France
19:13:39 <MrsB> hi sebsebseb, just doing introductions, your turn :P
19:14:38 * mga3RCgazer is a long time unix person, started with porting AT&TsystemV to 386 in the 80's. Working in computer security and using Linux about 13 years. Most of those with Mandrake/Mandriva/Mageia. I live in UK
19:15:09 <MrsB> \o/
19:15:12 <wilcal> Ahhh the days of Mandrake
19:15:34 <rindolf> mga3RCgazer: nice!
19:15:43 <lewyssmith> Interesting. I worked on SVR4 when it started on Intel h/w as well as sparc
19:16:53 <MrsB> you two should have stuff to talk about!
19:17:03 <MrsB> Led43__Mag1: here too?
19:17:08 <mga3RCgazer> ICL? :-)
19:17:12 <lewyssmith> Yes!
19:17:20 <mga3RCgazer> It Cant Last...
19:17:21 <sebsebseb> I am Sebastian from Enlgand, done a bit of testing, but not that prperly, but  ISO testing soon :)
19:17:23 <sebsebseb> for the final ISO's
19:17:34 <sebsebseb> :)
19:17:38 <mga3RCgazer> lewyssmith: I was at BRA01
19:17:47 <Led43__Mag1> lurking at back of room
19:17:55 * sebsebseb should probably go in the QA credits, once he has actsauly done some proper QA ISO testing of the final ISO's :D  or  around then
19:17:58 <MrsB> stop lurking, say hello :P
19:18:17 <lewyssmith> mga3RCgazer: I was a 'pregnant programmer', but we were based at BRA01
19:18:24 * sebsebseb will be testing on three computer's that's the plan!
19:18:26 <mga3RCgazer> hi-5!
19:18:42 <Led43__Mag1> on phone
19:19:03 <MrsB> nice, so the gang is all here :)
19:19:09 <DavidWHodgins> #topic Upgrades - How are they, anything to block release?
19:19:18 <MrsB> welcome all, we're about to hit hell week so it's all hands on deck
19:19:40 <wilcal> I'm pretty confident of m3
19:20:00 <DavidWHodgins> mgaapplet is still not installing the prepare-upgrade package, still not enabling nonfree, and still failing to open the rpm db after the first transaction.
19:20:02 <MrsB> you've had some issues haven't you wilcal? I've not managed to follow them closely
19:20:14 <MrsB> add an info Dave
19:20:16 <wilcal> I am not confident on the testing I'm doing
19:20:27 <lewyssmith> You will have seen that I have had no joy with upgrading, but await the next ISOs.
19:20:30 <DavidWHodgins> #info mgaapplet is still not installing the prepare-upgrade package, still not enabling nonfree, and still failing to open the rpm db after the first transaction.
19:20:31 <wilcal> at least as far as the boot.iso upgrade path
19:20:57 <MrsB> alot has changed since RC so you may find things have improved lewyssmith
19:20:58 <wilcal> I've I use the Classical Installer that upgrades just fine
19:21:25 <lewyssmith> My problems *may* be SiS video related.
19:21:31 <wilcal> My problems my be isolated to just the boot.iso upgrade path?
19:21:42 <MrsB> Anybody can add #info's btw
19:21:49 <wilcal> Everything is here:
19:21:50 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=9819
19:21:52 <[mbot> Bug 9819: normal, release_blocker, bugsquad, bugsquad, NEW , Attempt to upgrade from M2 -> M3 cauldron fails
19:22:06 <lewyssmith> What id this 'boot.iso' much referred to?
19:22:16 <DavidWHodgins> Using the boot.iso should get all of the latest updates, so should be working the best.
19:22:33 <MrsB> #info lewyssmith has issues with SiS video in RC but may be resolved in final - to test again
19:22:41 <wilcal> I've always used boot.iso for installs and always to a blank drive
19:22:43 <rindolf> MrsB: do you want me to try upgrading some Mageia 2 VMs to Mag3?
19:22:51 <MrsB> by all means rindolf
19:23:11 <DavidWHodgins> lewyssmith: boot.iso is used for installing all of the packages from a mirror, rather then from a dvd
19:23:14 <rindolf> MrsB: OK.
19:23:16 <lewyssmith> I do not recall it from the usual media rsync choice
19:23:22 <wilcal> I would suggest upgrading from everything you can
19:23:32 <MrsB> It isn't, you're right
19:23:43 <wilcal> David what path would most people upgrade from
19:23:53 <MrsB> It's essential a network installer for current cauldron
19:23:55 <rindolf> MrsB: OK, will do.
19:24:11 <MrsB> You can find them in under cauldron on mirros
19:24:14 <MrsB> mirrors
19:24:18 <MrsB> eg.
19:24:22 <DavidWHodgins> I expect most will use mgaapplet, when it notifies them there is an upgrade available
19:24:34 <wilcal> I don't think there's a problem with my local repo as m3 installs, and updates just fine from that
19:24:41 <DavidWHodgins> lewyssmith: https://wiki.mageia.org/en/Installation_Media#Network_Installs
19:25:08 <lewyssmith> But surely it is important to test the ISOs?
19:25:18 <MrsB> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/cauldron/i586/install/images/
19:25:19 <[mbot> [ Index of /pub/linux/Mageia/distrib/cauldron/i586/install/images ]
19:25:22 <DavidWHodgins> Yes.  All methods have to be tested
19:25:28 <wilcal> Yes, I think most users will update from the ISO(s)
19:25:52 <wilcal> Should you be able to upgrade from like the KDE Live-CD?
19:26:09 <MrsB> The ISOs are a snapshot of cauldron. After they are released the most current test is going to be with boot.iso or boot-nonfree.iso
19:26:18 <lewyssmith> wilcal: Not from the live media
19:26:27 <DavidWHodgins> No. the Live iso images are not useable for upgrading.  They overwrite the installation, rather then upgrade it.
19:26:39 <wilcal> MANY THANKS!!! lew that didn't work for me
19:26:50 <wilcal> Super whew!
19:27:02 <MrsB> They shouldn't really offer it
19:27:10 <MrsB> it's probably a bug if they still do
19:27:12 <wilcal> But the Classical Installer for sure
19:27:32 <lewyssmith> For the post-mortem: do NOT mix install & upgrade (ex Fedora)
19:27:36 <DavidWHodgins> We have to test upgrading using the i586 and x86_64 dvd iso images, as well as mgaapplet, and network installs.
19:28:07 * sebsebseb tested his  broken package manager install of Mageia 2 the other week, upgrading that to the RC using the classical installer DVD, on netbook, external CD/DVD drive
19:28:10 <sebsebseb> anyway that went quite well
19:28:11 <sebsebseb> took ages
19:28:16 <DavidWHodgins> mgaapplet is the most likely to have problems, as it's upgrading a running system.
19:28:23 <sebsebseb> ,but went quite well,  same issues  as in broken package manager like before, but yeah
19:29:03 <wilcal> I only have problems with the network upgrade ( boot.iso )
19:29:10 <sebsebseb> hi velus :)
19:29:16 <sebsebseb> he might join us later on in QA, but here to watch :D
19:29:26 <MrsB> morning velus :)
19:29:27 <DavidWHodgins> wilcal: That's the opposite of what I would expect.
19:29:37 <wilcal> Ya, I don't understand
19:29:58 <wilcal> I keep put'n the reports in 9819
19:30:40 <DavidWHodgins> One thing about cauldron, is if you are testing a network install while packages are being pushed, in between the package being selected, and it being downloaded, it can be removed when a new version is pushed.
19:30:49 * Led43__Mag1 has 2x 32bit m2 boxes +1 64bit vm to test upgrades on if health allows
19:31:09 <wilcal> FWIW my last real job 2-years ago ( now retired ) we were NEVER allowed to upgrade a Mandrake/Mandriva install
19:31:46 <DavidWHodgins> I've been using, or at least testing upgrading since Mandriva 2009.1
19:32:13 <wilcal> The few times I've done it before all this it went just fine
19:32:49 <DavidWHodgins> I'm holding off further testing of upgrading using the dvds, as the new iso images should include a lot of fixes since the rc.
19:33:10 <lewyssmith> Me too
19:33:16 <wilcal> Should they be ready on Tue the 13th?
19:33:19 <sebsebseb> yep sme here
19:33:20 <lewyssmith> Install ditto
19:33:21 <sebsebseb> I am waiting for new IOS's
19:33:23 <MrsB> We don't have long to wait..
19:33:24 <sebsebseb> ISO's
19:33:40 <sebsebseb> MrsB: yeah the 11th I thought it was ?
19:33:42 <sebsebseb> so soon in that case
19:34:02 <MrsB> they're expected on 11th but tmb was building some test live isos today
19:34:04 <wilcal> Cauldron will also see changes
19:34:19 <sebsebseb> velus: you could help us test Mageia 3 in a way early to, but right you should probably run the normal one first etc etc :d
19:34:40 <velus> yeha
19:34:46 <velus> and i can help with the website
19:34:52 <sebsebseb> yep :)
19:34:56 <lewyssmith> What is the difference between Cauldron & Mageia3 ?
19:34:58 <wilcal> Just 2-hours ago I updated both my 32&64-bit m3 platforms and that went just fine
19:35:03 <sebsebseb> lewyssmith: good question
19:35:09 <sebsebseb> lewyssmith: Cauldron is the packagers play ground
19:35:16 <sebsebseb> they base the ISO's on Cauldron
19:35:29 <sebsebseb> if you get the updates into say the RC you or alpha or beta you run Cauldron basically
19:35:44 <MrsB> cauldron is a dev branch, alpha/beta/rc and even final are snapshots of the current cauldron. When 3 is released cauldron is branched to make new repositories for 3
19:36:10 <DavidWHodgins> lewyssmith: When the cauldron repos are frozen, they will become mageia 3.  Some time after that, a new cauldron will open for Mageia 4.
19:36:28 <sebsebseb> yep thought MrsB would say something to that to :d  ,but yes what she put basically,  also if you install from th RC,  you'll still be runnign  Cauldron when doing updates even when the final is out, unless you change the repo's to the normal ones
19:36:33 <wilcal> In the words of doktor5000:
19:36:33 <wilcal> Cauldron is not for the faint of heart!
19:36:33 <wilcal> Caution: Hot, bubbling magic inside. May explode or cook your kittens!
19:36:37 <lewyssmith> So Cauldron is like other people's Testing repo?
19:36:49 <sebsebseb> lewyssmith: it's what the packagers put their stuff into
19:37:05 <DavidWHodgins> It's where the developers create the packages, before they get tested.
19:37:06 <sebsebseb> well for the version that's in development
19:37:07 <mga3RCgazer> Cauldron is the developemt version, right?
19:37:13 <sebsebseb> yes
19:37:21 <wilcal> Right now Cauldron is pretty stable, but after m3 is released it will get crazy
19:37:58 <lewyssmith> Shouldn't people then concentrate on fixing Mag3?
19:38:02 <MrsB> so lets move on
19:38:09 <DavidWHodgins> #topic ISO testing - Last chance to ask questions before they're here
19:38:30 <MrsB> Is everybody happy they know what they're doing?
19:38:37 <wilcal> My question was going to be upgrade from the Live Media
19:38:53 <MrsB> #info live medias should not be used for upgrades
19:38:59 <lewyssmith> shalll we be informed when they are available for download with rsync?
19:39:29 <MrsB> #info I have a new password to email to everybody and there will be notices on qa-discuss when isos are ready for testing
19:39:29 <wilcal> I will continue to work on the 9819 thing
19:39:40 <wilcal> k
19:39:52 <DavidWHodgins> See the note about upgrading at https://wiki.mageia.org/en/Installation_Media#Live_CD_ISO
19:40:25 <MrsB> #action MrsB to email the new rsync password after the meeting
19:40:35 <velus> brb
19:40:43 <sebsebseb> MrsB: new rsync password ok, bu the ISO's aren't here just yet I Guess ?
19:40:51 <DavidWHodgins> Correct
19:41:11 <MrsB> #info Please keep an eye on qa-discuss for announcements
19:41:44 <MrsB> #info please make good use of the pad, the link to the new pad will be in the annoncement on qa-discuss
19:41:58 <lewyssmith> When to use it?
19:42:26 <DavidWHodgins> lewyssmith: From when the iso images become available, until they are approved for release.
19:42:37 <MrsB> #info it's important to note there what you are testing as well as any bugs you've encountered. Please also create actual bug report for bugs, the pad is just for qa team and not read by devs.
19:43:22 <mga3RCgazer> should we include the MD5sum of the iso when opening a bug?
19:43:30 <lewyssmith> I find it important to confirm problems with others (where possible) before pushing them
19:43:49 <wilcal> I like to see others having the same problems I am
19:43:54 <lewyssmith> mga3RCgazer: Normally the *date*
19:44:10 <MrsB> Each ISo has a DATE.txt file. It's easier to read if you just put iso whatever it is dated whatever (whichever build)
19:44:12 <DavidWHodgins> mga3RCgazer: No.  There is a DATE.txt file with each iso, if the version of the iso has to be specified
19:44:24 <MrsB> any combination of the above
19:45:00 <dvg> if all remarks are archived and cleaned, the date is less important
19:45:04 <MrsB> #info if you encounter a serious bug which is likely to block the release please also email qa-discuss about it and CC in thomas or anne
19:45:22 <MrsB> #info thomas for live isos or anne for classic dvds and dualcd
19:46:00 <MrsB> #info Thomas is tmb@mageia.org and Anne is ennael@mageia.org
19:46:42 <MrsB> hows that?
19:46:52 <DavidWHodgins> Looks good to me.
19:47:05 <wrw105> I"m going to have to run to make dinner--I just wanted to get a big thank you to tmb for the broadcomm stuff in mga3.  It just works!
19:47:14 <DavidWHodgins> Any other questions about iso testing?
19:47:16 <MrsB> Thanks for being here wrw105
19:47:23 <wilcal> I'm cool for now
19:47:29 <lewyssmith> When should we use the mailing list while testing?
19:47:47 <mga3RCgazer> yes, kudos to thomas for fixing broadcom drivers
19:48:09 <MrsB> #info big thanks to tmb from wrw105 and all for the broadcom stuff
19:48:10 <DavidWHodgins> When a bug is found, that might be important, or if there are any questions about the testing.
19:48:39 <DavidWHodgins> If in doubt, go ahead and post to the mailing list.
19:48:47 <MrsB> #info Please never hesitate to ask if you have any questions
19:48:55 <lewyssmith> DavidWHodgins: Will it be worth me re-trying EFI?
19:49:02 <DavidWHodgins> Yes
19:49:19 <DavidWHodgins> At least yes, once the new iso images are available.
19:49:55 <lewyssmith> I raised a bug about Install not starting on my EFI system
19:50:29 <MrsB> it's still quite experimental but it's good to report bugs anyway
19:50:34 <DavidWHodgins> I'm not sure if the classical installers will have the efi support, or if that will only be for the live iso images.
19:50:59 <lewyssmith> I need to know to try: downloads take HOURS
19:51:02 <DavidWHodgins> We'll find out when the new images become available, I guess.
19:51:33 <DavidWHodgins> I download all of the iso images.  I'll let you know if the efi is in the classical installers or not.
19:51:38 <lewyssmith> I will probably concentrate on 32-bit
19:52:02 <DavidWHodgins> #topic Luigi's Roundup
19:52:15 <DavidWHodgins> As he's not here, see the mailing list messages
19:52:16 <dvg> you do rsync with the old isos, don't you?
19:52:34 <MrsB> #info Luigi went out to play today so is not here. The roundup is on the mailing list instead
19:52:49 <DavidWHodgins> dvg: Yes, instructions for renaming them prior to rsyncing will be in the mailing list
19:53:04 <MrsB> oh yes, forgot that, thanks dvg
19:53:20 <dvg> I know, but if lewyssmith takes hours I wanted to remind him
19:53:51 <DavidWHodgins> treegazer: Are you testing open-afs?
19:53:54 <MrsB> #info instructions to rename your RC isos to Final will be in the email / on qa-discuss or on the pad - or all the above
19:54:36 <MrsB> #topic Anything else?
19:54:55 <mga3RCgazer> DavidWHodgins: I am preparing to test it, yes. I have installed and configured a kerberos5 authentication server and now I have to build an OpenAFS cell
19:55:00 <velus> back sorry
19:55:09 <MrsB> sorry, jumped the gun there
19:56:09 <DavidWHodgins> mga3RCgazer: Great.  I've got the kerberos server running, and the Cell set up for my test.  Still working on the right pricnciples for afs within the kerberos server.
19:56:31 <DavidWHodgins> Close, but not quite there yet.
19:56:38 * mga3RCgazer is confident to complete OpenAFS testing. I have lost of sysadmin experience with AFS and authored the AFS faq
19:56:51 <mga3RCgazer> oopsie: s/lost/lots/
19:56:52 <DavidWHodgins> Where is that faq?
19:56:57 <MrsB> are you still planning to write a wiki page for it mga3RCgazer?
19:57:11 <mga3RCgazer> MrsB I already started the wiki page
19:57:17 <MrsB> great \o/
19:57:48 <MrsB> Is there anything else?
19:57:59 <DavidWHodgins> Nothing else here.
19:58:00 * MrsB looks at wilcal
19:58:08 <wilcal> Hold a sec
19:58:15 <wilcal> Has anyone any experiance creating a successful Samba server
19:58:15 <wilcal> out of m2/m3? That to a Windows XP/7 platform? I'm tinkering
19:58:15 <wilcal> with one for a friend and am having problems. Probably
19:58:15 <wilcal> because I don't understand how to do it.
19:58:30 <rindolf> wilcal: I have some experience with it.
19:58:30 <mga3RCgazer> DavidWHodgins: the AFS FAQ is linked from here: http://www.central.org/
19:58:31 <[mbot> [ grand.central.org ]
19:58:47 <wilcal> What do I have to do to the Win7 system
19:58:54 <MrsB> can do that after the meeting wilcal
19:58:58 <wilcal> k
19:59:02 <DavidWHodgins> wilcal: I've done that before, although it's been a while.  Need a registry edit on 7, iirc
19:59:09 <DavidWHodgins> MrsB: Yep
19:59:18 <MrsB> If there's nothing else then I'll close
19:59:28 <wilcal> thanks MrsB
19:59:29 <rindolf> MrsB: nothing else here.
19:59:33 <rindolf> Thanks, MrsB.
19:59:35 <dvg> ok
19:59:36 <MrsB> Thanks all for beign here. It'll be a long week next week, lots to do!
19:59:41 <lewyssmith> Goodnight
19:59:45 <wilcal> nite
19:59:45 <rindolf> lewyssmith: night.
19:59:48 <MrsB> Please don't give up when it gets tough
19:59:50 <mga3RCgazer> nos da
19:59:51 <dvg> nite
19:59:51 <DavidWHodgins> mga3RCgazer: Thanks, I'll look through it later.
20:00:04 <MrsB> Same time next week!
20:00:07 <MrsB> #endmeeting