19:04:41 <MrsB> #startmeeting
19:04:41 <Inigo_Montoya`> Meeting started Thu Apr  4 19:04:41 2013 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:41 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:02 <MrsB> Morning all, hope you're well! Welcome to another qa meeting :)
19:05:12 <MrsB> #chair DavidWHodgins
19:05:12 <Inigo_Montoya`> Current chairs: DavidWHodgins MrsB
19:05:14 <DavidWHodgins> #topic Who's new?
19:05:28 <MrsB> Is there anybody new today?
19:05:43 <MrsB> it doesn't look like it
19:05:47 <alfred__> not new, but back again :)
19:05:52 <MrsB> welcome back alf
19:06:08 <DavidWHodgins> #topic Beta 4
19:06:29 <MrsB> I missed beta4 testing, how did it go?
19:06:45 <lewyssmith> I have a problem with it: Installer dual-arch CD
19:06:55 <MrsB> Dave you had a number of encryption bugs didn't you?
19:07:01 <DavidWHodgins> tmb: I see push requests with a fix for bug 9326.  Does that mean live iso images will be built soon?
19:07:02 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=9326 normal, release_blocker, mageia, mageia, RESOLVED FIXED, live media: Live media contains incorrectly owned files which are copied to "installed" system, draklive
19:07:03 * tmb saved some testing for MrsB :)
19:07:16 <MrsB> hi lewis, what did you find?
19:07:17 <alfred__> tested only x86_64DVD, no pb so far
19:07:19 <MrsB> tmb :P
19:07:43 <DavidWHodgins> Yes. The diskdrake problem with encrypted filesystem on lvm still has to be fixed.
19:07:57 <lewyssmith> During post-install system update, it failed to find 'aria2 failed: exited with 3'
19:08:02 <MrsB> #info The diskdrake problem with encrypted filesystem on lvm still has to be fixed.
19:08:29 <MrsB> that usually means it can't contact the server i think lewyssmith
19:08:38 <lewyssmith> then 'problem readin synthesis file medium "Core Release Debug"
19:08:59 <lewyssmith> I Ok'd that, & install finsished. It basically worked, but
19:09:13 <DavidWHodgins> lewyssmith: That also happens if the mirror you're using resyncs in the middle of the update. Only affects cauldron, as old packages get removed.
19:09:17 <MrsB> it may have been a mirror issue
19:09:27 <lewyssmith> I could not install any useful s/w, it always asked to insert "Core Release" medium
19:09:47 <MrsB> ahh, was it looking for the disk?
19:09:56 <wilcal> FWIW the rsync script file i use updates twice back to back
19:10:01 <DavidWHodgins> The update finds packages to install, but by the time it goes to download them, they've been replaced with newer ones, so it fails to fetch them.
19:10:10 <lewyssmith> How might I progress? Re-install?
19:10:28 <MrsB> test the installation again, yep
19:10:37 <lewyssmith> Will do.
19:10:52 <tmb> So, a status update for live images...
19:10:56 <DavidWHodgins> lewyssmith: Use drakrpm-edit-media to remove all of the existing repositories, then re-add a full set of sources.
19:11:14 <lewyssmith> DavidWHodgins: how do i do the last?
19:11:15 <MrsB> tmb will have some other isos for us to test soon and our daily work needs mageia 2 anyway so test installs are only temporary
19:11:29 <DavidWHodgins> lewyssmith: I'll walk you through it after the meeting.
19:11:46 <wilcal> I'm have'n good success with the Classic Installers
19:11:46 <wilcal> with boot to desktop. Also with boot.iso/Cauldron
19:11:47 <lewyssmith> DavidWHodgins: but I do not mind re-installing
19:12:11 <tmb> I've just validated that the second fix tv did for 9326 is valid and creates the expected permissions on the isos
19:12:28 <MrsB> \o/
19:12:28 <DavidWHodgins> tmb: Great.
19:12:54 <MrsB> so aside from the encryption issue there was nothing major?
19:13:06 <wilcal> Nothing major here
19:13:19 <wilcal> we should see the live stuff soon right
19:13:28 <Kernewes> only on the dual CD if you didn't want LXDE
19:13:49 <MrsB> we need to really be picky now, check artwork integration, other desktops etc
19:13:51 <tmb> as KDE 4.10.2 is still in middle of update, I'll wait for it to finish before starting builds of isos, so you can expect new live isos tomorrow
19:14:04 <MrsB> thanks tmb
19:14:16 <MrsB> #info Live ISOs should be with us tomorrow
19:14:23 <wilcal> super
19:14:53 <MrsB> anybody anything to ask about beta testing while we're talking about it?
19:15:15 <wilcal> not from me
19:15:26 <MrsB> how about upgrade tests, any issues lately?
19:15:27 <lewyssmith> I noted your 'be really picky' ...
19:15:49 <wilcal> I had a successful upgrade on Tues
19:15:59 <Kernewes> my upgrade problem was solved
19:16:25 <wilcal> M2 32-bit -> M3 boot.iso/cauldron
19:17:00 <DavidWHodgins> I need to retest to see if the gdm/rtkit postinstall scriptlets are still blocking urpmi on upgrades.
19:17:01 <wilcal> Question....is the upgrade path used a lot
19:17:12 <DavidWHodgins> wilcal: Yes
19:17:39 <MrsB> Marja has asked if we could help with creating screenshots of an ISO which doesn't have beta4 on the artwork. ennael is going to produce one soon, if you could grab any screenshots it would help her immensely. Not just english either, if it's not your language.
19:17:54 <wilcal> Hmmm I don't think I've ever done an upgrade all the way back to 98
19:18:03 <MrsB> to grab a screenshot in the installer you can press F2
19:18:17 <Kernewes> MrsB: I just use a VM
19:18:20 <alfred__> just talked about this with marja
19:18:32 <MrsB> when the install is complete you can find them in /root/Drakx-screenshots (or similar)
19:18:39 <alfred__> will do a fresh install tomorrow in german
19:18:57 <MrsB> Not yet alfred__ as they will have beta4 on the artwork
19:19:11 <alfred__> ah ok
19:19:28 <wilcal> Artwork looks nicely integrate
19:19:28 <MrsB> ennael is going to build a special ISO to do that with which is clear of any version other than Mageia 3
19:19:29 <marja> MrsB: ennael thought she'd finish the iso tonight...
19:19:39 <MrsB> ahh there you have it, thanks marja
19:19:44 <Kernewes> MrsB: are we still using the pad for beta4 or not now it's released?
19:19:47 <marja> MrsB: but I don't know what the plans of her children are ;)
19:20:01 <DavidWHodgins> Kernewes: We'll still use it for the live iso images.
19:20:08 <MrsB> We'll use it for live ISOs Kernewes
19:20:09 <Kernewes> DavidWHodgins: thks
19:20:11 <MrsB> yep
19:20:18 <Kernewes> ok
19:20:32 <Kernewes> so anything else I notice just goes on Bugzilla?
19:20:50 <MrsB> #info please read the meeting log, marja has asked if we can produce some screenshots for her
19:20:54 <DavidWHodgins> And the qa-discuss mailing list.
19:21:17 <Kernewes> DavidWHodgins: doesn't that ml get copied in anyway?
19:21:23 <MrsB> they should go bugzilla aswell anyway really
19:21:31 <DavidWHodgins> No.
19:21:42 <Kernewes> DavidWHodgins: ah, ok
19:21:57 <Kernewes> it's only picky stuff really now
19:22:00 <MrsB> the pad is just for us to keep track of our testing, nobody other than us and anne/thomas reads it
19:22:12 <DavidWHodgins> Kernewes: You're probably thinking of the qa-bugs mailing list, which only gets copies when the bug is ready to test a fix.
19:22:26 <Kernewes> DavidWHodgins: probably
19:22:55 <MrsB> Live isos should be tested in live mode and installed please
19:23:12 <alfred__> could someone gimme the adress of pad, didnt find it
19:23:39 <MrsB> http://bn.parinux.org/p/mageia3beta4
19:23:40 <[mbot> [ Etherpad Lite ]
19:23:49 <Kernewes> MrsB: just beat me to it :)
19:24:02 <alfred__> thx Clair
19:24:27 <MrsB> I'll email everybody tomorrow when the live isos are available
19:25:04 <MrsB> anything else on iso testing or beta4?
19:25:43 <wilcal> nope
19:25:49 <Kernewes> no
19:25:56 <DavidWHodgins> #topic Automated installer testing (os-autoinst)
19:26:07 <MrsB> thanks Dave
19:26:15 <MrsB> I was hoping Glen would be here for this
19:26:16 <wilcal> lots'o discussion on this
19:26:25 <AL13N> has anyone in QA tested a cauldron netinstall recently?
19:26:47 <wilcal> I do a boot.iso/cauldron install at least a couple times per week
19:26:55 <AL13N> it seems some user had some error on xen-blkfront module at the beginning of stage2, while it was a physical machine (no xen)
19:27:00 <wilcal> yesterday I did a 64-bit install
19:27:04 <AL13N> did anyone have this issue?
19:27:18 <AL13N> someone reported this issue
19:27:31 <wilcal> I had a wrinkle but won't report it until I see it twice
19:27:34 <DavidWHodgins> I doubt it will be very useful.  I've used automated testers before.  For simple predictable output, they work well.  For complex things, they tend to show problems in the test procedure more than problems in the installer, so it ends up wasting peoples time.
19:27:39 <wilcal> and it completed to a successful install
19:27:43 <AL13N> stuff has been changed regarding that, it's it's very well possible: https://bugs.mageia.org/show_bug.cgi?id=9546
19:27:44 <[mbot> Bug 9546: normal, Normal, alien, alien, REOPENED , XEN driver autodetection support
19:27:57 <AL13N> wilcal: he said it was just an error message
19:28:03 <DavidWHodgins> Haven't tried a xen installation.
19:28:03 <wilcal> k
19:28:09 <AL13N> not sure if it was just visible or if you had to click it away
19:28:14 <AL13N> DavidWHodgins: it wasn't a xen install
19:28:16 <wilcal> I'll do another by Tue latests
19:28:19 <AL13N> DavidWHodgins: that's the whole problem
19:28:25 <DavidWHodgins> Ah.  Ok.
19:28:27 <MrsB> AL13N: can you save it til after the meeting pls
19:28:34 <AL13N> ah oops, meeting
19:28:37 <AL13N> sorry
19:28:40 <MrsB> np :)
19:29:25 <MrsB> If we could come up with a range of tests, just for basics like a raid setup, various partitioning schemes, etc it could be useful imho
19:29:34 <wilcal> What's that os-autoinst page
19:30:14 <AL13N> MrsB: or for regression testing, to make a test for each bug
19:30:28 <MrsB> there are a couple.. https://github.com/bmwiedemann/os-autoinst or http://gitorious.org/os-autoinst/
19:30:29 <[mbot> [ bmwiedemann/os-autoinst ยท GitHub ]
19:30:54 <MrsB> Yeah. Only for the installation process.
19:31:10 <wilcal> https://wiki.mageia.org/en/Auto_inst
19:31:15 <wilcal> gave me a headache
19:31:23 <MrsB> that's something different
19:31:44 <MrsB> it could be used though aswell
19:32:02 <MrsB> Dave, you don't like this?
19:32:04 <wilcal> Way back when there was a proposal in Mandrake to
19:32:04 <wilcal> use an external ( CD/Floppy/USB ) text file with
19:32:04 <wilcal> the packages to be installed. From what I remember
19:32:04 <wilcal> it was really pretty simple and kinda worked.
19:32:04 <wilcal> apache
19:32:06 <wilcal> proftp
19:32:08 <wilcal> kompozer
19:32:10 <wilcal> audacity
19:32:12 <wilcal> openshot
19:32:14 <wilcal> ect ect It never got any further then that.
19:32:45 <Luigi12_work> wilcal: it wasn't a proposal, it was implemented.  It got removed because nobody has a floppy drive anymore.
19:33:06 <Luigi12_work> they also removed full package selection from the installer after that
19:33:09 <wilcal> Well no floppy but that's the kind of thing I was thinking about
19:33:22 <MrsB> an auto_inst file could be used for each testcase
19:33:23 <Luigi12_work> well that Auto_inst thing is what that used
19:33:36 <wilcal> Ever try and install a dozen or so OS's in an office
19:33:36 <Luigi12_work> the floppy with the packages list just used a subset of the Auto_inst functionality
19:34:01 <MrsB> the installer leaves one in /root/drakx at the end of an installation
19:34:21 <wilcal> I'd like to see something simple for tests
19:34:39 <MrsB> not sure how they're used but even without them the os-autoinst is capable of moving the mouse and clicking things
19:34:43 <Luigi12_work> that is simple, it automates a lot of the installer, so you don't have to use some macro recorder for clicks or something
19:35:35 <MrsB> anyway, it would have been nice to hear from Glen in this bit, he's played with it a bit.
19:35:44 <wilcal> Problem with https://wiki.mageia.org/en/Auto_inst is a office manager can't understand and use it
19:35:49 <MrsB> let's move on and try and get him to next meeting
19:35:57 <DavidWHodgins> #topic Luigi's Roundup
19:36:03 <Luigi12_work> boo
19:36:05 <MrsB> Over to you
19:36:07 <wilcal> No rush on this but I am really interested in it
19:36:28 <MrsB> we still have sssd and ruby packages :\
19:36:50 <Luigi12_work> I'd like bind and dhcp to get tested ASAP so if there's any problems they can be fixed in Cauldron before the freeze (although I don't anticipate any problems)
19:37:08 <Luigi12_work> a testing procedure was proposed for sssd quite some time ago, so it'd be nice if someone would finally tackle that
19:37:13 <DavidWHodgins> For sssd, I've been trying to get ldap working first.  Ran into a buch of auth problems.  I'll leave the ldap stuff, and test sssd in local mode.
19:37:25 <MrsB> careful with it Dave
19:37:39 <DavidWHodgins> Yep.
19:37:44 <Luigi12_work> local is fine, we just need to test the affected functionality of the update
19:37:52 <MrsB> #info bind and dhcp are priorities
19:38:14 <wilcal> dhcp new security issue CVE-2013-2494
19:38:14 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=9547
19:38:15 <[mbot> Bug 9547: normal, Normal, qa-bugs, qa-bugs, NEW , dhcp new security issue CVE-2013-2494, dhcp
19:38:22 <wilcal> I did the dhcp client thing
19:38:25 <MrsB> morning wrw105
19:38:28 <Luigi12_work> libuser is low priority
19:38:29 <DavidWHodgins> I can test both of those fairly quickly, right after the meeting.
19:38:35 <wilcal> but really don't understand how to test the server part of it
19:38:36 <wrw105> HI MrsB
19:38:42 <MrsB> #info libuser is lower priority
19:38:57 <DavidWHodgins> wilcal: I'll add a comment to the bug report, explaining how I test the server part.
19:38:58 <Luigi12_work> gajim and samba are the other ones of moderate severity
19:39:03 <MrsB> isn't there a procedure for dhcp?
19:39:09 <wilcal> DHCP client i testing in Vbox and on real hardware worked fine
19:39:11 <wilcal> thanks
19:39:37 <DavidWHodgins> The procedure is probably in an older dhcp bug report.
19:39:52 <wilcal> double thanks
19:39:57 <MrsB> checking previous bug reports (click the Bugzilla link on madb) is useful to see how it was done before
19:40:37 <Luigi12_work> any questions for me?
19:40:49 <MrsB> #info gajim & samba medium priority
19:40:57 <MrsB> anything coming soon Luigi12_work?
19:40:58 <wilcal> Keep up the good Java work Luigi
19:41:07 <Luigi12_work> lemme check
19:41:10 <DavidWHodgins> https://bugs.mageia.org/show_bug.cgi?id=4514#c7
19:41:12 <[mbot> Bug 4514: normal, Normal, qa-bugs, qa-bugs, RESOLVED FIXED, dhcpcd is missing a security update for CVE-2011-0996, dhcpcd-5.2.7-1.mga1.src.rpm
19:41:25 <Luigi12_work> the postgresqls will all be updated again soon (once funda updates them)
19:41:31 <DavidWHodgins> Procedure used for server testing is in that comment.
19:41:52 <MrsB> #info postgresql updates are coming soon
19:42:10 <DavidWHodgins> There's an opera update today too, but no bug report for it yet.
19:42:15 <Luigi12_work> there are some others waiting on packagers, so we'll see
19:42:31 <Luigi12_work> nothing in my pipeline at the moment
19:42:43 <MrsB> you can use dhcping with dhcp too
19:43:04 * Luigi12_work just hopes tmb has a plan for getting more help on the sysadmin team
19:43:04 <MrsB> thanks Luigi12_work
19:44:04 <DavidWHodgins> #topic Anything else?
19:44:12 <Kernewes> that depends
19:44:18 <MrsB> thankyou Dave. Is there anythign else?
19:44:20 <wilcal> I'm good M3B4 looks really good
19:44:21 <Kernewes> is the unmentionable still unmentionable?
19:44:46 <MrsB> Ohh there was something about that wasn't there
19:44:52 <Kernewes> it was sounding promising
19:44:54 <DavidWHodgins> Have to test the patch, and see if it works, before it gets pushed to updates testing.
19:45:11 <MrsB> It would be good if we could get a package built rather than applying patches
19:45:13 <DavidWHodgins> Just haven't gotten around to trying it yet.
19:45:38 <MrsB> difficult to remove patches if it doesn't work
19:45:50 <DavidWHodgins> Use a vb snapshot.
19:45:57 <MrsB> i guess
19:46:36 <MrsB> #action DavidWHodgins to check the patch for TBWNWDNM
19:46:45 <DavidWHodgins> Lol
19:46:56 <MrsB> anything else?
19:47:09 <wilcal> Not from me
19:47:11 <Kernewes> no
19:47:13 <DavidWHodgins> Not here.
19:47:25 <alfred__> not here
19:47:27 <wrw105> Nothing from me....
19:47:30 <lewyssmith> N
19:47:32 <wilcal> Short QA meetings are a good thing
19:47:36 <Kernewes> +1
19:47:41 <MrsB> if nobody has anything I'd just like to say thankyou to Dave for doing a great job last week and for his help as always today.
19:47:50 <lewyssmith> Seconded
19:47:50 <wilcal> Super Dave
19:47:53 <Kernewes> yep
19:47:55 <DavidWHodgins> Thanks everyone.
19:47:58 <MrsB> and thank you all for the great job you did last week too :)
19:48:07 <alfred__> +1
19:48:15 <Kernewes> MrsB: hope you're all sorted out now
19:48:15 <MrsB> Thanks for coming, same time next week!
19:48:22 <MrsB> #endmeeting