20:07:22 <MrsB> #startmeeting
20:07:22 <Inigo_Montoya> Meeting started Thu Jan 10 20:07:22 2013 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:22 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:07:34 <MrsB> Hi all welcome to another meeting
20:07:41 <MrsB> #chair DavidWHodgins
20:07:41 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB
20:07:44 <DavidWHodgins> #topic Who's new? - Thinking about getting involved, come and say Hi!
20:07:51 <MrsB> lol thanks
20:08:07 <MrsB> Is there anybody new this week?
20:08:26 * MrsB looking at the list of nicks
20:08:59 <MrsB> i think we've all been here before
20:09:09 <DavidWHodgins> #topic ISO testing
20:09:23 <MrsB> ahaa so the main event..
20:09:43 <MrsB> #info the first buildsare expected this weekend
20:09:48 <MrsB> #undo
20:09:48 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x832f12c>
20:09:52 <MrsB> #info the first builds are expected this weekend
20:10:15 <MrsB> is everybody clear about how to test, what to test, how to use the pad etc etc?
20:10:26 <wilcal> I've a concern about M3B2 ISO's
20:10:26 <Kernewes> what's the focus with B2?
20:10:33 <Led43_Mag1> do we need new p/words to dl
20:10:43 <MrsB> ok, first one last
20:10:50 <wilcal> Bug 8535: LibreOffice is still broken and does not install
20:10:51 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=8535 normal, Normal, bugsquad, bugsquad, NEW, Missing package(s) and dependencies prevents installation of Libreoffice, libreoffice
20:11:00 <MrsB> yes, you'll need a password, I'll email everybody when I know it
20:11:06 <wilcal> Is that what M3B2 is gonna do
20:11:24 <MrsB> There are problems building LO at the moment
20:11:29 <MrsB> it's being worked on though
20:12:16 <wilcal> I understand we are moving on to 4
20:12:25 <MrsB> is that as a regular cauldron update wilcal?
20:12:41 <wilcal> Lemme post this:
20:12:46 <MrsB> hi napcok
20:12:51 <wilcal> I've successfully executed an entirely new 32-bit M3 KDE install from a blank drive up with using the 18 Dec 12 boot.iso this morning
20:12:52 <napcok> hi
20:12:59 <wilcal> LibreOffice did not install
20:13:11 <MrsB> ahh ok, well that's just regular cauldron.
20:13:27 <MrsB> Beta 2 will be a built first this weekend
20:13:51 <MrsB> LO is a major part of the installs so I guess it needs to be working before they'll build the isos
20:14:30 <MrsB> We concern ourselves with the finished article
20:14:32 <DavidWHodgins> LO is just one package, which can be fixed by an update after install, so it would not be a release blocker.
20:14:49 <Kernewes> it would be a deal breaker for me
20:14:57 <MrsB> yeah, it's pretty major.
20:15:07 <MrsB> It's up to release managers though really
20:15:16 <DavidWHodgins> Guess it would be a blocker for the live iso images, but not for the installer images.
20:15:34 <MrsB> Kernewes: you asked about focus
20:15:35 <Kernewes> well I need it for lots of stuff here
20:15:47 <Kernewes> MrsB: yes, what are we concentrating on this time?
20:16:03 <MrsB> we need to start to look in finer detail now but also need to ensure all hardware is supported.
20:16:29 <wilcal> I have three different testing platforms here
20:16:36 <MrsB> I posted some links in the long email i sent to qa-discuss which should give some ideas.
20:16:46 <DavidWHodgins> Now that cauldron is in version freeze, we have to start looking for packages that cause problems upgrading from Mageia 2 to 3, as well as everything we've been testing before.
20:17:09 <wilcal> Mageia 1 is no longer supported
20:17:18 <MrsB> Hopefully most of the major issues will begin to be less of an issue now and we'll be able to concentrate more on the rest of it
20:17:41 <Kernewes> MrsB: what would you want us to look at in finer detail?
20:18:33 <MrsB> #info anybody intending to help with pre-release qa testing of the ISOs please ensure your details are up to date here: https://wiki.mageia.org/en/QA_ISO_testers
20:18:41 <MrsB> well, the short answer is everything
20:19:04 <Kernewes> MrsB: use it as much as possible for different things
20:19:14 <MrsB> This might give you some ideas http://www.ethercalc.org/qa
20:19:15 <[mbot> [ EtherCalc - Share the URL to your friends and edit together! ]
20:19:26 <Kernewes> thanks
20:19:51 <Led43_Mag1> test apps to see if hey run or go deeper, like set up email account open doc play music
20:19:53 <MrsB> each spreadsheet can be printed off if you like by clicking the 'cog' icon at the top left
20:20:21 <MrsB> I think initially make sure your hardware works
20:20:31 <MrsB> then test each application
20:20:33 <Kernewes> don't worry, I'll soon say if it doesn't
20:20:40 <MrsB> then if we get time test deeper
20:20:50 <Kernewes> ok, that's helpful, thanks
20:20:58 <MrsB> it's still quite early so there will likely be bugs
20:21:00 <wilcal> I do a lot of multimedia including video editing
20:21:27 <MrsB> what's important is that each build of each ISO is tested on as many setups as possible
20:22:29 <MrsB> http://www.ethercalc.org/mga3-alpha1 is a better link, sorry
20:22:29 <[mbot> [ EtherCalc - Share the URL to your friends and edit together! ]
20:23:41 <MrsB> please only use that for reference though, we decided beefore that it was too clunky to use for what we want so we agreed to use the pad
20:24:40 <MrsB> #info I gave a bad ethercalc link in the long email to qa-discuss, the one above is better
20:25:10 <MrsB> anybody anything to add?
20:25:21 <Led43_Mag1> not here
20:25:28 <Luigi12_work> apparently libreoffice built
20:25:29 <wilcal> I'm good here
20:25:35 <wilcal> 4?
20:25:38 <MrsB> everybody clear on what we do and how we do it?
20:25:42 <wilcal> or still in 3?
20:25:49 <Kernewes> who cares as long as we have it
20:25:54 <wilcal> k
20:25:55 <Luigi12_work> 4
20:25:57 <Luigi12_work> beta
20:26:01 <wilcal> WOW! kool
20:26:16 <Kernewes> we're all happy then :)
20:26:33 <MrsB> This will be our last chance to get together before we start testing so if you have anything to ask now is a good time :)
20:27:03 <MrsB> or any comments on how it's done, suggestions to do it better, etc
20:27:26 <Kernewes> we need to have the pad cleared between builds
20:27:29 <Luigi12_work> lol, rpmlint rejected LO
20:27:46 <Kernewes> :(
20:27:51 <MrsB> #info reminder for Anne and Thomas to please tend the pad between builds, thanks.
20:29:06 <MrsB> #info if you have any questions about anything please don't hesitate to ask, either IRC or list
20:29:15 <wilcal> k
20:29:30 <MrsB> if there's nothing else then let's move on. Last chance..?
20:29:31 <DavidWHodgins> #Topic Luigi's Roundup
20:29:48 <MrsB> Thanks dave
20:30:03 <MrsB> Luigi12_work: pingaling
20:30:19 * Kernewes bracing herself for the "boo"
20:30:25 <Luigi12_work> boo
20:30:53 <MrsB> If you don't know already, Luigi12 builds most of our security updates, he is David Walser
20:30:55 <Luigi12_work> so the most important updates we have are still kernel and virtualbox
20:31:28 <DavidWHodgins> I'll be redoing my mass kernel install/update testing, after todays meeting.
20:31:33 <Luigi12_work> we also have an important freeciv update
20:31:46 <Luigi12_work> so if you like playing games, you'll like that
20:32:14 <Luigi12_work> if the local build is successful, I'll have an inkscape update soon, but it's not so important
20:32:14 <MrsB> #info the most important sec updates are kernel & vbox right now then freeciv (a game!)
20:32:51 <Luigi12_work> just some notes on other updates, dmorgan told me he'd look into the tomcat5 permissions issue soon
20:32:55 <DavidWHodgins> What's happening with firefox?  I saw that Mandriva pushed an update today.
20:33:02 <wilcal> Where's kernel Ver at now?
20:33:12 <Luigi12_work> still need confirmation from Oden that php-apc is actually ready to test, the rest of the PHP stuff has been ready for quite some time
20:33:14 <MrsB> Ok, shall we split that bug then David?
20:33:25 <Kernewes> DavidWHodgins: are they on the LTS one like us?
20:33:32 <Luigi12_work> MrsB: let's give dmorgan some time
20:33:33 <MrsB> php-apc is ready now, I was working with Oden today
20:33:50 <Luigi12_work> MrsB: ahh good, I know he had to revert it to 3.1.13
20:33:51 <DavidWHodgins> Not sure.  Didn't keep the rss feed item.
20:34:20 <Luigi12_work> ok, so the PHP update should be ready to test then
20:34:32 <MrsB> He's made some shanges to php-apc so please check the extra advisory he's added
20:34:36 <MrsB> changes*
20:34:58 <Luigi12_work> for the FF update, it's in updates_testing (17.0.2, moving to the new ESR branch).  It still needs to be rebuilt one more time, to fix the Opus issue.  spturtle/cjw fixed it in iceape, so we just need to port the patches over.
20:35:06 <MrsB> I've checked  php on x86_64 all except the new, new php-apc
20:35:18 <Luigi12_work> MrsB: last I saw the extra advisory he added still referenced 3.1.14
20:35:39 <MrsB> no, it shouldnt. It's 3.1.13 again now
20:35:52 <Luigi12_work> right
20:36:16 <MrsB> he's changes the config aspect of it though so it will update cleaner in future
20:36:36 <MrsB> it'll still clobber the login/password on update this time but in future it shouldn't
20:36:45 <Luigi12_work> oh, and Thunderbird 10.0.12 should be in updates_testing ready to test.  You need the updated rootcerts, nss (and libnss), and nspr (and libnspr) along with it.  No bug has been filed yet for TB.
20:37:34 <wrw105> is iceape going to be backported to 2?  Or is it cauldron only for the current release?
20:37:36 <MrsB> we'll stick to the ones we have bugs for i reckon :P
20:37:57 <Luigi12_work> iceape isn't in mga2 updates_testing yet
20:38:05 <Luigi12_work> well TB doesn't have a bug yet because I didn't make it yet :o)
20:38:17 <Luigi12_work> FF has a bug, but like I said will be rebuilt one more time to fix the Opus issue
20:38:38 <MrsB> #info Firefox and thunderbird updates are coming soon
20:39:13 <MrsB> #info FF will be moving to 17 lts series
20:39:41 <wilcal> FF stability finally
20:39:43 <Luigi12_work> it should have the duckduckgo integration too
20:39:52 <MrsB> ahh thats cool
20:39:57 <Kernewes> yeah
20:40:14 <MrsB> #info FF should also have the duckduckgo integration as an optional search engine
20:40:15 * Led43_Mag1 was wandering when that would happen
20:40:35 <MrsB> everybody know about that?
20:40:42 <djennings> no
20:41:01 <Kernewes> it was a few months ago now that it came up
20:41:14 <MrsB> DDG approached us to see if we wanted to integrate it in our browsers as eithe default or optional search engine
20:42:04 <MrsB> Mageia will get a commision on any revenues accrued by doing so
20:42:18 <wilcal> kool
20:42:22 <MrsB> It was decided to offer it as an option rather than default
20:42:25 <djennings> excellent
20:42:38 <Led43_Mag1> help pay for switches and servers
20:43:05 <MrsB> yes, it'll certanly help. We'll have to wait and see how well it works out
20:43:43 <MrsB> So, is there anything for Luigi12_work or anything to add David?
20:43:59 <wrw105> I've been hearing good things about DDG about privacy issues, as opposed to Google....
20:44:07 <Kernewes> exactly
20:44:08 <Luigi12_work> hopefully not :o)  I guess the world is back from vacations now so they're making new security bugs for us to fix!
20:44:29 <MrsB> booo hiss!
20:44:46 <MrsB> thanks for that then Luigi12_work :)
20:44:50 <DavidWHodgins> #topic The bug that can now be named. :-) Bug 2317
20:44:52 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, release_blocker, thierry.vignaud, thierry.vignaud, NEW, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
20:45:03 <MrsB> ahaa, some good news!
20:45:17 <Kernewes> nearly fell of my chair when I read about that
20:45:21 <Kernewes> off
20:45:37 <MrsB> Have you ever had an update which said it couldn't be installed because of missing suchnsuch package?
20:46:04 <Led43_Mag1> once or thrice
20:46:07 <MrsB> if you have then that is most likely due to this infamous bug
20:46:25 <MrsB> we try to check for it but obviously some slip through
20:46:36 <MrsB> we've done a pretty good job though
20:46:59 <MrsB> It absolutely WILL be fixed before Mageia 3
20:47:06 <MrsB> tmb said so
20:47:06 <DavidWHodgins> We still get caught some times, when a dependency is also in updates testing, so our script doesn't realize it's needed.
20:47:29 <MrsB> it should check updates_testing automatically dave
20:48:22 <DavidWHodgins> If it's in updates testing, the script assumes it will be available in updates, when the package that needs the dependency gets pushed.  If the dependency is from another update, it may not get pushed at the same time.
20:48:34 <MrsB> Until now this bug has been a major pain, we have had to check every package of every update and sysadmin has had to link half of the release media into updates
20:48:46 <MrsB> ahh yeah, you're right
20:49:06 <MrsB> So all rejoice \o/
20:49:28 <wilcal> Will this fix be in at the time of M3B2?
20:49:34 <Kernewes> no pressure on tmb there, then
20:49:39 <MrsB> not likely wilcal
20:50:12 <MrsB> well tmb is probably more affected by it than we are, he is the one who has been making all the links we find things need.
20:50:48 <MrsB> any comments on this bit?
20:51:13 <wilcal> not from me
20:51:15 <Led43_Mag1> not here
20:51:29 <rindolf> Yay. \o/
20:51:36 <DavidWHodgins> Test procedure is in the bug report.
20:51:50 <MrsB> I saw that Dave, good thinking that
20:51:57 <Kernewes> revenge will be sweet
20:52:22 <MrsB> So let's put it behind us and move on :)
20:52:34 <DavidWHodgins> #topic Anything else?
20:52:36 <MrsB> (until we have to test it anyway)
20:52:49 <MrsB> Is there anything else?
20:52:55 <DavidWHodgins> Not here.
20:52:56 <Kernewes> not here
20:53:01 <wilcal> I wanted to comment on 8228 & 8580
20:53:08 <MrsB> please do
20:53:29 <wilcal> If you have a problem connecting WiFi simply turn off the auto connect at boot up
20:53:49 <MrsB> wilcal: add an #info so it will show in the minutes
20:54:01 <wilcal> You'll have to manually configure your network every time but that works every time
20:54:07 <MrsB> anybody can add #info's btw
20:54:23 <wilcal> Bug 6541: Still lots of NFS issues not only just this bug
20:54:24 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=6541 normal, Normal, mageia, mageia, NEW, systemd seems to have problems with NFS mounts in /etc/fstab, systemd
20:55:21 <MrsB> #info a workaround for bug 8228 & 8250 is to disable the 'connect at boot'
20:55:23 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=8228 normal, Normal, mageia, mageia, NEW, drakx-net doesn't handle signal strength reported in dBm (negative values), drakx-net-1.16
20:55:26 * MrsB did it
20:56:05 <MrsB> #info seems to be lots of NFS bugs eg. 6541
20:56:06 <wilcal> Wore out a couple pair of shoes figuring the WiFi thing out
20:56:31 <wilcal> Yes the NFS thing goes all the way back into Mandrake
20:57:02 <MrsB> If they get reported they will get fixed sooner or later
20:57:09 <djennings> Well I did write a patch for Bug 207 but no one seems to want to apply it.
20:57:10 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=207 normal, Normal, thierry.vignaud, thierry.vignaud, REOPENED, can't mount NFS servers, drakxtools
20:57:55 <MrsB> djennings: shall I give you an #action to find out what's happening with it, maybe check with ennael?
20:58:13 <MrsB> Oh reminds me, I need to report on some previous action points
20:58:21 <djennings> OK
20:59:12 <MrsB> #action djennings to find out what is happening with bug 207 (can't mount NFS servers, drakxtools) and his proposed patch
20:59:44 <MrsB> Before Christmas I gave myself (stupid!) some action items
21:00:04 * tmb thinks we shold apply fix in 207
21:00:45 <MrsB> dare you add an info tmb :P
21:01:02 <MrsB> My action items, there were 3.. MrsB to ask leuhmanu about adding the whiteboard field to the new bug form
21:01:41 <MrsB> Apparently leuhmanu is unable to do this, it will need sysadmin. dmorgan currently looks after bugzilla I think but he is a bit unavaliable at the moment
21:02:11 <MrsB> MrsB to find out what's happening with bug 6061 (disabling nonfree/tainted during upgrade)
21:02:12 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=6061 major, Normal, thierry.vignaud, thierry.vignaud, ASSIGNED, mgaapplet-upgrade-helper removes nonfree and tainted repo (and so radeon-firmware) when upgrading to next Mageia version, mgaonline
21:02:52 <MrsB> I've asked on the bug but will need to ask ennael/tmb about this one I think
21:03:16 <MrsB> MrsB to ask about bug 2317 at next council meeting
21:03:17 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, release_blocker, thierry.vignaud, thierry.vignaud, NEW, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
21:03:29 <MrsB> Successs with this one \o/
21:04:52 <MrsB> tmb should bug 6061 be set release blocker? concensus is it probably should be i think
21:06:11 <tmb> MrsB: yep
21:06:22 <MrsB> I'll do that now then, thanks
21:07:08 <MrsB> Does anyone have anything else they'd like to add?
21:07:16 <rindolf> Not me.
21:07:17 <wilcal> Nope not from me
21:07:19 <Kernewes> nope
21:07:24 <DavidWHodgins> Nothing to add here.
21:07:29 <Led43_Mag1> nope
21:07:53 <MrsB> Thankyou all for coming then and as always thanks to Dave for your help :)
21:07:54 <djennings> Bug 8379 is similar to 6061  Any one who installs from Live media will not have non free repos enabled.
21:07:55 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=8379 normal, Normal, thierry.vignaud, thierry.vignaud, NEW, draklive-install should enable nonfree repo if nonfree packages are installed, draklive-install
21:08:26 <MrsB> ahh yes, they are linked arent they, set blocker I think djennings as they're more or less the same bug
21:08:59 <DavidWHodgins> Similar bug, but different rpm packages that need to be fixed.
21:09:05 <MrsB> Please keep an eye on qa-discuss for news of the ISOs
21:09:19 <Led43_Mag1> will do. will lurk here as well
21:09:19 <Kernewes> will do
21:09:25 <Luigi12_work> MrsB:
21:09:26 <leuhmanu> it's drakxtools in fact
21:09:27 <Kernewes> and you'll let us know the password
21:09:30 <MrsB> #endmeeting