20:06:21 <MrsB> #startmeeting
20:06:21 <Inigo_Montoya`> Meeting started Thu Nov  1 20:06:21 2012 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:06:21 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:06:24 <rindolf> Hi all.
20:06:29 <MrsB> #chair DavidWHodgins
20:06:29 <Inigo_Montoya`> Current chairs: DavidWHodgins MrsB
20:06:43 <MrsB> hi everybody, welcome to another meet :)
20:06:52 <rindolf> DavidWHodgins: sounds like your cat needs coffee too. ;-)
20:07:04 <DavidWHodgins> Lol
20:07:08 <DavidWHodgins> #topic Alpha 3
20:07:16 <MrsB> thankyou!
20:07:46 <MrsB> So, we just recovered from the extended testing for alpha2 and alpha 3 is almost upon us
20:08:10 <MrsB> it is due for public release on November 12th so we should expect it in the next day or so
20:08:38 <MrsB> everyone up for some ISo testing?
20:08:50 <DavidWHodgins> Should be ok.
20:09:01 <Kernewes> hopefully, but not until after Sunday
20:09:09 <alfred__> will have time for that
20:09:33 <rindolf> MrsB: I'm up for it.
20:09:57 <Latte> I hope so, too. Depends on my regular work...
20:10:02 <Edux_099> I will try.
20:10:09 <MrsB> we need to clear the existing security updates at least before it arrives so please make a push to get them done, we're about out of time.
20:11:23 <DavidWHodgins> I'm currently working on bacula
20:11:42 <MrsB> that's good news, I've been doing everything but bacula :D
20:12:16 <tmb> just a small info regarding isos... I will sync frozen repo and build first set of livecds on friday night, so early testers can play with them over the weekend
20:12:41 <MrsB> thanks tmb
20:12:46 <tmb> (unless I hit some bad problem with the build that is)
20:13:01 <MrsB> #info first ISOs should be available for testing at the weekend
20:14:10 <MrsB> During alpha 2 we had alot of people show an interest in testing, who signed up for the list and put their names down as testers but very few actually did any testing.
20:14:41 <MrsB> I know most here at the moment did do, but we need to think about how we can get people testing.
20:14:59 <MrsB> There are a couple of suggestions currently..
20:15:56 <MrsB> There has been a start made on a page to help introduce people new to ISO testing with how we do it.. the pad, rsync, bugzilla etc
20:16:08 <MrsB> I've not had time yet to add to it
20:16:18 <MrsB> http://bn.parinux.org/p/howto_qa_iso
20:16:19 <[mbot> [ Etherpad Lite ]
20:16:41 <MrsB> If you have some spare time please do work on it
20:17:24 <MrsB> Alot of the info was in the email I sent around last time but it could be added to and clarified etc
20:17:53 <MrsB> Another idea is to password the rsync
20:18:11 <MrsB> wdyt?
20:18:22 <rindolf> MrsB: you mean protect it using a password?
20:18:37 <MrsB> so you would need a password to be able to download it
20:19:21 <rindolf> MrsB: OK, that's what I meant.
20:19:26 <Latte> I don't think that a password will help to encourage people to test?
20:19:59 <DavidWHodgins> The purpose of adding a password, would be to prevent people from downloading it, who haven't signed up, to prevent the server from becoming overloaded.  Was there a problem with the server load?
20:20:07 <tmb> Latte: nope, but it will save availavle bandwidth for those that do test
20:20:22 <Latte> DavidWHodgins: tmb: yes, that's true
20:20:46 <MrsB> That was my first instinct too, but it could give a sense of ownership and access could be withdrawn for those who do download it and don't do any testing. It would give us a truer picture of exactly the manpower we do have.
20:20:51 <Kernewes> the trouble is, all the testing has to happen in the space of about a week
20:21:01 <Kernewes> if real life gets in the way you lose your opportunity
20:21:09 <Kernewes> that's what happened to me with Alpha 2
20:22:00 <DavidWHodgins> Right now, we only know who is testing based on the updates to the pad, or bugzilla reports.  We don't know who tested, but didn't find any new bugs.
20:22:16 <DavidWHodgins> We don't know who downloaded which versions either.
20:22:34 <tmb> Kernewes: that's why we have expanded the planned testing to  ~10 days so it covers 2 weekends
20:22:42 <MrsB> That should have been on the pad, I guess we need to clarify
20:23:46 <MrsB> it isn't all on our shoulders, tmb/ennael needed to clear the pad a bit better too when they built new isos
20:24:11 <tmb> yep
20:24:21 <MrsB> we do need to think how we can improve things though and these are just two of the current ideas
20:24:54 <Kernewes> tmb: if most the ISOs aren't out until after this weekend, that only leaves a week
20:25:06 <MrsB> anybody have any better ideas?
20:25:14 <MrsB> or against the current ones
20:25:37 <Kernewes> maybe rearrange the page that tells you what to test
20:25:47 <DavidWHodgins> Unless we encounter problems with the server load, I don't think adding a password will help.
20:25:50 <Kernewes> so the easier items are further up and newbies can find them easier
20:26:32 <MrsB> I must admit, the password does have the potential to be a bad idea, but it could deter those who just fancy a sneak preview
20:27:07 <DavidWHodgins> True.  We don't want another review based on an alpha or beta.
20:27:14 <MrsB> If we have a list of 20 people and only 5 or 6 are testing then we need to look at what we can do to change that
20:28:35 <MrsB> is anybody against having a password this time around, and if so what are the reasons?
20:29:17 <Latte> how is the password provided?
20:29:19 <DavidWHodgins> Is the server setup for using a password?
20:29:38 <MrsB> it would probably be me handing it out Latte
20:30:04 <MrsB> it's possible to have a different password for each person too
20:30:06 <Latte> but a general one or a individual?
20:30:11 <Latte> ah OK ;)
20:30:22 <MrsB> well, I say possible, is that true tmb?
20:31:30 <tmb> MrsB: yep
20:31:54 <MrsB> so what do you think guys?
20:32:13 <Latte> fo me it's OK
20:32:31 <MrsB> do we think it would help or hinder?
20:32:43 <alfred__> well i don't see it's really needed but i'm not against
20:32:53 <Kernewes> same with me
20:33:21 <rindolf> Maybe have something based on ssh keys.
20:33:34 <rindolf> Because entering the password every time is annoying.
20:33:41 <rindolf> Can I specify it on the command line?
20:33:46 <MrsB> I'm not sure how it would work
20:34:05 <Kernewes> what if you don't use ssh?
20:35:12 <MrsB> so lets give it a try shall we and see how it works out
20:35:38 <MrsB> we may decide it's a bad idea and give up on it or might find it encourages people to get involved
20:35:50 <MrsB> it's up to us though
20:35:56 <MrsB> mainly ;)
20:35:57 <DavidWHodgins> Looking at man rsyncd.conf, I think we should either use the secrets file, or leave it for the next release, so everyone can get the ssh stuff set up and tested first.
20:36:04 <leuhmanu> rindolf: you can add the pass in your rsync command
20:36:12 <rindolf> leuhmanu: OK, thanks.
20:36:26 <leuhmanu> (with the basic password file conf)
20:36:29 <DavidWHodgins> You can also put the password in a file.
20:36:54 <MrsB> so now we need some volunteers to add some info to the help page I gave before..
20:37:14 * MrsB watches everybody hide
20:37:49 <DavidWHodgins> What info needs to be added, depends on how/if we add a password, or use rsync over ssh.
20:38:39 <MrsB> yes, you're right. We can add general info though like how to update the pad, what with, what to test etc. How to use bugzilla, whiteboard etc
20:39:08 <MrsB> how to download the ISo can be added when we have that information
20:39:25 <MrsB> it'll be sent out individually though I think anyway
20:39:48 <MrsB> how to dump onto USb stick too
20:39:57 <MrsB> how to dual boot
20:40:10 <MrsB> anything which could be useful for a new tester
20:41:02 <Kernewes> there's already a long wiki page on dual booting
20:41:14 <MrsB> it'll be added as a wiki page when we're happy with it, or we could do it straight onto the wiki
20:41:25 <MrsB> that's good to know Kernewes
20:41:42 <alfred__> another thing, what about a database about the hw used for tests?
20:42:09 <MrsB> didn't we have something like that at one point?
20:42:22 <DavidWHodgins> alfred__: There is a wiki page for that.
20:42:24 <Kernewes> MrsB: actually I think the wiki page is more about dual booting alongside Windows
20:42:31 <alfred__> there's a wiki page i know
20:42:34 <Kernewes> MrsB: which people shouldn't dabbel with
20:42:36 <Kernewes> dabble
20:42:49 <Kernewes> not with cauldron
20:43:31 <Kernewes> unless they're already experts :)
20:43:42 <MrsB> which we all are, of ocurse :D
20:43:46 <alfred__> would be a good idea the iso-tester would let the information about their hw there
20:44:04 <MrsB> alfred feel free to add a QA wiki page for that
20:44:06 <alfred__> i did already i think
20:44:16 <Kernewes> yes there is one
20:44:27 <MrsB> it's good to see soem ideas :)
20:44:30 <MrsB> some*
20:44:36 <MrsB> typing is bad today, sorry
20:45:36 <DavidWHodgins> https://wiki.mageia.org/en/QA_iso_hardware_list
20:46:24 <MrsB> i knew I'd seen one somewhere
20:47:03 <MrsB> #info please add your test system info to the list above but remember to keep it updated too please
20:47:37 <MrsB> DavidWHodgins: is that page linked from the qa portal?
20:47:54 <alfred__> not yet
20:48:01 <DavidWHodgins> Not sure.  Just did a search on hardware in the wiki, to find it.
20:48:07 <MrsB> alfred__: would you like to add one somewhere please
20:48:38 <alfred__> yes, will see
20:48:44 <MrsB> #action alfred__ to add a link on the portal to the qa hardware list
20:48:54 <MrsB> thanks
20:49:00 <alfred__> should also be mentioned/linked on the pad
20:49:14 <MrsB> yes and in the new help page
20:50:33 <MrsB> ok so there is work to be done anyway, please have a think how we could encourage more people to do testing while you're next on the loo :)
20:50:48 <DavidWHodgins> Link added to help page.
20:51:02 <MrsB> thanks Dave, lets move on for now
20:51:27 <DavidWHodgins> #topic Mageia 1 End of Life (EOL) date
20:51:37 <MrsB> tah :)
20:51:55 <MrsB> We now have a date for when Mageia 1 will become End of Life
20:52:26 <MrsB> #info Support for Mageia 1 will end on 1st December
20:52:27 <DavidWHodgins> Good.  I need the disk space. :-)
20:52:48 <MrsB> it'll help us with our qa load when we get into beta season etc too
20:52:57 <Kernewes> How does that make you feel who were here when it first came out?  Sad or...?
20:53:21 <MrsB> well, in the words of our glorious leader.. Mageia is dead, Long live Mageia!
20:53:30 <DavidWHodgins> I'm glad.  Although it took a while to work the bugs out, I prefer systemd.
20:54:00 <MrsB> There *should* be a blog post about this today
20:54:12 <MrsB> and another is planned for the 16th to remind people
20:54:51 <MrsB> http://www.mageia.org/en/support/
20:54:52 <[mbot> [ Support for Mageia distribution ]
20:55:56 <MrsB> for me Mga1 was a good solid release, it is dated now though. It did run properly on my laptop though *cought*tmb*
20:56:05 <tmb> :)
20:56:40 <tmb> so does mga2 if you use kernel-linus :)
20:56:57 <MrsB> yes but if I install mga2 it just crashes until i install linus :P
20:57:17 <DavidWHodgins> MrsB: I thought it was mga3 the laptop was having problems with?
20:57:25 <MrsB> it's both
20:58:11 <MrsB> are there any comments or questions on this topic before we move on?
20:58:36 <alfred__> not here
20:58:41 <Kernewes> no
20:58:56 <MrsB> disco dave..
20:59:11 <tmb> I guess wait for blog post before starting to notify BRs
20:59:36 <DavidWHodgins> tmb: Will the patches I suggested for the live iso images be included? https://bugs.mageia.org/show_bug.cgi?id=7774
20:59:37 <[mbot> Bug 7774: normal, Normal, tmb, NEW, fglrx default resolution is too high., draklive
21:01:54 <tmb> DavidWHodgins: I havent decided yet... I'm also looking on  fglrx code
21:01:56 * Luigi12_work strongly oppposes killing mga1 so early :P
21:02:18 <alfred__> doesn't work the -/+ keys any longer?
21:02:19 <MrsB> it will have been 18 months
21:04:05 <DavidWHodgins> alfred__: Forgot about those.  I used alt+ctrl+f2, ran XFdrake to set the resolution, then restarted the dm.  Not good for a new user with an old monitor though.
21:04:32 <alfred__> ok, log time not used
21:04:38 <alfred__> *long
21:05:01 <MrsB> if there's nothing else mga1 lets do the roundup
21:05:18 <DavidWHodgins> #topic Luigi's Roundup
21:05:32 <MrsB> Luigi12_work: over to you :)
21:06:15 <Luigi12_work> looks like security updates are mostly cleared out.  Dave said he's working on bacula, I think webkit is done on one arch.
21:06:33 <Luigi12_work> tinyproxy has some minor issues that need fixed, and I need to investigate further in the blender one.
21:06:44 <Latte> I can do the webkit this evening
21:06:50 <Luigi12_work> great
21:07:08 <DavidWHodgins> From the messages in the developers mailing list, I thought it tinyproxy was going to be dropped.
21:07:24 <Luigi12_work> the courier-authlib one is marked as bugfix...upstream claimed it was a minor security issue.  I'm not sure about that, but if you're gonna dive into the bugfix ones, maybe look at that sooner than later.
21:07:34 <Luigi12_work> DavidWHodgins: it can be dropped in Cauldron, not Mageia 2
21:07:44 <DavidWHodgins> Ah.  Ok. Thanks.
21:07:53 <Luigi12_work> it's not like wicd which is completely non-functional and therefore doesn't need to be fixed
21:08:06 <MrsB> if there is no interest in maintaining it maybe we should push it as it is
21:08:21 <Luigi12_work> well minor things like nobody->nogroup should be easy to fix
21:08:33 <DavidWHodgins> I'll test if after I finish with bacula.
21:08:38 <MrsB> that exposes another bug unfortunately
21:08:41 <Luigi12_work> the init script not killing the processes...well that's just weird as systemd should handle that, so dunno what the deal is there
21:09:06 <tmb> ping coling for thst
21:09:25 <tmb> *that
21:09:36 <Luigi12_work> other than that, for the other bugfix ones, PHP is the only one I care about, but it's not real high priority
21:10:00 <Luigi12_work> so...good job everyone.  The list had gotten quite long, so it's nice to see it back down.
21:10:02 <tmb> And I'm about to land full kernel sets for QA :)
21:10:07 <Luigi12_work> w00t
21:10:08 <MrsB> we have to focus our time now, we'll be ISO testing for the next week probably
21:10:08 <DavidWHodgins> I'll try to get as many done as I can, before the iso images start coming out.
21:10:17 <Luigi12_work> so hopefully we won't have too many new updates in the near future
21:10:26 <Luigi12_work> just had about a week where a bunch of them came out
21:10:30 <DavidWHodgins> knock on wood. :-)
21:10:35 <Luigi12_work> seriously
21:10:38 <Luigi12_work> any questions for me?
21:10:49 <DavidWHodgins> Not here.
21:10:58 <alfred__> no
21:11:01 <Latte> no
21:11:03 <Kernewes> no
21:11:16 <DavidWHodgins> #topic Anything else?
21:11:26 <MrsB> thanks for that Luigi12_work
21:11:44 <MrsB> Is there anything else?
21:11:50 <DavidWHodgins> Time zone change happens this coming weekend here.
21:12:09 <Luigi12_work> stupid time change
21:12:14 <alfred__> already done here :9
21:12:20 <alfred__> *:)
21:12:22 <Latte> Luigi12_work: I agree
21:12:26 <MrsB> are you two OK to carry on at 20 UTC?
21:12:51 <DavidWHodgins> Btw, I've been diagnosed with uveitis, so I have to limit my time on the computer a lot more than I used to.
21:12:58 <Luigi12_work> :o(
21:13:05 <DavidWHodgins> Yes. 20 utc is fine with me.
21:13:25 <Luigi12_work> I guess 20 utc will move it back to 3pm, so yes that's better actually
21:13:26 <MrsB> sounds painful dave
21:13:57 <MrsB> 20 UTC should keep us at the same local time after the clocks change
21:14:40 <DavidWHodgins> I've had to change the lighting in my room, so the wall behind the computer is roughly the same brigtness as the monitor.  That has helped a lot, but when my eyes start to hurt, I have to stop and close them for an hour or so.
21:15:08 <Edux_099> I have problems too (with the computer)
21:16:14 <Edux_099> 2 hours and my eyes hurt...
21:16:16 <DavidWHodgins> Good idea for everyone.  Keep the monitor contrast as low as possible. Brightness as low as still easy to read. Use black on white where possible.  Keep area around the monitor roughly the same brightness as the monitor.
21:16:35 <MrsB> What was that program that dimmed the screen depending on the time of day, so you remember?
21:16:49 <MrsB> got it, gtkredshift
21:16:52 <Kernewes> I'm having to limit my time at the computer because of my back
21:17:21 <MrsB> makes the screen more red when as the light changes
21:17:40 <DavidWHodgins> The redshift helps a little, but it distorts the colours, which is a problem with some web sites, etc.
21:17:55 <MrsB> yeah, it's not pretty but it should be easier on the eyes
21:18:05 <MrsB> I'm not sure we have one for backs :\
21:18:12 <Kernewes> DavidWHodgins: how long do they say that's going to last?
21:18:21 <MrsB> maybe the one that reminds you to get up and have a walk around
21:18:37 <Kernewes> MrsB: my back reminds me
21:18:48 <Kernewes> MrsB: occupational hazard after 25 years of office work
21:18:53 <MrsB> :(
21:19:10 <MrsB> as we're all falling apart shall we end the meeting before it actually happens?
21:19:13 <DavidWHodgins> It's a result of having lupus, which I've had for seven years.  The uveitis started about 6 months ago, but has been getting steadily worse, and finally diagnosed a few days ago.
21:19:47 <DavidWHodgins> Like most of my lupus symptoms, it will probably come and go over time, pretty much on it's own.
21:20:01 <MrsB> Thankyou all for coming!
21:20:05 <MrsB> #endmeeting