19:04:44 <MrsB> #startmeeting
19:04:44 <Inigo_Montoya> Meeting started Thu Oct  4 19:04:44 2012 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:44 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:04:53 <MrsB> #chair DavidWHodgins
19:04:53 <Inigo_Montoya> Current chairs: DavidWHodgins MrsB
19:05:00 <MrsB> disco dave \o/
19:05:18 <DavidWHodgins> Remembered what day of the week it is, this time. :-)
19:05:30 <MrsB> Hi all, welcome to another meeting :)
19:05:38 <MrsB> who's here?
19:05:54 * Latte is here
19:06:02 * Edux_099 is here
19:06:21 <DavidWHodgins> I'm here, with my cat, Malone, who just got my my lap to watch the screen.
19:06:29 <MrsB> lol ever helpful
19:06:38 <DavidWHodgins> Yep.
19:06:54 <MrsB> ready for the first topic then..
19:07:21 <MrsB> #topic Who's new?
19:07:31 <MrsB> sooo who's new?
19:07:39 <MrsB> N9NU is new
19:08:07 <MrsB> morning alfred__
19:08:26 <MrsB> It doesn't look like N9NU is here though
19:08:35 <alfred__> morning MrsB, sorry for beeing late hat to rebbot meanwhile
19:08:40 <MrsB> it's ok
19:09:06 <MrsB> ok lets cut who's new short and move on, he may come on later on
19:09:17 <MrsB> what was next?
19:09:28 <DavidWHodgins> #topic Which ISOs we will now have
19:09:41 <MrsB> thankyou :)
19:09:52 <MrsB> Did you all see the email the other day?
19:10:00 <Edux_099> yes
19:10:03 <alfred__> yep
19:10:12 <MrsB> I'll add some info's here anyway
19:10:58 <MrsB> #info after the consultation period a list of ISOs we will have in Mageia 3 was decided and passed down to council on Monday
19:11:43 <MrsB> #info The new list incorporates alot more Nonfree 'stuff' which should help with hardware support
19:11:57 <MrsB> #info we will now have..
19:13:21 <MrsB> #info 2 Live CD's - 1 Gnome i586 and 1 KDE i586 - both english only and Nonfree - One language helps to fit more desktop on the CD
19:14:35 <wassi232> yep
19:14:35 <MrsB> #info 4 Live DVD's - 2 Gnome (i586 & x86_64) and 2 KDE (i586 & x86_64) - All languages - Nonfree
19:14:41 <MrsB> sorry slow typing tonight
19:15:59 <MrsB> #info 2 Installer DVD's as before (1 i586 & 1 x86_64) - These will change though to enable the use of nonfree if desired. Not sure how yet but it will be on the disk.
19:16:17 <MrsB> #info also the LXDE Dual arch CD
19:16:53 <MrsB> #info also after release there will be at least one vdi virtual machine image
19:17:09 <MrsB> phew, alot of thinking :\
19:17:30 <MrsB> Any questions on all of this?
19:18:08 <DavidWHodgins> Ok to delete the x86-64 cd files, or are they still on rabbit, so they'll rsync again, if deleted?
19:18:24 <alfred__> sorry but having live CD seems obsolete to me
19:18:31 <MrsB> I'm not sure if they are still there, don't think so, but they are now obsolete
19:18:50 <DavidWHodgins> The live cd images are needed for magazine distribution.
19:18:50 <MrsB> Check with --list-only Dave
19:19:00 <DavidWHodgins> Wlll do.
19:19:14 <alfred__> well as give-aways the DVD would be better
19:19:23 <Edux_099> I have a live cd with Mageia 2 x86_64 KDE
19:19:33 <Edux_099> I like it because it fits in a cheap cd
19:19:46 <Edux_099> dvd is more expensive
19:19:49 <MrsB> I think the CD's are just easier and cheaper to make
19:19:54 <alfred__> no not rally
19:20:00 <MrsB> they can be handed out at shows and things
19:20:03 <Edux_099> yeah
19:20:14 <DavidWHodgins> Much better to get a usb stick that can be reused many times.
19:20:22 <MrsB> there are livedvd's too though so you have a choice
19:21:03 <alfred__> i think we shouldn't discuss this further
19:21:05 <MrsB> the livedvd's will not be full dvd's. When all the languages are included they currently come out about 1Gb
19:21:29 <DavidWHodgins> The list-only shows the x86-64 cd directories are gone, so safe to delete local copies.
19:21:59 <MrsB> #info It is safe to delete any x86_64 Live CD's you have as they are now obsolete
19:22:27 <MrsB> Anything else on this topic?
19:22:46 <MrsB> oh yes..
19:22:48 <DavidWHodgins> Not here.
19:23:15 <Latte> no
19:23:19 <alfred__> no
19:23:24 <MrsB> #info Upgrades WILL be supported with the Installer DVD's but obviously not all packages can fit on a DVD.
19:23:50 <wassi232> no
19:24:05 <MrsB> ok then disco dave do your thing!
19:24:18 <wassi232> MrsB: why are updates from DVD still supported?
19:24:20 <DavidWHodgins> I was thinking about that.  Might be better if the installer, when used for upgrade of a system that has network stuff defined, default to auto adding online repositories.
19:24:40 <MrsB> People wanted it wassi232
19:24:51 <wassi232> last time I heard about this consensus seemed to be it would be dropped for causing too many problems
19:24:52 <Luigi12_work> even for new installations adding network media via the mirror list would be nice
19:24:55 <wassi232> and being hard to test
19:25:06 <wassi232> ok
19:25:20 <DavidWHodgins> It's easy to do manually, but would be better if automated.
19:25:25 <Luigi12_work> yep
19:25:43 <MrsB> Feel free to make the suggestion, I'll raise it at council if you like too
19:25:56 <MrsB> send a message to qa-discuss for now
19:26:24 <MrsB> ennael: ping?
19:26:34 <DavidWHodgins> #action DavidWHodgins will email qa-discuss regarding auto enabling online repositories, when upgrading.
19:27:03 <MrsB> nobody home :) lets move on for now
19:27:07 <DavidWHodgins> That would make it more like the first boot after installing from live.
19:27:12 <MrsB> yeah
19:27:24 <DavidWHodgins> #topic Luigi's Roundup
19:27:40 <MrsB> Over to you david
19:27:59 <Luigi12_work> the only security update in QA is apache, but there's a PHP bugfix update, so test them at the same time to save yourselves some work
19:28:13 <MrsB> good advice
19:28:20 <Luigi12_work> probably not gonna be a lot more security udpates unless I get some help
19:28:26 <MrsB> #info the only security update in QA is apache, but there's a PHP bugfix update, so test them at the same time to save yourselves some work
19:28:41 <DavidWHodgins> I'll work on those two after the meeting, before I get back to iso testing.
19:28:41 <MrsB> whats the problem Luigi12_work?
19:29:00 <Luigi12_work> main problem is package maintainers aren't contributing much to the cause
19:29:16 <Luigi12_work> I'm getting busier at work and it's harder to justfiy working on packages I/we don't use
19:30:11 <MrsB> Perhaps you could come to council meeting on monday, now there are the beginnings of a real sec team
19:30:22 <Luigi12_work> I'll be teaching the next two weeks
19:30:29 <Luigi12_work> working 10-11 hour days
19:31:02 <MrsB> I'm happy to pass on any message you'd liek to pass on
19:31:27 <Luigi12_work> well I guess "Mageia" as a whole needs to decide what support really means
19:31:38 <Luigi12_work> we started off not wanting to carry over the main/contrib distinction from Mandriva
19:31:49 <Luigi12_work> where only main was officially supported
19:32:04 <MrsB> everything is supported is my understanding
19:32:08 <Luigi12_work> and that's all well and good to have everything supported, but we're not doing our users any favors when we say we support everything and we really can't
19:32:36 <MrsB> it shouldn't be being left to one person to provide all updates
19:32:46 <Luigi12_work> yeah, and too many people only want to work on Cauldron
19:32:51 <MrsB> it's a mdv hangover I think
19:33:09 <Luigi12_work> yes, former mdv packagers are used to Oden doing all the stable release support
19:33:34 <MrsB> We're struggling against tradition :\
19:33:53 <MrsB> It needs to be raised then
19:34:05 <MrsB> packagers meeting or council, whichever
19:34:34 <MrsB> could you attend either of those?
19:34:50 <Luigi12_work> not in the next two weeks
19:34:59 <MrsB> maybe an email to ennael to get the ball rolling
19:35:11 <Luigi12_work> I'll try to be on IRC but probably won't be available much, especially next week
19:35:22 <Luigi12_work> actually Monday is a holiday
19:35:25 * Luigi12_work just remembered that
19:35:28 <MrsB> It's not something we should just ignore. It's not fair on you and not good for Mageia to do so
19:35:48 <Luigi12_work> what time is the meeting Monday?
19:35:55 <MrsB> same time as this one
19:36:05 <Luigi12_work> ok I might be able to swing that then
19:36:34 <Luigi12_work> packagers meeting on Tuesday I won't be available for sure though
19:36:39 <MrsB> that'd be good. As future sec team leader (probably) you should maybe be on council anyway
19:36:42 <Edux_099> "Monday is a holiday" here too
19:37:00 <Luigi12_work> yeah not sure why it's a holiday, happy October 8th?
19:37:13 <MrsB> works for me :D
19:37:17 <DavidWHodgins> Thanksgiving here.
19:37:28 <Luigi12_work> Thanksgiving is late November here
19:37:35 <MrsB> i thought thanksgiving was novenber usually?
19:37:39 <MrsB> ahh
19:37:40 <Luigi12_work> we also have Halloween in late October
19:37:51 <DavidWHodgins> In the states, yes.  In Canada, October.
19:37:59 <MrsB> never knew that
19:38:19 <MrsB> so I'll set an action..
19:38:22 <DavidWHodgins> Get's cold sooner here, than in most of the states, so our harvest is done.
19:38:46 <Luigi12_work> anyway, anyone have any questions for me?
19:38:54 <DavidWHodgins> Nope.
19:38:57 <alfred__> no
19:38:58 <MrsB> #action Luigi12 to email ennael and try to attend council on Monday regarding cooperation from packagers with security updates.
19:39:04 <lemonzest> http://pkgsubmit.mageia.org/ on this page it would be a good idea to colour each branch a diff colour for easy viewing
19:39:06 <[mbot> [ Build system status ]
19:39:14 <lemonzest> 1/2/cauld
19:39:31 <Luigi12_work> lemonzest: something to make it stand out would be nice, if you have suggestions, talk to rda when he's on
19:39:36 <lemonzest> but then tere is colours for failed, sucsess
19:39:46 <lemonzest> Luigi12_work: yeah
19:39:50 <Luigi12_work> yeah I wouldn't want to mess too much more with colors
19:39:52 <MrsB> yes, rda is the man to talk to for that lemonzest
19:39:57 <lemonzest> thanks
19:40:07 <Luigi12_work> ok, cool beans everyone
19:40:12 <lemonzest> makes it a pain tho looking for new packages for 2 tho
19:40:13 <MrsB> thanks Luigi12_work
19:40:22 <lemonzest> Luigi12_work: Meep
19:40:29 <DavidWHodgins> #topic ISO Testing, how's it going?
19:40:45 <MrsB> right yes..
19:41:07 <DavidWHodgins> I've synced todays updates, but haven't tested them yet.
19:41:08 <rindolf> Well, I've ran into some issues testing the ISOs on VBox.
19:41:21 <MrsB> we are having issues with Live ISOs it seems
19:41:34 <alfred__> tested today KDE-live-DVD and install DVD both x86_64
19:41:45 <alfred__> the latter runs like a charme
19:42:08 <alfred__> but live DVD as Claire said
19:42:12 <MrsB> #info Could everybody please make use of the pad so we know where we are with testing
19:42:30 <alfred__> did my comments in the pad
19:42:35 <MrsB> thanks :)
19:43:05 <MrsB> The 64 bit DVD could do with testing
19:43:12 <DavidWHodgins> http://bn.parinux.org/p/mageia3alpha2archive
19:43:13 <[mbot> [ Etherpad Lite ]
19:43:17 <MrsB> oh, you say you've done that
19:43:40 <MrsB> alfred__: did you install from the livedvd or the installer dvd
19:44:25 <MrsB> Mageia-3-alpha2-x86_64-DVD.iso still needs some love :)
19:44:45 <MrsB> that link is to the archive DavidWHodgins
19:44:53 <DavidWHodgins> Oops.
19:45:00 <alfred__> oh, yes i see left no comment for install dvd
19:45:17 <MrsB> How is everybody getting on with ISO testing?
19:45:36 <MrsB> I realise it's alot of work
19:45:43 <DavidWHodgins> http://bn.parinux.org/p/mageia3alpha2
19:45:44 <[mbot> [ Etherpad Lite ]
19:45:48 <MrsB> thanks
19:46:07 <alfred__> well idid an install from within live-session and later on an istall with install dvd
19:46:34 <alfred__> the comments in pad are for live dvd
19:46:55 <MrsB> When we say Install DVD we usually mean the classic installer, the livedvd installation is somewhat different
19:47:02 <DavidWHodgins> All of my installs on real hardware, are being done with encrypted root.  Have to test todays updates later, to see if dual is working ok now.
19:47:26 <alfred__> i only work with real hw
19:47:30 <MrsB> yes, please Dave. I've never played with encryption
19:48:16 <alfred__> isn't the luks module blacklisted in live dvd?
19:48:28 <MrsB> We had alot of people volunteer for ISO testing but relatively few have actually done any. How can we improve that, any ideas?
19:49:00 <DavidWHodgins> Only so that it doesn't ask for passphrases when booting into live mode.  You can still manually open an encrypted filesystem, or install onto one.
19:49:38 <alfred__> ah, ok
19:49:52 <swecarp> MrsB:  i did volounter but havent donne anny testing beuccose hardewear trubbel
19:50:13 <Edux_099> I won't get my new disk because we deciced to get a new borzoi puppy, so I will have to wait 2 months...
19:50:33 <DavidWHodgins> Lol.
19:50:42 <MrsB> We had loads of people join recently to do ISO testing though
19:50:52 <MrsB> Ohh puppise!
19:50:56 <MrsB> puppies too
19:51:02 <DavidWHodgins> You really only need about 10 gb of space for testing, and just keep reusing the same partition for each test.
19:51:05 * MrsB struggling now
19:51:32 * Edux_099 Only has 5 gb free space
19:51:36 <Edux_099> ;)
19:52:09 <alfred__> you can do also an install to external disks
19:52:20 <MrsB> yes, even USB sticks
19:53:14 <alfred__> and for live testing no hd-space is necessary
19:53:31 <DavidWHodgins> Except for a place to download the iso images to.
19:53:39 <alfred__> yeah
19:53:39 <Latte> one can sync also just single CDs/DVDs correct?
19:53:40 <Edux_099> I tried with USB sticks for live cd, but it didn't work with dd nor unn... something like that
19:54:06 <Edux_099> "Except for a place to download the iso images to." That is my problem
19:54:10 <DavidWHodgins> unetbootin.  Don't use it. Just dd if=nameof.iso of=/dev/sd? bs=1M
19:54:47 <Latte> right now I have only very limited internet connection, so I will try to sync at least one DVD this night
19:54:59 <Edux_099> I can only test cd live on windows using a hard disk from another computer with virtual box
19:55:22 <MrsB> thanks Latte
19:55:28 <Edux_099> windows homegroup option
19:56:11 <Latte> It feels here like in the 90ties with 56k modem :(
19:56:33 <MrsB> #info Please everybody, we need your tests on the ISOs :) Do what you can..
19:56:48 <DavidWHodgins> Try 300 baud back in the 80's. :-)
19:56:55 <MrsB> I hate internet problems, it feels like losing an arm
19:57:08 <Latte> I'm too young to remember ;)
19:57:18 <MrsB> ohh yeah, me too ;)
19:57:57 <MrsB> so is there anything else on ISO testing ?
19:58:01 <Edux_099> I will leave apache and php testing for David :), I will start downloading some isos right now.
19:58:13 <MrsB> thankyou Edux_099 :)
19:58:14 <DavidWHodgins> Nothing else here.
19:58:21 <wassi232> yes, MrsB
19:58:26 <wassi232> although not strictly related
19:58:35 <MrsB> go on..
19:58:39 <wassi232> I think now would be a good time to remember packagers to test their packages
19:58:48 <wassi232> because if we find an error after release
19:58:54 <wassi232> and we have to release an update
19:59:01 <wassi232> it has to go through QA
19:59:07 <MrsB> lol]
19:59:09 <wassi232> meaning more work for us and for them
19:59:24 <wassi232> After the release of MGA2 there were programs packages which wouldn't even start
19:59:42 <MrsB> Well, we're still a way off from final release, it isn't until March next year but it's a good point
19:59:44 <wassi232> because of a wrong/missing dependency/path mainly
19:59:57 <wassi232> so this could easily be avoided
20:00:29 <wassi232> oh, March, really?
20:00:30 <DavidWHodgins> A lot of those were system units, the developers didn't know how to set up properly.  That should be in the past now.
20:00:32 <MrsB> everything will change as new versions land in cauldron, we can cerainly do so later on when it gets towards the freeze
20:00:36 <wassi232> sorry, I thought it was quite a bit closer
20:00:42 <Edux_099> downloading Mageia-3-alpha2-i586-DVD
20:00:49 <DavidWHodgins> When is version freeze?
20:00:58 <MrsB> there are 3 alphas, 2 or 3 beta's and an RC before final
20:01:05 <wassi232> ok, so we should probably wait... but still I think it would be a good idea to remind packagers
20:01:22 <wassi232> I understand that they mainly package for cauldron where such errors easily go unnoticed
20:01:30 <MrsB> yep, I think it's maybe a bit premature just now though, good suggestion though wassi232
20:01:51 <DavidWHodgins> #topic Anything else?
20:02:06 <MrsB> thanks dave
20:02:09 <DavidWHodgins> Changing topic, since we're already into the next topic.
20:02:12 <MrsB> Is there anything else?
20:02:19 <DavidWHodgins> Not here.
20:02:24 <wassi232> not here
20:02:24 <Edux_099> nop
20:02:27 <alfred__> no nothing
20:02:27 <MrsB> it feels like bedtime
20:02:45 <Edux_099> here is 17:02
20:02:53 <DavidWHodgins> 16:02 here.
20:02:54 <Edux_099> bedtime???? lol
20:02:58 <MrsB> 21:02 here, been a long week
20:03:27 <MrsB> ok if there  is nothing else lets bring the meeting to a close
20:03:31 <alfred__> 6 hrs more to test, Dave ;)
20:03:42 <Edux_099> lol
20:03:51 <MrsB> thankyou all for coming, please keep on testing, same time next week :)
20:03:55 <MrsB> #endmeeting