19:06:38 <MrsB> #startmeeting
19:06:38 <Inigo_Montoya> Meeting started Thu Jul 19 19:06:38 2012 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:38 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:06:44 * led43_Mag1 trying to get a printer to work so may swap from mag1 -> mag2 from time to time
19:06:59 <MrsB> So , morning qa, thatnkyou all for coming
19:07:03 <MrsB> -t
19:07:32 <MrsB> Is there anybody here who feels they need some mentoring?
19:08:02 <Kernewes> I'm going to stick to the easy stuff
19:08:20 <MrsB> I've been neglecting the easy bugs emails again, sorry :\
19:08:33 <Kernewes> you can't do everything
19:08:41 <stblack> I need mentoring
19:08:48 <led43_Mag1> I do
19:09:08 <MrsB> #info stblack and led43 need mentoring
19:09:22 <MrsB> We can begin some tomorrow maybe
19:09:32 <MrsB> will either of you be available?
19:10:07 <led43_Mag1> froim the late afternoon after wards
19:10:12 <led43_Mag1> *from
19:10:18 <MrsB> how late?
19:10:30 <led43_Mag1> 2/3pm onwards
19:10:50 <MrsB> that should be OK, if not then lets say we will start on Monday?
19:11:08 <MrsB> how about you stblack?
19:11:09 <stblack> I'll be not available all the day. during work quite less, afternoon-evening yes
19:11:47 <MrsB> I might have to ask stormi or dave h to help
19:11:56 <Led43_Mag2> that would be ok for me F afternoon or Monday
19:12:23 <MrsB> #info led43 is available for being mentored from 1-2UTC onwards
19:12:41 <MrsB> #info stblack is available 6-7 UTC
19:12:57 <MrsB> we'll have to get started with that :)
19:13:16 <MrsB> #info MrsB will send an Easy Bugs email in the morning
19:13:22 <stblack> ok thanks
19:13:25 <MrsB> so.. first topic..
19:13:34 <Led43_Mag2> ok
19:13:47 <MrsB> #topic Mageia 3 Features Update
19:13:57 <MrsB> Some news to keep you all in the loop :)
19:14:33 <MrsB> As you know from last time, the deadline for deciding Mageia 3 features was last Friday
19:15:01 <MrsB> Since then the proposals have been discussed and they have been sorted into 4 categories
19:15:49 <MrsB> #link https://wiki.mageia.org/en/FeatureMageia3_Review This is where you can see the proposals sorted into 4 categories
19:16:51 <MrsB> The first are proposals which have been fully completed and we have the resources etc to fulfill them. They are ready to start or have already been started.
19:17:59 <MrsB> The second one is a list with features complete but missing resources - meaning it may be started if we do get the resources to go ahead with it.
19:18:08 <Berxwedan> Feature:NvidiaOptimusSupport <<--- Support planned in upstream kernel before Mageia 3 is released.
19:18:18 <Berxwedan> is this really correct?
19:18:32 <MrsB> The third one is a list of features that needs to be completed
19:18:51 <MrsB> The 4th have been rejected, for various reasons.
19:19:00 <Berxwedan> xorg.server and kernel 3.5/3.6 will have optimus okey support.. bumblebee.. what is left
19:19:29 <MrsB> what do you mean Berxwedan?
19:19:59 <Berxwedan> MrsB: mean why should not we have nvidia optimus support for mageia 3
19:20:20 <Berxwedan> https://wiki.mageia.org/en/FeatureMageia3_Review <<<-- reading this
19:20:37 <MrsB> The optimus one is in the list of accepted features.
19:21:39 <MrsB> Any questions or comments on these?
19:22:11 <Berxwedan> MrsB: okey. if it is supported, then I do not have any question.
19:22:14 <Led43_Mag2> no Q from here
19:22:38 <stblack> no questions
19:22:48 <Kernewes> nothing from mer
19:22:50 <Kernewes> me
19:23:00 <MrsB> Anything in the 2nd list can still be accepted btw if the resources are found to do it
19:23:08 <MrsB> Also..
19:23:27 <MrsB> #info there will be a blog post about this and the process to select them
19:23:48 <MrsB> moving on then :)
19:23:54 <MrsB> #topic A Quick ARM Update
19:24:09 <MrsB> It will only be quick as there is still not much to tell
19:24:10 * Led43_Mag2 all ears
19:24:25 <MrsB> as you may know rtp is working on rebuilding cauldron for arm
19:25:01 <MrsB> he is working on a script to do technical stuff with the build system
19:25:09 <Led43_Mag2> have we now got the arm add on board for the build system?
19:25:40 <MrsB> not sure, I didn't know it needed one
19:26:05 <MrsB> rtp is currently taking the x86_64 packages and rebuilding them for ARM
19:26:21 <tmb> yes, we have 2 arm build nodes
19:26:24 <MrsB> He is working on the 'bootstrap'
19:26:38 <MrsB> do they need an addon board tmb?
19:26:48 <Led43_Mag2> i thought they needed an add on arm board for the build server, i may have been wrong
19:26:57 <MrsB> ohh
19:27:03 <MrsB> no they are two separate servers
19:27:17 <coincoin> 2 boards imx53 (loco)
19:27:33 <MrsB> In case you're wondering what a 'bootstrap' is like I was..
19:27:58 <MrsB> #link http://blog.mageia.org/en/2011/02/02/bootstrap-what-bootstrap-i-want-mageia-iso/ this is what bootstrap means :)
19:27:59 <[mbot> [ Bootstrap? What bootstrap? I want Mageia ISO! | Mageia Blog (English) ]
19:28:25 <Led43_Mag2> coincoin: can i set up 1 of my pc's for packaging arm stuff?
19:28:54 <stblack> Qemu can be useful I believe
19:29:23 <MrsB> #info Arm support is still 'experimental' so not yet sure of the impact on QA.
19:29:32 <Led43_Mag2> ok never used qemu, just vbox & vmplayer
19:29:45 <tmb> you need either arm hw, or qemu
19:30:05 <MrsB> maybe the board will buy us all an arm board to test with ;)
19:30:14 <Led43_Mag2> yes we will have to put together a qa policy for arm
19:30:41 <MrsB> well, if we do end up testing on arm then it will just be another architecture I think
19:31:04 * Led43_Mag2 has a raspberry pi on santa's list for next xmass
19:31:05 <MrsB> so i586, x86_64 & arm
19:31:21 <coincoin> arm v7 to be precise :)
19:31:32 <MrsB> you, me and 1000's of others :D
19:31:43 * Led43_Mag2 was just about to ask what chip version
19:31:52 <MrsB> we can cross that bridge when we come to it though
19:32:01 <coincoin> Led43_Mag2: <coincoin> 2 boards imx53 (loco)
19:32:05 <coincoin> ;)
19:32:16 <MrsB> there may well be an arm version of Mageia 3 though :)
19:32:32 <coincoin> MrsB: no, there will be :)
19:32:41 <Kernewes> but then Mageia 1 support will stop won't it?
19:32:50 <MrsB> #info there will definitely be an ARM version of Mageia 3
19:32:53 <Led43_Mag2> we all hope
19:32:54 <coincoin> :)
19:33:10 <MrsB> great news :)
19:33:26 <Led43_Mag2> how many qa people have arm cpu to run tests?
19:33:32 <MrsB> I'll keep you all informed of news as I find it
19:33:43 <MrsB> right now, none I would imagine
19:34:03 <coincoin> Led43_Mag2: it's just recompilation for ARM, so... package will be the same as on x86
19:34:22 <coincoin> but compiled on ARM BS
19:34:49 <coincoin> so if there is a bug on x86, the bug will be on ARM, and the contrary
19:34:58 <MrsB> next topic then, we'll keep track of this one though :)
19:35:09 <coincoin> k
19:35:09 <Led43_Mag2> coincoin: so we can test in vm with qemu or run mag3 on our raspberries?
19:35:28 <coincoin> Led43_Mag2: for example
19:35:52 <coincoin> raspeberry Pi is old ARM v5 so, it will works with an ARM v7 compiled distro
19:36:14 <MrsB> I vote for MagPi
19:36:22 <Kernewes> lol
19:36:39 <Led43_Mag2> MrsB: +1
19:36:39 <MrsB> It's a species of bird in English
19:36:51 <Luigi12_work> hi, I can only stay for a minute.  Can I give a quick roundup?
19:37:00 <MrsB> Sure Luigi12_work one sec
19:37:09 <MrsB> #topic Luigi's Roundup
19:37:12 <MrsB> all yours
19:37:17 <Luigi12_work> thanks
19:37:25 <Luigi12_work> most recent mail is https://ml.mageia.org/l/arc/qa-discuss/2012-07/msg00109.html
19:37:26 <[mbot> [ qa-discuss - Discussions about QA tasks and requests - arc_protect ]
19:37:31 <MrsB> thankyou :)
19:37:42 <Luigi12_work> nothing has been added since then, Firefox, Thunderbird, and Busybox are finished
19:38:00 <Luigi12_work> so the other ones there would be the highest priority security updates left
19:38:08 <Luigi12_work> after that, I would just say "oldest first"
19:38:13 <Luigi12_work> any questions for me?
19:38:28 <MrsB> Would you mind doing a new one on the ML?
19:38:54 <Luigi12_work> next time there's a priority one to add, I'll send a new mail
19:39:04 <MrsB> Ok sounds good, thanks
19:39:09 <MrsB> I think it is helping
19:39:15 <Luigi12_work> actually in the middle of teaching at the moment :o)
19:39:23 <MrsB> Okay, thanks for coming then
19:39:23 <Luigi12_work> that's good to hear
19:39:28 <Luigi12_work> ok, see you all later
19:39:32 <MrsB> o/
19:39:42 <coincoin> ciao Luigi12_work
19:39:55 <Led43_Mag2> Luigi12_work: thanks
19:40:27 <MrsB> #info https://ml.mageia.org/l/arc/qa-discuss/2012-07/msg00109.html is the most recent priority updates mail
19:40:28 <[mbot> [ qa-discuss - Discussions about QA tasks and requests - arc_protect ]
19:40:42 <MrsB> #info nothing has been added since then, Firefox, Thunderbird, and Busybox are finished
19:40:58 <MrsB> #info so the other ones there would be the highest priority security updates left
19:41:42 * sebsebseb idles here
19:41:43 <MrsB> #info after that, "oldest first". He'll send a new mail when something needs to be added.
19:41:52 <MrsB> hi sebsebseb
19:42:08 <sebsebseb> hi
19:42:11 <MrsB> any questions on luigi's roundup?
19:42:53 <MrsB> moving on then :)
19:42:59 <MrsB> #topic Missing Mandriva 2010 Packages
19:43:15 <MrsB> As you may have seen, there was some discussion recently about this
19:43:58 <Kernewes> you mean memtester and stuff like that?
19:44:07 <MrsB> You maybe know already that there is an exclusion in our updates policy to allow packages which were in Mandriva 2010 at the time of the fork to be brought into Mageia as updates if they were missed rather than backports.
19:44:32 <MrsB> yes, there were two packages which raised a question
19:44:36 * led43_Mag1 the more packages the better AS long as we can support them QA wise
19:44:45 <MrsB> chocolate-doom was one and the other was inxi
19:45:03 <Kernewes> oh yes
19:45:19 <MrsB> What was different about these two was that they only appears in mdv2010 as backports, they were not in Release or Updates medias
19:45:25 <led43_Mag1> doom - the shoot em up?
19:45:37 <MrsB> its a game engine for that yes
19:45:46 <led43_Mag1> ok
19:46:15 <MrsB> This isn't something we in QA could simply decide for ourselves so this was discussed at council with the other teams
19:46:40 <MrsB> The outcome was that they can indeed be allowed in as normal updates rather than backports.
19:46:54 * led43_Mag1 doom is to blame for my pc knowledge quest
19:47:08 <MrsB> #info the packages which were only in backports qualify for the exclusion in the updates policy
19:47:16 * Kernewes didn't dare test chocolate-doom, would have had nightmares
19:47:21 <coincoin> led43_Mag1: :)
19:47:25 <led43_Mag1> 2/3 aps won't brake the bank
19:47:33 <coincoin> Kernewes: just do it \o/
19:47:46 <MrsB> #link https://wiki.mageia.org/en/Updates_policy This is our updates policy in case you've not seen it
19:48:23 <MrsB> any questions or comments on this?
19:48:25 * led43_Mag1 has read it but will check it for updates
19:48:51 <Kernewes> don't quite understand
19:48:57 <MrsB> which bit?
19:49:00 <Kernewes> if they were only backports in Mdv
19:49:15 <Kernewes> why are they being treated as important omissions from Mga?
19:49:51 <MrsB> When the fork happened not everythign could be brought into mga, simple due to resources
19:49:56 <Kernewes> ok
19:50:18 <MrsB> the exclusion was made to allow things to be brought in as people found them missing and asked for them
19:50:29 <MrsB> morning DavidWHodgins
19:50:36 <DavidWHodgins> HiYa
19:50:41 <coincoin> Kernewes: backport in Mandriva meant we hadn't the time to care about this package so it was handle by community
19:50:52 <Kernewes> ok
19:51:01 <coincoin> not that the package was not important
19:51:05 <Kernewes> I see
19:51:06 <Kernewes> thank you
19:51:12 <coincoin> yw
19:51:16 <MrsB> Thankyou coincoin :)
19:51:34 <MrsB> any other questions or comments?
19:51:51 <DavidWHodgins> Is the meeting already in progress?
19:52:00 <MrsB> for 51 minutes :P
19:52:21 <DavidWHodgins> Oops. Sorry, my mistake.  Sorry for being late.
19:52:31 <MrsB> You get your utc's mixed up?
19:52:37 <DavidWHodgins> Yep.
19:52:50 <MrsB> you can add utc to your clock in kde
19:53:15 <stblack> may I know what http://check.mageia.org/2/ is ?
19:53:16 <[mbot> [ QA global report ]
19:53:17 <MrsB> in the clock options, right clicky
19:53:44 <MrsB> Miand if we come back to that later stblack?
19:53:48 <MrsB> mind*
19:54:14 <stblack> no. it's ok ?
19:54:18 <stblack> 1
19:54:20 <stblack> !
19:54:30 <MrsB> yeah, we can ask coincoin at the end
19:54:58 <MrsB> #topic Backports revisited again
19:55:29 <MrsB> Your team leaders were useless last week and hadn't done what they said they would :\
19:55:45 <DavidWHodgins> Lol
19:56:09 <MrsB> I've been working on the backports validation procedure today though \o/
19:56:34 <MrsB> #link https://wiki.mageia.org/en/QA_process_for_validating_backports See what you think! It is not complete yet.
19:57:27 <MrsB> #info If you notice anything missing or mistakes either please correct/add them or mention on the ML and I will do so.
19:58:18 <MrsB> #action Stormi is still to update the backports policy when he gets some time
19:58:41 <MrsB> #link https://wiki.mageia.org/en/Backports_policy This is the backports policy page
19:59:08 <MrsB> also, we discussed before about possibly using another ML for backports or something
19:59:11 <Led43_Mag2> MrsB: will do
19:59:30 <MrsB> Did we decide anything about that?
20:00:17 * Led43_Mag2 don't remember a definite decision
20:00:44 * Kernewes neither do I
20:01:16 <DavidWHodgins> If I remember correctly we were going to ask sysadmin team which method do they prefer.
20:01:17 <MrsB> #action MrsB send an email to the ML about new ML for backports or something. We didn't make a decision yet.
20:01:33 <Kernewes> DavidWHodgins: I think you're right
20:01:48 <MrsB> which methods were discussed, can you remember?
20:02:09 <DavidWHodgins> Using existing updates mailing list, or create a new list just for backports.
20:02:30 <MrsB> we wanted to distinguish backports somehow though didn't we
20:02:52 <DavidWHodgins> We also considered auto adding backports to the subject, if using the existing list.
20:03:30 <MrsB> ok, i'll put that in the email to ML and see who is watching :)
20:04:09 <MrsB> #info we'll catch up with Stormi next week hopefully :)
20:04:25 <MrsB> lets move on, nearly done..
20:04:48 <MrsB> #topic Anything else?
20:05:10 <MrsB> #info stblack asked what http://check.mageia.org/2/ is for
20:05:11 <[mbot> [ QA global report ]
20:05:23 <stblack> yes
20:05:29 <MrsB> coincoin: could you explain please?
20:05:37 <MrsB> or tmb?
20:07:16 <MrsB> they've run away :D
20:07:23 <MrsB> ennael: ping?
20:07:41 <ennael> yep
20:07:44 <MrsB> hi :)
20:07:48 <ennael> hi
20:08:03 <MrsB> stblack was asking what this is for http://check.mageia.org/2/
20:08:04 <[mbot> [ QA global report ]
20:08:45 <DavidWHodgins> A quick glance shows the missing is inconsistencies between the source and binary repositories, and I think the Mandriva part is showing packages that are newer in 2010.2 than Mageia 2.
20:09:15 <ennael> yep
20:09:34 <ennael> update page helps maintainers to check if there is newer version available
20:10:06 <Berxwedan> is there any plan to support mageia 3 more then 18 month
20:10:07 <Berxwedan> ?
20:10:18 <stblack> ennael thanks
20:10:27 <MrsB> yes, thankyou :)
20:10:51 <MrsB> Berxwedan: Not at the moment, we really need more people to be able to do that
20:11:14 <stblack> and Mageia 1 end of life ?
20:11:17 <ennael> Berxwedan: decision is not taken while we do not have people enough in QA and secteam
20:11:22 <MrsB> i think it's something everybody would like to do though
20:11:24 <Berxwedan> MrsB: okey. I hope more will join, now when distrowatch is ranking us high :).
20:11:39 <ennael> stblack: count 18 months
20:11:42 <DavidWHodgins> Having a long term release would mean having to do and qa updates for three releases at the same time.
20:11:54 <Kernewes> DavidWHodgins: ouch
20:12:01 <MrsB> we're struggling with just two
20:12:17 <Kernewes> and if we get ARM as well
20:12:33 <Berxwedan> I understand. 18 month is good start.
20:12:44 <ennael> stblack: should be 2013/12/01
20:13:01 <MrsB> we may need to rethink the 18 months even if ISo testing starts to cause delays wqith updates
20:13:08 <MrsB> ISO*
20:13:22 <Berxwedan> MrsB: mandriva seems to base there server edition on mageia, maybe there developer and people can work with us
20:13:30 <Berxwedan> or they maybe aldready do?
20:13:42 <ennael> unfortunatelly their team is quite small
20:14:02 <MrsB> I think some have been, but personally I think we've come under pressure from it aswell
20:14:19 <Berxwedan> ennael: okey that sound weird with a company behind them I expected big team.
20:14:38 <MrsB> It is community now though
20:14:39 <ennael> it has decreased a lot this last 2 years
20:14:44 <Kernewes> Berxwedan: the company bit never was secure, that's why we have Mageia
20:15:20 <MrsB> sooo, anything else while we're here?
20:15:35 <Berxwedan> Kernewes: +1. I thought with financial support more developer would join.. anyway.. 18 month is good start.. I hope more wiill join mageia
20:15:51 <Kernewes> Berxwedan: so do I
20:16:43 <MrsB> #info Berxwedan (Ezim) asked about the possibility of an LTS release for Mga 3
20:17:09 <MrsB> shall we close or is there anything else?
20:17:11 <stblack> what about the QA statistics we spoke on ML ?
20:17:30 <MrsB> lets discuss it further on the ML?
20:17:39 <DavidWHodgins> I don't know of any easy way to gather such stats.
20:18:04 <MrsB> #info stblack asked about the statistics discussion from the ML
20:18:08 <stblack> explore other distro
20:18:12 <Kernewes> you can interpret stats any way you like anyway
20:18:42 <MrsB> it would be nice to see some graphs :)
20:19:00 <MrsB> so, lets cloe for today
20:19:05 <MrsB> close even
20:19:06 <coincoin> back
20:19:20 <stblack> Bye
20:19:33 <MrsB> Thankyou all for coming! Same time next week :)
20:19:39 <Kernewes> thank you
20:19:41 <MrsB> #endmeeting