19:03:31 <MrsB> #startmeeting
19:03:31 <Inigo_Montoya> Meeting started Thu Jul  5 19:03:31 2012 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:31 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:53 <MrsB> Morning QA, thankyou for coming
19:04:19 <MrsB> a quick word on how this works in case anybody hasn't used it before
19:04:48 <MrsB> anybody can add an info line in the meeting notes by using the #info command
19:04:56 <MrsB> #info this is how you use the info command
19:05:18 <MrsB> so first topic..
19:05:31 <MrsB> #topic A quick ARM update
19:06:11 <MrsB> It was mentioned in the packagers meeting that some progress is being made towards being able to produce an ARM build for Mageia \o/
19:06:45 <MrsB> The logs are here is anybody is interested..
19:06:49 <MrsB> http://meetbot.mageia.org/mageia-dev/2012/mageia-dev.2012-07-04-19.08.log.html#l-288
19:06:50 <[mbot> [ #mageia-dev log ]
19:07:31 <led43_Mag1> that will be interesting, but we will need qa policy sorted for qa-ing the arm branch
19:07:38 <MrsB> there are still a few bits to be sorted out with the build system but as alot of people are starting to get their raspberry pi's it's becoming asked for
19:07:46 <MrsB> yes we will
19:08:08 <MrsB> #info we need to sort out qa for ARM when it gets nearer the time
19:08:39 * led43_Mag1 mine is on my santa's letter
19:08:41 <DavidWHodgins> Is there a reasonable arm emulator we can use?
19:08:45 <MrsB> In case you've been living in a bucket this is the raspberry pi
19:08:47 <MrsB> http://www.raspberrypi.org
19:08:48 <[mbot> [ Raspberry Pi | An ARM GNU/Linux box for $25. Take a byte! ]
19:09:08 <MrsB> I think qemu can emulate arm can't it but never looked at it
19:09:26 <Umeaboy> DavidWHodgins: qemu.
19:09:33 <djennings> I have my Pi already
19:09:37 <MrsB> i guess it depends which arm
19:09:41 <MrsB> nice djennings!
19:09:45 <MrsB> how is it?
19:09:53 <Umeaboy> I have pie here to. Blueberry. ;)
19:09:55 <Umeaboy> Yummie.
19:09:56 <Umeaboy> heheh
19:10:05 <djennings> I have arch linux running on it v nicely
19:10:07 <Umeaboy> Yes, I know.
19:10:19 <Umeaboy> I know what Pi is.
19:10:25 <Umeaboy> I was just joking.
19:10:35 <MrsB> i see there are addons for it now too, diy ones anyway
19:11:14 <MrsB> are there any questions or shall we move on, try and keep it short tonight
19:11:37 <Umeaboy> But if we are trying to build Mageia for ARM, couldn't we build it like MeeGo or Android? Menu-system & GUI.
19:11:48 <led43_Mag1> its had a lot of press, mostly good and is getting a large user base, it would be good if we had a mag compatible version
19:11:53 <djennings> only are there updated ARM repositories?
19:12:25 <led43_Mag1> Umeaboy: doupt it it can run any dm
19:12:29 <MrsB> I guess there will be djennings, the build system is still being built but it was being tested with the current x86_64 packages
19:12:51 <Stormi> at one point we will have to decide how we treat ARM arch at QA
19:12:56 <Umeaboy> djennings: There is an unofficial Mageia ARM-image linked on the first blog-page.
19:13:04 <Umeaboy> Or is it second?
19:13:11 <Umeaboy> Some of them any way.
19:13:16 <Umeaboy> led43_Mag1: Huh?
19:13:18 <MrsB> yes, it may be we will request a mageia sponsored pi :D
19:13:59 <MrsB> there isn't much to report as yet but I'll keep you all updated if there is news :)
19:14:01 <DavidWHodgins> At 25 pounds, I'm not worried about the cost.  It's the time it'll take to get it, and the speed of it.
19:14:03 <djennings> The mga1 arm image is v old. An ARM cauldron repo would be nice
19:14:25 <DavidWHodgins> Can it run mkinitrd in under 10 minutes?
19:14:38 <led43_Mag1> djennings: all in good time, lets get a build system up and running first
19:14:42 <MrsB> it runs xbmc quite happily in hd
19:15:01 <MrsB> anyway lets chat after and move on..
19:15:22 <MrsB> #topic A quick recruiting update
19:15:51 <MrsB> I should first thank you all for your hard work. It's a difficult time and we are coming under alot of pressure.
19:16:33 <MrsB> We have had a few new starters recently, two today even \o/
19:16:43 <MrsB> please make them warmly welcome
19:16:51 <Ezim> is this meeting only about arm?
19:16:52 <MrsB> is anybody new here today?
19:17:11 <vcg3rd> I am new
19:17:19 <MrsB> Ezim: no, it's QA
19:17:29 <MrsB> hiya vcg3rd don't be shy :)
19:17:40 <MrsB> Has everybody said hello?
19:17:48 <Ezim> MrsB: okey I think we should have example how validation goes in wiki. good examples.
19:17:51 <MrsB> I'm claire btw
19:17:57 <vcg3rd> Hi
19:18:05 <Ezim> hi btw to you all
19:18:21 <MrsB> are you subscribed to the mailing lists yet vcg3rd?
19:18:36 <Stormi> yes, it's Bo Grimes
19:18:39 <vcg3rd> Yes, both of them, and I'm Bo, btw
19:18:42 <vcg3rd> Yes!
19:18:43 <MrsB> ohhh hi!
19:18:52 <MrsB> well done, I saw you'd had some difficulty
19:19:08 <Umeaboy> Ezim: ARM-discussions should really be held in my unofficial ARM-channel for Mageia.
19:19:12 <Umeaboy> ##mageia-arm
19:19:30 <Ezim> Umeaboy: okey. thx.
19:19:34 <MrsB> if there is anything whatsoever you need or are not sure about please don't hesitate to ask, you're never alone so don't feel stuck with anything
19:19:44 <vcg3rd> OK, thanks!
19:19:51 <Kernewes> vcg3rd: they don't bite - not on Thursdays, anyway
19:19:57 <vcg3rd> :-)
19:20:01 <Stormi> gnap
19:20:02 <MrsB> lol
19:20:04 <Ezim> vcg3rd: MrsB and others in the team are great people. you will like them.
19:20:25 <MrsB> where are you based vcg3rd? just to get an idea of time zones?
19:20:51 <vcg3rd> America, Eastern North Carolina, EST UTC-4 while on daylight savings
19:21:06 <Umeaboy> It just so happens that I'm looking to buy this tablet soon: http://www.prisjakt.nu/produkt.php?p=1245489 :)
19:21:07 <[mbot> [ Asus Transformer Pad Infinity TF700T with Keyboard Dock 64GB - Surfplatta - Hitta l�ta pris, omd� och information ]
19:21:12 <MrsB> I am UK and Stormi in FR but DavidWHodgins and Luigi12 are both US
19:21:14 <Umeaboy> A good test-object.
19:21:15 <DavidWHodgins> Same time zone as me.  I'm in London Ontario, Canada.
19:21:22 <MrsB> Umeaboy: please
19:21:32 <Umeaboy> MrsB: Whuut?
19:21:39 <MrsB> save it for after the meeting pls
19:21:45 <Umeaboy> OK.
19:22:10 <MrsB> DavidWHodgins: would you look after vcg3rd for us?
19:23:24 <DavidWHodgins> Sure.
19:23:42 <Ezim> Umeaboy: :) keep this about QA.
19:23:52 <MrsB> great, thanks. So if you need any help DavidWHodgins is a good person to ask!
19:24:00 <vcg3rd> Thanks!
19:24:53 <MrsB> anyway, you might have seen but there have been posts on the mageia-discuss ML and the forums asking for people
19:25:00 <MrsB> some links..
19:25:09 <vcg3rd> That's where I saw it
19:25:14 <MrsB> https://www.mageia.org/pipermail/mageia-discuss/2012-June/008075.html
19:25:14 <Kernewes> MrsB: saw your forum post
19:25:15 <[mbot> [ [Mageia-discuss] Appeal for people - QA Needs You ]
19:25:24 <MrsB> https://forums.mageia.org/en/viewtopic.php?f=3&t=2910
19:25:25 <[mbot> [ Mageia forum View topic - Appeal for people - QA Needs You ]
19:25:32 <MrsB> thats good to hear :)
19:25:42 <MrsB> Kernewes: are you trying again?
19:25:50 <Kernewes> trying what again?
19:26:04 <MrsB> to do some qa i meant, sorry
19:26:12 <Kernewes> well i want to keep in touch
19:26:18 <MrsB> great :)
19:26:25 <Kernewes> perhaps when the isos are out?
19:26:37 <MrsB> yes we'll need as many eyes as possible then
19:27:22 <MrsB> There is also going to be a blog post featuring yours truly similar to the one Stormi did last year
19:27:27 <Ezim> how many qa-testers do we have for both 32 an 64-bits?
19:27:37 <Stormi> great, another occasion to call for help
19:27:46 <MrsB> yeah!
19:28:02 <MrsB> I'm not sure Ezim really, it varies when people are active
19:28:10 <Stormi> Ezim: it depends, some test all day, others from time to time
19:28:16 <Ezim> okey.
19:28:45 <Ezim> :) I have update-testing always enabled so if there is any easy validation I can help out.
19:28:48 <MrsB> stormi do you have a link to your old post?
19:28:53 <Umeaboy> Everything around Free software depends on free volunteering.
19:28:55 <Umeaboy> ;)
19:29:10 <MrsB> that it does
19:29:59 <MrsB> got it
19:30:01 <MrsB> http://blog.mageia.org/en/2011/10/03/they-make-mageia-samuel-verschelde/
19:30:03 <[mbot> [ They make Mageia: Samuel Verschelde | Mageia Blog (English) ]
19:30:41 <MrsB> I hope they won't need a photo :D
19:30:50 <Ezim> :) lyon coolt.. les bleus
19:31:03 <Stormi> :)
19:31:25 <MrsB> anyway, welocme to the team vcg3rd make yourself aat home and never be afraid to get involved or ask questions.
19:31:31 <Ezim> Stormi: thats you?
19:31:36 <Stormi> Ezim: yes
19:31:44 <Ezim> Stormi: :) cool. nice.
19:31:48 <vcg3rd> OK...I will..thanks
19:32:03 <diogenese> Nice photo :)
19:32:41 <MrsB> so next topic..
19:32:48 <MrsB> #topic Backports Revisited
19:33:02 <MrsB> Did you all see the email?
19:33:22 <Ezim> MrsB and others in the team, do not hesitate if I can help out, when I am online.
19:33:24 <DavidWHodgins> The qa-discuss posting?
19:33:35 <MrsB> yes, i tried to summarise
19:33:55 <Ezim> now I am login out. take care all.
19:34:02 <MrsB> night Ezim
19:34:47 <Stormi> yes, I wrote down some notes for the meeting
19:35:00 <Stormi> nothing big
19:35:01 <MrsB> its all yours then Stormi
19:35:13 <Stormi> first let's remind what backports are
19:35:23 <Stormi> updates are only bugfixes or security fixes
19:35:35 <Stormi> no new versions of software (except when it's the only way to fix bugs)
19:35:58 <Stormi> backports media are where providing new versions for a stable release of mageia is (will shortly be) allowed
19:36:18 <Stormi> they are supported which means QA validates them, although with lower priority than standard updates
19:36:27 <Stormi> and with lighter tests
19:36:47 <Stormi> #info backports policy https://wiki.mageia.org/en/Backports_policy
19:37:13 <Stormi> now, in addition to what was summarized by MrsB in her mail :
19:37:46 <Stormi> I would just like to propose a checklist for backports
19:37:52 <Stormi> when a new backport arrives
19:38:16 <Stormi> that we can put in our future "how to validate a backport" page
19:38:26 <MrsB> yes good idea
19:38:48 <Stormi> most of it is checking the packager followed the policy
19:38:53 <Stormi> - only leaf packages, new packages, or leaf group of packages (no other package depends on them). A script could check that.
19:39:15 <Stormi> - new packages must not obsolete other packages from release or updates
19:39:33 <DavidWHodgins> urpmq --whatrequires doesn't work with virtual provides though. How to find those?
19:39:37 <Stormi> - version in mga2 >= version in mga1
19:40:00 <Stormi> DavidWHodgins: I don't know, if we can't then we won't :)
19:40:09 <DavidWHodgins> Ok
19:40:31 <Stormi> but we can work on that to try to find a solution
19:40:40 <MrsB> what are virtual provides?
19:40:57 <DavidWHodgins> A provides that isn't a filename or package name.
19:41:19 <MrsB> sorry stormi, do you want to finish your list first
19:41:27 <Stormi> yes :)
19:41:34 <Stormi> - if the package depends on another package to work, it should work both with the version in updates and in backports, or have strict versioned requires
19:41:45 <Stormi> this one should be rare
19:42:03 <Stormi> only concerns when it's more than a leaf package that is backporte
19:42:59 <MrsB> have you finished?
19:43:12 <Stormi> that's all I have for now (except another question I have to submit), I don't think we need a big checklist
19:43:20 <MrsB> question time then :D
19:43:23 <Stormi> we can complete it afterwards
19:43:25 <Stormi> yes
19:43:35 <Stormi> it's only a proposal
19:43:39 <MrsB> i don't understand the last one
19:43:57 <MrsB> oh i do, just had to read it twice
19:44:18 <Stormi> flightgear needs simgear. either newer flightgear has a strict requires to a newer simgear, or works with existing one
19:44:30 <MrsB> yep, got it, thankyou
19:44:38 <Stormi> maybe that last one is over-thought :)
19:44:44 <MrsB> i think they're all good points
19:44:59 <MrsB> any comments or questions anybody?
19:45:08 <harms> Stormi, I like the idea of a checklist for backport packages
19:45:20 <harms> (I guess in the package specific wiki pages). Who prepares
19:45:22 <DavidWHodgins> The backports policy says qa moves the packages from testing to backports.  Is that going to happen soon?
19:45:48 <harms> the list? I suggest the guy how did the backport
19:45:50 <Stormi> DavidWHodgins: I don't know
19:46:02 <Stormi> DavidWHodgins: that was written when we thought it would happen soon :)
19:46:32 <Stormi> harms: you mean per-package checklist?
19:46:37 <Stormi> looks like testing procedures to me
19:46:47 <Stormi> we can use the same for updates and backports here
19:47:03 <Stormi> only with permission to test less points for backports
19:47:12 <Stormi> s/less/fewer/ maybe?
19:47:25 <harms> yes, testing procedures
19:47:31 <DavidWHodgins> For example, no need to try to recreate a bug.
19:47:35 <Stormi> yep
19:48:07 <MrsB> installs ok with all the needed packages and seems to work ok is my impression
19:48:47 <MrsB> vcg3rd: do you have any questions?
19:48:48 <Stormi> I propose to duplicate https://wiki.mageia.org/en/QA_process_for_validating_updates
19:48:54 <Stormi> with a backports specific process
19:49:00 <DavidWHodgins> Possibly only tested on one arch by the backport requestor, if specific hardware is needed.
19:49:07 <Stormi> taking into accounts what we said in this meeting and previous one
19:49:33 <MrsB> Anybody disagree with Stormi's suggestions?
19:49:34 <vcg3rd> I guess I'm wondering if the first thing I need to do is add the testing repos which I don't have enabled at the moment
19:49:54 <MrsB> Ok we can talk about that afterwards vcg3rd
19:49:55 <DavidWHodgins> vcg3rd: Not really.
19:50:06 <DavidWHodgins> I'll explain later.
19:50:11 <MrsB> you don't need to leave them enabled tho no
19:50:31 <MrsB> do you understand what is being talked about here?
19:51:06 <DavidWHodgins> MrsB: I agree with Stormi's suggestion.
19:51:07 <vcg3rd> Let's say I understand the words... :-)
19:51:20 <Stormi> good enough for a first day :)
19:51:32 <MrsB> lol ok, well it's something that has been ongoing for a while so you're coming in the middle of a long debate really
19:51:33 <led43_Mag1> vcg3rd: thats a start ;)
19:51:38 <MrsB> yeah
19:51:49 <MrsB> You'll soon pick things up
19:51:57 <MrsB> and never ever be afraid to ask stuff
19:52:26 <MrsB> Can we say then that we agree to Stormi's suggestions guys?
19:52:37 <diogenese> I agree
19:52:41 * led43_Mag1 yep
19:52:46 <harms> meto
19:52:57 <MrsB> meto is yes?
19:53:06 <Stormi> me too I guess
19:53:08 <MrsB> ohh lol me too
19:53:18 * Stormi agrees with Stormi
19:53:22 <Stormi> though...
19:53:23 <MrsB> i do too
19:53:35 <Stormi> then I've got one question left
19:53:52 <Stormi> do we ask for a qa-backports ML?
19:54:02 <MrsB> beat you to it
19:54:12 <Stormi> last week?
19:54:20 <MrsB> yep, there is a saved search "Backport waiting for QA test"
19:54:25 <DavidWHodgins> Another mailing list?
19:54:28 <MrsB> ohh ML, sorry
19:54:48 <Stormi> i'm thinking of QA members who would concentrate on updates only
19:54:53 <led43_Mag1> it would be a good idea
19:55:12 <Stormi> the alternative would be being able to filter backports mails
19:55:28 <Stormi> which means we must ask to have "backport" in the subject or something like that
19:55:32 <MrsB> I think it's an idea to keep them kind of separate
19:55:35 <DavidWHodgins> Wouldn't that require a change in the procedure for the packagers and bugzilla?
19:55:57 <Stormi> DavidWHodgins: yes it would, so that's not a trivial change
19:56:16 <MrsB> wouldn't only mean changing qa-bugs to qa-backports
19:56:40 <Stormi> I'd like ideally when I get mail to see at first sight if we're talking about a backport or an update
19:56:55 * led43_Mag1 same here
19:57:23 <MrsB> i think it could be a good idea.
19:58:01 <MrsB> the procedural changes are just an email address change so nothing major, unless I'm missing something
19:58:25 <DavidWHodgins> Bugzilla has an assign to qa button.
19:58:33 <Stormi> it has?
19:58:39 <MrsB> thats leuhmanu bugsqad script
19:59:01 <MrsB> it's a greasemonkey script, easy enough to add another button
19:59:22 <DavidWHodgins> Or rather "Reset QA Contact to default".  I've never used it, so don't know what it does.
19:59:41 <Stormi> the other solution, is ask for each bug subject to start with Update: or Backport:
19:59:49 <Stormi> would not be bad either
20:00:29 <Stormi> maybe we should talk with bugsquad and see what's best for them
20:00:48 <Stormi> any solution that allows to separate updates from backports in e-mails is ok for us, isn't it?
20:00:49 <MrsB> i think we should do one or the other, the ML is probably easier to manage, for us at least
20:01:01 <DavidWHodgins> I'm not objecting to a new mailing list, just surprised by it.
20:01:03 <MrsB> yeah inho
20:01:07 <MrsB> -n +M
20:01:14 <MrsB> typo city today :\
20:01:20 <Stormi> yes, sysadmins don't like Yet Another Mailing List :)
20:01:21 <DavidWHodgins> Lol
20:02:07 <MrsB> so what are we deciding. somebody talk to bugsquad I guess?
20:02:09 <Stormi> so, we agree that we'd like to have those separate, whatever the way
20:02:23 <Stormi> yes, either MrsB or me, whoever sees them first
20:02:34 <DavidWHodgins> Either by a forced subject, or a separate mailing list is fine by me.
20:02:42 <MrsB> i agree Stormi yeah
20:03:03 <Stormi> who volunteers to create the QA process for validating backports page?
20:03:11 <Stormi> I volunteer to review it :Þ
20:03:19 <DavidWHodgins> Hiding :-)
20:03:32 <MrsB> I guess I can do that
20:03:52 <MrsB> #action MrsB work on a validating backports QA page
20:04:05 <Stormi> thanks, then I think the backports topic is closed for tonight
20:04:13 <MrsB> who volunteers to update the backports policy?
20:04:22 <Stormi> I can
20:04:35 <MrsB> #action Stormi to update the backports policy page
20:04:37 <Stormi> But I don't see much to add to it, most things are in it already
20:04:48 <MrsB> ok perhaps we should swap :P
20:05:10 <Stormi> I'll use my packager hat for the backport policy
20:05:35 <Stormi> but if you see missing items in it please tell
20:05:36 <DavidWHodgins> Instead of a separate validating backports page, why not just add the differences in the existing page?
20:05:50 <Stormi> both are fine for me
20:06:08 <MrsB> I can do, it can always be moved to a new page if it's confusing
20:06:31 <MrsB> #action MrsB to try the backports info in the validating updates page first
20:07:00 <Kernewes> MrsB: perhaps use a different colour font for the backports bits?
20:07:27 <MrsB> maybe Kernewes yes, I'll refer to docteam :)
20:07:47 <Kernewes> MrsB: good idea, refer to them
20:07:53 <MrsB> Who wants an action for talking to bugsquad?
20:07:57 <Stormi> And a colour for updates only bits :)
20:08:03 * MrsB looking at dave
20:08:06 <Stormi> such as "test the security fix"
20:08:24 <DavidWHodgins> Ok, but other then a bug report, how do I contact them?
20:08:41 <Stormi> #mageia-bugsquad or their mailing list
20:08:41 <MrsB> #info maybe use different colours for backports and updates on the wiki page
20:08:50 <Stormi> I'm in both, I guess I could contact them easily
20:08:51 <DavidWHodgins> Ok.
20:09:02 <Stormi> but I won't deprive you of a fun task :)
20:09:04 <MrsB> we haven't left anything for dave to do :P
20:09:22 <Stormi> MrsB: you forgot all those updates candidates :P
20:09:22 <Kernewes> MrsB: he's looking after a newcomer
20:09:31 <MrsB> oh yes :)
20:10:10 <MrsB> #action Stormi to talk to bugsquad about bugzilla process or new ML
20:10:14 <MrsB> :)
20:10:19 <Stormi> ack
20:10:24 <MrsB> hi Matth_
20:11:12 <MrsB> sooooo is it safe to say we've finished here, except the ML/bugzilla summary thing?
20:12:12 <MrsB> We can check on progress next week
20:12:18 <Stormi> yes
20:12:21 <MrsB> lets move on
20:12:31 <MrsB> Luigi12: Luigi12_lappy ping?
20:13:08 <MrsB> hmm I was hoping for Luigi's roundup
20:13:32 <MrsB> #topic Anything else?
20:13:40 <MrsB> is there anything else?
20:14:17 * led43_Mag1 not here
20:14:43 <DavidWHodgins> Not here either.
20:15:34 <MrsB> lets close then. Thankyou all for coming, it was a much shorter one this week, maybe next week even shorter!
20:15:41 <Stormi> MrsB: priority?
20:15:50 <Stormi> or is that topic canceled?
20:15:56 <MrsB> luigi doesn't seem to be here
20:15:58 <Stormi> ok
20:16:06 * Stormi likes short meetings
20:16:22 <MrsB> #info Please prioritise any security updates if you can do
20:16:30 <DavidWHodgins> Leaves more time for testing. :-)
20:16:39 <MrsB> #endmeeting