20:05:08 <MrsB> #startmeeting
20:05:08 <Inigo_Montoya> Meeting started Fri Jun 15 20:05:08 2012 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:08 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:05:11 <Led43_mag2> ok
20:05:24 <MrsB> So, Morning QA
20:05:33 <MrsB> thank you all for coming
20:06:00 <MrsB> We've a few things to get through tonight so we'll try to keep it brief
20:06:26 <MrsB> #topic The news
20:07:06 <MrsB> In case anybody has not seen it yet, there was a blog post showing the planned release schedule for Mageia 3
20:07:18 <MrsB> http://blog.mageia.org/en/2012/06/11/cauldron-is-boiling-again-never-2-without-3/
20:07:19 <[mbot> [ Cauldron is boiling again: never 2 without 3 | Mageia Blog (English) ]
20:07:52 <MrsB> #info The first Mageia 3 alpha is planned for 4th September
20:08:21 <MrsB> btw, if you want to note anything in the meeting minutes just use the #info command
20:08:43 <MrsB> Nest news item..
20:08:45 <MrsB> next
20:09:17 <MrsB> There is a short period now, until the 18th where you can propose features you'd like to see in Mageia 3
20:09:35 <MrsB> https://wiki.mageia.org/en/Features_policy
20:09:59 <MrsB> There is also a list of features which have already been proposed here https://wiki.mageia.org/en/Category:ProposedFeatureMageia3
20:10:45 <MrsB> #info Until the 18th June fetaures you'd like to see in Mga3 can be proposed. See on the wiki  https://wiki.mageia.org/en/Features_policy
20:11:07 <MrsB> Anybody any questions or comments before we move on?
20:11:16 <DavidWHodgins> Not here.
20:11:27 <Stormi> ack
20:11:39 <MrsB> ok so next topic
20:11:53 <MrsB> #topic New starters
20:12:05 <Led43_mag2> new features are great but we need enough peolpe to dev and qa them all
20:12:23 <MrsB> You've probably noticed a few new people in QA \o/
20:12:44 <Led43_mag2> yes and some qa mentoring
20:13:38 <MrsB> There have been (hoping I don't forget anybody) harms, zvonimir, wassi, diogenese, Olivier and hopefulyl Kernewes :)
20:13:46 <MrsB> had to think then..
20:13:51 <MrsB> did I miss anybody?
20:14:07 <Kernewes> mine might have to be mainly when I'm on holiday from work
20:14:29 <Led43_mag2> Kernewes: every bit helps
20:14:36 <MrsB> So guys, how have you found it so far?
20:14:51 <MrsB> is there anything we need to improve?
20:15:03 <Kernewes> I like the easy bugs e-mails
20:15:18 * Led43_mag2 apologizes for not doing much over last few weeks real life got in the way
20:15:22 <MrsB> yes, we can keep those going
20:15:52 <MrsB> ohh yes, Led43_mag2 my apologies. I'm so used to seeing you here. Led43_mag2 also is going to start validating updates.
20:15:56 <Led43_mag2> Kernewes: so do i, maybe also a long standing bug test list for bugs not being tested
20:16:21 <Led43_mag2> or missed
20:16:40 <MrsB> I know we need to improve our documentation and have made a start but could we all take a look and see what we can improve there please.
20:17:02 <MrsB> (not right now :P)
20:17:14 <MrsB> harms, anything to add?
20:17:24 <harms> nothing from my side
20:17:29 <Kernewes> docs is useful to start with
20:17:36 <Kernewes> but it's the doing it
20:17:36 <Led43_mag2> i shall be reading and following our pages so can maybe add things as i go
20:17:43 <Kernewes> that's how I'll learn
20:17:46 <MrsB> great :)
20:17:47 <harms> but we had some discussion on possible issues
20:17:57 <harms> (tools for instance)
20:18:23 <Led43_mag2> yes we need to set up some collaborating tools
20:18:35 <MrsB> Well I can't say it enough.. If there is anything you need or are unsure about please do ask. Myself, Stormi or Dave H will be only too pleased to help.
20:19:01 <Led43_mag2> will be doing so over next few weeks
20:19:04 <MrsB> Yes, we talked about adding a page for QA tools, perhpas things like urpmi, strace etc
20:19:20 <MrsB> Who valunteers to look at that?
20:19:23 <MrsB> +o
20:19:54 <Led43_mag2> maybe how to pipe lsub, dmesg ectra to txt files
20:19:56 <harms> (much of it probably exists in the wiki, but pointers, just makin aware)
20:20:13 <MrsB> Led43_mag2: do you want to make a start?
20:20:42 * MrsB looking at DavidWHodgins  and Stormi
20:20:43 <Led43_mag2> MrsB: ok will troll the wiki first and note what is already covered
20:20:59 * Stormi looks at DavidWHodgins
20:21:03 <DavidWHodgins> Trying to hide.
20:21:10 <DavidWHodgins> Yes, I'll help. :-)
20:21:14 <MrsB> Well volunteered :D
20:21:43 <MrsB> #action Dave H and Led43 will make a start on a QA tools wiki page
20:21:55 <MrsB> thanks guys
20:22:18 <MrsB> Ok so we'll keep a regular check on how peope are getting on
20:22:30 <MrsB> next topic then?
20:22:56 <MrsB> #action Mrsb will keep sending the Some easy bugs emails
20:23:10 <Kernewes> thank you
20:23:16 <MrsB> #topic Backports
20:23:20 <Led43_mag2> thanks
20:23:24 <Stormi> this one will be quick
20:23:31 <MrsB> Yes.
20:23:41 <Stormi> because or work will depend on the policy, which is not decided yet
20:23:57 <MrsB> You may know that there has been alot of discussion about opening backports
20:23:58 <Stormi> especially concerning upgrade from one distro to the next
20:24:03 <MrsB> yep
20:24:12 <MrsB> do you want to explain it Stormi?
20:24:24 <Stormi> yes
20:24:33 * MrsB sips her tea
20:24:52 <Stormi> if the policy is not totally changed next week, backports are supported
20:24:58 <Stormi> so go through QA
20:25:04 <Stormi> (with a lower priority than updates)
20:25:43 <Stormi> there will be some peculiarities to backports testing, I will make sure we bring the needed changes in our testing process
20:25:49 <Stormi> with proper wiki documentation
20:25:50 <DavidWHodgins> Good oportunity to get people who want the backports to help with qa testing.
20:26:07 <Stormi> yes, that's indeed a good opportunity to get new testers
20:26:29 <MrsB> Does everybody understand what backports are?
20:26:32 <Kernewes> no
20:26:39 <Stormi> ok I'll explain that
20:26:52 <Stormi> first, you need to understand what updates are
20:27:00 <Stormi> updates are only security fixes and bugfixes
20:27:02 <Kernewes> ok
20:27:18 <Stormi> updates policy forbids to update to the "next newer version"
20:27:23 <Stormi> unless there's a very good reason
20:27:51 <Kernewes> ok
20:27:52 <Stormi> or unless the new version is just a bugfix releease
20:28:15 <Stormi> however, users sometimes need the "new version" of some pieces of software
20:28:27 <Stormi> this is allowed in the backports media
20:28:35 <Stormi> which are not activated on your system by default
20:28:37 <Kernewes> oh I see
20:28:57 <Kernewes> is that because they might be too buggy?
20:29:01 <Stormi> yes
20:29:04 <Kernewes> fine
20:29:07 <Stormi> or change user habits too much
20:29:23 <Stormi> an update can be installed eyes closed
20:29:32 <Stormi> it won't break anything or change the way you work
20:29:40 <Stormi> a backport can change the way you work
20:29:47 <Stormi> and sometimes break things, even if we test them
20:29:51 <Kernewes> I see
20:30:17 <Stormi> so, before backports arrive to Mageia, some key points in the policy are still to be defined. There's a lot of discussion happening between packagers.
20:30:56 <Stormi> So after this introduction, I propose to just wait, and speak of it again in next meeting and on our mailing list once the backports policy is finalized
20:31:09 <MrsB> I think you're right Stormi
20:31:19 <MrsB> There is no rush to validate backports
20:31:30 <MrsB> we can make sure we know what we're doing first
20:31:54 <Stormi> #info Stormi will be part of first backports validation and QA backport testing process definition
20:32:03 <MrsB> we'll have another meeting, probably the week after next, a few people are away next week
20:32:34 <Stormi> any questions ?
20:32:46 <Kernewes> no but thank you for the explanation
20:32:48 <harms> How about a dry-run backport to get some idea on practical
20:32:55 <harms> issues?
20:32:57 <Led43_mag2> no, but thanks for the explanation
20:33:13 <Stormi> harms: I think we will just take the first backport that arrives to us as a test case :)
20:34:01 <MrsB> The packagers policy still has to be finalised so we can't really set our policies until then anyway
20:34:24 <Stormi> yes
20:34:48 <MrsB> anybody anything alse to add on this topic?
20:35:01 <MrsB> +e
20:35:06 <Led43_mag2> not here
20:35:09 <DavidWHodgins> Just that I don't think a backport that breaks upgrading should be blocked.
20:35:26 <MrsB> add that as an info Dave
20:35:34 <Stormi> that's depending on policy
20:35:37 <Stormi> not our decision
20:35:57 <MrsB> yes i suppose thats right
20:36:02 <Stormi> that's one of the key points being discussed in fact
20:36:03 <DavidWHodgins> The existing dvd.iso cannot be changed, so a backport that triggers a urpmi cascade error will block upgrades
20:36:29 <MrsB> we can have an input in the process but it is packagers policy
20:36:38 <harms> backports already in an dvd.iso ?
20:37:11 <Stormi> in fact it's a team-independent policy but being elaborated by packagers mainly, with QA and bugsquad participating
20:37:14 <DavidWHodgins> Mga 1 +backports, then try to upgrade to Mageia 2 using dvd.iso, will likely not work.
20:37:28 <harms> i see
20:38:13 <Stormi> next topic?
20:38:18 <MrsB> yep.
20:38:24 <MrsB> you'll like this one..
20:38:28 <MrsB> #Bug 2317
20:38:29 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, High, ---, thierry.vignaud, NEW, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
20:38:37 <MrsB> #topic Bug 2317
20:38:41 <MrsB> thats better
20:38:46 * MrsB newbie
20:38:53 <DavidWHodgins> Following the dev discussion, it doesn't look like it's going to be quickly solved.
20:39:22 <Stormi> at least AL13N is having a look at the code
20:39:23 <MrsB> Our new starters won't have any idea what this is about so a short description first..
20:39:24 <Led43_mag2> :( at least its being worked on
20:39:33 <Stormi> yes
20:39:45 <MrsB> This bug has been QA's biggest nightmare
20:39:59 <DavidWHodgins> I'll give a recent example.
20:40:02 <MrsB> it's a long standing bug which affects Mageia update
20:40:23 <MrsB> When it occurs it means that updates can't be selected to be installed
20:40:27 <DavidWHodgins> Using the dual-cd to upgrade from Mageia 1, at the end of the install, it tries to install updates.
20:40:44 <MrsB> It happens where new requires or suggests have been added with an update
20:40:49 <MrsB> go on dave.
20:41:00 <DavidWHodgins> The update failed, because one of the packages required by one of the updates, was only in the core release repository.
20:41:37 <DavidWHodgins> The istallation of updates, currently only looks for dependencies in the updates repositories, not the release repositories, even if they are enabled.
20:42:14 <DavidWHodgins> To work around the bug, a copy of the needed package had to be hard linked into the updates repsository, so it's available at update time.
20:42:38 <DavidWHodgins> Other workaround is to use "urpmi --auto-select", but there is currently no gui way to run that command.
20:43:18 <MrsB> In short. If an update has had a require or suggest added to it which is not then provided in media's marked as update medias then it will fail. If it needs something extra from release medias in other words.
20:43:31 <DavidWHodgins> Whether or not a user encounters the bug, depends on whether or not they already have the dependency installed.
20:43:49 <DavidWHodgins> That means it's easy for qa to miss the bug, that will only affect some users.
20:44:12 <MrsB> The goooooood news is.. finally.. It is being looked at \o/
20:44:20 <DavidWHodgins> We have a script that will detect the most common cases, but it doesn't catch all of the possible causes.
20:44:28 <DavidWHodgins> Hopefully it will get solved.
20:44:32 <MrsB> AL13N and also rindolf are having a go at fixing it
20:44:45 <MrsB> I think that deserves a separate topic from the news :)
20:45:04 <Led43_mag2> do we run the script locally
20:45:05 <DavidWHodgins> I've looked at the code involved myself, and it is not going to be simple to fix, or to test.
20:45:20 <MrsB> #info AL13N and rindolf are having a go at fixing bug 2317 \o/ - Thankyou both from all the QA team!
20:45:21 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, High, ---, thierry.vignaud, NEW, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
20:45:26 <DavidWHodgins> Led43_mag2:  yes.
20:45:51 <Led43_mag2> got an url to the script
20:45:57 <DavidWHodgins> I'm hopeful that it will finally get fixed, bug not holding my breath. :-)
20:46:06 <MrsB> It is attached to the bug
20:46:28 <MrsB> Unfortunately there is another bug (with urpmf -m) which means the script is broken.
20:46:56 <MrsB> There is an echo command commented out which can be uncommented to make it work
20:47:12 <DavidWHodgins> It still ids the packages, just not the media, so it's still better than nothing.
20:47:37 * Led43_mag2 seems i already had it!
20:48:25 <MrsB> #info The depcheck script is currently broken due to a bug in urpmf but can be 'fixed' by uncommenting the line   echo "$finished"
20:49:18 <MrsB> Kernewes harms do you understand any of this?
20:49:27 <Kernewes> sort of
20:49:39 <harms> yes - wondering what that implies in everyday testing
20:49:54 <harms> run the script on each tested package?
20:49:59 <DavidWHodgins> Always try to install updates using mgapplet first.
20:50:08 <Led43_mag2> MrsB: line 132 col 21?
20:50:13 <Kernewes> what's mgapplet?
20:50:32 <DavidWHodgins> The icon that shows up when there are updates to install.
20:50:33 <Stormi> harms: yes, but no need to have each tester run the script. The person validating the update for push to updates media can do it.
20:50:40 <Kernewes> ok
20:50:52 <harms> great
20:50:53 <MrsB> Led43_mag2: just above wthe line that says # List the links and the media they can be found in
20:51:23 <MrsB> Now, in other related news..
20:51:37 <MrsB> If it can't be fixed for any reason..
20:51:53 <Led43_mag2> MrsB: got it
20:52:13 <MrsB> there is probably the possibility for a modified depcheck to take place automatically when the update is pushed
20:52:38 <MrsB> Ideally it should be fixed though
20:52:56 <MrsB> so big thanks to AL13N and rindolf. Buy them both a drink!
20:53:12 <Kernewes> not too many or they'll be too drunk to fix it
20:53:18 <MrsB> lol
20:53:23 <MrsB> so, next topic?
20:53:27 * Led43_mag2 slides 2 virtual beers down the bar
20:54:16 <MrsB> #topic Buzilla process for updates on Mga1 AND Mga2
20:54:24 <MrsB> #undo
20:54:24 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x8445b8c>
20:54:33 <MrsB> #topic Bugzilla process for updates on Mga1 AND Mga2
20:55:02 <MrsB> So, as you know we are now getting bug which contain updates for both mga1 and mga2
20:55:26 <MrsB> we've been trialling using just one bug
20:55:43 <MrsB> It seems to be working quite well so far..
20:55:47 <MrsB> what do you think?
20:56:09 <DavidWHodgins> I think it's actually better than two bugs, where you have to remember to ensure 2 is validated b4 1.
20:56:26 <MrsB> I hate to admit it but I think you're right :D
20:56:37 <DavidWHodgins> Lol
20:56:45 <MrsB> So, the real reason for this topic..
20:57:11 <MrsB> There is no way unfortunately with the current bugzilla version to show the bug is for both releases
20:57:13 <Led43_mag2> does any version have priority?
20:57:42 <MrsB> I spoke to marja who is bugsquad amongst other things
20:57:43 <DavidWHodgins> Yes, to ensure upgrades will work, 2 should always be pushed before, or at the same time as 1.
20:58:04 <Led43_mag2> DavidWHodgins: ok
20:58:09 <MrsB> She suggested we use the same policy as they do, which seems to make sense
20:58:51 <Kernewes> what's that?
20:59:03 <MrsB> Where the update is for more than one release, the 'Version' is set to the highest one and in the 'Whiteboard' the keyword is added, MGA2TOO or MGA1TOO
20:59:10 <MrsB> In our case..
20:59:36 <MrsB> it means a bug will be set to 'Version' 2 and will have the Whiteboard keyword MGA1TOO
20:59:50 <MrsB> it means at a glance we can tell the bug affects both releases
21:00:01 <Kernewes> seems to make sense
21:00:19 <MrsB> Luigi12 has already begun using that method in his updates, if you look
21:00:26 <DavidWHodgins> It could be set to cauldron, and have MGA2TOO and/or MGA1TOO as well.
21:00:57 <Led43_mag2> just looking at one like that
21:00:59 <MrsB> I suggested it at the last packagers meeting on Wednesday and sent an email to mageia-dev ML about it so hopefully it should begin to be used
21:01:41 <MrsB> Dave it could be but a bug like that would be fixed in cauldron first usually
21:01:55 <DavidWHodgins> Then changed to 2?
21:02:07 <MrsB> yeah
21:02:13 <DavidWHodgins> Ok.
21:02:32 <MrsB> by the time they reach us they will mostly just be 2 and MGA1too
21:02:48 <MrsB> Stormi: any thoughts on this?
21:04:04 <Stormi> I think we can try this way
21:04:35 <Stormi> packagers will probably forget to set to MGA2 if the bug was targetted at cauldron first though
21:04:49 <Stormi> we will have to be patient with that
21:04:59 <MrsB> Yeah, we'll need to educate them for a while
21:05:18 <DavidWHodgins> When they assign to qa, if they've forgotten, we can change it to 2 or 1, depending on the srpms
21:05:39 <MrsB> When bugzilla is upgraded to bugzilla 4 this problem will be solved as it is possible to select more than one release
21:06:12 <MrsB> any other comments or questions on this?
21:06:22 <harms> Might be good to make it QA practice to update the whiteboard for
21:06:26 <Led43_mag2> when is bugzilla 4 due to arive
21:06:35 <harms> each chunk (mga1, mag2, architecture) finished - keeps everyone posted
21:06:46 <DavidWHodgins> Have they decided yet whether our bugzilla will use rpm packages going through regular qa?
21:07:21 <MrsB> harms good point, it is something we will probably have to do ourself if packagers forget but we an let them know on the bug in case they don't realise
21:07:57 <MrsB> Bugzilla 4 has been on its way for a long time apparently but it is not simple due to our modifications
21:08:38 <Led43_mag2> ahh i c
21:08:43 <MrsB> harms we will carry on using our whiteboard keywords btw too
21:09:05 <MrsB> Dave I've no idea, sorry
21:09:07 <harms> that was my point
21:09:21 <MrsB> yeah, I read it twice :)
21:09:24 <DavidWHodgins> Just noticed on mageia-dev, AL13N thinks he's found the solution for bug 2317.
21:09:25 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, High, ---, thierry.vignaud, NEW, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
21:09:48 <MrsB> we'll keep an eye on progress \o/
21:10:00 <MrsB> next topic?
21:10:26 <MrsB> #topic QA processes for ISO testing
21:11:13 <MrsB> As you've probably see on qa-discuss we are trying to come up with a process to ensure everybody tests everything which is needed when ISO testing
21:11:39 <MrsB> Stormi had an idea and we've put some effort into creating something to show you
21:11:55 <MrsB> http://www.ethercalc.org/qa
21:11:56 <[mbot> [ EtherCalc - Share the URL to your friends and edit together! ]
21:12:24 <MrsB> Stormi: care to elaborate on this one?
21:12:37 <Stormi> ok
21:13:15 <Stormi> some thing that appeared missing in Mageia 2 testing was a clear way to keep track of everybody's testing effort and results
21:13:26 <Stormi> and a quick way to see what was tested and what wasn't
21:13:58 <Stormi> the collaborative text tool (etherpad) that was used, and will still be used probably, is useful but not enough
21:14:31 <Stormi> the wiki page Coincoin created, modeled after what they used at Mandriva QA Team, wasn't used at all
21:15:12 <DavidWHodgins> Guilty.
21:15:34 <MrsB> to be fair i don't think it would have worked very well on the wiki
21:15:37 <Stormi> it occurred to me that a simple spreadsheet with proper organization could do the trick
21:15:56 <Stormi> and found a collaborative one will real-time parallell editing
21:16:06 <Stormi> we hope it will be easier to use than the wiki
21:16:16 <DavidWHodgins> The biggest problem I had with online tools, is that when testing the iso images, I was offline.  Once I have a second computer, that will be easier.
21:17:03 <MrsB> Dave, it has a little button you can press to give an html output which you could print
21:17:05 <Stormi> so, MrsB created a front page with a list of ISOs and statuses, with links to individual testing pages for each ISO
21:17:12 <Stormi> http://www.ethercalc.org/qa
21:17:13 <[mbot> [ EtherCalc - Share the URL to your friends and edit together! ]
21:17:38 <Stormi> with an example sub-page: http://www.ethercalc.org/dual_cd_32
21:17:40 <[mbot> [ EtherCalc - Share the URL to your friends and edit together! ]
21:17:53 <harms> The tool should support some flexibility / alternatives - see "normal" iso
21:18:02 <harms> vs the graphics repeat where some tests were relaxed
21:18:31 <Kernewes> would it allow for more than one person testing an iso?
21:18:46 <Kernewes> or someone taking over if the first tester had to stop for some reason?
21:19:03 <Stormi> Kernewes: yes
21:19:45 <Stormi> but most of the time we don't have enough testers to have several people test the same ISO
21:19:50 <DavidWHodgins> We always want more than one person per iso, due to different hardware availibility.
21:20:03 <Kernewes> Stormi: yet!
21:20:07 <Stormi> yet :)
21:20:10 <Led43_mag2> maybe add a real iron / vm question
21:20:21 <MrsB> we generally apply some liberal common sense
21:20:22 <Stormi> Led43_mag2: good idea
21:20:39 <Stormi> the templates can evolve
21:20:45 <Stormi> if you have ideas to improve them
21:21:18 <Kernewes> that's what tends to happen with these things
21:21:26 <Kernewes> once you start using them you think of things you want to change
21:21:31 <Stormi> about the sub-pages, I'm wondering if we should create one per ISO, or suppose most people have large screens and add one column per ISO and one big comment section
21:21:37 <Kernewes> so as long as there's flexibility that's OK
21:21:45 <MrsB> What are you first impressions guys?
21:21:57 * Led43_mag2 votes for 1 per iso
21:22:04 <MrsB> yes me too
21:22:07 <harms> +1
21:22:09 <Kernewes> and me
21:22:19 <Led43_mag2> screen looks less noisy
21:22:24 <DavidWHodgins> Too many, if they still have so many live cds.
21:23:06 <MrsB> Its something we can work on but it's something we should have ready before the next round of ISO tests
21:23:27 <MrsB> when we've sorted out what we are going to do we need to update the wiki documentation
21:23:41 <DavidWHodgins> Agreed, but we have to see what isos will be generated for Mageia 3.
21:23:55 <MrsB> yes, that's still not known
21:24:01 <Led43_mag2> may be have a kde/gnome/lxd question
21:24:04 <Stormi> it will be sorted out in the next few weeks
21:24:35 <MrsB> There are of course other posibilities, there was a suggestion of a mozilla app wasn't there.
21:24:48 <Stormi> yes
21:24:56 <MrsB> we need to try and get this sorted though while it's still fresh in our minds
21:25:13 <Stormi> https://litmus.mozilla.org/
21:25:16 <[mbot> [ Litmus - Active Test Runs ]
21:25:27 <MrsB> does somebody volunteer to have a look at that, maybe a test instance?
21:25:42 <Led43_mag2> yes if we sort out collaborative tools now it will save in the long run
21:25:51 <MrsB> yep
21:26:25 <MrsB> my server is probably a bit old to host that or I'd put it up there to play with
21:26:48 * Led43_mag2 will troll the internet over next few days and see what free tools/sites are available
21:27:21 <MrsB> first impressions of the spreadsheet idea are favourable though are they?
21:27:25 <Kernewes> yes
21:28:18 <MrsB> so we need a volunteer..
21:28:19 <Led43_mag2> MrsB: yes, was a bit dubious at first, but i can see your improvements
21:28:40 <MrsB> I'll see if it'll install on my server if you like
21:29:12 * MrsB watches everybody run away from volunteering :D
21:29:32 <Kernewes> I don't do servers
21:29:39 <Led43_mag2> we also need to have a set of tests that are needed, and maybe a wiki page explaining how to run each test
21:29:56 <MrsB> #action MrsB to check if litmus will install on server
21:30:21 <MrsB> Led43_mag2: follow the link to the dual cd on the spreadsheet
21:30:23 <Led43_mag2> MrsB: i will have a go next week after doing an upgrade on my test server box
21:31:18 <Led43_mag2> MrsB: have done already, i might add a few more iso links if i get time i tried to the other day but lost my input
21:31:46 <MrsB> Yes, it's only there to see if it's suitable at the moment
21:32:19 <MrsB> any other thoughts on this?
21:32:36 <MrsB> harms, leuhmanu
21:32:52 <harms> no other ideas
21:33:04 <Luigi12> does QA need anything from me before I head home?
21:33:07 <Led43_mag2> MrsB: yes, maybe put 4/5 iso links and have a few do some dummy runs at filling in reports, see how the site handles a bu squash weekend type scenario
21:33:20 <leuhmanu> sorry I completly away from this meeting /o\
21:33:25 <leuhmanu> +am
21:33:26 <MrsB> I don't think so Luigi12, have a good night
21:33:38 <Kernewes> Led43_mag2: good idea
21:34:24 <Stormi> If we keep the ethercalc tool, then we'll see if we can have it installed for QA on Mageia servers
21:34:34 <Stormi> but first we need to use it and see
21:34:53 <MrsB> #info maybe have ethercalc installed on mga servers if we decide to keep it
21:35:11 <MrsB> So play with it guys and see what you think
21:35:31 <MrsB> next topic?
21:35:36 <Stormi> yes
21:35:38 <MrsB> last one for me
21:35:57 <MrsB> #topic Gnome update 3.4.2 (Olav Vitters)
21:36:15 <MrsB> As you probably saw in the meeting email
21:36:31 <MrsB> There is a big update coming for gnome
21:36:44 <MrsB> We were asked how we want to handle it
21:36:56 <MrsB> there are some with added requires/suggests
21:36:59 <Led43_mag2> yes have read it
21:37:05 <MrsB> and a big version upgrade
21:37:39 <MrsB> My suggestion was to send the ones with added requires/suggests as separate bugs and treat the upgrade as with kde
21:37:39 <leuhmanu> (mikala will also certaily come with kde 4.8.4 in the comming weeks)
21:37:47 <DavidWHodgins> Let's hold it off, till the update for bug 2317 gets tested.
21:37:49 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, High, ---, thierry.vignaud, NEW, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
21:38:08 <MrsB> He's hoping it will be the next week or so
21:38:32 <Led43_mag2> MrsB: DavidWHodgins yes
21:39:31 <MrsB> there are alot of bug fixes etc so he is hoping to push it through quite soon.
21:39:43 <Kernewes> Led43_mag2: that beer you arrange worked fast
21:39:47 <Kernewes> arranged
21:40:40 <MrsB> so, there seems to be some good progress with bug 2317
21:40:58 <MrsB> What response shall we give to him?
21:41:01 <Stormi> the fix is wrong, to me, but at least people are diving into the code
21:41:31 <MrsB> he's happy to go along with whatever we decide
21:41:59 <MrsB> suggestions then guys..
21:42:40 <DavidWHodgins> I'd rather see one big update, with a list of bugs that are supposed to be fixed.
21:42:57 <MrsB> what about the added requires /suggests?
21:43:21 <DavidWHodgins> One bug report with a list of added requires.  Suggests don't matter for 2317.
21:43:30 <MrsB> they do
21:43:38 <MrsB> they didnt until the upgrade testing
21:43:48 <MrsB> see last few comments
21:44:10 <MrsB> either way tho you favour one big bug report?
21:44:11 <DavidWHodgins> Ah, right. Forgot about that.
21:44:21 <DavidWHodgins> Yes.  With a complete checklist.
21:44:48 <MrsB> he's unlikely to list all the added requires is all, you know how it works
21:44:55 <DavidWHodgins> List of added suggests/requires and list of bug fixes to be checked.
21:45:25 <MrsB> we can go with that if nobody objects
21:46:11 <Led43_mag2> lets give it a try
21:46:16 <MrsB> #action MrsB to contact ovitters about the gnome update
21:47:02 <MrsB> #info agreed to use one big bug but ovitters please specify all added requires/suggests and a complete checklist of bug fixes etc
21:47:10 <MrsB> ok?
21:47:16 <Led43_mag2> +1
21:47:18 <DavidWHodgins> Yep.
21:47:30 <DavidWHodgins> Makes it easier when it's time to push.
21:47:30 <MrsB> alright then, almost done.
21:47:43 <MrsB> yeah as long as we catch all the links
21:47:57 * Led43_mag2 spitting feathers here
21:48:12 <MrsB> #topic Anything else
21:48:31 <DavidWHodgins> Not here.
21:48:33 <MrsB> Over to you guys. Is there anything you want to bring up r discuss?
21:48:40 <Led43_mag2> not me
21:48:57 <harms> no aob, but a question re bugzilla 2317
21:49:02 <MrsB> stormi harms Kernewes last chance..
21:49:06 <Kernewes> no
21:49:13 <MrsB> fire away harms
21:49:32 <harms> isnt it possible to configure core_release as an update medium?
21:50:03 <DavidWHodgins> That would make checking to see if there are any updates take too much more time.
21:50:15 <MrsB> it isn't just core though, its also nonfree and tainted
21:50:32 <harms> I understand + the others even worse
21:50:42 <DavidWHodgins> That was considered back at the start of 2317
21:50:43 <MrsB> shall I end the meeting?
21:50:51 <harms> ok
21:50:53 <DavidWHodgins> I think so.
21:50:58 <Kernewes> yes
21:51:11 <MrsB> Ok everybody, sorry it was a long one. Thankyou all for coming :)
21:51:16 <MrsB> #endmeeting