15:54:12 <coincoin> #startmeeting
15:54:12 <Inigo_Montoya> Meeting started Thu Dec 22 15:54:12 2011 UTC.  The chair is coincoin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:54:12 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:54:38 <coincoin> #chair obgr_seneca MrsB coincoin
15:54:38 <Inigo_Montoya> Current chairs: MrsB coincoin obgr_seneca
15:54:53 <coincoin> #topic alpha feedback
15:55:04 <coincoin> so... we can try to see if it's usefull :)
15:55:19 <coincoin> MrsB, obgr_seneca: any POV on alpha feedback or improvements?
15:55:58 <coincoin> for my part I think we should work on making a QA ISO team to be sure to know who is doing what...
15:56:09 <MrsB> to be honest I haven't had any chance to look at it, been doing qa on mga 1
15:56:33 <coincoin> and work on better process. I wrote a "QA ISO process with check boxes", I need to push it on Magea wiki
15:57:06 <coincoin> I think that it will help ppl not to do bad test or useless test... and not to disturb release manager with stupid reports :)
15:57:34 <MrsB> There is already some documentation on the wiki
15:57:39 <MrsB> no check boxes though
15:57:39 <coincoin> MrsB: great to have ppl still on stable QA while ISO arrive :)
15:57:53 <coincoin> MrsB: yes, I saw it but it's not "simple enough"
15:58:08 <coincoin> I think a check box page will be clever and easy to follow
15:58:11 <MrsB> true. It could be more specific
15:58:25 <MrsB> ubuntu have a qa 'system'
15:58:34 <coincoin> green: ok, next. red: wait, there is a problem master!
15:58:57 <coincoin> yes but before having such a QA system like fedora or ubuntu, we need more ppl in the team...
15:59:13 <MrsB> indeed. we need more just to do qa on mga 1 even
15:59:26 <coincoin> to many tools with only 5 6 ppl will be a bad thing I think...
15:59:41 <MrsB> 5 or 6 is stretching the truth
15:59:45 <coincoin> :)
16:00:14 <MrsB> 2 regular 2 or 3 others occasional
16:00:21 <coincoin> #action dams will push a "check box" process for QA ISO
16:00:46 <coincoin> ok, we will speak about "how to grow the team" on a next point
16:00:56 <coincoin> anything to add on alpha feedback?
16:01:29 <MrsB> not without having looked at it properly :) I think the checkbox thing is a good idea though
16:01:37 <coincoin> #action dams try to make a choice on "whoi is testing ISO" as a lot of tester are doing "what they want" and do not really help...
16:01:40 <MrsB> one thing maybe
16:02:43 <MrsB> the feedback currently is a bit disorganised, people using piratepad/mailing lists some on bugzilla. We could do with a simple way for people to report problems against the ISO
16:02:55 <coincoin> true.
16:03:22 <coincoin> the idea of a check box page is to use ONLY this page. no piratepad or ML or other thing hard to follow...
16:03:49 <MrsB> will that enable people to give feedback or just give them things to check?
16:04:00 <coincoin> #action do not put report on ML/bugzilla/piratepad at the same time!
16:04:47 <coincoin> MrsB: the idea "small process and a check box to say "ok" or "not ok" and a small place for comment (140 words as on twitter?)
16:05:19 <MrsB> sounds good, you mean use the wiki for the feedback place
16:05:41 <MrsB> or print a form an attach to email type thing
16:05:53 <coincoin> yes the wiki not to duplicate QA tools
16:05:59 <MrsB> ok
16:06:13 <coincoin> with the page cleaned on each new ISO release
16:06:34 <MrsB> will you be monitoring it?
16:06:47 <coincoin> if it's working as expected, we will perhaps have to optimize it or to remove it from the wiki to do a better tool
16:06:54 <MrsB> yes
16:06:55 <coincoin> yes I will
16:07:11 <coincoin> an other point to QA ISO is...
16:07:16 <coincoin> #topic ISOcheck
16:07:20 <MrsB> its a good idea, it'll help to keep everything in one place. I think we'll end up moving fro the wiki though probably
16:07:24 <coincoin> what a good transition! :�
16:07:36 <coincoin> MrsB: I hope so...
16:08:11 <coincoin> #info http://svnweb.mageia.org/soft/isocheck/
16:08:48 <coincoin> in the past, I had a tool to do automatic test on Mandriva ISO (made by one of my MDV trainee: remi)
16:09:10 <coincoin> now, rda and I worked on this tools (perl based) to made it available for Mageia
16:09:13 <obgr_seneca> sorry, phone
16:09:17 <coincoin> it's called isocheck
16:09:22 <MrsB> ok
16:09:28 <MrsB> what does it check?
16:09:40 <coincoin> it allows to do a lot of check on ISO to earn time
16:10:08 <coincoin> check if ISO is burnable, isohybrid, good name, autorun OK, no bad words, good packages, ...
16:10:36 <MrsB> so it installs everything and checks everything installs?
16:10:41 <coincoin> dev is still in progress but for now it's already working pretty well
16:10:56 <coincoin> no, it's only working on "mount in loopback"
16:10:56 <leuhmanu> good packages ?
16:11:01 <coincoin> leuhmanu: idxlist
16:11:10 <coincoin> #chair leuhmanu
16:11:10 <Inigo_Montoya> Current chairs: MrsB coincoin leuhmanu obgr_seneca
16:11:30 <MrsB> isn't mount in loopback currently broken?
16:11:41 <coincoin> MrsB: the main next evolution will be to integrate a VM installation with automagic testy
16:12:00 <obgr_seneca> that would be a real help
16:12:06 <MrsB> it would, yes
16:12:08 <coincoin> MrsB: no, it's working for my needs : "mount -o loop blabla.iso /mnt/
16:12:13 <MrsB> ahh ok
16:12:15 <obgr_seneca> it would free us for more specific tests
16:12:21 <leuhmanu> coincoin: and it's compare with a specific file (idx) ?
16:12:26 <coincoin> obgr_seneca, MrsB: yes but still need work :)
16:12:50 <coincoin> leuhmanu: a static "list of package" is compared with idxlist provided for each ISO by bcd
16:13:08 <leuhmanu> ok
16:13:26 <leuhmanu> because there is some rpms to add and remove :)
16:13:26 <coincoin> obgr_seneca, MrsB: isocheck is here to be sure that, when release manager ask for QA on ISO, isocheck already said "ok, it worth test it"
16:13:40 <obgr_seneca> ah, I see
16:13:49 <coincoin> leuhmanu: feel free to warn us about thoses packages
16:13:56 <MrsB> sounds good.
16:14:08 <leuhmanu> coincoin: bugs are opened :D
16:14:17 <coincoin> it was called "drakisocheck" in mandriva but only used by internal QA
16:14:36 <coincoin> obgr_seneca, MrsB: feel free to contribute if perl is your friend
16:14:46 <MrsB> not in the slightest
16:14:57 <obgr_seneca> if it was python :D
16:14:57 <MrsB> I'd like to learn though
16:15:16 <coincoin> rda and I will post en -dev in a few days, we were just waiting for alpha2 to be release not to have -dev working on isocheck and not on alhap2 bugs
16:15:42 <coincoin> any comment or remaks on isocheck? (for feature or needs)
16:15:53 <MrsB> is it run on bcd then?
16:16:15 <coincoin> not for now
16:16:40 <coincoin> but in a near future, it will be run by bcd after an ISO generation
16:16:56 <coincoin> for now it's run by my little hands :�
16:16:58 <MrsB> it's hard to comment without playing with it so might be worth us playing with it
16:18:11 <coincoin> ok, next point?
16:18:21 <MrsB> yep
16:18:38 <coincoin> #QA process/wiki
16:18:42 <coincoin> #topic QA process/wiki
16:18:45 <coincoin> so...
16:18:53 <coincoin> QA wiki needs a lot of work... :)
16:19:03 <MrsB> so I'm told :\
16:19:25 <coincoin> the idea we could make in place: have a list of pages to be wrote each week... any comment on this idea?
16:19:38 <coincoin> MrsB: it just need to grow more and more
16:19:49 <MrsB> the processes you mean?
16:20:36 <coincoin> yep sorry
16:21:02 <MrsB> I've been adding some for the more technical packages
16:21:10 <coincoin> "how to ...", "what to do if...", "how to..." <<< a lot of guides to write
16:21:41 <MrsB> In what way, not sure we're talkign of the same thing
16:22:18 <coincoin> not only packages but also, for example : "how to test cauldron", "how to build a kernel module", "how to do hardware report"... guidelines for QA ppl
16:22:56 <MrsB> ahh Ok. Yes I agree.. but.. I think most of that will need to be done by the people with the knowledge
16:24:04 <coincoin> yes, true. I can help for some of them. I will have more time at the beginning of 2012 \o/
16:24:19 <MrsB> hurray :D
16:24:32 <coincoin> #action write more guideline on QA : processes but also 'how to build/install/report..."
16:24:35 <coincoin> he he :)
16:24:45 <MrsB> It would be good if we could convince the devs to add pages for QA procedures
16:25:02 <coincoin> I asked 48h days for Christmas!
16:25:15 <MrsB> I hope santa brings them
16:25:22 <MrsB> hi Led43_Netbook
16:25:37 <coincoin> #action MrsB gave the idea to ask dev to help on QA procedures
16:25:49 <MrsB> ohhh sure - name and shame :P
16:25:58 <coincoin> ok, anything to add on this?
16:25:58 <coincoin> :)
16:26:11 <MrsB> not really, agree with it tho
16:26:37 <coincoin> great! \o/
16:26:49 <coincoin> #topic updates request
16:27:17 <coincoin> so... any improvments to ask or missing things on this topic?
16:27:31 <MrsB> yes, can we please fix bug 2317
16:27:38 <coincoin> for my part, it will be the last topic.. we need more ppl to be more reactive...
16:27:44 <MrsB> and ask more devs to leave testing procedures
16:27:58 <MrsB> yes indeed, we're very short handed
16:28:55 * coincoin is on the phone, sorry...
16:29:02 * MrsB taps fingers
16:29:05 <coincoin> :�
16:30:05 <coincoin> back
16:30:06 <coincoin> sorry...
16:30:09 <MrsB> :)
16:30:19 * coincoin give chocolate to MrsB
16:30:29 <coincoin> ok, I will have a look on 2317
16:30:36 <MrsB> ok you're forgiven, anything for chocolate :\
16:30:50 <coincoin> #action dams fix bug #2317
16:30:51 <coincoin> he he :)
16:31:26 <coincoin> #info need more testing procedures by dev team
16:31:43 <MrsB> it would certainly speed things up if they could do that
16:31:57 <coincoin> for an update request, depending on the policy, dev must give a procedure for EACH update request opened!
16:32:09 <leuhmanu> (and also follow more the policy in general)
16:32:11 <MrsB> hmmm
16:32:20 <coincoin> leuhmanu: that join my point...
16:32:40 <MrsB> It would save some repetition if they would assist with the QA wiki pages maybe
16:32:51 <MrsB> I know everyone is short of time tho
16:32:52 <coincoin> #action dams ask dev to follow the procedure and so to give a step by step procedure to each update request
16:33:22 <coincoin> MrsB: yes but I fear it will be hard for this point... dev ppl don't like to write things :�
16:33:23 <leuhmanu> package in testing and ready, not wait 3 months to open a bug/ reassign to the QA
16:33:46 <MrsB> ohh yes that reminds me
16:34:05 <coincoin> #info leuhmanu warn about time between package arrival in testing and the update request
16:34:06 <MrsB> there is a wacom driver sat in updates_testing, been there forever
16:36:41 <MrsB> #info example - x11-driver-input-wacom-0.10.11-3.1.mga1
16:38:17 <coincoin> "treat or sweet!"
16:38:25 <coincoin> bad halloween is far... :)
16:39:50 <coincoin> anything else on this point leuhmanu or MrsB?
16:40:13 <MrsB> I think we've moaned enough :D
16:41:30 <coincoin> :) I made leuhmanu leave with my question :�
16:41:37 <MrsB> scared him!
16:41:41 <coincoin> #topic we need more people!
16:41:44 <leuhmanu> sorry to much lag
16:41:54 <leuhmanu> (don't know why :/)
16:41:54 <coincoin> so, how to atttract ppl in the team? any idea?......
16:42:03 <coincoin> leuhmanu: to much download! :�
16:42:31 <leuhmanu> no, nothing at the moment
16:42:36 <MrsB> Its difficult. Mga 2 will help.
16:42:46 <MrsB> good leadership ;)
16:42:49 <leuhmanu> and I don't know for have more people
16:43:01 <leuhmanu> It's the same in the bugsquad
16:43:21 <obgr_seneca> and in i18n and in artwork and in...
16:43:21 <coincoin> the big issue is to show "QA is sexy!"
16:43:25 <coincoin> obgr_seneca: :)
16:43:35 * MrsB falls off chair laughing
16:43:49 <obgr_seneca> coincoin: wasn't it you who said in 1.000 users there's only one contributor?
16:43:53 <coincoin> in the grumpy team, there is a lot of ppl!
16:44:10 <coincoin> obgr_seneca: no, but I join this idea!
16:45:10 <MrsB> I think if we can make it simple, with procedures and information, maybe even a backend system at soem point it could make it more accessible for people
16:45:30 <MrsB> and traffic on the ML so people can see things happening
16:45:32 <coincoin> perhaps we can do a QA calendar with nude pic of actual team! :)
16:45:43 <obgr_seneca> :D
16:45:46 <leuhmanu> outch
16:45:46 <MrsB> weekly meetings if we can manage it
16:45:54 <obgr_seneca> I thought you wanted to have more people?
16:46:09 <coincoin> MrsB: I tried weekly meeting in the past. I was alone or only 2 ppl...
16:46:20 <coincoin> obgr_seneca: we are beautiful!
16:46:23 <MrsB> still, it helps to see records of meetings happening
16:46:38 <MrsB> every few weeks or something
16:46:46 <coincoin> #action dams plan weekly meeting
16:46:57 <MrsB> we need people to see there is a team to join
16:47:13 <coincoin> MrsB: it was on friday before but I realized that on friday evening, ppl are in WE. so I changed the date
16:47:28 <MrsB> lol yes I bet
16:47:37 <coincoin> #info MrsB: "we need people to see there is a team to join" << \o/
16:48:11 <MrsB> we don't have much in the way of communication with each other at the moment
16:48:18 <coincoin> so can we keep thursday as the QA meeting day?
16:48:24 <leuhmanu> how many are actually in the QA ?
16:48:44 <coincoin> leuhmanu: hard to know. "how many active ppl" is a better question...
16:48:53 <leuhmanu> yes
16:48:59 <leuhmanu> 10 or less ?
16:49:04 <MrsB> much less
16:49:13 <coincoin> #info QA meeting will be every Thursday at 16:00 UTC if no complains
16:49:28 <coincoin> between 4 and 7 I would say...
16:49:52 <leuhmanu> We need stats from the bugzilla :D
16:50:13 <MrsB> who do we know that knows their way around bigzilla... :D
16:50:23 <MrsB> bug even
16:51:22 <MrsB> I think there are more people testing mga 2 than normally involved with qa for mga 1
16:51:44 <leuhmanu> yep
16:52:00 <obgr_seneca> there are those people who did the qa on mga1 isos
16:52:45 <obgr_seneca> magnus or me for example
16:52:51 <coincoin> obgr_seneca: yes but as we told before "those people..." only a few one were usefull... :/
16:53:10 <obgr_seneca> yep
16:54:13 <coincoin> so, I hope that isocheck and the new "check box" page for QA ISO will help for next ISOs
16:54:38 <MrsB> i think they will, they're certainly a step in the right direction
16:54:42 <coincoin> #info try to attract ppl by showing QA is alive and working hard for world
16:55:35 <coincoin> #info QA will rule the world!
16:55:45 <coincoin> anything to add on this point?
16:55:45 <MrsB> #info lol
16:55:47 <coincoin> :)
16:56:40 <obgr_seneca> I always thought I would rule the world...
16:56:49 <MrsB> I think we will see an influx of new people when mga 2 is released, until then we probably just have who we have.
16:56:50 <obgr_seneca> must have mistaken something there
16:57:19 <coincoin> :)
16:57:53 <coincoin> MrsB: Yes but tasks will be hard for too few ppl. I hope other will join us in the way of mga2 to have a perfect distro
16:58:18 <coincoin> #topic open QA
16:58:23 <coincoin> any open topics to add?
16:58:35 <leuhmanu> and for now we can forget the LTS I guess
16:58:37 <MrsB> we could have some test weekends or test weeks for mga 2
16:59:03 <MrsB> leave less important qa on 1 and dedicate our time to mga 2 for a time
16:59:11 <coincoin> MrsB: we had test WE for mageia1
16:59:16 <coincoin> but not a big success
16:59:29 <coincoin> ah ok, not the same thing
16:59:55 <coincoin> yes, why not. but we always ONE ppl at least on mageia1 for following updates of other things
17:00:17 <MrsB> the difficult part is getting the message out to people, i dont think our problem is that people aren't willing to help, just don't know we need it or don't know how to
17:00:23 <coincoin> we can perhaps have a "mageia 1" or "updates" chief, a "ISO" chief, ...
17:00:59 <MrsB> unless there are any security updates then i think we're ok for a few days on mga 2
17:01:14 <MrsB> we can apply common sense
17:01:36 <MrsB> after the new year though preferably
17:02:37 <MrsB> all common sense is suspended over christmas :)
17:02:59 <coincoin> champagne! \o/
17:03:02 * MrsB hic
17:03:22 <coincoin> or so perhaps we can try this idea in January: "a dedicated week on mga2"
17:03:27 <MrsB> yeah
17:03:37 <MrsB> publicise it well before hand
17:03:54 <coincoin> #action MrsB will work on thinking about a dedicated week on mga2
17:03:55 <coincoin> :)
17:04:00 <MrsB> :\
17:04:12 <coincoin> I can't take your idea... O:-)
17:04:25 <MrsB> it was yours to begin with
17:05:10 <coincoin> don't worry, we will talk about it on next meeting ;)
17:05:41 <coincoin> so, any other point or 'it's Christmas time!"?
17:05:41 <MrsB> yes, when do you think you'll have the check boxes done?
17:05:53 <coincoin> on next week on the QA wiki
17:06:01 <MrsB> great :)
17:06:08 <coincoin> #action dams to put on the wiki his 'QA check box' page
17:06:08 <MrsB> phone
17:06:36 <leuhmanu> do we know when we can test the upgrade to mga 2 ?
17:07:01 <coincoin> not before systemd entirely in place...
17:07:13 <leuhmanu> for the 1 I have to it for the beta2 iirc
17:07:25 <leuhmanu> hum yes indeed :)
17:07:27 <coincoin> it's good to start test upgrade in beta to have all fixes for rc
17:07:58 <coincoin> so... endmeeting? :)
17:08:08 <MrsB> ok 4 me
17:08:13 <leuhmanu> me too
17:08:17 <coincoin> ok
17:08:19 <coincoin> #endmeeting