17:12:41 <coincoin> #startmeeting
17:12:41 <Inigo_Montoya> Meeting started Fri Aug  5 17:12:41 2011 UTC.  The chair is coincoin. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:12:41 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:12:59 <coincoin> #chairs MrsB Jehane DavidWHodgins coincoin eskroni Stormi
17:13:09 <coincoin> #chair MrsB Jehane DavidWHodgins coincoin eskroni Stormi
17:13:09 <Inigo_Montoya> Current chairs: DavidWHodgins Jehane MrsB Stormi coincoin eskroni
17:13:34 <coincoin> #topic welcome ppl
17:14:04 <coincoin> so, I know that QA meeting were missing last months but, now, here we are
17:14:22 <coincoin> welcome all, anyone new would like to present himself?
17:14:45 <coincoin> I'm Damien Lallement (dams/damsweb/coincoin)
17:14:45 <MrsB> Hiya, Im new
17:15:06 <MrsB> Im Claire Robinson, claire on the forums
17:15:11 <MrsB> Uk based
17:15:28 <DavidWHodgins> I'm Dave Hodgins, from London, Ontario, Canada.
17:15:43 <Stormi> Samuel Verschelde, Lyon, France
17:15:58 <coincoin> I forgot, I'm from Paris
17:16:01 <eskroni> Hi, I'm new too. :)
17:16:01 <eskroni> I am Sigrid Carrera, currently Lund, Sweden.
17:16:07 <Jehane> Marianne, from Paris (France not Texas)
17:16:42 <MrsB> Its good to meet you all
17:16:48 <coincoin> great, so, hello all and welcome on this wonderful team! :)
17:17:33 <eskroni> thanks.
17:17:35 <coincoin> first, I would like to choose the Friday as the QA meeting day. Do you all agree? 5:00 UTC is good for all of you?
17:17:53 <DavidWHodgins> Fine with me.
17:18:09 <eskroni> yes, that's a good time for me.
17:18:10 <MrsB> Yes it should be Ok with me
17:18:13 <Stormi> ok
17:18:28 <coincoin> #info QA meeting will attend each Friday at 5:00 UTC
17:18:45 <coincoin> (you can add info by doing like this is needed: it will improve logs)
17:19:17 <Stormi> #info #info improves logs
17:19:24 <coincoin> :)
17:19:26 <MrsB> :D
17:19:39 <coincoin> #topic qa roles
17:19:50 <coincoin> so, i quick reminder...
17:19:58 <coincoin> QA team must:
17:20:14 <coincoin> - validate updates (security updates or normal updates)
17:20:31 <coincoin> - report bugs on main component as installer, desktop, web browser, ...
17:20:55 <coincoin> - slap dev team to have bug resolved
17:21:19 <coincoin> - try to improve Mageia by working on projects like 'auto-test', ...
17:22:00 <coincoin> #info QA validates updates (sec or not), report bugs on main components (installer, ...), follow bugs reports and try to improve mga with QA projects
17:22:18 <coincoin> any remarks/question?
17:22:25 <MrsB> What is auto-test?
17:23:04 <eskroni> It sounds like automatic testing, at least, that's my guess.
17:23:25 <coincoin> auto-test is a project of having computers (clients/servers) always validating/checking the distribution by doing network installation to test new packages
17:23:32 <coincoin> eskroni: right
17:23:54 <coincoin> we will speak more about it in the last part of the meeting
17:23:55 <MrsB> ahh ok thankyou
17:24:33 <MrsB> what is the best way to contact the various teams?
17:25:07 <coincoin> MrsB: you can contact other teams by checking their page on the wiki
17:25:19 <coincoin> or by subscribing to ML (ml.mageia.org)
17:25:29 <coincoin> https://ml.mageia.org/
17:25:34 <DavidWHodgins> I have a question.  When an update fixes a bug, but other bugs are found (not regressions), should the update go ahead anyway?  kolab-webmin
17:26:24 <Stormi> I'd say it depends whether the bug can be quickly solved or not
17:26:34 <Stormi> and on the severity
17:27:37 <coincoin> DavidWHodgins: it depends on the other bugs but if bugs are on the package, they should be solved before pushing only if broking something else. If minor bugs, update can be pushed if the fixed bug is more important than the new one. but all this issue can be discussed on qa-discuss@ ML ou on -dev ML
17:27:54 <coincoin> so, let's talk about organization
17:28:01 <coincoin> #topic QA organization
17:28:20 <coincoin> #info qa-discuss@ is the ML to talk about QA stuff
17:28:26 <coincoin> I think you all know it :)
17:28:54 <coincoin> you can also join qa-bugs to receive a mail when a bug need QA approval/validation
17:29:24 * eskroni will subscribe to this ml
17:29:29 <Stormi> yes, that's very useful so that you can react and help testing
17:29:39 * MrsB did that bit
17:29:46 <coincoin> for now, it will be great to see the team growing as 5 ppl (even if motivated ppl) is quite short...
17:30:20 <coincoin> QA is a new thing for all of you or are you friend with QA?
17:30:25 <Stormi> we are more than 5 I think. zezinho and leuhmanu for example are very active
17:30:33 <MrsB> It is new for me
17:30:45 <Stormi> djennings: is quite active too
17:30:50 <MrsB> I have reported bugs but never been actually part of any team
17:31:39 <DavidWHodgins> My background is mainframe software development (cobol, ims, db/2, etc).  Lots of testing.
17:31:49 <eskroni> MrsB: Same is true for me as well.
17:31:57 <MrsB> :)
17:32:03 <coincoin> Stormi: I said 5 like I would have said 10 :)
17:32:05 <MrsB> We can help each other then
17:32:08 <coincoin> it's to short
17:32:19 <Jehane> same for me, I report bug but I'm not part of the team
17:33:40 <coincoin> ok so for a good organization and a good way of work, we will need to have a lot of process written down. Process help work and offer to be sure of the work done
17:34:08 <DavidWHodgins> I think ppl are not used to the idea, that if you want to be part of the team, you just have to decide you are part of the team.  Not wait for someone to approve you joining.
17:34:32 <coincoin> before next week meeting, I would like to have the QA wiki better than now... who is interessted in writting QA process or helping on it?
17:34:52 <DavidWHodgins> I'm willing to help.
17:35:02 <MrsB> I can help, once I know what it needs
17:35:11 <coincoin> DavidWHodgins: right, all mga team are open to volunters
17:35:33 <MrsB> Yes I wondered about that DavidWHodgins
17:35:36 <Jehane> I can proofread but I don't have enough time or english skills to write
17:35:50 <coincoin> #action coincoin working on a new QA wiki to improve work in the team
17:36:07 <eskroni> I can help too, but like MrsB, I'm not sure what to do.
17:36:18 <coincoin> #action DavidWHodgins MrsB will help
17:36:32 <coincoin> #action Jehane will proofread the work
17:36:41 <coincoin> #action eskroni will help too
17:36:51 <Stormi> same as Jehane, it will be mainly proofreading
17:37:08 <Stormi> or write some parts if I feel sure enough
17:37:16 <coincoin> ok so my idea is to work on a canevas for Thuesday, discussing it on the ML and to ask task once this canevas ready
17:37:30 <coincoin> #action Stormi will proofread the work too
17:38:04 <coincoin> the main idea is to have the team ready for Monday the 15th
17:38:28 <Jehane> coincoin: the new wiki will be deployed soon ?
17:38:48 <MrsB> I will be away that week probably for a holiday but until then its no problem
17:39:09 <coincoin> Jehane: no, we will work on the actual one for now
17:39:19 <Stormi> s/actual/current/
17:39:44 <coincoin> MrsB: great, you will help after if needed, there is a lot of work don't worry :)
17:39:59 <MrsB> Well, I am pleased to be able to help
17:40:08 <coincoin> any comment on this organization?
17:41:06 <Stormi> ok for me
17:41:21 <eskroni> sounds good to me, no complaints
17:41:28 <coincoin> #action dams to work on a canevas for Thuesday
17:41:36 <coincoin> ok, good
17:41:51 <Jehane> coincoin: ok
17:42:00 <coincoin> #topic Updates request
17:42:24 <coincoin> so, the only process available for now is my process for qa_updates
17:42:32 <coincoin> I don't know if you all know it
17:42:45 <coincoin> http://www.mageia.org/wiki/doku.php?id=qa_updates
17:42:48 <eskroni> I certainly don't know it.
17:42:49 <coincoin> #info http://www.mageia.org/wiki/doku.php?id=qa_updates
17:43:12 <coincoin> I advise you to read it, to create you bugzilla account and to start browsing bugzilla to be familiar with it
17:43:31 <coincoin> you can also read http://www.mageia.org/wiki/doku.php?id=qa_bugzilla
17:43:37 <coincoin> #info http://www.mageia.org/wiki/doku.php?id=qa_bugzilla
17:44:16 <coincoin> here are all the process/pages I wrote about QA: http://www.mageia.org/wiki/doku.php?do=search&id=qa_
17:44:22 <coincoin> #info here are all the process/pages I wrote about QA: http://www.mageia.org/wiki/doku.php?do=search&id=qa_
17:44:27 <MrsB> The process maybe ought to say how to remove the core/testing media once testing is complete
17:44:34 <DavidWHodgins> Will the push script be available soon, or should the wiki be changed to add the keyword validated_update and cc mageia-sysadm@mageia.org ?
17:44:51 <coincoin> MrsB: for know this job is doing by a few admin ppl
17:45:07 <coincoin> MrsB: we are working on it in sysadmin team give rights to other ppl
17:45:15 <MrsB> No not that..
17:45:37 <coincoin> it's a wiki, feel free to fix, improve it
17:45:41 <MrsB> One the wiki page it says how to add the repository but not how to remove it :)
17:45:49 <eskroni> Oh, I guess you can just disable the source in the MCC (just remove the checkmark)
17:46:22 <coincoin> MrsB: hum, ok. I can add it "urpmi.removemedia medianame"
17:46:47 <coincoin> eskroni: yep, right too
17:47:19 <coincoin> so please read these pages
17:47:50 <eskroni> I will.
17:48:05 <coincoin> to talk about the topic, will be great to see the number of "updates waiting for QA" to go down
17:48:26 <coincoin> there are a lot of importants updates waiting for us, for you! :)
17:48:40 <coincoin> firefox5, kde, ...
17:49:06 <Stormi> about that, note that the best bugzilla saved queries are those shared by manuel hiebel
17:49:54 <Stormi> they take care to not miss relevant bug reports
17:50:22 <Jehane> coincoin: thunderbird5 ?
17:50:29 <Stormi> https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=waiting%20for%20QA%20test&sharer_id=22 and https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=updates-push&sharer_id=22
17:50:36 <coincoin> careful, their are "updates request" and "other bugs that will become update request on day" :)
17:50:53 <coincoin> Jehane: hum, I can't see it, what's the #?
17:51:14 <coincoin> for know we are talking about "updates request"
17:51:20 <Jehane> coincoin:  #2088
17:51:54 <coincoin> Jehane: it's not an update request, it's a package demand
17:52:09 <Stormi> we should call them update candidates
17:52:17 <Stormi> no ambiguity
17:52:17 <coincoin> an update request is a bug posted by the mainteneur of a package to update it
17:52:24 <Jehane> coincoin: ok
17:52:48 <Stormi> coincoin: update request yields also for people asking for a newer version, so best use update candidates
17:53:20 <coincoin> not in my brain but... if you want :)
17:53:48 <Stormi> it would be clearer for people not used to the specific meaning QA team gives to updates requests
17:54:25 <coincoin> #info stormi ask to use update candidates instead of update request not to missunderstood with package update request on bugzilla by users
17:54:28 <Stormi> and matches madb's naming (but that's a detail) : http://88.191.121.20/madb/mageia/
17:55:20 <coincoin> ok, just a big point, when working on a package, don't forget to test on both arch! i586 AND x86_64
17:55:32 <coincoin> any other point on this topic?
17:55:51 <Stormi> yes, we will have to choose how to test complex packages
17:55:54 <Stormi> such as KDE, firefox
17:56:07 <Stormi> where "it works here" x 2 is not enough
17:56:21 <Stormi> and how to decide that the update is ready
17:56:29 <eskroni> How do I test on both architectures, if I have only one?
17:56:42 <Stormi> eskroni: you can test one, and someone else the other
17:56:51 <Stormi> eskroni: and it's better  to have 2 different testers
17:57:01 <coincoin> <Stormi> and how to decide that the update is ready << that's the goal of the process
17:57:19 <coincoin> that's why we need a lot of important process right now
17:57:26 <Stormi> indeed
17:57:44 <coincoin> eskroni: or you can use virtual machine for some kind of bugs
17:59:49 <eskroni> ok, I see. I know, that a virtual machine doesn't work for all the testing, but at least for some it could work. Thanks. I should have thought of this myself. And thanks to Stormi too. ;)
18:00:20 <coincoin> yw, all questions are good :)
18:00:48 <coincoin> #info don't forget that you can use a VM for some kind of bugs
18:00:51 <DavidWHodgins> Deciding on when an update is ready, has to be done on a case by case basis, depending on whether the scope of the change, and the importance of the package.
18:02:03 <coincoin> an update is "ready" when the advisory provided by the maintainer is good @ 100% and that we didn't noticed any regression
18:02:17 <coincoin> but after it can depend on case by case, agree
18:03:14 <coincoin> ok, I think that we already have a lot of work for the next week... :)
18:03:28 <coincoin> #topic open discussion
18:04:00 <coincoin> anything else? I think we will talk about automated test next time as it's not a big part for next weeks
18:04:10 <Stormi> yes, backports
18:04:26 <coincoin> #topic backports
18:04:30 <coincoin> Stormi: go ahead
18:04:44 <Stormi> In the backports process I proposed (not adopted for now) I proposed that they follow the same policy as updates, but slightly lighter
18:04:56 <Stormi> and provided backports testing don't delay updates testing
18:05:09 <Stormi> would you be ok with that approach ?
18:05:22 <Stormi> to consider our backports as first class citizens
18:06:23 <coincoin> hum backports testing and updates (core) testing are different, you mean having package going to backport testing in the first step?
18:06:56 <DavidWHodgins> Yes, I think backports should be tested, but simply that it installs, and appears to work.
18:07:06 <Stormi> coincoin: backports go to backports_testing, a bug is assigned to qa-bugs (or qa-backports-bugs), then pushed if ok
18:07:17 <Stormi> same as updates, but with maybe less testing
18:07:40 <DavidWHodgins> That sounds good to me.
18:08:04 <Stormi> I know that it was different back in mandriva, but we have the ambition to have good quality backports :)
18:08:10 <coincoin> yes, I agree with this idea as backport are often package already available in "core" but with newer release
18:08:33 <coincoin> in MDV QA didn't test backport... :p
18:08:37 <coincoin> Stormi: :)
18:08:40 <Stormi> yep, I know :)
18:08:56 <MrsB> If the releases are going to be less often then backports are going to become more important imho
18:09:03 <Stormi> indeed
18:09:22 <eskroni> that's a good point
18:09:22 <Stormi> that's my main topic of interest :)
18:09:53 <coincoin> if we are 100 ppl in QA, less testing backport won't be a discussion but as we are a few ppl for now... I agree
18:10:12 <Stormi> yes, that's a compromise
18:10:33 <Stormi> also, we hope to make people asking for backports test them
18:10:47 <Stormi> so that's a first step which doesn't require QA team work :)
18:11:02 <coincoin> :)
18:11:25 <DavidWHodgins> Qa still has to co-ordinate, and ensure the testing gets done, and submit the push request, when it's ready.
18:11:30 * coincoin thinks that Stormi is in war against backports
18:11:44 <Stormi> coincoin: not against, pro
18:11:53 <Stormi> I like backports
18:11:58 <Stormi> I just want them to be good
18:12:01 <eskroni> :) only a minor difference.
18:12:02 <coincoin> Stormi: yep but I was talking on QA side ;)
18:12:15 <Stormi> war against bugs then
18:12:26 <coincoin> we are all :)
18:12:39 <coincoin> QA Team, ROUND 1 - FIGHT!
18:12:55 <MrsB> :D
18:13:24 <coincoin> Stormi: thank you for sharing your idea
18:13:32 <coincoin> anything else?
18:13:55 <Stormi> yes, but maybe we can discuss it on ML
18:14:15 <coincoin> as you wish, you can try here :)
18:14:16 <Stormi> who can get updates push rights (once it will be feasible technically)
18:14:26 <Stormi> the sysadmins are overloaded
18:14:33 <coincoin> Stormi: I told about in the meeting
18:14:44 <Stormi> and many "ready" updates have waited for a week
18:14:50 <coincoin> Stormi: WIP, a few ppl will have rights soon
18:15:16 <coincoin> Stormi: yep, boklm was in holidays and the script is his baby...
18:15:25 <coincoin> a lot of things are still hand made
18:15:33 <Stormi> coincoin: my question is about that "few people"
18:15:48 <coincoin> #action dams to see with sysadmin about pushing updates
18:16:11 <coincoin> Stormi: "that few people" means ldap account, catdap patch, etc...
18:16:18 <coincoin> that's why it's WIP
18:16:25 <Stormi> coincoin: you don't understand me
18:16:33 <Stormi> I know there's a technical side of things
18:16:37 <Stormi> but my question is organisational
18:16:50 <MrsB> You mean Who rather than How?
18:16:54 <coincoin> with misc holiday and boklm out of France next week with pterjan, I'm the only one from sysadmin here for now
18:17:02 <Stormi> i was thinking for example about an experienced QA team member status which gives this right
18:17:14 <coincoin> Stormi: that's what I explained
18:17:16 <Stormi> starting with very few people but growing with time
18:17:30 <coincoin> we can't have it for now as it needs technical modificatoins
18:17:40 <Stormi> coincoin: you said few people but now how those few peoples are chosen
18:17:54 <DavidWHodgins> I think the starting point, should be the people who have been submitting push requets, that have been accepted.
18:18:01 <coincoin> for now, those few people are : boklm as he is working on this script
18:18:19 <coincoin> after ppl will be choosen by council I think
18:18:31 <Stormi> why not by QA team itself ?
18:19:08 <DavidWHodgins> The sysadmins are responsible, so they should decide who they can trust.
18:19:39 <Stormi> ok
18:19:39 <coincoin> council can choose QA team ppl you know. As it's a big part (like the sec team rights), we need council discussion (opened discussion, like for secteam members)
18:19:59 <Stormi> no more questions for now :)
18:20:12 <coincoin> DavidWHodgins: we are not talking about trusting by sysadmin (2 ppl of sysadmin are in the board ;))
18:21:12 <Stormi> my point was, sysadmins are not chosen by the council AFAIK, so maybe QA updates pusher don't need a council decision either
18:21:15 <DavidWHodgins> Sorry. Mixing up sysadmin team and board.
18:21:58 <MrsB> Maybe council should have veto?
18:22:12 <Stormi> maybe, but I don't think that would be needed
18:22:18 <coincoin> Stormi: sysadmin only manage server, they can't break all mga desktop in the word by stopping a mail server for example ;))
18:22:27 <Stormi> coincoin: yes they can
18:22:35 <Stormi> coincoin: they can push any package
18:22:38 <coincoin> updates is like secteam : the most important task for users
18:24:01 <coincoin> so, I will send you information about this request on the ML after disucssing it on council (public ML)
18:24:06 <coincoin> no other point?
18:24:35 <MrsB> Other than to say thankyou :)
18:25:53 <eskroni> yes, a very important point! Thanks MrsB  - and a big thank you to coincoin
18:26:03 <coincoin> thank you to all of you, see you next week, same channel, same hour :)
18:26:10 <coincoin> #endmeeting