15:12:14 <damsweb> #startmeeting
15:12:14 <Inigo_Montoya> Meeting started Thu Feb  3 15:12:14 2011 UTC.  The chair is damsweb. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:12:14 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:12:34 <damsweb> #chairs damsweb coincoin boklm dmorgan nocktames
15:12:46 <damsweb> #chair damsweb coincoin boklm dmorgan nocktames
15:12:46 <Inigo_Montoya> Current chairs: boklm coincoin damsweb dmorgan nocktames
15:13:09 <harms> + harms
15:13:19 <damsweb> #chair harms
15:13:19 <Inigo_Montoya> Current chairs: boklm coincoin damsweb dmorgan harms nocktames
15:13:21 <damsweb> :-)
15:13:28 <damsweb> so Inigo_Montoya is the bot for logs
15:13:55 <damsweb> you can add information during the meeting with #info "the information to highlight in log"
15:14:23 <damsweb> As you know, the bootstrap is almost done (a blog post will be available in a few minutes on Mageeia blog
15:14:42 <damsweb> so we will soon be able to have Mageia installed on computer
15:15:00 <damsweb> and so... QA will have to start his job :-)
15:15:34 <damsweb> I already know nocktames, dmorgan, boklm and stormi (they all come from mandriva community)
15:15:41 <damsweb> harms: do you already know QA?
15:16:27 <harms> I am a pure, but very (past) Mandriva conscient user - have "seen" QA, but can only guess how it works
15:16:54 <damsweb> ok, so welcome :-)
15:17:18 <damsweb> #topic different roles of QA
15:18:03 <damsweb> As we start "from scratch for everything (QA inside), will be great to list all the field where you think that QA must work
15:19:08 <damsweb> My list is : Desktops/control center/install/X/sane/cups/kernel/browsers/samba/nfs/updates/office/automatic test/building ISO
15:19:29 <damsweb> do you think about anything else?
15:21:03 <harms> some key applications? eg http editing?
15:21:40 <damsweb> harms: ok, like internet applications (kopete, nvu, irc...?)
15:22:31 <damsweb> #info QA will be shared between Desktops/control center/install/X/sane/cups/kernel/browsers/samba/nfs/updates/office/automatic test/building ISO/Internet applications
15:22:38 <harms> yes, similar. Probably to be decided as we go - I just want clarity about our "state of mind"
15:22:56 <damsweb> yes, that's important
15:23:22 <damsweb> we also need a "secteam" to work with QA on pushing updates
15:23:31 <damsweb> #info we also need a "secteam" to work with QA on pushing updates
15:24:13 <damsweb> and I think that we should work on automated test on the BS (build system) to test packages just after the output of the BS
15:24:22 <harms> can we make "how we work/organise" a point to be discussed ?
15:24:25 <damsweb> it will prevent broken packages or dependencies
15:24:40 <damsweb> harms: yes sure, this is the next point
15:25:13 <damsweb> #info we should work on automated test on the BS (build system) to test packages just after the output of the BS to prevent broken packages or dependancies
15:26:26 <damsweb> #topic Tasks to be done to set up the QA
15:26:48 <damsweb> So we first need to write process
15:27:18 <damsweb> harms: that's what you were thinking about?
15:27:40 <harms> I guess, still try to interpret PROCESS
15:28:40 <harms> Probably there are different components: how does QA as an entity work , how does QA work between participants
15:28:53 <damsweb> a process is the way you need to follow to test something (for example if you want to test X, it will explain you all the steps to follow to test X : install computer, and the command to perform to test X)
15:29:23 <harms> I see: a third technical component: methods
15:30:08 <harms> But, please shove my questions aside if I am too naive - I consider myself an apprentice
15:30:12 <damsweb> yes, for the way QA work between participants, I will talk about ML/wiki and bugzilla on a next topic
15:30:37 <damsweb> harms: your question are good as they are helping the debate :-)
15:30:59 <damsweb> nocktames, dmorgan: any opinion? :-)
15:31:49 <damsweb> harms: would you be interessted in writing process for the field you like?
15:32:19 <harms> I think that this is too early - I need examples
15:32:56 <damsweb> #info before asking people to write process, I must provide examples on the wiki
15:32:59 <damsweb> k
15:33:48 <harms> second issue: apprentices need to focus on specific fields where they feel committed and knowledgable
15:33:48 <damsweb> bad we are not a lot of ppl here as it will be interessting to talk about process and automated tests with people. perhaps during next meeting
15:34:17 <harms> Do you have examples of fields?
15:34:28 <damsweb> yes, right, that's why we first list the differents fields we thought about
15:34:52 <damsweb> the fields are :  Desktops/control center/install/X/sane/cups/kernel/browsers/samba/nfs/updates/office/automatic test/building ISO/Internet applications
15:34:57 <nocktames> how would you display all process ? any admin tool ready to work like trac or bugzilla ? (bugzilla : ok) but  where can we write any process ?
15:35:21 <nocktames> or just using wiki ?
15:35:21 <damsweb> so for example, a process could be "how to test kopete" or "how to test printing on libreoffice"
15:36:07 <damsweb> nocktames: I think that process should be in the wiki as it will allow a lot of people to have access to it
15:36:21 <damsweb> bugzilla will only be used as a bug tracker
15:36:28 <harms> how much automation is possible, how much converativity is indicated as we just start and rapidly want to start cracking?
15:36:40 <nocktames> i think, we have to make 2 categories : HARD & SOFT :p
15:36:49 <nocktames> it previous to test hard ?
15:37:30 <damsweb> nocktames: yes will depend on HW ppl can have @home or @work and if we will be able to have a lab for manufacturers to send us HW
15:38:11 <damsweb> harms: automation is now allowing a lot of things on linux : we can emulate mouse click or other thing on a screen
15:38:41 <damsweb> or automation can just be: test the installation of a samba server and check read/write on it
15:38:55 <harms> how to get knowledgable about existing tools?
15:39:02 <nocktames> ok, so in first, we need to organize this, make a list about hardware we have, make a list about all soft able to be testing with priority marks
15:39:21 <damsweb> #info make a page explaining automated test and process
15:39:54 <dmorgan> damsweb: i don't know mdv  a lot but the kind of "testzilla" you had ?
15:40:00 <damsweb> harms: you can get this knowledge be browsing the internet or be asking ppl on IRC channels or ML
15:40:54 <harms> list of hardware: what can we get from manufactureres, what can we access at nearbyy "friends?" - add to the list?
15:41:23 <damsweb> dmorgan: testzilla we had was a product made by warly and flepied from scratch (no backup by MDV...), we be a huge but very good thing to do a new testzilla as this one (was checking output of the BS and was testing packages depending on packages built (X, ntp, mail, samba...)
15:41:46 <nocktames> on wiki QA_page, update the "ressources" List & "what's hot" list, no ?
15:42:25 <damsweb> nocktames: yes I will update the page after the meeting (was waiting for the meeting to be done to see people involved :-))
15:42:31 <nocktames> ok
15:42:50 <damsweb> # check all the automated test solution available and benchmark them
15:43:11 <damsweb> dmorgan: would you like to do this search? :-)
15:43:31 <damsweb> #action dams will update wiki page to explain process/qa/meeting
15:44:27 <nocktames> so, about "what's hot", we have to see with R&D, it seems to be better... they say to us on what they're working in priority.
15:45:05 <damsweb> #info see with dev team the "hot things" to test first (as nocktames underlined)
15:45:34 <damsweb> nocktames: first it will be the basesystem/kernel/X (the first ISO will be a very light one)
15:45:35 <harms> I see a question of equilibrium: sharpening / Improving tools vs. pragmatically and rapidly  producing QA for the coming release
15:46:06 <nocktames> damsweb: would you get a list about all hardware ressources could be testing now ? or using ML and you'll update wiki ?
15:46:09 <damsweb> nocktames: do you want to start a list on what's hot?
15:46:45 <damsweb> nocktames: for now I have no idea of HW available by people. I need to ask on ML/wiki/twitter first
15:47:23 <damsweb> nocktames: do you want to work on the HW part by asking people?
15:47:24 <nocktames> damsweb: ok aout iso, but about list "what's hot" is probably better to see with R&D i thought
15:47:42 <damsweb> nocktames: yes, I put your idea on the last #info ;-)
15:48:17 <nocktames> damsweb: dunno, if got lot of time on this, but i can do a list on all hardware ressources available i got for mageia test
15:48:26 <damsweb> nocktames: great
15:48:51 <nocktames> hi wanne
15:48:51 <damsweb> #action nocktames will do a list of the HW he can provide for Mageia QA
15:48:58 <damsweb> hello wanne
15:49:23 <damsweb> hi rda
15:49:27 <rda> damsweb: \o/
15:49:29 <wanne> hi
15:49:33 <rda> hi all
15:49:37 <nocktames> hi
15:50:00 <damsweb> rda: as you are here, does QA team will need to do some QA on website or web apps from Mageia?
15:50:36 <rda> damsweb: probably, but I did not think of this thoroughly. I expect most of this to be run in scripts (selenium and others)
15:50:42 <rda> but that would still need to be setup.
15:50:45 <stormi> hi, sorry I couldn't attend, a meeting at work was longer than expected
15:51:01 <stormi> (and another meeting starts in 10 minutes)
15:51:07 <damsweb> #info see with webteam the need for QA on website or webapps
15:51:46 <damsweb> stormi: ok, I hope you will be available next time. thank for coming. I will send a email after meeting
15:52:14 <stormi> I would like to add, as a subject to study, QA on backports
15:52:40 <stormi> they don't have the same level of support usually, but a minimal QA could be great
15:52:56 <stormi> even if the goal is to have users test themselves and just provide the framework for it
15:52:59 <damsweb> stormi: yes, I didn't thought about backports
15:53:03 <damsweb> you're right!
15:53:23 <damsweb> #info as stormi noticed, will be great to make so QA on backports
15:53:41 <damsweb> so, next topic
15:53:55 <damsweb> #topic tools to be used to communicate between QA members and other teams
15:54:37 <damsweb> After the meeting I will add people to the QA ML
15:54:49 <damsweb> #info a ML will be set up ASAP
15:54:50 <nocktames> damsweb: stormi : it what i said about trac or something like that !
15:55:40 <damsweb> nocktames: can you explain please? I don't understand
15:55:55 <nocktames> and if possible, any tool to inventory hardware, because wiki is not easy for this
15:56:15 <damsweb> nocktames: do you have an idea on what tool we should use?
15:56:34 <nocktames> glpi
15:56:49 <damsweb> #info the bug tracker is bugzilla and can be found on bugs.mageia.org
15:57:07 <damsweb> nocktames: glpi is huge for our need I think. Don't you?
15:57:24 <nocktames> damsweb: hardware inventory : glpi, and project around any process, use trac
15:58:00 <nocktames> damsweb: perhaps, but glpi is not so huge in practice :p
15:58:24 <damsweb> nocktames: yes but the discussion about bug tracker is far away now and bugzilla wins :-)
15:58:25 <nocktames> just an sql db & a frontend
15:59:00 <nocktames> damsweb: oh, ok i don't see that on ML, probably in vacation :p
15:59:12 <stormi> in the tools topic, every functionality that could help can be envisioned on mageia-app-db. Easy listing of testing packages is already planned, but if we can couple that with other QA tools, why not.
15:59:22 <damsweb> yes but we must be sure that it worth it as we don't know if we will have HW for a long time or just 1 2 days
16:00:14 <damsweb> #info (stormi) every functionality that could help can be envisioned on mageia-app-db. Easy listing of testing packages is already planned, but if we can couple that with other QA tools, why not.
16:00:41 <damsweb> #info as already said, a wiki will be used for the team
16:01:00 <damsweb> #info still need to see were we will put process
16:01:17 <stormi> by saying a wiki, you mean a section in the common mageia wiki I guess ?
16:01:19 <damsweb> I need to check if testlink can be a good solution for process
16:01:36 <damsweb> stormi: yes that what I meant
16:01:37 <nocktames> damsweb: would you begin a template about process of testing seems like that : http://www.w3.org/QA/WG/2003/09/OpsET-qapd-20030922.html but specific for a distrib
16:01:53 <stormi> will we review other distributions processes ?
16:02:25 <damsweb> I already review the fedora one and the Mandriva one O:-)
16:02:54 <stormi> ok, adding the debian one could give another point of view too
16:02:57 <damsweb> nocktames: I was thinking to start from a Mandriva process as I know they are good and easy to understand
16:03:00 * stormi must already go
16:03:05 <stormi> see you later :/
16:03:27 <nocktames> damsweb: yeah good idea, don't stole mine :p
16:03:28 <damsweb> #info template that can be used for process  http://www.w3.org/QA/WG/2003/09/OpsET-qapd-20030922.html
16:03:31 <damsweb> nocktames: ;-)
16:03:43 <damsweb> see you stormi. thanks for the tips
16:04:12 <damsweb> harms: so I will send you an example of process ASAP to show you what it's about
16:04:22 <nocktames> have to go, beer time ! :p (but keep open to get logs) cya all !
16:04:33 <harms> Thanks, will give me some work
16:05:08 <damsweb> thank you nocktames. will we see you @fosdem this WE?
16:05:29 <damsweb> harms: from which country do you come from?
16:05:30 <nocktames> damsweb: can't :/
16:05:31 <damsweb> I don't remember
16:05:50 <harms> Living in Geneva, but I am Autrian
16:05:51 <damsweb> nocktames: see you soon in Paris!
16:05:58 <damsweb> harms: ok
16:06:07 <nocktames> damsweb: you welcome !
16:06:28 <damsweb> so...
16:06:36 <damsweb> dmorgan, harms: any other remark?
16:06:42 <damsweb> rda: same question :-)
16:07:32 <rda> ok for me
16:08:00 <harms> I need some watching to see how I can progress as an apprentice
16:08:28 <damsweb> k, this is quite a positive point :-)
16:09:12 <damsweb> So I will try to do a new meeting next week. I will create the ML and ask on it for an hour better for people
16:09:38 <damsweb> #info create the ML and ask people for a better hour for next meetings
16:09:47 <damsweb> #undo
16:09:47 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x858326c>
16:09:55 <damsweb> #action create the ML and ask people for a better hour for next meetings
16:09:57 <damsweb> #undo
16:09:57 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x85830ec>
16:10:04 <damsweb> #action create the ML and ask people for a better hour for next meetings (dams)
16:10:22 <damsweb> #endmeeting