19:02:40 <DavidWHodgins> #startmeeting
19:02:40 <Inigo_Montoya> Meeting started Thu Sep 20 19:02:40 2018 UTC.  The chair is DavidWHodgins. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:40 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:45 <DavidWHodgins> #topic * Who's new? - If you are then come and say hello
19:03:03 <DavidWHodgins> Anyone new here who hasn't been to a qa team irc meeting before?
19:03:49 <DavidWHodgins> #topic * M6.1 iso images testing. How's it going?
19:04:25 * dvg sees netinstall results in riseup pad but is there a 6.1 netinstall? where?
19:04:29 <wilcal> I pounded away on M6.1 x86_64 Plasma Live-DVD yesterday
19:04:43 <DavidWHodgins> dvg: Same rsync directory as the other iso images
19:04:45 <wilcal> it looked good
19:05:03 <dvg> DavidWHodgins: gotcha
19:05:29 <rindolf> hi all
19:05:33 <tmb> dvg: they are in official release tree already
19:05:43 <tarazed> good evening Shlomi
19:05:56 <rindolf> tarazed: hi
19:06:04 <dvg> tmb: then i will find 'm
19:06:41 <DavidWHodgins> Yes, the mageia6.1 directory, not the mageia6.1-rc dir
19:07:04 <tmb> here: http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/install/images/
19:07:05 <[mbot> [ Index of /mirrors/mageia.org/distrib/6/x86_64/install/images/ ]
19:07:34 <tmb> we just have not officially announced them in case they need more fixes
19:07:36 <Benmc> M6.1 only issue for me is still is bug 23420
19:07:37 <dvg> tmb: tx !!
19:07:38 <[mbot> Bug: ['Plasma and XFCE live install unable to complete because of missing text and data entry fields', 'NEW', 'Kernel and Drivers maintainers'] https://bugs.mageia.org/show_bug.cgi?id=23420
19:08:01 <DavidWHodgins> Ah. Sorry, not the testing rsync dir, but on the public mirrors already.
19:08:44 <DavidWHodgins> What's the status of bug 23420
19:08:46 <[mbot> Bug: ['Plasma and XFCE live install unable to complete because of missing text and data entry fields', 'NEW', 'Kernel and Drivers maintainers'] https://bugs.mageia.org/show_bug.cgi?id=23420
19:09:51 <Benmc> it has awork around, but it sometimes make the install near impossible if you have never used the mageia installer before
19:10:27 <MageiaTJ> I didn't see that with my 32-bit Xfce install on my old Inspiron.
19:10:35 <DavidWHodgins> That's a nasty one to have to put in the errata, but if we don't have a fix for it that can be done quickly, I think we are stuck with it.
19:10:44 <DavidWHodgins> Does it only affect some video cards?
19:11:09 <Benmc> i.e. sometimes the info boxes will just be a white blank.
19:11:27 <wilcal> Nvidia?
19:11:41 <Benmc> yep, a common intel one about 8-10 years old. uses intel 810 driver
19:12:51 <Benmc> on the plus side, Mageia is not the only distribution affected
19:13:05 <wilcal> i use i915 here
19:13:08 <DavidWHodgins> bug 23546 only affects classical installs, so doesn't matter
19:13:10 <[mbot> Bug: ['M6.1 plasma5 does not install when choosing all desktop install', 'NEW', 'ISO building group'] https://bugs.mageia.org/show_bug.cgi?id=23546
19:14:26 <Benmc> that one hopefully to be fixed during m7 release
19:15:25 <Benmc> I think also wilcal had this with just a plasmaa installl, ended up with icewm
19:15:38 <DavidWHodgins> bug 23594 is minor. It's not a worth considering as a blocker, so can go in the errata.
19:15:40 <[mbot> Bug: ['Xfce4 Live in Live mode cannot move a file to wastebasket', 'NEW', 'Mageia Bug Squad'] https://bugs.mageia.org/show_bug.cgi?id=23594
19:15:48 <wilcal> yes, i remember that
19:16:28 <Benmc> sorry folks. got to go again....
19:16:32 <wilcal> I've done Vbox and hardware installs here of M6.1 x86_64 Plasma Live-DVD so far so good
19:16:39 <DavidWHodgins> IIRC, icewm is awlays installed when installing as a fallback in case the chosen desktop doesn't work
19:16:51 <DavidWHodgins> s /installing/installed/
19:17:35 <MageiaTJ> FWIW, I was successful in using netinstall to put 32-bit 6.1 Plasma on my Inspiron. Took a while, but it worked.
19:17:46 <DavidWHodgins> That's for the classical iso images, so again, doesnt matter.
19:18:05 <DavidWHodgins> Good
19:18:32 <DavidWHodgins> Does anyone have any bugs they've found that they think should be blockers for the iso images?
19:18:48 <MageiaTJ> Trick is to use the VESA video driver.
19:18:49 <wilcal> In order to test tmb's latest kernels I had to do a ground up netinstall on a Nvidia platform and that went well
19:19:31 <wilcal> and that included Vbox
19:19:34 <DavidWHodgins> tmb: Is it worth it to rebuild the current iso images for a more recent kernel?
19:20:05 <DavidWHodgins> Target date for release is next Tuesday, if iso images and all other teams are ready.
19:20:25 <wilcal> isos as they presently are?
19:20:47 <DavidWHodgins> Yes, unless we have a blocker or tmb wants newer kernels included.
19:20:57 <wilcal> thumbs up from here
19:21:12 <dvg> DavidWHodgins: okay by me for Live ones and if errata checked and posted
19:21:39 <MageiaTJ> +1
19:22:11 <DavidWHodgins> We are only releasing the live iso images, and announcing that the newer netinstall iso images are ready, not the classical iso images.
19:22:43 <DavidWHodgins> The primary purpose of 6.1 is to allow installing on hardware newer than what the 6.0 kernels would boot on.
19:23:25 <tmb> Well, for new kernels... there is also a new potential local privilegie escalation bug: https://www.phoronix.com/scan.php?page=news_item&px=Linux-3.16-4.18-vmacache-bug
19:23:26 <[mbot> [ Linux 3.16~4.18.8 Affected By Another Potential Local Privilege Escalation Bug - Phoronix ]
19:24:34 <tmb> so I'm little mixed if I should respin current testing kernels with only that fix, then we do a "quick" ~24 test that they still boot and flush it out...
19:24:57 <wilcal> your choice
19:26:53 <DavidWHodgins> tmb: Opinion?
19:26:55 <dvg> DavidWHodgins: I only see TJ's findings for netinstall. not sure how many more tested those...
19:28:10 <DavidWHodgins> We have until Tuesday to do more testing. I'll tell council the iso images are ok as far as we know, but that we'll keep testing between now and Tuesday.
19:28:33 <dvg> DavidWHodgins: i will
19:28:43 <dvg> DavidWHodgins: ...tets
19:28:51 <wilcal> i'll keep tinkering
19:30:50 <tmb> I think I'll respin the kernels and we respin new isos... that will probably be better press than "release with known security issues"
19:31:17 <DavidWHodgins> Ok
19:31:25 <wilcal> I have an open Saturday
19:31:34 <DavidWHodgins> Doesn't look like Martin is here right now.
19:33:22 <DavidWHodgins> I'll hold off informing council then, until after some basic tests on the iso images with the new kernels (which have to be tested for regular updates release too).
19:33:50 <DavidWHodgins> #action I'll hold off informing council then, until after some basic tests on the iso images with the new kernels (which have to be tested for regular updates release too).
19:34:30 <DavidWHodgins> #info. One more build of the iso images expected, so new kernels can be included
19:34:52 <DavidWHodgins> #topic * Testing updates - Any questions or problems
19:35:15 <wilcal> A lot of those with only 65-bit ok can be OK'd
19:35:16 <MageiaTJ> Do I need to test the netinstall again?
19:35:22 <wilcal> 64-bit
19:36:07 <MageiaTJ> I went on a validating binge the other evening. I can do that again.
19:36:08 <DavidWHodgins> MageiaTJ: Not sure. As the exploit can not be done during a netinstall, I don't think it's necessary to update them, but that will be up to Martin
19:36:59 <DavidWHodgins> I need to sit down for a few hours and get the adivsories added to svn, so they can be pushed. I'll try to do that later today.
19:37:10 <tmb> actually I'm the one building the netinstall isos ... :)
19:37:28 <DavidWHodgins> Ah. Ok. I didn't know that.
19:37:31 <tmb> or the BS actually as it comes from drakx-installer-images :)
19:38:24 <DavidWHodgins> You're choice then.
19:39:04 <DavidWHodgins> s /You're/Your/
19:39:28 <tmb> I'll look through the kernel changelogs to see if its needed... but iirc there was some fixes for some non-booting systems so it might be wise to build them ..
19:39:32 <dvg> Sorry for previous topic: we test only the iso's with "netinstall" in their name, right?
19:39:36 <MageiaTJ> It's not something I'd choose to do again for myself, but I can for a test.
19:40:28 <dvg> Cause there are also other img's in the same directory
19:41:40 <tmb> well, technically netinstall isos only need testing on real hw if they boot, get network and find the stage2 & rescue images and loads them properly...
19:42:11 <wilcal> where are the netinstall iso's to test?
19:42:13 <DavidWHodgins> Yes. both the netinstall and netinstall-nonfree iso images. The hd_grub iso images, I have no idea what they are for.
19:42:25 <dvg> Righton
19:42:41 <dvg> i only do on real hw ;)
19:42:50 <DavidWHodgins> wilcal: http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/install/images/ or your favorite mirror
19:42:51 <[mbot> [ Index of /mirrors/mageia.org/distrib/6/x86_64/install/images/ ]
19:43:02 <tmb> the rest is a "moving target" as we push updates efter isos are released, so... but you can always test in vbox that it finishes the install if you want..
19:43:13 <wilcal> O thats just on the regular mirror then. Thanks
19:43:52 <dvg> some mirros have 'pub' in structure and 'mageia' instead of 'mageia.org'
19:43:54 <tmb> since stage2/rescue does not change anymore in mga6(.1) besides what is already online
19:44:35 <DavidWHodgins> So no new netinstall iso images then?
19:44:55 <wilcal> ok I see it 9/12/18
19:44:59 <tmb> yep, on mirror structures only the part starting with distrib/ is the same on all mirrors
19:45:13 <dvg> kay
19:45:21 <DavidWHodgins> tmb. What are the hd_grub iso images?
19:45:52 <dvg> and there is *all*
19:46:18 <MageiaTJ> I only tested the 32-bit non-free netinstall iso.
19:46:39 <tmb> DavidWHodgins, basically they are extremely minimal boot setups using grub legacy that can be used for special installs...
19:47:15 <dvg> more info here: https://doc.mageia.org/netinstall/6/en/content/SOME_UNIQUE_ID.html#d4e18
19:47:16 <[mbot> [ Installation with a tiny boot image ]
19:47:45 <tmb> but yes, we have not really tested them for a long time, so...
19:48:13 <tmb> We need to review if we should kill some of it for mga7+
19:49:03 <dvg> If mageia releases them they ought to have been tested ;)
19:49:23 <wilcal> I'll tinker with them
19:49:33 <DavidWHodgins> Ok. No info about them to be included when announcing the release of 6.1 iso images.
19:49:54 <DavidWHodgins> Just the netinstall and netinstall-nonfree.
19:49:56 <dvg> wilcal: / others: if you find anything to remark please add chapters to the riseup pad
19:49:57 <tmb> nope, those few that have needed them knows how to use them :)
19:50:04 <wilcal> k
19:50:28 <DavidWHodgins> Let's move on then.
19:50:44 <DavidWHodgins> #topic * Anything else?
19:51:05 <wilcal> Not from me
19:51:08 <DavidWHodgins> Anyone have anything else to discuss?
19:51:26 <DavidWHodgins> Countdown time then
19:51:27 <dvg> channel doc is voicing peopkle, whatever it means... does qa need that?
19:51:33 <wilcal> bye all
19:51:39 <wilcal> thanks David your the best
19:52:06 <DavidWHodgins> dvg: No. We'll stick to people having to be registered for the qa channel, and move meetings to this channel.
19:52:14 <dvg> gotcha
19:52:19 <DavidWHodgins> t - 5
19:52:23 <DavidWHodgins> 4
19:52:26 <DavidWHodgins> 3
19:52:28 <DavidWHodgins> 2
19:52:31 <DavidWHodgins> 1
19:52:49 <DavidWHodgins> Thanks for coming everyone. I'll post the links to the logs to the mailing list
19:52:54 <DavidWHodgins> #endmeeting