20:19:20 <marja> #startmeeting
20:19:20 <Inigo_Montoya> Meeting started Tue Nov 21 20:19:20 2017 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:19:20 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:19:45 <marja> #chair ennael tmb filip_ lebarhon papoteur_ DavidWHodgins
20:19:45 <Inigo_Montoya> Current chairs: DavidWHodgins ennael filip_ lebarhon marja papoteur_ tmb
20:19:53 <marja> #chair schultz
20:19:53 <Inigo_Montoya> Current chairs: DavidWHodgins ennael filip_ lebarhon marja papoteur_ schultz tmb
20:20:00 <marja> whom did I forget?
20:20:09 <DavidWHodgins> :-)
20:20:29 <marja> #topic dev meeting / discussion about the feature requests
20:21:06 <marja> #info Ennael and Akien are preparing a first mail to introduce the discussion, it'll hopefully be sent tonight
20:21:30 <marja> To be honest, I'm starting to get the feeling that trying to get our DrakX, mana, urpmi and dnf developers to meet and agree about features, is like trying to get the upstr
20:21:33 <marja> eam KDE and Gnome developers to agree on features.
20:21:59 <marja> Is it silly to ask What Would be needed to allow parallel development including separate testing repositories (and a separate boot.iso + stage2) that support mana and dnf by default?
20:22:00 <papoteur_> :/
20:23:01 <marja> tmb: can you please shed your light on my maybe foolish question?
20:23:12 <DavidWHodgins> We'd have to make sure we didn't have both branches of iso images going through testing at the same time
20:23:20 <tmb> boot.iso and stage2 is not a problem... we just name them differently and upload them both to the mirrors
20:23:38 <DavidWHodgins> It would be like a fork though.
20:24:02 <marja> DavidWHodgins: I wasn't thinking about full isos, yet.... only later, when mana is more mature
20:24:17 <marja> tmb: thx
20:24:29 <tmb> its not a fork... its more of a POC so we can see the new and still keep the fallback working
20:24:39 <DavidWHodgins> Ok
20:24:51 <marja> DavidWHodgins: but it is nice that you're not a priori against testing both!
20:25:30 <marja> Is there more to say about this topic?
20:25:41 <DavidWHodgins> I'm not against it, just want to make sure we don't make things too confusing for testers.
20:26:28 <marja> DavidWHodgins: that is very wise, we really need to keep that in mind (*if* we get separate isos for old and new tools)
20:27:29 <DavidWHodgins> If we do go with separate iso images, I'd suggest having staged releases. Release one, then a few months later the other.
20:27:31 <marja> What would be a good #info line about the possibility to support both?
20:28:23 <marja> DavidWHodgins: I like that idea
20:28:47 <DavidWHodgins> I'd wait till after the packagers do meet before including anything that seems like a formal announcment
20:30:14 <tmb> new boot isos would be built against every new kernel as normal... its the stage2 part that is the harder part..
20:30:30 <marja> DavidWHodgins: I don't want a formal announcement, but I want ennael and Akien to see it, so they have another option as fallback if the discussion doesn't go as desired
20:31:31 <marja> DavidWHodgins: but they'll see it now, since I mentioned them ;-)
20:31:41 <DavidWHodgins> #info Council is open to considering having new iso images created that use dnf and mana tools as default, if needed, but with some restrictions.
20:31:56 <DavidWHodgins> How's that?
20:32:04 <marja> DavidWHodgins: almost good
20:32:17 <marja> DavidWHodgins: it misses that the normal isos will still be there
20:32:31 <DavidWHodgins> #undo
20:32:31 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0xf6649ecc>
20:32:45 <DavidWHodgins> #info Council is open to considering having additional iso images created that use dnf and mana tools as default, if needed, but with some restrictions.
20:33:01 <marja> DavidWHodgins: perfect, thanks :-)
20:33:15 <filip_> nice
20:33:27 <DavidWHodgins> The restriction being testing and release being staged to be after the regular iso images are released
20:33:44 <marja> DavidWHodgins: fine with me
20:34:20 <schultz> looks good
20:34:38 <papoteur> Fine
20:34:48 <marja> anything else on the feature proposals?
20:35:05 <DavidWHodgins> Not until after the packagers meet
20:35:09 <ennael> nope
20:35:13 <marja> good
20:35:13 <DavidWHodgins> In my opinion.
20:35:30 <papoteur> For what I now, the features review isn't finished, isn't it ?
20:35:58 <marja> papoteur: no, dev/pkg team needs to discuss them
20:36:00 <DavidWHodgins> No. We need to know which features have packagers willing to work on them first
20:36:37 <ennael> then maybe mail a summary about fatures to ask for volunteer
20:38:50 <marja> ennael: that is not (partly) covered by your mail?
20:39:27 <ennael> nope the mail is about drakx/mana tools
20:39:46 <ennael> we can deal on the other side with other feature at least to start work on it
20:40:56 <marja> yeah.... I think Pharaoh_Atem was willing to start meetings about features he's not involved in, if Akien would tell dev ml that he had asked Pharaoh_Atem to do that
20:41:38 <marja> but I don't know whether Pharaoh_Atem (Neal Gompa) was ever introduced as meeting leader by Akien
20:42:06 <ennael> well I don't think he needs to be introduced :)
20:42:24 <ennael> we can send a mail about accepted features and then people can also organize their own work
20:42:33 <marja> ennael: he didn't feel comfortable starting a meeting without the team leaders
20:42:40 <ennael> oh ok
20:42:49 <ennael> I will check with him then
20:42:54 <marja> ennael: thanks
20:43:02 <ennael> I'm back home on thursday, I will check with him
20:43:27 <marja> ennael: perfect... we'll leave it to you, then
20:43:36 <DavidWHodgins> One thing I learned a long time ago that may help him. If you act like you have the authority to do something, people will most likely assume you have it.
20:43:49 <ennael> :)
20:43:54 <marja> Pharaoh_Atem: ^^^
20:44:01 * ennael will call DavidWHodgins yoda
20:44:03 <marja> DavidWHodgins: thx :-)
20:44:07 <ennael> fits well :)
20:44:07 <DavidWHodgins> lol
20:45:23 <marja> Shall we continue with a short teams review and not forget to enjoy what's going very well?
20:45:37 <DavidWHodgins> Sure.
20:45:40 <Pharaoh_Atem> marja: hi?
20:45:52 <DavidWHodgins> Pharaoh_Atem: One thing I learned a long time ago that may help him. If you act like you have the authority to do something, people will most likely assume you have it.
20:46:00 <Pharaoh_Atem> haha
20:46:11 <DavidWHodgins> Go ahead and feel free to call meetings for packagers
20:46:26 <Pharaoh_Atem> DavidWHodgins: hehe, sure :)
20:46:36 <Pharaoh_Atem> I just didn't want to step on anyone's toes unnecessarily
20:46:52 <Pharaoh_Atem> I seem to be good at making people upset when I don't mean to, so I try to be cautious here :)
20:47:03 <DavidWHodgins> :-)
20:47:14 <ennael> I just checked the wiki
20:47:17 <papoteur> Pharaoh_Atem: if there is no foot, you won't step on any toes ;)
20:47:23 <DavidWHodgins> lol
20:47:24 <ennael> it seems we do not have sum up all accepted features
20:47:32 <schultz> that I can sympathise with :)
20:47:54 <marja> ennael: there are no accepted features, yet, are there?
20:48:08 * ennael is loosing head it seems
20:48:19 <DavidWHodgins> We put the review on hold pending the packagers meeting
20:48:22 <marja> ennael: me too, my memory is bad
20:48:30 <ennael> sorry for thatuntil end
20:48:34 <ennael> oups
20:48:37 <DavidWHodgins> :-)
20:48:39 <ennael> sorry for that then
20:48:45 <marja> ennael: np
20:49:22 <ennael> ok we need a meeting then
20:49:29 <marja> #agreed let Neal Gompa lead a dev/packagers meeting about the feature requests that aren't his
20:49:33 <ennael> even if I doubt we will have a lot of people
20:50:00 <Pharaoh_Atem> ennael: we do already have some accepted features
20:50:07 <ennael> ah !
20:50:13 * ennael is not that crazy then
20:50:23 * marja hides
20:50:27 <Pharaoh_Atem> go back to the meeting notes from the one right after the first deadline
20:50:32 <Pharaoh_Atem> iirc, we got through 1/3 of the features
20:50:41 <ennael> ok thanks Pharaoh_Atem :)
20:51:12 <ennael> Pharaoh_Atem: would you mind adding it on the wiki page?
20:51:13 <DavidWHodgins> I don't remember which ones we approved. Will have to dig back through the irc log to figure that out.
20:51:14 <tmb> yeah, no-one just updated the wiki...
20:51:21 <Pharaoh_Atem> http://meetbot.mageia.org/mageia-meeting/2017/mageia-meeting.2017-09-19-19.07.log.html
20:51:22 <[mbot> [ #mageia-meeting log ]
20:51:27 <ennael> https://wiki.mageia.org/en/FeatureMageia7_Review
20:51:28 <Pharaoh_Atem> I can do that, which wiki page is that?
20:51:38 <marja> Pharaoh_Atem: thanks!
20:51:43 <ennael> thanks
20:52:19 <DavidWHodgins> I think a new page has to be set up, same as the proposed features but with the word proposed removed
20:53:00 <marja> #action Pharaoh_Atem will list the already approved features in our wiki
20:53:34 <marja> more on the features?
20:53:50 <DavidWHodgins> Not here
20:54:12 <ennael> nope
20:54:47 <DavidWHodgins> #topic Mageia 6.1
20:55:12 <marja> :-D
20:55:13 <DavidWHodgins> Martin is working on a couple of installer bugs. bug 22032
20:55:15 <[mbot> Bug: ['Encrypted partition has wrong size in ext4 FS', 'NEW', 'Mageia tools maintainers'] https://bugs.mageia.org/show_bug.cgi?id=22032
20:55:25 <DavidWHodgins> And bug 22059
20:55:26 <[mbot> Bug: ["Incorrect UUID for /boot partition may be used when creating the initrd, leading to an unbootable system ( _only_ with stage2's diskdrake; diskdrake from drakxtools works fine)", 'NEW', 'Mageia tools maintainers'] https://bugs.mageia.org/show_bug.cgi?id=22059
20:55:54 <DavidWHodgins> Would be nice if we can include those fixes in the 6.1 iso images, as well as the various other package updates
20:56:13 <marja> how's the kernel?
20:56:39 <DavidWHodgins> tmb: Which kernel is it that 6.1 is waiting for?
20:56:42 <marja> and, yes, it would be nice if those bugs could be fixed and the fix included
20:57:06 <tmb> kernel is shaping up nicely... the only part missing is virtualbox proper support for 4.14 series kernels
20:58:01 <DavidWHodgins> As in being able to run vb under the 4.14 kernels, or having the 4.14 kernels working in vb guests?
20:58:11 <DavidWHodgins> Or both.
20:58:13 <marja> that support becoming available might coincide with those installer bugs getting fixed
21:00:11 <tmb> DavidWHodgins, a bit of both... upstream should hopefully release a 5.2.2 soon-ish that will sort out the missing pieces...
21:00:31 <marja> DavidWHodgins: the new method to become healthy again, includes going to bed at 22:00 CET (now)
21:00:51 <marja> DavidWHodgins: so I won't do another topic
21:01:04 <ennael> do we have another one ?
21:01:26 <DavidWHodgins> The teams review
21:01:44 <DavidWHodgins> marja: Have a good night.
21:01:51 <marja> thanks
21:01:56 <marja> good night all
21:02:03 <DavidWHodgins> #topic Teams review
21:02:09 <papoteur> marja goog night
21:02:46 <DavidWHodgins> The qa team is doing a good job of keeping on top of testing the updates, though I've been doing little myself due to my usual sleep problems this time of year
21:03:25 <DavidWHodgins> I'm holding off notifying the qa iso testers of the 6.1 iso images till we have a better eta for them becoming available for testing.
21:03:42 <DavidWHodgins> That's it for the qa team.
21:03:47 <DavidWHodgins> Next team?
21:04:10 <ennael> can you ping me when you think it's the good time so that I can setupisos ?
21:04:35 <DavidWHodgins> ennael: Yes
21:05:05 <schultz> Atelier can go if no one else wants to
21:05:14 <DavidWHodgins> Go ahead
21:06:14 <schultz> Well we need more blog topics, or rather we need people to write the ones that they said that they would
21:06:23 <schultz> myself included in fairness
21:07:10 <schultz> The other big thing I was wanting to bring up was getting an in house image hosting solution going, would be nice to finally get that sorted
21:07:52 <ennael> speaking about atelier
21:08:06 <ennael> as you may have seen Mageia has a bitcoins account
21:08:33 <ennael> and it should bring some significant amount of money
21:08:40 <DavidWHodgins> And the tulip bulbs have been a good investment. :-)
21:08:56 <ennael> maybe we could think about more improvment on Mageia design
21:09:03 <filip_> DavidWHodgins: in the narrow time frame ;)
21:09:17 <ennael> Animtim work did bring a big improvement
21:09:37 <schultz> Yep, that was a nice find
21:10:30 <filip_> ennael: which areas of Mageia design you have in mind?
21:10:38 <schultz> How are things with infra? Don't we need to set aside funds for upgrades there?
21:10:55 <ennael> schultz: we do have money, more then 23k€
21:11:52 <schultz> ah, I knew we were good financially, didn't realise it was that good
21:14:04 <tmb> yeah, we should buy 2 new powerful buildnodes + maybe a 3rd node for CI.. then the older nodes could do some easier work... and figure out what do do / find better /more powerful arm build nodes to not slow us donw... and we should start looking at bringing up 64bit arm...
21:14:28 <ennael> pb is still there
21:14:34 <ennael> we cannot add more servers in datacenter
21:14:55 <DavidWHodgins> So we need a new data center?
21:15:05 <schultz> Do you think that there will be issues with transferring them? Once its sorted we should put a blog out about what we will use it for and thanking the donators
21:15:14 <ennael> at least the current one is free
21:15:44 <schultz> Listing that hardware remended me that we were wanting to put a blog out about the infra and what we use
21:15:45 <DavidWHodgins> What kind of rates do data centers normally charge? Perhaps we can afford it.
21:16:25 <filip_> I remember some info about closing one data-center
21:16:50 <ennael> the thing is more and more datacenter propose now virtual server
21:17:06 <ennael> hosting physical server may cost a lot
21:17:20 <tmb> well the dead jonund is 2U, and can be replaced by 2 powerful 1U nodes ... and alamut only needs backing up and it can be removed too.. and the old arm nodes in dc can be removed (if they are still there)
21:17:45 <filip_> tmb: which data-center will close?
21:18:51 <schultz> How much power do we need? Surely if we use the money to upgrade what we have, there is enough space there for what we need?
21:18:53 <tmb> it's not the one hosting the buildsystem... it's the one carrying the blog
21:19:13 <ennael> yep they are moving datacenter
21:20:13 <tmb> so it's only gandi vms that are moving
21:20:30 <filip_> so we don't need to do anything
21:20:32 <filip_> ?
21:21:09 <filip_> any netconfig change or something?
21:21:50 <tmb> well the vms should be converted/upgraded/replaceed to fit the new hosting... wich is why pterjan suggeested to look of possible other solutions
21:22:08 <tmb> ennael, are we still getting free gandi credits ?
21:22:40 <ennael> I don't think so
21:23:15 <tmb> otoh gandi people at kernel-recipes told me we get ssl certs for free so just ask if we need more of them :)
21:24:12 <tmb> but that could have been the beer talking :)
21:24:26 <ennael> oh :)
21:24:30 <ennael> I will ping them
21:25:20 <tmb> filip_, technically they can move/re-route ips between data-centers
21:25:46 <filip_> tmb: maybe he talked about Letsencrypt certs?
21:26:17 <ennael> nope they offer quite often some certs to open source projects
21:26:37 <ennael> they did it for kernel.org if I remember well
21:26:38 <tmb> filip_, nope. they provide our current certs too, propery signed for iirc a year at a time
21:27:27 <filip_> sorry. back to topic ;)
21:32:16 <tmb> so seems people is falling asleap again... :)
21:33:10 <tmb> ennael, maybe we should use some of the bitcoins to ship coffeine pills around :)
21:33:24 <ennael> :))
21:33:28 <DavidWHodgins> :-
21:33:29 * ennael falling asleep also
21:33:43 <schultz> well, I don't think that there is anything more from Atelier, unless filip+ has more to add
21:33:52 <tmb> "cone work with mageia... we got all the pills you need..."
21:34:22 <DavidWHodgins> Let's close this meeting then. We can pick up again next week.
21:35:13 <filip_> ok. I'm sleepy too
21:35:22 <ennael> ok let see that next week then
21:35:38 <tmb> yeah, lets try weekly but shorter meetings from now on... to keep stuff going
21:35:48 <schultz> ok sounds good
21:35:50 <filip_> +1
21:36:42 <filip_> T-5 ;)
21:37:09 <filip_> 4
21:37:20 <filip_> 3
21:37:27 <schultz> 2
21:37:46 <filip_> 1
21:38:07 <ennael> #endmeeting