19:07:49 <DavidWHodgins> #startmeeting
19:07:49 <Inigo_Montoya> Meeting started Tue Sep  5 19:07:49 2017 UTC.  The chair is DavidWHodgins. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:49 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:08:01 <DavidWHodgins> #chair ennael tmb akien
19:08:01 <Inigo_Montoya> Current chairs: DavidWHodgins akien ennael tmb
19:08:03 <Akien> Thanks DavidWHodgins :)
19:08:12 <DavidWHodgins> #topic Mageia 7 goals
19:08:19 <wilcal> Yippeee I'm not in charge
19:08:40 <papoteur> Hi
19:09:25 <DavidWHodgins> Given the delays we've had in the past due to uefi, gnome, and kde to plasma, might be nice to have a release that just concentrates on getting updated versions out, as quick as possible from version freeze to final release
19:09:27 <papoteur> We starts in the hard directly ;)
19:09:51 <wilcal> More a clean up of M6 then anything else?
19:09:59 <ennael> back sorry
19:10:12 <DavidWHodgins> wilcal: Yes
19:10:21 <Akien> I agree that we should aim for a fast release, and not get used to the mga5 and mga6 long release cycles
19:10:35 <wilcal> Are there any new tecknolgies expected in M7?
19:10:55 <DavidWHodgins> That we won't know till we have all of the proposed features.
19:11:01 <Akien> But it's not easy, Cauldron as started with business as usual (big breakage), so the main question is how fast we can stabilize it all once all updates are in
19:11:17 <papoteur> BTRFS?
19:11:31 <DavidWHodgins> papoteur: As default?
19:11:55 <Akien> I think the btrfs trend as died out already, most distros are departing from it
19:11:56 <papoteur> yes
19:11:57 <ennael> keep in mind that Red Hat gave up btrfs support and so fedora
19:12:09 <papoteur> oops
19:12:13 <DavidWHodgins> :-)
19:12:21 <ennael> don't know if it's dying but still SUSE is the main maintainer for now
19:12:34 <DavidWHodgins> Perhaps we should start with a deadline for proposed features
19:12:43 <wilcal> So RH and Fedora still use extx?
19:12:52 <ennael> yep
19:13:03 <Akien> Yes I guess before defining the scope of what Mageia 7 should be, we need to see what our contributors have in mind
19:13:33 <ennael> wilcal: ext* and xfs
19:13:45 <Akien> If some want to undertake big changes and those features have support from several contributors, it might be worth taking the time to do them now
19:14:26 <ennael> maybe give 10 days for writting features, 2 or 3 days to read carefully
19:14:27 <DavidWHodgins> Let's ask the packagers then. How's two weeks for them to propose the features they would like to have considered?
19:14:31 <ennael> and then plan a meeting
19:14:43 <papoteur> I think to something like a guide to facilitate access to external services like Frama*
19:15:48 <DavidWHodgins> I'm assuming the packagers will have to do some checking, to see what is currently scheduled for upstream sources
19:16:27 <wilcal> How about the other way. Are there any packages/functions that should be abandoned in M7?
19:16:33 <Akien> I agree with ennael. 10 days is a bit short, but we shouldn't waste too much time either. If we see that some of the proposed features still need discussion in 2 weeks, we can always give some more time for them to settle, but indeed having an initial idea of where we're going in 2 weeks would be good.
19:16:53 <wilcal> Packagers should be asked that too
19:17:36 <DavidWHodgins> Ok, let's plan on initial review of proposed features in 2 weeks, keeping it clear that it won't necessarily be final at that point.
19:17:54 <ennael> or propose 10 days and if more needed then 2 weeks
19:18:08 <ennael> a way to negociate deadlines :)
19:18:21 <DavidWHodgins> :-)
19:18:51 <papoteur> wilcal: some feature need to be reviewed, sure.
19:19:01 <Akien> Ok so Friday 15?
19:19:11 <tmb> Plasma 5.12 LTS is planned 2018-01-30, And Gnome 3.28 will probably go stable in March 2018, so a april-may 2018 release could be good...
19:19:36 <Akien> That sounds good yes.
19:19:48 <DavidWHodgins> Wile asking for packagers for proposed features, state that removal of existing packages can be considered a feature.
19:20:02 <DavidWHodgins> s /Wile/While/
19:21:13 <Akien> Alright, I'll take that one ;)
19:21:22 <DavidWHodgins> Let's assume Gnome will have at least some delays, so propose a May 2018 release right up front.
19:21:40 <Akien> #action Akien asks contributors to make feature proposals until Friday 15 September, to be reviewed at Council meeting in 2 weeks
19:22:05 <Akien> Well I'd assume more that \*we\* would have delay :p
19:22:27 <ennael> :)
19:22:40 <Akien> #info Plasma 5.12 LTS is planned 2018-01-30, And Gnome 3.28 will probably go stable in March 2018, so a april-may 2018 release could be good
19:23:03 <wilcal> april-may-june
19:23:12 <wilcal> before the summer holidays
19:23:19 <Akien> #info Proper development roadmap TBD depending on scope of accepted feature proposals
19:23:43 <wilcal> so long as this is more of a clean up then anything else
19:24:11 <Akien> Well it depends. If some contributors have grand ideas and the means to implement it, I don't think we should prevent them.
19:24:21 <tmb> wilcal, that depends on accepted features :)
19:25:35 <Akien> For example I think that ngompa would like to use libdnf as a backend for the installer, instead of perl-URPM. We don't know yet what the exact scope of such a change would be, if it's accepted.
19:25:45 <Akien> So the feature discussions on the MLs in the coming two weeks should be interesting :)
19:26:15 <wilcal> In retrospect I think the inclusion of Xfce isos was a good one
19:27:36 <Akien> Yeah definitely.
19:27:53 <Akien> And I haven't seen any complaint about the ISOs we removed, so the new lineup is good.
19:28:01 <wilcal> If you had the choice again would you choose Mate or Xfce?
19:28:03 <papoteur> don't we do post-mortem review?
19:28:13 <DavidWHodgins> Changing the installer and other drakx tools to use dnf would be a major change. Would have to be started soon to avoid having it end up delaying iso testing
19:28:48 <Akien> papoteur: good question :)
19:29:04 <wilcal> all things to think about over the next couple weeks
19:29:12 <Akien> I think Mageia 6 took so much time to develop that we've done its post mortem several times already while it wasn't born yet :p
19:29:23 <DavidWHodgins> :-)
19:30:49 <DavidWHodgins> Anything else, or shall we close the meeting and see where we stand in 2 weeks?
19:30:55 <Akien> To be honest I'm not sure if the postmortem exercise really bears fruit. The issues are easy to identify and self-evident for many, but the solutions are often difficult to implement (and require infra work, which is the other topic I''d like to discuss tonight)
19:31:23 <Akien> On the other hand, it's good to give contributors a place to express themselves, so maybe it's good to have a short postmortem in each team anyway, and summarize the findings
19:31:40 <DavidWHodgins> Anything else about Mageia 7 goals before we move on?
19:31:54 <Akien> I think we can move on
19:32:03 <wilcal> not from me
19:32:19 <DavidWHodgins> #topic Infrastructure
19:32:33 <filip_> we need to decide if we'll enable mga5->mga6 in mgaonline
19:32:53 <papoteur> Akien: I agree with a short PM by teams.
19:32:57 <DavidWHodgins> Ah. I forgot about that.
19:33:19 <Akien> ok let's do those two quickly before discussing the infra
19:33:22 <Akien> #undo
19:33:26 <Akien> #topic Postmortem
19:33:58 <DavidWHodgins> #chair Akien
19:33:58 <Inigo_Montoya> Current chairs: Akien DavidWHodgins akien ennael tmb
19:34:07 <filip_> I think that PM is good for some teams with less active leaders
19:34:11 <DavidWHodgins> #topic Postmortem
19:34:59 <Akien> Yeah, let's have a short PM in each team then. We shouldn't drag it on too long, but gather feedback and the general feeling of each team about the Mageia 6 release
19:35:13 <Akien> It's also good to be able to vent out potential frustration linked to this hellish release :D
19:35:14 <DavidWHodgins> Agreed
19:35:20 <filip_> +1
19:36:20 <Akien> #action Team leaders start postmortem discussions in their respective teams. Shouldn't drag it too long, up to Friday 15 September or so.
19:36:49 <Akien> Redoing previous action as I'm not sure it worked
19:36:50 <Akien> #action Akien asks contributors to make feature proposals until Friday 15 September, to be reviewed at Council meeting in 2 weeks
19:37:10 <Akien> #topic Reenabling upgrade from Mageia 5 to Mageia 6 via mgaonline
19:37:53 <Akien> As you may know, due to many users ending up with a broken system when upgrading their Mageia 5 to Mageia 6 via mgaonline, we disabled the API that triggers the "Do you want to upgrade" message.
19:38:06 <DavidWHodgins> I'll ask the qa team to re-test upgrading plasma installs, for review in this weeks qa team meeting on Thursday
19:38:32 <Akien> Several of the upgrade issues have been fixed since then (some conflicts notably)
19:39:02 <Akien> Here is the tracker bug: https://bugs.mageia.org/show_bug.cgi?id=21340
19:39:04 <[mbot> [ 21340 – [TRACKER] Upgrade issues from Mageia 5 to Mageia 6 ]
19:39:19 <filip_> IMHO (as I see in ML and forum) we're in way better shape now then on the release day
19:39:50 <filip_> DavidWHodgins: great
19:40:06 <Akien> The worst issues are likely https://bugs.mageia.org/show_bug.cgi?id=21263 and https://bugs.mageia.org/show_bug.cgi?id=21425
19:40:08 <[mbot> [ 21263 – Endless reboot loop after switching from nouveau to nvidia proprietary driver ]
19:40:32 <Akien> Both have patches proposed, but somehow no dev had/took the time to test them and release them.
19:40:55 <Akien> So we probably need a small push on that topic before we can reenable the upgrade path.
19:41:18 <Akien> I'll try to post an overview to the dev@ ML tomorrow and look for volunteers to hunt down the issues and fix them
19:41:51 <Akien> #action Akien reminds devs about mga5 -> mga6 upgrade issues ( https://bugs.mageia.org/show_bug.cgi?id=21340 ) and sees how we can fix them ASAP.
19:41:53 <[mbot> [ 21340 – [TRACKER] Upgrade issues from Mageia 5 to Mageia 6 ]
19:42:02 <filip_> we must act quickly on this as we should not delay mga5 EOL
19:42:12 <Akien> Indeed.
19:43:59 <Akien> That's a topic we should re review in two weeks at the latest; ideally we would reenable mgaonline upgrades sooner than that if the main issues are fixed
19:44:12 <Akien> Next topic?
19:44:24 <DavidWHodgins> None here.
19:44:50 <Akien> #topic Infrastructure
19:45:14 <Pharaoh_Atem> Infrastructure was probably the most painful part of the Mageia 6 release
19:45:29 <Pharaoh_Atem> and it was partly my fault, as I drove a good deal of the infrastructure changes :P
19:46:19 <filip_> Pharaoh_Atem: I think we need a pusher sometimes ;)
19:46:21 <Akien> Yeah, the difficulty we have to let our infrastructure evolve is really dragging us behind.
19:46:41 <Pharaoh_Atem> we still didn't quite get everything planned for Mageia 6, even with me poking a lot about it
19:46:59 <Pharaoh_Atem> is there something we can do better to make this better for Mageia 7?
19:47:46 <Akien> There are many new tools that we really need to ensure a good workflow: a patch review system (either a big forge like GitLab or Pagure, or a specific review tool like Reviewboard), mirrorbrain for our mirrors, hunting down the last wiki issues and setting up the translate plugin
19:48:19 <Akien> Ideally, change our buildsystem to Fedora's Koji, but that seems daunting, though we would really benefit from a more modern buildsystem
19:48:19 <Pharaoh_Atem> for what it's worth, I'm working on porting the Pagure packaging from Fedora to Mageia
19:48:39 <Pharaoh_Atem> and I've already written basic scaffolding for moving to Koji
19:48:55 <Akien> We did have a nice Bugzilla upgrade and now a good bugzilla maintainer, and upgraded all our infra to Mageia 5, so that's good :)
19:48:58 <Pharaoh_Atem> https://gitlab.com/mdklinux/mgapkg-koji
19:49:00 <[mbot> [ MDK Linux / mgapkg-koji · GitLab ]
19:49:12 <Pharaoh_Atem> this should eventually be moved to Mageia's Git
19:49:41 <Pharaoh_Atem> moving to Koji + Pagure *will* require Mageia 6
19:49:47 <Pharaoh_Atem> as we need modern Mock and stuff
19:49:56 <Akien> But the lack of sysadmin availability is really a strong bottleneck for our project. I feel like the sysadmins team could/should better organize its work/setup priorities, etc.
19:50:14 <Pharaoh_Atem> Luigi12 also maintains a Koji system for work, so he knows it inside and out now :)
19:50:23 <Pharaoh_Atem> so he's a great candidate to help our sysadmins get up to speed
19:51:15 <Pharaoh_Atem> what I would like to see is the sysadmins having some kind of regular session where we can establish a good feedback loop between developers and administriva
19:51:25 <Akien> I don't have the solutions to fix the sysadmins team :p Progress is being made, stormi is being tutored by neoclust for example and started doing some tasks
19:51:46 <Pharaoh_Atem> and get more people involved (either partially or fully) on the sysadmin group
19:52:40 <Akien> I think that we should make specific infra changes part of the mga7 feature proposals, and have a real discussions with sysadmins and interested parties about who can work on them, how and within what time scale
19:53:05 <Pharaoh_Atem> I don't disagree with this
19:53:20 <Pharaoh_Atem> I believe I did that for the DNF enablement for Mageia 6, simply because it was a good idea
19:53:25 <ennael> (hard to discuss about it without people...)
19:53:44 <Pharaoh_Atem> tmb: what do you think?
19:54:37 <Pharaoh_Atem> (or blino, or stormi, or anyone...?)
19:54:55 <Akien> Yeah but it's the problem, it's also hard to have the people around to discuss it, and hard to have the people discuss it with each other :D
19:54:56 <ennael> this is a council meeting not a team one :) maybe better to plan one
19:55:03 <tmb> well, it should be improved, no argument there...
19:56:22 <tmb> as always it comes down to resources, and I'm not sure I should be a sysadmin managing this as my time is very limited to say the least...
19:57:21 <tmb> so I have a lot of ideas, but not the energy for now to do the needed work...
19:57:48 <Pharaoh_Atem> tmb: would you be willing to help others become more involved to take on some of the load?
19:58:10 <marja> tmb: take care
19:59:21 <Akien> I wonder if it would help to have another machine which wouldn't host critical services, and on which "new" sysadmin contributors could start working on some new services?
19:59:32 <Pharaoh_Atem> interesting thought
19:59:45 <ennael> what about planning a meeting with current team and people interested in
19:59:51 <Pharaoh_Atem> like a staging machine?
20:00:00 <ennael> and one representative from QA, packagers, security
20:00:00 <Pharaoh_Atem> ennael: that's a good thing to do regardless
20:00:20 <Pharaoh_Atem> I'd argue that each of the major teams should be doing something like that regularly
20:00:23 <ennael> hard to find solution tonight without those guys
20:00:31 <Pharaoh_Atem> where stakeholders can participate and get involved
20:00:36 <Akien> Yeah a meeting with sysadmins + interested contributors to discuss the infra would be really good.
20:01:03 <tmb> for infra I think we should buy 2 new buildhosts with lot of cpu, ram and ssds... that would free up rabbit and ecosse for infra enhancement, and getting rid of sucuk spof
20:01:09 <Akien> It's hard to find a schedule though, last time stormi tried to organize one it took weeks to find a time slot :D
20:01:34 <ennael> Akien: I've found matches back here I can help
20:01:37 <Akien> But let's start discussions about it on the sysadmin ML, I agree that we can't solve everything by discussing it in the Council
20:01:46 <DavidWHodgins> tmb: We have the money. Just  need a proposal for the council to approve
20:01:50 <Akien> Hehe
20:01:53 <Pharaoh_Atem> haha
20:01:55 <Akien> +1
20:02:07 <ennael> tmb: also we can check for the server during Kernel Recipes
20:02:08 <Pharaoh_Atem> +100 (though I don't matter :) )
20:02:09 <marja> tmb: how much would that cost.... if we can afford it, then it's fine with me
20:02:10 <Akien> All expenses allowed™
20:02:11 <ennael> and buy it
20:02:18 <DavidWHodgins> :-)
20:02:44 <Pharaoh_Atem> also, I've got some prototype work on running arm builds on x86 systems
20:03:10 <Pharaoh_Atem> which could also be used for moving the arm builds to nice aarch64 systems
20:03:21 <Akien> tmb: could you make a quick post on the sysadmin ML about your investment ideas, so that it doesn't get lost in the limbo of council meeting logs?
20:03:23 <tmb> yeah, we really need to find a way to get arm builds up to speed and aarch
20:03:55 <tmb> Yeah, I'll post on sysadm about it...
20:04:08 <Akien> Thanks :)
20:04:13 <Pharaoh_Atem> I've heard from at least one potential contributor who is very interested in helping with an aarch64 bringup in Mageia
20:04:33 <Akien> I think we can stop the infra discussion for today then, as mentioned it would be best further discussed with all other sysadmins to assess what we can reasonably do.
20:04:33 <Pharaoh_Atem> which sorta kicked off my efforts to try to get some pieces into place for making that possible
20:04:51 <Akien> (and of course tmb take care of yourself in priority, we don't mean to pressure you :))
20:05:11 <Pharaoh_Atem> tmb: please, take care of yourself. :)
20:05:49 <Akien> Should we wrap up? Short meetings are good meetings :)
20:05:56 <marja> yep
20:06:02 <wilcal> Sounds like a plan :-))
20:06:06 <ennael> good conclusion :)
20:06:08 <wilcal> good start
20:06:11 <Pharaoh_Atem> haha
20:06:15 <ennael> oups
20:06:17 <DavidWHodgins> Yep
20:06:23 <Akien> Thanks everyone for attending :)
20:06:25 <Akien> #endmeeting