19:12:45 <Akien> #startmeeting
19:12:45 <Inigo_Montoya> Meeting started Tue Jul 11 19:12:45 2017 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:12:45 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:12:58 <Akien> #chair ennael tmb marja
19:12:58 <Inigo_Montoya> Current chairs: Akien ennael marja tmb
19:13:26 <ennael> so I guess we will speak about mageia 7 :)
19:13:35 <DavidWHodgins> lol
19:13:44 <Akien> \o/
19:13:50 <Schultz> Should we pull a microsoft and skip a release number? :)
19:13:52 <Akien> Let's just skip mga6 :p
19:14:00 <ennael> ok then :)
19:14:09 <filip> I hope that current heavy storm will let me be around ;)
19:14:10 <ennael> I've just pushed new classical isos
19:14:12 <wilcal> Over 2-years in the making must be good
19:14:41 <DavidWHodgins> I've lost track. When did m6 start?
19:14:55 <Akien> May 2015 or something?
19:14:56 <ennael> (next step is to switch to dpkg :p)
19:15:05 <DavidWHodgins> :-)
19:15:08 <Schultz> Fairly sure I was still doing my undergrad when we started...
19:15:30 <Akien> So you probably know that we had ISOs on Saturday, on which some issues were found thanks to QA's active testing
19:15:59 <Akien> The most annoying ones were fixed yesterday, so we have a new set of ISOs incoming. Already updated for the classicals IIUC, what about the lives?
19:17:00 <Akien> If all goes well I hope we could get a first impression from the QA team after the Thursday meeting
19:17:15 <Akien> If it's a consensual "go", we could likely release during the week-end
19:17:45 <Akien> (or early next week if more testing is needed)
19:17:47 <DavidWHodgins> Can we confirm all of the teams are ready?
19:17:49 <wilcal> I executed a x86_64, Plasma, Vbox client netinstall in the last few hours and that went without issues
19:17:50 <tmb> I know Martin was testing/fixing some wireless issues with live isos ... so Ill assume he'll respin the isos when he's happy with them
19:19:05 <Schultz> leuhmanau: was updating the website, release announcement could do with more eyes, otherwise Atelier should be ready, unless I've missed something
19:19:09 <Akien> So yeah, basically the agenda for today would be to review that everything is ready or being readied for the release day
19:20:03 <wilcal> I am really really ready to get 100% back to testing updates
19:20:23 <Akien> We should probably write a short press release and try to get it sent to major tech news websites?
19:20:40 <Akien> Most of the tech world thinks we're dead, so it may be good to reach out to them when we release
19:21:03 <Schultz> Yes, that needs doen too
19:21:25 <Akien> I can probably draft it, but I'll need help to list some contacts to get in touch with
19:21:27 <papoteur_> FOr documentation, help for drakx is ready.
19:21:56 <Schultz> IIRC there is a list in the wiki somewhere, but it's probably very out of date
19:22:14 <Akien> What about the online help? http://www.mageia.org/en/doc/
19:22:15 <[mbot`> [ Mageia Documentation ]
19:22:31 <Akien> Is it for that that filip flooded git with binaries? :p
19:22:51 <filip> Akien: doc page is in the works
19:23:27 <DavidWHodgins> What about the images loading in the wiki?
19:23:28 <filip> that doc binaries will be available for DL but git -> mirrors path needs to be done
19:24:04 <Akien> Right, getting the wiki back on its feet would be a nice to have for the release day :)
19:24:12 <tmb> Yeah, I'll try to finish of my TODO infra work tomorrow.
19:24:20 <filip> thx tmb
19:24:27 <Akien> Thanks :)
19:24:52 <tmb> I will get wiki online, I see wikigazer have been experimenting so I'll review his work and pull it online
19:25:57 <Akien> I'll #action a few of the things we mentioned for the logs, keep talking :)
19:26:21 <tmb> "once upon a time ..."
19:26:39 <DavidWHodgins> :-)
19:26:46 <filip> "there was a wizard ..."
19:27:02 <Akien> #info New classical ISOs Tue 11 July, early feedback from QA expected for Thu 13 July. Live ISOs still to come.
19:27:22 <DavidWHodgins> tmb: Any ideas on nvme paritioning bug mentioned by Tony on qa discuss ml?
19:27:45 <Akien> #action All teams prepare the release for this week-end (15-16 July), might happen later if more testing needed but we should be ready.
19:28:13 <Akien> #action Atelier finished website (leuhmanu, filip), release announcement (schultz, akien, *), press release (schultz, akien, *)
19:28:34 <Akien> #action Docteam + tmb put up the docs online (mageia.org/doc)
19:28:54 <Akien> #action tmb works on the infra TODO list and hopefully fixes the wiki :)
19:29:16 <Akien> There's another topic which is reviewing the errata
19:29:36 <Akien> stormi started working on it on Monday, but there's still more work needed and that's something where everyone can help
19:29:52 * wikigazer thinks it's just the missing extensions and $wgFileExtensions from /etc/mediawiki/LocalSettings.php   (sorry about top-posting in gmail)
19:30:00 <Schultz_phone> It would be good to release a blog about the upcoming highlights of the release on Monday or so
19:30:19 <Akien> He sent an email about it on dev@ + docteam@, basically one just needs to review the FOR_ERRATA6 bugs, add them to the errata, and mark them as IN_ERRATA6.
19:30:47 <Akien> #action All contributors with some time could help review the Errata thanks to the FOR_ERRATA6 keyword in Bugzilla
19:31:00 <wilcal> I wanted to mention there should be two fuzzy issues in errata. Upgrade from M5 KDE -> M6 Plasma is fuzzy
19:31:13 <wilcal> Plasma itself is a work in progress
19:31:34 <Akien> Schultz_phone: When you say Monday, you mean that post-release or pre-release? :)
19:31:58 <schultz> Pre-release, as in this coming Monday, give or take some Mageia time
19:32:13 <Akien> Well I hope we might have released Mageia 6 by Monday :)
19:32:33 <filip> Schultz_phone: I think wep pages facelift deserves a blog too. leuhmanu did a great and huge job!
19:33:03 <Akien> #action Atelier + leuhmanu to write a blog post about web pages facelift :)
19:33:15 <filip> cross site navigation is updated too
19:33:29 <Akien> I think we can present the highlights of Mageia 6 in the release announcement: https://wiki.mageia.org/en/Mageia_6_Release_Notes
19:33:37 <Akien> That gives us good material for an interesting announcement
19:33:50 <filip> +1
19:33:53 <Akien> Then in the following weeks we could have blog posts to showcase some of them into more details
19:34:16 <schultz> Akien: I suppose so, just there are some features that really deserve a lot more time than the release annoucement can give them
19:34:41 <wilcal> We got Plasma to work. Kinda
19:34:50 <Akien> Yeah that's why I'd cover them afterwards with some blog posts; we could start posting some before the release though if one is ready
19:35:10 <Akien> Like I think Pharaoh_Atem is mostly ready with his DNF 2 post
19:35:45 <schultz> Akien: yeah that would work too, we should say we want them done now though, that way they might be ready for just after release when there is good traffic coming our way
19:35:55 <schultz> Hows the games blog coming :)
19:35:59 <Akien> For ARM support, it would be good to have a technical blog post from pterjan or blino which actually explains how to install Mageia on an ARM device :)
19:36:04 <wilcal> Are we the only distro with Xfce i586 & x86_64?
19:36:32 <wilcal> Live media
19:36:38 <Akien> wilcal: No idea
19:36:39 <filip> Akien: I'll but Rpi just for that ;)
19:36:44 <wilcal> I bet we are
19:37:21 <Akien> filip: hehe me too
19:37:25 <filip> wilcal: maybe distrowatch has a search option for that
19:37:29 <DavidWHodgins> We should list all of the desktop environments available in a blog post too
19:37:49 <schultz> Its a big list, saw it somewhere recently
19:38:01 <Akien> DavidWHodgins: Good point. Maybe that could also go in the release highlights of the release notes btw.
19:38:14 <Akien> It's not something new in Mageia 6, but it's kind of a unique feature of Mageia
19:38:40 <Akien> Though... maybe not a good idea. If we start listing our unique features in there it will grow too much :D
19:38:49 <Akien> But a blog post would be nice
19:38:57 <Akien> With some screenshots of all DEs :)
19:39:18 <DavidWHodgins> I have 26 files in /etc/X11/wmsession.d/ on my main Mageia 5 install
19:39:21 <filip> DavidWHodgins: indeed. that's one of the key Mageia strong points
19:39:48 <Akien> #action Blog: show release highlights in release announcements + prepare specific blog posts for each/most of them
19:39:54 <schultz> Going to add a hint about it now in the annoucement while its in memory
19:39:56 * wikigazer misses the dual arch iso. I understand it grew too big to fit on optical disk?
19:40:09 <filip> wikigazer: yeah
19:40:23 <Akien> #action Blog: Other post idea: Mageia's support for 25+ DEs and lightweight WMs
19:40:25 <filip> wikigazer: netinstall is the way to go
19:41:20 <DavidWHodgins> Would be nice to have a dual arch netinstall iso, with the option to force i586 on an x86_64 system
19:41:27 <Akien> schultz: games blog is... still not started :D But I still have it in mind, and it should make interesting post release highlight too
19:41:33 <wikigazer> filip: yes, but I understand you need to know whethet to use 32 ort 64 bit netinstall. Th advantage of dual arch was it automatically detected that for you. Useful capability.
19:41:46 <schultz> Akien: I know, couldn't resist the nudge :)
19:42:22 <schultz> wikigazer: tmb: could a dual arch boot.iso fix that? or is that completely pointless?
19:42:42 <wikigazer> filip: I think install from install ISO already on disk is a faster way to go. :-)
19:42:50 <Akien> #action schultz and Akien talk with the competent contributors for the highlight blog posts, and ensure something happens :)
19:42:59 <wikigazer> (and grub2 makes that easy)
19:44:28 <schultz> Akien with the DE blog, we should start a desktop contest, those things were great fun ages ago
19:44:53 <Akien> tmb: leuhmanu: What are the remaining steps to fully make Mageia 6 official when we want to release? Especially regarding branching, and making sure users get proposed to upgrade from Mageia 5 via MageiaUpdate?
19:48:15 <tmb> for distrib repo branching we need to do that (including uploading isos) ~1-2 days before we officially release so that downstream mirrors have time to catch up
19:48:56 <filip> wilcal: http://distrowatch.com/search.php#advanced
19:48:57 <tmb> on official release day leuhmanu will push release api
19:48:57 <[mbot`> [ DistroWatch.com: Put the fun back into computing. Use Linux, BSD. ]
19:49:55 <Akien> tmb: Ok, so as soon as we decide the ISOs are good to go, we should branch and aim for the official release 2 days later
19:49:56 <tmb> mirror api is already pointing on the "6" symlink
19:51:12 <DavidWHodgins> Mageia 5 support end date? Halloween ok?
19:51:47 <schultz> Do we go with the 'standard' 3 months?
19:51:47 <tmb> Mageia 5 should go EOL ~3 months after Mageia 6 is released
19:52:08 <Akien> Oh yes we need to decide that formally and announce it on the blog, once we know the exact day.
19:52:29 <Akien> I think the standard 3 months is good yes.
19:52:47 <Akien> That brings us to mid October
19:52:59 <wilcal> 31 Oct 12
19:53:00 <wilcal> 7
19:53:05 <wilcal> 31 Oct 17
19:53:14 <Schultz_phone> Yeah that sounds good
19:53:35 <Akien> So halloween EOL for the magic distro? :p
19:53:49 <filip> sounds like magic ;)
19:53:52 <wilcal> Sounds like a plan
19:54:05 <DavidWHodgins> Or is it better to end mid month, for sysadmins that have to do a lot of stuff at month end?
19:54:29 <Akien> Well if they have a lot to do they should upgrade mid month anyway, or earlier :p
19:54:35 <Akien> They don't have to wait for the EOL
19:54:39 <DavidWHodgins> True.
19:54:57 <DavidWHodgins> So everyone ok with Oct. 31st?
19:54:57 <tmb> nope. EOL is simply locking repo and wiping testing, nothing else
19:55:27 <Akien> Oh I thought Dave talked about non-Mageia sysadmins, those who need to upgrade their Mageias
19:55:35 <wilcal> the ultimate freeze
19:55:39 <DavidWHodgins> Akien: I was
19:55:57 <Akien> The "absolute zero" as Luigi calls it :p
19:56:52 <Akien> #action If all goes as planned for Mageia 6 release schedule, Mageia 5 EOL planned for 31 Oct 2017
19:57:35 <Akien> We can mention that in the mga6 release blog post, and do a later short blog post about it as a reminder to make sure people got it
19:58:33 <Akien> Ok, I think we've talked about most topics... Anything we missed, or should we end the meeting? :)
19:58:50 <DavidWHodgins> Nothing else here. Ready to get back to testing. :-)
19:59:05 <schultz> Will just add that to the announcement now
19:59:19 <wilcal> Gotta get those new CI isos
19:59:57 <Akien> Great. Next meeting is about Mageia 7!! :D
20:00:06 <wilcal> Whew!
20:00:09 <Akien> (I hope :))
20:00:28 <Akien> #endmeeting