19:12:50 <Akien> #startmeeting
19:12:50 <Inigo_Montoya> Meeting started Tue Jul  4 19:12:50 2017 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:12:50 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:13:09 <ennael> hi
19:13:15 <ennael> (sorry, kids)
19:13:28 <tmb> ennael, you mean us ?
19:13:29 <wilcal> The gangs really all here :-)
19:13:36 <ennael> :)
19:13:39 <Akien> #chair ennael marja filip Luigi12 wilcal stormi papoteur Son_Goku tmb
19:13:39 <Inigo_Montoya> Current chairs: Akien Luigi12 Son_Goku ennael filip marja papoteur stormi tmb wilcal
19:13:49 <Akien> Alright, I guess we're all well seated now :D
19:13:55 <Son_Goku> indeed
19:14:08 <Schultz> Evening all
19:14:19 <wilcal> Just after noon here
19:14:35 <Akien> Schultz: Ah, please stand in the back, there are no more chairs sorry :D
19:14:43 <filip> #chair Schultz
19:14:43 <Inigo_Montoya> Current chairs: Akien Luigi12 Schultz Son_Goku ennael filip marja papoteur stormi tmb wilcal
19:15:00 <filip> there was one behind me. sorry big fella
19:15:10 <Schultz> I'd have built one, but that works too :)
19:15:30 <Akien> So, let's start with the good news
19:15:37 <Akien> #topic Blockers review
19:15:47 <Akien> #link http://madb.mageia.org/tools/blockers
19:15:53 <[mbot`> [ Mageia App Db - Current Blockers ]
19:16:23 <Akien> Both remaining bugs are partly fixed, and actually linked together (same fix for both)
19:16:44 <Akien> Martin pushed a fix some time ago: https://bugs.mageia.org/show_bug.cgi?id=20624#c37
19:16:46 <[mbot`> [ 20624 Hidden buttons in the Installer gui - UI elements and fonts are too big for screen resolution ]
19:17:10 <Akien> But Frédéric mentioned that the latest issues don't seem to use the fix at the bootloader level: https://bugs.mageia.org/show_bug.cgi?id=20624#c41
19:17:12 <[mbot`> [ 20624 Hidden buttons in the Installer gui - UI elements and fonts are too big for screen resolution ]
19:17:49 <Akien> So I think ennael and tmb need to check that, Martin mentioned on the isobuild@ ML that he wasn't sure if the file he modified in git would be deployed on the classical ISOs
19:19:27 <Akien> ennael, tmb: Any idea what should be changed where to match http://gitweb.mageia.org/software/drakx/commit/?id=14eb1e5893eb7bc6748cf388df7cb05a3f05c7da ?
19:19:27 <[mbot`> [ drakx - Mageia Installer and base platform for many utilities ]
19:19:41 <ennael> let me have a look
19:21:01 <ennael> looks like I cannot see it
19:22:58 <ennael> oups it's inside
19:24:24 <ennael> 14eb1e589 Increase the default window size of the installer to 1024x768 (mga#20624)
19:25:01 <Akien> Well we'll let you have a look with all the time you need. Basically once this is fixed, we have no blockers for Mageia 6 anymore \o/
19:25:11 <Son_Goku> yay
19:25:32 <tmb> it's already vga=791 on last isos ennael built
19:25:52 <Akien> wilcal: Can you confirm that from QA's point of view we're now blocker free? (I expect not bug-free, but if there are no blockers we need to let this release out :D)
19:25:53 <wilcal> Whew
19:26:37 <wilcal> Yes, QA reviewed all this last Tues and no one brought up anything that would prevent this set of isos being released
19:27:03 <wilcal> But, there are ongoing issues some of them may cause us some heartburn
19:27:16 <wilcal> Some with Plasma
19:27:34 <wilcal> I'd like to mention one here
19:28:02 <wilcal> Plasma shell occasionally fails to start on Live DVD
19:28:04 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=21082
19:28:05 <wilcal> or my description
19:28:05 <[mbot`> [ 21082 Plasma shell occasionally fails to start on Live DVD ]
19:28:07 <wilcal> Random ksmserver errors reported
19:28:22 <ennael> label linux kernel x86_64/vmlinuz append initrd=x86_64/all.rdz automatic=method:cdrom vga=791 splash quiet noiswmd
19:28:29 <wilcal> this shows itself randomly and may freeze the plasma desktop
19:28:32 <ennael> this is what is used currently
19:28:39 <wilcal> We recommeded it be in the errata
19:28:58 <Akien> ennael: Yeah it looks like I misinterpreted Martin's last comment. The vga option looks good, but he mentioned "Yes, the bootloader on the classic ISOs hasn't been updated."
19:29:03 <wilcal> it does not prevent successful install
19:29:13 <Luigi12> I saw some ksmserver issues last year when I last tested Cauldron on real hardware.  The issues don't present themselves in VirtualBox.
19:29:19 <Luigi12> guess it's still flaky?
19:29:27 <wilcal> It is very flaky
19:29:27 <Akien> ennael: though you released mageia-gfxboot-theme 4.5.14.7 before making the ISOs so I'm not sure what he means
19:29:42 <wilcal> if a reviewer gets a bad case of it things will not go well
19:30:15 <wilcal> I think Martin and I would ask folks to help with this on tracing it in the logs
19:30:22 <Luigi12> wilcal: would these problems be the same on other Plasma distros?
19:30:22 <Akien> I still get ksmserver crashes too every now and then (once a month or so), never had the time to debug them but that's definitely a bug of our plasma or qt5 version.
19:30:38 <ennael> Akien: gfxboot is only the graphical part of the screen, the vga config is proposed by isolinux.cfg
19:30:40 <wilcal> I have not had time to review this in other Plasma distros
19:30:48 <ennael> which is part of drakx-installer-images
19:30:49 <tmb> well, we had the same issue with gnome a release or so back where it crashed for some users... it's plasma time to be the "bad boy" this release :)
19:30:58 <Luigi12> we can investigate Qt 5.9.1 once mga6 is out, but I think the next Plasma LTS version is still a ways off
19:31:11 <wilcal> No problem getting out from under it
19:31:17 <filip> wilcal: Neon is a reference I guess
19:31:21 <wilcal> Ctrl-Alt-Backspace-Backspace
19:31:23 <Akien> ennael: Yeah I think there's a mix up i the bug report, the "new" issue now is that the F3 option can't change the default. But the default is 1024x768 as expected.
19:31:27 <wilcal> gets you out of it every time
19:31:39 <Akien> ennael: I guess it would be worth asking Martin what he means exactly (https://bugs.mageia.org/show_bug.cgi?id=20624#c42 )
19:31:41 <[mbot`> [ 20624 Hidden buttons in the Installer gui - UI elements and fonts are too big for screen resolution ]
19:31:46 <Luigi12> wilcal: sure
19:31:58 <Son_Goku> Luigi12, isn't the next one 5.10?
19:32:04 <wilcal> Just wanted to make sure everyone here is aware of it
19:32:08 <Akien> I agree with tmb, we just have to document that plasma has some imperfections, but we can release as is
19:32:12 <Luigi12> Son_Goku: I can't remember, I read about it recently
19:32:30 <Son_Goku> ah, Plasma 5.12 will be
19:32:32 <Akien> Ideally when we're rested we can investigate and patch the bug via an update
19:32:33 <wilcal> "imperfections" is stating it mildly
19:32:34 <Son_Goku> in January 2018
19:32:41 <Akien> :D
19:33:08 <Akien> Basically, I think that all "bad" issues that remain at this stage should get the FOR_ERRATA6 keyword
19:33:15 <filip> wilcal: there was also some discussion about possible dropping of some packages with unfixed security issues IIRC
19:33:17 <wilcal> Yup
19:33:36 <wilcal> Sounds like a plan filip
19:33:38 <Akien> Then we can add them to the errata so that people are aware of these issues
19:34:01 <Akien> That could be our next topic, the "other" blockers page
19:34:06 <Luigi12> Akien: yeah maybe we can make new Live ISOs in 6-9 months or so
19:34:22 <filip> Luigi12: mga7
19:34:23 <Akien> #topic Security bugs: packages to drop before mga6?
19:34:27 <Akien> #link https://madb.mageia.org/tools/security
19:34:30 <Luigi12> filip: mga7 doesn't help
19:34:32 * filip runs
19:34:35 <[mbot`> [ Mageia App Db - Security issues ]
19:34:59 <Akien> Can we do a quick review of the pending security issues and of the packages that could or should be dropped asap?
19:35:48 <Luigi12> please
19:36:06 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=18557
19:36:08 <[mbot`> [ 18557 tika new security issue CVE-2016-4434 ]
19:36:15 <Akien> From what I checked last week, I think we could maybe drop mp3splt, ytnef (and tika?)
19:36:29 <Luigi12> tika: no feedback from neoclust or david, I don't know why it hasn't been updated or if it can't be.  Looks possibly droppable, but no feedback on that either.
19:37:04 <Akien> AFAIK neoclust tried to update tika but it did not build. Not sure he investigated further
19:37:16 <Luigi12> I wasn't aware of that, thanks
19:37:28 <Son_Goku> sounds like tika should be removed
19:37:46 <Luigi12> it'd be nice if we could drop it.  We can reintroduce it as an update if that makes things easier later once there's a fix.
19:38:03 <Akien> We just need to make sure it can be disabled in its reverse deps
19:38:14 <Akien> Son_Goku: volunteer? :p
19:38:20 <Son_Goku> ehhhhhh
19:38:30 <Akien> :D
19:39:02 <Son_Goku> Java stuff is scary... >_<
19:39:24 <Luigi12> some of the reverse deps didn't look too hard to drop it, the others looked more involved but I didn't get too far with them
19:40:36 <Akien> Luigi12: apart from tika, I think we could drop mp3splt (and maybe readd it in updates if it gets a fix) and ytnef
19:40:44 <Luigi12> cool
19:40:45 <Akien> For the rest, I don't see stuff that could be dropped easily at this stage
19:41:13 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=18987  binutils: tmb has probably addressed as well as we can for now, rest can be fixed later
19:41:16 <[mbot`> [ 18987 binutils several new security issues ]
19:41:25 <tmb> yep
19:41:36 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=19029  apache-poi: another one that is fixed in a later version, not sure why it hasn't been updated (maybe doesn't build again)
19:41:39 <[mbot`> [ 19029 apache-poi new security issues CVE-2016-5000 and CVE-2017-5644 ]
19:41:56 <Luigi12> but again no feedback from neoclust or david or anyone
19:42:18 <Akien> Ah we can drop openvswitch too
19:42:26 <Luigi12> oh yes, definitely
19:42:31 <Akien> Its maintainer is not known for being responsive on security bugs, it's dead upstream and a leaf package
19:42:39 <Luigi12> for sure
19:42:43 <Luigi12> any thoughts on apache-poi?
19:42:48 <Akien> (just needs its dependency removed from os-autoinst)
19:42:54 <Son_Goku> when did openvswitch get dead upstream?
19:42:59 <Son_Goku> it was merged into the kernel, afaik
19:43:02 <Luigi12> well our package has been dead for 4 years
19:43:17 <Luigi12> not sure about upstream, but it was imported and never maintained downstream
19:43:25 <Son_Goku> oh gross
19:43:34 <Akien> apache-poi seems to be a friend of tika's
19:43:45 <Son_Goku> I think OpenQA kind of requires it, though
19:43:59 <Son_Goku> so that package might just need to be kicked hard and synchronized with Fedora
19:44:11 <Akien> Can be done via Core Updates post release
19:44:26 <Luigi12> hopefully
19:44:48 <Son_Goku> openvswitch packaging is actively maintained in Fedora, so we can just synchronize there and benefit from that
19:44:48 <Akien> So to summarize:
19:45:00 <Akien> Drop: mp3splt, ytnef, openvswitch
19:45:06 <Luigi12> Son_Goku: yeah but we have nobody interested in maintaining it
19:45:17 <Akien> Review and if possible drop: tika, apache-poi
19:45:19 <Son_Goku> do we have any interest in using OpenQA?
19:45:24 <Akien> The rest: fix.
19:45:34 <Son_Goku> if we do, then someone needs to keep openvswitch updated too
19:45:42 <Akien> Yes, but we have no interest in maintaining dependencies for OpenQA without having OpenQA in Mageia 6 :)
19:45:45 <Luigi12> ok, https://bugs.mageia.org/show_bug.cgi?id=19668  graphicsmagick: Akien e-mailed the upstream maintainer, we're hoping for a new version shortly after mga6 release
19:45:48 <[mbot`> [ 19668 graphicsmagick several (possible) new security issues ]
19:45:49 <Akien> We can drop it now, readd it fixed for mga7
19:45:54 <Son_Goku> Akien, we have OpenQA in Mageia 6, afaik
19:46:04 <Son_Goku> os-autoinst and openqa packages are both in cauldron now
19:46:09 <Son_Goku> though they might be out of date
19:46:17 <Akien> Son_Goku: Well it doesn't appear to depend on openvswitch then
19:46:20 <Luigi12> we talked about using OpenQA but I don't think we ever got around to it
19:46:29 <Luigi12> so maybe we can drop it and re-add it for mga7
19:46:48 <Akien> === rpms that will have to be deleted ===
19:46:49 <Akien> openvswitch
19:46:50 <Akien> os-autoinst: losing ["os-autoinst-openvswitch"], remaining ["os-autoinst", "os-autoinst", "os-autoinst-debuginfo"]
19:47:00 <Akien> (from a script that checks reverse deps)
19:47:56 <Akien> Anyway, let's move on, there are other topics to discuss tonight :)
19:47:58 <Son_Goku> if we can safely purge that dep, then sure
19:48:10 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=19800  dracut: I'm confused on the status here
19:48:12 <[mbot`> [ 19800 dracut new security issue CVE-2016-4484 ]
19:48:26 <Luigi12> it sounded like there's some disagreement on whether an adjustment needs to be made in the installer
19:49:53 <Akien> tmb: Do you have an opinion about that one?
19:50:09 <Son_Goku> my understanding is that the shell is *supposed* to be disabled when you have an encrypted disk
19:51:18 <Son_Goku> besides, it's a debug shell, not the emergency shell, etc.
19:53:02 <tmb> well, the "rd.shell=0" should be added by drakx, but I dont want to change drakx/installer anymore this late in the game... we can errata it with theese points: https://harald.hoyer.xyz/2016/11/15/dracut-and-cve-2016-4484-cryptsetup-initrd-root-shell/
19:53:03 <[mbot`> [ dracut and CVE-2016-4484: Cryptsetup Initrd root Shell Harald Hoyer ]
19:53:30 <Luigi12> ok, thanks.  FOR_ERRATA then
19:53:42 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=20050  nagios: accepted my patch upstream, just need to add it to the package
19:53:44 <[mbot`> [ 20050 nagios new security issue CVE-2016-10089 ]
19:53:57 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=20224 mp3splt: Akien already proposed dropping
19:53:59 <[mbot`> [ 20224 mp3splt new security issues CVE-2017-566[56] and CVE-2017-5851 ]
19:54:20 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=20231  jenkins: I don't understand why this package is so far behind upstream, no movement here, and it doesn't seem the package is needed
19:54:22 <[mbot`> [ 20231 jenkins several security issues ]
19:54:38 <Luigi12> Java stuff is annoying :o)
19:55:05 <Akien> Indeed jenkins seems to have no reverse deps
19:55:47 <Akien> So likely a candidate for dropping + reintroduction as a fixed update if requested (I think it's a popular leaf package)
19:55:56 <Luigi12> sounds good
19:56:09 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=20234  podofo: addressed by Akien as well as can be for now
19:56:11 <[mbot`> [ 20234 podofo new security issues CVE-2015-8981, CVE-2017-585[2-5], CVE-2017-5886, CVE-2017-684[0-9], CVE-2017-737[89], CVE-2017-738[0-3], CVE-2017-8787 ]
19:56:33 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=20625  ruby: patch needs ported to our version, I looked at it.  It looks doable, but it's a bit of work, more than I had time for.
19:56:36 <[mbot`> [ 20625 ruby new security issue CVE-2016-2339 ]
19:57:04 <Luigi12> anyone want to take a stab?
19:57:57 <Luigi12> this one's been sitting for three months
19:59:33 <Akien> You should poke pterjan, he's the registered maintainer for ruby
19:59:44 <Luigi12> guess we can try
19:59:53 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=20685  qtwebengine5: we have plans to address this later
19:59:55 <[mbot`> [ 20685 qtwebengine5 several new security issues fixed in 5.8.0 ]
20:00:18 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=20731  mysql-connector-java: fixed in the next upstream version.  neoclust said it didn't build but I don't remember seeing a build attempt for it (maybe I forgot?)
20:00:21 <[mbot`> [ 20731 mysql-connector-java new security issues CVE-2017-3523, CVE-2017-3586, and CVE-2017-3589 ]
20:00:23 <Akien> Or more like, upstream doesn't give a damn, so we shouldn't either :p
20:00:36 <Luigi12> for qtwebengine5?  I would agree there
20:00:54 <Akien> Yeah for qtwebengine5
20:00:56 <Luigi12> yeah I don't see mysql-connector-java 5.1.42 in SVN
20:00:59 <Akien> Their "LTS" is a joke
20:01:03 <Luigi12> I'm not sure the upgrade was attempted
20:01:06 <Luigi12> Akien: agreed
20:01:28 <Son_Goku> qt5webengine was a mistake, imo
20:01:34 <Luigi12> would be nice if we could try to upgrade mysql-connector-java
20:01:59 <Son_Goku> oh, that reminds me, what do we do about qt5webkit (qtwebkit5)?
20:02:30 <Luigi12> probably not much we can do
20:02:51 <Akien> Trying to build mysql-connector-java locally
20:02:56 <Luigi12> thanks
20:03:12 <Luigi12> next 4 security bugs on the list Akien has already reviewed (thanks Akien!)
20:03:39 <Luigi12> oh, next 5 I should have said
20:03:51 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=21101 mariadb: I need some help with this
20:03:53 <[mbot`> [ 21101 mariadb 10.1.24 ]
20:03:56 <Akien> The libcroco one too yeah, it's pretty minor so no big deal IMO
20:04:15 <Luigi12> the update to 10.1.24 needs to be finished, that's the easy part, but the package also contains a downstream script that needs fixed the same way Fedora fixed theirs
20:04:36 <Luigi12> our two scripts obviously have the same ancestor but they have diverged, so it needs a bit of brains to port the fix to our script
20:04:46 <Akien> (mysql-connector-java doesn't build, error: package org.hibernate.engine.jdbc.connections.spi does not exist)
20:05:03 <Luigi12> ok, so probably a missing package we need to import.  Lovely.  Thanks for checking.
20:05:18 <Luigi12> can anyone help with fixing the script in mariadb?
20:05:42 <Luigi12> this is really the one I'd like most to fix out of all of these
20:09:35 <Akien> I guess send a call for help on the dev@ ML, I'm not sure we can or should find a voluntary between the happy few who attend this meeting
20:09:43 <marja> Luigi12: AL13N is still around in #mageia-dev, afaik he's still the registered maintainer of mariadb
20:09:48 <Akien> (and I'd like to move on to further topics regarding the release)
20:09:49 <Luigi12> Akien: good idea
20:09:52 <Luigi12> almost done
20:10:03 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=21169  rkhunter: I would be satisifed with disabling the cron by default as a "fix"
20:10:05 <[mbot`> [ 21169 rkhunter new security issue CVE-2017-7480 ]
20:10:06 <Luigi12> so that should be doable
20:10:18 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=21170  lame: no fixes available AFAIK
20:10:20 <[mbot`> [ 21170 lame new security issues CVE-2015-9099, CVE-2015-910[01], CVE-2017-9869, CVE-2017-987[01] ]
20:10:30 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=21177  libgphoto: I can update it, I should do that soon
20:10:32 <Luigi12> done
20:10:32 <[mbot`> [ 21177 libmtp, libgphoto new security issues CVE-2017-9831 and CVE-2017-9832 ]
20:10:34 <Luigi12> next topic
20:10:38 <Luigi12> thanks for the review
20:10:48 <Akien> Thanks :)
20:10:59 <Akien> #topic Release notes
20:11:17 <Akien> To all the not security-savvy here: wake up! :p
20:11:32 <marja> :)
20:12:08 <Akien> Basically we're almost release ready, I'd expect the QA team to give a GO during their Thursday meeting unless a huge blocker shows up
20:12:15 <Akien> What we really need to work on right now is the release notes though.
20:12:33 <wilcal> I agree Akien
20:12:36 <Akien> After 2 years of development, reviewers and users will really be looking at "what have we been waiting for for so long?"
20:12:45 <Akien> So we need release notes that look great.
20:12:50 <ennael> yep needs to be updated to include in stage2 at least
20:12:52 <Akien> https://wiki.mageia.org/en/Mageia_6_Release_Notes
20:13:09 <Akien> I haven't had time to look into detail yet, but the current release notes are partly outdated and lack quite important stuff
20:13:26 <marja> Akien: i missed the decision that the classical isos don't need to fit on a 4 gb  usb key
20:13:26 <Akien> For example no mention of DNF 2.x support in the "Major new features"
20:13:29 <Akien> Son_Goku: ^
20:13:34 <Son_Goku> and dnfdragora as a tech preview too
20:13:42 <Son_Goku> that didn't exist when I wrote those notes a year ago
20:13:42 <ennael> marja: yep indeed I just forgot to ask it here
20:13:58 <Akien> Son_Goku: My ping means, you need to write the relevant stuff in the release notes :p
20:14:05 <Son_Goku> yeah, I know
20:14:14 <Son_Goku> I'm also nearly finished with a very nice blog post
20:14:42 <marja> ennael: ok, so that needs to be decided and then communicated?
20:14:48 <ennael> yep
20:14:50 <Son_Goku> the DNF 2.x thing is going to be exciting, as we're the first distro to release with it :)
20:14:56 <Akien> And yeah, the release notes need to be synced when building the ISOs, so we should as them "good" as soon as possible so that we can build the final final final ISOs.
20:14:58 <Son_Goku> aside from Yocto, I guess
20:15:00 <ennael> it becomes more and more complicated to remove packages
20:15:13 <marja> ennael: yeah
20:15:16 <ennael> more DE included and those DEs are bigger and bigger
20:15:34 <Akien> #topic Maximum size of ISOs: lift the 4G limit?
20:15:58 <Son_Goku> this is specifically about classic ISOs, right?
20:16:06 <ennael> for now yes
20:16:12 <ennael> don't know about live
20:16:12 <Luigi12> do we still have old LXDE on the 4G ISO?
20:16:17 <Akien> What's the current size for the classical 64-bit ISO?
20:16:50 <Son_Goku> if we have LXQt, we should drop LXDE
20:16:56 <Luigi12> that's what I was thinking
20:16:59 <ennael> 4053794816      Mageia-6-x86_64-DVD.iso
20:17:01 <Luigi12> you can only fit some many DEs on one ISO
20:17:05 <Luigi12> s/some/so/
20:17:28 <ennael> Luigi12: pb is when we remove one then we get "why this one ?"
20:17:32 <ennael> endless pb :)
20:17:36 <Luigi12> yeah but we have to demote one
20:17:37 <Akien> Just remove the 1G of 0ad-data :p
20:17:45 <Luigi12> LOL
20:17:52 <Son_Goku> well, at least with LXDE, the answer is "it's dead, jim!"
20:17:59 <Schultz> If we do, it might be an issue for older systems, they are likely the ones that don't have decent internet in the first place
20:17:59 <Luigi12> and has a fine replacement
20:18:02 <Luigi12> and "it's 2017"
20:18:12 <Luigi12> that's why we have the new Live ISO with a light DE
20:18:14 <Luigi12> I forget which one
20:18:17 <Son_Goku> xfce
20:18:17 <Luigi12> XFCE?
20:18:31 <marja> Luigi12: yes
20:18:36 <Luigi12> and it shouldn't be an issue for older systems, there are still other options on the classical ISO
20:18:36 <Son_Goku> it would have been lxqt if it wasn't for the qt5 issues with disabling sse2
20:18:51 <Luigi12> it seems like the most logical one to go
20:18:53 <Son_Goku> specifically with sddm
20:18:54 <Son_Goku> yeah
20:19:00 <Son_Goku> if we're not removing from the archive, at least from the ISO
20:19:03 <papoteur> 64 b DVD is 4 053 794 816 bytes
20:19:14 <Schultz> As in bad internet - get the classical iso from the library or wherever, then you are set for a large package choice - the live can't provide that
20:19:38 <Son_Goku> Schultz, yes, but when you have Xfce AND LXQt, there's no point in including LXDE
20:19:47 <Akien> Well there is no reason to drop LXDE completely. But yes we can remove it from ISOs if it removes the 55M necessary.
20:19:48 <tmb> it's also about being able to reuse 4GB usb sticks
20:19:56 <Luigi12> yeah we can't fit ALL of the distro on the ISO, choices have to be made
20:20:14 <Schultz> Son_guku: really not my point - I agree LXDE should be dropped
20:20:17 <Son_Goku> Luigi12: well....
20:20:19 <ennael> do you still have 4GB usb keys ?
20:20:22 <Luigi12> yes I'm not proposing dropping it completely
20:20:36 <Luigi12> there certainly still are 4GB DVD discs
20:20:40 <Son_Goku> yes
20:20:47 <Son_Goku> 4.7GB DVDs still exist
20:20:59 <Schultz> Yeah the DVD size is my concern, not many Bluray readers going
20:21:00 <Son_Goku> but I have a hard time finding 4GB USB sticks these days
20:21:11 <marja> ennael: i do,  my 32bit laptop refuses to boot from usb keys that are larger than 4gb
20:21:17 <Akien> (about the talk of dropping LXDE, I don't think we'd win much place - it is really lightweight)
20:21:33 <ennael> Akien: indeed just checked it's nearly nothing
20:21:54 <Akien> Installing task-lxde-minimal on my system brings 13MB.
20:21:55 <Son_Goku> hmm, apparently we don't include LXQt on the ISO
20:21:57 <Schultz> its not like it brings in many unneeded toolkits and such
20:21:58 * Luigi12 has 3 4GB USB sticks sitting on his desk right in front of him
20:22:06 <Akien> Arguably I might have many of its deps installed, but many of its deps are the same as Xfce anyway.
20:22:12 <filip> not new but old 4 gb are still around. and very useful for exactly this purpose (install)
20:22:22 <tmb> oh they are still around and I dont think of devs, as most of them have bigger... but end-users with no extra money to spare would like to use their usb sticks and not have to buy new ones
20:22:33 <Schultz> I have a fair few 4Gb lying around, some 1 and 2Gb ones too
20:22:41 * sebsebseb idles
20:23:01 <Luigi12> sebsebseb: no interruptions please
20:23:03 <Son_Goku> if we really wanted to, we could produce large USB / DVD-DL media to go with the small USB / DVD-SL media
20:23:12 <Luigi12> Akien: ahh that's a bummer, I thought it'd free more space
20:23:23 <tmb> so the 4GB limit is more of a service to to end-users
20:23:52 <tmb> the current isos will still fit nicely on SL DVDs
20:24:10 <marja> yeah
20:24:20 <filip> DVDs are dying anyway
20:24:23 <wilcal> moving to another computer
20:24:25 <Akien> At the same time if we decide not to lift the limit now, we'll have to lift it next time anyway. libreoffice, firefox, DEs, etc., even the kernel only grow bigger and bigger.
20:24:47 <Schultz> I feel that we should be ok with DVDs, not sure how much the USB issue matters, although if the issue marja has is common, then maybe its a bigger one
20:24:58 <Luigi12> indeed
20:25:05 <Son_Goku> if it's not too much more work, we could produce two images, one with a larger selection for larger sticks and DVD-DL media
20:25:08 <Schultz> How big is the 32bit ISO?
20:25:10 <Son_Goku> not now, but in the future
20:25:20 <marja> we need to lift the limit, or we won't get mga6 out
20:25:22 <tmb> yeah, there is a lot of broken hw out there :/
20:25:59 <ennael> 4075814912      Mageia-6-i586-DVD.iso
20:26:16 <ennael> nearly the same
20:26:16 <Luigi12> I don't think we want to add another ISO at this point though
20:26:28 <Luigi12> we already did with the Live XFCE, don't want to kill QA
20:26:30 <filip> but if it takes a lot of time it's not worth it I guess. mga6 can't wait much longer ;)
20:26:48 <marja> no, no extra iso now
20:26:54 <ennael> one other solution would be to remove languages
20:27:00 <ennael> but it can be tricky
20:27:05 <Luigi12> I've seen other distros do that
20:27:07 <ennael> what languages and we have to sync all apps
20:27:12 <Schultz> Hmm, I guess the 32/64bit argument doesn't really hold, you have to go back a pretty long way to get 32bit only systems
20:27:14 <Akien> I don't like the idea to remove languages.
20:27:26 <ennael> neither do I
20:27:30 <filip> ennael: not worth it because only active ones are big
20:27:35 <Son_Goku> yeah
20:27:36 <Schultz> Same, languages should stay
20:27:39 <Luigi12> it's not that hard to find a 32-bit system, it's called a VM
20:27:53 <Akien> I think we should allow ourselves to go past the 4G limit for Mageia 6, otherwise we'll delay endlessly trying to put the ISOs on a diet.
20:27:57 <marja> yep, keep the languages
20:28:06 <Akien> If users complain, we can reconsider and maybe make a lightweight classical ISO later on.
20:28:16 <marja> Akien: +1
20:28:20 <Luigi12> sounds OK
20:28:27 <filip> there's still a network install as a fallback
20:28:33 <Luigi12> yep
20:28:35 <Schultz> Luigi12: but how many 32bit vms are there that wont work on larger iso's?
20:28:40 <Akien> But tbh, I expect that users who can't afford a 8G USB stick would just use a live DVD and then install packages over network.
20:28:48 <Luigi12> Schultz: oh LOL, sorry
20:28:55 <Son_Goku> I forgot, we do have the netinstall ISO
20:29:13 <Son_Goku> and of course, we have the live media, which sit at ~2GB
20:29:41 <Schultz> Luigi12: no worries, was having a giggle at the thought of trying to run a vm on a 32bit system... P4 days
20:30:01 <filip> I'm against if it takes more than a few hours. we're even wasting time now ;)
20:30:17 <Akien> So I say let's go for those 4.05G ISOs.
20:30:30 <Akien> And no, that's not a pretext to add plenty of new packages now :p We only fix bugs at this stage ;)
20:30:39 <tmb> ok, so lets go for lifting the limit to SL DVD size for now and see the fallout when we release :)
20:30:51 <Akien> SL DVD is 4.7G?
20:30:54 <Son_Goku> yes
20:30:56 <Schultz> yeah, lets get this release out, sl dvd limit makes perfect sense to me
20:31:00 <Akien> Sounds good.
20:31:03 <ennael> I will not add more packages
20:31:16 <tmb> thats sales speak... computer speak is some 4.3
20:31:29 <filip> CI still does fit on some 4g keys anyway
20:32:02 <Akien> filip: not the 3.7G ones marketed as 4G :P
20:32:14 <tmb> ennael, you can drop the all-nonfree.rdz from the isos to gain some space
20:32:15 <filip> yeah. let's move on
20:32:19 <Akien> But it would be the same issue with being just below the 4G limit anyway
20:32:59 <Son_Goku> can we hurry through this? I gotta go soon
20:33:22 <Akien> Yeah. Maybe we can finish by deciding of the next steps for the release? (and a kind of ETA?)
20:33:42 <Akien> Just so that we don't miss 2 weeks of meeting again and it's already end of July :D
20:33:45 <marja> #agreed lift the 4GB limit for the isos, consider building a light CI later on if users complain
20:33:45 <tmb> ennael, and drop kernel-source... the kernel-devel packages are enough
20:34:23 * tmb already found 150K to drop :)
20:34:23 <Akien> #topic Release schedule
20:34:37 <filip> there are 2 more issue I see: web documentation update and mga6 pages
20:34:52 <papoteur> tmb :)
20:35:13 <ennael> 130M
20:35:20 <Akien> Should we aim at making the final final final ISOs for this week-end?
20:35:26 <ennael> let's try this for now
20:35:45 <Son_Goku> can we please just do the "really final" ones now?
20:35:45 <ennael> even if I agree with Akien , at one point it will not be enough anymore
20:35:55 <ennael> we need mageia-release
20:35:59 <Son_Goku> lets flip the bloody switches and start doing this
20:36:24 <Son_Goku> mageia-release, mageia-repos (mkrel 1 and non-Cauldron), and doc update->sync are required, right?
20:36:28 <Luigi12> this weekend sounds OK
20:36:29 <wilcal> Lets Go!
20:36:33 <Akien> Son_Goku: Do you want DNF to be missing from the release notes on the release final ones? :)
20:36:35 <ennael> release notes
20:36:53 <Schultz> Lets aim for the weekend
20:36:55 <Son_Goku> Akien, I'm going to be updating the release notes this evening, after my independence day bbq thing
20:36:59 <tmb> yep. its time to flip the switch, but that also means _no_ more freeze pushes unless they fix something _on_ the isos
20:37:03 <Akien> Son_Goku: Great :)
20:37:13 <Akien> tmb: Duly noted.
20:37:32 <Luigi12> hopefully QA can give final GO on ISOs Thursday, July 13?
20:37:35 <Akien> So let's say new ISOs on Friday evening?
20:37:41 <Akien> Until then:
20:37:50 <Akien> - Improve release notes (please all read them and do fixes, add stuff)
20:38:03 <Akien> - Drop packages we mentioned before
20:38:43 <Akien> - Prepare web and docs
20:38:56 <papoteur> Are documentation manuals on ISO. If yes, they should be released before. There are ready.
20:39:02 <Son_Goku> oh, and we need do some summer cleanup of the mirrors
20:39:06 <Son_Goku> this is really painful :(
20:39:11 <Akien> So release on Friday 14? :o)
20:39:21 <Son_Goku> well, it's not Friday the 13th, so it's a great omen!
20:39:26 <filip> leuhmanu has also refreshed our main website image: https://mga.hiebel.eu/. I hope he'll soon push it
20:39:27 <Luigi12> that'd be nice
20:39:27 <[mbot`> [ Home of the Mageia project ]
20:39:27 <Akien> Bastille Day release :D
20:39:33 <marja> papoteur: yes, afaik they are
20:39:35 <Luigi12> oh is it?  that's cool
20:40:03 <Luigi12> that reminds me of Paris When It Sizzles with Audrey Hepburn
20:40:20 <Son_Goku> hmm, the new site doesn't load for me :(
20:40:25 <Akien> Anything else that needs to be done before the final ISOs?
20:40:43 <Son_Goku> is there anything we can do about the mirror situation, tmb?
20:40:44 <marja> Akien:  new mageia-doc needs to be packaged before last iso build
20:40:57 <filip> Son_Goku: strange. it does here albeit a bit slow
20:41:01 <Akien> marja: I'll work on that.
20:41:08 <tmb> Son_Goku, what mirror situation ?
20:41:10 <marja> Akien: thx!
20:41:20 <papoteur> Akien: \o/
20:41:22 <Schultz> release announcement and such, but that shouldnt be an issue
20:41:28 <Son_Goku> tmb, we have tons of dead-ish and out of date mirrors that are getting selected and pushed
20:41:36 <Son_Goku> it's caused problems for Akien and I with the Rust work
20:41:39 <Son_Goku> among other things
20:41:50 <Akien> We have some dead mirrors yeah: http://mirrors.mageia.org/status
20:41:58 <Son_Goku> the problem is more prevalent with our North American mirror network
20:42:21 <Son_Goku> ordinarily, this wouldn't be an issue if we had MirrorBrain, as it would deprioritize them automatically
20:42:32 <Son_Goku> but since we don't, manual intervention is required :(
20:43:35 <filip> tmb: regarding mirrors I hope that git -> mirrors part for doc files (epub + pdf) is doable before release?
20:44:11 <filip> or soonish after
20:44:14 <tmb> filip, do you have the stuff ready in git ?
20:44:32 <filip> I already emailed you :)
20:44:40 <filip> jsut a sec
20:45:15 <filip> http://gitweb.mageia.org/artwork/general/tree/doc_binaries_for_website
20:45:16 <[mbot`> [ general - General Artwork ]
20:45:25 <Akien> Should I do a last run of translation update releases of our soft before Friday?
20:45:48 <marja> Akien: good idea
20:45:59 <filip> Akien: translators will be gratefull and also all others ;)
20:46:08 <tmb> filip, sorry, I missed that mail :/ I'll fix that up this week
20:46:17 <filip> tmb: no worry
20:47:03 <Akien> #action All: Read, proofread, fix and improve the release notes. They should reflect the quality of our work over those 2 years!
20:47:24 <filip> tmb for better search if needed: Date: Fri, 23 Jun 2017 01:45:47 +0200
20:47:36 <Akien> #action Akien releases translation updates for all Mageia software
20:47:42 <tmb> Akien, yeah, you could wait until ~thursday and then roll new releases so translators have some more days .... maybe ping i18n too so they can do a last rush :)
20:47:55 <Akien> tmb: good idea
20:48:28 <Akien> #action Security: some packages should be dropped, others reviewed (see logs)
20:49:01 <Akien> #action Final release ISOs to be produced on Friday 7th. Public release expected a week after.
20:49:05 <tmb> Son_Goku, I'll clean the mirror list ... and ping k.org about their mirror not syncing properly...
20:49:16 <Son_Goku> tmb: thanks
20:49:36 <Akien> #action Atelier gets everything ready communication wise for next week.
20:49:45 <Son_Goku> does that mean the repodata.old.* dirs showing up everywhere and the missing repodata/ dirs in arm arches are related to that?
20:50:06 <Akien> #action @all start buying beer and baking cake for the release party
20:50:22 <Akien> Ok I'm done actioning everything :p
20:50:34 <marja> Akien: :)
20:50:42 <filip> we all are I guess ;)
20:50:57 <Schultz> Can I bake beer and buy cake :)
20:51:31 <marja> Schultz: sure, in your dreams ;)
20:52:04 <Schultz> The joke is that I hate beer :) It's only use is for baking bread :)
20:52:28 <marja> Schultz: ?
20:52:29 <tmb> Son_Goku, that seems to be bug on our build system not cleaning up arm* properly... :/
20:52:45 <Son_Goku> tmb, ah
20:53:59 <marja> can we end the meeting ?
20:54:09 <Akien> Yeah
20:54:15 <Son_Goku> #endmeeting