19:09:01 <stormi> #startmeeting
19:09:01 <Inigo_Montoya> Meeting started Tue May 16 19:09:01 2017 UTC.  The chair is stormi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:09:01 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:09:36 <stormi> #chair DavidWHodgins Akien marja wilcal Schultz2 filip__ Schultz ennael
19:09:36 <Inigo_Montoya> Current chairs: Akien DavidWHodgins Schultz Schultz2 ennael filip__ marja stormi wilcal
19:09:49 <stormi> #topic Mageia 6 RC
19:09:51 * Akien plays some music.
19:10:09 <DavidWHodgins> There are still some serious bugs such as bug 20810
19:10:10 <wilcal> The laptop I am using now has M6 RC installed
19:10:22 <wilcal> netinstall was clean
19:10:25 <DavidWHodgins> That one affects upgrades only
19:10:30 <wilcal> yesterday
19:11:05 <wilcal> IMO the basic system is in good shape at least from a net install
19:11:15 <ennael> hi there sorry to be late
19:11:20 <DavidWHodgins> As it's only for upgrades, I'm inclined to say go ahead and release the rc iso images
19:11:28 <DavidWHodgins> Opinions?
19:11:35 <DavidWHodgins> #chair ennael
19:11:35 <Inigo_Montoya> Current chairs: Akien DavidWHodgins Schultz Schultz2 ennael filip__ marja stormi wilcal
19:11:36 <stormi> Given that we really need to release and considering that only testers would upgrade using RC, I agree
19:11:48 <stormi> now ennael has two chairs
19:11:53 <stormi> :)
19:12:02 <wilcal> I wanted to ask everyone their feelings about releasing M6 RC without the forums being up
19:12:13 <wikigazer> good point
19:12:14 <stormi> True, that's a concern
19:12:25 <marja> doktor5000__: wdyt? ^^^
19:12:28 <ennael> but we need also to go on
19:12:29 <DavidWHodgins> I forgot, as I rarely use the forums
19:12:35 <wilcal> goes hand and hand with releasing the RC
19:13:00 <wilcal> seems pointless to release without the forum being up
19:13:15 <stormi> The problem is, forum upgrade is currently stuck
19:13:45 <stormi> So I think people could forgive us if we give a status in the blog post + point at the mailing lists
19:13:56 <marja> maybe the blog post about RC could have a section explaining how to use discuss ml and IRC, for those who never used that
19:13:57 <stormi> RC is overdue
19:14:06 <stormi> same as marja :)
19:14:15 <marja> schultz: :-)
19:14:20 <wilcal> I can see making the RC available but announcing it's not really released until the forum is up
19:14:28 <wikigazer> then is the pragmatic thing to release and encourage use of IRC to help new users with mga6 ?
19:14:37 <wilcal> it's a predicament
19:14:51 <stormi> If someone could tell us when the forum would be up then I would accept some delay, but we have no ETA
19:15:02 <stormi> neoclust works on it but he is stuck currently and needs help
19:15:11 <wilcal> kinda hopeing someone here today could predict that
19:15:13 <stormi> and other sysadmins are not very aviaible
19:15:30 <stormi> aviaiable obviously stands for available :)
19:15:58 <wilcal> I'm for releasing it assuming there's probably going to be a RC #2
19:16:03 <wikigazer> has the old forum server been lost now?
19:16:07 <wilcal> gotta get wide feedback
19:16:17 <marja> stormi: could maat get more permissions... I mean, if he was allowed to physically handle our servers, why not give him more access?
19:16:26 <Schultz2> I'm strongly against releasing with a forum
19:16:44 <marja> s/more/full/
19:16:49 <stormi> Schultz2: without you mean
19:16:56 <Schultz2> Could we have a forum that is blank if it's quicker, then merge it later
19:17:03 <Schultz2> Yes quite...
19:17:05 <stormi> marja: I don't know, when I asked I did not get an answer
19:17:17 <stormi> Or maybe I missed it
19:17:28 <schultz> Anything stupid Schult2 says is either the phones, or plymouths fault :)
19:17:34 <DavidWHodgins> :-)
19:18:40 <filip__> it would be nice if we manage to redirect forum domain to dedicated blog post/wiki page
19:19:43 <stormi> Schultz2: merging that kind of database is a nightmare
19:19:46 <wikigazer> what is the status of the wiki now? last time I looked it was not handling graphics for existing content but seemed to work for new content?
19:19:57 <stormi> that's next topic :)
19:20:01 <wikigazer> sorry
19:20:36 <marja> stormi: I asked in #mageia-sysadm
19:20:42 <wilcal> I think Dave and I are both in support of getting M6 out there.
19:20:51 <DavidWHodgins> Yes
19:20:55 <schultz> stormi: Ok, ignore that then, what is it that is holding the upgrade up, we need to give an update on this
19:20:58 <filip__> can we ask other forum sysadmins if they borrow us part of their infra?
19:21:28 <wilcal> We have several issues that are unique to us, I opened a couple of bugs today, it would be nice to see if others see the same issues
19:21:29 <DavidWHodgins> The upgrade problem is primarily under virtualbox
19:21:48 <filip__> I mean fr on any other lang
19:21:49 <wilcal> I struggle with the upgrade issue(s)
19:21:53 <stormi> last message from neoclust about it was "I enabled forums on sucuk but i don't understand why, the databases are not enabled on the new pgsql server."
19:21:57 <DavidWHodgins> My real hardware upgrade tests have been ok
19:22:02 <marja> the French MLO forums are up, we can suggest our users to use translate.google and use the MLO forums
19:22:14 <stormi> basically he just needs help from other sysadmins in the team
19:22:17 <wikigazer> one thought: will external reviewers of mga6 pick up on and criticize the distro because of forum/wiki issues ?
19:22:29 <stormi> marja: I'd rather avoid that and just suggest using mailing lists
19:22:47 <marja> stormi: ok
19:23:02 <stormi> wikigazer: they might say that we're slow at solving issues, but there's no reason why they should criticize the distro itself
19:23:08 <wikigazer> ok
19:23:10 <wilcal> I want to get back on the upgrade issue M5 -> M6
19:23:28 <Schultz2> Yeah I'd avoid Google translate too, we already look pretty incompetent
19:23:49 <stormi> DavidWHodgins: is the upgrade issue the same as what happens if you update a virtualbox mga5? You get an unbootable system due to graphical driver issues.
19:24:05 <DavidWHodgins> Yes
19:24:12 <wilcal> IMO it's even more globular then that
19:24:31 <DavidWHodgins> Only seems to affect x86_64 upgrades
19:24:38 <wilcal> Can we all agree that M4 -> M6 direct upgrade is not valid
19:24:52 <wilcal> especially with KDE -> Plasma
19:24:55 <stormi> I think this can be a note in the blog post + a detailed entry in errata but not blocker for RC
19:24:59 <DavidWHodgins> wilcal: Yes. We've never supported upgrading over 2 releases
19:25:23 <stormi> wilcal: but 4 > 5 > 6 is
19:25:33 <DavidWHodgins> stormi: I argree with that
19:25:34 <wilcal> I can also suggest that maybe M5 KDE -> M6 Plasma may also not work 100% of the time
19:25:57 <wilcal> everywhere
19:25:59 <wikigazer> for me upgrading is a bit academic. I never do it. I feel fresh overwrite install is faster, safer and more efficient and makes me think about what I actually need from old version.
19:26:15 <stormi> same as wikigazer :)
19:26:20 <stormi> except on server
19:26:27 <wilcal> i feel the same wikig
19:26:28 <DavidWHodgins> My current primary install started as Mageia 3
19:26:48 <stormi> It's important that upgrade IS supported though, indeed
19:26:56 <stormi> So back to RC
19:27:16 <DavidWHodgins> I don't expect many virtualbox users to be doing upgrades though
19:27:24 <stormi> Am I right if I say it's ready, with known issues about upgrades in virtualbox maybe and about the KDE to plasma upgrade?
19:27:26 <wilcal> I think if your going from Xfce -> Xfce your going to be fine
19:27:37 <wilcal> Gnome -> Gnome is fine
19:27:46 <stormi> thanks for testing all those combinations
19:27:48 <wilcal> but KDE -> Plasma is dicey
19:28:18 <stormi> I think the KDE to plasma upgrade could be a whole topic for next time
19:28:47 <stormi> Or for a different day where neoclust could maybe join us (during QA's meeting?)
19:29:08 <wilcal> for sure I think there has to be something mentioned in te M6 release errata that KDE -> Plasma upgrade may be problematic
19:29:15 <stormi> #info RC is ready, with known issues about upgrades in virtualbox and regarding KDE to plasma upgrade
19:29:31 <wilcal> new installs are very much cleaner
19:29:41 <stormi> Maybe we should move KDE's configuration out before upgrading to plasma
19:29:46 <filip__> does any distro support KDE -> Plasma ?
19:29:56 <stormi> but again, we're off-topic for now
19:31:08 <stormi> #action discuss the KDE -> plasma upgrade with KDE team and QA and see what can be improved, what warnings can be given, etc.
19:31:31 <stormi> So in the end who's against releasing the RC
19:31:35 <stormi> without the forums I mean
19:32:01 <DavidWHodgins> While I do consider the forums important, I don't think we should hold the RC due to them.
19:32:21 <wilcal> Final release for sure
19:32:21 <stormi> What about a deadline?
19:32:36 <Schultz2> I'm for holding until they are up, assuming it will take a few days or so to get them ready
19:33:03 <wilcal> got to get this out tere
19:33:08 <wilcal> there
19:33:27 <stormi> I propose we schedule RC release to saturday, and try to get the forums up before then, but release even if we can't
19:33:40 <wilcal> sounds like a plan
19:33:43 <filip__> or at lest redirect
19:34:06 <filip__> s/lest/least
19:34:07 <stormi> and at least a redirect or a "maintenance" page
19:34:21 <DavidWHodgins> That sounds ok to me. That would also mean switching package updates to release freeze, wouldn't it?
19:34:47 <stormi> let's ask ennael
19:34:50 <schultz> Sounds good to me
19:34:51 <stormi> and Akien
19:34:51 * wikigazer can accept forums not being up for release. It is not ideal but it seems to me not having a forum server is not really related to the suitableness of the RC for release.
19:36:08 <stormi> #action Release RC on saturday. Try to get the forums online before. If we can't, add a maintenance page instead, pointing at mailing lists and IRC.
19:36:29 <stormi> #action Akien and ennael decide about release freeze?
19:36:50 <stormi> They'll answer when they can :)
19:36:56 <stormi> Can we proceed to next topic?
19:37:16 <marja> yep
19:37:28 <stormi> #topic Infra upgrade status
19:38:06 <stormi> There's not much to discuss because we haven't got an available sysadmin around tonight. I think neoclust has some real life activities on tuesdays :)
19:38:24 <stormi> But I gathered some information for the meeting
19:38:24 <marja> New users still can't log into the wiki, and afaik the pictures are still missing from the wiki
19:39:01 <marja> stormi: which information?
19:39:21 <stormi> well first what I told already about forums
19:39:30 <marja> ok
19:39:32 <stormi> neoclust is stuck and is looking for help
19:40:30 <stormi> It's not specifically a phpBB issue (if that's the forum engine we use), but rather a puppet or configuration issue
19:40:35 <stormi> If I understood correctly
19:40:46 <stormi> So the most likely to be able to help are pterjan and blino
19:40:51 <marja> ok
19:41:45 <stormi> About the wiki, indeed the image issue is known. I haven't been told about that issue about new users so either Akien forget about it or it's not known enough. marja can you maybe tomorrow see if there's a bug report about it and it's well known from sysadmins?
19:42:27 <stormi> And the MLs should be ok but sometimes have performance issues, maybe some disk space issues to be checked.
19:42:29 <marja> https://bugs.mageia.org/show_bug.cgi?id=20813
19:42:30 <[mbot> [ 20813 Can't login to the wiki (Auto-creation of a local account failed) ]
19:42:33 <stormi> That's all I've got.
19:42:39 <wilcal> Can we get a more definitive status by this time next week?
19:43:03 <stormi> Well I can't promise anything, I'm just the messenger :)
19:43:37 <stormi> I think all effort will be put on the forum
19:43:49 <wikigazer> actually, the wiki new users bug is both a blessing and s curse. It's a blessing because it immediately stops malicious junk pages being created while existing wiki contribs can still work on their pages
19:44:05 <wilcal> We in QA are great Cheerleaders
19:44:25 <stormi> so I'd tend to think that this time next week either the forum will be fixed and nothing else will have been fixed, or we'll be at the same stage as today.
19:44:55 <stormi> If there's only one thing to fix in the next days it's the forum
19:44:59 <wilcal> that won't hold up release of RC6 #1
19:45:17 <wilcal> That's a for sure on Sat
19:45:18 <stormi> indeed
19:45:25 <wilcal> that's progress
19:46:20 <stormi> Can someone tell about this saturday release on the council mailing list so that all those who need to prepare something ( filip__, schultz, Schultz2 ?) can do it in time?
19:46:34 <stormi> and of course about the forum plan
19:47:01 <Schultz2> Blog is started, I'll finish it this week
19:47:53 <stormi> I'll use a magical power and suggest wilcal sends the mail to the council mailing list :)
19:48:03 <stormi> If he forgets I'll try to think to do it
19:48:06 <wilcal> :-))
19:48:42 <wilcal> I don't like to be in charge. I'm completely irresponsible :-))
19:48:43 <stormi> So next topic would be ennael's
19:48:55 <schultz> Can you use those magical powers to get the plymouth guys to use qml scripting to please :)
19:49:02 <stormi> wilcal: just send the mail and you're not in charge anymore, you will be free again :)
19:49:17 <stormi> schultz: too late, magical powers exhausted
19:49:35 <stormi> ennael: are you around for the topic about goodies?
19:49:47 <stormi> Or anyone else willing to preside it
19:49:53 <ennael> yep
19:49:59 <ennael> I was just following discussion
19:50:03 <stormi> #topic Goodies
19:50:27 <ennael> I've just seen a mail on atelier about goodies
19:50:49 <ennael> we have some coming events and nearly no more goodies available except some tee-shirts
19:52:07 <schultz> ennael: finally got that one out of the drafts, forgot it was there until you mailed again, sorry for that
19:52:19 <ennael> no pb :)
19:52:27 <ennael> just tobe able to get it on time
19:54:18 <wilcal> council-owner@ml.mageia.org is the council mailing list right?
19:55:17 <DavidWHodgins> wilcal: No. That's the sender. To send to the list use council#ml.mageia.org
19:55:20 <DavidWHodgins> Argh
19:55:22 <marja> wilcal: council@
19:55:28 <DavidWHodgins> wilcal: No. That's the sender. To send to the list use council@ml.mageia.org
19:56:04 <wilcal> got it thanks
19:56:52 <stormi> and the tee-shirts are only those in sizes that no one wears :)
19:56:52 <schultz> So we need usb keys, pens and stickers at least
19:57:07 <schultz> then there are banners
19:57:25 <schultz> would getting a dark blue table cloth with the logo on it be worth it too?
19:57:49 <stormi> about goodies, I would favor more expensive but sustainable / ethical production
19:58:40 <stormi> If anyone knows of appropriate vendors
19:58:55 <wikigazer> it's not practical but I would love to be able to replace the "windows" key on my keyboard with a Mageia cauldron key. :-)
19:59:01 <filip__> stormi: +
19:59:48 <stormi> wikigazer: could be a sticker
19:59:51 <filip__> wikigazer: there are already such stickers but not from us
20:01:03 <ennael> I can ask for usb key, the one we had
20:01:07 <ennael> wood
20:01:17 <Schultz2> They were very nice with the wood
20:01:26 <Schultz2> What capacity did they have?
20:01:45 <stormi> 4 Gb
20:01:50 <stormi> and some of them didn't work
20:01:54 <wikigazer> do the stickers say something like: "Mageia inside" ?
20:01:55 <stormi> but overall I liked them
20:02:10 <ennael> wikigazer: just mageia logo
20:02:15 <DavidWHodgins> We should probably go with at least 8GB
20:02:20 <ennael> yep
20:02:22 <schultz> 4 seems a little stingy, maybe they have bigger ones now
20:02:32 <schultz> how bad was the failure rate?
20:03:09 <schultz> woot - plymouth now has 3/5 of the bubbles working in the right place, no idea where the other 2 have gone though...
20:03:14 <wikigazer> need to be careful with usb sticks. There  are real cases of companies giving out usb sticks and then finding out they had pre-installed malware
20:04:26 <wilcal> one dug itself deep into the bios of most intel mobos
20:04:27 <schultz> don't we do a complete wipe when we put the mageia install on there?
20:05:28 <wikigazer> what would be nice is a live version of Mageia on the usb stick which you can use and update moving from machine to machine?
20:05:56 <wilcal> I've actuall built myself one of those
20:07:34 <wikigazer> could even be used to "rescue" a system (by running off the USB memory and getting the hard disks mounted)?
20:07:44 <marja> wilcal: intel didn't need USB sticks for that https://semiaccurate.com/2017/05/01/remote-security-exploit-2008-intel-platforms/
20:07:47 <[mbot> [ Remote security exploit in all 2008+ Intel platforms - SemiAccurate ]
20:09:02 <stormi> schultz: yes we format them because they usually come unformatted
20:09:11 <stormi> with Live ISOs
20:10:05 <DavidWHodgins> Just run a search on "bad usb firmware"
20:12:25 <filip__> did we derail a bit ;)?
20:12:38 <ennael> :)
20:12:40 <marja> filip__: we're getting tired
20:13:20 <wilcal> get'n late
20:13:27 <wikigazer> consider usb 3 type sticks, much faster
20:13:32 <ennael> so can we get a full list so that we can start looking for price
20:15:39 <schultz> Sounds good, what else other than usb sticks are needed?
20:15:52 <marja> the pens were nice
20:16:00 <marja> stickers
20:16:12 <marja> someone suggested mugs
20:16:17 <schultz> As we are sort of on the subject, who do I speak to about getting repo's made on the git server, or can I do that myself?
20:16:19 <wikigazer> basges?
20:16:23 <wikigazer> badges?
20:16:44 <schultz> wikigazer: do you have a site in mind for them? If so, then they sound good
20:16:49 <marja> forget the mugs, they're heavy
20:17:05 <DavidWHodgins> And fragile
20:17:06 <wikigazer> schultz: yes, I will find it and share
20:17:08 <marja> (thinking of contributors travelling with goodies by train)
20:17:10 <schultz> marja: pens and mugs would be good, but yeah, the shipping could be tough
20:17:21 <schultz> wikigazer, great thanks for that
20:17:47 <marja> DavidWHodgins: indeed, fragile, too
20:18:24 <filip__> schultz: you can try to create git as it might work
20:18:26 <marja> sorry, leaving... good night all
20:18:38 <schultz> Maybe we could get some of the recycled pastic thermal style coffee ones, they would be great
20:18:48 <wikigazer> schultz: https://www.facebook.com/thebonnybadgecompany/   These folks do badges to order. I have a "citizen of Europe" badge from them which I like to wear.
20:18:51 <[mbot> [ The Bonny Badge Company ]
20:19:17 <schultz> filip__: will try, but as always my git access is messed up, svn works great though..
20:20:01 <schultz> wikigazer: Scottish too, makes me happy
20:20:20 <filip__> schultz: if you'll have trouble I can also try
20:21:06 <filip__> I guess we should close the mtg
20:21:21 <wilcal> i'm done being a pest :-)
20:21:32 <schultz> yeah nothing else from me unless people want to test a new plymouth for me?
20:22:24 <DavidWHodgins> Enough for today. :-)
20:22:53 <wilcal> Hooray for M6
20:23:08 <wilcal> I'm Cheerleading
20:23:12 <schultz> 3
20:23:14 <schultz> 2
20:23:18 <schultz> 1
20:23:25 <schultz> #endmeeting
20:23:34 <ennael> #endmeeting