19:08:05 <Akien> #startmeeting
19:08:05 <Inigo_Montoya> Meeting started Tue May  2 19:08:05 2017 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:08:05 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:08:12 <Akien> #chair ennael stormi marja
19:08:12 <Inigo_Montoya> Current chairs: Akien ennael marja stormi
19:08:37 * Akien bringing some parity in those council meetings :p
19:08:49 <marja> :-)
19:09:17 <Akien> #topic Mageia 6 RC: current status, TODOs
19:09:42 <Akien> wilcal, DavesNotHereMan: How are the current ISOs doing?
19:10:11 <Akien> #link http://madb.mageia.org/tools/blockers
19:10:17 <[mbot> [ Mageia App Db - Current Blockers ]
19:10:23 <wilcal> Running on the Plasma Live DVD as we speak :))
19:10:43 <wilcal> https://bugs.mageia.org/show_bug.cgi
19:10:44 <[mbot> [ Search by bug number ]
19:11:02 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=20368
19:11:04 <[mbot> [ 20368 Installing Mageia 6 in VirtualBox ends with display corruptions (when switching to vboxvideo drm device) ]
19:11:13 <wilcal> is still a problem
19:11:14 <schultz_> ping me if you need my opinion on anything, playing with shades of blue so might miss something
19:11:52 <wilcal> I think the rc isos are ready for wide release
19:12:06 <marja> schultz_: what is the status of https://bugs.mageia.org/show_bug.cgi?id=20647
19:12:08 <[mbot> [ 20647 Desktop selection shows old KDE logo instead of current Plasma one ]
19:12:13 <wilcal> we need final review of this things
19:12:21 <wilcal> likely one more go around
19:12:22 <Akien> marja: schultz_ is working on it right now :)
19:12:35 <marja> Akien: schultz_: ooops
19:12:47 <schultz_> marja: half fixed, just deciding on what logo to use, the plasma one looks, well, odd
19:13:00 <Akien> tmb: Do you have any idea about the vboxvideo/modesetting issues? (bug 20368, bug 20455)
19:13:02 <marja> schultz_: ok, thx
19:13:10 <Akien> Ah no [mbot here
19:13:10 <Akien> https://bugs.mageia.org/show_bug.cgi?id=20368
19:13:12 <[mbot> [ 20368 Installing Mageia 6 in VirtualBox ends with display corruptions (when switching to vboxvideo drm device) ]
19:13:14 <Akien> https://bugs.mageia.org/show_bug.cgi?id=20455
19:13:16 <[mbot> [ 20455 Vbox upgrade from 5 to 6 breaks due to changing driver from vboxvideo to modesetting but keeping nomodeset argument ]
19:14:19 <schultz_> marja: https://drive.google.com/file/d/0B35tx4Q9SNELVjRSczBOZzRuV2M/view?usp=sharing
19:14:20 <[mbot> [ desktop-KDE-big.png - Google Drive ]
19:14:28 <schultz_> doesn't look very kde like
19:14:56 <schultz_> https://drive.google.com/open?id=0B35tx4Q9SNELVjRSczBOZzRuV2M
19:14:57 <[mbot> [ desktop-KDE-big.png - Google Drive ]
19:15:13 <marja> how important is it for us to let upgrading work? it is impossible to add additional (online) media atm, even when installing instead of upgrading
19:15:23 <schultz_> Thats the new adverts for the install
19:15:34 <marja> schultz_: no, but then Plasma doesn't look like KDE, either ;-)
19:15:41 <schultz_> https://drive.google.com/open?id=0B35tx4Q9SNELSGt5Sm9uWHNPTkU
19:15:42 <[mbot> [ Ads and such – Google Drive ]
19:16:06 <wilcal> KDE -> Plasma upgrade does not do well for me :-(
19:16:26 <schultz_> Sorry, thats the link - Akien and myself thought the blue on the text didn't have enough contrast - the dark blue is in the test image
19:16:46 <schultz_> I'll shutup now, don't want to get in the way of upgrade talk
19:17:37 <Akien> Basically we have a pretty good RC, but still some blocking upgrade issues, so there's indeed the question of whether we want upgrades to work with the RC ISOs
19:17:48 <marja> schultz_: np, what you're saying is related to fixing  release blocker, too
19:18:22 <Akien> I'll ping all packagers and ask them to attempt some cli upgrades to fix the remaining package conflicts, as those are pretty bad during upgrades
19:18:28 <schultz_> Will have the other ads fixed so we can compare shortly
19:19:31 <Akien> If I manage to gather some momentum around fixing package conflicts, I guess we could get fixed ISOs in a couple days, and maybe have something release ready at the end of the weekend, WDYT?
19:20:11 <Akien> The bug that marja mentioned is pretty bad, but since we're discovering it pretty late and it will take time to debug it, I'd prefer not to have it prevent releasing the RC: https://bugs.mageia.org/show_bug.cgi?id=20484
19:20:13 <[mbot> [ 20484 The "Media Selection (Configure Supplemental Installation Media)" screen has gone missing (during installs & upgrades). ]
19:20:19 <marja> Yeah, it's time to release something
19:20:46 <wilcal> agreed
19:21:02 <tmb> yeah, to keep some momentum we need the RC out.. worst case scenario means a RC2 before final
19:21:03 <Akien> Worst case we can always make a RC2 shortly after RC to make sure upgrades work in all configurations - otherwise it will be done as part of the testing of the final ISOs
19:21:11 <Akien> +1
19:21:23 * marja thinks that in Mandriva times, her upgrades always ended in having to do a fresh install, so I'm in doubt about how much work we should put into enabling smooth upgrades
19:21:45 <Akien> #action Akien will build some momentum among devs to get upgrades tested to fix package conflicts. New ISOs can then be made around Thursday, hopefully RC release ready by Sunday
19:22:15 <wilcal> I've made it quite public that I am not a fan of upgrades. Especially KDE -> Plasma
19:22:45 <Akien> #info Apart from upgrades issues (package conflicts), vbox issues (mga#20368 and mga#20455) and missing media selection at install time (mga#20484), current RC ISOs are pretty good.
19:23:25 <wilcal> http://www.killdisk.com/ is your best friend
19:23:26 <[mbot> [ How to erase hard drive by Active@ KillDisk? Low Level Disk Format & Disk Sanitizer. ]
19:23:46 <lebarhon_> I did smooth updates KDE -> Plasma
19:23:46 <Akien> Yeah upgrades are tricky. I think it's good that we try to support them, as it forces us to fine tune our ISOs, but personally I prefer clean installs or net-upgrades.
19:24:21 <tmb> I'll try to take a look on the vbox issues... but so far I try to limit my work to ~1 day  week, so we'll see how it goes
19:25:10 <Akien> tmb: Thanks - don't do more than you can/should, but I'm sure Martin or Thierry could use some general advice and then continue the work themselves
19:25:24 <marja> tmb: we're happy with one day a week, it's good to have you back.... we don't want to see you disappear again
19:26:40 <tmb> marja, I'm "too big" to just disappear :)
19:26:46 <Akien> :D
19:26:50 <marja> tmb: lol
19:27:37 <Akien> Alright, let's move to the next topic. If we keep this meeting short I might have time to attempt fixing some package conflicts myself before sleeping :p
19:27:42 <Akien> #topic Blog posts
19:27:59 <Akien> First of all, thanks a lot to schultz_ for his awesome work on the weekly roundup
19:28:31 <Akien> I know how demanding it can be to write something every week, and I wish I'd have helped more the last 2-3 weeks, so great work :)
19:28:41 <schultz_> Thanks also to the people that put up with my writing habits and proofing stuff at 10 on a Friday :)
19:29:30 <tmb> yeah, it's nice to see the blog alive ... very good work :)
19:30:06 <wilcal> I'm impressed by the work the sysadmins did on the os upgrades
19:30:27 <wilcal> great job under pressure
19:30:44 <Akien> Currently in our upcoming posts (they all still need to be written), we have a post about plasma 5 integration, games in Mageia 6, Rust packaging, and a They Make Mageia about me
19:31:09 <Akien> Any new suggestions for stuff to add on our todo list? :)
19:31:53 <Akien> We should blog about the infra upgrade soon, but it would be nice to have the forums back online before that. Sysadmins are still working on it, there seems to be an issue setting up the forums database
19:32:22 <schultz_> What the sysadmins were doing before the mad push, what they had done, what they did, and what they will do
19:32:31 <schultz_> Think I got all my tenses in there :)
19:32:36 <Akien> schultz: I guess we can start a draft :)
19:33:15 <schultz_> Would be nice to have something in that blog about the hardware as well, need to give a scale about how big our infra is
19:34:20 <Akien> Yeah definitely.
19:35:14 <Akien> I'll ping Pharaoh_Atem again about the idea to make a new blog post regarding his work on DNF integration and related tools in Mageia 6
19:35:27 <Akien> The previous one was a big success :p
19:35:34 <schultz_> Sounds good, yeah was just about to say that
19:36:20 <Akien> I don't know if filip is around, he had another topic to discuss
19:36:42 <Akien> #topic Deprecating FTP protocol for mirrors?
19:36:54 <Akien> Quoting filip from the ML: "Many (most noted in FOSS
19:36:54 <Akien> community are kernel.org and Debian) discourage, deprecate or even
19:36:54 <Akien> stop using ftp protocol."
19:36:58 <Akien> "I would like to at least remove it from our main page as DL protocol
19:36:58 <Akien> if there is an alternative available like http and https. To me it
19:36:58 <Akien> seems like a council decision."
19:37:54 <Akien> I have no real opinion on this, I lack the context to understand why FTP usage should be discouraged or deprecated.
19:38:40 <Akien> Is it because it's not secure, contrarily to HTTPS?
19:38:47 <wilcal> i have a long term problem with using ftp on our repos
19:39:02 <wilcal> for me netinstall using ftp does not work
19:39:27 <tmb> well... debian and kernel.org did run their own ftp services, wich mean they can do what they want... we dont have own mirrors, only the mirror admins can control their decisions...
19:40:02 <wilcal> i've been using http netinstall a very long time
19:40:35 <tmb> but generally http(s) works better on load balancers, and is better designed for "packet loss" than ftp is...
19:41:56 <tmb> and since there is now a push for "https everywhere" ftp cant really compete unless you go for ftps, but that is another problematic thing :)...
19:42:16 <Akien> So maybe we could just tweak our mirrors layout to show "recommended URLs" and "alternative URLs" instead of just "URLs"? http://mirrors.mageia.org/mirrors/mirrors.ustc.edu.cn
19:42:27 <wilcal> I'm with him :-)
19:42:31 <Akien> e.g. list https and rsync as recommended, and http and ftp as alternative
19:43:13 <Akien> Just to help users pick the best choice if they have no clue
19:44:47 <Akien> Well we can discuss this further on the ML, filip seems afk so can't defend his case :p
19:44:56 <Akien> #topic Team elections
19:45:03 <Akien> Hm hm... :°)
19:45:23 <wilcal> QA is settled
19:45:43 <Akien> I'll try to start the topic on the dev@ ML this week. More than just asking for candidates, I think we should start a discussion on what kind of team leadership we need/want in the dev/packaging team(s)
19:47:07 <Akien> I'll ping sysadmins too
19:47:31 <Akien> Other teams are mostly settled AFAIK, we just need to check the council@ access have been updated
19:48:24 <Akien> #action Akien will restart the topic of team elections on dev@ and sysadmin@
19:48:54 <Akien> That's it on my side :) Do we have other topics you want to discuss?
19:48:56 <schultz> Atelier is settled too
19:49:02 <wilcal> not from me
19:49:18 <tmb> not from me
19:49:23 <marja> not here
19:49:26 <schultz> Can people tell me if these are readable for them
19:49:28 <schultz> https://drive.google.com/open?id=0B35tx4Q9SNELSGt5Sm9uWHNPTkU
19:49:29 <[mbot> [ Ads and such – Google Drive ]
19:49:45 <schultz> if not, I'll fiddle the blue more
19:50:10 <schultz> its mainly the difference between the images with test/no test
19:50:16 <Akien> schultz: the dark blue is too dark IMO
19:50:26 <Akien> schultz: something between that and the original light blue should be perfect
19:50:35 <Akien> (like, just in the middle)
19:50:37 <marja> schultz: a bit more contrast between the dark blue letters and the blue in the picture wold be good
19:50:52 <wilcal> look ok on this low performance laptop
19:51:25 <Akien> schultz: and I still think we should go with the KDE community logo instead of the Plasma logo, nobody knows the latter
19:51:29 <marja> schultz: in the darker pictures
19:51:44 <Akien> KDE4 users will already be confused by the name "Plasma", so best keep the logo they know :)
19:52:07 <schultz> Yeah me too with kde logo, just haven't got around to it yet
19:52:57 <schultz> Yep, will fettle the blue more, shouldn't be too much to get it readable
19:53:54 * tmb has to go to sleep now, bye all
19:54:02 <marja> tmb: sleep well
19:54:03 <Akien> Bye tmb, good night!
19:54:17 <Akien> Let's end the meeting now :)
19:54:22 <marja> +1
19:54:23 <Akien> 5
19:54:24 <Akien> 4
19:54:24 <wilcal> bye all
19:54:25 <Akien> 3
19:54:26 <Akien> 2
19:54:27 <Akien> 1
19:54:28 <marja> wilcal: night
19:54:29 <Akien> zero
19:54:31 <Akien> #endmeeting