19:07:26 <Akien> #startmeeting
19:07:26 <Inigo_Montoya`> Meeting started Tue Apr 25 19:07:26 2017 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:26 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:30 <Akien> #chair ennael stormi
19:07:30 <Inigo_Montoya`> Current chairs: Akien ennael stormi
19:07:59 <Akien> #topic Mageia 6 RC: status and plan
19:08:20 <Akien> So, I've been a bit out of the loop for the past two weeks, and I think that's the case for several others
19:08:25 <wilcal> Note: I am presently running on an old Dell laptop, no HD, M6, 32-bit, Xfce, LiveDVD from a DVD disc. So I may be a little unstable here but will return when I can.
19:08:43 <wilcal> runs quite nicely thank you
19:09:02 <Akien> Could we get a quick update on the Mageia 6 RC testing from QA? How old are the builds, and how do they behave?
19:09:04 <DavidWHodgins> Waiting for bug 20111 to be resolved, then new iso images generated for qa testing
19:09:08 <filip> wilcal: nice to read that
19:09:28 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=20111
19:09:30 <[mbot> [ 20111 partway through upgrade from Mga5 to Mga6 "Error: 'script' failed for glibc-6:2.22-21.mga6.i586...." ]
19:10:07 <DavidWHodgins> The current classic iso images are from April 7th, live from March 29th
19:11:10 <Akien> Ok, so we really need bug 20111 to get fixed asap
19:11:16 <Akien> I agree that it's a big blocker for RC
19:11:39 <DavidWHodgins> Yes. That's not only a blocker for rc, it's a blocker for a lot of other upgrade testing
19:11:39 <ennael> shall I build a first isos with all pending updates
19:11:55 <wilcal> hold a sec
19:11:56 <ennael> while the fix is done
19:12:39 <DavidWHodgins> That would be useful for new install tests, though not for upgrade tests
19:12:52 <ennael> as pre-test for now ?
19:13:05 <wilcal> can we get this fixed:
19:13:07 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=20368
19:13:09 <[mbot> [ 20368 Net installation of Mageia 6 sta2 finished with a very small and double screen. ]
19:13:24 <wilcal> the little green windows thing
19:13:42 <wilcal> it's only in Vbox
19:13:54 <wilcal> clients
19:14:46 <Akien> well it needs further debugging from people like tmb, tv and martinw, it's too low level for most of us
19:15:44 <Akien> tmb is not around much sadly, so he hasn't had the opportunity to look at it yet AFAIK
19:15:56 <ennael> we could ask pterjan
19:16:12 <wilcal> I can deal with it but others will not be able to
19:16:32 <wilcal> may end up as the last blocker
19:17:09 <Akien> If you reboot after that display corruption, does the install break, or does it happen once it's finished?
19:17:31 <wilcal> once your past it everything from then on is fine including reboots
19:17:47 <wilcal> and you don't see it again
19:18:25 <Akien> Ok. Still pretty bad for RC, but if it does not corrupt stuff and affects only VirtualBox VMs, we *could* release RC with a disclaimer if it was the last blocker
19:18:33 <Akien> But let's hope we can fix it before that :)
19:18:38 <wilcal> yup
19:18:46 <Akien> Any other big RC blocker?
19:19:42 <DavidWHodgins> I have to go back over some of the reports to confirm, but I don't recall any other major blockers off hand.
19:20:05 <wilcal> nothing that can't be fixed maybe even after release
19:20:26 <Akien> Ok. I'll go through all blockers and ping developers to get some momentum again, it's been calm lately :)
19:21:11 <Akien> The main focus should be on fixing that glibc upgrade issue. martinw mentioned a potential solution (forcing the use of dash.static) and Luigi12 recommended to convert the scripts to lua - would be nice to have tv's input on both suggestions
19:21:30 <wilcal> what's the "Java conundrum"?
19:21:37 <wilcal> does that effect M6
19:21:51 <wilcal> release
19:22:32 <filip> OT or not: thanks sysadmins for tag funtion in BZ and of course much bigger stuff latelly \o/
19:22:56 <Akien> Indeed :°)
19:22:58 <DavidWHodgins> wilcal: Just the regular pain figuring out how to test java apps
19:23:05 <Akien> Thanks for reminding me about what the next #topic should be about :p
19:23:31 <Akien> So for Mageia 6 RC, what our plan? I'll try to get some momentum again on the blockers, especially bug 20111 and bug 20368
19:23:46 <Akien> Do we want new ISOs now, while work is done on blockers, or do we want to wait?
19:24:04 <DavidWHodgins> May as well wait, in my opinion
19:24:19 <DavidWHodgins> Assuming of course that it's only a few days
19:24:23 <papoteur> Akien: infra status
19:24:26 <Akien> Let's hope :)
19:24:27 <papoteur> ?
19:24:29 <Akien> papoteur: yep
19:25:02 <Akien> #action Akien gets things in motion again on release blockers. QA needs bug 20111 fixed ASAP, then new ISOs can be made.
19:25:07 <wilcal> would like to see some new iso's foor this coming weekend
19:26:12 <Schultz> Hey everyone, sorry I'm late
19:26:23 <Akien> Let's see if we can get that RC released in the coming two weeks :)
19:26:44 <papoteur> Schultz: hi
19:26:46 <wilcal> Agreed
19:26:53 <Akien> Schultz: You're just in time to get a release blocker on your todo list: https://bugs.mageia.org/show_bug.cgi?id=20647
19:26:55 <[mbot> [ 20647 Desktop selection shows old KDE logo instead of current Plasma one ]
19:26:55 <filip> Akien: #info some blockers, especially bug 20111 and bug 20368
19:27:23 <Akien> #info Main blocker for RC (bad for upgrades): https://bugs.mageia.org/show_bug.cgi?id=20111
19:27:25 <[mbot> [ 20111 partway through upgrade from Mga5 to Mga6 "Error: 'script' failed for glibc-6:2.22-21.mga6.i586...." ]
19:27:43 <Akien> #info Other nasty one on net installs in vbox: https://bugs.mageia.org/show_bug.cgi?id=20368
19:27:46 <[mbot> [ 20368 Net installation of Mageia 6 sta2 finished with a very small and double screen. ]
19:27:48 <wilcal> Note: I do a net Vbox client install here every week or so and that has all gone very well lately. Except for the little green windows :-))
19:28:57 <Schultz> Akien: will sort out that image this week, should have time for it and teh plymouth changes, although they aren't anywhere near blocker status
19:30:02 <Akien> #topic Infra status
19:30:23 <Akien> A HUGE thankyou to neoclust, blino and pterjan for the impressive work they've done over the last weeks
19:30:37 <DavidWHodgins> +1
19:30:45 <papoteur> +1
19:30:46 <ennael> +1
19:30:50 <Schultz> Yeah really, its been impressive what they've done
19:30:51 <filip> +1 #info that
19:31:09 <Akien> As you remember from our last meeting (3 weeks ago?), we had to shutdown most services which were running on a vulnerable Mageia 1.
19:31:15 <Akien> #info A HUGE thankyou to neoclust, blino and pterjan for the impressive work they've done over the last weeks
19:31:24 <wilcal> Things are really working nicely
19:31:34 <ennael> maybe a blog post?
19:31:34 <Akien> Migrating them to Mageia 5 took a while, but it has been very well done, now it's almost finished
19:32:03 <wilcal> New Bugzilla, nice
19:32:19 <Akien> We should make a new blog post yeah, though there are still the forums which are offline, it would be nice to have everything fixed before we announce it
19:32:19 <Schultz> Is the forum back?
19:32:27 <papoteur> Are forum now  active?
19:32:32 <Akien> No and no :p
19:32:39 <papoteur> :)
19:33:13 <Schultz> It was said in one of the blogs about the down time that tehre would be a full post about everything that was done, why it took so long and the changes in the sysadmin team, so we should try and get that out soon
19:33:28 <wilcal> https://forums.mageia.org/en/  "unable to connect"
19:33:47 <Akien> The "changes" so far is that neoclust became a lot more familiar with the infra and puppet :D
19:34:10 <wilcal> that's a career builder :-))
19:34:15 <Akien> Hehe
19:35:09 <Schultz> Yep, its been impressive to follow what hes been working on
19:36:33 <Schultz> Is there an eta on the forum being back?
19:37:35 <filip> IIRC it'a priority now tht ML are back
19:37:56 <Schultz> Also, while we are on the topic of blogs, we need some more content there, anyone have ideas? Or want to finish their drafts ;)
19:37:58 <Akien> I need to check with neoclust, I don't know if work has started on the forum
19:38:21 <Akien> Ah, I could finish (start) my draft on games in mga6
19:38:24 <stormi> I saw maat saying somewhere on IRC that he would have been able to help if only he had access
19:38:39 <Akien> Then maat should be given access :)
19:38:48 <filip> indeed
19:39:19 <stormi> Well that's to be submitted to sysadmin team but why not
19:39:19 <filip> anyone knows what's with tmb
19:40:05 <marja> Akien: there was a forums related commit this morning http://gitweb.mageia.org/infrastructure/puppet/commit/?id=afe4ab9187356f6ed94fea29b85b6fbe2dc0d39f
19:40:06 <[mbot> [ puppet - Mageia Infrastructure Configuration ]
19:41:04 <DavidWHodgins> The dns for forums.mageia.org is still an alias for alamut
19:41:09 <marja> but I guess many more are needed
19:41:34 <Schultz> Akien: that would be perfect, something nice a far from infra issues
19:41:37 <marja> filip: not to my knowledge
19:42:07 <marja> ennael: do you have news about tmb?
19:42:16 <ennael> not for now
19:43:44 <Akien> We should pay a holiday to our sysadmins for Oktoberfest in Munich. There's no way we can pay them enough beer for all the work they do :p
19:43:59 <filip> +1
19:44:02 <marja> Akien: +1 :-)
19:44:08 <DavidWHodgins> +1
19:44:31 <Akien> (suddenly, sysadmin team gets 5 new candidates :p)
19:44:49 <ennael> :))
19:44:59 <Akien> Do we have another topic? Sorry, haven't prepared the meeting :D
19:45:02 <DavidWHodgins> Once this is done, we need better planning for upgrading to Mageia 6, with more hardware if needed
19:45:07 <Schultz> sounds like a good investment
19:45:10 <Akien> Yes
19:45:19 <Schultz> Elections
19:45:31 <Akien> I proposed to help maintain the critical packages for our infra even beyond the mga5 EOL
19:45:50 <Akien> So that we can plan the upgrades and perform them without stress
19:46:14 <Akien> It would not be a mga5 LTS, it would just be for the subset of packages we need to keep up to date
19:46:23 <Akien> So kernel, mediawiki, sympa, etc.
19:46:24 <DavidWHodgins> I really dislike that idea, as I expect it would eventually lead to the same problem down the road
19:46:26 <Schultz> Akien: very much so, and that planning should be in the blog to make sure that we show that this wont happen again
19:47:20 <Akien> Well it won't lead to the same problem if it's given the proper focus. The problem with that old mga1 is that there had never been an official effort to maintain it. There has been some work done by sysadmins initially, but not packagers committing to maintaining some packages.
19:47:29 <Akien> It's not particularly hard, and it's for 6 months, not 5 years.
19:48:04 <filip> Schultz: +1 we need to be open
19:48:05 <Akien> Of course if the upgrades can be done before the EOL, that's better :)
19:48:47 <Schultz> Could the infra run a tamed down Cauldron where the upgrades are cherry picked?
19:49:24 <stormi> You can't cherry-pick from cauldron without having in the end to download half of the distro
19:49:34 <stormi> I mean, not for more than a few weeks/months
19:50:21 <stormi> The thing is we don't have any other reasonable plan for now. Migrating everything to mga6 is not something that we can do before end of Mageia 5 EOL's
19:50:39 <DavidWHodgins> What about extending Mageia 5 support for a full 9 months after 6 is released, as originally planned?
19:50:57 <DavidWHodgins> That would require more packager help with security updates
19:51:28 <wilcal> How comfortable are we with M6?
19:51:33 <Schultz> Then in that case we need to find a way where there is a supported system for the infra that gives enough time to get it upgraded
19:51:49 <filip> we'll release this June anyway ;)
19:51:50 <wilcal> that would delay M7 wouldn't it David?
19:51:52 <stormi> Schultz: isn't it what Akien proposed?
19:52:08 <DavidWHodgins> wilcal: How?
19:52:42 <wilcal> 9mos more of M5 + M6 active and M7 in development seems quite a load
19:52:49 <Schultz> stormi: yes, pretty much, but I'm wondering if having the infra upgrades, or the prep for them at least, lead the release of the next version would give sufficient time with the current support period
19:53:43 <DavidWHodgins> wilcal: That's what we did with the earlier releases. We reduced support from 9 months after next release to 3, due to problems porting security updates for the older releases.
19:54:09 <Schultz> Does anyone know how other distros handle this? Some are on similar release cycles and support periods, so surely they have similar issues
19:54:33 <filip> DavidWHodgins: I don't recall that
19:56:04 <DavidWHodgins> http:/www.mageia.org/en/support - lifecycle
19:56:22 <DavidWHodgins> Plan was a release every 9 months with 18 months support
19:56:49 <DavidWHodgins> Late releases meant reducing the overlap from 9 months to 3
19:57:03 <wilcal> and we've gone how long with M5 now?
19:58:40 <wilcal> EOL M5.1 in Sept 2017?
19:58:59 <filip> got it. M5 was released in June 2015
20:00:09 <DavidWHodgins> And M5.1 was released in Dec 2016
20:00:32 <wilcal> so we're going on 22 months on M5 and 9 months on M5.1 in Sept
20:00:53 <wilcal> that's a lot of months
20:01:35 <DavidWHodgins> Yes. But clearly there's a problem with only supporting the prior release for 3 months after next release
20:01:58 <DavidWHodgins> If our sysadmins can't keep up, how can we expect the users of Mageia to keep up?
20:02:18 <wilcal> EOL M5.1 in Dec 2017
20:06:53 <DavidWHodgins> Let's all think about what we want (or rather need) for lifecycle support, and review it again next meeting
20:07:07 <Akien> Agreed.
20:07:08 <wilcal> agreed
20:07:18 <Akien> (sorry, mostly afk now, but I guess we can wrap this up)
20:07:55 * ennael falling asleep...
20:08:00 <Schultz> sounds good
20:08:13 <Schultz> or do we want to run down elections quickly?
20:08:25 <wilcal> I'm done and this little laptop is getting winded :-))
20:08:33 <ennael> :)
20:09:08 <DavidWHodgins> Let's leave it till next week.
20:09:14 <Schultz> Sounds good
20:10:00 <ennael> I will start build some isos on my side for very first tests
20:10:06 <wilcal> Hugs
20:10:06 <ennael> to check there is no regression
20:12:00 <DavidWHodgins> Time to end the meeting then?
20:12:35 <wilcal> Yes
20:12:45 <ennael> yep
20:12:53 <ennael> 5
20:12:56 <ennael> 4
20:12:58 <ennael> 3
20:13:00 <ennael> 2
20:13:02 <ennael> 1
20:13:08 <ennael> #endmeeting