20:10:56 <Akien> #startmeeting
20:10:56 <Inigo_Montoya`> Meeting started Tue Jan 24 20:10:56 2017 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:10:56 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:11:02 <Akien> #chair ennael stormi
20:11:02 <Inigo_Montoya`> Current chairs: Akien ennael stormi
20:11:14 <Akien> Hello everybody
20:11:36 <Remmy-> Hi :)
20:11:40 <Akien> I forgot to send an agenda for the meeting (or more like, I haven't thought about what it should be), but I guess we can start with the usual suspects
20:11:49 <Akien> #topic Mageia 6sta2
20:12:04 <Akien> We need to get this out :D
20:12:14 <wilcal> Yes
20:12:22 <wilcal> There are some issues with partitioning
20:12:32 <Akien> As I understand it we still have some partitioner issues, but it's become a bit unclear what was fixed and what wasn't/or was broken
20:12:41 <wilcal> some folks feel strongly that that should get first
20:12:46 <wilcal> fixed
20:12:50 <marja> manual partitioning is fixed
20:13:12 <marja> but letting DrakX do the parititioning still corrupts the parrtition table
20:13:22 <Akien> Yeah I believe we can't release until it's fixed, it's too bad to have partitioning issues when installing.
20:13:26 <marja> +1
20:13:29 <Akien> Can we decide autopartitioning and release? :D
20:13:32 <Akien> *disable
20:13:36 <marja> lol
20:13:59 <Akien> (I'm half serious :D)
20:14:01 <wilcal> Question. The problem will never surface if you are installing to a blank drive, right?
20:15:25 <Akien> No idea
20:15:29 <wilcal> or erasing the drive to start with
20:15:34 <papoteur> wilcal: for what I know, yes
20:15:38 <wilcal> I think that is the case
20:15:44 * marja is confused about whether patches are available or not https://bugs.mageia.org/show_bug.cgi?id=20074
20:15:46 <[mbot> [ Invalid Bug ID ]
20:15:53 <wilcal> IMO that should be the criteria for releasing test isos
20:15:57 <marja> bug 20074
20:16:21 <marja> [mbot: it's a valid bug number!
20:17:16 * ennael was reading the backlog of the bug
20:17:23 <ennael> would be great to have a sum up
20:17:27 <ennael> what is ok what is not
20:19:58 <marja> full manual partitioning is ok, but letting installer auto-allocate isn't, nor other ways of letting installer do the partitioning (like "use entire disk", Use free space on windows partition and Use empty space)
20:20:42 <Remmy-> Is the same bug present in 5.1?
20:21:23 <marja> Remmy-: I don't think so (even if I didn't really test 5.1) ... it would have bitten QA testers
20:21:33 <marja> if it existed
20:21:34 <Akien> I don't think so, though I'm not sure what triggered it now.
20:21:53 <Akien> But we're used to having critical issues in the partitioner at each release for some reason :D
20:22:33 <Remmy-> I always wonder when something that worked yesterday is broken today
20:22:45 <Akien> Well I guess the only way forward is to get martinw and tv to finish reviewing the patches they are discussing on bug 20074, right?
20:23:11 <marja> I think what created this, was adding support for legacy installs on GPT disks
20:23:22 <marja> Akien: yes
20:23:28 <papoteur> I hit a similar problem in the past, some years ago, with a corrupted partition table.
20:24:08 <Akien> But yeah it seems to be an old bug(s) made easier to trigger by new features
20:24:14 <marja> papoteur: yeah, the bug that a partition with the "Empty" type corrupts the partition table has been around forever
20:24:25 <marja> papoteur: it's only become very visible now
20:24:39 <papoteur> marja: Yes, I agree
20:25:31 <Akien> Is the bug now limited to this "Empty" stuff?
20:25:47 <Akien> Or are there still other bugs than bug 20074?
20:26:09 <marja> Akien: yes, but the trigger (installer creating an Empty partition) hasn't been fully fixed
20:26:34 <marja> Akien: it's only fixed for full manual partitioning
20:26:35 <Akien> Ok, so once this one is fixed, it should be good? /me knocks wood
20:27:01 <ennael> :)
20:27:27 <marja> Akien: yes, either installer no longer creating empty partitions, or bug 20074 getting fixed, is good
20:27:33 <marja> so two chances :-)
20:27:50 <Akien> Oh ok
20:27:56 <Akien> Sounds good.
20:28:06 <Akien> I think we agree that it's the only blocker for sta2?
20:28:46 <ennael> yep
20:28:47 <wilcal> i can agree with that
20:28:47 <marja> for me it's the only one.. other issues can wait for the following release
20:28:51 <Akien> So I'll ask martinw and tv for an update on their progress, mentioning that we need this one fixed in priority.
20:29:01 <marja> good
20:29:07 <Akien> Once its fixed, we'll have new ISOs for the QA team to test, and if they're good we release
20:29:47 <wilcal> yipeeee
20:29:55 <marja> :-)
20:30:12 <Akien> Then the next step would be the RC? I've seen some mentions of doing a sta3 to be sure, what are the opinions on this?
20:30:34 <stormi> RC
20:30:35 <wilcal> there are still some critical problems with some apps
20:30:39 <ennael> sta2 is rather in good shape
20:30:54 <Pharaoh_Atem> the only bugs I see these days are the ones that just don't let me partition to begin with
20:31:02 <wilcal> functionally it does run nicely
20:31:17 <Pharaoh_Atem> and that's only in a specific set of cases that are somewhat rare
20:31:21 <Akien> App issues can in theory be fixed by updates, so they would not be blocking at that stage (though crashes should still have a high priority and ideally be fixed before the release)
20:31:22 <ennael> oh notification on plasma
20:31:23 <wilcal> Plasma has polished up nicely
20:31:32 <Pharaoh_Atem> (GPT with non-UEFI)
20:31:40 <Pharaoh_Atem> Plasma has been solid for me, and GNOME has been good too
20:31:56 <Akien> ennael: Regarding the mga applets on Plasma, I think we now have a worst case workaround to make them functional
20:31:58 <marja> Pharaoh_Atem: that should work now :-(
20:32:10 <Akien> There's some env variable that forces them to use retro gtk feature and work apparently
20:32:30 <Akien> stormi: right? ^
20:32:38 <stormi> yes
20:32:51 <stormi> ugly but should work if really needed
20:33:09 <stormi> although it won't fix other gtk3 apps or java apps if we do it just for our applets
20:33:09 <Pharaoh_Atem> marja: haven't seen anything related to https://bugs.mageia.org/show_bug.cgi?id=19888 coming through...
20:33:11 <[mbot> [ Bug 19888 Autopartitioner doesn't account for required BIOS boot partition for GPT MBR disks ]
20:33:36 <ennael> stormi: any link on that one ?
20:34:01 <marja> Pharaoh_Atem: is that still valid with the current QA isos?
20:34:09 <Pharaoh_Atem> I have not tried yet
20:34:30 <stormi> ennael: https://bugs.mageia.org/show_bug.cgi?id=17592
20:34:32 <[mbot> [ Bug 17592 Un-clickable mgaapplet + net_applet + various other GTK apps' systray icons in Plasma ]
20:34:35 <Pharaoh_Atem> I'll need to grab the latest ISOs and give it another go
20:34:41 <marja> Pharaoh_Atem: thx
20:35:12 <Akien> Basically I think we can go for RC after sta2, but we need to put a very strong focus on all remaining blockers
20:35:16 <wilcal> renaming libreoffice desktop icons causes problems
20:35:33 <Akien> They should get activity daily if we want to release RC in a few weeks.
20:35:38 <marja> Akien: yes
20:36:12 <wilcal> https://bugs.mageia.org/show_bug.cgi?id=19449
20:36:14 <[mbot> [ Bug 19449 renaming LibreOffice Plasma desktop icons prevents launch ]
20:36:26 <ennael> it works indeed
20:36:38 * ennael has used GDK_CORE_DEVICE_EVENTS=1
20:36:38 <wilcal> works if you don't rename the icon
20:37:24 <Pharaoh_Atem> marja: downloading new classic ISO
20:37:32 <marja> ;-)
20:37:37 <wilcal> new ci's work nicely
20:38:52 <Akien> Ok, I guess there isn't much more to say about this topic?
20:39:21 <Akien> #action Akien asks martinw and tv about status on the diskdrake issues that prevent releasing sta2
20:39:32 <marja> On QA ml, someone suggested a blog post about the XFCE live
20:39:46 <Akien> #info We then go towards 6RC, we need a strong focus on blockers with daily input to get there
20:39:55 <Akien> #topic Blog posts
20:40:12 <Pharaoh_Atem> we need to talk more about stuff, I think that's quite obvious
20:40:20 <Akien> Definitely.
20:40:27 <Pharaoh_Atem> maybe talking about some of the new things we're getting in Mageia 6
20:40:34 <Pharaoh_Atem> to get people really interested in what we're doing
20:40:38 <Akien> We're already IMO too late to mention that we're doing a talk at FOSDEM, but we should still do it ASAP nevertheless IMO.
20:41:01 <ennael> indeed
20:41:02 <Akien> 10 days before is still better than not at all :)
20:41:10 <Pharaoh_Atem> in Fedora, we have the ChangeSet stuff, and Fedora Magazine turns around and talks up the most interesting user-facing ones
20:41:27 <Akien> I guess I can do some write up about the FOSDEM
20:41:28 <ennael> on my side I've started a technical article about high availibility with Mageia
20:41:35 <Pharaoh_Atem> my blog post about DNF for Mageia got very good coverage across the blogosphere
20:41:51 <papoteur> ennael: Oh, fine
20:41:53 <Akien> Do we confirm that we'll have an informal meeting during FOSDEM?
20:41:59 <marja> 3 x nice
20:42:21 <Remmy-> Now that we have no stand at fosdem, would there be any interest for a more Mageia-only type of event?
20:42:33 <marja> Akien: when it is sure we have a place to meet informally
20:43:21 <Akien> marja: Isn't that usually decided on Saturday morning?
20:43:34 <papoteur> Remmy-: it's very difficult. Magnux tried to have one in Paris, not sure he get success
20:43:57 <ennael> nope
20:44:02 <marja> Akien: that's the GA, I'm not sure we're allowed to have lunch in one of the rooms
20:44:10 <Pharaoh_Atem> We should consider doing online events
20:44:15 <Pharaoh_Atem> like what Ubuntu does with UOS
20:44:24 <ennael> well proposal was to have online GA
20:44:46 <ennael> about blog posts
20:44:51 <wilcal> on-line GA is IMO a good idea
20:44:52 <marja> ennael: yeah, but there was another proposal to have lunch together after the talk
20:45:02 <ennael> we could organize an interview with alcasar guys
20:45:28 <ennael> http://www.alcasar.net/en
20:45:29 <[mbot> [ ALCASAR - un portail captif authentifiant et sécurisé. ]
20:45:50 <ennael> the main distro for it is mageia
20:45:51 <marja> ennael: nice
20:45:53 <Akien> Just saying, for every topic we mention, we'd need someone (ideally from the participants of this meeting) to say "I'll take care of it and send a draft to atelier for publication"
20:46:08 <Akien> We've often listed good ideas, but you know the state of atelier... stuff just doesn't happen.
20:46:08 <ennael> and it's used in french gendarmerie
20:46:19 <marja> :-)
20:46:30 <Pharaoh_Atem> wow, didn't even know someone used Mageia commercially anymore
20:46:32 <ennael> I've seen it while I was working there
20:46:43 <ennael> Pharaoh_Atem: I have a client using it
20:46:52 <ennael> but he cannot mention it officially :/
20:46:57 <Pharaoh_Atem> :(
20:47:04 <Akien> #action Akien writes draft blog post about Mageia @ FOSDEM
20:47:06 <marja> Akien: sorry, can't promise anything, but if I do write something I'll send it to Atelier ml
20:47:15 <ennael> but it's based on high abailibility so I will try to give a conytext at least
20:48:18 <Akien> ennael: Can I action you to draft this blog post? :)
20:48:26 <ennael> yep
20:48:36 <Akien> #action ennael drafts a blog post about http://www.alcasar.net/en
20:48:37 <[mbot> [ ALCASAR - un portail captif authentifiant et sécurisé. ]
20:48:57 <Akien> stormi: Want to write "What's going on with Mageia 6?" :p
20:49:37 <Akien> (he's not talking, it's the right time to do some stealthy #actions :D)
20:50:08 <marja> :-)
20:50:11 <stormi> err
20:50:20 <stormi> I've got trouble writing my slides already
20:50:27 <Akien> :D
20:51:11 <Akien> Maybe we could get neoclust/daviddavid to write about the Plasma 5 packaging in Mageia 6?
20:51:36 <stormi> that would be nice
20:51:39 <ennael> would be great
20:52:05 <ennael> as I'm working with different dstro at the moment I must say Mageia's integration is maybe the best one
20:52:37 <papoteur> ennael: integration?
20:52:40 <marja> :-)
20:52:53 <wilcal> mandrak/mandriva/mageia legacy is a very good one for integration
20:53:04 <ennael> papoteur: packaging, final result, usability, design
20:53:38 <papoteur> ennael: OK. Nice :)
20:53:48 <Akien> #info Proposal: KDE maintainers could maybe propose a blog post about Plasma 5 in Mageia 6
20:54:17 <Akien> So yes marja mentioned someone proposing that we write a blog post about XFCE lives
20:54:56 <Akien> (BTW we can take the habit to post short posts often instead of very detailed ones rarely, so it's fine if we do short stuff)
20:55:28 <ennael> and maybe work with less people on it
20:55:31 <marja> that was Brian Rockwell's suggestion
20:55:38 <marja> Akien: yes, more short ones is better
20:56:13 <marja> ennael: yes, the review time is sometimes weeks... that's way too long
20:56:36 <ennael> so maybe 2 or 3 guys for one article
20:56:43 <ennael> it does not need to be perfect
20:56:51 <ennael> but provides information and communication
20:56:53 <marja> +1
20:57:59 <stormi> XFCE lives would be good material for the sta2 blog post too and that information would get more coverage
20:58:08 <wilcal> yes
20:58:11 <Akien> True
20:58:48 * papoteur agree
21:00:20 <marja> funny how we all talk about "XFCE Lives"... seems we just want the 64bit version, too ;-)
21:00:31 <Akien> I do want it :D
21:00:43 <wilcal> i only want the 32-bit version :-)
21:00:50 <Akien> I'd like keep a 64-bit XFCE Live as system rescue CD :)
21:00:54 <Akien> *likely
21:02:00 <Akien> Schultz has started a draft for the sta2 blog post, anyone wants to review it/improve some things? https://mypads.framapad.org/mypads/?/mypads/group/mageia-atelier-v7b2m7c1/pad/view/sta2-release-announcement-6t8mq75m
21:02:01 <[mbot> [ MyPads ]
21:03:07 <papoteur> Akien: You need to distribute some credentials if you want some comments ;)
21:03:29 <Akien> Well we've proposed them several times on the council ML, but only a few required them :)
21:04:57 <papoteur> sta2 seemed too hypotetical, perhaps, at this time ;)
21:05:06 <Akien> Well it was months ago :)
21:05:18 <Akien> Not about sta2 but about all pads we used in the last 6 months ;)
21:05:36 <Akien> But that explains why it's hard to get reviews... :p
21:06:44 <Akien> I bumped the email about it
21:07:33 <Pharaoh_Atem> well, if anaselli and I can agree on when to make a dnfdragora preview release, I might be able to contribute a small blog post introducing it as a preview in Mageia 6
21:07:44 <Akien> That would be great :)
21:08:08 <Akien> #action Pharaoh_Atem prepares a blog post about dnfdragora
21:08:32 <marja> :-)
21:09:06 <Pharaoh_Atem> but we have a *lot* of goodies in our upcoming release, we should have the various teams talk them up (ovitters with GNOME, neoclust with Plasma, someone about Xfce, etc.)
21:09:39 <Pharaoh_Atem> and even you, Akien, about some of the cool games and stuff
21:09:49 <Pharaoh_Atem> maybe even some of the updates or new things related to that
21:10:10 <Akien> I thought about that, but I guess posting about some random games when we haven't given sign of life in months might not be the most appropriate :p
21:10:13 <Pharaoh_Atem> it's not like there isn't stuff to talk about (our release notes might be spartan, but they do have a lot of items: https://wiki.mageia.org/en/Mageia_6_Release_Notes)
21:10:19 <Akien> Maybe after sta2 though
21:11:05 <Akien> There are some cool games and game-related applications new in mga6 that might be worth mentioning (Godot, Lugaru.. hey, all mine :p)
21:11:14 <marja> lol
21:11:28 <Pharaoh_Atem> Oi! Lugaru is partly mine too ;)
21:11:36 <marja> nice!
21:11:39 <Akien> #action Akien prepares a draft blog post about interesting game updates in mga6 (to be post _after_ sta2)
21:11:43 <Akien> #undo
21:11:43 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0xb6a3222c>
21:11:46 <Akien> #action Akien prepares a draft blog post about interesting game updates in mga6 (to be posted _after_ sta2)
21:12:20 <Akien> Yeah, we have a new game in mga6 developped 2/3rd on Mageia :D
21:12:25 <Pharaoh_Atem> I don't know if we can get anyone to talk about the plumbing stuff (virtualization, kernel, etc.), but these are things that attract people
21:13:22 <Pharaoh_Atem> and we do want to make people interested in what we do at that level, because it may attract more contributors on that front
21:13:52 <stormi> reminds be of all the blog posts we never posted about mageia 5 :)
21:14:09 <Pharaoh_Atem> well, it's easy to forget we exist when we don't say anything :)
21:14:18 <Pharaoh_Atem> we need to be loud and proud
21:14:39 <stormi> most of them didn't get written either
21:14:43 <Pharaoh_Atem> for example, if Mageia 6 goes out before May/June, we'll beat Fedora in offering DNF 2.0
21:14:46 <stormi> but mageia 6 is a different story
21:15:33 <marja> Pharaoh_Atem: I wasn't aware of that
21:15:38 <marja> stormi: that's right!
21:15:58 <marja> Pharaoh_Atem: nice
21:16:00 <Pharaoh_Atem> marja: yes, I imported DNF 2.0 because a lot of the fixes in there were specifically because of issues we encountered
21:16:12 <marja> :-)
21:16:47 <Pharaoh_Atem> and because PackageKit no longer supports libhif...
21:16:52 <Pharaoh_Atem> using libdnf now
21:17:33 <Pharaoh_Atem> but yeah, we're on the cutting edge in a lot of the cases that matter
21:17:36 <Pharaoh_Atem> and we need to talk about it
21:17:52 <Pharaoh_Atem> SVN does not make for a good story :)
21:18:37 <Akien> Definitely
21:19:02 <Akien> Sadly this needs someone in atelier committed to pushing those topics forward and making sure posts are written, reviewed and posted
21:19:09 <Akien> And so far that's been hard to get :/
21:19:33 <ennael> well we just need to have somebody for each post
21:19:35 <Pharaoh_Atem> I can write posts about DNF 2.0 and dnfdragora, but they have to have somewhere to go :)
21:20:13 <ennael> we should not be linked to atelier for blog. It depends mainly on free time to write posts
21:20:13 <marja> I think one person writing a post and one person reviewing it would work a lot faster
21:20:24 <Pharaoh_Atem> if tmb wasn't so taxed as it is, it'd be cool if he could write up something abou the kernel coming with Mageia 6
21:20:34 <Pharaoh_Atem> *about
21:21:52 <Akien> Any, we have some actions to handle, so we should be able to make some progress (like always I managed to give half the actions to myself, grrr  :p)
21:21:55 <Akien> Should we wrap this up?
21:22:09 <Pharaoh_Atem> and if we could poke him, get tv to write about virt stuff
21:22:10 <marja> yeah
21:22:13 <Pharaoh_Atem> :P
21:22:19 <marja> yeah Akien
21:22:26 <Pharaoh_Atem> indeed
21:23:00 <Akien> Alright, let's end the meeting and I'll get on my fosdem blog post
21:23:05 <Akien> #endmeeting