20:09:10 <Akien> #startmeeting
20:09:10 <Inigo_Montoya> Meeting started Tue Jan 17 20:09:10 2017 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:09:10 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:09:14 <Akien> #chair ennael stormi
20:09:14 <Inigo_Montoya> Current chairs: Akien ennael stormi
20:09:25 <Akien> Hello everybody :)
20:09:38 <DavidWHodgins> HiYa
20:09:44 * ennael thought we were monday...
20:09:47 <ennael> hi all
20:09:52 <Akien> :D
20:10:09 <Akien> #topic Mageia 6 sta2
20:10:30 <Akien> Looks like we have wilcal and DavidWHodgins there: what's the current state of the ISOs QA-wise?
20:10:33 <DavidWHodgins> We can't release sta2 till the partitioning bug is fixed, in my opinion
20:10:43 * marja agrees
20:10:45 <Akien> I agree, it sounds pretty bad.
20:10:49 <DavidWHodgins> All other bugs can wait till sta3
20:11:05 <stormi> can you tell us again what the bug is and who's likely to encounter it?
20:11:19 <Akien> #info http://madb.mageia.org/tools/blockers
20:11:31 <[mbot> [ Mageia App Db - Current Blockers ]
20:11:34 <DavidWHodgins> Creating new partitions can cause partition table corruption
20:11:41 <DavidWHodgins> bug 19935
20:11:46 <marja> https://bugs.mageia.org/show_bug.cgi?id=19935
20:11:50 <[mbot> [ Bug 19935 Custom disk partitioning requests BIOS boot partition on non-GPT disk ]
20:11:52 <wilcal> OK all the isos at this time for me are very usable
20:12:08 <stormi> in common situations or corner cases?
20:12:10 <Akien> (note that the bug was renamed to focus on one sub-bug, there are two other open bugs about this thematic)
20:12:18 <marja> this bug is fixed in the Live isos, but not in the CI
20:12:18 <DavidWHodgins> Common
20:12:26 <wilcal> just used the x86_64 Plasma boot.iso in a Vbox install this morning. All went well
20:12:54 <Akien> From what I read, martinw found a fix but only for the Custom partitioning, he says Auto partitioning would still bring the issue
20:13:37 <wilcal> there are issues some of them very serious
20:13:57 <marja> Akien: auto partitioning would needlesly create a BIOS Boot partitition, but as I understood it, not corrupt the partition table
20:14:02 <Akien> On the technical side there are several bugs, though on the user side it's pretty simple: the partitioning can brick the system. So I believe we should try to get martinw, pterjan and tv to discuss it (and ideally fix) asap.
20:14:11 <DavidWHodgins> Apparently a very old bug, but made more obvious by the problem with the bug about asking for a bios partition when one shouldn't be needed
20:14:20 <Akien> (pterjan since he seems to know the partitioning stuff well)
20:14:21 <marja> indeed
20:14:34 <marja> yeah, pterjan is our diskdrake man
20:14:49 <Akien> From what I could see, I also believe that once this issue(s) fixed, sta2 could be released
20:14:51 <ennael> juste asked. Let see if we can some of his time
20:14:59 <marja> ennael: thx
20:15:03 <DavidWHodgins> Akien: Agreed
20:15:11 <wilcal> yes, sta2 must get out there for a wider testing
20:15:25 <wilcal> even with the warts
20:15:27 <Akien> I guess if at least pterjan and martinw could discuss it live, it would go fast. tv might be harder to get for a meeting :p
20:16:07 <Akien> Otherwise, from what I could read on the ML I think the QA team is relatively happy with the current ISOs?
20:16:14 <wilcal> yes
20:16:14 <DavidWHodgins> Yes
20:16:21 <Akien> That's good :D
20:16:21 <DavidWHodgins> :-)
20:16:27 <wilcal> we are a team David
20:16:34 <DavidWHodgins> lol
20:16:35 <marja> and the XFCE iso is nice, too
20:16:59 <wilcal> Much discussion on the live media mix, how many or few
20:17:03 <Akien> BTW on the Mageia 6 topic, stormi had a phone call with tv yesterday, which was quite productive.
20:17:15 <marja> \o/
20:17:27 <wilcal> the 32-bit XFCE Live-DVD is very attractive
20:17:29 <Akien> Several blockers were fixed or better debugged, so there was some nice progress.
20:17:37 <marja> good
20:18:19 <Akien> Which shows that we need to innovate in our team communication - but that's a topic for another meeting maybe :)
20:18:32 <Akien> #topic Live ISOs set, proposals to discuss and vote on
20:18:59 <Akien> Some mentioned it already, martinw spinned XFCE ISOs as was proposed, and it seems they are nice :)
20:19:02 * ennael thought it was already done :)
20:19:25 <stormi> should be quick
20:19:29 <Akien> Well I think my proposal (Live 64 Plasma, Live 64 GNOME, Live 64 XFCE and Live 32 XFCE) was quite popular
20:19:30 <marja> ennael: we only agreed on asking martin, so far ;-)
20:19:30 <wilcal> IMO 64-bit Plasma & Gnome and 32-bit XFCE is a very nice compact set
20:19:40 <marja> Akien: yes, it was
20:19:44 <DavidWHodgins> I agree with replacing the gnome and kde i586 iso images with one xfce i586 iso. Having a x86_64 xfce iso is ok though I'd prefer to reduce the number of iso images if we can.
20:19:44 <marja> or is
20:20:09 <stormi> It would be hard to justify not having the 64 bit XFCE
20:20:14 <wilcal> IMO the Marketing idea of 3 Live ISO's is very attractive
20:20:32 <DavidWHodgins> ennael: The iso images have been created, but the council hasn't voted yet on the issue
20:20:33 <marja> DavidWHodgins: for marting,it's not really extra work
20:20:36 <stormi> Yes it shows Mageia is not a binary distro with just KDE and GNOME
20:20:45 <filip_> +1
20:21:05 <wilcal> this is one of those 1+1+1=5 Marketing deals
20:21:29 <wilcal> Don't put too much stuff in the box
20:21:40 <filip_> still we can atract XFCE crowd
20:21:52 <Akien> Personally I think a 64-bit XFCE ISO would be quite popular (there are many users with 64-bit who still want a light DE), but I understand if the QA team would prefer only 3 ISOs to test
20:22:08 <wilcal> yes you can always install with with boot.iso and CI
20:22:08 <filip_> there are mayn that run away from Gnome and KDE
20:22:34 <DavidWHodgins> Anyone against adding at least i586 xfce iso?
20:22:44 <papoteur> No
20:22:46 <wilcal> we don't have to make the final decision until later. Develop them all
20:22:52 <marja> I'm all for adding i586 XFCE
20:23:09 <wilcal> 100% support for 32-bit XFCE iso
20:23:10 <marja> (at least)
20:23:16 <DavidWHodgins> Then let's vote A or B. A=i586 only, B=both
20:23:27 <DavidWHodgins> I vote A
20:23:31 <wilcal> A for me
20:23:48 <Akien> I'd like B
20:23:54 <marja> 32bit will run on any 64bit system, right?
20:23:59 <DavidWHodgins> Yes
20:24:02 <wilcal> yes
20:24:05 <Akien> Yeah, but would force a 32-bit install
20:24:07 <marja> (just not use all memory)
20:24:12 <wilcal> there is some preference to do that too
20:24:54 <marja> We can start with A, and do B for sta3 when there's a lot of user demand after sta2 is released
20:25:06 * marja votes for A for now
20:25:07 <Akien> I guess we can say that the Council agree to drop the 32-bit Plasma and GNOME ISOs, and to add a 32-bit XFCE
20:25:19 <filip_> +1
20:25:20 <Akien> Regarding the 64-bit XFCE, I guess the decision should be in the hands of the QA team
20:25:27 <Akien> So maybe a topic for Thursday's meeting?
20:25:27 <stormi> I don't know
20:25:49 <DavidWHodgins> That should be a council decision, since it impacts more than just qa
20:25:57 <filip_> we had 4 lives till recently
20:26:09 <stormi> I don't think 64 bit and 32 bit isos are that different
20:26:23 <Akien> If one works, the other should work too. But that's still two tests to make.
20:26:35 <marja> DavidWHodgins: Martin Whitaker said it wasn't really extra work for him, to create a 64bit XFCE when a 32bit XFCE exists
20:26:37 <stormi> If we don't ship with 64 bit XFCE we're basically saying that it's only for low-end
20:26:45 <papoteur> I vote B
20:26:50 <DavidWHodgins> It's just that adding uefi doubled the number of install tests for each iso, so if we can reduce it, that would help
20:26:57 <Akien> Yeah that's what I wanted to avoid too, for me XFCE is not just for low end. It's a lightweight modern DE.
20:26:59 <stormi> B too if voting is the right thingto do
20:27:13 <filip_> +1
20:27:26 * marja hadn't taken UEFI into account, and changes her vote to B
20:27:57 <wilcal> Is there any other distro with an XFCE Live?
20:28:09 <marja> DavidWHodgins: however, if it's too much work for QA, then just refuse to test it as team
20:28:12 <DavidWHodgins> filip_: You're voting B (Both i586 and x86_64 xfce live iso images?
20:28:27 <filip_> marja: yes
20:29:12 <Akien> I'd say let's take the time to think, and for now let martinw produce 32-bit + 64-bit for sta2. We can decide on the final set later on.
20:29:17 <filip_> DavidWHodgins: sorry, I misread the author.
20:29:29 <Akien> At any rate we agreed about the general direction :)
20:29:37 <marja> :-)
20:29:54 <DavidWHodgins> If I'm counting right, that's a majority for both
20:30:13 <stormi> I think so, but it can be reviewed later if too much QA work
20:30:34 <papoteur> Both is the best, but if we can't, it's OK
20:30:40 <filip_> I guess trying QA and the public can gives us more info
20:30:40 <DavidWHodgins> 4 votes in favour, 3 against
20:31:14 <DavidWHodgins> We can do it, it's just it would have been nice to cut things down if ok with the majority
20:32:02 <DavidWHodgins> Adding gpt support also doubled the number of iso tests
20:32:12 <marja> :-/
20:32:37 <DavidWHodgins> For each iso we have uefi/bios x mbr/gpt
20:33:11 <DavidWHodgins> So four install tests for each iso, where we used to have one for each
20:33:20 <marja> DavidWHodgins: discuss it with QA team on Thursday... if it's too much work, the 3 Live isos is fine
20:33:22 <stormi> Does it have to be tested all in every ISO?
20:33:36 <filip_> IIRC in the past there was some discusion about some auatomation for QA. what was the result?
20:33:48 <marja> filip_: thx for asking that
20:34:06 <DavidWHodgins> We have had problems in the past, where one iso was missing some package that would cause it to fail in one mode, so each iso really should have all modes tested
20:34:08 <Akien> The install is the same for all lives, so I'd expect that one fully tested ISO should already give a good notion of what works and what doesn't. Though for the final final ISOs, I agree the full battery of tests should likely be done.
20:34:16 <stormi> indeed
20:34:36 <DavidWHodgins> Automated testing can end up being more work to maintain, than the testing it's replacing
20:34:56 <DavidWHodgins> Automated testing doesn't handle minor gui changes very well
20:35:18 <DavidWHodgins> It's fine for command line only testing but very difficult for gui
20:35:38 <filip_> can it handle any of UEFI, GPT combos?
20:36:27 <filip_> at least to check that partitions are still ok and install exits with OK?
20:36:28 <wilcal> back
20:36:29 <DavidWHodgins> As the partitioning is handled by diskdrake during installation, that has to be gui testing
20:37:15 <filip_> DavidWHodgins: thx
20:37:30 <Akien> So, to summarize:
20:37:33 <DavidWHodgins> For uefi, it's pretty much hardware dependent
20:37:51 <Akien> #info 32-bit Live ISOs for Plasma and GNOME are dropped. 32-bit XFCE ISO should replace them.
20:38:03 <Akien> #info 64-bit XFCE ISO should also be considered, final decision pending.
20:38:15 <DavidWHodgins> s /should/will/
20:38:23 <Akien> Yeah :)
20:38:31 <wilcal> sounds great
20:38:34 <marja> Akien: you can #undo
20:38:48 <Akien> I think it's understandable like that :)
20:38:54 <DavidWHodgins> Yeah. :-)
20:38:55 <marja> :-)
20:39:04 <Akien> Next topic?
20:39:09 <marja> ok
20:39:15 <DavidWHodgins> That's infra
20:39:17 <Akien> #topic Infra: current state and priorities (esp. wiki)
20:39:41 <Akien> IINM neoclust removed the lock on the wiki today, so it's no longer read only
20:39:52 <marja> correct
20:40:10 <Akien> Still, its upgrade should really be made a top priority for the remaining sysadmin forces that we have
20:40:25 <Akien> It's been pending for many years
20:40:41 <marja> indeed
20:40:49 <Akien> So on top of preventing a better workflow for docteam and i18n, it is filled with security vulnerabilities
20:40:59 <Akien> (which may explain some of the spam we're getting?)
20:41:52 <Akien> IINM we have contributors who can help with the config update, but we still need sysadmins to pull the switch
20:42:22 <DavidWHodgins> With an option to fall back, if things don't go well
20:42:31 <marja> well, I haven't heard from our most recent wiki-upgrade volunteer
20:42:47 <marja> and diogenese is too ill to help
20:42:48 <Akien> neoclust is quite busy with bugfixing, pterjan is needed for some drakx fixes, tmb probably doesn't need more pressure... who's left? :)
20:43:59 * marja is afraid she already put too much pressure on our volunteer
20:44:05 <filip_> wasn't Pharaoh_Atem a volunter for sysadmin work in the past?
20:44:42 <marja> Pharaoh_Atem: were you?
20:44:42 <filip_> he seems to know stuff well
20:46:11 <marja> it'll be easier when tmb created a vm for the wiki that someone can have full access to, without automatically having full access to all of mageia.org
20:46:13 <Akien> I guess the wiki upgrade will have to wait a bit more, even if we want to make it a priority I really don't see whom to hand it to in this release hell :/
20:46:59 <marja> Akien: tmb said he want to work on infra coming weekend, but I don't know whether that includes a separate VM for the wiki
20:47:06 <Akien> It should likely stay a recurring topic on our agenda so that as soon as there is aan opportunity we should ensure it's taken :D
20:47:14 <marja> +1
20:47:17 <stormi> like bugzilla upgrade
20:47:25 <Akien> Indeed.
20:47:48 <Akien> Let's keep in mind that those two points need to be briefly reviewed at each meeting then, like QA's Who's new :p
20:48:22 <marja> stormi: LpSolit prepared it long ago.... is that also waiting for a separate VM (outside puppet controlled parts of Mageia)
20:48:24 <Akien> #action Opportunities (in sysadmin disponibility) for upgrading the wiki and bugzilla should be reviewed at each meeting until we can get them actually upgraded
20:48:25 <marja> ?
20:49:11 <marja> What happened to danf?
20:49:38 <marja> he was getting mentored to become a full Mageia sysadming, wasn't he?
20:49:51 <marja> s/ing/in/
20:49:52 <filip_> I don't see him much around but I'm seen less two ;)
20:49:57 <wilcal_> nick wilcal
20:50:11 <wilcal_> #nick wilcal
20:50:29 <marja> wilcal_: "/ wilcal"
20:50:34 <marja> without ""
20:50:39 <marja> oops
20:50:47 <marja> wilcal_: "/nick wilcal"
20:51:03 <wilcal> Ahhhh thanks
20:51:04 <Akien> He's still active on the sysadmin ML once a month or so, but I think that since no sysadmin is there to review his changes and finally give him more access, he can't do much
20:51:07 <marja> yw
20:51:51 <marja> Akien: did pterjan forget (assuming he was the mentor), or is he just way too busy?
20:52:28 <Akien> I guess too busy
20:52:41 <marja> he's not on IRC now
20:53:46 <Akien> Next topic I guess?
20:54:01 <DavidWHodgins> fosdem
20:54:01 <marja> there's nothing we can do against lack of time :-(
20:54:02 <Akien> #topic FOSDEM: official communication needed
20:54:09 <Akien> ennael, stormi:
20:54:30 <Akien> So this year we don't have a FOSDEM stand, so it's a bit awkward to invite the community to come to FOSDEM to see us
20:54:40 <Akien> Still, ennael and stormi will be giving a talk about Mageia, so that's one thing
20:54:45 <marja> but we can invite them to the talk https://fosdem.org/2017/schedule/event/mageia_successes_and_lessons/
20:54:47 <[mbot> [ FOSDEM 2017 - Mageia, successes and lessons learned 6 years after forking ]
20:54:55 <Akien> And various Mageians are still going to FOSDEM, so I think we should communicate about it on the blog asap
20:55:09 <marja> yes
20:55:22 <filip_> +1
20:55:23 <Akien> Maybe plan a community meeting/beer-drinking at some time?
20:55:36 <DavidWHodgins> When is FOSDEM?
20:55:42 <Akien> It's on Feb 4-5
20:55:54 <Akien> So in 2½ weeks
20:56:10 <DavidWHodgins> So that means we should plan for team elections in mid February too then.
20:56:32 <marja> yeah
20:56:54 <marja> Baud started a wiki page, it needs further updating https://wiki.mageia.org/en/Fosdem_2017
20:57:03 <ennael> humpf back
20:57:09 <ennael> sorry connection hickup
20:57:11 <marja> ennael: wb
20:59:14 <Akien> So what should we propose to the community?
20:59:45 <Akien> Meetup at 13:00 on Saturday to eat our sandwiches, drink beer and chat? :)
20:59:58 <ennael> maybe have the room at least to speak on some various topic
21:00:05 <Akien> Yes, sounds good.
21:00:09 <Akien> IRL meetings are great :)
21:00:13 <ennael> yep
21:00:15 <marja> DavidWHodgins: last  meeting, ennael suggested to have the GA online with an audio meeting
21:00:36 <ennael> and I have to propose some dates
21:00:44 <marja> so sandwiches and beer right after ennael's and stormi's talk, nice :-)
21:00:45 <DavidWHodgins> Yes, read the log. That's fine with me
21:00:48 <ennael> I will do it here for the council and then we choose
21:01:07 <ennael> marja: will it will depend on the time we can have a room
21:01:18 <marja> ennael: yeah
21:01:52 <ennael> oups s/^will/well/
21:02:02 <marja> :-)
21:02:49 <ennael> we do have another phone call tomorrow with stormi and Akien to work on this presentation
21:03:43 <marja> ennael: isn't Akien getting a German accent, yet (to more easily know he's he and not his brother)?
21:03:56 <DavidWHodgins> lol
21:04:17 <marja> DavidWHodgins: ennael couldn't tell them apart during the first test meeting
21:04:41 <DavidWHodgins> Which software is being used for the meeting?
21:04:46 <ennael> and they are playing with that
21:04:47 <marja> DavidWHodgins: mumble
21:04:56 <marja> ennael: :-)
21:05:05 <ennael> DavidWHodgins: mumble a bit like grumbl
21:05:23 <DavidWHodgins> :-)
21:05:51 <DavidWHodgins> Audio only, or video too?
21:05:55 <stormi> audio only
21:06:01 <marja> DavidWHodgins: audio
21:06:13 <DavidWHodgins> Good. I don't have to worry about cleaning up this room. :-)
21:06:18 <marja> lol
21:06:26 <wilcal> which delivery service?
21:06:26 * ennael will not have to hide bottles
21:06:34 <marja> :-)
21:07:09 <marja> stormi: did you upgrade to Mga5, yet, or aren't you going to run the server?
21:07:32 <marja> s/yet/already/
21:08:26 <stormi> Confidential information
21:08:32 <marja> otoh, GAs are public, so why care?
21:12:42 <wilcal> are we still here?
21:12:48 <marja> yeah
21:12:48 <DavidWHodgins> I am
21:13:00 * filip_ 2
21:13:06 <ennael> yep
21:13:32 <marja> and receiving spam during a meeting isn't great, so caring about security during our online sound meeting is ok
21:14:32 <stormi> risk low
21:14:58 <marja> so for Fosdem, we need to communicate about the talk, about the maybe-lunch together..... dinner too?
21:15:19 <marja> and probably about the GA being done online
21:15:32 <filip_> sound nice. but currently out of my budget :(
21:16:07 <marja> ennael: is there budget to invite & pay for filip_ ?
21:16:23 <ennael> yep of course
21:16:36 <marja> filip_: ^^^^ :-)
21:17:11 <marja> filip_: it would be great if we could meet you
21:17:24 <filip_> ennael: that sounds nice but is this budget more valuable in HW?
21:17:54 <ennael> we can do both
21:18:46 <filip_> I can take a look on plain tickets but need some time to plan. this a total surprise for me
21:18:58 <marja> :-)
21:22:31 <marja> did we all fall asleep now?
21:22:55 <DavidWHodgins> Trying to figure out how to avoid feedback in mumble. :-)
21:23:14 <DavidWHodgins> echo cancelation doesn't seem to be enough
21:23:22 <marja> DavidWHodgins: I keep forgetting to buy a headset, so haven't tried it, yet
21:23:42 <DavidWHodgins> I've got one somewhere. Will have to find it
21:24:24 <marja> ennael: Akien: stormi: are we done with the meeting?
21:25:00 <wilcal> I'm done
21:25:02 <DavidWHodgins> Nothing else here
21:25:06 <filip_> should I mail on council with aproximate cost?
21:25:29 <DavidWHodgins> Sure. As long as it's reasonable, I'm ok with it
21:25:38 <marja> filip_: mailing ennael is enough (and ping her when she doesn't see your mail)
21:25:40 <filip_> it's in the order of 200€
21:25:54 <DavidWHodgins> That's reasonable to me.
21:26:13 <ennael> indeed
21:26:22 <marja> filip_: that's fine.... you'll need a hotel, too... some of us are in hotel Villa Royale
21:26:46 <filip_> marja: what's the cost there?
21:26:59 <marja> filip_: € 120 for two nights
21:27:16 <marja> filip_: breakfast included
21:27:32 <marja> filip_: if you book using stormi's method
21:27:35 <filip_> I'll probably cut to one only
21:27:43 <Akien> sorry semi-afk, but yes I'm done
21:28:02 <ennael> done also
21:28:07 <ennael> was submitting some updates
21:28:07 <marja> (I think stormi's booking site is cheaper than booking.com)
21:29:36 <marja> filip_: he used booked.net
21:30:11 <filip_> marja: I apreciate your offer and info very much!
21:30:13 <stormi> I think it's not possible
21:30:16 <stormi> that it's cheaper
21:31:07 <stormi> because it's booking's contract
21:31:13 <marja> stormi: in that case, the prices went down
21:31:35 <marja> stormi: since last year
21:31:47 <stormi> end of meeting then?
21:31:54 <wilcal> sounds good to me
21:31:55 <marja> yep
21:32:00 <ennael> yep
21:34:37 <DavidWHodgins> Someone #endmeeting then. :-)
21:35:09 <marja> stormi: ennael: Akien: ^^^^
21:35:17 <Akien> #endmeeting