20:11:28 <ennael> #startmeeting
20:11:28 <Inigo_Montoya> Meeting started Tue Nov 29 20:11:28 2016 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:11:28 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:12:10 <ennael> #chair Akien
20:12:10 <Inigo_Montoya> Current chairs: Akien ennael
20:12:16 <ennael> let start then
20:12:24 <ennael> #topic Mageia 5.1
20:12:25 <papoteur> :)
20:13:01 <ennael> ok so isos have been validated if I'm not wrong
20:13:18 <wilcal> I'm fine with it all
20:13:48 <stormi> great
20:14:10 <Akien> Nice work to QA and the ISO builders :)
20:14:42 <ennael> what about communication aprt ?
20:14:43 <ennael> part
20:15:06 <Akien> I'll check the pads
20:15:08 <stormi> Donald had started a draft IIRC
20:15:38 <Akien> Yeah, there's a draft here but it's just a few lines for now: https://mypads.framapad.org/mypads/?/mypads/group/mageia-atelier-v7b2m7c1/pad/view/mageia-5-1-release-announcement-79vk970y
20:15:40 <[mbot> [ MyPads ]
20:15:52 <Akien> But if we're about to release, Atelier will get onto it seriously :)
20:15:57 <stormi> true
20:16:23 <Akien> Do we want to do some extended internal testing of the release ISOs before we publish them?
20:16:56 <wilcal> We could test it all forever and find faults. We need to move back to M6
20:17:02 <filip> hi there. I can try to do the web part in a few days.
20:17:04 <ennael> I agree
20:17:25 <ennael> should be published within 2 days
20:17:37 <wilcal> I've kinda moved on to M6. All my recent Vbox testing has been on an M6 platform
20:17:51 <Akien> Well by internal testing I mean going from 10 QA testers to 100 from the community. But if you think it's safe hardware-wise, we can publish.
20:18:04 <Akien> *extended community
20:18:08 <wilcal> that'll give us one more QA meeting on Thursday
20:18:22 <wilcal> I'll push hard for a conclusion there
20:18:49 <Akien> But ok, let's publish asap then. I'll see with Schultz for the blog.
20:20:14 <Akien> #action Atelier to prepare M5.1 release announcement + website, aiming for a release in ~2 days
20:20:57 <ennael> we need also to sign and push isos
20:21:14 <ennael> we can ask neoclust for it
20:22:15 <filip> isos needs at least 12 hours to propagate. and we also need torrents
20:24:42 <Akien> So let's aim for propagating the ISOs on Thursday evening then, and we publish the release announcement on Friday morning?
20:25:10 <filip> I guess blog post goes after web page
20:25:35 <wilcal> sounds like a plan
20:25:44 <ennael> I'm trying to reach neoclust
20:26:01 <Akien> Yeah
20:27:04 <ennael> anything else ?
20:27:21 <wilcal> Lets move on to M6
20:27:58 <ennael> #topic Mageia 6
20:28:34 <wilcal> I continue to find bugs but it's very usable in its present state
20:28:37 <Akien> There have been some weird bugs recently with Xorg, but it seems to be settling down for some users
20:28:51 <Akien> stormi, did you manage to get to a working X11 finally?
20:29:09 <wilcal> Just found that wine seems mostly unusable but I think it's a graphic x11 thing
20:30:08 <ennael> on isos side I was asked by QA to postpone new set of isos for now
20:30:16 <ennael> so that QA can focus on updates
20:30:22 <ennael> is it still the case ?
20:31:25 <stormi> Akien: no, not for now, I mean not without logging to console before
20:31:40 <stormi> But someone said it may be a symptom of the same prefdm bug
20:32:31 <Akien> I think it would be nice to have a set of ISOs, if not for regular QA testers, at least for devs to take the temperature of the cauldron
20:32:53 <wilcal> it's been a very long time since M6 isos
20:33:11 <Akien> If QA needs to focus on updates for a while, that's fine, but packagers should start testing ISOs too and see what they can debug/fix.
20:33:47 <ennael> well we cannot give access to all packagers on rabbit
20:35:04 <Akien> all *active* packagers, of course we can :)
20:35:11 <Akien> They just have to put themselves in the ISO testers list
20:35:39 <ennael> I mean too many people
20:35:53 <ennael> we cannot afford it due to needed bandwicth
20:35:59 <ennael> bandwidth
20:36:08 <Akien> Well, I can count at most 15 active packagers.
20:36:08 <ennael> it's hosted by IELO
20:36:20 <Akien> Out of which maybe 5 will take the time to test ISOs.
20:36:24 <Akien> That should be doable no?
20:36:26 <papoteur> have we to put ISOs on some other server?
20:37:28 <Akien> What I mean is that pre-release ISOs should not be just for QA. QA's job is to test ISOs to ensure they are release ready, not to hit the wall all the time due to packaging and dev bugs exposed by the ISOs.
20:37:30 <papoteur> MLO has some place, perhaps can we ask to Adrien.
20:37:36 <Akien> So packagers should also be testing ISOs, especially now.
20:38:08 <ennael> I understand but we cannot take any risk on IELO
20:38:24 <ennael> why not uploading isos on public mirrors in dev directory ?
20:38:26 <Akien> I don't get it. Should developers remove themselves from the ISO testers list?
20:38:41 <ennael> I mean do not increase it
20:38:51 <ennael> we have free hosting there
20:38:52 <Akien> Are we already at the limit?
20:39:20 <ennael> I've always seens something like 10 access
20:39:54 <stormi> well since QA is busy doing something else that leaves 10 accesses for packagers, doesn't it?
20:40:05 <Akien> I'd be fine with having ISOs mirrored in a public mirror if marked as WIP
20:40:11 <stormi> me too
20:40:21 <Akien> In the past I think there were reticences to doing that, but personally I think it's not an issue.
20:40:34 <Akien> If some lurker makes a review based on a dev ISO, that's their problem, not ours :p
20:40:50 <ennael> add an index.html or some kind of README to explain again what it is about
20:40:53 <ennael> should be enough
20:40:56 <Akien> Good idea.
20:41:08 <Akien> What server do we have that could rsync from rabbit?
20:41:20 <Akien> stormi, marja: would one of yours do the job?
20:41:40 <ennael> have to check if it can be done fromt rabbit to distrib-coffee
20:41:50 <Akien> Alternatively we could ask baud for some disk space on TuxFamily
20:42:07 <Akien> This kind of bandwidth would not be an issue for them.
20:42:23 <stormi> I have 125G free
20:42:29 <ennael> ok we are syncing local repo from rsync.mageia.org
20:42:32 <stormi> I don't know what bandwith I'm allowed to use
20:42:36 <ennael> which is the primary one
20:45:14 <Akien> The problem with putting ISOs on distrib-coffee is that mirrors syncing from it might mirror them
20:45:21 <Akien> What we don't really want
20:46:18 <Akien> How big is the distribution for all ISOs?
20:46:25 <Akien> 20 GB?
20:46:51 <Pharaoh_Atem> do we not have some kind of alt location or something?
20:47:05 <Pharaoh_Atem> for example, Fedora has alt.fedoraproject.org with a staging subdir for these things
20:47:10 <ennael> 5.1 is 14 G
20:48:36 <Akien> I'll ask baud if we can get some 20 G of repository on tuxfamily (could register mageia.tuxfamily.org for that)
20:49:09 <papoteur> Akien: Ok.
20:49:27 <Akien> The bandwidth is quite good in my experience, and baud has already told me it was no problem (when I wondered about Godot's important traffic)
20:49:49 <stormi> If needed I think my server would be able to serve the ISOs to the few who need them, just tell me if the other plans fail
20:50:07 <stormi> I think I've got a decent bandwidth
20:50:12 <Akien> Alright, let's try that then.
20:50:26 <Pharaoh_Atem> I may be able to do some hosting as well
20:50:28 <Akien> #action Akien sees with TuxFamily guys if we can use their hosting for our dev ISOs.
20:50:48 <Akien> #info Fallback plan for ISOs hosting would be stormi's or Pharaoh_Atem's servers.
20:53:28 <papoteur> OK. That's all ?
20:53:37 <Akien> #action Once the hosting is setup, we should have a new set of 6 sta2 ISOs for testing.
20:54:08 <Akien> I think we can move to the next topic yeah.
20:54:18 <Akien> #topic FOSDEM
20:54:18 <ennael> which is ?
20:54:25 <stormi> I'd like to hear from tmb and tv soon about the recent Xorg issues some including me have had
20:54:25 <ennael> ah
20:54:44 <papoteur> it's no more a topic, isn't it?
20:54:53 <Akien> Well that's the topic.
20:54:54 <Akien> :)
20:55:07 <wilcal> Many of you saw what I think about it
20:55:18 <Akien> As you've seen on the ML, we were refused a stand for FOSDEM.
20:55:19 <wilcal> I was being American :-))
20:55:38 <Akien> I've had a quick look and indeed various projects had the same fate, e.g. OpenMandriva or Enlightenment
20:55:49 <wilcal> That's really not acceptable for such an event
20:55:56 <Akien> That's not the topic..
20:56:39 <Akien> So, apart from telling the FOSDEM guys to try to get more space from the ULB next year, what do we want to do?
20:56:50 <ennael> I'd like us not being hard
20:56:59 <Akien> Yes.
20:57:00 <ennael> FOSDEM is a great event organized by volunteers
20:57:09 <ennael> only volunteers
20:57:16 <ennael> and fo technical topics only
20:57:31 <ennael> it has never been a companies show
20:57:39 <wilcal> is their a similar event in Europe
20:57:47 <ennael> no it's unique
20:58:06 <ennael> except very focused events on specific topics
20:58:19 <wilcal> regional shows but nothing European wide
20:58:24 <ennael> I'm not event sure there is such event in the rest of the world
20:58:37 <wilcal> sounds like an opportunity for someone to me
20:58:43 <ennael> not regional, but focused on a dev language
20:58:46 <ennael> or kernel
20:58:49 <ennael> or cloud
20:58:49 <wilcal> SCALE is similar
20:58:50 <ennael> ...
20:59:01 <Akien> Anyway... my point was not for us to rethink what events should be made and should not be made..
20:59:21 <Akien> wilcal, you have great ideas as someone with lots of experience in this field, but for us now it's offtopic.
20:59:33 <Akien> My point was: what do we do for FOSDEM on Mageia's side?
20:59:38 <papoteur> yes. We planned to have General Assembly there. What to do?
20:59:39 <Akien> Personally I will still be there.
20:59:48 <ennael> I will be there also
20:59:54 <Akien> Do we want to have an official Mageia presence nevertheless and invite people to meet us?
20:59:58 <ennael> and there is a git meeting the day before :p
21:00:32 <ennael> we should not remove t from the mageia events list
21:00:44 <ennael> we could not achieve this year well ok let see next year
21:01:08 <wilcal> will there be a better chance for us to participate in FOSDEM 2018?
21:01:19 <ennael> I'm not in organizers head :)
21:01:42 <ennael> let's make some noise in 2017 then we will have better chance for 2018
21:01:51 <Akien> Yeah
21:01:52 <grenoya> have proposed a talk in distribution room ?
21:01:59 <Akien> grenoya: +1
21:02:08 <ennael> nope and talks are closed I think
21:02:09 <Akien> That would be great to give Mageia some visibility.
21:02:22 <Akien> Nope, no talks have been announced yet.
21:02:31 <Akien> The distribution devroom still accepts paper until Dec 5
21:02:55 <Akien> And lightning talks were closed last week, but I think one can still submit them (two weeks ago they still accepted main talks, that should have been closed end of October...)
21:03:14 <Akien> So if someone from the community has an idea, that's definitely worth submitting.
21:03:50 <Akien> Actually submission deadline is Dec 2 for the distro devroom: https://lists.fosdem.org/pipermail/fosdem/2016-November/002501.html
21:03:51 <[mbot> [ [FOSDEM] FOSDEM 2017 - Distributions Devroom EXTENDED DEADLINE ]
21:04:08 <Akien> So Friday
21:04:33 <Akien> Question is, do we have something we want to talk about? :)
21:04:45 <grenoya> having a talk could help having a booth next yeah
21:04:47 <ennael> oh it's longer than planned initially
21:06:13 <ennael> FOSDEM killed them all :p
21:06:26 <Akien> We're all waiting on your awesome talk idea :D
21:06:40 <ennael> gnagnagna :)
21:07:09 <ennael> could be something like 6years after forking a distro and recreating a community
21:07:14 <ennael> kind of review of mistakes
21:07:19 <ennael> and what worked well
21:07:28 <filip> great idea
21:07:36 <grenoya> sounds good :)
21:07:58 <Akien> Yes, that would also answer many questions some might have about Mageia's current whereabouts
21:08:04 <Akien> (including within the community :D)
21:09:10 <Akien> We could quickly outline some ideas for the submission, and then spend some time to actually think about it and prepare it together, as a kind of 5 Years After postmortem review :)
21:09:46 <ennael> also I will try to convince rtp to have one there as he has been working on a build system project
21:09:50 <grenoya> 6years :p
21:09:52 <ennael> for both rpm and deb
21:09:53 <papoteur> SHould be submission be a finalized paper?
21:10:10 <Akien> papoteur: Nope, just a description of what we want to talk about
21:10:10 <ennael> including mageia. I'd like him also to propose it to Mageia
21:11:00 <Pharaoh_Atem> Akien: well, there's also the thing about our collaboration with the community
21:11:10 <Akien> Haha https://archive.fosdem.org/2016/schedule/event/illumos_overview/
21:11:11 <[mbot> [ FOSDEM 2016 - illumos at 5 ]
21:11:15 <Akien> And illumos got a stand this year :p
21:11:19 <Pharaoh_Atem> bah
21:11:20 <papoteur> ennael: interesting ;)
21:11:30 <Akien> Same idea as we just had hehe
21:12:07 <Akien> papoteur: The above link is what is expected of us to fill in the "call for papers"
21:12:17 <Akien> So it's quite short actually
21:12:32 <Pharaoh_Atem> ennael: a buildsystem project?
21:14:13 <ennael> Akien: can we work on this proposal ?
21:14:47 <Akien> ennael: yeah
21:15:08 <ennael> ok then
21:15:25 <Akien> Time to wrap up the meeting? :)
21:15:35 <stormi> and eat it?
21:15:57 <Akien> meeting, not meat-ing :p
21:15:59 * stormi looks up the meaning of wrapping up
21:16:15 <wilcal> I have some turkey left overs
21:17:20 <ennael> nothing to add before
21:17:22 <ennael> 5
21:17:26 <ennael> 4
21:17:29 <ennael> 3
21:17:30 <filip> Pharaoh_Atem: buildsystem project sound interesting too
21:17:34 <ennael> 2
21:17:38 <ennael> 1
21:17:43 <wilcal> bye all
21:17:46 <ennael> #endmeeting